NVAPI Reference Documentation
NVIDIA
Release 361: January 27
2016
  • Main Page
  • Related Pages
  • Modules
  • Data Structures
  • Files
NVIDIA NVAPI

NVAPI is NVIDIA's core software development kit that allows direct access to NVIDIA GPUs and drivers on all Microsoft® Windows® platforms. NVAPI provides support for categories of operations that range beyond the scope of those found in familiar graphics APIs such as DirectX and OpenGL.

Some of the features that programmers can access using NVAPI include:

  • Driver Management: Initialization and driver version controls.
  • GPU Management: Enumeration of physical and logical GPUs. Thermal and Cooling controls.
  • Display Management: Enumeration of NVDIA displays, display postion and timings controls.
  • System Management: Ability to query chipset and system specific information.
  • Connecting and Configuring Monitors: Ability to set views on multiple target monitors.

Documentation Contents

  • About this Documentation
  • System Requirements
  • Important NVAPI Concepts
  • Deprecation Warnings
NVIDIA
Copyright (c) 2007-2016 NVIDIA Corporation. All rights reserved.


  • Main Page
  • Related Pages
  • Modules
  • Data Structures
  • Files
  • NVIDIA NVAPI
About this Documentation

This document is provided to OEMs, game developers, and NVIDIA technology partners.

Navigating the Documentation

This document describes the interface constants, structure definitions, and function prototypes for NvAPI. It is presented as an on-line help file. This format provides hypertext linking between related topics.

The Contents tab lets you access information as follows:

  • NVIDIA NVAPI - Main Page contains supplemental documentation pages.
  • Modules organizes the APIs by groups to help you easily locate a particular API.
  • Data Structures and Files provide a straightforward listing of functions, structures, and data types within the header file.
  • NVIDIA NVAPI contains related documentation pages.


  • Files
  • NVIDIA NVAPI
System Requirements

NvAPI Files

Make sure you have the following files:

  • nvapi.h
  • nvapi.lib (for 32-bit support)
  • nvapi64.lib (for 64-bit support)

Operating System and Platforms

The current version of NvAPI is supported on Windows XP, Windows Vista and later, both 32-bit and 64-bit architectures. Some API calls are OS specific–see the individual calls for OS support information.

NVIDIA ForceWare Driver Version

NvAPI is supported on ForceWare driver versions 81.20 and up. See the individual calls for specific driver version information.


  • NVIDIA NVAPI
Important NVAPI Concepts

This section explains the following NVAPI concepts and principles:

  • NvAPI Handles
  • Structure Versions Must be Initialized
  • Use a Static Link with Applications

NvAPI Handles

NvAPI handles are retrieved from various calls and passed to other calls in NvAPI. These are meant to be opaque types, and do not necessarily correspond to specific indices, HDCs, or display indices.

Most handles remain valid until a display re-configuration such as a display mode set, or a GPU reconfiguration such as going into or out of SLI modes. If NvAPI returns NVAPI_HANDLE_INVALIDATED, the application should discard all handles and re-enumerate them.

The following is a description of key NvAPI handles and identifiers:

  • Physical GPU handle: NvPhysicalGpuHandle is a reference to a physical GPU. Each GPU in a multi-GPU board will have its own handle. GPUs are assigned a handle even if they are not in use by the OS.
  • Logical GPU handle: NvLogicalGpuHandle is a reference to one or more physical GPUs acting as a single logical device. A single GPU will have a single logical GPU handle and a single physical GPU handle. Two GPUs acting in an SLI configuration will have a single logical GPU handle and two physical GPU handles.
  • NVIDIA display handle: NVIDIA display handles map one-to-one to the GDI handles for the attached displays in the Windows Display Properties Settings page. NvDisplayHandles reflect only the displays that the OS is aware of. Therefore, there is only one NvDisplayHandle for displays in Clone or Span mode, but there are two in Dualview mode. Some APIs use NvUnAttachedDisplayHandle for GDI dsplays that are not attached.
  • GPU output: GPU output IDs are identifiers for the GPU outputs that drive display devices. The GPU output might or might not be connected to a display, or be active. Each output is identified by a bit setting within a 32-bit unsigned integer. A GPU output mask consists of a 32-bit integer with several bits set, identifying more than one output from the same physical GPU.

The following figures illustrate these four identifiers used by NvAPI under various GPU configurations.

NvAPI Handles–Dualview, Clone and Spanning Modes

NvAPI Handles–SLI Mode

NvAPI Handles–Two GPUs Under Dualview

Structure Versions Must be Initialized

Each structure contains a version field which the caller must initialize so that the API library can track the version that is used by the calling application.

Each structure also has an associated NvAPI macro that you can use to initialize the version field. For example, the macro for structure NV_XXX is NV_XXX_VER. Initialize the version field as follows:

 NV_XXX.version = NV_XXX_VER;

Use a Static Link with Applications

NvAPI cannot be dynamically linked to applications. You must create a static link to the library and then call NvAPI_Initialize(), which loads nvapi.dll dynamically.

If the NVIDIA drivers are not installed on the system or nvapi.dll is not present when the application calls NvAPI_Initialize(), the call just returns an error. The application will still load.


  • NVIDIA NVAPI
Deprecation Warnings

All legacy APIs will be deprecated if a replacement is available. When an API is deprecated, it still remains in the code. However, any attempts to use it will result in a warning message recommending alternative APIs and stating that the API will be removed in the future - the API will not remain in the code indefinitely.

As the API is not removed immediately, this gives the client time to bring their code into compliance with the new APIs.

Example of Some Warnings

error C2220: warning treated as error - no 'object' file generated

warning C4996: 'NvAPI_GPU_GetConnectedOutputs': Do not use this function -
it is deprecated in release 290.
Instead, use NvAPI_GPU_GetConnectedDisplayIds.

How to Avoid Warnings

There are two courses of action that clients should take to avoid being presented with the warnings. These include a short term phase and a long term phase:

Phase-I (short term):

  • Option 1: Ignore the warning by using CFFLAG. Add “CFLAGS += -wd4996” and “CFLAGS += -wd4995”
  • Option 2: Don't use CFLAG, which treats the warning as an error. Remove “CFLAGS += -WX” from the make file.

Phase-II (long term): Clients need to avoid using the deprecated APIs and switch to the replacement APIs.


Related Pages
Here is a list of all related documentation pages:
  • Legal Notice


Legal Notice

Copyright (c) 2007- 2016 NVIDIA Corporation. All rights reserved.

Notice
This software may not, in whole or in part, be copied through any means, mechanical, electromechanical, or otherwise, without the express permission of NVIDIA Corporation.

Information furnished is believed to be accurate and reliable. However, NVIDIA assumes no responsibility for the consequences of use of such information nor for any infringement of patents or other rights of third parties, which may result from its use. No License is granted by implication or otherwise under any patent or patent rights of NVIDIA Corporation. Specifications mentioned in the software are subject to change without notice.

NVIDIA Corporation products are not authorized for use as critical components in life support devices or systems without express written approval of NVIDIA Corporation.

Trademarks
NVIDIA, the NVIDIA logo, and NVIDIA Quadro are registered trademarks or trademarks of NVIDIA Corporation in the United States and/or other countries.

Microsoft, Windows, and the Windows logo are registered trademarks of Microsoft Corporation.

Other company and product names may be trademarks or registered trademarks of the respective companies with which they are associated.


Modules
Here is a list of all modules:
  • General NVAPI
    • General NVAPI Functions
    • General NVAPI Defines, Structs, and Enums
    • NVAPI Handles
    • NvAPI Status Values
  • Graphics Driver APIs
  • Display APIs
    • Display Handle Interface
    • Display Control Interface
  • GPU APIs
    • GPU General Control Interface
    • GPU Thermal Control Interface
    • GPU Performance State Interface
    • GPU Clock Control Interface
    • GPU Cooler Interface
    • GPU ECC Interface
  • Video APIs
    • Video Input/Output Interface
  • DirectX APIs
    • DirectX Interface
    • DirectX Video Control
  • TV APIs
  • System APIs
    • System - General Interface
  • OpenGL APIs
  • I2C APIs
  • Mosaic APIs
  • Quadro G-Sync APIs
  • Stereoscopic 3D APIs
  • Driver Settings (DRS) APIs


Modules
General NVAPI

Modules

General NVAPI Functions
General NVAPI Defines, Structs, and Enums
NVAPI Handles
NvAPI Status Values

Detailed Description

This section describes APIs that:

  • Initialize the NVAPI library,
  • Return the NVAPI version,
  • Return the human readable error message, It also describes the list of handles and return status indicators.


Functions
General NVAPI Functions
General NVAPI

Functions

NVAPI_INTERFACE NvAPI_Initialize ()
NVAPI_INTERFACE NvAPI_Unload ()
NVAPI_INTERFACE | NvAPI_GetErrorMessage (NvAPI_Status nr, NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GetInterfaceVersionString (NvAPI_ShortString szDesc)

Function Documentation

NVAPI_INTERFACE NvAPI_GetErrorMessage | ( | NvAPI_Status | nr,
 |  | NvAPI_ShortString | szDesc
 | ) |  |

This function converts an NvAPI error code into a null terminated string.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Parameters:
nr | The error code to convert
szDesc | The string corresponding to the error code
Returns:
NULL terminated string (always, never NULL)
NVAPI_INTERFACE NvAPI_GetInterfaceVersionString ( NvAPI_ShortString szDesc )

This function returns a string describing the version of the NvAPI library. The contents of the string are human readable. Do not assume a fixed format.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Parameters:
szDesc User readable string giving NvAPI version information
Returns:
See NvAPI Status Values for the list of possible return values.
NVAPI_INTERFACE NvAPI_Initialize ( )

This function initializes the NvAPI library (if not already initialized) but always increments the ref-counter. This must be called before calling other NvAPI_ functions.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_ERROR | An error occurred during the initialization process (generic error)
NVAPI_LIBRARYNOTFOUND | Failed to load the NVAPI support library
NVAPI_OK | Initialized
See also:
NvAPI Status Values
NVAPI_INTERFACE NvAPI_Unload ( )

DESCRIPTION: Decrements the ref-counter and when it reaches ZERO, unloads NVAPI library. This must be called in pairs with NvAPI_Initialize.

SUPPORTED OS: Windows XP and higher

Note: By design, it is not mandatory to call NvAPI_Initialize before calling any NvAPI. When any NvAPI is called without first calling NvAPI_Initialize, the internal refcounter will be implicitly incremented. In such cases, calling NvAPI_Initialize from a different thread will result in incrementing the refcount again and the user has to call NvAPI_Unload twice to unload the library. However, note that the implicit increment of the refcounter happens only once. If the client wants unload functionality, it is recommended to always call NvAPI_Initialize and NvAPI_Unload in pairs.

Unloading NvAPI library is not supported when the library is in a resource locked state. Some functions in the NvAPI library initiates an operation or allocates certain resources and there are corresponding functions available, to complete the operation or free the allocated resources. All such function pairs are designed to prevent unloading NvAPI library.

For example, if NvAPI_Unload is called after NvAPI_XXX which locks a resource, it fails with NVAPI_ERROR. Developers need to call the corresponding NvAPI_YYY to unlock the resources, before calling NvAPI_Unload again.

Return values:
NVAPI_ERROR | One or more resources are locked and hence cannot unload NVAPI library
NVAPI_OK | NVAPI library unloaded


Data Structures | Defines | Typedefs
General NVAPI Defines, Structs, and Enums
General NVAPI

Data Structures

struct | NvSBox

Defines

#define | NVAPI_GENERIC_STRING_MAX 4096
#define | NVAPI_LONG_STRING_MAX 256
#define | NVAPI_SHORT_STRING_MAX 64
#define | NVAPI_MAX_PHYSICAL_GPUS 64
#define | NVAPI_MAX_PHYSICAL_BRIDGES 100
#define | NVAPI_PHYSICAL_GPUS 32
#define | NVAPI_MAX_LOGICAL_GPUS 64
#define | NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES 256
#define | NVAPI_MAX_AVAILABLE_SLI_GROUPS 256
#define | NVAPI_MAX_GPU_TOPOLOGIES NVAPI_MAX_PHYSICAL_GPUS
#define | NVAPI_MAX_GPU_PER_TOPOLOGY 8
#define | NVAPI_MAX_DISPLAY_HEADS 2
#define | NVAPI_ADVANCED_DISPLAY_HEADS 4
#define | NVAPI_MAX_DISPLAYS NVAPI_PHYSICAL_GPUS * NVAPI_ADVANCED_DISPLAY_HEADS
#define | NVAPI_MAX_ACPI_IDS 16
#define | NVAPI_MAX_VIEW_MODES 8
#define | NV_MAX_HEADS 4
#define | NV_MAX_HEADS 4
#define | NVAPI_MAX_HEADS_PER_GPU 32
#define | NV_MAX_VID_STREAMS 4
#define | NV_MAX_VID_PROFILES 4
#define | NVAPI_SYSTEM_MAX_DISPLAYS NVAPI_MAX_PHYSICAL_GPUS * NV_MAX_HEADS
#define | NVAPI_SYSTEM_MAX_HWBCS 128
#define | NVAPI_SYSTEM_HWBC_INVALID_ID 0xffffffff
#define | NVAPI_MAX_AUDIO_DEVICES 16
#define | MAKE_NVAPI_VERSION(typeName, ver) (NvU32)(sizeof(typeName) | ((ver)<<16))
#define | GET_NVAPI_VERSION(ver) (NvU32)((ver)>>16)
#define | GET_NVAPI_SIZE(ver) (NvU32)((ver) & 0xffff)

Typedefs

typedef char | NvAPI_String [NVAPI_GENERIC_STRING_MAX]
typedef char | NvAPI_LongString [NVAPI_LONG_STRING_MAX]
typedef char | NvAPI_ShortString [NVAPI_SHORT_STRING_MAX]

Define Documentation

#define GET_NVAPI_SIZE ( ver ) (NvU32)((ver) & 0xffff)
#define GET_NVAPI_VERSION ( ver ) (NvU32)((ver)>>16)
#define MAKE_NVAPI_VERSION | ( | typeName,
 |  | ver
 | ) | (NvU32)(sizeof(typeName) | ((ver)<<16))

NvAPI Version Definition
Maintain per structure specific version define using the MAKE_NVAPI_VERSION macro.
Usage: #define NV_GENLOCK_STATUS_VER MAKE_NVAPI_VERSION(NV_GENLOCK_STATUS, 1)

#define NV_MAX_HEADS 4

Maximum heads, each with NVAPI_DESKTOP_RES resolution.

Maximum number of heads, each with #NVAPI_DESKTOP_RES resolution.

#define NV_MAX_HEADS 4

Maximum heads, each with NVAPI_DESKTOP_RES resolution.

Maximum number of heads, each with #NVAPI_DESKTOP_RES resolution.

#define NV_MAX_VID_PROFILES 4

Maximum number of output video profiles supported.

#define NV_MAX_VID_STREAMS 4

Maximum number of input video streams, each with a #NVAPI_VIDEO_SRC_INFO.

#define NVAPI_ADVANCED_DISPLAY_HEADS 4
#define NVAPI_GENERIC_STRING_MAX 4096
#define NVAPI_LONG_STRING_MAX 256
#define NVAPI_MAX_ACPI_IDS 16
#define NVAPI_MAX_AUDIO_DEVICES 16
#define NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES 256
#define NVAPI_MAX_AVAILABLE_SLI_GROUPS 256
#define NVAPI_MAX_DISPLAY_HEADS 2
#define NVAPI_MAX_DISPLAYS NVAPI_PHYSICAL_GPUS * NVAPI_ADVANCED_DISPLAY_HEADS
#define NVAPI_MAX_GPU_PER_TOPOLOGY 8
#define NVAPI_MAX_GPU_TOPOLOGIES NVAPI_MAX_PHYSICAL_GPUS
#define NVAPI_MAX_HEADS_PER_GPU 32
#define NVAPI_MAX_LOGICAL_GPUS 64
#define NVAPI_MAX_PHYSICAL_BRIDGES 100
#define NVAPI_MAX_PHYSICAL_GPUS 64
#define NVAPI_MAX_VIEW_MODES 8
#define NVAPI_PHYSICAL_GPUS 32
#define NVAPI_SHORT_STRING_MAX 64
#define NVAPI_SYSTEM_HWBC_INVALID_ID 0xffffffff
#define NVAPI_SYSTEM_MAX_DISPLAYS NVAPI_MAX_PHYSICAL_GPUS * NV_MAX_HEADS
#define NVAPI_SYSTEM_MAX_HWBCS 128

Typedef Documentation

typedef char NvAPI_LongString[NVAPI_LONG_STRING_MAX]
typedef char NvAPI_ShortString[NVAPI_SHORT_STRING_MAX]
typedef char NvAPI_String[NVAPI_GENERIC_STRING_MAX]


Typedefs | Functions
NVAPI Handles
General NVAPI

Typedefs

typedef void * | StereoHandle

Functions

NV_DECLARE_HANDLE (NvDisplayHandle)
NV_DECLARE_HANDLE (NvMonitorHandle)
NV_DECLARE_HANDLE (NvUnAttachedDisplayHandle)
NV_DECLARE_HANDLE (NvLogicalGpuHandle)
NV_DECLARE_HANDLE (NvPhysicalGpuHandle)
NV_DECLARE_HANDLE (NvEventHandle)
NV_DECLARE_HANDLE (NvVisualComputingDeviceHandle)
NV_DECLARE_HANDLE (NvHICHandle)
NV_DECLARE_HANDLE (NvGSyncDeviceHandle)
NV_DECLARE_HANDLE (NvVioHandle)
NV_DECLARE_HANDLE (NvTransitionHandle)
NV_DECLARE_HANDLE (NvAudioHandle)
NV_DECLARE_HANDLE (Nv3DVPContextHandle)
NV_DECLARE_HANDLE (Nv3DVPTransceiverHandle)
NV_DECLARE_HANDLE (Nv3DVPGlassesHandle)
NV_DECLARE_HANDLE (NvSourceHandle)
NV_DECLARE_HANDLE (NvTargetHandle)
NV_DECLARE_HANDLE (NVDX_SwapChainHandle)
#define | NVAPI_DEFAULT_HANDLE 0
#define | NV_BIT(x) (1 << (x))

Detailed Description

NVAPI Handles - These handles are retrieved from various calls and passed in to others in NvAPI These are meant to be opaque types. Do not assume they correspond to indices, HDCs, display indexes or anything else.

Most handles remain valid until a display re-configuration (display mode set) or GPU reconfiguration (going into or out of SLI modes) occurs. If NVAPI_HANDLE_INVALIDATED is received by an app, it should discard all handles, and re-enumerate them.

Define Documentation

#define NV_BIT ( x ) (1 << (x))
#define NVAPI_DEFAULT_HANDLE 0

Typedef Documentation

typedef void* StereoHandle

A stereo handle, that corresponds to the device interface.

Function Documentation

NV_DECLARE_HANDLE ( NvDisplayHandle )

Display Device driven by NVIDIA GPU(s) (an attached display)

NV_DECLARE_HANDLE ( NvMonitorHandle )

Monitor handle.

NV_DECLARE_HANDLE ( NvUnAttachedDisplayHandle )

Unattached Display Device driven by NVIDIA GPU(s)

NV_DECLARE_HANDLE ( NvLogicalGpuHandle )

One or more physical GPUs acting in concert (SLI)

NV_DECLARE_HANDLE ( NvPhysicalGpuHandle )

A single physical GPU.

NV_DECLARE_HANDLE ( NvEventHandle )

A handle to an event registration instance.

NV_DECLARE_HANDLE ( NvVisualComputingDeviceHandle )

A handle to a Visual Computing Device.

NV_DECLARE_HANDLE ( NvHICHandle )

A handle to a Host Interface Card.

NV_DECLARE_HANDLE ( NvGSyncDeviceHandle )

A handle to a Sync device.

NV_DECLARE_HANDLE ( NvVioHandle )

A handle to an SDI device.

NV_DECLARE_HANDLE ( NvTransitionHandle )

A handle to address a single transition request.

NV_DECLARE_HANDLE ( NvAudioHandle )

NVIDIA HD Audio Device.

NV_DECLARE_HANDLE ( Nv3DVPContextHandle )

A handle for a 3D Vision Pro (3DVP) context.

NV_DECLARE_HANDLE ( Nv3DVPTransceiverHandle )

A handle for a 3DVP RF transceiver.

NV_DECLARE_HANDLE ( Nv3DVPGlassesHandle )

A handle for a pair of 3DVP RF shutter glasses.

NV_DECLARE_HANDLE ( NvSourceHandle )

Unique source handle on the system.

NV_DECLARE_HANDLE ( NvTargetHandle )

Unique target handle on the system.

NV_DECLARE_HANDLE ( NVDX_SwapChainHandle )

DirectX SwapChain objects.


Defines | Typedefs | Enumerations
NvAPI Status Values
General NVAPI

Defines

#define | NVAPI_API_NOT_INTIALIZED NVAPI_API_NOT_INITIALIZED
#define | NVAPI_INVALID_USER_PRIVILEDGE NVAPI_INVALID_USER_PRIVILEGE

Typedefs

typedef enum _NvAPI_Status | NvAPI_Status

Enumerations

enum _NvAPI_Status {
NVAPI_OK = 0, NVAPI_ERROR = -1, NVAPI_LIBRARY_NOT_FOUND = -2, NVAPI_NO_IMPLEMENTATION = -3,
NVAPI_API_NOT_INITIALIZED = -4, NVAPI_INVALID_ARGUMENT = -5, NVAPI_NVIDIA_DEVICE_NOT_FOUND = -6, NVAPI_END_ENUMERATION = -7,
NVAPI_INVALID_HANDLE = -8, NVAPI_INCOMPATIBLE_STRUCT_VERSION = -9, NVAPI_HANDLE_INVALIDATED = -10, NVAPI_OPENGL_CONTEXT_NOT_CURRENT = -11,
NVAPI_INVALID_POINTER = -14, NVAPI_NO_GL_EXPERT = -12, NVAPI_INSTRUMENTATION_DISABLED = -13, NVAPI_NO_GL_NSIGHT = -15,
NVAPI_EXPECTED_LOGICAL_GPU_HANDLE = -100, NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE = -101, NVAPI_EXPECTED_DISPLAY_HANDLE = -102, NVAPI_INVALID_COMBINATION = -103,
NVAPI_NOT_SUPPORTED = -104, NVAPI_PORTID_NOT_FOUND = -105, NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE = -106, NVAPI_INVALID_PERF_LEVEL = -107,
NVAPI_DEVICE_BUSY = -108, NVAPI_NV_PERSIST_FILE_NOT_FOUND = -109, NVAPI_PERSIST_DATA_NOT_FOUND = -110, NVAPI_EXPECTED_TV_DISPLAY = -111,
NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR = -112, NVAPI_NO_ACTIVE_SLI_TOPOLOGY = -113, NVAPI_SLI_RENDERING_MODE_NOTALLOWED = -114, NVAPI_EXPECTED_DIGITAL_FLAT_PANEL = -115,
NVAPI_ARGUMENT_EXCEED_MAX_SIZE = -116, NVAPI_DEVICE_SWITCHING_NOT_ALLOWED = -117, NVAPI_TESTING_CLOCKS_NOT_SUPPORTED = -118, NVAPI_UNKNOWN_UNDERSCAN_CONFIG = -119,
NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO = -120, NVAPI_DATA_NOT_FOUND = -121, NVAPI_EXPECTED_ANALOG_DISPLAY = -122, NVAPI_NO_VIDLINK = -123,
NVAPI_REQUIRES_REBOOT = -124, NVAPI_INVALID_HYBRID_MODE = -125, NVAPI_MIXED_TARGET_TYPES = -126, NVAPI_SYSWOW64_NOT_SUPPORTED = -127,
NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED = -128, NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS = -129, NVAPI_OUT_OF_MEMORY = -130, NVAPI_WAS_STILL_DRAWING = -131,
NVAPI_FILE_NOT_FOUND = -132, NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS = -133, NVAPI_INVALID_CALL = -134, NVAPI_D3D10_1_LIBRARY_NOT_FOUND = -135,
NVAPI_FUNCTION_NOT_FOUND = -136, NVAPI_INVALID_USER_PRIVILEGE = -137, NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE = -138, NVAPI_EXPECTED_COMPUTE_GPU_HANDLE = -139,
NVAPI_STEREO_NOT_INITIALIZED = -140, NVAPI_STEREO_REGISTRY_ACCESS_FAILED = -141, NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED = -142, NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED = -143,
NVAPI_STEREO_NOT_ENABLED = -144, NVAPI_STEREO_NOT_TURNED_ON = -145, NVAPI_STEREO_INVALID_DEVICE_INTERFACE = -146, NVAPI_STEREO_PARAMETER_OUT_OF_RANGE = -147,
NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED = -148, NVAPI_TOPO_NOT_POSSIBLE = -149, NVAPI_MODE_CHANGE_FAILED = -150, NVAPI_D3D11_LIBRARY_NOT_FOUND = -151,
NVAPI_INVALID_ADDRESS = -152, NVAPI_STRING_TOO_SMALL = -153, NVAPI_MATCHING_DEVICE_NOT_FOUND = -154, NVAPI_DRIVER_RUNNING = -155,
NVAPI_DRIVER_NOTRUNNING = -156, NVAPI_ERROR_DRIVER_RELOAD_REQUIRED = -157, NVAPI_SET_NOT_ALLOWED = -158, NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED = -159,
NVAPI_SETTING_NOT_FOUND = -160, NVAPI_SETTING_SIZE_TOO_LARGE = -161, NVAPI_TOO_MANY_SETTINGS_IN_PROFILE = -162, NVAPI_PROFILE_NOT_FOUND = -163,
NVAPI_PROFILE_NAME_IN_USE = -164, NVAPI_PROFILE_NAME_EMPTY = -165, NVAPI_EXECUTABLE_NOT_FOUND = -166, NVAPI_EXECUTABLE_ALREADY_IN_USE = -167,
NVAPI_DATATYPE_MISMATCH = -168, NVAPI_PROFILE_REMOVED = -169, NVAPI_UNREGISTERED_RESOURCE = -170, NVAPI_ID_OUT_OF_RANGE = -171,
NVAPI_DISPLAYCONFIG_VALIDATION_FAILED = -172, NVAPI_DPMST_CHANGED = -173, NVAPI_INSUFFICIENT_BUFFER = -174, NVAPI_ACCESS_DENIED = -175,
NVAPI_MOSAIC_NOT_ACTIVE = -176, NVAPI_SHARE_RESOURCE_RELOCATED = -177, NVAPI_REQUEST_USER_TO_DISABLE_DWM = -178, NVAPI_D3D_DEVICE_LOST = -179,
NVAPI_INVALID_CONFIGURATION = -180, NVAPI_STEREO_HANDSHAKE_NOT_DONE = -181, NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS = -182, NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED = -183,
NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST = -184, NVAPI_CLUSTER_ALREADY_EXISTS = -185, NVAPI_DPMST_DISPLAY_ID_EXPECTED = -186, NVAPI_INVALID_DISPLAY_ID = -187,
NVAPI_STREAM_IS_OUT_OF_SYNC = -188, NVAPI_INCOMPATIBLE_AUDIO_DRIVER = -189, NVAPI_VALUE_ALREADY_SET = -190, NVAPI_TIMEOUT = -191,
NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE = -192, NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE = -193, NVAPI_SYNC_NOT_ACTIVE = -194, NVAPI_SYNC_MASTER_NOT_FOUND = -195,
NVAPI_INVALID_SYNC_TOPOLOGY = -196, NVAPI_ECID_SIGN_ALGO_UNSUPPORTED = -197, NVAPI_ECID_KEY_VERIFICATION_FAILED = -198, NVAPI_FIRMWARE_OUT_OF_DATE = -199,
NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED = -200, NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED = -201, NVAPI_D3D_DEVICE_NOT_REGISTERED = -202, NVAPI_RESOURCE_NOT_ACQUIRED = -203,
NVAPI_TIMING_NOT_SUPPORTED = -204, NVAPI_HDCP_ENCRYPTION_FAILED = -205, NVAPI_PCLK_LIMITATION_FAILED = -206, NVAPI_NO_CONNECTOR_FOUND = -207
}

Detailed Description

All functions return an NvAPI_Status value. For example,

  • Any function receiving an invalid argument will return NVAPI_INVALID_ARGUMENT.
  • If communication with an NVIDIA display driver cannot be established, functions return NVAPI_NVIDIA_DEVICE_NOT_FOUND.
  • If one or more handles passed have been invalidated due to a modeset or SLI reconfiguration event, then functions return NVAPI_HANDLE_INVALIDATED.

Define Documentation

#define NVAPI_API_NOT_INTIALIZED NVAPI_API_NOT_INITIALIZED

Fix typo in error code

#define NVAPI_INVALID_USER_PRIVILEDGE NVAPI_INVALID_USER_PRIVILEGE

Fix typo in error code

Typedef Documentation

typedef enum _NvAPI_Status NvAPI_Status

NvAPI Status Values All NvAPI functions return one of these codes.

Enumeration Type Documentation

enum _NvAPI_Status

NvAPI Status Values All NvAPI functions return one of these codes.

Enumerator:
NVAPI_OK

Success. Request is completed.

NVAPI_ERROR

Generic error.

NVAPI_LIBRARY_NOT_FOUND

NVAPI support library cannot be loaded.

NVAPI_NO_IMPLEMENTATION

not implemented in current driver installation

NVAPI_API_NOT_INITIALIZED

NvAPI_Initialize has not been called (successfully)

NVAPI_INVALID_ARGUMENT

The argument/parameter value is not valid or NULL.

NVAPI_NVIDIA_DEVICE_NOT_FOUND

No NVIDIA display driver, or NVIDIA GPU driving a display, was found.

NVAPI_END_ENUMERATION

No more items to enumerate.

NVAPI_INVALID_HANDLE

Invalid handle.

NVAPI_INCOMPATIBLE_STRUCT_VERSION

An argument's structure version is not supported.

NVAPI_HANDLE_INVALIDATED

The handle is no longer valid (likely due to GPU or display re-configuration)

NVAPI_OPENGL_CONTEXT_NOT_CURRENT

No NVIDIA OpenGL context is current (but needs to be)

NVAPI_INVALID_POINTER

An invalid pointer, usually NULL, was passed as a parameter.

NVAPI_NO_GL_EXPERT

OpenGL Expert is not supported by the current drivers.

NVAPI_INSTRUMENTATION_DISABLED

OpenGL Expert is supported, but driver instrumentation is currently disabled.

NVAPI_NO_GL_NSIGHT

OpenGL does not support Nsight.

NVAPI_EXPECTED_LOGICAL_GPU_HANDLE

Expected a logical GPU handle for one or more parameters.

NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE

Expected a physical GPU handle for one or more parameters.

NVAPI_EXPECTED_DISPLAY_HANDLE

Expected an NV display handle for one or more parameters.

NVAPI_INVALID_COMBINATION

The combination of parameters is not valid.

NVAPI_NOT_SUPPORTED

Requested feature is not supported in the selected GPU.

NVAPI_PORTID_NOT_FOUND

No port ID was found for the I2C transaction.

NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE

Expected an unattached display handle as one of the input parameters.

NVAPI_INVALID_PERF_LEVEL

Invalid perf level.

NVAPI_DEVICE_BUSY

Device is busy; request not fulfilled.

NVAPI_NV_PERSIST_FILE_NOT_FOUND

NV persist file is not found.

NVAPI_PERSIST_DATA_NOT_FOUND

NV persist data is not found.

NVAPI_EXPECTED_TV_DISPLAY

Expected a TV output display.

NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR

Expected a TV output on the D Connector - HDTV_EIAJ4120.

NVAPI_NO_ACTIVE_SLI_TOPOLOGY

SLI is not active on this device.

NVAPI_SLI_RENDERING_MODE_NOTALLOWED

Setup of SLI rendering mode is not possible right now.

NVAPI_EXPECTED_DIGITAL_FLAT_PANEL

Expected a digital flat panel.

NVAPI_ARGUMENT_EXCEED_MAX_SIZE

Argument exceeds the expected size.

NVAPI_DEVICE_SWITCHING_NOT_ALLOWED

Inhibit is ON due to one of the flags in NV_GPU_DISPLAY_CHANGE_INHIBIT or SLI active.

NVAPI_TESTING_CLOCKS_NOT_SUPPORTED

Testing of clocks is not supported.

NVAPI_UNKNOWN_UNDERSCAN_CONFIG

The specified underscan config is from an unknown source (e.g. INF)

NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO

Timeout while reconfiguring GPUs.

NVAPI_DATA_NOT_FOUND

Requested data was not found.

NVAPI_EXPECTED_ANALOG_DISPLAY

Expected an analog display.

NVAPI_NO_VIDLINK

No SLI video bridge is present.

NVAPI_REQUIRES_REBOOT

NVAPI requires a reboot for the settings to take effect.

NVAPI_INVALID_HYBRID_MODE

The function is not supported with the current Hybrid mode.

NVAPI_MIXED_TARGET_TYPES

The target types are not all the same.

NVAPI_SYSWOW64_NOT_SUPPORTED

The function is not supported from 32-bit on a 64-bit system.

NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED

There is no implicit GPU topology active. Use NVAPI_SetHybridMode to change topology.

NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS

Prompt the user to close all non-migratable applications.

NVAPI_OUT_OF_MEMORY

Could not allocate sufficient memory to complete the call.

NVAPI_WAS_STILL_DRAWING

The previous operation that is transferring information to or from this surface is incomplete.

NVAPI_FILE_NOT_FOUND

The file was not found.

NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS

There are too many unique instances of a particular type of state object.

NVAPI_INVALID_CALL

The method call is invalid. For example, a method's parameter may not be a valid pointer.

NVAPI_D3D10_1_LIBRARY_NOT_FOUND

d3d10_1.dll cannot be loaded.

NVAPI_FUNCTION_NOT_FOUND

Couldn't find the function in the loaded DLL.

NVAPI_INVALID_USER_PRIVILEGE

Current User is not Admin.

NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE

The handle corresponds to GDIPrimary.

NVAPI_EXPECTED_COMPUTE_GPU_HANDLE

Setting Physx GPU requires that the GPU is compute-capable.

NVAPI_STEREO_NOT_INITIALIZED

The Stereo part of NVAPI failed to initialize completely. Check if the stereo driver is installed.

NVAPI_STEREO_REGISTRY_ACCESS_FAILED

Access to stereo-related registry keys or values has failed.

NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED

The given registry profile type is not supported.

NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED

The given registry value is not supported.

NVAPI_STEREO_NOT_ENABLED

Stereo is not enabled and the function needed it to execute completely.

NVAPI_STEREO_NOT_TURNED_ON

Stereo is not turned on and the function needed it to execute completely.

NVAPI_STEREO_INVALID_DEVICE_INTERFACE

Invalid device interface.

NVAPI_STEREO_PARAMETER_OUT_OF_RANGE

Separation percentage or JPEG image capture quality is out of [0-100] range.

NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED

The given frustum adjust mode is not supported.

NVAPI_TOPO_NOT_POSSIBLE

The mosaic topology is not possible given the current state of the hardware.

NVAPI_MODE_CHANGE_FAILED

An attempt to do a display resolution mode change has failed.

NVAPI_D3D11_LIBRARY_NOT_FOUND

d3d11.dll/d3d11_beta.dll cannot be loaded.

NVAPI_INVALID_ADDRESS

Address is outside of valid range.

NVAPI_STRING_TOO_SMALL

The pre-allocated string is too small to hold the result.

NVAPI_MATCHING_DEVICE_NOT_FOUND

The input does not match any of the available devices.

NVAPI_DRIVER_RUNNING

Driver is running.

NVAPI_DRIVER_NOTRUNNING

Driver is not running.

NVAPI_ERROR_DRIVER_RELOAD_REQUIRED

A driver reload is required to apply these settings.

NVAPI_SET_NOT_ALLOWED

Intended setting is not allowed.

NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED

Information can't be returned due to "advanced display topology".

NVAPI_SETTING_NOT_FOUND

Setting is not found.

NVAPI_SETTING_SIZE_TOO_LARGE

Setting size is too large.

NVAPI_TOO_MANY_SETTINGS_IN_PROFILE

There are too many settings for a profile.

NVAPI_PROFILE_NOT_FOUND

Profile is not found.

NVAPI_PROFILE_NAME_IN_USE

Profile name is duplicated.

NVAPI_PROFILE_NAME_EMPTY

Profile name is empty.

NVAPI_EXECUTABLE_NOT_FOUND

Application not found in the Profile.

NVAPI_EXECUTABLE_ALREADY_IN_USE

Application already exists in the other profile.

NVAPI_DATATYPE_MISMATCH

Data Type mismatch.

NVAPI_PROFILE_REMOVED

The profile passed as parameter has been removed and is no longer valid.

NVAPI_UNREGISTERED_RESOURCE

An unregistered resource was passed as a parameter.

NVAPI_ID_OUT_OF_RANGE

The DisplayId corresponds to a display which is not within the normal outputId range.

NVAPI_DISPLAYCONFIG_VALIDATION_FAILED

Display topology is not valid so the driver cannot do a mode set on this configuration.

NVAPI_DPMST_CHANGED

Display Port Multi-Stream topology has been changed.

NVAPI_INSUFFICIENT_BUFFER

Input buffer is insufficient to hold the contents.

NVAPI_ACCESS_DENIED

No access to the caller.

NVAPI_MOSAIC_NOT_ACTIVE

The requested action cannot be performed without Mosaic being enabled.

NVAPI_SHARE_RESOURCE_RELOCATED

The surface is relocated away from video memory.

NVAPI_REQUEST_USER_TO_DISABLE_DWM

The user should disable DWM before calling NvAPI.

NVAPI_D3D_DEVICE_LOST

D3D device status is D3DERR_DEVICELOST or D3DERR_DEVICENOTRESET - the user has to reset the device.

NVAPI_INVALID_CONFIGURATION

The requested action cannot be performed in the current state.

NVAPI_STEREO_HANDSHAKE_NOT_DONE

Call failed as stereo handshake not completed.

NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS

The path provided was too short to determine the correct NVDRS_APPLICATION.

NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED

Default stereo profile is not currently defined.

NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST

Default stereo profile does not exist.

NVAPI_CLUSTER_ALREADY_EXISTS

A cluster is already defined with the given configuration.

NVAPI_DPMST_DISPLAY_ID_EXPECTED

The input display id is not that of a multi stream enabled connector or a display device in a multi stream topology.

NVAPI_INVALID_DISPLAY_ID

The input display id is not valid or the monitor associated to it does not support the current operation.

NVAPI_STREAM_IS_OUT_OF_SYNC

While playing secure audio stream, stream goes out of sync.

NVAPI_INCOMPATIBLE_AUDIO_DRIVER

Older audio driver version than required.

NVAPI_VALUE_ALREADY_SET

Value already set, setting again not allowed.

NVAPI_TIMEOUT

Requested operation timed out.

NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE

The requested workstation feature set has incomplete driver internal allocation resources.

NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE

Call failed because InitActivation was not called.

NVAPI_SYNC_NOT_ACTIVE

The requested action cannot be performed without Sync being enabled.

NVAPI_SYNC_MASTER_NOT_FOUND

The requested action cannot be performed without Sync Master being enabled.

NVAPI_INVALID_SYNC_TOPOLOGY

Invalid displays passed in the NV_GSYNC_DISPLAY pointer.

NVAPI_ECID_SIGN_ALGO_UNSUPPORTED

The specified signing algorithm is not supported. Either an incorrect value was entered or the current installed driver/hardware does not support the input value.

NVAPI_ECID_KEY_VERIFICATION_FAILED

The encrypted public key verification has failed.

NVAPI_FIRMWARE_OUT_OF_DATE

The device's firmware is out of date.

NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED

The device's firmware is not supported.

NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED

The caller is not authorized to modify the License.

NVAPI_D3D_DEVICE_NOT_REGISTERED

The user tried to use a deferred context without registering the device first.

NVAPI_RESOURCE_NOT_ACQUIRED

Head or SourceId was not reserved for the VR Display before doing the Modeset.

NVAPI_TIMING_NOT_SUPPORTED

Provided timing is not supported.

NVAPI_HDCP_ENCRYPTION_FAILED

HDCP Encryption Failed for the device. Would be applicable when the device is HDCP Capable.

NVAPI_PCLK_LIMITATION_FAILED

Provided mode is over sink device pclk limitation.

NVAPI_NO_CONNECTOR_FOUND

No connector on GPU found.


Data Structures | Defines | Typedefs | Functions
Graphics Driver APIs

Data Structures

struct | NV_DISPLAY_DRIVER_VERSION
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V1
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V2
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V3

Defines

#define | NV_DISPLAY_DRIVER_VERSION_VER MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_VERSION,1)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V1,1)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V2,2)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V3,3)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3

Typedefs

typedef
NV_DISPLAY_DRIVER_MEMORY_INFO_V3 		NV_DISPLAY_DRIVER_MEMORY_INFO

Functions

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_SYS_GetDriverAndBranchVersion.") NVAPI_INTERFACE NvAPI_GetDisplayDriverVersion(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_SYS_GetDriverAndBranchVersion (NvU32 *pDriverVersion, NvAPI_ShortString szBuildBranchString)
NVAPI_INTERFACE | NvAPI_GPU_GetMemoryInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_DISPLAY_DRIVER_MEMORY_INFO *pMemoryInfo)

Detailed Description

The display driver APIs are used to retrieve information about the display driver.

Define Documentation

#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3
#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V1,1)

Macro for constructing the version field of NV_DISPLAY_DRIVER_MEMORY_INFO_V1

#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V2,2)

Macro for constructing the version field of NV_DISPLAY_DRIVER_MEMORY_INFO_V2

#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V3,3)

Macro for constructing the version field of NV_DISPLAY_DRIVER_MEMORY_INFO_V3

#define NV_DISPLAY_DRIVER_VERSION_VER MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_VERSION,1)

Typedef Documentation

typedef NV_DISPLAY_DRIVER_MEMORY_INFO_V3 NV_DISPLAY_DRIVER_MEMORY_INFO

Function Documentation

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_SYS_GetDriverAndBranchVersion." |
 | ) |  |
NVAPI_INTERFACE NvAPI_GPU_GetMemoryInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_DISPLAY_DRIVER_MEMORY_INFO * | pMemoryInfo
 | ) |  |

DESCRIPTION: This function retrieves the available driver memory footprint for the specified GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 177
Parameters:
[in] | hPhysicalGpu | Handle of the physical GPU for which the memory information is to be extracted.
[out] | pMemoryInfo | The memory footprint available in the driver. See NV_DISPLAY_DRIVER_MEMORY_INFO.
Return values:
NVAPI_INVALID_ARGUMENT | pMemoryInfo is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_DISPLAY_DRIVER_MEMORY_INFO structure version mismatch.
NVAPI_INTERFACE NvAPI_SYS_GetDriverAndBranchVersion | ( | NvU32 * | pDriverVersion,
 |  | NvAPI_ShortString | szBuildBranchString
 | ) |  |

DESCRIPTION: This API returns display driver version and driver-branch string.

SUPPORTED OS: Windows XP and higher

Parameters:
[out] | pDriverVersion | Contains the driver version after successful return.
[out] | szBuildBranchString | Contains the driver-branch string after successful return.
Return values:
NVAPI_INVALID_ARGUMENT,: either pDriverVersion is NULL or enum index too big
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized
NVAPI_ERROR | - miscellaneous error occurred


Modules
Display APIs

Modules

Display Handle Interface
Display Control Interface

Detailed Description

The Display APIs include

  • Display handle functions: Retrieve the handle for the specified display.
  • Display control functions: Retrieve and control various display settings such as display name, refresh rate, hardware cursor, etc.


Functions
Display Handle Interface
Display APIs

Functions

NVAPI_INTERFACE | NvAPI_EnumNvidiaDisplayHandle (NvU32 thisEnum, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_EnumNvidiaUnAttachedDisplayHandle (NvU32 thisEnum, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayHandle (const char *szDisplayName, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle (const char *szDisplayName, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)

Function Documentation

NVAPI_INTERFACE NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle | ( | const char * | szDisplayName,
 |  | NvUnAttachedDisplayHandle * | pNvUnAttachedDispHandle
 | ) |  |

DESCRIPTION: This function returns the handle of an unattached NVIDIA display that is associated with the given display name (such as "\\DISPLAY1").

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Return values:
NVAPI_INVALID_ARGUMENT | Either argument is NULL.
NVAPI_OK | *pNvUnAttachedDispHandle is now valid.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name.
NVAPI_INTERFACE NvAPI_EnumNvidiaDisplayHandle | ( | NvU32 | thisEnum,
 |  | NvDisplayHandle * | pNvDispHandle
 | ) |  |

This function returns the handle of the NVIDIA display specified by the enum index (thisEnum). The client should keep enumerating until it returns NVAPI_END_ENUMERATION.

Note: Display handles can get invalidated on a modeset, so the calling applications need to renum the handles after every modeset.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Parameters:
[in] | thisEnum | The index of the NVIDIA display.
[out] | pNvDispHandle | Pointer to the NVIDIA display handle.
Return values:
NVAPI_INVALID_ARGUMENT | Either the handle pointer is NULL or enum index too big
NVAPI_OK | Return a valid NvDisplayHandle based on the enum index
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device found in the system
NVAPI_END_ENUMERATION | No more display device to enumerate
NVAPI_INTERFACE NvAPI_EnumNvidiaUnAttachedDisplayHandle | ( | NvU32 | thisEnum,
 |  | NvUnAttachedDisplayHandle * | pNvUnAttachedDispHandle
 | ) |  |

This function returns the handle of the NVIDIA unattached display specified by the enum index (thisEnum). The client should keep enumerating until it returns error. Note: Display handles can get invalidated on a modeset, so the calling applications need to renum the handles after every modeset.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Parameters:
[in] | thisEnum | The index of the NVIDIA display.
[out] | pNvUnAttachedDispHandle | Pointer to the NVIDIA display handle of the unattached display.
Return values:
NVAPI_INVALID_ARGUMENT | Either the handle pointer is NULL or enum index too big
NVAPI_OK | Return a valid NvDisplayHandle based on the enum index
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device found in the system
NVAPI_END_ENUMERATION | No more display device to enumerate.
NVAPI_INTERFACE NvAPI_GetAssociatedNvidiaDisplayHandle | ( | const char * | szDisplayName,
 |  | NvDisplayHandle * | pNvDispHandle
 | ) |  |

This function returns the handle of the NVIDIA display that is associated with the given display "name" (such as "\\.\DISPLAY1").

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | Either argument is NULL
NVAPI_OK | *pNvDispHandle is now valid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name


Data Structures | Defines | Typedefs | Enumerations | Functions
Display Control Interface
Display APIs

Data Structures

struct | tagNV_TIMINGEXT
struct | _NV_TIMING
struct | NV_VIEW_TARGET_INFO
struct | NV_DISPLAY_PATH
struct | NV_DISPLAY_PATH_INFO_V3
struct | NV_DISPLAY_PATH_INFO
struct | _NV_POSITION
struct | _NV_RESOLUTION
struct | _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
struct | _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V2
struct | _NV_DISPLAY_PORT_INFO_V1
struct | NV_DISPLAY_PORT_CONFIG
struct | _NV_HDMI_SUPPORT_INFO_V1
struct | _NV_HDMI_SUPPORT_INFO_V2
struct | NV_TIMING_FLAG
struct | _NV_TIMING_INPUT
struct | _NV_MONITOR_COLOR_DATA
struct | NV_CUSTOM_DISPLAY

Defines

#define | NVFORMAT_MAKEFOURCC(ch0, ch1, ch2, ch3)
#define | NV_TIMING_H_SYNC_POSITIVE 0
#define | NV_TIMING_H_SYNC_NEGATIVE 1
#define | NV_TIMING_H_SYNC_DEFAULT NV_TIMING_H_SYNC_NEGATIVE
#define | NV_TIMING_V_SYNC_POSITIVE 0
#define | NV_TIMING_V_SYNC_NEGATIVE 1
#define | NV_TIMING_V_SYNC_DEFAULT NV_TIMING_V_SYNC_POSITIVE
#define | NV_TIMING_PROGRESSIVE 0
#define | NV_TIMING_INTERLACED 1
#define | NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 1
#define | NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 2
#define | NV_VIEW_TARGET_INFO_VER MAKE_NVAPI_VERSION(NV_VIEW_TARGET_INFO,2)
#define | NVAPI_MAX_DISPLAY_PATH NVAPI_MAX_VIEW_TARGET
#define | NVAPI_ADVANCED_MAX_DISPLAY_PATH NVAPI_ADVANCED_MAX_VIEW_TARGET
#define | NV_DISPLAY_PATH_INFO_VER NV_DISPLAY_PATH_INFO_VER4
#define | NV_DISPLAY_PATH_INFO_VER4 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,4)
#define | NV_DISPLAY_PATH_INFO_VER3 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,3)
#define | NV_DISPLAY_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,2)
#define | NV_DISPLAY_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1
#define | _NV_DISPLAYCONFIG_PATH_INFO_V2 _NV_DISPLAYCONFIG_PATH_INFO
#define | NV_DISPLAYCONFIG_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V2,2)
#define | NV_DISPLAY_PORT_CONFIG_VER MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_DISPLAY_PORT_CONFIG_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,1)
#define | NV_DISPLAY_PORT_CONFIG_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_MONITOR_COLOR_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_COLOR_CAPS_V1,1)
#define | NV_CUSTOM_DISPLAY_VER MAKE_NVAPI_VERSION(NV_CUSTOM_DISPLAY,1)

Typedefs

typedef enum _NV_DP_LINK_RATE | NV_DP_LINK_RATE
typedef enum _NV_DP_LANE_COUNT | NV_DP_LANE_COUNT
typedef enum _NV_DP_COLOR_FORMAT | NV_DP_COLOR_FORMAT
typedef enum _NV_DP_COLORIMETRY | NV_DP_COLORIMETRY
typedef enum _NV_DP_DYNAMIC_RANGE | NV_DP_DYNAMIC_RANGE
typedef enum _NV_DP_BPC | NV_DP_BPC
typedef enum _NV_SCALING | NV_SCALING
typedef enum _NV_ROTATE | NV_ROTATE
typedef enum _NV_FORMAT | NV_FORMAT
typedef enum _NV_TIMING_OVERRIDE | NV_TIMING_OVERRIDE
typedef struct tagNV_TIMINGEXT | NV_TIMINGEXT
typedef struct _NV_TIMING | NV_TIMING
typedef struct _NV_POSITION | NV_POSITION
typedef struct _NV_RESOLUTION | NV_RESOLUTION
typedef struct
_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 		NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
typedef
NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 		NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO
typedef struct
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 		NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
typedef struct
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 		NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
typedef
NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 		NV_DISPLAYCONFIG_PATH_TARGET_INFO
typedef enum
_NV_DISPLAYCONFIG_SPANNING_ORIENTATION 		NV_DISPLAYCONFIG_SPANNING_ORIENTATION
typedef struct
_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 		NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
typedef struct
_NV_DISPLAYCONFIG_PATH_INFO_V1 		NV_DISPLAYCONFIG_PATH_INFO_V1
typedef struct
_NV_DISPLAYCONFIG_PATH_INFO_V2 		NV_DISPLAYCONFIG_PATH_INFO_V2
typedef enum
_NV_DISPLAYCONFIG_FLAGS 		NV_DISPLAYCONFIG_FLAGS
typedef struct
_NV_DISPLAY_PORT_INFO_V1 		NV_DISPLAY_PORT_INFO_V1
typedef struct
_NV_HDMI_SUPPORT_INFO_V1 		NV_HDMI_SUPPORT_INFO_V1
typedef struct
_NV_HDMI_SUPPORT_INFO_V2 		NV_HDMI_SUPPORT_INFO_V2
typedef struct _NV_TIMING_INPUT | NV_TIMING_INPUT
typedef struct
_NV_MONITOR_COLOR_DATA 		NV_MONITOR_COLOR_CAPS_V1

Enumerations

enum | _NV_DP_LINK_RATE { NV_DP_1_62GBPS = 6, NV_DP_2_70GBPS = 0xA, NV_DP_5_40GBPS = 0x14, NV_DP_8_10GBPS = 0x1E }
enum | _NV_DP_LANE_COUNT { NV_DP_1_LANE = 1, NV_DP_2_LANE = 2, NV_DP_4_LANE = 4 }
enum | _NV_DP_COLOR_FORMAT { NV_DP_COLOR_FORMAT_RGB = 0, NV_DP_COLOR_FORMAT_YCbCr422, NV_DP_COLOR_FORMAT_YCbCr444 }
enum | _NV_DP_COLORIMETRY { NV_DP_COLORIMETRY_RGB = 0, NV_DP_COLORIMETRY_YCbCr_ITU601, NV_DP_COLORIMETRY_YCbCr_ITU709 }
enum | _NV_DP_DYNAMIC_RANGE { NV_DP_DYNAMIC_RANGE_VESA = 0, NV_DP_DYNAMIC_RANGE_CEA }
enum _NV_DP_BPC {
NV_DP_BPC_DEFAULT = 0, NV_DP_BPC_6, NV_DP_BPC_8, NV_DP_BPC_10,
NV_DP_BPC_12, NV_DP_BPC_16
}
enum _NV_SCALING {
NV_SCALING_DEFAULT = 0, NV_SCALING_GPU_SCALING_TO_CLOSEST = 1, NV_SCALING_GPU_SCALING_TO_NATIVE = 2, NV_SCALING_GPU_SCANOUT_TO_NATIVE = 3,
NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE = 5, NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST = 6, NV_SCALING_GPU_SCANOUT_TO_CLOSEST = 7, NV_SCALING_MONITOR_SCALING = NV_SCALING_GPU_SCALING_TO_CLOSEST,
NV_SCALING_ADAPTER_SCALING = NV_SCALING_GPU_SCALING_TO_NATIVE, NV_SCALING_CENTERED = NV_SCALING_GPU_SCANOUT_TO_NATIVE, NV_SCALING_ASPECT_SCALING = NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE, NV_SCALING_CUSTOMIZED = 255
}
enum _NV_ROTATE {
NV_ROTATE_0 = 0, NV_ROTATE_90 = 1, NV_ROTATE_180 = 2, NV_ROTATE_270 = 3,
NV_ROTATE_IGNORED = 4
}
enum _NV_FORMAT {
NV_FORMAT_UNKNOWN = 0, NV_FORMAT_P8 = 41, NV_FORMAT_R5G6B5 = 23, NV_FORMAT_A8R8G8B8 = 21,
NV_FORMAT_A16B16G16R16F = 113
}
enum _NV_TIMING_OVERRIDE {
NV_TIMING_OVERRIDE_CURRENT = 0, NV_TIMING_OVERRIDE_AUTO, NV_TIMING_OVERRIDE_EDID, NV_TIMING_OVERRIDE_DMT,
NV_TIMING_OVERRIDE_DMT_RB, NV_TIMING_OVERRIDE_CVT, NV_TIMING_OVERRIDE_CVT_RB, NV_TIMING_OVERRIDE_GTF,
NV_TIMING_OVERRIDE_EIA861, NV_TIMING_OVERRIDE_ANALOG_TV, NV_TIMING_OVERRIDE_CUST, NV_TIMING_OVERRIDE_NV_PREDEFINED,
NV_TIMING_OVERRIDE_NV_PSF = NV_TIMING_OVERRIDE_NV_PREDEFINED, NV_TIMING_OVERRIDE_NV_ASPR, NV_TIMING_OVERRIDE_SDI, NV_TIMING_OVRRIDE_MAX
}
enum | _NV_DISPLAYCONFIG_SPANNING_ORIENTATION { NV_DISPLAYCONFIG_SPAN_NONE = 0, NV_DISPLAYCONFIG_SPAN_HORIZONTAL = 1, NV_DISPLAYCONFIG_SPAN_VERTICAL = 2 }
enum | _NV_DISPLAYCONFIG_FLAGS { NV_DISPLAYCONFIG_VALIDATE_ONLY = 0x00000001, NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE = 0x00000002, NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED = 0x00000004, NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION = 0x00000008 }

Functions

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_SetDisplayConfig.") NVAPI_INTERFACE NvAPI_SetViewEx(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_CreateDisplayFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvDisplayHandle *pNvDisplay)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayName (NvDisplayHandle NvDispHandle, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_GetUnAttachedAssociatedDisplayName (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_EnableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_DisableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_GetVBlankCounter (NvDisplayHandle hNvDisplay, NvU32 *pCounter)
NVAPI_INTERFACE | NvAPI_SetRefreshRateOverride (NvDisplayHandle hNvDisplay, NvU32 outputsMask, float refreshRate, NvU32 bSetDeferred)
NVAPI_INTERFACE | NvAPI_GetAssociatedDisplayOutputId (NvDisplayHandle hNvDisplay, NvU32 *pOutputId)
NVAPI_INTERFACE | NvAPI_GetDisplayPortInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_DISPLAY_PORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_SetDisplayPort (NvDisplayHandle hNvDisplay, NvU32 outputId, NV_DISPLAY_PORT_CONFIG *pCfg)
NVAPI_INTERFACE | NvAPI_GetHDMISupportInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_HDMI_SUPPORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_Disp_InfoFrameControl (__in NvU32 displayId, __inout NV_INFOFRAME_DATA *pInfoframeData)
NVAPI_INTERFACE | NvAPI_DISP_GetTiming (__in NvU32 displayId, __in NV_TIMING_INPUT *timingInput, __out NV_TIMING *pTiming)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorCapabilities (__in NvU32 displayId, __inout NV_MONITOR_CAPABILITIES *pMonitorCapabilities)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorColorCapabilities (__in NvU32 displayId, __inout_ecount_part_opt(*pColorCapsCount,*pColorCapsCount) NV_MONITOR_COLOR_CAPS *pMonitorColorCapabilities, __inout NvU32 *pColorCapsCount)
NVAPI_INTERFACE | NvAPI_DISP_EnumCustomDisplay (__in NvU32 displayId, __in NvU32 index, __inout NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_TryCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in_ecount(count) NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_DeleteCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_SaveCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NvU32 isThisOutputIdOnly, __in NvU32 isThisMonitorIdOnly)
NVAPI_INTERFACE | NvAPI_DISP_RevertCustomDisplayTrial (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_GetDisplayConfig.") NVAPI_INTERFACE NvAPI_GetView(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_GetSupportedViews (NvDisplayHandle hNvDisplay, NV_TARGET_VIEW_MODE *pTargetViews, NvU32 *pViewCount)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayIdByDisplayName (const char *displayName, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayConfig (__inout NvU32 *pathInfoCount, __out_ecount_full_opt(*pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo)
NVAPI_INTERFACE | NvAPI_DISP_SetDisplayConfig (__in NvU32 pathInfoCount, __in_ecount(pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_DISP_GetGDIPrimaryDisplayId (NvU32 *displayId)
enum _NV_TARGET_VIEW_MODE {
NV_VIEW_MODE_STANDARD = 0, NV_VIEW_MODE_CLONE = 1, NV_VIEW_MODE_HSPAN = 2, NV_VIEW_MODE_VSPAN = 3,
NV_VIEW_MODE_DUALVIEW = 4, NV_VIEW_MODE_MULTIVIEW = 5
}
typedef enum _NV_TARGET_VIEW_MODE | NV_TARGET_VIEW_MODE
#define | NVAPI_MAX_VIEW_TARGET 2
#define | NVAPI_ADVANCED_MAX_VIEW_TARGET 4
#define | _NV_TARGET_VIEW_MODE_
enum NV_INFOFRAME_CMD {
NV_INFOFRAME_CMD_GET_DEFAULT = 0, NV_INFOFRAME_CMD_RESET, NV_INFOFRAME_CMD_GET, NV_INFOFRAME_CMD_SET,
NV_INFOFRAME_CMD_GET_OVERRIDE, NV_INFOFRAME_CMD_SET_OVERRIDE, NV_INFOFRAME_CMD_GET_PROPERTY, NV_INFOFRAME_CMD_SET_PROPERTY
}
NVAPI_INTERFACE | NvAPI_Disp_ColorControl (NvU32 displayId, NV_COLOR_DATA *pColorData)
enum | NV_MONITOR_CAPS_TYPE { NV_MONITOR_CAPS_TYPE_HDMI_VSDB = 0x1000, NV_MONITOR_CAPS_TYPE_HDMI_VCDB = 0x1001 }

Detailed Description

Timing-related constants

Macro for constructing the version fields of NV_DISPLAY_PATH_INFO

Macro for constructing the version field of NV_DISPLAY_PORT_CONFIG

Define Documentation

#define _NV_DISPLAYCONFIG_PATH_INFO_V2 _NV_DISPLAYCONFIG_PATH_INFO

This define is temporary and must be removed once DVS failure is fixed.

#define _NV_TARGET_VIEW_MODE_

Used in NvAPI_SetView().

#define NV_CUSTOM_DISPLAY_VER MAKE_NVAPI_VERSION(NV_CUSTOM_DISPLAY,1)

Used in NV_CUSTOM_DISPLAY.

#define NV_DISPLAY_PATH_INFO_VER NV_DISPLAY_PATH_INFO_VER4
#define NV_DISPLAY_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,1)
#define NV_DISPLAY_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,2)
#define NV_DISPLAY_PATH_INFO_VER3 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,3)
#define NV_DISPLAY_PATH_INFO_VER4 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,4)
#define NV_DISPLAY_PORT_CONFIG_VER MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define NV_DISPLAY_PORT_CONFIG_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,1)

Macro for constructing the version field of NV_DISPLAY_PORT_CONFIG.

#define NV_DISPLAY_PORT_CONFIG_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)

Macro for constructing the version field of NV_DISPLAY_PORT_CONFIG.

#define NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1
#define NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1,1)
#define NV_DISPLAYCONFIG_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V1,1)
#define NV_DISPLAYCONFIG_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V2,2)
#define NV_MONITOR_COLOR_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_COLOR_CAPS_V1,1)
#define NV_TIMING_H_SYNC_DEFAULT NV_TIMING_H_SYNC_NEGATIVE
#define NV_TIMING_H_SYNC_NEGATIVE 1
#define NV_TIMING_H_SYNC_POSITIVE 0
#define NV_TIMING_INTERLACED 1
#define NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 1
#define NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 2
#define NV_TIMING_PROGRESSIVE 0
#define NV_TIMING_V_SYNC_DEFAULT NV_TIMING_V_SYNC_POSITIVE
#define NV_TIMING_V_SYNC_NEGATIVE 1
#define NV_TIMING_V_SYNC_POSITIVE 0
#define NV_VIEW_TARGET_INFO_VER MAKE_NVAPI_VERSION(NV_VIEW_TARGET_INFO,2)
#define NVAPI_ADVANCED_MAX_DISPLAY_PATH NVAPI_ADVANCED_MAX_VIEW_TARGET
#define NVAPI_ADVANCED_MAX_VIEW_TARGET 4

Used in NvAPI_SetView().

#define NVAPI_MAX_DISPLAY_PATH NVAPI_MAX_VIEW_TARGET
#define NVAPI_MAX_VIEW_TARGET 2

Used in NvAPI_SetView().

#define NVFORMAT_MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((NvU32)(NvU8)(ch0) | ((NvU32)(NvU8)(ch1) << 8) |   \
                     ((NvU32)(NvU8)(ch2) << 16) | ((NvU32)(NvU8)(ch3) << 24 ))

Color formats- used in NvAPI_SetViewEx().

Typedef Documentation

typedef struct _NV_DISPLAY_PORT_INFO_V1 NV_DISPLAY_PORT_INFO_V1

Used in NvAPI_GetDisplayPortInfo().

typedef enum _NV_DISPLAYCONFIG_FLAGS NV_DISPLAYCONFIG_FLAGS
typedef NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO
typedef struct _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V1 NV_DISPLAYCONFIG_PATH_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V2 NV_DISPLAYCONFIG_PATH_INFO_V2
typedef NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 NV_DISPLAYCONFIG_PATH_TARGET_INFO

As version is not defined for this structure, we will be using version of NV_DISPLAYCONFIG_PATH_INFO

typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
typedef struct _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
typedef enum _NV_DISPLAYCONFIG_SPANNING_ORIENTATION NV_DISPLAYCONFIG_SPANNING_ORIENTATION
typedef enum _NV_DP_BPC NV_DP_BPC

Used in NV_DISPLAY_PORT_INFO.

typedef enum _NV_DP_COLOR_FORMAT NV_DP_COLOR_FORMAT

Used in NV_DISPLAY_PORT_INFO.

typedef enum _NV_DP_COLORIMETRY NV_DP_COLORIMETRY

Used in NV_DISPLAY_PORT_INFO.

typedef enum _NV_DP_DYNAMIC_RANGE NV_DP_DYNAMIC_RANGE

Used in NV_DISPLAY_PORT_INFO.

typedef enum _NV_DP_LANE_COUNT NV_DP_LANE_COUNT

Used in NV_DISPLAY_PORT_INFO.

typedef enum _NV_DP_LINK_RATE NV_DP_LINK_RATE

Used in NV_DISPLAY_PORT_INFO.

typedef enum _NV_FORMAT NV_FORMAT

Color formats- used in NvAPI_SetViewEx().

typedef struct _NV_HDMI_SUPPORT_INFO_V1 NV_HDMI_SUPPORT_INFO_V1

Used in NvAPI_GetHDMISupportInfo().

typedef struct _NV_HDMI_SUPPORT_INFO_V2 NV_HDMI_SUPPORT_INFO_V2

Used in NvAPI_GetHDMISupportInfo().

typedef struct _NV_MONITOR_COLOR_DATA NV_MONITOR_COLOR_CAPS_V1
typedef struct _NV_POSITION NV_POSITION
typedef struct _NV_RESOLUTION NV_RESOLUTION
typedef enum _NV_ROTATE NV_ROTATE

Rotate modes- used in NvAPI_SetViewEx().

typedef enum _NV_SCALING NV_SCALING

Scaling modes - used in NvAPI_SetViewEx().

typedef enum _NV_TARGET_VIEW_MODE NV_TARGET_VIEW_MODE

Used in NvAPI_SetView().

typedef struct _NV_TIMING NV_TIMING

The very basic timing structure based on the VESA standard:

            |<----------------------------htotal--------------------------->|
             ---------"active" video-------->|<-------blanking------>|<-----
            |<-------hvisible-------->|<-hb->|<-hfp->|<-hsw->|<-hbp->|<-hb->|
 --------- -+-------------------------+      |       |       |       |      |
   A      A |                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
   :vertical|    addressable video    |      |       |       |       |      |
   : visible|                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
 vertical V |                         |      |       |       |       |      |
  total   --+-------------------------+      |       |       |       |      |
   :      vb         border                  |       |       |       |      |
   :      -----------------------------------+       |       |       |      |
   :      vfp        front porch                     |       |       |      |
   :      -------------------------------------------+       |       |      |
   :      vsw        sync width                              |       |      |
   :      ---------------------------------------------------+       |      |
   :      vbp        back porch                                      |      |
   :      -----------------------------------------------------------+      |
   V      vb         border                                                 |
 ---------------------------------------------------------------------------+
typedef struct _NV_TIMING_INPUT NV_TIMING_INPUT

Used in NvAPI_DISP_GetTiming().

typedef enum _NV_TIMING_OVERRIDE NV_TIMING_OVERRIDE

The timing override is not supported yet; must be set to _AUTO.

typedef struct tagNV_TIMINGEXT NV_TIMINGEXT

NVIDIA-specific timing extras
Used in NV_TIMING.

Enumeration Type Documentation

enum _NV_DISPLAYCONFIG_FLAGS
Enumerator:
NV_DISPLAYCONFIG_VALIDATE_ONLY
NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE
NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED

Driver reload is permitted if necessary.

NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION

Refresh OS mode list.

enum _NV_DISPLAYCONFIG_SPANNING_ORIENTATION
Enumerator:
NV_DISPLAYCONFIG_SPAN_NONE
NV_DISPLAYCONFIG_SPAN_HORIZONTAL
NV_DISPLAYCONFIG_SPAN_VERTICAL
enum _NV_DP_BPC

Used in NV_DISPLAY_PORT_INFO.

Enumerator:
NV_DP_BPC_DEFAULT
NV_DP_BPC_6
NV_DP_BPC_8
NV_DP_BPC_10
NV_DP_BPC_12
NV_DP_BPC_16
enum _NV_DP_COLOR_FORMAT

Used in NV_DISPLAY_PORT_INFO.

Enumerator:
NV_DP_COLOR_FORMAT_RGB
NV_DP_COLOR_FORMAT_YCbCr422
NV_DP_COLOR_FORMAT_YCbCr444
enum _NV_DP_COLORIMETRY

Used in NV_DISPLAY_PORT_INFO.

Enumerator:
NV_DP_COLORIMETRY_RGB
NV_DP_COLORIMETRY_YCbCr_ITU601
NV_DP_COLORIMETRY_YCbCr_ITU709
enum _NV_DP_DYNAMIC_RANGE

Used in NV_DISPLAY_PORT_INFO.

Enumerator:
NV_DP_DYNAMIC_RANGE_VESA
NV_DP_DYNAMIC_RANGE_CEA
enum _NV_DP_LANE_COUNT

Used in NV_DISPLAY_PORT_INFO.

Enumerator:
NV_DP_1_LANE
NV_DP_2_LANE
NV_DP_4_LANE
enum _NV_DP_LINK_RATE

Used in NV_DISPLAY_PORT_INFO.

Enumerator:
NV_DP_1_62GBPS
NV_DP_2_70GBPS
NV_DP_5_40GBPS
NV_DP_8_10GBPS
enum _NV_FORMAT

Color formats- used in NvAPI_SetViewEx().

Enumerator:
NV_FORMAT_UNKNOWN

unknown. Driver will choose one as following value.

NV_FORMAT_P8

for 8bpp mode

NV_FORMAT_R5G6B5

for 16bpp mode

NV_FORMAT_A8R8G8B8

for 32bpp mode

NV_FORMAT_A16B16G16R16F

for 64bpp(floating point) mode.

enum _NV_ROTATE

Rotate modes- used in NvAPI_SetViewEx().

Enumerator:
NV_ROTATE_0
NV_ROTATE_90
NV_ROTATE_180
NV_ROTATE_270
NV_ROTATE_IGNORED
enum _NV_SCALING

Scaling modes - used in NvAPI_SetViewEx().

Enumerator:
NV_SCALING_DEFAULT

No change.

NV_SCALING_GPU_SCALING_TO_CLOSEST

Balanced - Full Screen.

NV_SCALING_GPU_SCALING_TO_NATIVE

Force GPU - Full Screen.

NV_SCALING_GPU_SCANOUT_TO_NATIVE

Force GPU - Centered Scaling.

NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE

Force GPU - Aspect Ratio.

NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST

Balanced - Aspect Ratio.

NV_SCALING_GPU_SCANOUT_TO_CLOSEST

Balanced - Centered Scaling.

NV_SCALING_MONITOR_SCALING
NV_SCALING_ADAPTER_SCALING
NV_SCALING_CENTERED
NV_SCALING_ASPECT_SCALING
NV_SCALING_CUSTOMIZED

For future use.

enum _NV_TARGET_VIEW_MODE

Used in NvAPI_SetView().

Enumerator:
NV_VIEW_MODE_STANDARD
NV_VIEW_MODE_CLONE
NV_VIEW_MODE_HSPAN
NV_VIEW_MODE_VSPAN
NV_VIEW_MODE_DUALVIEW
NV_VIEW_MODE_MULTIVIEW
enum _NV_TIMING_OVERRIDE

The timing override is not supported yet; must be set to _AUTO.

Enumerator:
NV_TIMING_OVERRIDE_CURRENT

get the current timing

NV_TIMING_OVERRIDE_AUTO

the timing the driver will use based the current policy

NV_TIMING_OVERRIDE_EDID

EDID timing.

NV_TIMING_OVERRIDE_DMT

VESA DMT timing.

NV_TIMING_OVERRIDE_DMT_RB

VESA DMT timing with reduced blanking.

NV_TIMING_OVERRIDE_CVT

VESA CVT timing.

NV_TIMING_OVERRIDE_CVT_RB

VESA CVT timing with reduced blanking.

NV_TIMING_OVERRIDE_GTF

VESA GTF timing.

NV_TIMING_OVERRIDE_EIA861

EIA 861x pre-defined timing.

NV_TIMING_OVERRIDE_ANALOG_TV

analog SD/HDTV timing

NV_TIMING_OVERRIDE_CUST

NV custom timings.

NV_TIMING_OVERRIDE_NV_PREDEFINED

NV pre-defined timing (basically the PsF timings)

NV_TIMING_OVERRIDE_NV_PSF
NV_TIMING_OVERRIDE_NV_ASPR
NV_TIMING_OVERRIDE_SDI

Override for SDI timing.

NV_TIMING_OVRRIDE_MAX
enum NV_INFOFRAME_CMD

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_CMD_GET_DEFAULT

Returns the fields in the infoframe with values set by the manufacturer - NVIDIA/OEM.

NV_INFOFRAME_CMD_RESET

Sets the fields in the infoframe to auto, and infoframe to the default infoframe for use in a set.

NV_INFOFRAME_CMD_GET

Get the current infoframe state.

NV_INFOFRAME_CMD_SET

Set the current infoframe state (flushed to the monitor), the values are one time and do not persist.

NV_INFOFRAME_CMD_GET_OVERRIDE

Get the override infoframe state, non-override fields will be set to value = AUTO, overridden fields will have the current override values.

NV_INFOFRAME_CMD_SET_OVERRIDE

Set the override infoframe state, non-override fields will be set to value = AUTO, other values indicate override; persist across modeset/reboot.

NV_INFOFRAME_CMD_GET_PROPERTY

get properties associated with infoframe (each of the infoframe type will have properties)

NV_INFOFRAME_CMD_SET_PROPERTY

set properties associated with infoframe

enum NV_MONITOR_CAPS_TYPE

HDMI-related and extended CAPs.

Enumerator:
NV_MONITOR_CAPS_TYPE_HDMI_VSDB
NV_MONITOR_CAPS_TYPE_HDMI_VCDB

Function Documentation

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_DISP_SetDisplayConfig." |
 | ) |  |
__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_DISP_GetDisplayConfig." |
 | ) |  |

This API lets caller retrieve the target display arrangement for selected source display handle.

Note:
Display PATH with this API is limited to single GPU. DUALVIEW across GPUs will be returned as STANDARD VIEW. Use NvAPI_SYS_GetDisplayTopologies() to query views across GPUs.
Since:
Release: 85
Parameters:
[in] | hNvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[out] | pTargets | User allocated storage to retrieve an array of NV_VIEW_TARGET_INFO. Can be NULL to retrieve the targetCount.
[in,out] | targetMaskCount | Count of target device mask specified in pTargetMask.
[out] | targetView | Target view selected from NV_TARGET_VIEW_MODE.
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.

DESCRIPTION: This API lets caller retrieve the target display arrangement for selected source display handle.

Note:
Display PATH with this API is limited to single GPU. DUALVIEW across GPUs will be returned as STANDARD VIEW. Use NvAPI_SYS_GetDisplayTopologies() to query views across GPUs.
Since:
Release: 165
Parameters:
[in] | hNvDisplay | NVIDIA Display selection. NVAPI_DEFAULT_HANDLE is not allowed, it has to be a handle enumerated with NvAPI_EnumNVidiaDisplayHandle().
[in,out] | pPathInfo | Count field should be set to NVAPI_MAX_DISPLAY_PATH. Can be NULL to retrieve just the pathCount.
[in,out] | pPathCount | Number of elements in array pPathInfo->path.
[out] | pTargetViewMode | Display view selected from NV_TARGET_VIEW_MODE.
Return values:
NVAPI_OK | Completed request
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.
NVAPI_EXPECTED_DISPLAY_HANDLE | hNvDisplay is not a valid display handle.
NVAPI_INTERFACE NvAPI_CreateDisplayFromUnAttachedDisplay | ( | NvUnAttachedDisplayHandle | hNvUnAttachedDisp,
 |  | NvDisplayHandle * | pNvDisplay
 | ) |  |

This function converts the unattached display handle to an active attached display handle.

At least one GPU must be present in the system and running an NVIDIA display driver.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | hNvUnAttachedDisp is not valid or pNvDisplay is NULL.
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_INTERFACE NvAPI_DisableHWCursor ( NvDisplayHandle hNvDisplay )

This function disables hardware cursor support

SUPPORTED OS: Windows XP

Since:
Release: 80
Returns:
NVAPI_ERROR or NVAPI_OK
NvAPI_Disp_ColorControl | ( | NvU32 | displayId,
 |  | NV_COLOR_DATA * | pColorData
 | ) |  |

DESCRIPTION: This API controls the Color values.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | displayId | Monitor Identifier
[in,out] | pColorData | Contains data corresponding to color information
Returns:
RETURN STATUS: NVAPI_OK, NVAPI_ERROR, NVAPI_INVALID_ARGUMENT
NVAPI_INTERFACE NvAPI_DISP_DeleteCustomDisplay | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count,
 |  | __in NV_CUSTOM_DISPLAY * | pCustDisp
 | ) |  |

DESCRIPTION: This function deletes the custom display configuration, specified from the registry for all the displays whose display IDs are passed.

SUPPORTED OS: Windows XP and higher

Since:
Release: 313
Parameters:
[in] | pDisplayIds | Array of Dispaly IDs on which custom display configuration is to be saved.
[in] | count | Total number of the incoming Dispaly IDs. This is for the multi-head support.
[in] | pCustDisp | Pointer to the NV_CUSTOM_DISPLAY structure
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_DISPLAY_ID,: Custom Timing is not supported on the Display, whose display id is passed
NVAPI_INTERFACE NvAPI_DISP_EnumCustomDisplay | ( | __in NvU32 | displayId,
 |  | __in NvU32 | index,
 |  | __inout NV_CUSTOM_DISPLAY * | pCustDisp
 | ) |  |

DESCRIPTION: This API enumerates the custom timing specified by the enum index. The client should keep enumerating until it returns NVAPI_END_ENUMERATION.

SUPPORTED OS: Windows XP and higher

Since:
Release: 313
Parameters:
[in] | displayId | Dispaly ID of the display.
[in] | index | Enum index
[in,out] | pCustDisp | Pointer to the NV_CUSTOM_DISPLAY structure
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_DISPLAY_ID,: Custom Timing is not supported on the Display, whose display id is passed
NVAPI_INTERFACE NvAPI_DISP_GetDisplayConfig | ( | __inout NvU32 * | pathInfoCount,
 |  | __out_ecount_full_opt *pathInfoCount NV_DISPLAYCONFIG_PATH_INFO * | pathInfo
 | ) |  |

DESCRIPTION: This API lets caller retrieve the current global display configuration. USAGE: The caller might have to call this three times to fetch all the required configuration details as follows: First Pass: Caller should Call NvAPI_DISP_GetDisplayConfig() with pathInfo set to NULL to fetch pathInfoCount. Second Pass: Allocate memory for pathInfo with respect to the number of pathInfoCount(from First Pass) to fetch targetInfoCount. If sourceModeInfo is needed allocate memory or it can be initialized to NULL. Third Pass(Optional, only required if target information is required): Allocate memory for targetInfo with respect to number of targetInfoCount(from Second Pass). SUPPORTED OS: Windows Vista and higher

Parameters:
[in,out] | pathInfoCount | Number of elements in pathInfo array, returns number of valid topologies, this cannot be null.
[in,out] | pathInfo | Array of path information
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT - Invalid input parameter. Following can be the reason for this return value:
  1. pathInfoCount is NULL.
  2. *pathInfoCount is 0 and pathInfo is not NULL.
  3. *pathInfoCount is not 0 and pathInfo is NULL.
NVAPI_DEVICE_BUSY - ModeSet has not yet completed. Please wait and call it again.
NVAPI_INTERFACE NvAPI_DISP_GetDisplayIdByDisplayName | ( | const char * | displayName,
 |  | NvU32 * | displayId
 | ) |  |

SUPPORTED OS: Windows XP and higher DESCRIPTION: This API retrieves the Display Id of a given display by display name. The display must be active to retrieve the displayId. In the case of clone mode or Surround gaming, the primary or top-left display will be returned.

Parameters:
[in] | displayName | Name of display (Eg: "\\DISPLAY1" to retrieve the displayId for.
[out] | displayId | Display ID of the requested display.

retval NVAPI_OK: Capabilties have been returned. retval NVAPI_INVALID_ARGUMENT: One or more args passed in are invalid. retval NVAPI_API_NOT_INTIALIZED: The NvAPI API needs to be initialized first retval NVAPI_NO_IMPLEMENTATION: This entrypoint not available retval NVAPI_ERROR: Miscellaneous error occurred

NVAPI_INTERFACE NvAPI_DISP_GetGDIPrimaryDisplayId ( NvU32 * displayId )

SUPPORTED OS: Windows XP and higher DESCRIPTION: This API returns the Display ID of the GDI Primary.

Parameters:
[out] displayId Display ID of the GDI Primary display.
Return values:
NVAPI_OK,: Capabilties have been returned.
NVAPI_NVIDIA_DEVICE_NOT_FOUND,: GDI Primary not on an NVIDIA GPU.
NVAPI_INVALID_ARGUMENT,: One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED,: The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION,: This entrypoint not available
NVAPI_ERROR,: Miscellaneous error occurred
NVAPI_INTERFACE NvAPI_DISP_GetMonitorCapabilities | ( | __in NvU32 | displayId,
 |  | __inout NV_MONITOR_CAPABILITIES * | pMonitorCapabilities
 | ) |  |

SUPPORTED OS: Windows Vista and higher

NVAPI_INTERFACE NvAPI_DISP_GetMonitorColorCapabilities | ( | __in NvU32 | displayId,
 |  | __inout_ecount_part_opt *,*pColorCapsCount NV_MONITOR_COLOR_CAPS * | pMonitorColorCapabilities,
 |  | __inout NvU32 * | pColorCapsCount
 | ) |  |

DESCRIPTION: This API returns all the color formats and bit depth values supported by a given DP monitor.

USAGE: Sequence of calls which caller should make to get the information. 1. First call NvAPI_DISP_GetMonitorColorCapabilities() with pMonitorColorCapabilities as NULL to get the count. 2. Allocate memory for color caps(NV_MONITOR_COLOR_CAPS) array. 3. Call NvAPI_DISP_GetMonitorColorCapabilities() again with the pointer to the memory allocated to get all the color capabilities.

Note : 1. pColorCapsCount should never be NULL, else the API will fail with NVAPI_INVALID_ARGUMENT. 2. *pColorCapsCount returned from the API will always be the actual count in any/every call. 3. Memory size to be allocated should be (*pColorCapsCount * sizeof(NV_MONITOR_COLOR_CAPS)). 4. If the memory allocated is less than what is required to return all the timings, this API will return the amount of information which can fit in user provided buffer and API will return NVAPI_INSUFFICIENT_BUFFER. 5. If the caller specifies a greater value for *pColorCapsCount in second call to NvAPI_DISP_GetMonitorColorCapabilities() than what was returned from first call, the API will return only the actual number of elements in the color capabilities array and the extra buffer will remain unused.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | displayId | Monitor Identifier
[in,out] | pMonitorColorCapabilities | The monitor color capabilities information
[in,out] pColorCapsCount - During input, the number of elements allocated for the pMonitorColorCapabilities pointer
  • During output, the actual number of color data elements the monitor supports
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INSUFFICIENT_BUFFER | The input buffer size is not sufficient to hold the total contents. In this case pColorCapsCount will hold the required amount of elements.
NVAPI_INVALID_DISPLAY_ID | The input monitor is either not connected or is not a DP panel.
NVAPI_INTERFACE NvAPI_DISP_GetTiming | ( | __in NvU32 | displayId,
 |  | __in NV_TIMING_INPUT * | timingInput,
 |  | __out NV_TIMING * | pTiming
 | ) |  |

DESCRIPTION: This function calculates the timing from the visible width/height/refresh-rate and timing type info.

SUPPORTED OS: Windows XP and higher

Since:
Release: 313
Parameters:
[in] | displayId | Display ID of the display.
[in] | timingInput | Inputs used for calculating the timing.
[out] | pTiming | Pointer to the NV_TIMING structure.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INTERFACE NvAPI_Disp_InfoFrameControl | ( | __in NvU32 | displayId,
 |  | __inout NV_INFOFRAME_DATA * | pInfoframeData
 | ) |  |

DESCRIPTION: This API controls the InfoFrame values.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | displayId | Monitor Identifier
[in,out] | pInfoframeData | Contains data corresponding to InfoFrame
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INTERFACE NvAPI_DISP_RevertCustomDisplayTrial | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count
 | ) |  |

DESCRIPTION: This API is used to restore the display configuration, that was changed by calling NvAPI_DISP_TryCustomDisplay(). This function must be called only after a custom display configuration is tested on the hardware, using NvAPI_DISP_TryCustomDisplay(), otherwise no action is taken. On Vista, NvAPI_DISP_RevertCustomDisplayTrial should be called with an active display that was affected during the NvAPI_DISP_TryCustomDisplay() call, per GPU.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 313
Parameters:
[in] | pDisplayIds | Pointer to display Id, of an active display.
[in] | count | Total number of incoming Display IDs. For future use only. Currently it is expected to be passed as 1.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INTERFACE NvAPI_DISP_SaveCustomDisplay | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count,
 |  | __in NvU32 | isThisOutputIdOnly,
 |  | __in NvU32 | isThisMonitorIdOnly
 | ) |  |

DESCRIPTION: This function saves the current hardware display configuration on the specified Display IDs as a custom display configuration. This function should be called right after NvAPI_DISP_TryCustomDisplay() to save the custom display from the current hardware context. This function will not do anything if the custom display configuration is not tested on the hardware.

SUPPORTED OS: Windows XP and higher

Since:
Release: 313
Parameters:
[in] | pDisplayIds | Array of Dispaly IDs on which custom display configuration is to be saved.
[in] | count | Total number of the incoming Dispaly IDs. This is for the multi-head support.
[in] | isThisOutputIdOnly | If set, the saved custom display will only be applied on the monitor with the same outputId (see NvAPI Handles).
[in] | isThisMonitorIdOnly | If set, the saved custom display will only be applied on the monitor with the same EDID ID or the same TV connector in case of analog TV.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_DISPLAY_ID,: Custom Timing is not supported on the Display, whose display id is passed
NVAPI_INTERFACE NvAPI_DISP_SetDisplayConfig | ( | __in NvU32 | pathInfoCount,
 |  | __in_ecount(pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO * | pathInfo,
 |  | __in NvU32 | flags
 | ) |  |

DESCRIPTION: This API lets caller apply a global display configuration across multiple GPUs.

If all sourceIds are zero, then NvAPI will pick up sourceId's based on the following criteria :

  • If user provides sourceModeInfo then we are trying to assign 0th sourceId always to GDIPrimary. This is needed since active windows always moves along with 0th sourceId.
  • For rest of the paths, we are incrementally assigning the sourceId per adapter basis.
  • If user doesn't provide sourceModeInfo then NVAPI just picks up some default sourceId's in incremental order. Note : NVAPI will not intelligently choose the sourceIDs for any configs that does not need a modeset.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | pathInfoCount | Number of supplied elements in pathInfo
[in] | pathInfo | Array of path information
[in] | flags | Flags for applying settings
Return values:
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized
NVAPI_ERROR | - miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | - Invalid input parameter.
NVAPI_INTERFACE NvAPI_DISP_TryCustomDisplay | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count,
 |  | __in_ecount(count) NV_CUSTOM_DISPLAY * | pCustDisp
 | ) |  |

DESCRIPTION: This API is used to set up a custom display without saving the configuration on multiple displays.

Note:
All the members of srcPartition, present in NV_CUSTOM_DISPLAY structure, should have their range in (0.0,1.0). In clone mode the timings can applied to both the target monitors but only one target at a time.
For the secondary target the applied timings works under the following conditions:
  • If the secondary monitor EDID supports the selected timing, OR
  • If the selected custom timings can be scaled by the secondary monitor for the selected source resolution on the primary, OR
  • If the selected custom timings matches the existing source resolution on the primary. Setting up a custom display on non-active but connected monitors is supported only for Win7 and above.

SUPPORTED OS: Windows XP, Windows 7 and higher

Since:
Release: 313
Parameters:
[in] | pDisplayIds | Array of the target display Dispaly IDs - See NvAPI Handles.
[in] | count | Total number of the incoming Display IDs and corresponding NV_CUSTOM_DISPLAY structure. This is for the multi-head support.
[in] | pCustDisp | Pointer to the NV_CUSTOM_DISPLAY structure array.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_DISPLAY_ID,: Custom Timing is not supported on the Display, whose display id is passed
NVAPI_INTERFACE NvAPI_EnableHWCursor ( NvDisplayHandle hNvDisplay )

This function enables hardware cursor support

SUPPORTED OS: Windows XP

Since:
Release: 80
Returns:
NVAPI_ERROR or NVAPI_OK
NVAPI_INTERFACE NvAPI_GetAssociatedDisplayOutputId | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 * | pOutputId
 | ) |  |

This function gets the active outputId associated with the display handle.

SUPPORTED OS: Windows XP and higher

Since:
Release: 90
Parameters:
[in] | hNvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[out] | outputId | The active display output ID associated with the selected display handle hNvDisplay. The outputid will have only one bit set. In the case of Clone or Span mode, this will indicate the display outputId of the primary display that the GPU is driving. See NvAPI Handles.
Return values:
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_DISPLAY_HANDLE | hNvDisplay is not a valid display handle.
NVAPI_INTERFACE NvAPI_GetAssociatedNvidiaDisplayName | ( | NvDisplayHandle | NvDispHandle,
 |  | NvAPI_ShortString | szDisplayName
 | ) |  |

For a given NVIDIA display handle, this function returns a string (such as "\\.\DISPLAY1") to identify the display.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | Either argument is NULL
NVAPI_OK | *pNvDispHandle is now valid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name
NvAPI_GetDisplayPortInfo | ( | __in_opt NvDisplayHandle | hNvDisplay,
 |  | __in NvU32 | outputId,
 |  | __inout NV_DISPLAY_PORT_INFO * | pInfo
 | ) |  |

DESCRIPTION: This function returns the current DisplayPort-related information on the specified device (monitor).

SUPPORTED OS: Windows XP and higher

Since:
Release: 165
Parameters:
[in] | hvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle(). This parameter is ignored when the outputId is a NvAPI displayId.
[in] | outputId | This can either be the connection bit mask or the NvAPI displayId. When the legacy connection bit mask is passed, it should have exactly 1 bit set to indicate a single display. If it's "0" then the default outputId from NvAPI_GetAssociatedDisplayOutputId() will be used. See NvAPI Handles.
[out] | pInfo | The DisplayPort information
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.
NvAPI_GetHDMISupportInfo | ( | __in_opt NvDisplayHandle | hNvDisplay,
 |  | __in NvU32 | outputId,
 |  | __inout NV_HDMI_SUPPORT_INFO * | pInfo
 | ) |  |

SUPPORTED OS: Windows Vista and higher
This API returns the current infoframe data on the specified device(monitor).

Since:
Release: 95
Parameters:
[in] | hvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle(). This parameter is ignored when the outputId is a NvAPI displayId.
[in] | outputId | This can either be the connection bit mask or the NvAPI displayId. When the legacy connection bit mask is passed, it should have exactly 1 bit set to indicate a single display. If it's "0" then the default outputId from NvAPI_GetAssociatedDisplayOutputId() will be used. See NvAPI Handles.
[out] | pInfo | The monitor and GPU's HDMI support info
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.
NVAPI_INTERFACE NvAPI_GetSupportedViews | ( | NvDisplayHandle | hNvDisplay,
 |  | NV_TARGET_VIEW_MODE * | pTargetViews,
 |  | NvU32 * | pViewCount
 | ) |  |

This API lets caller enumerate all the supported NVIDIA display views - nView and Dualview modes.

SUPPORTED OS: Windows XP and higher

Since:
Release: 85
Parameters:
[in] | hNvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[out] | pTargetViews | Array of supported views. Can be NULL to retrieve the pViewCount first.
[in,out] | pViewCount | Count of supported views.
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.
NVAPI_INTERFACE NvAPI_GetUnAttachedAssociatedDisplayName | ( | NvUnAttachedDisplayHandle | hNvUnAttachedDisp,
 |  | NvAPI_ShortString | szDisplayName
 | ) |  |

This function returns the display name given, for example, "\\DISPLAY1", using the unattached NVIDIA display handle

SUPPORTED OS: Windows XP and higher

Since:
Release: 95
Return values:
NVAPI_INVALID_ARGUMENT | Either argument is NULL
NVAPI_OK | *pNvDispHandle is now valid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name
NVAPI_INTERFACE NvAPI_GetVBlankCounter | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 * | pCounter
 | ) |  |

This function gets the V-blank counter

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Returns:
NVAPI_ERROR or NVAPI_OK
NvAPI_SetDisplayPort | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 | outputId,
 |  | NV_DISPLAY_PORT_CONFIG * | pCfg
 | ) |  |

DESCRIPTION: This function sets up DisplayPort-related configurations.

SUPPORTED OS: Windows XP and higher

Since:
Release: 165
Parameters:
[in] | hNvDisplay | NVIDIA display handle. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[in] | outputId | This display output ID, when it's "0" it means the default outputId generated from the return of NvAPI_GetAssociatedDisplayOutputId(). See NvAPI Handles.
[in] | pCfg | The display port config structure. If pCfg is NULL, it means to use the driver's default value to setup.
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter
NVAPI_INTERFACE NvAPI_SetRefreshRateOverride | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 | outputsMask,
 |  | float | refreshRate,
 |  | NvU32 | bSetDeferred
 | ) |  |

This function overrides the refresh rate on the given display/outputsMask. The new refresh rate can be applied right away in this API call or deferred to be applied with the next OS modeset. The override is good for only one modeset (regardless whether it's deferred or immediate).

SUPPORTED OS: Windows XP

Since:
Release: 80
Parameters:
[in] | hNvDisplay | The NVIDIA display handle. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[in] | outputsMask | A set of bits that identify all target outputs which are associated with the NVIDIA display handle to apply the refresh rate override. When SLI is enabled, the outputsMask only applies to the GPU that is driving the display output.
[in] | refreshRate | The override value. "0.0" means cancel the override.
[in] bSetDeferred
  • "0": Apply the refresh rate override immediately in this API call.
  • "1": Apply refresh rate at the next OS modeset.
Return values:
NVAPI_INVALID_ARGUMENT | hNvDisplay or outputsMask is invalid
NVAPI_OK | The refresh rate override is correct set
NVAPI_ERROR | The operation failed


Modules
GPU APIs

Modules

GPU General Control Interface
GPU Thermal Control Interface
GPU Performance State Interface
GPU Clock Control Interface
GPU Cooler Interface
GPU ECC Interface

Detailed Description

The GPU APIs retrieve and control various attributes of the GPU, such as outputs, VBIOS revision, APG rate, frame buffer size, and thermal settings.


Data Structures | Defines | Typedefs | Enumerations | Functions
GPU General Control Interface
GPU APIs

Data Structures

struct | _NV_GPU_DISPLAYIDS
struct | _NV_BOARD_INFO
struct | NV_GPU_GET_HDCP_SUPPORT_STATUS
HDPC support status - used in NvAPI_GPU_GetHDCPSupportStatus() More...
struct | NV_SCANOUT_INTENSITY_DATA_V1
struct | NV_SCANOUT_INTENSITY_DATA_V2
struct | _NV_SCANOUT_INTENSITY_STATE_DATA
struct | NV_SCANOUT_WARPING_DATA
struct | _NV_SCANOUT_WARPING_STATE_DATA
struct | _NV_SCANOUT_INFORMATION
struct | _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
struct | _NV_GPU_GET_ILLUMINATION_PARM_V1
struct | _NV_GPU_SET_ILLUMINATION_PARM_V1

Defines

#define | NV_GPU_CONNECTED_IDS_FLAG_UNCACHED NV_BIT(0)
#define | NV_GPU_CONNECTED_IDS_FLAG_SLI NV_BIT(1)
#define | NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE NV_BIT(2)
#define | NV_GPU_CONNECTED_IDS_FLAG_FAKE NV_BIT(3)
#define | NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST NV_BIT(4)
#define | NV_GPU_DISPLAYIDS_VER1 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,1)
#define | NV_BOARD_INFO_VER NV_BOARD_INFO_VER1
#define | NV_GPU_GET_HDCP_SUPPORT_STATUS_VER MAKE_NVAPI_VERSION(NV_GPU_GET_HDCP_SUPPORT_STATUS,1)
#define | NV_SCANOUT_INTENSITY_DATA_VER1 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V1, 1)
#define | NV_SCANOUT_INTENSITY_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_STATE_DATA, 1)
#define | NV_SCANOUT_WARPING_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_DATA, 1)
#define | NV_SCANOUT_WARPING_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_STATE_DATA, 1)
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1,1)
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1
#define | NV_GPU_GET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_GET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_GET_ILLUMINATION_PARM_VER NV_GPU_GET_ILLUMINATION_PARM_VER_1
#define | NV_GPU_SET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_SET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_SET_ILLUMINATION_PARM_VER NV_GPU_SET_ILLUMINATION_PARM_VER_1

Typedefs

typedef enum _NV_GPU_CONNECTOR_TYPE | NV_GPU_CONNECTOR_TYPE
typedef struct _NV_GPU_DISPLAYIDS | NV_GPU_DISPLAYIDS
typedef enum _NV_GPU_OUTPUT_TYPE | NV_GPU_OUTPUT_TYPE
typedef enum _NV_GPU_TYPE | NV_GPU_TYPE
typedef enum _NV_GPU_BUS_TYPE | NV_GPU_BUS_TYPE
typedef struct _NV_BOARD_INFO | NV_BOARD_INFO_V1
typedef NV_BOARD_INFO_V1 | NV_BOARD_INFO
typedef enum
_NV_GPU_HDCP_FUSE_STATE 		NV_GPU_HDCP_FUSE_STATE
typedef enum
_NV_GPU_HDCP_KEY_SOURCE 		NV_GPU_HDCP_KEY_SOURCE
typedef enum
_NV_GPU_HDCP_KEY_SOURCE_STATE 		NV_GPU_HDCP_KEY_SOURCE_STATE
typedef struct
_NV_SCANOUT_INTENSITY_STATE_DATA 		NV_SCANOUT_INTENSITY_STATE_DATA
typedef struct
_NV_SCANOUT_WARPING_STATE_DATA 		NV_SCANOUT_WARPING_STATE_DATA
typedef struct
_NV_SCANOUT_INFORMATION 		NV_SCANOUT_INFORMATION
typedef enum
_NV_GPU_ILLUMINATION_ATTRIB 		NV_GPU_ILLUMINATION_ATTRIB
typedef struct
_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 		NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
typedef
NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 		NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM
typedef struct
_NV_GPU_GET_ILLUMINATION_PARM_V1 		NV_GPU_GET_ILLUMINATION_PARM_V1
typedef
NV_GPU_GET_ILLUMINATION_PARM_V1 		NV_GPU_GET_ILLUMINATION_PARM
typedef struct
_NV_GPU_SET_ILLUMINATION_PARM_V1 		NV_GPU_SET_ILLUMINATION_PARM_V1
typedef
NV_GPU_SET_ILLUMINATION_PARM_V1 		NV_GPU_SET_ILLUMINATION_PARM

Enumerations

enum _NV_GPU_CONNECTOR_TYPE {
NVAPI_GPU_CONNECTOR_VGA_15_PIN = 0x00000000, NVAPI_GPU_CONNECTOR_TV_COMPOSITE = 0x00000010, NVAPI_GPU_CONNECTOR_TV_SVIDEO = 0x00000011, NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT = 0x00000013,
NVAPI_GPU_CONNECTOR_TV_SCART = 0x00000014, NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 = 0x00000016, NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 = 0x00000017, NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB = 0x00000018,
NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO = 0x00000019, NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE = 0x0000001A, NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO = 0x00000020, NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE = 0x00000021,
NVAPI_GPU_CONNECTOR_DVI_I = 0x00000030, NVAPI_GPU_CONNECTOR_DVI_D = 0x00000031, NVAPI_GPU_CONNECTOR_ADC = 0x00000032, NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 = 0x00000038,
NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 = 0x00000039, NVAPI_GPU_CONNECTOR_SPWG = 0x00000040, NVAPI_GPU_CONNECTOR_OEM = 0x00000041, NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL = 0x00000046,
NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL = 0x00000047, NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT = 0x00000048, NVAPI_GPU_CONNECTOR_HDMI_A = 0x00000061, NVAPI_GPU_CONNECTOR_HDMI_C_MINI = 0x00000063,
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 = 0x00000064, NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 = 0x00000065, NVAPI_GPU_CONNECTOR_VIRTUAL_WFD = 0x00000070, NVAPI_GPU_CONNECTOR_UNKNOWN = 0xFFFFFFFF
}
enum NV_MONITOR_CONN_TYPE {
NV_MONITOR_CONN_TYPE_UNINITIALIZED = 0, NV_MONITOR_CONN_TYPE_VGA, NV_MONITOR_CONN_TYPE_COMPONENT, NV_MONITOR_CONN_TYPE_SVIDEO,
NV_MONITOR_CONN_TYPE_HDMI, NV_MONITOR_CONN_TYPE_DVI, NV_MONITOR_CONN_TYPE_LVDS, NV_MONITOR_CONN_TYPE_DP,
NV_MONITOR_CONN_TYPE_COMPOSITE, NV_MONITOR_CONN_TYPE_UNKNOWN = -1
}
enum | NV_SYSTEM_TYPE { NV_SYSTEM_TYPE_UNKNOWN = 0, NV_SYSTEM_TYPE_LAPTOP = 1, NV_SYSTEM_TYPE_DESKTOP = 2 }
enum | _NV_GPU_OUTPUT_TYPE { NVAPI_GPU_OUTPUT_UNKNOWN = 0, NVAPI_GPU_OUTPUT_CRT = 1, NVAPI_GPU_OUTPUT_DFP = 2, NVAPI_GPU_OUTPUT_TV = 3 }
enum | _NV_GPU_TYPE { NV_SYSTEM_TYPE_GPU_UNKNOWN = 0, NV_SYSTEM_TYPE_IGPU = 1, NV_SYSTEM_TYPE_DGPU = 2 }
enum _NV_GPU_BUS_TYPE {
NVAPI_GPU_BUS_TYPE_UNDEFINED = 0, NVAPI_GPU_BUS_TYPE_PCI = 1, NVAPI_GPU_BUS_TYPE_AGP = 2, NVAPI_GPU_BUS_TYPE_PCI_EXPRESS = 3,
NVAPI_GPU_BUS_TYPE_FPCI = 4, NVAPI_GPU_BUS_TYPE_AXI = 5
}
enum NVAPI_GPU_WORKSTATION_FEATURE_MASK {
NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP = 0x00000001, NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO = 0x00000010, NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING = 0x00000100, NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY = 0x00000200,
NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE = 0x00000400, NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 = 0x00001000
}
enum | _NV_GPU_HDCP_FUSE_STATE { NV_GPU_HDCP_FUSE_STATE_UNKNOWN = 0, NV_GPU_HDCP_FUSE_STATE_DISABLED = 1, NV_GPU_HDCP_FUSE_STATE_ENABLED = 2 }
enum _NV_GPU_HDCP_KEY_SOURCE {
NV_GPU_HDCP_KEY_SOURCE_UNKNOWN = 0, NV_GPU_HDCP_KEY_SOURCE_NONE = 1, NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM = 2, NV_GPU_HDCP_KEY_SOURCE_SBIOS = 3,
NV_GPU_HDCP_KEY_SOURCE_I2C_ROM = 4, NV_GPU_HDCP_KEY_SOURCE_FUSES = 5
}
enum | _NV_GPU_HDCP_KEY_SOURCE_STATE { NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN = 0, NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT = 1, NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT = 2 }
enum | NV_GPU_WARPING_VERTICE_FORMAT { NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ = 0, NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ = 1 }
enum | NV_GPU_SCANOUT_COMPOSITION_PARAMETER { NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD = 0 }
enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE {
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT = 0, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR = 0x100, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR = 0x101, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED = 0x102,
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE = 0x103, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR = 0x104, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED = 0x105, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE = 0x106
}
enum | _NV_GPU_ILLUMINATION_ATTRIB { NV_GPU_IA_LOGO_BRIGHTNESS = 0, NV_GPU_IA_SLI_BRIGHTNESS = 1 }

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
NVAPI_INTERFACE | NvAPI_EnumTCCPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_EnumLogicalGPUs (NvLogicalGpuHandle nvGPUHandle[NVAPI_MAX_LOGICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromDisplay (NvDisplayHandle hNvDisp, NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvPhysicalGpuHandle *pPhysicalGpu)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromDisplay (NvDisplayHandle hNvDisp, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromPhysicalGPU (NvPhysicalGpuHandle hPhysicalGPU, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromLogicalGPU (NvLogicalGpuHandle hLogicalGPU, NvPhysicalGpuHandle hPhysicalGPU[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GPU_GetGpuCoreCount (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pCount)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetAllDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetAllOutputs(NvPhysicalGpuHandle hPhysicalGpu
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetConnectedDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetConnectedOutputs(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetConnectedDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount,*pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GPU_GetAllDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount,*pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount)
NVAPI_INTERFACE | NvAPI_GPU_GetSystemType (NvPhysicalGpuHandle hPhysicalGpu, NV_SYSTEM_TYPE *pSystemType)
NVAPI_INTERFACE | NvAPI_GPU_GetActiveOutputs (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pOutputsMask)
NVAPI_INTERFACE | NvAPI_GPU_SetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
NVAPI_INTERFACE | NvAPI_GPU_GetOutputType (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NV_GPU_OUTPUT_TYPE *pOutputType)
NVAPI_INTERFACE | NvAPI_GPU_ValidateOutputCombination (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputsMask)
NVAPI_INTERFACE | NvAPI_GPU_GetFullName (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szName)
NVAPI_INTERFACE | NvAPI_GPU_GetPCIIdentifiers (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pDeviceId, NvU32 *pSubSystemId, NvU32 *pRevisionId, NvU32 *pExtDeviceId)
NVAPI_INTERFACE | NvAPI_GPU_GetGPUType (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_TYPE *pGpuType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusType (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_BUS_TYPE *pBusType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusId)
NVAPI_INTERFACE | NvAPI_GPU_GetBusSlotId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusSlotId)
NVAPI_INTERFACE | NvAPI_GPU_GetIRQ (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pIRQ)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosOEMRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosVersionString (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetAGPAperture (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentAGPRate (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pRate)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPCIEDownstreamWidth (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pWidth)
NVAPI_INTERFACE | NvAPI_GPU_GetPhysicalFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetVirtualFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetQuadroStatus (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pStatus)
NVAPI_INTERFACE | NvAPI_GPU_GetBoardInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_BOARD_INFO *pBoardInfo)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureSetup (__in NvPhysicalGpuHandle hPhysicalGpu, __in NvU32 featureEnableMask, __in NvU32 featureDisableMask)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureQuery (__in NvPhysicalGpuHandle hPhysicalGpu, __out_opt NvU32 *pConfiguredFeatureMask, __out_opt NvU32 *pConsistentFeatureMask)
NVAPI_INTERFACE | NvAPI_GPU_GetHDCPSupportStatus (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_GET_HDCP_SUPPORT_STATUS *pGetHDCPSupportStatus)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutIntensity (NvU32 displayId, NV_SCANOUT_INTENSITY_DATA *scanoutIntensityData, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutIntensityState (__in NvU32 displayId, __inout NV_SCANOUT_INTENSITY_STATE_DATA *scanoutIntensityStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutWarping (NvU32 displayId, NV_SCANOUT_WARPING_DATA *scanoutWarpingData, int *piMaxNumVertices, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutWarpingState (__in NvU32 displayId, __inout NV_SCANOUT_WARPING_STATE_DATA *scanoutWarpingStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutCompositionParameter (NvU32 displayId, NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE parameterValue, float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutCompositionParameter (__in NvU32 displayId, __in NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, __out NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE *parameterData, __out float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfiguration (NvU32 displayId, NvSBox *desktopRect, NvSBox *scanoutRect)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfigurationEx (__in NvU32 displayId, __inout NV_SCANOUT_INFORMATION *pScanoutInformation)
NVAPI_INTERFACE | NvAPI_GPU_GetPerfDecreaseInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NvU32 *pPerfDecrInfo)
NVAPI_INTERFACE | NvAPI_GPU_QueryIlluminationSupport (__inout NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM *pIlluminationSupportInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetIllumination (NV_GPU_GET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetIllumination (NV_GPU_SET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_EnumPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
typedef NV_EDID_V3 | NV_EDID
#define | NV_EDID_V1_DATA_SIZE 256
#define | NV_EDID_DATA_SIZE NV_EDID_V1_DATA_SIZE
#define | NV_EDID_VER1 MAKE_NVAPI_VERSION(NV_EDID_V1,1)
#define | NV_EDID_VER2 MAKE_NVAPI_VERSION(NV_EDID_V2,2)
#define | NV_EDID_VER3 MAKE_NVAPI_VERSION(NV_EDID_V3,3)
#define | NV_EDID_VER NV_EDID_VER3

Detailed Description

The general GPU APIs are used to get general information about the GPU, such as outputs, VBIOS revision, APG rate, and frame buffer size.

Define Documentation

#define NV_BOARD_INFO_VER NV_BOARD_INFO_VER1
#define NV_EDID_DATA_SIZE NV_EDID_V1_DATA_SIZE
#define NV_EDID_V1_DATA_SIZE 256
#define NV_EDID_VER NV_EDID_VER3
#define NV_EDID_VER1 MAKE_NVAPI_VERSION(NV_EDID_V1,1)
#define NV_EDID_VER2 MAKE_NVAPI_VERSION(NV_EDID_V2,2)
#define NV_EDID_VER3 MAKE_NVAPI_VERSION(NV_EDID_V3,3)
#define NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST NV_BIT(4)

Excludes devices that are part of the multi stream topology.

#define NV_GPU_CONNECTED_IDS_FLAG_FAKE NV_BIT(3)

Get devices that includes the fake connected monitors.

#define NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE NV_BIT(2)

Get devices such that to reflect the Lid State.

#define NV_GPU_CONNECTED_IDS_FLAG_SLI NV_BIT(1)

Get devices such that those can be selected in an SLI configuration.

#define NV_GPU_CONNECTED_IDS_FLAG_UNCACHED NV_BIT(0)

Get uncached connected devices.

#define NV_GPU_DISPLAYIDS_VER1 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,1)

Macro for constructing the version field of _NV_GPU_DISPLAYIDS

#define NV_GPU_GET_HDCP_SUPPORT_STATUS_VER MAKE_NVAPI_VERSION(NV_GPU_GET_HDCP_SUPPORT_STATUS,1)

Macro for constructing the version for structure NV_GPU_GET_HDCP_SUPPORT_STATUS.

#define NV_GPU_GET_ILLUMINATION_PARM_VER NV_GPU_GET_ILLUMINATION_PARM_VER_1
#define NV_GPU_GET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_GET_ILLUMINATION_PARM_V1,1)
#define NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1
#define NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1,1)
#define NV_GPU_SET_ILLUMINATION_PARM_VER NV_GPU_SET_ILLUMINATION_PARM_VER_1
#define NV_GPU_SET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_SET_ILLUMINATION_PARM_V1,1)
#define NV_SCANOUT_INTENSITY_DATA_VER1 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V1, 1)
#define NV_SCANOUT_INTENSITY_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_STATE_DATA, 1)
#define NV_SCANOUT_WARPING_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_STATE_DATA, 1)
#define NV_SCANOUT_WARPING_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_DATA, 1)

Typedef Documentation

typedef NV_BOARD_INFO_V1 NV_BOARD_INFO
typedef struct _NV_BOARD_INFO NV_BOARD_INFO_V1
typedef NV_EDID_V3 NV_EDID
typedef enum _NV_GPU_BUS_TYPE NV_GPU_BUS_TYPE

Used in NvAPI_GPU_GetBusType()

typedef enum _NV_GPU_CONNECTOR_TYPE NV_GPU_CONNECTOR_TYPE

Used in NV_GPU_CONNECTOR_DATA

typedef struct _NV_GPU_DISPLAYIDS NV_GPU_DISPLAYIDS
typedef NV_GPU_GET_ILLUMINATION_PARM_V1 NV_GPU_GET_ILLUMINATION_PARM
typedef struct _NV_GPU_GET_ILLUMINATION_PARM_V1 NV_GPU_GET_ILLUMINATION_PARM_V1
typedef enum _NV_GPU_HDCP_FUSE_STATE NV_GPU_HDCP_FUSE_STATE

HDCP fuse states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

typedef enum _NV_GPU_HDCP_KEY_SOURCE NV_GPU_HDCP_KEY_SOURCE

HDCP key sources - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

typedef enum _NV_GPU_HDCP_KEY_SOURCE_STATE NV_GPU_HDCP_KEY_SOURCE_STATE

HDCP key source states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

typedef enum _NV_GPU_ILLUMINATION_ATTRIB NV_GPU_ILLUMINATION_ATTRIB
typedef enum _NV_GPU_OUTPUT_TYPE NV_GPU_OUTPUT_TYPE

used in NvAPI_GPU_GetOutputType()

typedef NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM
typedef struct _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
typedef NV_GPU_SET_ILLUMINATION_PARM_V1 NV_GPU_SET_ILLUMINATION_PARM
typedef struct _NV_GPU_SET_ILLUMINATION_PARM_V1 NV_GPU_SET_ILLUMINATION_PARM_V1
typedef enum _NV_GPU_TYPE NV_GPU_TYPE

Used in NvAPI_GPU_GetGPUType().

typedef struct _NV_SCANOUT_INFORMATION NV_SCANOUT_INFORMATION

Used in NvAPI_GPU_GetScanoutConfigurationEx().

typedef struct _NV_SCANOUT_INTENSITY_STATE_DATA NV_SCANOUT_INTENSITY_STATE_DATA
typedef struct _NV_SCANOUT_WARPING_STATE_DATA NV_SCANOUT_WARPING_STATE_DATA

Enumeration Type Documentation

enum _NV_GPU_BUS_TYPE

Used in NvAPI_GPU_GetBusType()

Enumerator:
NVAPI_GPU_BUS_TYPE_UNDEFINED
NVAPI_GPU_BUS_TYPE_PCI
NVAPI_GPU_BUS_TYPE_AGP
NVAPI_GPU_BUS_TYPE_PCI_EXPRESS
NVAPI_GPU_BUS_TYPE_FPCI
NVAPI_GPU_BUS_TYPE_AXI
enum _NV_GPU_CONNECTOR_TYPE

Used in NV_GPU_CONNECTOR_DATA

Enumerator:
NVAPI_GPU_CONNECTOR_VGA_15_PIN
NVAPI_GPU_CONNECTOR_TV_COMPOSITE
NVAPI_GPU_CONNECTOR_TV_SVIDEO
NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT
NVAPI_GPU_CONNECTOR_TV_SCART
NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120
NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120
NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB
NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO
NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE
NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO
NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE
NVAPI_GPU_CONNECTOR_DVI_I
NVAPI_GPU_CONNECTOR_DVI_D
NVAPI_GPU_CONNECTOR_ADC
NVAPI_GPU_CONNECTOR_LFH_DVI_I_1
NVAPI_GPU_CONNECTOR_LFH_DVI_I_2
NVAPI_GPU_CONNECTOR_SPWG
NVAPI_GPU_CONNECTOR_OEM
NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL
NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL
NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT
NVAPI_GPU_CONNECTOR_HDMI_A
NVAPI_GPU_CONNECTOR_HDMI_C_MINI
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2
NVAPI_GPU_CONNECTOR_VIRTUAL_WFD
NVAPI_GPU_CONNECTOR_UNKNOWN
enum _NV_GPU_HDCP_FUSE_STATE

HDCP fuse states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

Enumerator:
NV_GPU_HDCP_FUSE_STATE_UNKNOWN
NV_GPU_HDCP_FUSE_STATE_DISABLED
NV_GPU_HDCP_FUSE_STATE_ENABLED
enum _NV_GPU_HDCP_KEY_SOURCE

HDCP key sources - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

Enumerator:
NV_GPU_HDCP_KEY_SOURCE_UNKNOWN
NV_GPU_HDCP_KEY_SOURCE_NONE
NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM
NV_GPU_HDCP_KEY_SOURCE_SBIOS
NV_GPU_HDCP_KEY_SOURCE_I2C_ROM
NV_GPU_HDCP_KEY_SOURCE_FUSES
enum _NV_GPU_HDCP_KEY_SOURCE_STATE

HDCP key source states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

Enumerator:
NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN
NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT
NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT
enum _NV_GPU_ILLUMINATION_ATTRIB
Enumerator:
NV_GPU_IA_LOGO_BRIGHTNESS
NV_GPU_IA_SLI_BRIGHTNESS
enum _NV_GPU_OUTPUT_TYPE

used in NvAPI_GPU_GetOutputType()

Enumerator:
NVAPI_GPU_OUTPUT_UNKNOWN
NVAPI_GPU_OUTPUT_CRT

CRT display device.

NVAPI_GPU_OUTPUT_DFP

Digital Flat Panel display device.

NVAPI_GPU_OUTPUT_TV

TV display device.

enum _NV_GPU_TYPE

Used in NvAPI_GPU_GetGPUType().

Enumerator:
NV_SYSTEM_TYPE_GPU_UNKNOWN
NV_SYSTEM_TYPE_IGPU

Integrated GPU.

NV_SYSTEM_TYPE_DGPU

Discrete GPU.

enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER
Enumerator:
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD
enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE

This enum defines a collection of possible scanout composition values that can be used to configure possible scanout composition settings. (Currently the only parameter defined is the WARPING_RESAMPLING_METHOD).

Enumerator:
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE
enum NV_GPU_WARPING_VERTICE_FORMAT
Enumerator:
NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ
NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ
enum NV_MONITOR_CONN_TYPE
Enumerator:
NV_MONITOR_CONN_TYPE_UNINITIALIZED
NV_MONITOR_CONN_TYPE_VGA
NV_MONITOR_CONN_TYPE_COMPONENT
NV_MONITOR_CONN_TYPE_SVIDEO
NV_MONITOR_CONN_TYPE_HDMI
NV_MONITOR_CONN_TYPE_DVI
NV_MONITOR_CONN_TYPE_LVDS
NV_MONITOR_CONN_TYPE_DP
NV_MONITOR_CONN_TYPE_COMPOSITE
NV_MONITOR_CONN_TYPE_UNKNOWN
enum NV_SYSTEM_TYPE

Used in NvAPI_GPU_GetSystemType()

Enumerator:
NV_SYSTEM_TYPE_UNKNOWN
NV_SYSTEM_TYPE_LAPTOP
NV_SYSTEM_TYPE_DESKTOP
enum NVAPI_GPU_WORKSTATION_FEATURE_MASK
Enumerator:
NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP
NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO
NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING
NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY
NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE
NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10

Function Documentation

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_GPU_GetAllDisplayIds." |
 | ) |  |

This function returns set of all GPU-output identifiers as a bitmask.

Since:
Release: 85
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL.
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_GPU_GetConnectedDisplayIds." |
 | ) |  |

This function is the same as NvAPI_GPU_GetAllOutputs() but returns only the set of GPU output identifiers that are connected to display devices.

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL.
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

DESCRIPTION: This function is the same as NvAPI_GPU_GetConnectedOutputs() but returns only the set of GPU-output identifiers that can be selected in an SLI configuration. NOTE: This function matches NvAPI_GPU_GetConnectedOutputs()

  • On systems which are not SLI capable.
  • If the queried GPU is not part of a valid SLI group.
Since:
Release: 170
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE,: hPhysicalGpu was not a physical GPU handle

This function is similar to NvAPI_GPU_GetConnectedOutputs(), and returns the connected display identifiers that are connected as an output mask but unlike NvAPI_GPU_GetConnectedOutputs() this API "always" reflects the Lid State in the output mask. Thus if you expect the LID close state to be available in the connection mask use this API.

  • If LID is closed then this API will remove the LID panel from the connected display identifiers.
  • If LID is open then this API will reflect the LID panel in the connected display identifiers.
Note:
This API should be used on notebook systems and on systems where the LID state is required in the connection output mask. On desktop systems the returned identifiers will match NvAPI_GPU_GetConnectedOutputs().
Since:
Release: 95
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

DESCRIPTION: This function is the same as NvAPI_GPU_GetConnectedOutputsWithLidState() but returns only the set of GPU-output identifiers that can be selected in an SLI configuration. With SLI disabled, this function matches NvAPI_GPU_GetConnectedOutputsWithLidState().

Since:
Release: 170
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_INTERFACE NvAPI_EnumLogicalGPUs | ( | NvLogicalGpuHandle | nvGPUHandle[NVAPI_MAX_LOGICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of logical GPU handles.

Each handle represents one or more GPUs acting in concert as a single graphics device.

At least one GPU must be present in the system and running an NVIDIA display driver.

The array nvGPUHandle will be filled with logical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

Note:
All logical GPUs handles get invalidated on a GPU topology change, so the calling application is required to renum the logical GPU handles to get latest physical handle mapping after every GPU topology change activated by a call to NvAPI_SetGpuTopologies().

To detect if SLI rendering is enabled, use NvAPI_D3D_GetCurrentSLIState().

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | nvGPUHandle or pGpuCount is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_INTERFACE NvAPI_EnumPhysicalGPUs | ( | NvPhysicalGpuHandle | nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of physical GPU handles. Each handle represents a physical GPU present in the system. That GPU may be part of an SLI configuration, or may not be visible to the OS directly.

At least one GPU must be present in the system and running an NVIDIA display driver.

The array nvGPUHandle will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

Note:
In drivers older than 105.00, all physical GPU handles get invalidated on a modeset. So the calling applications need to renum the handles after every modeset.
With drivers 105.00 and up, all physical GPU handles are constant. Physical GPU handles are constant as long as the GPUs are not physically moved and the SBIOS VGA order is unchanged.

For GPU handles in TCC MODE please use NvAPI_EnumTCCPhysicalGPUs()

SUPPORTED OS: Windows XP and higher, Mac OS X

Introduced in
Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | nvGPUHandle or pGpuCount is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_INTERFACE NvAPI_EnumTCCPhysicalGPUs | ( | NvPhysicalGpuHandle | nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of physical GPU handles that are in TCC Mode. Each handle represents a physical GPU present in the system in TCC Mode. That GPU may not be visible to the OS directly.

The array nvGPUHandle will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

NOTE: Handles enumerated by this API are only valid for NvAPIs that are tagged as TCC_SUPPORTED If handle is passed to any other API, it will fail with NVAPI_INVALID_HANDLE

For WDDM GPU handles please use NvAPI_EnumPhysicalGPUs()

SUPPORTED OS: Windows Vista and higher

Parameters:
[out] | nvGPUHandle | Physical GPU array that will contain all TCC Physical GPUs
[out] | pGpuCount | count represent the number of valid entries in nvGPUHandle
Return values:
NVAPI_INVALID_ARGUMENT | nvGPUHandle or pGpuCount is NULL
NVAPI_OK | One or more handles were returned
NVAPI_INTERFACE NvAPI_GetLogicalGPUFromDisplay | ( | NvDisplayHandle | hNvDisp,
 |  | NvLogicalGpuHandle * | pLogicalGPU
 | ) |  |

This function returns the logical GPU handle associated with the specified display. At least one GPU must be present in the system and running an NVIDIA display driver.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | hNvDisp is not valid; pLogicalGPU is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_INTERFACE NvAPI_GetLogicalGPUFromPhysicalGPU | ( | NvPhysicalGpuHandle | hPhysicalGPU,
 |  | NvLogicalGpuHandle * | pLogicalGPU
 | ) |  |

This function returns the logical GPU handle associated with specified physical GPU handle. At least one GPU must be present in the system and running an NVIDIA display driver.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGPU is not valid; pLogicalGPU is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_INTERFACE NvAPI_GetPhysicalGPUFromUnAttachedDisplay | ( | NvUnAttachedDisplayHandle | hNvUnAttachedDisp,
 |  | NvPhysicalGpuHandle * | pPhysicalGpu
 | ) |  |

This function returns a physical GPU handle associated with the specified unattached display. The source GPU is a physical render GPU which renders the frame buffer but may or may not drive the scan out.

At least one GPU must be present in the system and running an NVIDIA display driver.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | hNvUnAttachedDisp is not valid or pPhysicalGpu is NULL.
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_INTERFACE NvAPI_GetPhysicalGPUsFromDisplay | ( | NvDisplayHandle | hNvDisp,
 |  | NvPhysicalGpuHandle | nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of physical GPU handles associated with the specified display.

At least one GPU must be present in the system and running an NVIDIA display driver.

The array nvGPUHandle will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

If the display corresponds to more than one physical GPU, the first GPU returned is the one with the attached active output.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | hNvDisp is not valid; nvGPUHandle or pGpuCount is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | no NVIDIA GPU driving a display was found
NVAPI_INTERFACE NvAPI_GetPhysicalGPUsFromLogicalGPU | ( | NvLogicalGpuHandle | hLogicalGPU,
 |  | NvPhysicalGpuHandle | hPhysicalGPU[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns the physical GPU handles associated with the specified logical GPU handle. At least one GPU must be present in the system and running an NVIDIA display driver.

The array hPhysicalGPU will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Return values:
NVAPI_INVALID_ARGUMENT | hLogicalGPU is not valid; hPhysicalGPU is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_LOGICAL_GPU_HANDLE | hLogicalGPU was not a logical GPU handle
NVAPI_INTERFACE NvAPI_GPU_GetActiveOutputs | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pOutputsMask
 | ) |  |

This function is the same as NvAPI_GPU_GetAllOutputs but returns only the set of GPU output identifiers that are actively driving display devices.

SUPPORTED OS: Windows XP and higher

Since:
Release: 85
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL.
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_INTERFACE NvAPI_GPU_GetAGPAperture | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pSize
 | ) |  |

This function returns the AGP aperture in megabytes.

SUPPORTED OS: Windows XP and higher

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | pSize is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_INTERFACE NvAPI_GPU_GetAllDisplayIds | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout_ecount_part_opt *,*pDisplayIdCount NV_GPU_DISPLAYIDS * | pDisplayIds,
 |  | __inout NvU32 * | pDisplayIdCount
 | ) |  |

DESCRIPTION: This API returns display IDs for all possible outputs on the GPU. For DPMST connector, it will return display IDs for all the video sinks in the topology.
HOW TO USE: 1. The first call should be made to get the all display ID count. To get the display ID count, send in
a) hPhysicalGpu - a valid GPU handle(enumerated using NvAPI_EnumPhysicalGPUs()) as input,
b) pDisplayIds - NULL, as we just want to get the display ID count.
c) pDisplayIdCount - a valid pointer to NvU32, whose value is set to ZERO.
If all parameters are correct and this call is successful, this call will return the display ID's count.
2. To get the display ID array, make the second call to NvAPI_GPU_GetAllDisplayIds() with
a) hPhysicalGpu - should be same value which was sent in first call,
b) pDisplayIds - pointer to the display ID array allocated by caller based on display ID count,
eg. malloc(sizeof(NV_GPU_DISPLAYIDS) * pDisplayIdCount).
c) pDisplayIdCount - a valid pointer to NvU32. This indicates for how many display IDs
the memory is allocated(pDisplayIds) by the caller.
If all parameters are correct and this call is successful, this call will return the display ID array and actual display ID count (which was obtained in the first call to NvAPI_GPU_GetAllDisplayIds). If the input display ID count is less than the actual display ID count, it will overwrite the input and give the pDisplayIdCount as actual count and the API will return NVAPI_INSUFFICIENT_BUFFER.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hPhysicalGpu | GPU selection.
[in,out] | DisplayIds | Pointer to an array of NV_GPU_DISPLAYIDS structures, each entry represents one displayID and its attributes.
[in,out] | pDisplayIdCount | As input, this parameter indicates the number of display's id's for which caller has allocated the memory. As output, it will return the actual number of display IDs.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INSUFFICIENT_BUFFER When the input buffer(pDisplayIds) is less than the actual number of display IDs, this API will return NVAPI_INSUFFICIENT_BUFFER.
NVAPI_INTERFACE NvAPI_GPU_GetBoardInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_BOARD_INFO * | pBoardInfo
 | ) |  |

SUPPORTED OS: Windows XP and higher DESCRIPTION: This API Retrieves the Board information (a unique GPU Board Serial Number) stored in the InfoROM.

Parameters:
[in] | hPhysicalGpu | Physical GPU Handle.
[in,out] | NV_BOARD_INFO | Board Information.

TCC_SUPPORTED

Return values:
NVAPI_OK | completed request
NVAPI_ERROR | miscellaneous error occurred
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | handle passed is not a physical GPU handle
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized
NVAPI_INVALID_POINTER | pBoardInfo is NULL
NVAPI_INCOMPATIBLE_STRUCT_VERSION | the version of the INFO struct is not supported
NVAPI_INTERFACE NvAPI_GPU_GetBusId | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBusId
 | ) |  |

DESCRIPTION: Returns the ID of the bus associated with this GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 167
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBusId is NULL.
NVAPI_OK | *pBusId contains the bus ID.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_INTERFACE NvAPI_GPU_GetBusSlotId | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBusSlotId
 | ) |  |

DESCRIPTION: Returns the ID of the bus slot associated with this GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 167
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBusSlotId is NULL.
NVAPI_OK | *pBusSlotId contains the bus slot ID.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_INTERFACE NvAPI_GPU_GetBusType | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_BUS_TYPE * | pBusType
 | ) |  |

This function returns the type of bus associated with this GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBusType is NULL.
NVAPI_OK | *pBusType contains bus identifier.
NVAPI_INTERFACE NvAPI_GPU_GetConnectedDisplayIds | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout_ecount_part_opt *,*pDisplayIdCount NV_GPU_DISPLAYIDS * | pDisplayIds,
 |  | __inout NvU32 * | pDisplayIdCount,
 |  | __in NvU32 | flags
 | ) |  |
      DESCRIPTION: Due to space limitation NvAPI_GPU_GetConnectedOutputs can return maximum 32 devices, but
                   this is no longer true for DPMST. NvAPI_GPU_GetConnectedDisplayIds will return all
                   the connected display devices in the form of displayIds for the associated hPhysicalGpu.
                   This function can accept set of flags to request cached, uncached, sli and lid to get the connected devices.
                   Default value for flags will be cached .
    HOW TO USE: 1) for each PhysicalGpu, make a call to get the number of connected displayId's
                   using NvAPI_GPU_GetConnectedDisplayIds by passing the pDisplayIds as NULL
                   On call success:
                2) Allocate memory based on pDisplayIdCount then make a call NvAPI_GPU_GetConnectedDisplayIds to populate DisplayIds
    SUPPORTED OS:  Windows XP and higher

    PARAMETERS:     hPhysicalGpu (IN)  - GPU selection
                    flags        (IN)  - One or more defines from NV_GPU_CONNECTED_IDS_FLAG_* as valid flags.
                    pDisplayIds  (IN/OUT) - Pointer to an NV_GPU_DISPLAYIDS struct, each entry represents a one displayID and its attributes
                    pDisplayIdCount(OUT)- Number of displayId's.

    RETURN STATUS: NVAPI_INVALID_ARGUMENT: hPhysicalGpu or pDisplayIds or pDisplayIdCount is NULL
                   NVAPI_OK: *pDisplayIds contains a set of GPU-output identifiers
                   NVAPI_NVIDIA_DEVICE_NOT_FOUND: no NVIDIA GPU driving a display was found
                   NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE: hPhysicalGpu was not a physical GPU handle

NVAPI_INTERFACE NvAPI_GPU_GetCurrentAGPRate | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pRate
 | ) |  |

This function returns the current AGP Rate (0 = AGP not present, 1 = 1x, 2 = 2x, etc.).

SUPPORTED OS: Windows XP and higher

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | pRate is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_INTERFACE NvAPI_GPU_GetCurrentPCIEDownstreamWidth | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pWidth
 | ) |  |

This function returns the number of PCIE lanes being used for the PCIE interface downstream from the GPU.

SUPPORTED OS: Windows XP and higher

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | pWidth is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NvAPI_GPU_GetEDID | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | displayOutputId,
 |  | NV_EDID * | pEDID
 | ) |  |

This function returns the EDID data for the specified GPU handle and connection bit mask. displayOutputId should have exactly 1 bit set to indicate a single display. See NvAPI Handles.

SUPPORTED OS: Windows XP and higher

Since:
Release: 85
Return values:
NVAPI_INVALID_ARGUMENT | pEDID is NULL; displayOutputId has 0 or > 1 bits set
NVAPI_OK | *pEDID contains valid data.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_DATA_NOT_FOUND | The requested display does not contain an EDID.
NVAPI_INTERFACE NvAPI_GPU_GetFullName | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvAPI_ShortString | szName
 | ) |  |

This function retrieves the full GPU name as an ASCII string - for example, "Quadro FX 1400".

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Returns:
NVAPI_ERROR or NVAPI_OK
NVAPI_INTERFACE NvAPI_GPU_GetGpuCoreCount | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pCount
 | ) |  |

DESCRIPTION: Retrieves the total number of cores defined for a GPU. Returns 0 on architectures that don't define GPU cores.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Return values:
NVAPI_INVALID_ARGUMENT | pCount is NULL
NVAPI_OK | *pCount is set
NVAPI_NVIDIA_DEVICE_NOT_FOUND | no NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_NOT_SUPPORTED | API call is not supported on current architecture
NVAPI_INTERFACE NvAPI_GPU_GetGPUType | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_TYPE * | pGpuType
 | ) |  |

DESCRIPTION: This function returns the GPU type (integrated or discrete). See NV_GPU_TYPE.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 173
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu
NVAPI_OK | *pGpuType contains the GPU type
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE,: hPhysicalGpu was not a physical GPU handle
NvAPI_GPU_GetHDCPSupportStatus | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_GET_HDCP_SUPPORT_STATUS * | pGetHDCPSupportStatus
 | ) |  |

DESCRIPTION: This function returns a GPU's HDCP support status.

SUPPORTED OS: Windows XP and higher

Since:
Release: 175
Return values:
NVAPI_OK
NVAPI_ERROR
NVAPI_INVALID_ARGUMENT
NVAPI_HANDLE_INVALIDATED
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE
NVAPI_INCOMPATIBLE_STRUCT_VERSION
NvAPI_GPU_GetIllumination ( NV_GPU_GET_ILLUMINATION_PARM * pIlluminationInfo )

DESCRIPTION: This function reports value of the specified illumination attribute.

Note:
Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You should enumerate thru the GPUs with the NvAPI_GPU_QueryIlluminationSupport call to determine which GPU is managing the attribute.

SUPPORTED OS: Windows Vista and higher

Since:
Version: 300.05
Parameters:
[in] | hPhysicalGpu | Physical GPU handle
Attribute | An enumeration value specifying the Illumination attribute to be querried
[out] | Value | A DWORD containing the current value for the specified attribute. This is specified as a percentage of the full range of the attribute (0-100; 0 = off, 100 = full brightness)
Returns:
See NvAPI Status Values for the list of possible return values. Return values of special interest are: NVAPI_INVALID_ARGUMENT The specified attibute is not known to the driver. NVAPI_NOT_SUPPORTED: The specified attribute is not supported on the specified GPU
NVAPI_INTERFACE NvAPI_GPU_GetIRQ | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pIRQ
 | ) |  |

This function returns the interrupt number associated with this GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pIRQ is NULL.
NVAPI_OK | *pIRQ contains interrupt number.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NvAPI_GPU_GetOutputType | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | outputId,
 |  | NV_GPU_OUTPUT_TYPE * | pOutputType
 | ) |  |

This function returns the output type for a specific physical GPU handle and outputId (exactly 1 bit set - see NvAPI Handles).

SUPPORTED OS: Windows XP and higher

Earliest supported ForceWare version: 82.61

Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu, outputId, or pOutputsMask is NULL; or outputId has > 1 bit set
NVAPI_OK | *pOutputType contains a NvGpuOutputType value
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_INTERFACE NvAPI_GPU_GetPCIIdentifiers | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pDeviceId,
 |  | NvU32 * | pSubSystemId,
 |  | NvU32 * | pRevisionId,
 |  | NvU32 * | pExtDeviceId
 | ) |  |

This function returns the PCI identifiers associated with this GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Parameters:
DeviceId | The internal PCI device identifier for the GPU.
SubSystemId | The internal PCI subsystem identifier for the GPU.
RevisionId | The internal PCI device-specific revision identifier for the GPU.
ExtDeviceId | The external PCI device identifier for the GPU.
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or an argument is NULL
NVAPI_OK | Arguments are populated with PCI identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_INTERFACE NvAPI_GPU_GetPerfDecreaseInfo | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NvU32 * | pPerfDecrInfo
 | ) |  |

DESCRIPTION: This function retrieves - in NvU32 variable - reasons for the current performance decrease.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hPhysicalGPU | (IN) - GPU for which performance decrease is to be evaluated.
[out] | pPerfDecrInfo | (OUT) - Pointer to a NvU32 variable containing performance decrease info
Returns:
This API can return any of the error codes enumerated in NvAPI_Status.
NVAPI_INTERFACE NvAPI_GPU_GetPhysicalFrameBufferSize | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pSize
 | ) |  |

This function returns the physical size of framebuffer in KB. This does NOT include any system RAM that may be dedicated for use by the GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | pSize is NULL
NVAPI_OK | Call successful
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_INTERFACE NvAPI_GPU_GetQuadroStatus | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pStatus
 | ) |  |

This function retrieves the Quadro status for the GPU (1 if Quadro, 0 if GeForce)

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Returns:
NVAPI_ERROR or NVAPI_OK
NVAPI_INTERFACE NvAPI_GPU_GetScanoutCompositionParameter | ( | __in NvU32 | displayId,
 |  | __in NV_GPU_SCANOUT_COMPOSITION_PARAMETER | parameter,
 |  | __out NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE * | parameterData,
 |  | __out float * | pContainer
 | ) |  |

DESCRIPTION: This API queries current state of one of the various scanout composition parameters on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in] | parameter | scanout composition parameter to by queried.
[out] | parameterData | scanout composition parameter data.
[out] | pContainer | Additional container for returning data associated with the specified parameter
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_GPU_GetScanoutConfiguration | ( | NvU32 | displayId,
 |  | NvSBox * | desktopRect,
 |  | NvSBox * | scanoutRect
 | ) |  |

DESCRIPTION: This API queries the desktop and scanout portion of the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | desktopRect | desktop area of the display in desktop coordinates.
[in,out] | scanoutRect | scanout area of the display relative to desktopRect.
Return values:
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_GPU_GetScanoutConfigurationEx | ( | __in NvU32 | displayId,
 |  | __inout NV_SCANOUT_INFORMATION * | pScanoutInformation
 | ) |  |

DESCRIPTION: This API queries the desktop and scanout portion of the specified display.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 331
Parameters:
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | pScanoutInformation | desktop area to displayId mapping information.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status.
NVAPI_INTERFACE NvAPI_GPU_GetScanoutIntensityState | ( | __in NvU32 | displayId,
 |  | __inout NV_SCANOUT_INTENSITY_STATE_DATA * | scanoutIntensityStateData
 | ) |  |

DESCRIPTION: This API queries current state of the intensity feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | scanoutIntensityStateData | intensity state data.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_GPU_GetScanoutWarpingState | ( | __in NvU32 | displayId,
 |  | __inout NV_SCANOUT_WARPING_STATE_DATA * | scanoutWarpingStateData
 | ) |  |

DESCRIPTION: This API queries current state of the warping feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | scanoutWarpingStateData | warping state data.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.
NvAPI_GPU_GetSystemType | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_SYSTEM_TYPE * | pSystemType
 | ) |  |

This function identifies whether the GPU is a notebook GPU or a desktop GPU.

SUPPORTED OS: Windows XP and higher

Since:
Release: 95
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pSystemType contains the GPU system type
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE,: hPhysicalGpu was not a physical GPU handle
NVAPI_INTERFACE NvAPI_GPU_GetVbiosOEMRevision | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBiosRevision
 | ) |  |

This function returns the OEM revision of the video BIOS associated with this GPU.

SUPPORTED OS: Windows XP and higher

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBiosRevision is NULL
NVAPI_OK | *pBiosRevision contains revision number
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_INTERFACE NvAPI_GPU_GetVbiosRevision | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBiosRevision
 | ) |  |

This function returns the revision of the video BIOS associated with this GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBiosRevision is NULL.
NVAPI_OK | *pBiosRevision contains revision number.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_INTERFACE NvAPI_GPU_GetVbiosVersionString | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvAPI_ShortString | szBiosRevision
 | ) |  |

This function returns the full video BIOS version string in the form of xx.xx.xx.xx.yy where

  • xx numbers come from NvAPI_GPU_GetVbiosRevision() and
  • yy comes from NvAPI_GPU_GetVbiosOEMRevision().

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | hPhysicalGpu is NULL.
NVAPI_OK | szBiosRevision contains version string.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_INTERFACE NvAPI_GPU_GetVirtualFrameBufferSize | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pSize
 | ) |  |

This function returns the virtual size of framebuffer in KB. This includes the physical RAM plus any system RAM that has been dedicated for use by the GPU.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 90
Return values:
NVAPI_INVALID_ARGUMENT | pSize is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NvAPI_GPU_QueryIlluminationSupport ( __inout NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM * pIlluminationSupportInfo )

DESCRIPTION: This function reports if the specified illumination attribute is supported.

Note:
Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You should enumerate thru the GPUs with this call to determine which GPU is managing the attribute.

SUPPORTED OS: Windows Vista and higher

Since:
Version: 300.05
Parameters:
[in] | hPhysicalGpu | Physical GPU handle
Attribute | An enumeration value specifying the Illumination attribute to be querried
[out] | pSupported | A boolean indicating if the attribute is supported.
Returns:
See NvAPI Status Values for the list of possible return values.
NVAPI_INTERFACE NvAPI_GPU_SetEDID | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | displayOutputId,
 |  | NV_EDID * | pEDID
 | ) |  |

Thus function sets the EDID data for the specified GPU handle and connection bit mask. User can either send the GPU handle & output ID, or only the display ID in the displayOutputId parameter & hPhysicalGpu parameter can be the default handle (0).

Note:
The EDID will be cached across the boot session and will be enumerated to the OS in this call. To remove the EDID set sizeofEDID to zero. OS and NVAPI connection status APIs will reflect the newly set or removed EDID dynamically.

This feature will NOT be supported on the following boards:

  • GeForce
  • Quadro VX
  • Tesla

SUPPORTED OS: Windows XP and higher

Since:
Release: 100
Return values:
NVAPI_INVALID_ARGUMENT | pEDID is NULL; displayOutputId has 0 or > 1 bits set
NVAPI_OK | *pEDID data was applied to the requested displayOutputId.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE,: hPhysicalGpu was not a physical GPU handle.
NVAPI_NOT_SUPPORTED | For the above mentioned GPUs
NvAPI_GPU_SetIllumination ( NV_GPU_SET_ILLUMINATION_PARM * pIlluminationInfo )

DESCRIPTION: This function sets the value of the specified illumination attribute.

Note:
Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You should enumerate thru the GPUs with the NvAPI_GPU_QueryIlluminationSupport call to determine which GPU is managing the attribute.

SUPPORTED OS: Windows Vista and higher

Since:
Version: 300.05
Parameters:
[in] | hPhysicalGpu | Physical GPU handle
Attribute | An enumeration value specifying the Illumination attribute to be set
Value | The new value for the specified attribute. This should be specified as a percentage of the full range of the attribute (0-100; 0 = off, 100 = full brightness) If a value is specified outside this range, NVAPI_INVALID_ARGUMENT will be returned.
Returns:
See NvAPI Status Values for the list of possible return values. Return values of special interest are: NVAPI_INVALID_ARGUMENT The specified attibute is not known to the driver, or the specified value is out of range. NVAPI_NOT_SUPPORTED The specified attribute is not supported on the specified GPU.
NVAPI_INTERFACE NvAPI_GPU_SetScanoutCompositionParameter | ( | NvU32 | displayId,
 |  | NV_GPU_SCANOUT_COMPOSITION_PARAMETER | parameter,
 |  | NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE | parameterValue,
 |  | float * | pContainer
 | ) |  |

DESCRIPTION: This API sets various parameters that configure the scanout composition feature on the specified display. (currently there is only one configurable parameter defined: WARPING_RESAMPLING_METHOD, but this function is designed to support the addition of parameters as needed.)

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | displayId | Combined physical display and GPU identifier of the display to apply the intensity control
[in] | parameter | The scanout composition parameter to be set
[in] | parameterValue | The data to be set for the specified parameter
[in] | pContainer | Additional container for data associated with the specified parameter
Return values:
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs
NVAPI_INVALID_ARGUMENT | Invalid input data.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_GPU_SetScanoutIntensity | ( | NvU32 | displayId,
 |  | NV_SCANOUT_INTENSITY_DATA * | scanoutIntensityData,
 |  | int * | pbSticky
 | ) |  |

DESCRIPTION: This API enables and sets up per-pixel intensity feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | displayId | combined physical display and GPU identifier of the display to apply the intensity control.
[in] | scanoutIntensityData | the intensity texture info.
[out] | pbSticky(OUT) | indicates whether the settings will be kept over a reboot.
Return values:
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs
NVAPI_INVALID_ARGUMENT | Invalid input data.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_SCANOUT_INTENSITY_DATA structure version mismatch.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_GPU_SetScanoutWarping | ( | NvU32 | displayId,
 |  | NV_SCANOUT_WARPING_DATA * | scanoutWarpingData,
 |  | int * | piMaxNumVertices,
 |  | int * | pbSticky
 | ) |  |

DESCRIPTION: This API enables and sets up the warping feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | displayId | Combined physical display and GPU identifier of the display to apply the intensity control
[in] | scanoutWarpingData | The warping data info
[out] | pbSticky | Indicates whether the settings will be kept over a reboot.
Return values:
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs
NVAPI_INVALID_ARGUMENT | Invalid input data.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_SCANOUT_WARPING_DATA structure version mismatch.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_GPU_ValidateOutputCombination | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | outputsMask
 | ) |  |

This function determines if a set of GPU outputs can be active simultaneously. While a GPU may have <n> outputs, typically they cannot all be active at the same time due to internal resource sharing.

Given a physical GPU handle and a mask of candidate outputs, this call will return NVAPI_OK if all of the specified outputs can be driven simultaneously. It will return NVAPI_INVALID_COMBINATION if they cannot.

Use NvAPI_GPU_GetAllOutputs() to determine which outputs are candidates.

SUPPORTED OS: Windows XP and higher

Since:
Release: 85
Return values:
NVAPI_OK | Combination of outputs in outputsMask are valid (can be active simultaneously).
NVAPI_INVALID_COMBINATION | Combination of outputs in outputsMask are NOT valid.
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or outputsMask does not have at least 2 bits set.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_INTERFACE NvAPI_GPU_WorkstationFeatureQuery | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __out_opt NvU32 * | pConfiguredFeatureMask,
 |  | __out_opt NvU32 * | pConsistentFeatureMask
 | ) |  |

DESCRIPTION: This API queries the current set of workstation features.

SUPPORTED OS: Windows 7

Parameters:
[in] | hPhysicalGpu | Physical GPU Handle of the display adapter to be configured. GPU handles may be retrieved using NvAPI_EnumPhysicalGPUs.
[out] | pConfiguredFeatureMask | Mask of features requested for use by client drivers
[out] | pConsistentFeatureMask | Mask of features that have all resources allocated for completeness.
Return values:
NVAPI_OK | configuration request succeeded
NVAPI_ERROR | configuration request failed
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu is not a physical GPU handle.
NVAPI_NO_IMPLEMENTATION | only implemented for Win7
NVAPI_INTERFACE NvAPI_GPU_WorkstationFeatureSetup | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __in NvU32 | featureEnableMask,
 |  | __in NvU32 | featureDisableMask
 | ) |  |


Data Structures | Defines | Typedefs | Enumerations | Functions
GPU Thermal Control Interface
GPU APIs

Data Structures

struct | NV_GPU_THERMAL_SETTINGS_V1
struct | NV_GPU_THERMAL_SETTINGS_V2

Defines

#define | NVAPI_MAX_THERMAL_SENSORS_PER_GPU 3

Typedefs

typedef NV_GPU_THERMAL_SETTINGS_V2 | NV_GPU_THERMAL_SETTINGS

Enumerations

enum NV_THERMAL_TARGET {
NVAPI_THERMAL_TARGET_NONE = 0, NVAPI_THERMAL_TARGET_GPU = 1, NVAPI_THERMAL_TARGET_MEMORY = 2, NVAPI_THERMAL_TARGET_POWER_SUPPLY = 4,
NVAPI_THERMAL_TARGET_BOARD = 8, NVAPI_THERMAL_TARGET_VCD_BOARD = 9, NVAPI_THERMAL_TARGET_VCD_INLET = 10, NVAPI_THERMAL_TARGET_VCD_OUTLET = 11,
NVAPI_THERMAL_TARGET_ALL = 15, NVAPI_THERMAL_TARGET_UNKNOWN = -1
}
enum NV_THERMAL_CONTROLLER {
NVAPI_THERMAL_CONTROLLER_NONE = 0, NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL, NVAPI_THERMAL_CONTROLLER_ADM1032, NVAPI_THERMAL_CONTROLLER_MAX6649,
NVAPI_THERMAL_CONTROLLER_MAX1617, NVAPI_THERMAL_CONTROLLER_LM99, NVAPI_THERMAL_CONTROLLER_LM89, NVAPI_THERMAL_CONTROLLER_LM64,
NVAPI_THERMAL_CONTROLLER_ADT7473, NVAPI_THERMAL_CONTROLLER_SBMAX6649, NVAPI_THERMAL_CONTROLLER_VBIOSEVT, NVAPI_THERMAL_CONTROLLER_OS,
NVAPI_THERMAL_CONTROLLER_UNKNOWN = -1
}

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetThermalSettings (NvPhysicalGpuHandle hPhysicalGpu, NvU32 sensorIndex, NV_GPU_THERMAL_SETTINGS *pThermalSettings)
#define | NV_GPU_THERMAL_SETTINGS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V1,1)
#define | NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)
#define | NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Detailed Description

The GPU thermal control APIs are used to get temperature levels from the various thermal sensors associated with the GPU.

Define Documentation

#define NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS.

#define NV_GPU_THERMAL_SETTINGS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V1,1)

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS_V1.

#define NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS_V2.

#define NVAPI_MAX_THERMAL_SENSORS_PER_GPU 3

Typedef Documentation

typedef NV_GPU_THERMAL_SETTINGS_V2 NV_GPU_THERMAL_SETTINGS

Enumeration Type Documentation

enum NV_THERMAL_CONTROLLER

Used in NV_GPU_THERMAL_SETTINGS

Enumerator:
NVAPI_THERMAL_CONTROLLER_NONE
NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL
NVAPI_THERMAL_CONTROLLER_ADM1032
NVAPI_THERMAL_CONTROLLER_MAX6649
NVAPI_THERMAL_CONTROLLER_MAX1617
NVAPI_THERMAL_CONTROLLER_LM99
NVAPI_THERMAL_CONTROLLER_LM89
NVAPI_THERMAL_CONTROLLER_LM64
NVAPI_THERMAL_CONTROLLER_ADT7473
NVAPI_THERMAL_CONTROLLER_SBMAX6649
NVAPI_THERMAL_CONTROLLER_VBIOSEVT
NVAPI_THERMAL_CONTROLLER_OS
NVAPI_THERMAL_CONTROLLER_UNKNOWN
enum NV_THERMAL_TARGET

Used in NV_GPU_THERMAL_SETTINGS

Enumerator:
NVAPI_THERMAL_TARGET_NONE
NVAPI_THERMAL_TARGET_GPU

GPU core temperature requires NvPhysicalGpuHandle.

NVAPI_THERMAL_TARGET_MEMORY

GPU memory temperature requires NvPhysicalGpuHandle.

NVAPI_THERMAL_TARGET_POWER_SUPPLY

GPU power supply temperature requires NvPhysicalGpuHandle.

NVAPI_THERMAL_TARGET_BOARD

GPU board ambient temperature requires NvPhysicalGpuHandle.

NVAPI_THERMAL_TARGET_VCD_BOARD

Visual Computing Device Board temperature requires NvVisualComputingDeviceHandle.

NVAPI_THERMAL_TARGET_VCD_INLET

Visual Computing Device Inlet temperature requires NvVisualComputingDeviceHandle.

NVAPI_THERMAL_TARGET_VCD_OUTLET

Visual Computing Device Outlet temperature requires NvVisualComputingDeviceHandle.

NVAPI_THERMAL_TARGET_ALL
NVAPI_THERMAL_TARGET_UNKNOWN

Function Documentation

NVAPI_INTERFACE NvAPI_GPU_GetThermalSettings | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | sensorIndex,
 |  | NV_GPU_THERMAL_SETTINGS * | pThermalSettings
 | ) |  |

This function retrieves the thermal information of all thermal sensors or specific thermal sensor associated with the selected GPU. Thermal sensors are indexed 0 to NVAPI_MAX_THERMAL_SENSORS_PER_GPU-1.

  • To retrieve specific thermal sensor info, set the sensorIndex to the required thermal sensor index.
  • To retrieve info for all sensors, set sensorIndex to NVAPI_THERMAL_TARGET_ALL.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Since:
Release: 85
Parameters:
[in] | hPhysicalGPU | GPU selection.
[in] | sensorIndex | Explicit thermal sensor index selection.
[out] | pThermalSettings | Array of thermal settings.
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INVALID_ARGUMENT | pThermalInfo is NULL.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the INFO struct is not supported.


Data Structures | Defines | Typedefs | Enumerations | Functions
GPU Performance State Interface
GPU APIs

Data Structures

struct | NV_GPU_PERF_PSTATES_INFO_V1
struct | NV_GPU_PERF_PSTATES_INFO_V2
struct | NV_GPU_PERF_PSTATES20_PARAM_DELTA
Used to describe both voltage and frequency deltas. More...
struct | NV_GPU_PSTATE20_CLOCK_ENTRY_V1
Used to describe single clock entry. More...
struct | NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
Used to describe single base voltage entry. More...
struct | NV_GPU_PERF_PSTATES20_INFO_V1
Used in NvAPI_GPU_GetPstates20() interface call. More...
struct | _NV_GPU_PERF_PSTATES20_INFO_V2
Used in NvAPI_GPU_GetPstates20() interface call. More...
struct | NV_GPU_DYNAMIC_PSTATES_INFO_EX

Defines

#define | NVAPI_MAX_GPU_PSTATE20_PSTATES 16
#define | NVAPI_MAX_GPU_PSTATE20_CLOCKS 8
#define | NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES 4
#define | NV_GPU_PERF_PSTATES20_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES20_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES20_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES20_INFO_VER NV_GPU_PERF_PSTATES20_INFO_VER3
#define | NVAPI_MAX_GPU_UTILIZATIONS 8
#define | NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER MAKE_NVAPI_VERSION(NV_GPU_DYNAMIC_PSTATES_INFO_EX,1)

Typedefs

typedef enum _NV_GPU_PERF_PSTATE_ID | NV_GPU_PERF_PSTATE_ID
typedef NV_GPU_PERF_PSTATES_INFO_V2 | NV_GPU_PERF_PSTATES_INFO
typedef struct
_NV_GPU_PERF_PSTATES20_INFO_V2 		NV_GPU_PERF_PSTATES20_INFO_V2
typedef
NV_GPU_PERF_PSTATES20_INFO_V2 		NV_GPU_PERF_PSTATES20_INFO

Enumerations

enum _NV_GPU_PERF_PSTATE_ID {
NVAPI_GPU_PERF_PSTATE_P0 = 0, NVAPI_GPU_PERF_PSTATE_P1, NVAPI_GPU_PERF_PSTATE_P2, NVAPI_GPU_PERF_PSTATE_P3,
NVAPI_GPU_PERF_PSTATE_P4, NVAPI_GPU_PERF_PSTATE_P5, NVAPI_GPU_PERF_PSTATE_P6, NVAPI_GPU_PERF_PSTATE_P7,
NVAPI_GPU_PERF_PSTATE_P8, NVAPI_GPU_PERF_PSTATE_P9, NVAPI_GPU_PERF_PSTATE_P10, NVAPI_GPU_PERF_PSTATE_P11,
NVAPI_GPU_PERF_PSTATE_P12, NVAPI_GPU_PERF_PSTATE_P13, NVAPI_GPU_PERF_PSTATE_P14, NVAPI_GPU_PERF_PSTATE_P15,
NVAPI_GPU_PERF_PSTATE_UNDEFINED = NVAPI_MAX_GPU_PERF_PSTATES, NVAPI_GPU_PERF_PSTATE_ALL
}
enum | NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID { NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE = 0, NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE }

Functions

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 304. Instead, use NvAPI_GPU_GetPstates20.") NVAPI_INTERFACE NvAPI_GPU_GetPstatesInfoEx(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetPstates20 (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_PERF_PSTATES20_INFO *pPstatesInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPstate (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_PERF_PSTATE_ID *pCurrentPstate)
NVAPI_INTERFACE | NvAPI_GPU_GetDynamicPstatesInfoEx (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_DYNAMIC_PSTATES_INFO_EX *pDynamicPstatesInfoEx)
#define | NV_GPU_PERF_PSTATES_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3

Detailed Description

The GPU performance state APIs are used to get and set various performance levels on a per-GPU basis. P-States are GPU active/executing performance capability and power consumption states.

P-States range from P0 to P15, with P0 being the highest performance/power state, and P15 being the lowest performance/power state. Each P-State maps to a performance level. Not all P-States are available on a given system. The definition of each P-States are currently as follows:

  • P0/P1 - Maximum 3D performance
  • P2/P3 - Balanced 3D performance-power
  • P8 - Basic HD video playback
  • P10 - DVD playback
  • P12 - Minimum idle power consumption

Define Documentation

#define NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER MAKE_NVAPI_VERSION(NV_GPU_DYNAMIC_PSTATES_INFO_EX,1)

Macro for constructing the version field of NV_GPU_DYNAMIC_PSTATES_INFO_EX

#define NV_GPU_PERF_PSTATES20_INFO_VER NV_GPU_PERF_PSTATES20_INFO_VER3

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO.

#define NV_GPU_PERF_PSTATES20_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V1,1)

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO_V1.

#define NV_GPU_PERF_PSTATES20_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,2)

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO_V2.

#define NV_GPU_PERF_PSTATES20_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,3)

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO_V2.

#define NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO.

#define NV_GPU_PERF_PSTATES_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V1,1)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V1.

#define NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V2.

#define NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V2.

#define NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES 4
#define NVAPI_MAX_GPU_PSTATE20_CLOCKS 8
#define NVAPI_MAX_GPU_PSTATE20_PSTATES 16
#define NVAPI_MAX_GPU_UTILIZATIONS 8

Typedef Documentation

typedef enum _NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATE_ID
typedef NV_GPU_PERF_PSTATES20_INFO_V2 NV_GPU_PERF_PSTATES20_INFO
typedef struct _NV_GPU_PERF_PSTATES20_INFO_V2 NV_GPU_PERF_PSTATES20_INFO_V2

Used in NvAPI_GPU_GetPstates20() interface call.

typedef NV_GPU_PERF_PSTATES_INFO_V2 NV_GPU_PERF_PSTATES_INFO

Enumeration Type Documentation

enum _NV_GPU_PERF_PSTATE_ID
Enumerator:
NVAPI_GPU_PERF_PSTATE_P0
NVAPI_GPU_PERF_PSTATE_P1
NVAPI_GPU_PERF_PSTATE_P2
NVAPI_GPU_PERF_PSTATE_P3
NVAPI_GPU_PERF_PSTATE_P4
NVAPI_GPU_PERF_PSTATE_P5
NVAPI_GPU_PERF_PSTATE_P6
NVAPI_GPU_PERF_PSTATE_P7
NVAPI_GPU_PERF_PSTATE_P8
NVAPI_GPU_PERF_PSTATE_P9
NVAPI_GPU_PERF_PSTATE_P10
NVAPI_GPU_PERF_PSTATE_P11
NVAPI_GPU_PERF_PSTATE_P12
NVAPI_GPU_PERF_PSTATE_P13
NVAPI_GPU_PERF_PSTATE_P14
NVAPI_GPU_PERF_PSTATE_P15
NVAPI_GPU_PERF_PSTATE_UNDEFINED
NVAPI_GPU_PERF_PSTATE_ALL
enum NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID

Used to identify clock type.

Enumerator:
NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE

Clock domains that use single frequency value within given pstate.

NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE

Clock domains that allow range of frequency values within given pstate.

Function Documentation

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 304. | Instead,
 |  | use NvAPI_GPU_GetPstates20." |
 | ) |  |

DESCRIPTION: This API retrieves all performance states (P-States) information. This is the same as NvAPI_GPU_GetPstatesInfo(), but supports an input flag for various options.

P-States are GPU active/executing performance capability and power consumption states.

P-States ranges from P0 to P15, with P0 being the highest performance/power state, and P15 being the lowest performance/power state. Each P-State, if available, maps to a performance level. Not all P-States are available on a given system. The definitions of each P-State are currently as follows:

  • P0/P1 - Maximum 3D performance
  • P2/P3 - Balanced 3D performance-power
  • P8 - Basic HD video playback
  • P10 - DVD playback
  • P12 - Minimum idle power consumption
Parameters:
[in] hPhysicalGPU GPU selection.
[out] pPerfPstatesInfo P-States information retrieved, as detailed below:
  • flags is reserved for future use.
  • numPstates is the number of available P-States
  • numClocks is the number of clock domains supported by each P-State
  • pstates has valid index range from 0 to numPstates - 1
  • pstates[i].pstateId is the ID of the P-State, containing the following info:
    • pstates[i].flags containing the following info:
      • bit 0 indicates if the PCIE limit is GEN1 or GEN2
      • bit 1 indicates if the Pstate is overclocked or not
      • bit 2 indicates if the Pstate is overclockable or not
    • pstates[i].clocks has valid index range from 0 to numClocks -1
    • pstates[i].clocks[j].domainId is the public ID of the clock domain, containing the following info:
      • pstates[i].clocks[j].flags containing the following info: bit 0 indicates if the clock domain is overclockable or not
      • pstates[i].clocks[j].freq is the clock frequency in kHz
    • pstates[i].voltages has a valid index range from 0 to numVoltages - 1
    • pstates[i].voltages[j].domainId is the ID of the voltage domain, containing the following info:
      • pstates[i].voltages[j].flags is reserved for future use.
      • pstates[i].voltages[j].mvolt is the voltage in mV inputFlags(IN) - This can be used to select various options:
    • if bit 0 is set, pPerfPstatesInfo would contain the default settings instead of the current, possibily overclocked settings.
    • if bit 1 is set, pPerfPstatesInfo would contain the maximum clock frequencies instead of the nominal frequencies.
    • if bit 2 is set, pPerfPstatesInfo would contain the minimum clock frequencies instead of the nominal frequencies.
    • all other bits must be set to 0.
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide)
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the NV_GPU_PERF_PSTATES struct is not supported
NVAPI_INTERFACE NvAPI_GPU_GetCurrentPstate | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_PERF_PSTATE_ID * | pCurrentPstate
 | ) |  |

DESCRIPTION: This function retrieves the current performance state (P-State).

SUPPORTED OS: Windows XP and higher

Since:
Release: 165

TCC_SUPPORTED

Parameters:
[in] | hPhysicalGPU | GPU selection
[out] | pCurrentPstate | The ID of the current P-State of the GPU - see NV_GPU_PERF_PSTATES.
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_NOT_SUPPORTED | P-States is not supported on this setup.
NVAPI_INTERFACE NvAPI_GPU_GetDynamicPstatesInfoEx | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_DYNAMIC_PSTATES_INFO_EX * | pDynamicPstatesInfoEx
 | ) |  |

DESCRIPTION: This API retrieves the NV_GPU_DYNAMIC_PSTATES_INFO_EX structure for the specified physical GPU. Each domain's info is indexed in the array. For example:

  • pDynamicPstatesInfo->utilization[NVAPI_GPU_UTILIZATION_DOMAIN_GPU] holds the info for the GPU domain. There are currently 4 domains for which GPU utilization and dynamic P-State thresholds can be retrieved: graphic engine (GPU), frame buffer (FB), video engine (VID), and bus interface (BUS).

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Return values:
NVAPI_OK
NVAPI_ERROR
NVAPI_INVALID_ARGUMENT | pDynamicPstatesInfo is NULL
NVAPI_HANDLE_INVALIDATED
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the INFO struct is not supported
NVAPI_INTERFACE NvAPI_GPU_GetPstates20 | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_PERF_PSTATES20_INFO * | pPstatesInfo
 | ) |  |

DESCRIPTION: This API retrieves all performance states (P-States) 2.0 information.

P-States are GPU active/executing performance capability states. They range from P0 to P15, with P0 being the highest performance state, and P15 being the lowest performance state. Each P-State, if available, maps to a performance level. Not all P-States are available on a given system. The definition of each P-States are currently as follow:

  • P0/P1 - Maximum 3D performance
  • P2/P3 - Balanced 3D performance-power
  • P8 - Basic HD video playback
  • P10 - DVD playback
  • P12 - Minimum idle power consumption

TCC_SUPPORTED

Since:
Release: 295

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hPhysicalGPU | GPU selection
[out] | pPstatesInfo | P-States information retrieved, as documented in declaration above
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.


Data Structures | Defines | Typedefs | Enumerations | Functions
GPU Clock Control Interface
GPU APIs

Data Structures

struct | NV_GPU_CLOCK_FREQUENCIES_V1
struct | NV_GPU_CLOCK_FREQUENCIES_V2

Defines

#define | NV_GPU_CLOCK_FREQUENCIES_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V1,1)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_2 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,2)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_3 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,3)
#define | NV_GPU_CLOCK_FREQUENCIES_VER NV_GPU_CLOCK_FREQUENCIES_VER_3

Typedefs

typedef enum
_NV_GPU_PUBLIC_CLOCK_ID 		NV_GPU_PUBLIC_CLOCK_ID
typedef enum
_NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID 		NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID
typedef NV_GPU_CLOCK_FREQUENCIES_V2 | NV_GPU_CLOCK_FREQUENCIES

Enumerations

enum _NV_GPU_PUBLIC_CLOCK_ID {
NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS = 0, NVAPI_GPU_PUBLIC_CLOCK_MEMORY = 4, NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR = 7, NVAPI_GPU_PUBLIC_CLOCK_VIDEO = 8,
NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED = NVAPI_MAX_GPU_PUBLIC_CLOCKS
}
enum | _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID { NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE = 0, NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED = NVAPI_MAX_GPU_PERF_VOLTAGES }
enum | NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE { NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ = 0, NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK = 1, NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK = 2, NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM = 3 }

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetAllClockFrequencies (__in NvPhysicalGpuHandle hPhysicalGPU, __inout NV_GPU_CLOCK_FREQUENCIES *pClkFreqs)
#define | NVAPI_MAX_GPU_CLOCKS 32
#define | NVAPI_MAX_GPU_PUBLIC_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_VOLTAGES 16
#define | NVAPI_MAX_GPU_PERF_PSTATES 16

Detailed Description

The GPU clock control APIs are used to get and set individual clock domains on a per-GPU basis.

Define Documentation

#define NV_GPU_CLOCK_FREQUENCIES_VER NV_GPU_CLOCK_FREQUENCIES_VER_3
#define NV_GPU_CLOCK_FREQUENCIES_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V1,1)
#define NV_GPU_CLOCK_FREQUENCIES_VER_2 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,2)
#define NV_GPU_CLOCK_FREQUENCIES_VER_3 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,3)
#define NVAPI_MAX_GPU_CLOCKS 32
#define NVAPI_MAX_GPU_PERF_CLOCKS 32
#define NVAPI_MAX_GPU_PERF_PSTATES 16
#define NVAPI_MAX_GPU_PERF_VOLTAGES 16
#define NVAPI_MAX_GPU_PUBLIC_CLOCKS 32

Typedef Documentation

typedef NV_GPU_CLOCK_FREQUENCIES_V2 NV_GPU_CLOCK_FREQUENCIES

Used in NvAPI_GPU_GetAllClockFrequencies()

typedef enum _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID
typedef enum _NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PUBLIC_CLOCK_ID

Enumeration Type Documentation

enum _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID
Enumerator:
NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE
NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED
enum _NV_GPU_PUBLIC_CLOCK_ID
Enumerator:
NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS
NVAPI_GPU_PUBLIC_CLOCK_MEMORY
NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR
NVAPI_GPU_PUBLIC_CLOCK_VIDEO
NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED
enum NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE

Used in NvAPI_GPU_GetAllClockFrequencies()

Enumerator:
NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ
NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK
NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK
NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM

Function Documentation

NVAPI_INTERFACE NvAPI_GPU_GetAllClockFrequencies | ( | __in NvPhysicalGpuHandle | hPhysicalGPU,
 |  | __inout NV_GPU_CLOCK_FREQUENCIES * | pClkFreqs
 | ) |  |

This function retrieves the NV_GPU_CLOCK_FREQUENCIES structure for the specified physical GPU.

For each clock domain:

  • bIsPresent is set for each domain that is present on the GPU
  • frequency is the domain's clock freq in kHz

Each domain's info is indexed in the array. For example: clkFreqs.domain[NVAPI_GPU_PUBLIC_CLOCK_MEMORY] holds the info for the MEMORY domain.

SUPPORTED OS: Windows XP and higher

Since:
Release: 295
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT pClkFreqs is NULL.


Functions
GPU Cooler Interface
GPU APIs

Functions

NVAPI_INTERFACE NvAPI_GPU_GetTachReading (NvPhysicalGpuHandle hPhysicalGPU, NvU32 *pValue)

Detailed Description

The GPU cooler APIs are used to get and set the fan level or equivalent cooler levels for various target devices associated with the GPU.

Function Documentation

NVAPI_INTERFACE NvAPI_GPU_GetTachReading | ( | NvPhysicalGpuHandle | hPhysicalGPU,
 |  | NvU32 * | pValue
 | ) |  |

DESCRIPTION: This API retrieves the fan speed tachometer reading for the specified physical GPU.

HOW TO USE:

  • NvU32 Value = 0;
  • ret = NvAPI_GPU_GetTachReading(hPhysicalGpu, &Value);
  • On call success:
  • Value contains the tachometer reading

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Parameters:
[in] | hPhysicalGpu | GPU selection.
[out] | pValue | Pointer to a variable to get the tachometer reading
Return values:
NVAPI_OK | - completed request
NVAPI_ERROR | - miscellaneous error occurred
NVAPI_NOT_SUPPORTED | - functionality not supported
NVAPI_API_NOT_INTIALIZED | - nvapi not initialized
NVAPI_INVALID_ARGUMENT | - invalid argument passed
NVAPI_HANDLE_INVALIDATED | - handle passed has been invalidated (see user guide)
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | - handle passed is not a physical GPU handle


Data Structures | Defines | Functions
GPU ECC Interface
GPU APIs

Data Structures

struct | NV_GPU_ECC_STATUS_INFO
struct | NV_GPU_ECC_ERROR_INFO
struct | NV_GPU_ECC_CONFIGURATION_INFO

Defines

#define | NV_GPU_ECC_STATUS_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_STATUS_INFO,1)
#define | NV_GPU_ECC_ERROR_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_ERROR_INFO,1)
#define | NV_GPU_ECC_CONFIGURATION_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_CONFIGURATION_INFO,1)

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetECCStatusInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_STATUS_INFO *pECCStatusInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_ERROR_INFO *pECCErrorInfo)
NVAPI_INTERFACE | NvAPI_GPU_ResetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bResetCurrent, NvU8 bResetAggregate)
NVAPI_INTERFACE | NvAPI_GPU_GetECCConfigurationInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_CONFIGURATION_INFO *pECCConfigurationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetECCConfiguration (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bEnable, NvU8 bEnableImmediately)

Detailed Description

The GPU ECC APIs are used to configure ECC-capable GPUs.

Used in NV_GPU_ECC_STATUS_INFO.

Define Documentation

#define NV_GPU_ECC_CONFIGURATION_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_CONFIGURATION_INFO,1)

Macro for consstructing the verion field of NV_GPU_ECC_CONFIGURATION_INFO

#define NV_GPU_ECC_ERROR_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_ERROR_INFO,1)

Macro for constructing the version field of NV_GPU_ECC_ERROR_INFO

#define NV_GPU_ECC_STATUS_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_STATUS_INFO,1)

Macro for constructing the version field of NV_GPU_ECC_STATUS_INFO

Function Documentation

NvAPI_GPU_GetECCConfigurationInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_ECC_CONFIGURATION_INFO * | pECCConfigurationInfo
 | ) |  |

DESCRIPTION: This function returns ECC memory configuration information.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Parameters:
[in] | hPhysicalGpu | A handle identifying the physical GPU for which ECC configuration information is to be retrieved.
[out] | pECCConfigurationInfo | A pointer to an ECC configuration structure.
Return values:
NVAPI_OK | The request was completed successfully.
NVAPI_ERROR | An unknown error occurred.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | The provided GPU handle is not a physical GPU handle.
NVAPI_INVALID_HANDLE | The provided GPU handle is invalid.
NVAPI_HANDLE_INVALIDATED | The provided GPU handle is no longer valid.
NVAPI_INVALID_POINTER | An invalid argument pointer was provided.
NVAPI_NOT_SUPPORTED | The request is not supported.
NVAPI_API_NOT_INTIALIZED | NvAPI was not yet initialized.
NvAPI_GPU_GetECCErrorInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_ECC_ERROR_INFO * | pECCErrorInfo
 | ) |  |

DESCRIPTION: This function returns ECC memory error information.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Parameters:
[in] | hPhysicalGpu | A handle identifying the physical GPU for which ECC error information is to be retrieved.
[out] | pECCErrorInfo | A pointer to an ECC error structure.
Return values:
NVAPI_OK | The request was completed successfully.
NVAPI_ERROR | An unknown error occurred.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | The provided GPU handle is not a physical GPU handle.
NVAPI_INVALID_ARGUMENT | incorrect param value
NVAPI_INVALID_POINTER | An invalid argument pointer was provided.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | structure version is not supported, initialize to NV_GPU_ECC_ERROR_INFO_VER.
NVAPI_HANDLE_INVALIDATED | The provided GPU handle is no longer valid.
NVAPI_NOT_SUPPORTED | The request is not supported.
NVAPI_API_NOT_INTIALIZED | NvAPI was not yet initialized.
NvAPI_GPU_GetECCStatusInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_ECC_STATUS_INFO * | pECCStatusInfo
 | ) |  |

DESCRIPTION: This function returns ECC memory status information.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Parameters:
[in] | hPhysicalGpu | A handle identifying the physical GPU for which ECC status information is to be retrieved.
[out] | pECCStatusInfo | A pointer to an ECC status structure.
Return values:
NVAPI_OK | The request was completed successfully.
NVAPI_ERROR | An unknown error occurred.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | The provided GPU handle is not a physical GPU handle.
NVAPI_INVALID_HANDLE | The provided GPU handle is invalid.
NVAPI_HANDLE_INVALIDATED | The provided GPU handle is no longer valid.
NVAPI_INVALID_POINTER | An invalid argument pointer was provided.
NVAPI_NOT_SUPPORTED | The request is not supported.
NVAPI_API_NOT_INTIALIZED | NvAPI was not yet initialized.
NVAPI_INTERFACE NvAPI_GPU_ResetECCErrorInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU8 | bResetCurrent,
 |  | NvU8 | bResetAggregate
 | ) |  |

DESCRIPTION: This function resets ECC memory error counters.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Parameters:
[in] | hPhysicalGpu | A handle identifying the physical GPU for which ECC error information is to be cleared.
[in] | bResetCurrent | Reset the current ECC error counters.
[in] | bResetAggregate | Reset the aggregate ECC error counters.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_USER_PRIVILEGE - The caller does not have administrative privileges
NVAPI_INTERFACE NvAPI_GPU_SetECCConfiguration | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU8 | bEnable,
 |  | NvU8 | bEnableImmediately
 | ) |  |

DESCRIPTION: This function updates the ECC memory configuration setting.

SUPPORTED OS: Windows XP and higher

TCC_SUPPORTED

Parameters:
[in] | hPhysicalGpu | A handle identifying the physical GPU for which to update the ECC configuration setting.
[in] | bEnable | The new ECC configuration setting.
[in] | bEnableImmediately | Request that the new setting take effect immediately.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_CONFIGURATION | - Possibly SLI is enabled. Disable SLI and retry.
NVAPI_INVALID_USER_PRIVILEGE | - The caller does not have administrative privileges


Modules
Video APIs

Modules

Video Input/Output Interface

Detailed Description

NVIDIA
Copyright (c) 2007-2016 NVIDIA Corporation. All rights reserved.


Typedefs
Video Input/Output Interface
Video APIs

Typedefs

typedef NvU32 | NVVIOOWNERID
enum | _NVVIOOWNERTYPE { NVVIOOWNERTYPE_NONE, NVVIOOWNERTYPE_APPLICATION, NVVIOOWNERTYPE_DESKTOP }
typedef enum _NVVIOOWNERTYPE | NVVIOOWNERTYPE
#define | NVVIOOWNERID_NONE 0
#define | NVVIO_O_READ 0x00000000
#define | NVVIO_O_WRITE_EXCLUSIVE 0x00010001
#define | NVVIO_VALID_ACCESSRIGHTS
#define | NVVIO_OWNERID_INITIALIZED 0x80000000
#define | NVVIO_OWNERID_EXCLUSIVE 0x40000000
#define | NVVIO_OWNERID_TYPEMASK 0x0FFFFFFF
enum _NVVIOSIGNALFORMAT {
NVVIOSIGNALFORMAT_NONE, NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC, NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL, NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260,
NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260, NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295, NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274, NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274,
NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274, NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274, NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274, NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274, NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274, NVVIOSIGNALFORMAT_720P_60_00_SMPTE296, NVVIOSIGNALFORMAT_720P_59_94_SMPTE296,
NVVIOSIGNALFORMAT_720P_50_00_SMPTE296, NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274, NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274, NVVIOSIGNALFORMAT_720P_30_00_SMPTE296,
NVVIOSIGNALFORMAT_720P_29_97_SMPTE296, NVVIOSIGNALFORMAT_720P_25_00_SMPTE296, NVVIOSIGNALFORMAT_720P_24_00_SMPTE296, NVVIOSIGNALFORMAT_720P_23_98_SMPTE296,
NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372, NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372, NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372, NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372,
NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372, NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372, NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372, NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372,
NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372, NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372, NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274, NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274,
NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274, NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274, NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274, NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A, NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A, NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B,
NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B,
NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B,
NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B,
NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_END
}
typedef enum _NVVIOSIGNALFORMAT | NVVIOSIGNALFORMAT
typedef struct _NVVIOCAPS | NVVIOCAPS
typedef struct _NVVIOCHANNELSTATUS | NVVIOCHANNELSTATUS
typedef struct _NVVIOINPUTSTATUS | NVVIOINPUTSTATUS
typedef struct _NVVIOOUTPUTSTATUS | NVVIOOUTPUTSTATUS
typedef struct _NVVIOSTATUS | NVVIOSTATUS
typedef struct _NVVIOOUTPUTREGION | NVVIOOUTPUTREGION
typedef struct _NVVIOGAMMARAMP8 | NVVIOGAMMARAMP8
typedef struct _NVVIOGAMMARAMP10 | NVVIOGAMMARAMP10
typedef struct _NVVIOSYNCDELAY | NVVIOSYNCDELAY
typedef struct _NVVIOVIDEOMODE | NVVIOVIDEOMODE
typedef struct
_NVVIOSIGNALFORMATDETAIL 		NVVIOSIGNALFORMATDETAIL
typedef struct
_NVVIODATAFORMATDETAIL 		NVVIODATAFORMATDETAIL
typedef struct
_NVVIOCOLORCONVERSION 		NVVIOCOLORCONVERSION
typedef struct
_NVVIOGAMMACORRECTION 		NVVIOGAMMACORRECTION
typedef struct _NVVIOCOMPOSITERANGE | NVVIOCOMPOSITERANGE
typedef struct
_NVVIOOUTPUTCONFIG_V1 		NVVIOOUTPUTCONFIG_V1
typedef struct
_NVVIOOUTPUTCONFIG_V2 		NVVIOOUTPUTCONFIG_V2
typedef struct
_NVVIOOUTPUTCONFIG_V3 		NVVIOOUTPUTCONFIG_V3
typedef struct _NVVIOSTREAM | NVVIOSTREAM
typedef struct _NVVIOINPUTCONFIG | NVVIOINPUTCONFIG
typedef struct _NVVIOCONFIG_V1 | NVVIOCONFIG_V1
typedef struct _NVVIOCONFIG_V2 | NVVIOCONFIG_V2
typedef struct _NVVIOCONFIG_V3 | NVVIOCONFIG_V3
typedef NVVIOOUTPUTCONFIG_V3 | NVVIOOUTPUTCONFIG
typedef NVVIOCONFIG_V3 | NVVIOCONFIG
typedef struct _NV_VIO_TOPOLOGY | NV_VIO_TOPOLOGY
typedef struct _NV_VIO_TOPOLOGY | NVVIOTOPOLOGY
#define | NVVIOCAPS_VIDOUT_SDI 0x00000001
#define | NVVIOCAPS_SYNC_INTERNAL 0x00000100
#define | NVVIOCAPS_SYNC_GENLOCK 0x00000200
#define | NVVIOCAPS_SYNCSRC_SDI 0x00001000
#define | NVVIOCAPS_SYNCSRC_COMP 0x00002000
#define | NVVIOCAPS_OUTPUTMODE_DESKTOP 0x00010000
#define | NVVIOCAPS_OUTPUTMODE_OPENGL 0x00020000
#define | NVVIOCAPS_VIDIN_SDI 0x00100000
#define | NVVIOCAPS_PACKED_ANC_SUPPORTED 0x00200000
#define | NVVIOCAPS_AUDIO_BLANKING_SUPPORTED 0x00400000
#define | NVVIOCLASS_SDI 0x00000001
#define | NVVIOCAPS_VER1 MAKE_NVAPI_VERSION(NVVIOCAPS,1)
#define | NVVIOCAPS_VER2 MAKE_NVAPI_VERSION(NVVIOCAPS,2)
#define | NVVIOCAPS_VER NVVIOCAPS_VER2
#define | NVVIOSTATUS_VER MAKE_NVAPI_VERSION(NVVIOSTATUS,1)
#define | NVVIOSYNCDELAY_VER MAKE_NVAPI_VERSION(NVVIOSYNCDELAY,1)
#define | NVVIOBUFFERFORMAT_R8G8B8 0x00000001
#define | NVVIOBUFFERFORMAT_R8G8B8Z24 0x00000002
#define | NVVIOBUFFERFORMAT_R8G8B8A8 0x00000004
#define | NVVIOBUFFERFORMAT_R8G8B8A8Z24 0x00000008
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FP 0x00000010
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 0x00000020
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP 0x00000040
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 0x00000080
#define | NVVIOCOLORCONVERSION_VER MAKE_NVAPI_VERSION(NVVIOCOLORCONVERSION,1)
#define | NVVIOGAMMACORRECTION_VER MAKE_NVAPI_VERSION(NVVIOGAMMACORRECTION,1)
#define | MAX_NUM_COMPOSITE_RANGE 2
#define | NVVIOCONFIG_SIGNALFORMAT 0x00000001
#define | NVVIOCONFIG_DATAFORMAT 0x00000002
#define | NVVIOCONFIG_OUTPUTREGION 0x00000004
#define | NVVIOCONFIG_OUTPUTAREA 0x00000008
#define | NVVIOCONFIG_COLORCONVERSION 0x00000010
#define | NVVIOCONFIG_GAMMACORRECTION 0x00000020
#define | NVVIOCONFIG_SYNCSOURCEENABLE 0x00000040
#define | NVVIOCONFIG_SYNCDELAY 0x00000080
#define | NVVIOCONFIG_COMPOSITESYNCTYPE 0x00000100
#define | NVVIOCONFIG_FRAMELOCKENABLE 0x00000200
#define | NVVIOCONFIG_422FILTER 0x00000400
#define | NVVIOCONFIG_COMPOSITETERMINATE 0x00000800
#define | NVVIOCONFIG_DATAINTEGRITYCHECK 0x00001000
#define | NVVIOCONFIG_CSCOVERRIDE 0x00002000
#define | NVVIOCONFIG_FLIPQUEUELENGTH 0x00004000
#define | NVVIOCONFIG_ANCTIMECODEGENERATION 0x00008000
#define | NVVIOCONFIG_COMPOSITE 0x00010000
#define | NVVIOCONFIG_ALPHAKEYCOMPOSITE 0x00020000
#define | NVVIOCONFIG_COMPOSITE_Y 0x00040000
#define | NVVIOCONFIG_COMPOSITE_CR 0x00080000
#define | NVVIOCONFIG_COMPOSITE_CB 0x00100000
#define | NVVIOCONFIG_FULL_COLOR_RANGE 0x00200000
#define | NVVIOCONFIG_RGB_DATA 0x00400000
#define | NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE 0x00800000
#define | NVVIOCONFIG_STREAMS 0x01000000
#define | NVVIOCONFIG_ANC_PARITY_COMPUTATION 0x02000000
#define | NVVIOCONFIG_ANC_AUDIO_REPEAT 0x04000000
#define | NVVIOCONFIG_ALLFIELDS
#define | NVVIOCONFIG_VALIDFIELDS
#define | NVVIOCONFIG_DRIVERFIELDS
#define | NVVIOCONFIG_GAMMAFIELDS ( NVVIOCONFIG_GAMMACORRECTION )
#define | NVVIOCONFIG_RMCTRLFIELDS
#define | NVVIOCONFIG_RMSKEWFIELDS ( NVVIOCONFIG_SYNCDELAY )
#define | NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS
#define | NVVIOCONFIG_RMMODESET_FIELDS
#define | NVVIOCONFIG_VER1 MAKE_NVAPI_VERSION(NVVIOCONFIG_V1,1)
#define | NVVIOCONFIG_VER2 MAKE_NVAPI_VERSION(NVVIOCONFIG_V2,2)
#define | NVVIOCONFIG_VER3 MAKE_NVAPI_VERSION(NVVIOCONFIG_V3,3)
#define | NVVIOCONFIG_VER NVVIOCONFIG_VER3
#define | NV_VIO_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_VIO_TOPOLOGY,1)
#define | NVVIOTOPOLOGY_VER MAKE_NVAPI_VERSION(NVVIOTOPOLOGY,1)
NVAPI_INTERFACE | NvAPI_VIO_GetCapabilities (NvVioHandle hVioHandle, NVVIOCAPS *pAdapterCaps)
enum | _NVVIOPCILINKRATE { NVVIOPCILINKRATE_UNKNOWN = 0, NVVIOPCILINKRATE_GEN1 = 1, NVVIOPCILINKRATE_GEN2 = 2, NVVIOPCILINKRATE_GEN3 = 3 }
typedef enum _NVVIOPCILINKRATE | NVVIOPCILINKRATE
NVAPI_INTERFACE | NvAPI_VIO_GetPCIInfo (__in NvVioHandle hVioHandle, __inout NVVIOPCIINFO *pVioPCIInfo)
NVAPI_INTERFACE | NvAPI_VIO_IsRunning (NvVioHandle hVioHandle)
NVAPI_INTERFACE | NvAPI_VIO_Start (NvVioHandle hVioHandle)
NVAPI_INTERFACE | NvAPI_VIO_Stop (NvVioHandle hVioHandle)
NVAPI_INTERFACE | NvAPI_VIO_IsFrameLockModeCompatible (NvVioHandle hVioHandle, NvU32 srcEnumIndex, NvU32 destEnumIndex, NvU32 *pbCompatible)
NVAPI_INTERFACE | NvAPI_VIO_EnumDevices (NvVioHandle hVioHandle[NVAPI_MAX_VIO_DEVICES], NvU32 *vioDeviceCount)
NVAPI_INTERFACE | NvAPI_VIO_QueryTopology (NV_VIO_TOPOLOGY *pNvVIOTopology)
NVAPI_INTERFACE | NvAPI_VIO_EnumSignalFormats (NvVioHandle hVioHandle, NvU32 enumIndex, NVVIOSIGNALFORMATDETAIL *pSignalFormatDetail)
NVAPI_INTERFACE | NvAPI_VIO_EnumDataFormats (NvVioHandle hVioHandle, NvU32 enumIndex, NVVIODATAFORMATDETAIL *pDataFormatDetail)

Define Documentation

#define MAX_NUM_COMPOSITE_RANGE 2

Maximum number of ranges per channel.

#define NV_VIO_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_VIO_TOPOLOGY,1)

Macro for constructing the version field of NV_VIO_TOPOLOGY.

#define NVVIO_O_READ 0x00000000

Read access (not applicable for video output)

#define NVVIO_O_WRITE_EXCLUSIVE 0x00010001

Write exclusive access (not applicable for video input)

#define NVVIO_OWNERID_EXCLUSIVE 0x40000000

VIO_DATA.ulOwnerID next-bit is set only if device is currently in exclusive write access mode from NvAPI_VIO_Open()

#define NVVIO_OWNERID_INITIALIZED 0x80000000

VIO_DATA.ulOwnerID high-bit is set only if device has been initialized by VIOAPI examined at NvAPI_GetCapabilities|NvAPI_VIO_Open to determine if settings need to be applied from registry or POR state read

#define NVVIO_OWNERID_TYPEMASK 0x0FFFFFFF

mask for NVVIOOWNERTYPE_xxx

VIO_DATA.ulOwnerID lower bits are: NVGVOOWNERTYPE_xxx enumerations indicating use context

#define NVVIO_VALID_ACCESSRIGHTS
Value:
(NVVIO_O_READ              | \
                                             NVVIO_O_WRITE_EXCLUSIVE   )

Unregistered ownerId.

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FP 0x00000010

R16FP:G16FP:B16FP.

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP 0x00000040

R16FP:G16FP:B16FP:A16FP.

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 0x00000080

R16FP:G16FP:B16FP:A16FP:Z24.

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 0x00000020

R16FP:G16FP:B16FP:Z24.

#define NVVIOBUFFERFORMAT_R8G8B8 0x00000001

R8:G8:B8.

#define NVVIOBUFFERFORMAT_R8G8B8A8 0x00000004

R8:G8:B8:A8.

#define NVVIOBUFFERFORMAT_R8G8B8A8Z24 0x00000008

R8:G8:B8:A8:Z24.

#define NVVIOBUFFERFORMAT_R8G8B8Z24 0x00000002

R8:G8:B8:Z24.

#define NVVIOCAPS_AUDIO_BLANKING_SUPPORTED 0x00400000

Supports ANC audio blanking.

#define NVVIOCAPS_OUTPUTMODE_DESKTOP 0x00010000

Supports Desktop transparent mode.

#define NVVIOCAPS_OUTPUTMODE_OPENGL 0x00020000

Supports OpenGL application mode.

#define NVVIOCAPS_PACKED_ANC_SUPPORTED 0x00200000

Supports Packed ANC.

#define NVVIOCAPS_SYNC_GENLOCK 0x00000200

Supports Genlock timing source.

#define NVVIOCAPS_SYNC_INTERNAL 0x00000100

Supports Internal timing source.

#define NVVIOCAPS_SYNCSRC_COMP 0x00002000

Supports Composite synchronization input.

#define NVVIOCAPS_SYNCSRC_SDI 0x00001000

Supports Serial Digital Interface (SDI) synchronization input.

#define NVVIOCAPS_VER NVVIOCAPS_VER2

Supports Serial Digital Interface (SDI) output.

#define NVVIOCAPS_VER1 MAKE_NVAPI_VERSION(NVVIOCAPS,1)

Macro for constructing the version field of NVVIOCAPS.

#define NVVIOCAPS_VER2 MAKE_NVAPI_VERSION(NVVIOCAPS,2)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCAPS_VIDIN_SDI 0x00100000

Supports Serial Digital Interface (SDI) input.

#define NVVIOCAPS_VIDOUT_SDI 0x00000001

Supports Serial Digital Interface (SDI) output.

#define NVVIOCLASS_SDI 0x00000001

SDI-class interface: SDI output with two genlock inputs.

#define NVVIOCOLORCONVERSION_VER MAKE_NVAPI_VERSION(NVVIOCOLORCONVERSION,1)

macro for constructing the version field of _NVVIOCOLORCONVERSION.

#define NVVIOCONFIG_422FILTER 0x00000400

fields: bEnable422Filter

#define NVVIOCONFIG_ALLFIELDS
Value:
( NVVIOCONFIG_SIGNALFORMAT          | \
                                  NVVIOCONFIG_DATAFORMAT            | \
                                  NVVIOCONFIG_OUTPUTREGION          | \
                                  NVVIOCONFIG_OUTPUTAREA            | \
                                  NVVIOCONFIG_COLORCONVERSION       | \
                                  NVVIOCONFIG_GAMMACORRECTION       | \
                                  NVVIOCONFIG_SYNCSOURCEENABLE      | \
                                  NVVIOCONFIG_SYNCDELAY             | \
                                  NVVIOCONFIG_COMPOSITESYNCTYPE     | \
                                  NVVIOCONFIG_FRAMELOCKENABLE       | \
                                  NVVIOCONFIG_422FILTER             | \
                                  NVVIOCONFIG_COMPOSITETERMINATE    | \
                                  NVVIOCONFIG_DATAINTEGRITYCHECK    | \
                                  NVVIOCONFIG_CSCOVERRIDE           | \
                                  NVVIOCONFIG_FLIPQUEUELENGTH       | \
                                  NVVIOCONFIG_ANCTIMECODEGENERATION | \
                                  NVVIOCONFIG_COMPOSITE             | \
                                  NVVIOCONFIG_ALPHAKEYCOMPOSITE     | \
                                  NVVIOCONFIG_COMPOSITE_Y           | \
                                  NVVIOCONFIG_COMPOSITE_CR          | \
                                  NVVIOCONFIG_COMPOSITE_CB          | \
                                  NVVIOCONFIG_FULL_COLOR_RANGE      | \
                                  NVVIOCONFIG_RGB_DATA              | \
                                  NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE | \
                                  NVVIOCONFIG_STREAMS               | \
                                  NVVIOCONFIG_ANC_PARITY_COMPUTATION | \
                                                                  NVVIOCONFIG_ANC_AUDIO_REPEAT )

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS
Value:
( NVVIOCONFIG_DATAINTEGRITYCHECK     | \
                                             NVVIOCONFIG_SYNCDELAY              | \
                                             NVVIOCONFIG_CSCOVERRIDE            | \
                                             NVVIOCONFIG_ANCTIMECODEGENERATION  | \
                                             NVVIOCONFIG_COMPOSITE              | \
                                             NVVIOCONFIG_ALPHAKEYCOMPOSITE      | \
                                             NVVIOCONFIG_COMPOSITE_Y            | \
                                             NVVIOCONFIG_COMPOSITE_CR           | \
                                             NVVIOCONFIG_COMPOSITE_CB           | \
                                             NVVIOCONFIG_ANC_PARITY_COMPUTATION)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_ALPHAKEYCOMPOSITE 0x00020000

fields: bEnableAlphaKeyComposite

#define NVVIOCONFIG_ANC_AUDIO_REPEAT 0x04000000

fields: enableAudioBlanking

#define NVVIOCONFIG_ANC_PARITY_COMPUTATION 0x02000000

fields: ancParityComputation

#define NVVIOCONFIG_ANCTIMECODEGENERATION 0x00008000

fields: bEnableANCTimeCodeGeneration

#define NVVIOCONFIG_COLORCONVERSION 0x00000010

fields: colorConversion

#define NVVIOCONFIG_COMPOSITE 0x00010000

fields: bEnableComposite

#define NVVIOCONFIG_COMPOSITE_CB 0x00100000

fields: compRange

#define NVVIOCONFIG_COMPOSITE_CR 0x00080000

fields: compRange

#define NVVIOCONFIG_COMPOSITE_Y 0x00040000

fields: compRange

#define NVVIOCONFIG_COMPOSITESYNCTYPE 0x00000100

fields: compositeSyncType

#define NVVIOCONFIG_COMPOSITETERMINATE 0x00000800

fields: bCompositeTerminate (Not supported on Quadro FX 4000 SDI)

#define NVVIOCONFIG_CSCOVERRIDE 0x00002000

fields: colorConversion override

#define NVVIOCONFIG_DATAFORMAT 0x00000002

fields: dataFormat

#define NVVIOCONFIG_DATAINTEGRITYCHECK 0x00001000

fields: bEnableDataIntegrityCheck (Not supported on Quadro FX 4000 SDI)

#define NVVIOCONFIG_DRIVERFIELDS
Value:
( NVVIOCONFIG_OUTPUTREGION          | \
                                   NVVIOCONFIG_OUTPUTAREA            | \
                                   NVVIOCONFIG_COLORCONVERSION       | \
                                   NVVIOCONFIG_FLIPQUEUELENGTH)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_FLIPQUEUELENGTH 0x00004000

fields: flipqueuelength control

#define NVVIOCONFIG_FRAMELOCKENABLE 0x00000200

fields: EnableFramelock

#define NVVIOCONFIG_FULL_COLOR_RANGE 0x00200000

fields: bEnableFullColorRange

#define NVVIOCONFIG_GAMMACORRECTION 0x00000020

fields: gammaCorrection

#define NVVIOCONFIG_GAMMAFIELDS ( NVVIOCONFIG_GAMMACORRECTION )

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_OUTPUTAREA 0x00000008

fields: outputArea

#define NVVIOCONFIG_OUTPUTREGION 0x00000004

fields: outputRegion

#define NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE 0x00800000

fields: bEnableSDIOutput

#define NVVIOCONFIG_RGB_DATA 0x00400000

fields: bEnableRGBData

#define NVVIOCONFIG_RMCTRLFIELDS
Value:
( NVVIOCONFIG_SIGNALFORMAT          | \
                                   NVVIOCONFIG_DATAFORMAT            | \
                                   NVVIOCONFIG_SYNCSOURCEENABLE      | \
                                   NVVIOCONFIG_COMPOSITESYNCTYPE     | \
                                   NVVIOCONFIG_FRAMELOCKENABLE       | \
                                   NVVIOCONFIG_422FILTER             | \
                                   NVVIOCONFIG_COMPOSITETERMINATE    | \
                                   NVVIOCONFIG_DATAINTEGRITYCHECK    | \
                                   NVVIOCONFIG_COMPOSITE             | \
                                   NVVIOCONFIG_ALPHAKEYCOMPOSITE     | \
                                   NVVIOCONFIG_COMPOSITE_Y           | \
                                   NVVIOCONFIG_COMPOSITE_CR          | \
                                   NVVIOCONFIG_COMPOSITE_CB)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_RMMODESET_FIELDS
Value:
( NVVIOCONFIG_SIGNALFORMAT         | \
                                        NVVIOCONFIG_DATAFORMAT           | \
                                        NVVIOCONFIG_SYNCSOURCEENABLE     | \
                                        NVVIOCONFIG_FRAMELOCKENABLE      | \
                                        NVVIOCONFIG_COMPOSITESYNCTYPE    | \
                                                                                NVVIOCONFIG_ANC_AUDIO_REPEAT)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_RMSKEWFIELDS ( NVVIOCONFIG_SYNCDELAY )

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_SIGNALFORMAT 0x00000001

fields: signalFormat

#define NVVIOCONFIG_STREAMS 0x01000000

fields: streams

#define NVVIOCONFIG_SYNCDELAY 0x00000080

fields: syncDelay

#define NVVIOCONFIG_SYNCSOURCEENABLE 0x00000040

fields: syncSource and syncEnable

#define NVVIOCONFIG_VALIDFIELDS
Value:
( NVVIOCONFIG_SIGNALFORMAT          | \
                                   NVVIOCONFIG_DATAFORMAT            | \
                                   NVVIOCONFIG_OUTPUTREGION          | \
                                   NVVIOCONFIG_OUTPUTAREA            | \
                                   NVVIOCONFIG_COLORCONVERSION       | \
                                   NVVIOCONFIG_GAMMACORRECTION       | \
                                   NVVIOCONFIG_SYNCSOURCEENABLE      | \
                                   NVVIOCONFIG_SYNCDELAY             | \
                                   NVVIOCONFIG_COMPOSITESYNCTYPE     | \
                                   NVVIOCONFIG_FRAMELOCKENABLE       | \
                                   NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE | \
                                   NVVIOCONFIG_422FILTER             | \
                                   NVVIOCONFIG_COMPOSITETERMINATE    | \
                                   NVVIOCONFIG_DATAINTEGRITYCHECK    | \
                                   NVVIOCONFIG_CSCOVERRIDE           | \
                                   NVVIOCONFIG_FLIPQUEUELENGTH       | \
                                   NVVIOCONFIG_ANCTIMECODEGENERATION | \
                                   NVVIOCONFIG_COMPOSITE             | \
                                   NVVIOCONFIG_ALPHAKEYCOMPOSITE     | \
                                   NVVIOCONFIG_COMPOSITE_Y           | \
                                   NVVIOCONFIG_COMPOSITE_CR          | \
                                   NVVIOCONFIG_COMPOSITE_CB          | \
                                   NVVIOCONFIG_FULL_COLOR_RANGE      | \
                                   NVVIOCONFIG_RGB_DATA              | \
                                   NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE | \
                                   NVVIOCONFIG_STREAMS               | \
                                   NVVIOCONFIG_ANC_PARITY_COMPUTATION | \
                                                                   NVVIOCONFIG_ANC_AUDIO_REPEAT)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_VER NVVIOCONFIG_VER3

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_VER1 MAKE_NVAPI_VERSION(NVVIOCONFIG_V1,1)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_VER2 MAKE_NVAPI_VERSION(NVVIOCONFIG_V2,2)

Supports Serial Digital Interface (SDI) output.

#define NVVIOCONFIG_VER3 MAKE_NVAPI_VERSION(NVVIOCONFIG_V3,3)

Supports Serial Digital Interface (SDI) output.

#define NVVIOGAMMACORRECTION_VER MAKE_NVAPI_VERSION(NVVIOGAMMACORRECTION,1)

Macro for constructing thevesion field of _NVVIOGAMMACORRECTION.

#define NVVIOOWNERID_NONE 0

Unregistered ownerId.

#define NVVIOSTATUS_VER MAKE_NVAPI_VERSION(NVVIOSTATUS,1)

Macro for constructingthe version field of NVVIOSTATUS.

#define NVVIOSYNCDELAY_VER MAKE_NVAPI_VERSION(NVVIOSYNCDELAY,1)

Macro for constructing the version field of NVVIOSYNCDELAY.

#define NVVIOTOPOLOGY_VER MAKE_NVAPI_VERSION(NVVIOTOPOLOGY,1)

Macro for constructing the version field of NVVIOTOPOLOGY.

Typedef Documentation

typedef struct _NV_VIO_TOPOLOGY NV_VIO_TOPOLOGY

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOCAPS NVVIOCAPS

Device capabilities.

typedef struct _NVVIOCHANNELSTATUS NVVIOCHANNELSTATUS

Input channel status.

typedef struct _NVVIOCOLORCONVERSION NVVIOCOLORCONVERSION

Colorspace conversion.

typedef struct _NVVIOCOMPOSITERANGE NVVIOCOMPOSITERANGE

Supports Serial Digital Interface (SDI) output.

typedef NVVIOCONFIG_V3 NVVIOCONFIG

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOCONFIG_V1 NVVIOCONFIG_V1

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOCONFIG_V2 NVVIOCONFIG_V2

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOCONFIG_V3 NVVIOCONFIG_V3

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIODATAFORMATDETAIL NVVIODATAFORMATDETAIL

Data format details.

typedef struct _NVVIOGAMMACORRECTION NVVIOGAMMACORRECTION

Gamma correction.

typedef struct _NVVIOGAMMARAMP10 NVVIOGAMMARAMP10

Gamma ramp (10-bit index)

typedef struct _NVVIOGAMMARAMP8 NVVIOGAMMARAMP8

Gamma ramp (8-bit index)

typedef struct _NVVIOINPUTCONFIG NVVIOINPUTCONFIG

Input device configuration.

typedef struct _NVVIOINPUTSTATUS NVVIOINPUTSTATUS

Input device status.

typedef NVVIOOUTPUTCONFIG_V3 NVVIOOUTPUTCONFIG

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOOUTPUTCONFIG_V1 NVVIOOUTPUTCONFIG_V1

Output device configuration.

typedef struct _NVVIOOUTPUTCONFIG_V2 NVVIOOUTPUTCONFIG_V2

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOOUTPUTCONFIG_V3 NVVIOOUTPUTCONFIG_V3

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOOUTPUTREGION NVVIOOUTPUTREGION

Output region.

typedef struct _NVVIOOUTPUTSTATUS NVVIOOUTPUTSTATUS

Output device status.

typedef NvU32 NVVIOOWNERID

Unique identifier for VIO owner (process identifier or NVVIOOWNERID_NONE)

typedef enum _NVVIOOWNERTYPE NVVIOOWNERTYPE

Owner type for device.

typedef enum _NVVIOPCILINKRATE NVVIOPCILINKRATE
typedef enum _NVVIOSIGNALFORMAT NVVIOSIGNALFORMAT

Video signal format and resolution.

typedef struct _NVVIOSIGNALFORMATDETAIL NVVIOSIGNALFORMATDETAIL

Signal format details.

typedef struct _NVVIOSTATUS NVVIOSTATUS

Video device status.

typedef struct _NVVIOSTREAM NVVIOSTREAM

Stream configuration.

typedef struct _NVVIOSYNCDELAY NVVIOSYNCDELAY

Sync delay.

typedef struct _NV_VIO_TOPOLOGY NVVIOTOPOLOGY

Supports Serial Digital Interface (SDI) output.

typedef struct _NVVIOVIDEOMODE NVVIOVIDEOMODE

Video mode information.

Enumeration Type Documentation

enum _NVVIOOWNERTYPE

Owner type for device.

Enumerator:
NVVIOOWNERTYPE_NONE

No owner for the device.

NVVIOOWNERTYPE_APPLICATION

Application owns the device.

NVVIOOWNERTYPE_DESKTOP

Desktop transparent mode owns the device (not applicable for video input)

enum _NVVIOPCILINKRATE
Enumerator:
NVVIOPCILINKRATE_UNKNOWN
NVVIOPCILINKRATE_GEN1
NVVIOPCILINKRATE_GEN2
NVVIOPCILINKRATE_GEN3
enum _NVVIOSIGNALFORMAT

Video signal format and resolution.

Enumerator:
NVVIOSIGNALFORMAT_NONE

Invalid signal format.

NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC

01 487i 59.94Hz (SMPTE259) NTSC

NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL

02 576i 50.00Hz (SMPTE259) PAL

NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260

03 1035i 60.00Hz (SMPTE260)

NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260

04 1035i 59.94Hz (SMPTE260)

NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295

05 1080i 50.00Hz (SMPTE295)

NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274

06 1080i 60.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274

07 1080i 59.94Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274

08 1080i 50.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274

09 1080p 30.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274

10 1080p 29.97Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274

11 1080p 25.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274

12 1080p 24.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274

13 1080p 23.976Hz (SMPTE274)

NVVIOSIGNALFORMAT_720P_60_00_SMPTE296

14 720p 60.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_59_94_SMPTE296

15 720p 59.94Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_50_00_SMPTE296

16 720p 50.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274

17 1080I 48.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274

18 1080I 47.96Hz (SMPTE274)

NVVIOSIGNALFORMAT_720P_30_00_SMPTE296

19 720p 30.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_29_97_SMPTE296

20 720p 29.97Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_25_00_SMPTE296

21 720p 25.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_24_00_SMPTE296

22 720p 24.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_23_98_SMPTE296

23 720p 23.98Hz (SMPTE296)

NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372

24 2048p 30.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372

25 2048p 29.97Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372

26 2048i 60.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372

27 2048i 59.94Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372

28 2048p 25.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372

29 2048i 50.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372

30 2048p 24.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372

31 2048p 23.98Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372

32 2048i 48.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372

33 2048i 47.96Hz (SMPTE372)

NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274

34 1080PsF 25.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274

35 1080PsF 29.97Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274

36 1080PsF 30.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274

37 1080PsF 24.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274

38 1080PsF 23.98Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A

39 1080P 50.00Hz (SMPTE274) 3G Level A

NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A

40 1080P 59.94Hz (SMPTE274) 3G Level A

NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A

41 1080P 60.00Hz (SMPTE274) 3G Level A

NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B

42 1080p 60.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B

43 1080i 60.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B

44 2048i 60.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B

45 1080p 50.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B

46 1080i 50.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B

47 2048i 50.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B

48 1080p 30.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B

49 2048p 30.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B

50 1080p 25.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B

51 2048p 25.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B

52 1080p 24.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B

53 2048p 24.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B

54 1080i 48.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B

55 2048i 48.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B

56 1080p 59.94Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B

57 1080i 59.94Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B

58 2048i 59.94Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B

59 1080p 29.97Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B

60 2048p 29.97Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B

61 1080p 29.98Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B

62 2048p 29.98Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B

63 1080i 47.96Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B

64 2048i 47.96Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_END

65 To indicate end of signal format list

Function Documentation

NVAPI_INTERFACE NvAPI_VIO_EnumDataFormats | ( | NvVioHandle | hVioHandle,
 |  | NvU32 | enumIndex,
 |  | NVVIODATAFORMATDETAIL * | pDataFormatDetail
 | ) |  |

Function: NvAPI_VIO_EnumDataFormats

Description: This API enumerates data formats supported by Video I/O.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[in] | enumIndex | Enumeration index
[out] | pDataFormatDetail | Pointer to receive detail or NULL
Return values:
NVAPI_OK | Success
NVAPI_END_ENUMERATION | No more data formats to enumerate
NVAPI_NOT_SUPPORTED | Unsupported NVVIODATAFORMAT_ enumeration
NVAPI_INTERFACE NvAPI_VIO_EnumDevices | ( | NvVioHandle | hVioHandle[NVAPI_MAX_VIO_DEVICES],
 |  | NvU32 * | vioDeviceCount
 | ) |  |

Function: NvAPI_VIO_EnumDevices

Description: This API enumerate all VIO devices connected to the system.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[out] | NvVioHandle | User passes the pointer of NvVioHandle[] array to get handles to all the connected video I/O devices.
[out] | vioDeviceCount | User gets total number of VIO devices connected to the system.
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_ERROR | NVAPI Random errors
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No SDI Device found
NVAPI_INTERFACE NvAPI_VIO_EnumSignalFormats | ( | NvVioHandle | hVioHandle,
 |  | NvU32 | enumIndex,
 |  | NVVIOSIGNALFORMATDETAIL * | pSignalFormatDetail
 | ) |  |

Function: NvAPI_VIO_EnumSignalFormats

Description: This API enumerates signal formats supported by Video I/O.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[in] | enumIndex | Enumeration index
[out] | pSignalFormatDetail | Pointer to receive detail or NULL
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized
NVAPI_INVALID_ARGUMENT | Invalid argument passed
NVAPI_END_ENUMERATION | No more signal formats to enumerate
NVAPI_INTERFACE NvAPI_VIO_GetCapabilities | ( | NvVioHandle | hVioHandle,
 |  | NVVIOCAPS * | pAdapterCaps
 | ) |  |

Function: NvAPI_VIO_GetCapabilities

Description: This API determine the graphics adapter video I/O capabilities.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pAdapterCaps | Pointer to receive capabilities
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NVVIOCAPS struct version used by the app is not compatible
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_INTERFACE NvAPI_VIO_GetPCIInfo | ( | __in NvVioHandle | hVioHandle,
 |  | __inout NVVIOPCIINFO * | pVioPCIInfo
 | ) |  |

FUNCTION NAME: NvAPI_VIO_GetPCIInfo()

DESCRIPTION: This API gets PCI information of the attached SDI(input) capture card.

Parameters:
[in] | hVioHandle | Handle to SDI capture card.
[out] | pVioPCIInfo | PCI information of the attached SDI capture card.

SUPPORTED OS: Windows XP and higher

Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INTERFACE NvAPI_VIO_IsFrameLockModeCompatible | ( | NvVioHandle | hVioHandle,
 |  | NvU32 | srcEnumIndex,
 |  | NvU32 | destEnumIndex,
 |  | NvU32 * | pbCompatible
 | ) |  |

Function: NvAPI_VIO_IsFrameLockModeCompatible

Description: This API checks whether modes are compatible in frame lock mode.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[in] | srcEnumIndex | Source Enumeration index
[in] | destEnumIndex | Destination Enumeration index
[out] | pbCompatible | Pointer to receive compatibility
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_INTERFACE NvAPI_VIO_IsRunning ( NvVioHandle hVioHandle )

Function: NvAPI_VIO_IsRunning

Description: This API determines if Video I/O is running.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] NvVioHandle[IN] The caller provides the SDI device handle as input.
Return values:
NVAPI_DRIVER_RUNNING | Video I/O running
NVAPI_DRIVER_NOTRUNNING | Video I/O not running
NVAPI_INTERFACE NvAPI_VIO_QueryTopology ( NV_VIO_TOPOLOGY * pNvVIOTopology )

Function: NvAPI_VIO_QueryTopology

Description: This API queries the valid SDI topologies.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[out] pNvVIOTopology User passes the pointer to NVVIOTOPOLOGY to fetch all valid SDI topologies.
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Invalid structure version
NVAPI_ERROR | NVAPI Random errors
NVAPI_INTERFACE NvAPI_VIO_Start ( NvVioHandle hVioHandle )

Function: NvAPI_VIO_Start

Description: This API starts Video I/O. This API should be called for NVVIOOWNERTYPE_DESKTOP only and will not work for OGL applications.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] NvVioHandle[IN] The caller provides the SDI device handle as input.
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access
NVAPI_INTERFACE NvAPI_VIO_Stop ( NvVioHandle hVioHandle )

Function: NvAPI_VIO_Stop

Description: This API stops Video I/O. This API should be called for NVVIOOWNERTYPE_DESKTOP only and will not work for OGL applications.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] NvVioHandle[IN] The caller provides the SDI device handle as input.
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access


Modules
DirectX APIs

Modules

DirectX Interface
DirectX Video Control


Data Structures | Defines | Typedefs | Enumerations | Functions
DirectX Interface
DirectX APIs

Data Structures

struct | NvAPI_D3D11_RASTERIZER_DESC_EX
struct | NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1
struct | NVAPI_D3D12_PSO_EXTENSION_DESC_V1
struct | NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
struct | NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
struct | NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1
struct | NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
struct | NV_GET_CURRENT_SLI_STATE

Defines

#define | NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)
#define | NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1
#define | NV_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_EXTENSION_DESC_V1, 1)
#define | NV_PSO_EXTENSION_DESC_VER NV_PSO_EXTENSION_DESC_VER_1
#define | NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, 1)
#define | NV_RASTERIZER_PSO_EXTENSION_DESC_VER NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1
#define | NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)
#define | NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1
#define | NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1, 1)
#define | NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1
#define | NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1, 1)
#define | NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1
#define | NVAPI_COPY_ASYNCHRONOUSLY 1
#define | NV_GET_CURRENT_SLI_STATE_VER MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE,1)

Typedefs

typedef struct
NvAPI_D3D11_RASTERIZER_DESC_EX 		NvAPI_D3D11_RASTERIZER_DESC_EX
typedef enum _NV_SWIZZLE_MODE | NV_SWIZZLE_MODE
typedef enum _NV_SWIZZLE_OFFSET | NV_SWIZZLE_OFFSET
typedef enum _NV_FASTGS_FLAGS | NV_FASTGS_FLAGS
typedef
NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 		NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC
typedef enum _NV_PSO_EXTENSION | NV_PSO_EXTENSION
typedef
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 		NVAPI_D3D12_PSO_EXTENSION_DESC
typedef
NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 		NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC
typedef
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 		NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC
typedef
NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 		NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC
typedef
NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 		NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC
typedef enum _IMPLICIT_SLI_CONTROL | IMPLICIT_SLI_CONTROL
typedef enum
_NVAPI_D3D_SETRESOURCEHINT_CATEGORY 		NVAPI_D3D_SETRESOURCEHINT_CATEGORY
typedef enum
_NVAPI_D3D_SETRESOURCEHINT_SLI 		NVAPI_D3D_SETRESOURCEHINT_SLI
typedef enum
_NVAPI_D3D_RESOURCERENDERING_FLAG 		NVAPI_D3D_RESOURCERENDERING_FLAG

Enumerations

enum | NVAPI_ALIAS_SURFACE_FLAG { NVAPI_ALIAS_SURFACE_FLAG_NONE = 0x00000000, NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER = 0x00000001, NVAPI_ALIAS_SURFACE_FLAG_MASK = 0x00000001 }
enum | NVAPI_QUAD_FILLMODE { NVAPI_QUAD_FILLMODE_DISABLED = 0, NVAPI_QUAD_FILLMODE_BBOX = 1, NVAPI_QUAD_FILLMODE_FULL_VIEWPORT = 2 }
enum _NV_SWIZZLE_MODE {
NV_SWIZZLE_POS_X = 0, NV_SWIZZLE_NEG_X = 1, NV_SWIZZLE_POS_Y = 2, NV_SWIZZLE_NEG_Y = 3,
NV_SWIZZLE_POS_Z = 4, NV_SWIZZLE_NEG_Z = 5, NV_SWIZZLE_POS_W = 6, NV_SWIZZLE_NEG_W = 7
}
enum | _NV_SWIZZLE_OFFSET { NV_SWIZZLE_OFFSET_X = 0, NV_SWIZZLE_OFFSET_Y = 4, NV_SWIZZLE_OFFSET_Z = 8, NV_SWIZZLE_OFFSET_W = 12 }
enum | _NV_FASTGS_FLAGS { NV_FASTGS_USE_VIEWPORT_MASK = 0x01, NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX = 0x02, NV_FASTGS_STRICT_API_ORDER = 0x04 }
enum | _NV_PSO_EXTENSION { NV_PSO_RASTER_EXTENSION = 0, NV_PSO_REQUEST_FASTGS_EXTENSION = 1, NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION = 3, NV_PSO_EXPLICIT_FASTGS_EXTENSION = 4 }
enum | _IMPLICIT_SLI_CONTROL { DISABLE_IMPLICIT_SLI = 0, ENABLE_IMPLICIT_SLI = 1 }
enum NVAPI_DEVICE_FEATURE_LEVEL {
NVAPI_DEVICE_FEATURE_LEVEL_NULL = -1, NVAPI_DEVICE_FEATURE_LEVEL_10_0 = 0, NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS = 1, NVAPI_DEVICE_FEATURE_LEVEL_10_1 = 2,
NVAPI_DEVICE_FEATURE_LEVEL_11_0 = 3
}
enum | _NVAPI_D3D_SETRESOURCEHINT_CATEGORY { NVAPI_D3D_SRH_CATEGORY_SLI = 1 }
enum | _NVAPI_D3D_SETRESOURCEHINT_SLI { NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC = 1, NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE = 2 }
enum | _NVAPI_D3D_RESOURCERENDERING_FLAG { NVAPI_D3D_RR_FLAG_DEFAULTS = 0x00000000, NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT = 0x00000001, NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT = 0x00000002, NVAPI_D3D_RR_FLAG_MULTI_FRAME = 0x00000004 }

Functions

NVAPI_INTERFACE | NvAPI_D3D9_RegisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_UnregisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_AliasSurfaceAsTexture (IDirect3DDevice9 *pDev, IDirect3DSurface9 *pSurface, IDirect3DTexture9 **ppTexture, DWORD dwFlag)
NVAPI_INTERFACE | NvAPI_D3D9_StretchRectEx (IDirect3DDevice9 *pDevice, IDirect3DResource9 *pSourceResource, CONST RECT *pSourceRect, IDirect3DResource9 *pDestResource, CONST RECT *pDestRect, D3DTEXTUREFILTERTYPE Filter)
NVAPI_INTERFACE | NvAPI_D3D9_ClearRT (IDirect3DDevice9 *pDevice, NvU32 dwNumRects, CONST RECT *pRects, float r, float g, float b, float a)
NVAPI_INTERFACE | NvAPI_D3D9_GetSurfaceHandle (IDirect3DSurface9 *pSurface, NVDX_ObjectHandle *pHandle)
NVAPI_INTERFACE | NvAPI_D3D11_IsNvShaderExtnOpCodeSupported (__in IUnknown *pDev, __in NvU32 opCode, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D11_SetNvShaderExtnSlot (__in IUnknown *pDev, __in NvU32 uavSlot)
NVAPI_INTERFACE | NvAPI_D3D11_BeginUAVOverlapEx (__in IUnknown *pDeviceOrContext, __in NvU32 insertWFIFlags)
NVAPI_INTERFACE | NvAPI_D3D11_BeginUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D11_EndUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D_SetFPSIndicatorState (IUnknown *pDev, NvU8 doEnable)
NVAPI_INTERFACE | NvAPI_D3D11_CreateRasterizerState (__in ID3D11Device *pDevice, __in const NvAPI_D3D11_RASTERIZER_DESC_EX *pRasterizerDesc, __out ID3D11RasterizerState **ppRasterizerState)
NVAPI_INTERFACE | NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA (__in ID3D11Device *pDevice, __in ID3D11Texture2D *pInputTex, __out ID3D11Texture2D **ppOutTex)
NVAPI_INTERFACE | NvAPI_D3D11_CreateFastGeometryShaderExplicit (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC *pCreateFastGSArgs, __out ID3D11GeometryShader **ppGeometryShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateFastGeometryShader (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __out ID3D11GeometryShader **ppGeometryShader)
NVAPI_INTERFACE | NvAPI_D3D12_CreateGraphicsPipelineState (__in ID3D12Device *pDevice, __in const D3D12_GRAPHICS_PIPELINE_STATE_DESC *pPSODesc, NvU32 numExtensions, __in const NVAPI_D3D12_PSO_EXTENSION_DESC **ppExtensions, __out ID3D12PipelineState **ppPSO)
NVAPI_INTERFACE | NvAPI_D3D12_SetDepthBoundsTestValues (__in ID3D12GraphicsCommandList *pCommandList, __in const float minDepth, __in const float maxDepth)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncCapable (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncCapable)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncActive (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncActive)
NVAPI_INTERFACE | NvAPI_D3D1x_DisableShaderDiskCache (IUnknown *pDevice)
NVAPI_INTERFACE | NvAPI_D3D1x_HintCreateLowLatencyDevice (bool bCreateLowLatencyDevice)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_GetCaps (__out PNV_MULTIGPU_CAPS pMultiGPUCaps)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_Init (__in bool bEnable)
NVAPI_INTERFACE | NvAPI_D3D11_CreateMultiGPUDevice (__in ID3D11Device *pDevice, __in ULONG version, __out ULONG *currentVersion, __out ID3D11MultiGPUDevice **ppD3D11MultiGPUDevice, __in UINT maxGpus=ALL_GPUS)
NVAPI_INTERFACE | NvAPI_D3D_RegisterDevice (__in IUnknown *pDev)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawIndexedInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D_ImplicitSLIControl (__in IMPLICIT_SLI_CONTROL implicitSLIControl)
NVAPI_INTERFACE | NvAPI_D3D1x_GetLowLatencySupport (__in LUID pAdapterId, __out BOOL *pIsLowLatencySupported)
NVAPI_INTERFACE | NvAPI_D3D_GetObjectHandleForResource (IUnknown *pDevice, IUnknown *pResource, NVDX_ObjectHandle *pHandle)
NVAPI_INTERFACE | NvAPI_D3D11_CreateDevice (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_CreateDeviceAndSwapChain (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, CONST DXGI_SWAP_CHAIN_DESC *pSwapChainDesc, IDXGISwapChain **ppSwapChain, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_SetDepthBoundsTest (IUnknown *pDeviceOrContext, NvU32 bEnable, float fMinDepth, float fMaxDepth)
NVAPI_INTERFACE | NvAPI_D3D_GetCurrentSLIState (IUnknown *pDevice, NV_GET_CURRENT_SLI_STATE *pSliState)
NVAPI_INTERFACE | NvAPI_D3D_SetResourceHint (IUnknown *pDev, NVDX_ObjectHandle obj, NVAPI_D3D_SETRESOURCEHINT_CATEGORY dwHintCategory, NvU32 dwHintName, NvU32 *pdwHintValue)
NVAPI_INTERFACE | NvAPI_D3D_BeginResourceRendering (IUnknown *pDev, NVDX_ObjectHandle obj, NvU32 Flags)
NVAPI_INTERFACE | NvAPI_D3D_EndResourceRendering (IUnknown *pDev, NVDX_ObjectHandle obj, NvU32 Flags)

Define Documentation

#define NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1
#define NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1, 1)
#define NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1
#define NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1, 1)
#define NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1
#define NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)
#define NV_GET_CURRENT_SLI_STATE_VER MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE,1)
#define NV_PSO_EXTENSION_DESC_VER NV_PSO_EXTENSION_DESC_VER_1
#define NV_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_EXTENSION_DESC_V1, 1)
#define NV_RASTERIZER_PSO_EXTENSION_DESC_VER NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1
#define NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, 1)
#define NVAPI_COPY_ASYNCHRONOUSLY 1
#define NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1
#define NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)

Typedef Documentation

typedef enum _IMPLICIT_SLI_CONTROL IMPLICIT_SLI_CONTROL
typedef enum _NV_FASTGS_FLAGS NV_FASTGS_FLAGS

SUPPORTED OS: Windows Vista and higher

typedef enum _NV_PSO_EXTENSION NV_PSO_EXTENSION

Enum for CreatePSO extensions.

typedef enum _NV_SWIZZLE_MODE NV_SWIZZLE_MODE
typedef enum _NV_SWIZZLE_OFFSET NV_SWIZZLE_OFFSET
typedef NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC
typedef struct NvAPI_D3D11_RASTERIZER_DESC_EX NvAPI_D3D11_RASTERIZER_DESC_EX

SUPPORTED OS: Windows Vista and higher

typedef NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC
typedef NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC
typedef NVAPI_D3D12_PSO_EXTENSION_DESC_V1 NVAPI_D3D12_PSO_EXTENSION_DESC
typedef NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC
typedef NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC
typedef enum _NVAPI_D3D_RESOURCERENDERING_FLAG NVAPI_D3D_RESOURCERENDERING_FLAG

Used in NvAPI_D3D_BeginResourceRendering().

typedef enum _NVAPI_D3D_SETRESOURCEHINT_CATEGORY NVAPI_D3D_SETRESOURCEHINT_CATEGORY

Valid categories for NvAPI_D3D_SetResourceHint()

typedef enum _NVAPI_D3D_SETRESOURCEHINT_SLI NVAPI_D3D_SETRESOURCEHINT_SLI

Types of SLI hints;
NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will not track any rendering operations that would mark this resource as dirty, avoiding any form of synchronization across frames rendered in parallel in multiple GPUs in AFR mode.

NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will try to perform operations which involved target resource in broadcast, where its possible. Hint is static and must be set before resource starts using.

Enumeration Type Documentation

enum _IMPLICIT_SLI_CONTROL
Enumerator:
DISABLE_IMPLICIT_SLI
ENABLE_IMPLICIT_SLI
enum _NV_FASTGS_FLAGS

SUPPORTED OS: Windows Vista and higher

Enumerator:
NV_FASTGS_USE_VIEWPORT_MASK

Causes SV_ViewportArrayIndex value to be interpreted as a bitmask of viewports to broadcast to.

NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX

Causes SV_RenderTargetArrayIndex value to be offset by the viewport index when broadcasting.

NV_FASTGS_STRICT_API_ORDER

Causes broadcast primitives to be rendered strictly in API order (slow).
By default, primitives may be batched per viewport to improve performance.

enum _NV_PSO_EXTENSION

Enum for CreatePSO extensions.

Enumerator:
NV_PSO_RASTER_EXTENSION
NV_PSO_REQUEST_FASTGS_EXTENSION
NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION
NV_PSO_EXPLICIT_FASTGS_EXTENSION
enum _NV_SWIZZLE_MODE
Enumerator:
NV_SWIZZLE_POS_X
NV_SWIZZLE_NEG_X
NV_SWIZZLE_POS_Y
NV_SWIZZLE_NEG_Y
NV_SWIZZLE_POS_Z
NV_SWIZZLE_NEG_Z
NV_SWIZZLE_POS_W
NV_SWIZZLE_NEG_W
enum _NV_SWIZZLE_OFFSET
Enumerator:
NV_SWIZZLE_OFFSET_X
NV_SWIZZLE_OFFSET_Y
NV_SWIZZLE_OFFSET_Z
NV_SWIZZLE_OFFSET_W
enum _NVAPI_D3D_RESOURCERENDERING_FLAG

Used in NvAPI_D3D_BeginResourceRendering().

Enumerator:
NVAPI_D3D_RR_FLAG_DEFAULTS

All bits set to 0 are defaults.

NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT

(bit 0) The flag forces to discard previous content of the resource regardless of the NvApiHints_Sli_Disable_InterframeSync hint

NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT

(bit 1) The flag forces to respect previous content of the resource regardless of the NvApiHints_Sli_Disable_InterframeSync hint

NVAPI_D3D_RR_FLAG_MULTI_FRAME

(bit 2) The flag hints the driver that content will be used for many frames. If not specified then the driver assumes that content is used only on the next frame

enum _NVAPI_D3D_SETRESOURCEHINT_CATEGORY

Valid categories for NvAPI_D3D_SetResourceHint()

Enumerator:
NVAPI_D3D_SRH_CATEGORY_SLI
enum _NVAPI_D3D_SETRESOURCEHINT_SLI

Types of SLI hints;
NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will not track any rendering operations that would mark this resource as dirty, avoiding any form of synchronization across frames rendered in parallel in multiple GPUs in AFR mode.

NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will try to perform operations which involved target resource in broadcast, where its possible. Hint is static and must be set before resource starts using.

Enumerator:
NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC
NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE
enum NVAPI_ALIAS_SURFACE_FLAG

See NvAPI_D3D9_AliasSurfaceAsTexture().

Enumerator:
NVAPI_ALIAS_SURFACE_FLAG_NONE
NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER

Use the surface's msaa buffer directly as a texture, rather than resolving. (This is much slower, but potentially has higher quality.)

NVAPI_ALIAS_SURFACE_FLAG_MASK
enum NVAPI_DEVICE_FEATURE_LEVEL

D3D_FEATURE_LEVEL supported - used in NvAPI_D3D11_CreateDevice() and NvAPI_D3D11_CreateDeviceAndSwapChain()

Enumerator:
NVAPI_DEVICE_FEATURE_LEVEL_NULL
NVAPI_DEVICE_FEATURE_LEVEL_10_0
NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS
NVAPI_DEVICE_FEATURE_LEVEL_10_1
NVAPI_DEVICE_FEATURE_LEVEL_11_0
enum NVAPI_QUAD_FILLMODE

SUPPORTED OS: Windows Vista and higher

Enumerator:
NVAPI_QUAD_FILLMODE_DISABLED
NVAPI_QUAD_FILLMODE_BBOX
NVAPI_QUAD_FILLMODE_FULL_VIEWPORT

Function Documentation

NVAPI_INTERFACE NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA | ( | __in ID3D11Device * | pDevice,
 |  | __in ID3D11Texture2D * | pInputTex,
 |  | __out ID3D11Texture2D ** | ppOutTex
 | ) |  |

SUPPORTED OS: Windows Vista and higher DESCRIPTION: This function allows creating (aliasing) a non-MSAA Texture2D object using the same memory as the given multi-sampled texture (pInputTex). The surface created would be bloated in width and height but it will have SampleCount = 1 For 2X MSAA: OutTex.Width = InputTex.Width * 2, outTex.Height = InputTex.Height For 4X MSAA: OutTex.Width = InputTex.Width * 2, outTex.Height = InputTex.Height * 2 For 8X MSAA: OutTex.Width = InputTex.Width * 4, outTex.Height = InputTex.Height * 2 Only textures SampleQuality = 0 can be aliased as Non MSAA The app should ensure that original texture is released only after the aliased copy is released.

Parameters:
[in] | pDevice | current d3d device
[in] | pInputTex | The MultiSampled Texture2D resource that is being aliased
[out] | ppOutTex | The aliased non AA copy MultiSampled Texture2D resource
Returns:
NVAPI_OK if the call succeeds.
NVAPI_INTERFACE NvAPI_D3D11_BeginUAVOverlap ( __in IUnknown * pDeviceOrContext )

DESCRIPTION: Causes the driver to skip synchronization that is normally needed when accessing UAVs. Applications must use this with caution otherwise this might cause data hazards when multiple draw calls/compute shader launches are accessing same memory locations

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] *pDeviceOrContext pointer to D3D11 device, or D3D11 device context
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NvAPI_D3D11_BeginUAVOverlapEx | ( | __in IUnknown * | pDeviceOrContext,
 |  | __in NvU32 | insertWFIFlags
 | ) |  |

DESCRIPTION: Causes the driver to skip synchronization that is normally needed when accessing UAVs. Applications must use this with caution otherwise this might cause data hazards when multiple draw calls/compute shader launches are accessing same memory locations

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | *pDeviceOrContext | pointer to D3D11 device, or D3D11 device context
[in] | insertWFIFlags | bit fields to indicate which WFI would be inserted (gfx / compute / both).

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

NVAPI_INTERFACE NvAPI_D3D11_CreateDevice | ( | IDXGIAdapter * | pAdapter,
 |  | D3D_DRIVER_TYPE | DriverType,
 |  | HMODULE | Software,
 |  | UINT | Flags,
 |  | CONST D3D_FEATURE_LEVEL * | pFeatureLevels,
 |  | UINT | FeatureLevels,
 |  | UINT | SDKVersion,
 |  | ID3D11Device ** | ppDevice,
 |  | D3D_FEATURE_LEVEL * | pFeatureLevel,
 |  | ID3D11DeviceContext ** | ppImmediateContext,
 |  | NVAPI_DEVICE_FEATURE_LEVEL * | pSupportedLevel
 | ) |  |

DESCRIPTION: This function tries to create a DirectX 11 device. If the call fails (if we are running on pre-DirectX 11 hardware), depending on the type of hardware it will try to create a DirectX 10.1 OR DirectX 10.0+ OR DirectX 10.0 device. The function call is the same as D3D11CreateDevice(), but with an extra argument (D3D_FEATURE_LEVEL supported by the device) that the function fills in. This argument can contain -1 (NVAPI_DEVICE_FEATURE_LEVEL_NULL), if the requested featureLevel is less than DirecX 10.0.

NOTE: When NvAPI_D3D11_CreateDevice is called with 10+ feature level we have an issue on few set of tesla hardware (G80/G84/G86/G92/G94/G96) which does not support all feature level 10+ functionality e.g. calling driver with mismatch between RenderTarget and Depth Buffer. App developers should take into consideration such limitation when using NVAPI on such tesla hardwares. SUPPORTED OS: Windows Vista and higher

Since:
Release: 185
Parameters:
[in] | pAdapter
[in] | DriverType
[in] | Software
[in] | Flags
[in] | *pFeatureLevels
[in] | FeatureLevels
[in] | SDKVersion
[in] | **ppDevice
[in] | *pFeatureLevel
[in] | **ppImmediateContext
[in] | *pSupportedLevel | D3D_FEATURE_LEVEL supported
Returns:
NVAPI_OK if the createDevice call succeeded.
NVAPI_INTERFACE NvAPI_D3D11_CreateDeviceAndSwapChain | ( | IDXGIAdapter * | pAdapter,
 |  | D3D_DRIVER_TYPE | DriverType,
 |  | HMODULE | Software,
 |  | UINT | Flags,
 |  | CONST D3D_FEATURE_LEVEL * | pFeatureLevels,
 |  | UINT | FeatureLevels,
 |  | UINT | SDKVersion,
 |  | CONST DXGI_SWAP_CHAIN_DESC * | pSwapChainDesc,
 |  | IDXGISwapChain ** | ppSwapChain,
 |  | ID3D11Device ** | ppDevice,
 |  | D3D_FEATURE_LEVEL * | pFeatureLevel,
 |  | ID3D11DeviceContext ** | ppImmediateContext,
 |  | NVAPI_DEVICE_FEATURE_LEVEL * | pSupportedLevel
 | ) |  |

DESCRIPTION: This function tries to create a DirectX 11 device and swap chain. If the call fails (if we are running on pre=DirectX 11 hardware), depending on the type of hardware it will try to create a DirectX 10.1 OR DirectX 10.0+ OR DirectX 10.0 device. The function call is the same as D3D11CreateDeviceAndSwapChain, but with an extra argument (D3D_FEATURE_LEVEL supported by the device) that the function fills in. This argument can contain -1 (NVAPI_DEVICE_FEATURE_LEVEL_NULL), if the requested featureLevel is less than DirectX 10.0.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 185
Parameters:
[in] | pAdapter
[in] | DriverType
[in] | Software
[in] | Flags
[in] | *pFeatureLevels
[in] | FeatureLevels
[in] | SDKVersion
[in] | *pSwapChainDesc
[in] | **ppSwapChain
[in] | **ppDevice
[in] | *pFeatureLevel
[in] | **ppImmediateContext
[in] | *pSupportedLevel | D3D_FEATURE_LEVEL supported

return NVAPI_OK if the createDevice with swap chain call succeeded.

NvAPI_D3D11_CreateFastGeometryShader | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __out ID3D11GeometryShader ** | ppGeometryShader
 | ) |  |

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This function will convert a regular geometry shader into a fast GS variant if possible. It will not do any validation regarding the compatibility of the resulting fast GS with any Pixel shader. The validation has to be done by the application manually.

The parameters are identical to ID3D11Device::CreateGeometryShader() so please refer to its documentation for their usage.

If the shader is too complex or is not in adequate form to be converted to fast GS this function will simply fail. You should then call ID3D11Device::CreateGeometryShader() to create the regular geometry shader.

Since:
Release:
Parameters:
[in] | pDevice | The device pointer
[in] | pShaderBytecode | A pointer to the compiled shader.
[in] | BytecodeLength | Size of the compiled geometry shader.
[in] | pClassLinkage | A pointer to a class linkage interface. Can be NULL.
[out] | ppGeometryShader | Address of a pointer to a ID3D11GeometryShader interface.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INTERFACE NvAPI_D3D11_CreateFastGeometryShaderExplicit | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __in const NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC * | pCreateFastGSArgs,
 |  | __out ID3D11GeometryShader ** | ppGeometryShader
 | ) |  |

DESCRIPTION: This function will create a fast geometry shader written using an "explicit" coding style, rather than converting a standard GS. For the explicit coding style, the GS must be written with maxvertexcount(1), and must pass-through input vertex 0 to the output without modification.

Additional per-primitive outputs may also be computed and written to the single output vertex. If these outputs are read by the pixel shader, they must be declared with the "nointerpolation" attribute in the PS input signature; otherwise, visual corruption may occur. Also, unlike D3D API, there is no guarantee that pixel shader will get the default value of an attribute if that attribute is not written by the earlier shader stage in the pipeline.

The first four parameters are identical to ID3D11Device::CreateGeometryShader(), so please refer to its documentation for their usage.

Since:
Release:
Parameters:
[in] | pDevice | The device pointer
[in] | pShaderBytecode | A pointer to the compiled shader.
[in] | BytecodeLength | Size of the compiled geometry shader.
[in] | pClassLinkage | A pointer to a class linkage interface. Can be NULL.
[in] | pCreateFastGSArgs | A pointer to a NvAPI_D3D11_CREATE_FASTGS_EXPLICIT struct.
[out] | ppGeometryShader | Address of a pointer to a ID3D11GeometryShader interface.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NvAPI_D3D11_CreateMultiGPUDevice | ( | __in ID3D11Device * | pDevice,
 |  | __in ULONG | version,
 |  | __out ULONG * | currentVersion,
 |  | __out ID3D11MultiGPUDevice ** | ppD3D11MultiGPUDevice,
 |  | __in UINT | maxGpus = ALL_GPUS
 | ) |  |

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This function returns ID3D11MultiGPUDevice used for multi GPU VR support

Parameters:
[in] | pDevice | current d3d device
[in] | version | version of requested ID3D11MultiGPUDevice.
[out] | currentVersion | pointer to returned current version of ID3D11MultiGPUDevice.
[out] | ppD3D11MultiGPUDevice | pointer to returned ID3D11MultiGPUDevice.
[in] | maxGpus | max number of gpus this ID3D11MultiGPUDevice is allowed to use
Returns:
NVAPI_OK if the call succeeds.
NVAPI_INTERFACE NvAPI_D3D11_CreateRasterizerState | ( | __in ID3D11Device * | pDevice,
 |  | __in const NvAPI_D3D11_RASTERIZER_DESC_EX * | pRasterizerDesc,
 |  | __out ID3D11RasterizerState ** | ppRasterizerState
 | ) |  |

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This function is an extension of ID3D11Device::CreateRasterizerState with additional raster states

Parameters:
[in] | pDevice | current d3d device
[in] | pRasterizerDesc | Rasterizer state description of type NVAPI_D3D11_RASTERIZER_DESC_EX
[out] | ppRasterizerState | ID3D11RasterizerState
Returns:
NVAPI_OK if the call succeeds.
NVAPI_INTERFACE NvAPI_D3D11_EndUAVOverlap ( __in IUnknown * pDeviceOrContext )

DESCRIPTION: Re-enables driver synchronization between calls that access same UAVs See NvAPI_D3D_BeginUAVOverlap for more details.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] *pDeviceOrContext pointer to D3D11 device, or D3D11 device context
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INTERFACE NvAPI_D3D11_IsNvShaderExtnOpCodeSupported | ( | __in IUnknown * | pDev,
 |  | __in NvU32 | opCode,
 |  | __out bool * | pSupported
 | ) |  |

DESCRIPTION: This function checks if a nv HLSL shader extension opcode is supported on current hardware. List of opcodes is in nvShaderExtnEnums.h To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details on supported opcodes. SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | pDev | The device on which to query for support, should be a ID3D11Device+ device
[in] | opCode | the opcode to check
[out] | pSupported | true if supported, false otherwise
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_OK if the call succeeded
NVAPI_INTERFACE NvAPI_D3D11_MultiDrawIndexedInstancedIndirect | ( | __in ID3D11DeviceContext * | pDevContext11,
 |  | __in NvU32 | drawCount,
 |  | __in ID3D11Buffer * | pBuffer,
 |  | __in NvU32 | alignedByteOffsetForArgs,
 |  | __in NvU32 | alignedByteStrideForArgs
 | ) |  |

DESCRIPTION: Extension of DrawIndexedInstancedIndirect that takes a draw count in. The effect of this function is to loop over that draw count and perform the DrawIndexedInstancedIndirect operation each time, incrementing the buffer offset by the supplied stride each time.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | *pDevContext11 | Pointer to D3D11 device context (IC or DC)
[in] | drawCount | Do DrawIndexedInstancedIndirect operation this many times
[in] | *pBuffer | ID3D11Buffer that contains the command parameters
[in] | alignedByteOffsetForArgs | Start in pBuffer of the command parameters
[in] | alignedByteStrideForArgs | Stride of the command parameters - must be >= 5 * sizeof(NvU32)

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values:
NVAPI_D3D_DEVICE_NOT_REGISTERED When MultiDraw is called on a deferred context, and the device has not yet been registered (NvAPI_D3D_RegisterDevice), this error is returned.
NVAPI_INTERFACE NvAPI_D3D11_MultiDrawInstancedIndirect | ( | __in ID3D11DeviceContext * | pDevContext11,
 |  | __in NvU32 | drawCount,
 |  | __in ID3D11Buffer * | pBuffer,
 |  | __in NvU32 | alignedByteOffsetForArgs,
 |  | __in NvU32 | alignedByteStrideForArgs
 | ) |  |

DESCRIPTION: Extension of DrawInstancedIndirect that takes a draw count in. The effect of this function is to loop over that draw count and perform the DrawInstancedIndirect operation each time, incrementing the buffer offset by the supplied stride each time.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | *pDevContext11 | Pointer to D3D11 device context (IC or DC)
[in] | drawCount | Do DrawInstancedIndirect operation this many times
[in] | *pBuffer | ID3D11Buffer that contains the command parameters
[in] | alignedByteOffsetForArgs | Start in pBuffer of the command parameters
[in] | alignedByteStrideForArgs | Stride of the command parameters - must be >= 4 * sizeof(NvU32)

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values:
NVAPI_D3D_DEVICE_NOT_REGISTERED When MultiDraw is called on a deferred context, and the device has not yet been registered (NvAPI_D3D_RegisterDevice), this error is returned.
NvAPI_D3D11_MultiGPU_GetCaps ( __out PNV_MULTIGPU_CAPS pMultiGPUCaps )

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: Request to get multi GPU extension caps.

Parameters:
[out] pMultiGPUCaps Pointer to a structure returning multi GPU caps
Return values:
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INTERFACE NvAPI_D3D11_MultiGPU_Init ( __in bool bEnable )

SUPPORTED OS: Windows Vista and higher
DESCRIPTION: Request to enable/disable multi GPU extension. Also if enabled automatically disables auto stereo.

Parameters:
[in] bEnable if true enables the extension for all subsequently created devices. Otherwise disables it
Return values:
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INTERFACE NvAPI_D3D11_SetDepthBoundsTest | ( | IUnknown * | pDeviceOrContext,
 |  | NvU32 | bEnable,
 |  | float | fMinDepth,
 |  | float | fMaxDepth
 | ) |  |

DESCRIPTION: This function enables/disables the depth bounds test

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | pDeviceOrContext | The device or device context to set depth bounds test
[in] | bEnable | Enable(non-zero)/disable(zero) the depth bounds test
[in] | fMinDepth | The minimum depth for depth bounds test
[in] | fMaxDepth | The maximum depth for depth bounds test The valid values for fMinDepth and fMaxDepth are such that 0 <= fMinDepth <= fMaxDepth <= 1
Returns:
NVAPI_OK if the depth bounds test was correcly enabled or disabled
NVAPI_INTERFACE NvAPI_D3D11_SetNvShaderExtnSlot | ( | __in IUnknown * | pDev,
 |  | __in NvU32 | uavSlot
 | ) |  |

DESCRIPTION: This function sets the fake UAV slot that is used by Nvidia HLSL shader extensions. All createShader calls made to the driver after setting this slot would treat writes/reads to this UAV in a different way. Applications are expected to bind null UAV to this slot. The same slot is used for all shader stages. To disable shader extensions the app may set this uav slot to some value that is bigger than the max allowed slot index e.g, 128 or 0xFFFFFFFF. To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | pDev | The device for which to set the extension slot should be a ID3D11Device+ device
[in] | uavSlot | the uav slot to use
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_OK success, the uavSlot was set sucessfully
NVAPI_INTERFACE NvAPI_D3D12_CreateGraphicsPipelineState | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_GRAPHICS_PIPELINE_STATE_DESC * | pPSODesc,
 |  | NvU32 | numExtensions,
 |  | __in const NVAPI_D3D12_PSO_EXTENSION_DESC ** | ppExtensions,
 |  | __out ID3D12PipelineState ** | ppPSO
 | ) |  |

DESCRIPTION: This function will create PSO with provided extensions

Parameters:
[in] | pDevice | Current d3d device
[in] | pPSODesc | PSO description of type D3D12_GRAPHICS_PIPELINE_STATE_DESC
[in] | numExtensions | Number of extensions
[in] | ppExtensions | Array of PSO extensions (see NV_PSO_EXTENSION for possible extensions)
[out] | ppPSO | Output PSO object of type ID3D12PipelineState

SUPPORTED OS: Windows 10

Return values:
NVAPI_OK if the call succeeds.
NVAPI_INTERFACE NvAPI_D3D12_SetDepthBoundsTestValues | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in const float | minDepth,
 |  | __in const float | maxDepth
 | ) |  |

DESCRIPTION: This function will set the minDepth and maxDepth values for depth bounds test To enable/ disable depth bounds test use PSO extension NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION in the nvapi NvAPI_D3D12_CreateGraphicsPipelineState

Parameters:
[in] | pCommandList | Command List to set depth bounds test
[in] | minDepth | min value for depth bound test
[in] | maxDepth | max value for depth bound test

The valid values for minDepth and maxDepth are such that 0 <= minDepth <= maxDepth <= 1

SUPPORTED OS: Windows 10

Return values:
NVAPI_OK if the call succeeds.
NVAPI_INTERFACE NvAPI_D3D1x_DisableShaderDiskCache ( IUnknown * pDevice )

SUPPORTED OS: Windows Vista and higher DESCRIPTION: Disables driver managed caching of shader compilations to disk

Parameters:
[in] pDevice Device to disabled the shader disk cache on
Return values:
NVAPI_OK | Shader disk cache was disabled
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | Argument passed in is invalid.
NVAPI_INTERFACE NvAPI_D3D1x_GetLowLatencySupport | ( | __in LUID | pAdapterId,
 |  | __out BOOL * | pIsLowLatencySupported
 | ) |  |

SUPPORTED OS: Windows Vista and higher
DESCRIPTION: Query support for low latency nodes

Parameters:
[in] | adapterId | The adapter ID that specifies the GPU to query.
[out] | *pIsLowLatencySupported | Returns true if and only if low latency nodes are supported.
Return values:
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.
NVAPI_INVALID_POINTER | A NULL pointer was passed
NVAPI_INTERFACE NvAPI_D3D1x_HintCreateLowLatencyDevice ( bool bCreateLowLatencyDevice )

SUPPORTED OS: Windows Vista and higher
DESCRIPTION: Hint driver what type of D3D1x device has to be created

Parameters:
[in] bool true - Next CreateDevice call has to create low latency device. false - Next CreateDevice call has to create normal device. Caller has explicitely change state of the hint from true to false after low latency device is created. Default hint state is false.
Return values:
NVAPI_OK | Hint is set.
NVAPI_ERROR | Hint was not set.
NvAPI_D3D9_AliasSurfaceAsTexture | ( | IDirect3DDevice9 * | pDev,
 |  | IDirect3DSurface9 * | pSurface,
 |  | IDirect3DTexture9 ** | ppTexture,
 |  | DWORD | dwFlag
 | ) |  |

DESCRIPTION: Create a texture that is an alias of a surface registered with NvAPI. The new texture can be bound with IDirect3DDevice9::SetTexture(). Note that the texture must be unbound before drawing to the surface again. Unless the USE_SUPER flag is passed, MSAA surfaces will be resolved before being used as a texture. MSAA depth buffers are resolved with a point filter, and non-depth MSAA surfaces are resolved with a linear filter.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | pDev | The D3D device that owns the objects
[in] | pSurface | Pointer to a surface that has been registered with NvAPI to which a texture alias is to be provided
[out] | ppTexture | Fill with the texture created
[in] | dwFlag | NVAPI_ALIAS_SURFACE_FLAG to describe how to handle the texture
Return values:
NVAPI_OK | completed request
NVAPI_INVALID_POINTER | A null pointer was passed as an argument
NVAPI_INVALID_ARGUMENT | One of the arguments was invalid, probably dwFlag.
NVAPI_UNREGISTERED_RESOURCE | pSurface has not been registered with NvAPI
NVAPI_ERROR | error occurred
NVAPI_INTERFACE NvAPI_D3D9_ClearRT | ( | IDirect3DDevice9 * | pDevice,
 |  | NvU32 | dwNumRects,
 |  | CONST RECT * | pRects,
 |  | float | r,
 |  | float | g,
 |  | float | b,
 |  | float | a
 | ) |  |

DESCRIPTION: This API Clears the currently bound render target(s) with the given color

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | pDevice | The D3D device that owns the objects.
[in] | dwNumRects | The no of rectangles to clear. If 0, clear the entire surface (clipped to viewport)
[in] | pRects | Defines the rectangles to clear. Should be NULL if dwNumRects == 0
[in] | r | red component of the clear color
[in] | g | green component of the clear color
[in] | b | blue component of the clear color
[in] | a | alpha component of the clear color
Returns:
This API can return any of the error codes enumerated in NvAPI_Status.
NVAPI_INTERFACE NvAPI_D3D9_GetSurfaceHandle | ( | IDirect3DSurface9 * | pSurface,
 |  | NVDX_ObjectHandle * | pHandle
 | ) |  |

SUPPORTED OS: Windows XP and higher This function gets the handle of a given surface. This handle uniquely identifies the surface through all NvAPI entries.

Since:
Release: 313
Parameters:
[in] | pSurface | Surface to be identified
[out] | pHandle | Will be filled by the return handle
Returns:
An int which could be an NvAPI status or DX HRESULT code
NVAPI_INTERFACE NvAPI_D3D9_RegisterResource ( IDirect3DResource9 * pResource )

DESCRIPTION: This API binds a resource (surface/texture) so that it can be retrieved internally by NVAPI.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] pResource surface/texture
Returns:
NVAPI_OK, NVAPI_ERROR
NVAPI_INTERFACE NvAPI_D3D9_StretchRectEx | ( | IDirect3DDevice9 * | pDevice,
 |  | IDirect3DResource9 * | pSourceResource,
 |  | CONST RECT * | pSourceRect,
 |  | IDirect3DResource9 * | pDestResource,
 |  | CONST RECT * | pDestRect,
 |  | D3DTEXTUREFILTERTYPE | Filter
 | ) |  |

DESCRIPTION: This API copies the contents of the source resource to the destination resource. This function can convert between a wider range of surfaces than IDirect3DDevice9::StretchRect. For example, it can copy from a depth/stencil surface to a texture.

The source and destination resources *must* be registered with NvAPI before being used with NvAPI_D3D9_StretchRectEx().

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | pDevice | The D3D device that owns the objects.
[in] | pSourceResource | Pointer to the source resource.
[in] | pSrcRect | Defines the rectangle on the source to copy from. If NULL, copy from the entire resource.
[in] | pDestResource | Pointer to the destination resource.
[in] | pDstRect | Defines the rectangle on the destination to copy to. If NULL, copy to the entire resource.
[in] | Filter | Choose a filtering method: D3DTEXF_NONE, D3DTEXF_POINT, D3DTEXF_LINEAR.
Return values:
NVAPI_OK | completed request
NVAPI_INVALID_POINTER | An invalid pointer was passed as an argument (probably NULL)
NVAPI_INVALID_ARGUMENT | One of the arguments was invalid
NVAPI_UNREGISTERED_RESOURCE | a resource was passed in without being registered
NVAPI_ERROR | error occurred
NVAPI_INTERFACE NvAPI_D3D9_UnregisterResource ( IDirect3DResource9 * pResource )

DESCRIPTION: This API unbinds a resource (surface/texture) after use.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] pResource surface/texture
Returns:
NVAPI_OK, NVAPI_ERROR
NvAPI_D3D_BeginResourceRendering | ( | IUnknown * | pDev,
 |  | NVDX_ObjectHandle | obj,
 |  | NvU32 | Flags
 | ) |  |

DESCRIPTION: This function tells the driver that the resource will begin to receive updates. It must be used in combination with NvAPI_D3D_EndResourceRendering(). The primary use of this function is allow the driver to initiate early inter-frame synchronization of resources while running in AFR SLI mode.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in] | pDev | The ID3D10Device or IDirect3DDevice9 that is a using the resource
[in] | obj | Previously obtained HV resource handle
[in] | Flags | The flags for functionality applied to resource while being used.
Return values:
NVAPI_OK | Function succeeded, if used properly and driver can initiate proper sync'ing of the resources.
NVAPI_INVALID_ARGUMENT | Bad argument(s) or invalid flag values
NVAPI_INVALID_CALL | Mismatched begin/end calls
NVAPI_INTERFACE NvAPI_D3D_EndResourceRendering | ( | IUnknown * | pDev,
 |  | NVDX_ObjectHandle | obj,
 |  | NvU32 | Flags
 | ) |  |

DESCRIPTION: This function tells the driver that the resource is done receiving updates. It must be used in combination with NvAPI_D3D_BeginResourceRendering(). The primary use of this function is allow the driver to initiate early inter-frame syncs of resources while running in AFR SLI mode.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in] | pDev | The ID3D10Device or IDirect3DDevice9 thatis a using the resource
[in] | obj | Previously obtained HV resource handle
[in] | Flags | Reserved, must be zero
Return values:
NVAPI_OK | Function succeeded, if used properly and driver can initiate proper sync'ing of the resources.
NVAPI_INVALID_ARGUMENT | Bad argument(s) or invalid flag values
NVAPI_INVALID_CALL | Mismatched begin/end calls
NVAPI_INTERFACE NvAPI_D3D_GetCurrentSLIState | ( | IUnknown * | pDevice,
 |  | NV_GET_CURRENT_SLI_STATE * | pSliState
 | ) |  |

DESCRIPTION: This function returns the current SLI state for the specified device. The structure contains the number of AFR groups, the current AFR group index, and what the AFR group index will be for the next frame. pDevice can be either a IDirect3DDevice9 or ID3D10Device pointer.

SUPPORTED OS: Windows XP and higher

Since:
Release: 173
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Error occurred
NVAPI_INTERFACE NvAPI_D3D_GetObjectHandleForResource | ( | IUnknown * | pDevice,
 |  | IUnknown * | pResource,
 |  | NVDX_ObjectHandle * | pHandle
 | ) |  |

DESCRIPTION: This API gets a handle to a resource.

Parameters:
[in] | pDev | The ID3D11Device, ID3D10Device or IDirect3DDevice9 to use
[in] | pResource | The ID3D10Resource, ID3D10Resource or IDirect3DResource9 from which we want the NvAPI handle
[out] | pHandle | A handle to the resource

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Returns:
NVAPI_OK if the handle was populated.
NvAPI_D3D_ImplicitSLIControl ( __in IMPLICIT_SLI_CONTROL implicitSLIControl )

SUPPORTED OS: Windows 7 and higher

This function enables/disables the SLI rendering mode. It has to be called prior to D3D device creation. Once this function is called with DISABLE_IMPLICIT_SLI parameter all subsequently created devices will be forced to run in a single gpu mode until the same function is called with ENABLE_IMPLICIT_SLI parameter. The enable call will force all subsequently created devices to run in default implicit SLI mode being determined by an application profile or a global control panel SLI setting. This NvAPI call is supported in all DX10+ versions of the driver. It is supported on all Windows versions.

Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Error occurred
NVAPI_INTERFACE NvAPI_D3D_IsGSyncActive | ( | __in IUnknown * | pDeviceOrContext,
 |  | __in NVDX_ObjectHandle | primarySurface,
 |  | __out BOOL * | pIsGsyncActive
 | ) |  |

FUNCTION NAME: NvAPI_D3D_IsGSyncActive

DESCRIPTION: This API get the G-Sync state for the given device context. This is only reliable after the first present call has completed. As it is a bit time consuming, It should not be called per frame.

Parameters:
[in] | pDeviceOrContext | The D3D9, D3D10, D3D11 device, or D3D11 device context
[in] | NVDX_ObjectHandle | The handle of primary surface
[out] | pIsGsyncActive | if G-Sync is active, *pisGsyncActive is true.

SUPPORTED OS: Windows Vista and higher

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

NVAPI_INTERFACE NvAPI_D3D_IsGSyncCapable | ( | __in IUnknown * | pDeviceOrContext,
 |  | __in NVDX_ObjectHandle | primarySurface,
 |  | __out BOOL * | pIsGsyncCapable
 | ) |  |

FUNCTION NAME: NvAPI_D3D_IsGSyncCapable

DESCRIPTION: This API gets G-Sync capability for the given device context. This is only reliable after the first present call has completed.

Parameters:
[in] | pDeviceOrContext | The D3D9, D3D10, D3D11 device, or D3D11 device context
[in] | NVDX_ObjectHandle | The handle of primary surface
[out] | pIsGsyncCapable | if G-Sync can be enabled, *pIsGsyncCapable is true.

SUPPORTED OS: Windows Vista and higher

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

NVAPI_INTERFACE NvAPI_D3D_RegisterDevice ( __in IUnknown * pDev )

DESCRIPTION: Tells NvAPI about a D3D device. This must be called prior to using any DX1x deferred-context calls.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] pDev The ID3D10Device or ID3D11Device to use.

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

NVAPI_INTERFACE NvAPI_D3D_SetFPSIndicatorState | ( | IUnknown * | pDev,
 |  | NvU8 | doEnable
 | ) |  |

DESCRIPTION: Display an overlay that tracks the number of times the app presents per second, or, the number of frames-per-second (FPS)

SUPPORTED OS: Windows XP and higher

Parameters:
[in] bool Whether or not to enable the fps indicator.
Return values:
NVAPI_OK
NVAPI_ERROR
NvAPI_D3D_SetResourceHint | ( | IUnknown * | pDev,
 |  | NVDX_ObjectHandle | obj,
 |  | NVAPI_D3D_SETRESOURCEHINT_CATEGORY | dwHintCategory,
 |  | NvU32 | dwHintName,
 |  | NvU32 * | pdwHintValue
 | ) |  |

DESCRIPTION: This is a general purpose function for passing down various resource related hints to the driver. Hints are divided into categories and types within each category.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in] | pDev | The ID3D10Device or IDirect3DDevice9 that is a using the resource
[in] | obj | Previously obtained HV resource handle
[in] | dwHintCategory | Category of the hints
[in] | dwHintName | A hint within this category
[in] | *pdwHintValue | Pointer to location containing hint value
Returns:
an int which could be an NvAPI status or DX HRESULT code
Return values:
NVAPI_OK
NVAPI_INVALID_ARGUMENT
NVAPI_INVALID_CALL It is illegal to change a hint dynamically when the resource is already bound.


Data Structures | Defines | Typedefs | Enumerations | Functions
DirectX Video Control
DirectX APIs

Data Structures

struct | _NV_DX_VIDEO_STEREO_INFO

Defines

#define | NV_STEREO_VIDEO_FORMAT_DEFINE
#define | NV_DX_VIDEO_STEREO_INFO_VER MAKE_NVAPI_VERSION(NV_DX_VIDEO_STEREO_INFO,1)

Typedefs

typedef enum
_NV_STEREO_VIDEO_FORMAT 		NV_STEREO_VIDEO_FORMAT
typedef struct
_NV_DX_VIDEO_STEREO_INFO 		NV_DX_VIDEO_STEREO_INFO

Enumerations

enum _NV_STEREO_VIDEO_FORMAT {
NV_STEREO_VIDEO_FORMAT_NOT_STEREO = 0, NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR = 1, NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL = 2, NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR = 3,
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL = 4, NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR = 5, NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL = 6, NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR = 7,
NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET = 8, NV_STEREO_VIDEO_FORMAT_LAST = 9
}

Functions

NVAPI_INTERFACE | NvAPI_D3D9_VideoSetStereoInfo (IDirect3DDevice9 *pDev, NV_DX_VIDEO_STEREO_INFO *pStereoInfo)

Detailed Description

See also vidcontrol

SUPPORTED OS: Windows Vista and higher

Define Documentation

#define NV_DX_VIDEO_STEREO_INFO_VER MAKE_NVAPI_VERSION(NV_DX_VIDEO_STEREO_INFO,1)

Macro for constructing the version field of NV_DX_VIDEO_STEREO_INFO.

#define NV_STEREO_VIDEO_FORMAT_DEFINE

Typedef Documentation

typedef struct _NV_DX_VIDEO_STEREO_INFO NV_DX_VIDEO_STEREO_INFO
typedef enum _NV_STEREO_VIDEO_FORMAT NV_STEREO_VIDEO_FORMAT

Enumeration Type Documentation

enum _NV_STEREO_VIDEO_FORMAT
Enumerator:
NV_STEREO_VIDEO_FORMAT_NOT_STEREO
NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR
NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL
NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR
NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL
NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR
NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET
NV_STEREO_VIDEO_FORMAT_LAST

Function Documentation

NvAPI_D3D9_VideoSetStereoInfo | ( | IDirect3DDevice9 * | pDev,
 |  | NV_DX_VIDEO_STEREO_INFO * | pStereoInfo
 | ) |  |
   DESCRIPTION: This api specifies the stereo format of a surface, so that the
                surface could be used for stereo video processing or compositing.
                In particular, this api could be used to link the left and right
                views of a decoded picture.

 \since Release: 313

         INPUT: pDev        - The device on which the stereo surface will be used
                pStereoInfo - The stereo format of the surface

 \return  an int which could be an NvAPI status or DX HRESULT code


Typedefs | Enumerations
TV APIs

Typedefs

typedef enum _NV_DISPLAY_TV_FORMAT NV_DISPLAY_TV_FORMAT

Enumerations

enum _NV_DISPLAY_TV_FORMAT {
NV_DISPLAY_TV_FORMAT_NONE = 0, NV_DISPLAY_TV_FORMAT_SD_NTSCM = 0x00000001, NV_DISPLAY_TV_FORMAT_SD_NTSCJ = 0x00000002, NV_DISPLAY_TV_FORMAT_SD_PALM = 0x00000004,
NV_DISPLAY_TV_FORMAT_SD_PALBDGH = 0x00000008, NV_DISPLAY_TV_FORMAT_SD_PALN = 0x00000010, NV_DISPLAY_TV_FORMAT_SD_PALNC = 0x00000020, NV_DISPLAY_TV_FORMAT_SD_576i = 0x00000100,
NV_DISPLAY_TV_FORMAT_SD_480i = 0x00000200, NV_DISPLAY_TV_FORMAT_ED_480p = 0x00000400, NV_DISPLAY_TV_FORMAT_ED_576p = 0x00000800, NV_DISPLAY_TV_FORMAT_HD_720p = 0x00001000,
NV_DISPLAY_TV_FORMAT_HD_1080i = 0x00002000, NV_DISPLAY_TV_FORMAT_HD_1080p = 0x00004000, NV_DISPLAY_TV_FORMAT_HD_720p50 = 0x00008000, NV_DISPLAY_TV_FORMAT_HD_1080p24 = 0x00010000,
NV_DISPLAY_TV_FORMAT_HD_1080i50 = 0x00020000, NV_DISPLAY_TV_FORMAT_HD_1080p50 = 0x00040000, NV_DISPLAY_TV_FORMAT_UHD_4Kp30 = 0x00080000, NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp30,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25 = 0x00100000, NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp25, NV_DISPLAY_TV_FORMAT_UHD_4Kp24 = 0x00200000, NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp24,
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE = 0x00400000, NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 = 0x00800000, NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 = 0x00900000, NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 = 0x00A00000,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 = 0x00B00000, NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 = 0x00C00000, NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 = 0x00D00000, NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 = 0x00E00000,
NV_DISPLAY_TV_FORMAT_SD_OTHER = 0x01000000, NV_DISPLAY_TV_FORMAT_ED_OTHER = 0x02000000, NV_DISPLAY_TV_FORMAT_HD_OTHER = 0x04000000, NV_DISPLAY_TV_FORMAT_ANY = 0x80000000
}

Detailed Description

The TV APIs are used to retrieve TV-related information such as HDTV connector types, TV encoder types, and TV formats.

Typedef Documentation

typedef enum _NV_DISPLAY_TV_FORMAT NV_DISPLAY_TV_FORMAT

Used in NV_DISPLAY_TV_OUTPUT_INFO

Enumeration Type Documentation

enum _NV_DISPLAY_TV_FORMAT

Used in NV_DISPLAY_TV_OUTPUT_INFO

Enumerator:
NV_DISPLAY_TV_FORMAT_NONE
NV_DISPLAY_TV_FORMAT_SD_NTSCM
NV_DISPLAY_TV_FORMAT_SD_NTSCJ
NV_DISPLAY_TV_FORMAT_SD_PALM
NV_DISPLAY_TV_FORMAT_SD_PALBDGH
NV_DISPLAY_TV_FORMAT_SD_PALN
NV_DISPLAY_TV_FORMAT_SD_PALNC
NV_DISPLAY_TV_FORMAT_SD_576i
NV_DISPLAY_TV_FORMAT_SD_480i
NV_DISPLAY_TV_FORMAT_ED_480p
NV_DISPLAY_TV_FORMAT_ED_576p
NV_DISPLAY_TV_FORMAT_HD_720p
NV_DISPLAY_TV_FORMAT_HD_1080i
NV_DISPLAY_TV_FORMAT_HD_1080p
NV_DISPLAY_TV_FORMAT_HD_720p50
NV_DISPLAY_TV_FORMAT_HD_1080p24
NV_DISPLAY_TV_FORMAT_HD_1080i50
NV_DISPLAY_TV_FORMAT_HD_1080p50
NV_DISPLAY_TV_FORMAT_UHD_4Kp30
NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp25
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp24
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE
NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096
NV_DISPLAY_TV_FORMAT_SD_OTHER
NV_DISPLAY_TV_FORMAT_ED_OTHER
NV_DISPLAY_TV_FORMAT_HD_OTHER
NV_DISPLAY_TV_FORMAT_ANY


Modules
System APIs

Modules

System - General Interface


Data Structures | Defines | Enumerations | Functions
System - General Interface
System APIs

Data Structures

struct | NV_CHIPSET_INFO_v4
struct | NV_CHIPSET_INFO_v3
struct | NV_CHIPSET_INFO_v2
struct | NV_CHIPSET_INFO_v1
struct | NV_LID_DOCK_PARAMS

Defines

#define | NV_CHIPSET_INFO_VER_1 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v1,1)
#define | NV_CHIPSET_INFO_VER_2 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v2,2)
#define | NV_CHIPSET_INFO_VER_3 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v3,3)
#define | NV_CHIPSET_INFO_VER_4 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v4,4)
#define | NV_CHIPSET_INFO NV_CHIPSET_INFO_v4
#define | NV_CHIPSET_INFO_VER NV_CHIPSET_INFO_VER_4

Enumerations

enum | NV_CHIPSET_INFO_FLAGS { NV_CHIPSET_INFO_HYBRID = 0x00000001 }

Functions

NVAPI_INTERFACE | NvAPI_SYS_GetChipSetInfo (NV_CHIPSET_INFO *pChipSetInfo)
NVAPI_INTERFACE | NvAPI_SYS_GetLidAndDockInfo (NV_LID_DOCK_PARAMS *pLidAndDock)
NVAPI_INTERFACE | NvAPI_SYS_GetDisplayIdFromGpuAndOutputId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_SYS_GetGpuAndOutputIdFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu, NvU32 *outputId)
NVAPI_INTERFACE | NvAPI_SYS_GetPhysicalGpuFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu)

Detailed Description

The System APIs retrieve chipset information such as vendor/device name and IDs, and CPU information such as processor type, speed, embedded CPU name, etc.

Define Documentation

#define NV_CHIPSET_INFO NV_CHIPSET_INFO_v4
#define NV_CHIPSET_INFO_VER NV_CHIPSET_INFO_VER_4
#define NV_CHIPSET_INFO_VER_1 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v1,1)
#define NV_CHIPSET_INFO_VER_2 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v2,2)
#define NV_CHIPSET_INFO_VER_3 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v3,3)
#define NV_CHIPSET_INFO_VER_4 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v4,4)

Enumeration Type Documentation

enum NV_CHIPSET_INFO_FLAGS
Enumerator:
NV_CHIPSET_INFO_HYBRID

Function Documentation

NVAPI_INTERFACE NvAPI_SYS_GetChipSetInfo ( NV_CHIPSET_INFO * pChipSetInfo )

This function returns information about the system's chipset.

SUPPORTED OS: Windows XP and higher

Since:
Release: 95
Return values:
NVAPI_INVALID_ARGUMENT | pChipSetInfo is NULL.
NVAPI_OK | *pChipSetInfo is now set.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_CHIPSET_INFO version not compatible with driver.
NVAPI_INTERFACE NvAPI_SYS_GetDisplayIdFromGpuAndOutputId | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | outputId,
 |  | NvU32 * | displayId
 | ) |  |

DESCRIPTION: This API converts a Physical GPU handle and output ID to a display ID.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hPhysicalGpu | Handle to the physical GPU
[in] | outputId | Connected display output ID on the target GPU - must only have one bit set
[out] | displayId | Pointer to an NvU32 which contains the display ID
Return values:
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized
NVAPI_ERROR | - miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | - Invalid input parameter.
NVAPI_INTERFACE NvAPI_SYS_GetGpuAndOutputIdFromDisplayId | ( | NvU32 | displayId,
 |  | NvPhysicalGpuHandle * | hPhysicalGpu,
 |  | NvU32 * | outputId
 | ) |  |

DESCRIPTION: This API converts a display ID to a Physical GPU handle and output ID.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | displayId | Display ID of display to retrieve GPU and outputId for
[out] | hPhysicalGpu | Handle to the physical GPU
[out] | outputId | ) Connected display output ID on the target GPU will only have one bit set.
Return values:
NVAPI_OK
NVAPI_API_NOT_INTIALIZED
NVAPI_ID_OUT_OF_RANGE The DisplayId corresponds to a display which is not within the normal outputId range.
NVAPI_ERROR
NVAPI_INVALID_ARGUMENT
NVAPI_INTERFACE NvAPI_SYS_GetLidAndDockInfo ( NV_LID_DOCK_PARAMS * pLidAndDock )

DESCRIPTION: This function returns the current lid and dock information.

SUPPORTED OS: Windows XP and higher

Since:
Release: 177
Return values:
NVAPI_OK
NVAPI_ERROR
NVAPI_NOT_SUPPORTED
NVAPI_HANDLE_INVALIDATED
NVAPI_API_NOT_INTIALIZED
NVAPI_INTERFACE NvAPI_SYS_GetPhysicalGpuFromDisplayId | ( | NvU32 | displayId,
 |  | NvPhysicalGpuHandle * | hPhysicalGpu
 | ) |  |
    DESCRIPTION:     This API retrieves the Physical GPU handle of the connected display

    \since Release: 313

    SUPPORTED OS:  Windows Vista and higher

    PARAMETERS:      displayId(IN)     - Display ID of display to retrieve
                                         GPU handle
                     hPhysicalGpu(OUT) - Handle to the physical GPU

    RETURN STATUS:
                     NVAPI_OK - completed request
                     NVAPI_API_NOT_INTIALIZED - NVAPI not initialized
                     NVAPI_ERROR - miscellaneous error occurred
                     NVAPI_INVALID_ARGUMENT - Invalid input parameter.


Typedefs | Functions
OpenGL APIs

Typedefs

typedef void(* | NVAPI_OGLEXPERT_CALLBACK )(unsigned int categoryId, unsigned int messageId, unsigned int detailLevel, int objectId, const char *messageStr)

Functions

NVAPI_INTERFACE | NvAPI_OGL_ExpertModeSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask, NVAPI_OGLEXPERT_CALLBACK expertCallback)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask, NVAPI_OGLEXPERT_CALLBACK *pExpertCallback)

NvAPI_OGL_ExpertModeSet[Get] Functions

#define | NVAPI_OGLEXPERT_DETAIL_NONE 0x00000000
#define | NVAPI_OGLEXPERT_DETAIL_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_DETAIL_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_DETAIL_BASIC_INFO 0x00000004
#define | NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO 0x00000008
#define | NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING 0x00000010
#define | NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING 0x00000020
#define | NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING 0x00000040
#define | NVAPI_OGLEXPERT_DETAIL_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_REPORT_NONE 0x00000000
#define | NVAPI_OGLEXPERT_REPORT_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_REPORT_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX 0x00000004
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY 0x00000008
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB 0x00000010
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER 0x00000020
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT 0x00000040
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP 0x00000080
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER 0x00000100
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL 0x00000200
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE 0x00000400
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT 0x00000800
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE 0x00001000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM 0x00002000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_FBO 0x00004000
#define | NVAPI_OGLEXPERT_REPORT_FEATURE_SLI 0x00008000
#define | NVAPI_OGLEXPERT_REPORT_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_OUTPUT_TO_NONE 0x00000000
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE 0x00000001
#define | NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER 0x00000004
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK 0x00000008
#define | NVAPI_OGLEXPERT_OUTPUT_TO_ALL 0xFFFFFFFF

NvAPI_OGL_ExpertModeDefaultsSet[Get] Functions

NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask)

Detailed Description

The OpenGL APIs configure OpenGL Expert Mode, an API usage feedback and advice reporting mechanism.

This function configures OpenGL Expert Mode, an API usage feedback and advice reporting mechanism. The effects of this call are applied only to the current context, and are reset to the defaults when the context is destroyed.

Note:
This feature is valid at runtime only when GLExpert functionality has been built into the OpenGL driver installed on the system. All Windows Vista OpenGL drivers provided by NVIDIA have this instrumentation included by default. Windows XP, however, requires a special display driver available with the NVIDIA PerfSDK found at developer.nvidia.com.
These functions are valid only for the current OpenGL context. Calling these functions prior to creating a context and calling MakeCurrent with it will result in errors and undefined behavior.

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Parameters:
expertDetailMask | Mask made up of NVAPI_OGLEXPERT_DETAIL bits, this parameter specifies the detail level in the feedback stream.
expertReportMask | Mask made up of NVAPI_OGLEXPERT_REPORT bits, this parameter specifies the areas of functional interest.
expertOutputMask | Mask made up of NVAPI_OGLEXPERT_OUTPUT bits, this parameter specifies the feedback output location.
expertCallback | Used in conjunction with OUTPUT_TO_CALLBACK, this is a simple callback function the user may use to obtain the feedback stream. The function will be called once per fully qualified feedback stream extry.
Return values:
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU found
NVAPI_OPENGL_CONTEXT_NOT_CURRENT | No NVIDIA OpenGL context which supports GLExpert has been made current
NVAPI_ERROR | OpenGL driver failed to load properly
NVAPI_OK | Success

SUPPORTED OS: Windows XP and higher

Define Documentation

#define NVAPI_OGLEXPERT_DETAIL_ALL 0xFFFFFFFF
#define NVAPI_OGLEXPERT_DETAIL_BASIC_INFO 0x00000004
#define NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO 0x00000008
#define NVAPI_OGLEXPERT_DETAIL_ERROR 0x00000001
#define NVAPI_OGLEXPERT_DETAIL_NONE 0x00000000
#define NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING 0x00000010
#define NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING 0x00000020
#define NVAPI_OGLEXPERT_DETAIL_SWFALLBACK 0x00000002
#define NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING 0x00000040
#define NVAPI_OGLEXPERT_OUTPUT_TO_ALL 0xFFFFFFFF
#define NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK 0x00000008
#define NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE 0x00000001
#define NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER 0x00000004
#define NVAPI_OGLEXPERT_OUTPUT_TO_NONE 0x00000000
#define NVAPI_OGLEXPERT_REPORT_ALL 0xFFFFFFFF
#define NVAPI_OGLEXPERT_REPORT_ERROR 0x00000001
#define NVAPI_OGLEXPERT_REPORT_FEATURE_SLI 0x00008000
#define NVAPI_OGLEXPERT_REPORT_NONE 0x00000000
#define NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT 0x00000800
#define NVAPI_OGLEXPERT_REPORT_OBJECT_FBO 0x00004000
#define NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM 0x00002000
#define NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE 0x00001000
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT 0x00000040
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER 0x00000100
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY 0x00000008
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL 0x00000200
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER 0x00000020
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP 0x00000080
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE 0x00000400
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX 0x00000004
#define NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB 0x00000010
#define NVAPI_OGLEXPERT_REPORT_SWFALLBACK 0x00000002

Typedef Documentation

typedef void(* NVAPI_OGLEXPERT_CALLBACK)(unsigned int categoryId, unsigned int messageId, unsigned int detailLevel, int objectId, const char *messageStr)

DESCRIPTION: Used in conjunction with OUTPUT_TO_CALLBACK, this is a simple callback function the user may use to obtain the feedback stream. The function will be called once per fully qualified feedback stream entry.

Parameters:
categoryId | Contains the bit from the NVAPI_OGLEXPERT_REPORT mask that corresponds to the current message
messageId | Unique ID for the current message
detailLevel | Contains the bit from the NVAPI_OGLEXPERT_DETAIL mask that corresponds to the current message
objectId | Unique ID of the object that corresponds to the current message
messageStr | Text string from the current message

Function Documentation

NVAPI_INTERFACE NvAPI_OGL_ExpertModeDefaultsGet | ( | NvU32 * | pExpertDetailLevel,
 |  | NvU32 * | pExpertReportMask,
 |  | NvU32 * | pExpertOutputMask
 | ) |  |

This function configures OpenGL Expert Mode global defaults. These settings apply to any OpenGL application which starts up after these values are applied (i.e. these settings *do not* apply to currently running applications).

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Parameters:
expertDetailLevel | Value which specifies the detail level in the feedback stream. This is a mask made up of NVAPI_OGLEXPERT_LEVEL bits.
expertReportMask | Mask made up of NVAPI_OGLEXPERT_REPORT bits, this parameter specifies the areas of functional interest.
expertOutputMask | Mask made up of NVAPI_OGLEXPERT_OUTPUT bits, this parameter specifies the feedback output location. Note that using OUTPUT_TO_CALLBACK here is meaningless and has no effect, but using it will not cause an error.
Returns:
NVAPI_ERROR or NVAPI_OK SUPPORTED OS: Windows XP and higher
NVAPI_INTERFACE NvAPI_OGL_ExpertModeDefaultsSet | ( | NvU32 | expertDetailLevel,
 |  | NvU32 | expertReportMask,
 |  | NvU32 | expertOutputMask
 | ) |  |

This function configures OpenGL Expert Mode global defaults. These settings apply to any OpenGL application which starts up after these values are applied (i.e. these settings *do not* apply to currently running applications).

SUPPORTED OS: Windows XP and higher

Since:
Release: 80
Parameters:
expertDetailLevel | Value which specifies the detail level in the feedback stream. This is a mask made up of NVAPI_OGLEXPERT_LEVEL bits.
expertReportMask | Mask made up of NVAPI_OGLEXPERT_REPORT bits, this parameter specifies the areas of functional interest.
expertOutputMask | Mask made up of NVAPI_OGLEXPERT_OUTPUT bits, this parameter specifies the feedback output location. Note that using OUTPUT_TO_CALLBACK here is meaningless and has no effect, but using it will not cause an error.
Returns:
NVAPI_ERROR or NVAPI_OK SUPPORTED OS: Windows XP and higher
NVAPI_INTERFACE NvAPI_OGL_ExpertModeGet | ( | NvU32 * | pExpertDetailLevel,
 |  | NvU32 * | pExpertReportMask,
 |  | NvU32 * | pExpertOutputMask,
 |  | NVAPI_OGLEXPERT_CALLBACK * | pExpertCallback
 | ) |  |
NVAPI_INTERFACE NvAPI_OGL_ExpertModeSet | ( | NvU32 | expertDetailLevel,
 |  | NvU32 | expertReportMask,
 |  | NvU32 | expertOutputMask,
 |  | NVAPI_OGLEXPERT_CALLBACK | expertCallback
 | ) |  |

SUPPORTED OS: Windows XP and higher


Data Structures | Defines | Typedefs | Enumerations | Functions
I2C APIs

Data Structures

struct | NV_I2C_INFO_V1
Used in NvAPI_I2CRead() and NvAPI_I2CWrite() More...
struct | NV_I2C_INFO_V2
Used in NvAPI_I2CRead() and NvAPI_I2CWrite() More...
struct | NV_I2C_INFO_V3
Used in NvAPI_I2CRead() and NvAPI_I2CWrite() More...

Defines

#define | NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER 4096
#define | NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4
#define | NVAPI_DISPLAY_DEVICE_MASK_MAX 24
#define | NVAPI_I2C_SPEED_DEPRECATED 0xFFFF
#define | NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)
#define | NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)
#define | NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)
#define | NV_I2C_INFO_VER NV_I2C_INFO_VER3

Typedefs

typedef NV_I2C_INFO_V3 | NV_I2C_INFO

Enumerations

enum NV_I2C_SPEED {
NVAPI_I2C_SPEED_DEFAULT, NVAPI_I2C_SPEED_3KHZ, NVAPI_I2C_SPEED_10KHZ, NVAPI_I2C_SPEED_33KHZ,
NVAPI_I2C_SPEED_100KHZ, NVAPI_I2C_SPEED_200KHZ, NVAPI_I2C_SPEED_400KHZ
}

Functions

NVAPI_INTERFACE | NvAPI_I2CRead (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)
NVAPI_INTERFACE | NvAPI_I2CWrite (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)

Detailed Description

The I2C APIs are used to read or write data to DDC monitors using the I2C protocol.

Define Documentation

#define NV_I2C_INFO_VER NV_I2C_INFO_VER3
#define NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)
#define NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)
#define NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)
#define NVAPI_DISPLAY_DEVICE_MASK_MAX 24
#define NVAPI_I2C_SPEED_DEPRECATED 0xFFFF
#define NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER 4096
#define NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4

Typedef Documentation

typedef NV_I2C_INFO_V3 NV_I2C_INFO

Enumeration Type Documentation

enum NV_I2C_SPEED
Enumerator:
NVAPI_I2C_SPEED_DEFAULT

Set i2cSpeedKhz to I2C_SPEED_DEFAULT if default I2C speed is to be chosen, ie.use the current frequency setting.

NVAPI_I2C_SPEED_3KHZ
NVAPI_I2C_SPEED_10KHZ
NVAPI_I2C_SPEED_33KHZ
NVAPI_I2C_SPEED_100KHZ
NVAPI_I2C_SPEED_200KHZ
NVAPI_I2C_SPEED_400KHZ

Function Documentation

NVAPI_INTERFACE NvAPI_I2CRead | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_I2C_INFO * | pI2cInfo
 | ) |  |

This function reads the data buffer from the I2C port. The I2C request must be for a DDC port: pI2cInfo->bIsDDCPort = 1.

A data buffer size larger than 16 bytes may be rejected if a register address is specified. In such a case, NVAPI_ARGUMENT_EXCEED_MAX_SIZE would be returned.

If a register address is specified (i.e. regAddrSize is positive), then the transaction will be performed in the combined format described in the I2C specification. The register address will be written, followed by reading into the data buffer.

SUPPORTED OS: Windows XP and higher

Since:
Release: 85
Parameters:
[in] | hPhysicalGpu | GPU selection.
[out] | *pI2cInfo | The I2C data input structure
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Structure version is not supported.
NVAPI_INVALID_ARGUMENT | - argument does not meet specified requirements
NVAPI_ARGUMENT_EXCEED_MAX_SIZE | - an argument exceeds the maximum
NVAPI_INTERFACE NvAPI_I2CWrite | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_I2C_INFO * | pI2cInfo
 | ) |  |

This function writes the data buffer to the I2C port.

The I2C request must be for a DDC port: pI2cInfo->bIsDDCPort = 1.

A data buffer size larger than 16 bytes may be rejected if a register address is specified. In such a case, NVAPI_ARGUMENT_EXCEED_MAX_SIZE would be returned.

If a register address is specified (i.e. regAddrSize is positive), then the register address will be written and the data buffer will immediately follow without a restart.

SUPPORTED OS: Windows XP and higher

Since:
Release: 85
Parameters:
[in] | hPhysicalGpu | GPU selection.
[in] | pI2cInfo | The I2C data input structure
Return values:
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Structure version is not supported.
NVAPI_INVALID_ARGUMENT | Argument does not meet specified requirements
NVAPI_ARGUMENT_EXCEED_MAX_SIZE | Argument exceeds the maximum


Data Structures | Defines | Typedefs | Enumerations | Functions
Mosaic APIs

Data Structures

struct | NV_MOSAIC_TOPO_DETAILS
This structure defines the topology details. More...
struct | NV_MOSAIC_TOPO_BRIEF
struct | _NV_MOSAIC_DISPLAY_SETTING_V1
Basic per-display settings that are used in setting/getting the Mosaic mode. More...
struct | NV_MOSAIC_DISPLAY_SETTING_V2
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
so arrays are bound. More...
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
struct | NV_MOSAIC_TOPO_GROUP
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
struct | NV_MOSAIC_DISPLAY_TOPO_STATUS
struct | NV_MOSAIC_TOPOLOGY
Used in NvAPI_GetCurrentMosaicTopology() and NvAPI_SetCurrentMosaicTopology(). More...
struct | NV_MOSAIC_SUPPORTED_TOPOLOGIES
Used in NvAPI_GetSupportedMosaicTopologies(). More...

Defines

#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NV_MOSAIC_TOPO_VALIDITY_VALID 0x00000000
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU 0x00000001
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY 0x00000002
#define | NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES 0x00000004
#define | NVAPI_MOSAIC_TOPO_DETAILS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_DETAILS,1)
#define | NVAPI_MOSAIC_TOPO_BRIEF_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_BRIEF,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V1,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V2,2)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER NVAPI_MOSAIC_DISPLAY_SETTING_VER2
#define | NV_MOSAIC_DISPLAY_SETTINGS_MAX 40
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V1,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V2,2)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2
#define | NV_MOSAIC_TOPO_IDX_DEFAULT 0
#define | NV_MOSAIC_TOPO_IDX_LEFT_EYE 0
#define | NV_MOSAIC_TOPO_IDX_RIGHT_EYE 1
#define | NV_MOSAIC_TOPO_NUM_EYES 2
#define | NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP 2
#define | NVAPI_MOSAIC_TOPO_GROUP_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_GROUP,1)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY NV_BIT(0)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION NV_BIT(0)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED NV_BIT(1)
#define | NV_MOSAIC_DISPLAY_TOPO_STATUS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_TOPO_STATUS,1)
#define | NVAPI_MAX_MOSAIC_TOPOS 16
#define | NVAPI_MOSAIC_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPOLOGY,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPOLOGIES,1)

Typedefs

typedef struct
_NV_MOSAIC_DISPLAY_SETTING_V1 		NV_MOSAIC_DISPLAY_SETTING_V1
typedef struct
NV_MOSAIC_DISPLAY_SETTING_V2 		NV_MOSAIC_DISPLAY_SETTING_V2
typedef
NV_MOSAIC_DISPLAY_SETTING_V2 		NV_MOSAIC_DISPLAY_SETTING
typedef struct
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 		NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
typedef struct
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 		NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
typedef
NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 		NV_MOSAIC_SUPPORTED_TOPO_INFO

Enumerations

enum NV_MOSAIC_TOPO_TYPE {
NV_MOSAIC_TOPO_TYPE_ALL, NV_MOSAIC_TOPO_TYPE_BASIC, NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO, NV_MOSAIC_TOPO_TYPE_SCALED_CLONE,
NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE, NV_MOSAIC_TOPO_TYPE_MAX
}
enum NV_MOSAIC_TOPO {
NV_MOSAIC_TOPO_NONE, NV_MOSAIC_TOPO_BEGIN_BASIC, NV_MOSAIC_TOPO_1x2_BASIC = NV_MOSAIC_TOPO_BEGIN_BASIC, NV_MOSAIC_TOPO_2x1_BASIC,
NV_MOSAIC_TOPO_1x3_BASIC, NV_MOSAIC_TOPO_3x1_BASIC, NV_MOSAIC_TOPO_1x4_BASIC, NV_MOSAIC_TOPO_4x1_BASIC,
NV_MOSAIC_TOPO_2x2_BASIC, NV_MOSAIC_TOPO_2x3_BASIC, NV_MOSAIC_TOPO_2x4_BASIC, NV_MOSAIC_TOPO_3x2_BASIC,
NV_MOSAIC_TOPO_4x2_BASIC, NV_MOSAIC_TOPO_1x5_BASIC, NV_MOSAIC_TOPO_1x6_BASIC, NV_MOSAIC_TOPO_7x1_BASIC,
NV_MOSAIC_TOPO_END_BASIC = NV_MOSAIC_TOPO_7x1_BASIC + 9, NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO, NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO = NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO, NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO,
NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO, NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO, NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO, NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO,
NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO, NV_MOSAIC_TOPO_END_PASSIVE_STEREO = NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO + 4, NV_MOSAIC_TOPO_MAX
}

Functions

NVAPI_INTERFACE | NvAPI_Mosaic_GetSupportedTopoInfo (NV_MOSAIC_SUPPORTED_TOPO_INFO *pSupportedTopoInfo, NV_MOSAIC_TOPO_TYPE type)
NVAPI_INTERFACE | NvAPI_Mosaic_GetTopoGroup (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_TOPO_GROUP *pTopoGroup)
NVAPI_INTERFACE | NvAPI_Mosaic_GetOverlapLimits (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pMinOverlapX, NvS32 *pMaxOverlapX, NvS32 *pMinOverlapY, NvS32 *pMaxOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_SetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 overlapX, NvS32 overlapY, NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_GetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pOverlapX, NvS32 *pOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_EnableCurrentTopo (NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_ValidateDisplayGrids (__in NvU32 setTopoFlags, __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout_ecount_full(gridCount) NV_MOSAIC_DISPLAY_TOPO_STATUS *pTopoStatus, __in NvU32 gridCount)
NVAPI_INTERFACE | NvAPI_Mosaic_EnumDisplayGrids (__inout_ecount_part_opt(*pGridCount,*pGridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout NvU32 *pGridCount)
NVAPI_INTERFACE | NvAPI_GetSupportedMosaicTopologies (NV_MOSAIC_SUPPORTED_TOPOLOGIES *pMosaicTopos)
NVAPI_INTERFACE | NvAPI_GetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo, NvU32 *pEnabled)
NVAPI_INTERFACE | NvAPI_SetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo)
NVAPI_INTERFACE | NvAPI_EnableCurrentMosaicTopology (NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_GetDisplayViewportsByResolution (NvU32 displayId, NvU32 srcWidth, NvU32 srcHeight, NV_RECT viewports[NV_MOSAIC_MAX_DISPLAYS], NvU8 *bezelCorrected)
typedef struct
_NV_MOSAIC_GRID_TOPO_DISPLAY_V1 		NV_MOSAIC_GRID_TOPO_DISPLAY_V1

Detailed Description

MOSAIC mode allows multi-display target scan out from a single source.

The following is an example of a MOSAIC 1x4 topology with 8-pixel horizontal overlap:

//!+----------------------++----------------------++----------------------++----------------------+
//!|                    ->||<- 8 pixels           ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|       DVI1           ||          DVI2        ||         DVI3         ||        DVI4          |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!+----------------------++----------------------++----------------------++----------------------+
//!

Define Documentation

#define NV_MOSAIC_DISPLAY_SETTINGS_MAX 40

Set a reasonable maximum number of display settings to support

#define NV_MOSAIC_DISPLAY_TOPO_STATUS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_TOPO_STATUS,1)
#define NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION NV_BIT(0)

Indicates that a display's position in the grid is sub-optimal.

#define NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED NV_BIT(1)

Indicates that SetDisplaySettings would need to perform a driver reload.

#define NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP 2

This defines the maximum number of topos that can be in a topo group. At this time, it is set to 2 because our largest topo group (passive stereo) only needs 2 topos (left eye and right eye).

If a new topo group with more than 2 topos is added above, then this number will also have to be incremented.

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY NV_BIT(0)

DESCRIPTION: Sets a new display topology, replacing any existing topologies that use the same displays.

This function will look for an SLI configuration that will allow the display topology to work.

To revert to a single display, specify that display as a 1x1 grid.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | pGridTopologies | The topology details to set.
[in] | gridCount | The number of elements in the pGridTopologies array.
[in] | setTopoFlags | Zero or more of the NVAPI_MOSAIC_SETDISPLAYTOPO_FLAG_* flags.
Return values:
NVAPI_OK | Capabilities have been returned.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | No matching GPU topologies could be found.
NVAPI_TOPO_NOT_POSSIBLE | One or more of the display grids are not valid.
NVAPI_ERROR | Miscellaneous error occurred Do not change the current GPU topology. If the NO_DRIVER_RELOAD bit is not specified, then it may still require a driver reload.
#define NV_MOSAIC_TOPO_IDX_DEFAULT 0
#define NV_MOSAIC_TOPO_IDX_LEFT_EYE 0
#define NV_MOSAIC_TOPO_IDX_RIGHT_EYE 1
#define NV_MOSAIC_TOPO_NUM_EYES 2
#define NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY 0x00000002

topology. hPhysicalGPU will be 0 for these.

Not enough displays were found to fill the entire

#define NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU 0x00000001

Not enough SLI GPUs were found to fill the entire

#define NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES 0x00000004

topology. displayOutputId will be 0 for these.

The topoogy is only possible with displays of the same

#define NV_MOSAIC_TOPO_VALIDITY_VALID 0x00000000

The topology is valid.

#define NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8

Used in NV_MOSAIC_TOPOLOGY.

#define NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8

Used in NV_MOSAIC_TOPOLOGY.

#define NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8

Used in NV_MOSAIC_TOPOLOGY.

#define NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8

Used in NV_MOSAIC_TOPOLOGY.

#define NVAPI_MAX_MOSAIC_TOPOS 16

Used in NV_MOSAIC_TOPOLOGY.

#define NVAPI_MOSAIC_DISPLAY_SETTING_VER NVAPI_MOSAIC_DISPLAY_SETTING_VER2
#define NVAPI_MOSAIC_DISPLAY_SETTING_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V1,1)

Macro for constructing the version field of NV_MOSAIC_DISPLAY_SETTING.

#define NVAPI_MOSAIC_DISPLAY_SETTING_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V2,2)
#define NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2
#define NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V1,1)

Macro forconstructing the version field of NV_MOSAIC_SUPPORTED_TOPO_INFO.

#define NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V2,2)
#define NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPOLOGIES,1)

Used in NV_MOSAIC_SUPPORTED_TOPOLOGIES.

#define NVAPI_MOSAIC_TOPO_BRIEF_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_BRIEF,1)

Macro for constructing the version field of NV_MOSAIC_TOPO_BRIEF.

#define NVAPI_MOSAIC_TOPO_DETAILS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_DETAILS,1)

Macro for constructing te vesion field of NV_MOSAIC_TOPO_DETAILS.

#define NVAPI_MOSAIC_TOPO_GROUP_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_GROUP,1)

Macro for constructing the version field of NV_MOSAIC_TOPO_GROUP.

#define NVAPI_MOSAIC_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPOLOGY,1)

Used in NV_MOSAIC_TOPOLOGY.

Typedef Documentation

typedef NV_MOSAIC_DISPLAY_SETTING_V2 NV_MOSAIC_DISPLAY_SETTING
typedef struct _NV_MOSAIC_DISPLAY_SETTING_V1 NV_MOSAIC_DISPLAY_SETTING_V1

Basic per-display settings that are used in setting/getting the Mosaic mode.

typedef struct NV_MOSAIC_DISPLAY_SETTING_V2 NV_MOSAIC_DISPLAY_SETTING_V2
typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 NV_MOSAIC_GRID_TOPO_DISPLAY_V1

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

typedef NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 NV_MOSAIC_SUPPORTED_TOPO_INFO
typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 NV_MOSAIC_SUPPORTED_TOPO_INFO_V1

so arrays are bound.

This structure is used to contain a list of supported Mosaic topologies along with the display settings that can be used.

typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 NV_MOSAIC_SUPPORTED_TOPO_INFO_V2

Enumeration Type Documentation

enum NV_MOSAIC_TOPO

This is a complete list of supported Mosaic topologies.

Using a "Basic" topology combines multiple monitors to create a single desktop.

Using a "Passive" topology combines multiples monitors to create a passive stereo desktop. In passive stereo, two identical topologies combine - one topology is used for the right eye and the other identical //! topology (targeting different displays) is used for the left eye.
NOTE: common\inc\nvEscDef.h shadows a couple PASSIVE_STEREO enums. If this enum list changes and effects the value of NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO please update the corresponding value in nvEscDef.h

Enumerator:
NV_MOSAIC_TOPO_NONE
NV_MOSAIC_TOPO_BEGIN_BASIC
NV_MOSAIC_TOPO_1x2_BASIC
NV_MOSAIC_TOPO_2x1_BASIC
NV_MOSAIC_TOPO_1x3_BASIC
NV_MOSAIC_TOPO_3x1_BASIC
NV_MOSAIC_TOPO_1x4_BASIC
NV_MOSAIC_TOPO_4x1_BASIC
NV_MOSAIC_TOPO_2x2_BASIC
NV_MOSAIC_TOPO_2x3_BASIC
NV_MOSAIC_TOPO_2x4_BASIC
NV_MOSAIC_TOPO_3x2_BASIC
NV_MOSAIC_TOPO_4x2_BASIC
NV_MOSAIC_TOPO_1x5_BASIC
NV_MOSAIC_TOPO_1x6_BASIC
NV_MOSAIC_TOPO_7x1_BASIC
NV_MOSAIC_TOPO_END_BASIC
NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO
NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO
NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO
NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO
NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO
NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO
NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO
NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO
NV_MOSAIC_TOPO_END_PASSIVE_STEREO
NV_MOSAIC_TOPO_MAX

Total number of topologies.

enum NV_MOSAIC_TOPO_TYPE

These values refer to the different types of Mosaic topologies that are possible. When getting the supported Mosaic topologies, you can specify one of these types to narrow down the returned list to only those that match the given type.

Enumerator:
NV_MOSAIC_TOPO_TYPE_ALL

All mosaic topologies.

NV_MOSAIC_TOPO_TYPE_BASIC

Basic Mosaic topologies.

NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO

Passive Stereo topologies.

NV_MOSAIC_TOPO_TYPE_SCALED_CLONE

Not supported at this time.

NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE

Not supported at this time.

NV_MOSAIC_TOPO_TYPE_MAX

Always leave this at end of the enum.

Function Documentation

NVAPI_INTERFACE NvAPI_EnableCurrentMosaicTopology ( NvU32 enable )

DESCRIPTION: This API enables or disables the current Mosaic topology. When enabling, the last Mosaic topology will be set.

  • If enabled, enumeration of display settings will include valid Mosaic resolutions.
  • If disabled, enumeration of display settings will not include Mosaic resolutions.

SUPPORTED OS: Windows XP

Since:
Release: 177
Parameters:
[in] enable TRUE to enable the Mosaic Topology, FALSE to disable it.
Return values:
NVAPI_OK | Call succeeded
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.
NVAPI_INTERFACE NvAPI_GetCurrentMosaicTopology | ( | NV_MOSAIC_TOPOLOGY * | pMosaicTopo,
 |  | NvU32 * | pEnabled
 | ) |  |

DESCRIPTION: This API gets the current Mosaic topology.

SUPPORTED OS: Windows XP

Since:
Release: 177
Parameters:
[out] | pMosaicTopo | The current Mosaic topology
[out] | pEnabled | TRUE if returned topology is currently enabled, else FALSE
Return values:
NVAPI_OK | Call succeeded
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.
NVAPI_INTERFACE NvAPI_GetSupportedMosaicTopologies ( NV_MOSAIC_SUPPORTED_TOPOLOGIES * pMosaicTopos )

DESCRIPTION: This API returns all valid Mosaic topologies.

SUPPORTED OS: Windows XP

Since:
Release: 177
Parameters:
[out] pMosaicTopos An array of valid Mosaic topologies.
Return values:
NVAPI_OK | Call succeeded; 1 or more topologies were returned
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_MIXED_TARGET_TYPES | Mosaic topology is only possible with all targets of the same NV_GPU_OUTPUT_TYPE.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.
NVAPI_INTERFACE NvAPI_Mosaic_EnableCurrentTopo ( NvU32 enable )

DESCRIPTION: This API enables or disables the current Mosaic topology based on the setting of the incoming 'enable' parameter.

An "enable" setting enables the current (previously set) Mosaic topology. Note that when the current Mosaic topology is retrieved, it must have an isPossible value of 1 or an error will occur.

A "disable" setting disables the current Mosaic topology. The topology information will persist, even across reboots. To re-enable the Mosaic topology, call this function again with the enable parameter set to 1.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in] enable 1 to enable the current Mosaic topo, 0 to disable it.
Return values:
NVAPI_OK | The Mosaic topo was enabled/disabled.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more arguments passed in are invalid.
NVAPI_TOPO_NOT_POSSIBLE | The current topology is not currently possible.
NVAPI_MODE_CHANGE_FAILED | There was an error changing the display mode.
NVAPI_ERROR,: Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_Mosaic_EnumDisplayGrids | ( | __inout_ecount_part_opt *,*pGridCount NV_MOSAIC_GRID_TOPO * | pGridTopologies,
 |  | __inout NvU32 * | pGridCount
 | ) |  |

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Enumerates the current active grid topologies. This includes Mosaic, IG, and Panoramic topologies, as well as single displays.

If pGridTopologies is NULL, then pGridCount will be set to the number of active grid topologies.

If pGridTopologies is not NULL, then pGridCount contains the maximum number of grid topologies to return. On return, pGridCount will be set to the number of grid topologies that were returned.

Parameters:
[out] | pGridTopologies | The list of active grid topologies.
[in,out] | pGridCount | A pointer to the number of grid topologies returned.
Return values:
NVAPI_OK | Capabilties have been returned.
NVAPI_END_ENUMERATION | There are no more topologies to return.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INTERFACE NvAPI_Mosaic_GetCurrentTopo | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_DISPLAY_SETTING * | pDisplaySetting,
 |  | NvS32 * | pOverlapX,
 |  | NvS32 * | pOverlapY
 | ) |  |

DESCRIPTION: This API returns information for the current Mosaic topology. This includes topology, display settings, and overlap values.

You can call NvAPI_Mosaic_GetTopoGroup() with the topology if you require more information.

If there isn't a current topology, then pTopoBrief->topo will be NV_MOSAIC_TOPO_NONE.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[out] | pTopoBrief | The current Mosaic topology
[out] | pDisplaySetting | The current per-display settings
[out] | pOverlapX | The pixel overlap between horizontal displays
[out] | pOverlapY | The pixel overlap between vertical displays
Return values:
NVAPI_OK | Success getting current info.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entry point not available.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_Mosaic_GetDisplayViewportsByResolution | ( | NvU32 | displayId,
 |  | NvU32 | srcWidth,
 |  | NvU32 | srcHeight,
 |  | NV_RECT | viewports[NV_MOSAIC_MAX_DISPLAYS],
 |  | NvU8 * | bezelCorrected
 | ) |  |

SUPPORTED OS: Windows Vista and higher DESCRIPTION: This API returns the viewports that would be applied on the requested display.

Parameters:
[in] | displayId | Display ID of a single display in the active mosaic topology to query.
[in] | srcWidth | Width of full display topology. If both width and height are 0, the current resolution is used.
[in] | srcHeight | Height of full display topology. If both width and height are 0, the current resolution is used.
[out] | viewports | Array of NV_RECT viewports which represent the displays as identified in NvAPI_Mosaic_EnumGridTopologies. If the requested resolution is a single-wide resolution, only viewports[0] will contain the viewport details, regardless of which display is driving the display.
[out] | bezelCorrected | Returns 1 if the requested resolution is bezel corrected. May be NULL.
Return values:
NVAPI_OK | Capabilties have been returned.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_MOSAIC_NOT_ACTIVE | The display does not belong to an active Mosaic Topology
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INTERFACE NvAPI_Mosaic_GetOverlapLimits | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_DISPLAY_SETTING * | pDisplaySetting,
 |  | NvS32 * | pMinOverlapX,
 |  | NvS32 * | pMaxOverlapX,
 |  | NvS32 * | pMinOverlapY,
 |  | NvS32 * | pMaxOverlapY
 | ) |  |

DESCRIPTION: This API returns the X and Y overlap limits required if the given Mosaic topology and display settings are to be used.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in] | pTopoBrief | The topology for getting limits This must be one of the topo briefs returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[in] | pDisplaySetting | The display settings for getting the limits. This must be one of the settings returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[out] | pMinOverlapX | X overlap minimum
[out] | pMaxOverlapX | X overlap maximum
[out] | pMinOverlapY | Y overlap minimum
[out] | pMaxOverlapY | Y overlap maximum
Return values:
NVAPI_OK | Details were retrieved successfully.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not compatible with this entry point.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_Mosaic_GetSupportedTopoInfo | ( | NV_MOSAIC_SUPPORTED_TOPO_INFO * | pSupportedTopoInfo,
 |  | NV_MOSAIC_TOPO_TYPE | type
 | ) |  |

DESCRIPTION: This API returns information on the topologies and display resolutions supported by Mosaic mode.

NOTE: Not all topologies returned can be set immediately. See 'OUT' Notes below.

Once you get the list of supported topologies, you can call NvAPI_Mosaic_GetTopoGroup() with one of the Mosaic topologies if you need more information about it.

'IN' Notes: pSupportedTopoInfo->version must be set before calling this function. If the specified version is not supported by this implementation, an error will be returned (NVAPI_INCOMPATIBLE_STRUCT_VERSION).

'OUT' Notes: Some of the topologies returned might not be valid for one reason or another. It could be due to mismatched or missing displays. It could also be because the required number of GPUs is not found. At a high level, you can see if the topology is valid and can be enabled by looking at the pSupportedTopoInfo->topoBriefs[xxx].isPossible flag. If this is true, the topology can be enabled. If it is false, you can find out why it cannot be enabled by getting the details of the topology via NvAPI_Mosaic_GetTopoGroup(). From there, look at the validityMask of the individual topologies. The bits can be tested against the NV_MOSAIC_TOPO_VALIDITY_* bits.

It is possible for this function to return NVAPI_OK with no topologies listed in the return structure. If this is the case, it means that the current hardware DOES support Mosaic, but with the given configuration no valid topologies were found. This most likely means that SLI was not enabled for the hardware. Once enabled, you should see valid topologies returned from this function.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in,out] | pSupportedTopoInfo | Information about what topologies and display resolutions are supported for Mosaic.
[in] | type | The type of topologies the caller is interested in getting. See NV_MOSAIC_TOPO_TYPE for possible values.
Return values:
NVAPI_OK | No errors in returning supported topologies.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more arguments passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not
NVAPI_ERROR,: Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_Mosaic_GetTopoGroup | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_TOPO_GROUP * | pTopoGroup
 | ) |  |

DESCRIPTION: This API returns a structure filled with the details of the specified Mosaic topology.

If the pTopoBrief passed in matches the current topology, then information in the brief and group structures will reflect what is current. Thus the brief would have the current 'enable' status, and the group would have the current overlap values. If there is no match, then the returned brief has an 'enable' status of FALSE (since it is obviously not enabled), and the overlap values will be 0.

'IN' Notes: pTopoGroup->version must be set before calling this function. If the specified version is not supported by this implementation, an error will be returned (NVAPI_INCOMPATIBLE_STRUCT_VERSION).

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in] | pTopoBrief | The topology for getting the details This must be one of the topology briefs returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[in,out] | pTopoGroup | The topology details matching the brief
Return values:
NVAPI_OK | Details were retrieved successfully.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not
NVAPI_ERROR,: Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_Mosaic_SetCurrentTopo | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_DISPLAY_SETTING * | pDisplaySetting,
 |  | NvS32 | overlapX,
 |  | NvS32 | overlapY,
 |  | NvU32 | enable
 | ) |  |

DESCRIPTION: This API sets the Mosaic topology and performs a mode switch using the given display settings.

If NVAPI_OK is returned, the current Mosaic topology was set correctly. Any other status returned means the topology was not set, and remains what it was before this function was called.

SUPPORTED OS: Windows XP and higher

Since:
Release: 185
Parameters:
[in] | pTopoBrief | The topology to set. This must be one of the topologies returned from NvAPI_Mosaic_GetSupportedTopoInfo(), and it must have an isPossible value of 1.
[in] | pDisplaySetting | The per display settings to be used in the Mosaic mode. This must be one of the settings returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[in] | overlapX | The pixel overlap to use between horizontal displays (use positive a number for overlap, or a negative number to create a gap.) If the overlap is out of bounds for what is possible given the topo and display setting, the overlap will be clamped.
[in] | overlapY | The pixel overlap to use between vertical displays (use positive a number for overlap, or a negative number to create a gap.) If the overlap is out of bounds for what is possible given the topo and display setting, the overlap will be clamped.
[in] enable If 1, the topology being set will also be enabled, meaning that the mode set will occur.
If 0, you don't want to be in Mosaic mode right now, but want to set the current Mosaic topology so you can enable it later with NvAPI_Mosaic_EnableCurrentTopo().
Return values:
NVAPI_OK | The Mosaic topology was set.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_TOPO_NOT_POSSIBLE | The topology passed in is not currently possible.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not compatible with this entrypoint.
NVAPI_MODE_CHANGE_FAILED | There was an error changing the display mode.
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INTERFACE NvAPI_Mosaic_ValidateDisplayGrids | ( | __in NvU32 | setTopoFlags,
 |  | __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO * | pGridTopologies,
 |  | __inout_ecount_full(gridCount) NV_MOSAIC_DISPLAY_TOPO_STATUS * | pTopoStatus,
 |  | __in NvU32 | gridCount
 | ) |  |

DESCRIPTION: Determines if a list of grid topologies is valid. It will choose an SLI configuration in the same way that NvAPI_Mosaic_SetDisplayGrids() does.

On return, each element in the pTopoStatus array will contain any errors or warnings about each grid topology. If any error flags are set, then the topology is not valid. If any warning flags are set, then the topology is valid, but sub-optimal.

If the ALLOW_INVALID flag is set, then it will continue to validate the grids even if no SLI configuration will allow all of the grids. In this case, a grid grid with no matching GPU topology will have the error flags NO_GPU_TOPOLOGY or NOT_SUPPORTED set.

If the ALLOW_INVALID flag is not set and no matching SLI configuration is found, then it will skip the rest of the validation and return NVAPI_NO_ACTIVE_SLI_TOPOLOGY.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | setTopoFlags | Zero or more of the NVAPI_MOSAIC_SETDISPLAYTOPO_FLAG_* flags.
[in] | pGridTopologies | The array of grid topologies to verify.
[in,out] | pTopoStatus | The array of problems and warnings with each grid topology.
[in] | gridCount | The number of elements in the pGridTopologies and pTopoStatus arrays.
Return values:
NVAPI_OK,: Capabilities have been returned.
NVAPI_INVALID_ARGUMENT,: One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED,: The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION,: This entrypoint not available
NVAPI_NO_ACTIVE_SLI_TOPOLOGY,: No matching GPU topologies could be found.
NVAPI_ERROR,: Miscellaneous error occurred
NVAPI_INTERFACE NvAPI_SetCurrentMosaicTopology ( NV_MOSAIC_TOPOLOGY * pMosaicTopo )

DESCRIPTION: This API sets the Mosaic topology, and enables it so that the Mosaic display settings are enumerated upon request.

SUPPORTED OS: Windows XP

Since:
Release: 177
Parameters:
[in] pMosaicTopo A valid Mosaic topology
Return values:
NVAPI_OK | Call succeeded
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.


Data Structures | Defines | Typedefs | Enumerations | Functions
Quadro G-Sync APIs

Data Structures

struct | _NV_GSYNC_STATUS_PARAMS

Defines

#define | NV_GSYNC_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V1,1)
#define | NVAPI_MAX_RJ45_PER_GSYNC 2
#define | NV_GSYNC_STATUS_PARAMS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS,1)

Typedefs

typedef enum _NVAPI_GSYNC_POLARITY | NVAPI_GSYNC_POLARITY
typedef enum
_NVAPI_GSYNC_DELAY_TYPE 		NVAPI_GSYNC_DELAY_TYPE
typedef struct
_NV_GSYNC_STATUS_PARAMS 		NV_GSYNC_STATUS_PARAMS

Enumerations

enum | _NVAPI_GSYNC_POLARITY { NVAPI_GSYNC_POLARITY_RISING_EDGE = 0, NVAPI_GSYNC_POLARITY_FALLING_EDGE = 1, NVAPI_GSYNC_POLARITY_BOTH_EDGES = 2 }
enum | _NVAPI_GSYNC_DELAY_TYPE { NVAPI_GSYNC_DELAY_TYPE_UNKNOWN = 0, NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW = 1, NVAPI_GSYNC_DELAY_TYPE_STARTUP = 2 }

Functions

NVAPI_INTERFACE | NvAPI_GSync_EnumSyncDevices (__out NvGSyncDeviceHandle nvGSyncHandles[NVAPI_MAX_GSYNC_DEVICES], __out NvU32 *gsyncCount)
NVAPI_INTERFACE | NvAPI_GSync_QueryCapabilities (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CAPABILITIES *pNvGSyncCapabilities)
NVAPI_INTERFACE | NvAPI_GSync_GetTopology (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout_opt NvU32 *gsyncGpuCount, __inout_ecount_part_opt(*gsyncGpuCount,*gsyncGpuCount) NV_GSYNC_GPU *gsyncGPUs, __inout_opt NvU32 *gsyncDisplayCount, __inout_ecount_part_opt(*gsyncDisplayCount,*gsyncDisplayCount) NV_GSYNC_DISPLAY *gsyncDisplays)
NVAPI_INTERFACE | NvAPI_GSync_SetSyncStateSettings (__in NvU32 gsyncDisplayCount, __in_ecount(gsyncDisplayCount) NV_GSYNC_DISPLAY *pGsyncDisplays, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GSync_GetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_SetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_AdjustSyncDelay (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NVAPI_GSYNC_DELAY_TYPE delayType, __inout NV_GSYNC_DELAY *pGsyncDelay, __out_opt NvU32 *syncSteps)
NVAPI_INTERFACE | NvAPI_GSync_GetSyncStatus (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GSYNC_STATUS *status)
NVAPI_INTERFACE | NvAPI_GSync_GetStatusParameters (NvGSyncDeviceHandle hNvGSyncDevice, NV_GSYNC_STATUS_PARAMS *pStatusParams)

Detailed Description

These APIs control NVIDIA Quadro G-Sync.

Define Documentation

#define NV_GSYNC_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V1,1)

Macro for constructing the version field of NV_GSYNC_CAPABILITIES.

#define NV_GSYNC_STATUS_PARAMS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS,1)

Macro for constructing the version field of NV_GSYNC_STATUS_PARAMS

#define NVAPI_MAX_RJ45_PER_GSYNC 2

Typedef Documentation

typedef struct _NV_GSYNC_STATUS_PARAMS NV_GSYNC_STATUS_PARAMS

Used in NvAPI_GSync_GetStatusParameters().

typedef enum _NVAPI_GSYNC_DELAY_TYPE NVAPI_GSYNC_DELAY_TYPE

Used in NvAPI_GSync_AdjustSyncDelay()

typedef enum _NVAPI_GSYNC_POLARITY NVAPI_GSYNC_POLARITY

Source signal edge to be used for output pulse. See NV_GSYNC_CONTROL_PARAMS.

Enumeration Type Documentation

enum _NVAPI_GSYNC_DELAY_TYPE

Used in NvAPI_GSync_AdjustSyncDelay()

Enumerator:
NVAPI_GSYNC_DELAY_TYPE_UNKNOWN
NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW
NVAPI_GSYNC_DELAY_TYPE_STARTUP
enum _NVAPI_GSYNC_POLARITY

Source signal edge to be used for output pulse. See NV_GSYNC_CONTROL_PARAMS.

Enumerator:
NVAPI_GSYNC_POLARITY_RISING_EDGE
NVAPI_GSYNC_POLARITY_FALLING_EDGE
NVAPI_GSYNC_POLARITY_BOTH_EDGES

Function Documentation

NVAPI_INTERFACE NvAPI_GSync_AdjustSyncDelay | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __in NVAPI_GSYNC_DELAY_TYPE | delayType,
 |  | __inout NV_GSYNC_DELAY * | pGsyncDelay,
 |  | __out_opt NvU32 * | syncSteps
 | ) |  |

DESCRIPTION: This API adjusts the skew and startDelay to the closest possible values. Use this API before calling NvAPI_GSync_SetControlParameters for skew or startDelay.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 319
Parameters:
[in] | hNvGSyncDevice- | The caller provides the handle of the Sync device for which to get parameters
[in] | delayType- | Specifies whether the delay is syncSkew or startupDelay.
[in,out] | *pGsyncDelay- | The caller provides NV_GSYNC_DELAY. skew and startDelay will be adjusted and updated to the closest values.
[out] | *syncSteps- | This parameter is optional. It returns the sync delay in unit steps. If 0, it means either the NV_GSYNC_DELAY::numPixels is less than NV_GSYNC_DELAY::minPixels or NV_GSYNC_DELAY::numOfLines exceeds the NV_GSYNC_DELAY::maxLines.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INTERFACE NvAPI_GSync_EnumSyncDevices | ( | __out NvGSyncDeviceHandle | nvGSyncHandles[NVAPI_MAX_GSYNC_DEVICES],
 |  | __out NvU32 * | gsyncCount
 | ) |  |

DESCRIPTION: This API returns an array of Sync device handles. A Sync device handle represents a single Sync device on the system.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 313
Parameters:
[out] | nvGSyncHandles- | The caller provides an array of handles, which must contain at least NVAPI_MAX_GSYNC_DEVICES elements. The API will zero out the entire array and then fill in one or more handles. If an error occurs, the array is invalid.
[out] | *gsyncCount- | The caller provides the storage space. NvAPI_GSync_EnumSyncDevices sets *gsyncCount to indicate how many of the elements in the nvGSyncHandles[] array are valid. If an error occurs, *gsyncCount will be set to zero.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | nvGSyncHandles or gsyncCount is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INTERFACE NvAPI_GSync_GetControlParameters | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout NV_GSYNC_CONTROL_PARAMS * | pGsyncControls
 | ) |  |

DESCRIPTION: This API queries for sync control parameters as defined in NV_GSYNC_CONTROL_PARAMS.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 313
Parameters:
[in] | hNvGSyncDevice- | The caller provides the handle of the Sync device for which to get parameters
[in,out] | *pGsyncControls- | The caller provides the storage space. NvAPI_GSync_GetControlParameters() populates *pGsyncControls with values.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INTERFACE NvAPI_GSync_GetStatusParameters | ( | NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | NV_GSYNC_STATUS_PARAMS * | pStatusParams
 | ) |  |

DESCRIPTION: This API queries for sync status parameters as defined in NV_GSYNC_STATUS_PARAMS.

SUPPORTED OS: Windows XP and higher

Since:
Release: 313
Parameters:
[in] | hNvGSyncDevice | The caller provides the handle of the GSync device for which to get parameters
[out] | *pStatusParams | The caller provides the storage space. NvAPI_GSync_GetStatusParameters populates *pStatusParams with values.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL / pStatusParams is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any GSync Device.
NVAPI_INTERFACE NvAPI_GSync_GetSyncStatus | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GSYNC_STATUS * | status
 | ) |  |

DESCRIPTION: This API queries the sync status of a GPU - timing, stereosync and sync signal availability.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 313
Parameters:
[in] | hNvGSyncDevice- | Handle of the Sync device
[in] | hPhysicalGpu- | GPU to be queried for sync status.
[out] | *status- | The caller provides the storage space. NvAPI_GSync_GetSyncStatus() populates *status with values - timing, stereosync and signal availability. On error, *status is set to NULL.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL / SyncTarget is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any G-Sync Device.
NVAPI_INTERFACE NvAPI_GSync_GetTopology | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout_opt NvU32 * | gsyncGpuCount,
 |  | __inout_ecount_part_opt *,*gsyncGpuCount NV_GSYNC_GPU * | gsyncGPUs,
 |  | __inout_opt NvU32 * | gsyncDisplayCount,
 |  | __inout_ecount_part_opt *,*gsyncDisplayCount NV_GSYNC_DISPLAY * | gsyncDisplays
 | ) |  |

DESCRIPTION: This API returns the topology for the specified Sync device.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 313
Parameters:
[in] | hNvGSyncDevice- | The caller provides the handle for a Sync device for which the topology will be queried.
[in,out] | gsyncGpuCount- | It returns number of GPUs connected to Sync device
[in,out] | gsyncGPUs- | It returns info about GPUs connected to Sync device
[in,out] | gsyncDisplayCount- | It returns number of active displays that belongs to Sync device
[in,out] | gsyncDisplays- | It returns info about all active displays that belongs to Sync device

HOW TO USE: 1) make a call to get the number of GPUs connected OR displays synced through Sync device by passing the gsyncGPUs OR gsyncDisplays as NULL respectively. Both gsyncGpuCount and gsyncDisplayCount can be retrieved in same call by passing both gsyncGPUs and gsyncDisplays as NULL On call success: 2) Allocate memory based on gsyncGpuCount(for gsyncGPUs) and/or gsyncDisplayCount(for gsyncDisplays) then make a call to populate gsyncGPUs and/or gsyncDisplays respectively.

Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INSUFFICIENT_BUFFER | When the actual number of GPUs/displays in the topology exceed the number of elements allocated for SyncGPUs/SyncDisplays respectively.
NVAPI_INTERFACE NvAPI_GSync_QueryCapabilities | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout NV_GSYNC_CAPABILITIES * | pNvGSyncCapabilities
 | ) |  |

DESCRIPTION: This API returns the capabilities of the Sync device.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 313
Parameters:
[in] | hNvGSyncDevice- | The handle for a Sync device for which the capabilities will be queried.
[in,out] | *pNvGSyncCapabilities- | The caller provides the storage space. NvAPI_GSync_QueryCapabilities() sets pNvGSyncCapabilities to the version and capabilities details of the Sync device If an error occurs, *pNvGSyncCapabilities will be set to NULL.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INTERFACE NvAPI_GSync_SetControlParameters | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout NV_GSYNC_CONTROL_PARAMS * | pGsyncControls
 | ) |  |

DESCRIPTION: This API sets control parameters as defined in NV_SYNC_CONTROL_PARAMS.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 313
Parameters:
[in] | hNvGSyncDevice- | The caller provides the handle of the Sync device for which to get parameters
[in,out] | *pGsyncControls- | The caller provides NV_GSYNC_CONTROL_PARAMS. skew and startDelay will be updated to the applied values.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_SYNC_MASTER_NOT_FOUND | Control Parameters can only be set if there is a Sync Master enabled on the Gsync card.
NVAPI_INTERFACE NvAPI_GSync_SetSyncStateSettings | ( | __in NvU32 | gsyncDisplayCount,
 |  | __in_ecount(gsyncDisplayCount) NV_GSYNC_DISPLAY * | pGsyncDisplays,
 |  | __in NvU32 | flags
 | ) |  |

DESCRIPTION: Sets a new sync state for the displays in system.

SUPPORTED OS: Windows 7 and higher

Since:
Release: 313
Parameters:
[in] | gsyncDisplayCount- | The number of displays in gsyncDisplays.
[in] | pGsyncDisplays- | The caller provides the structure containing all displays that need to be synchronized in the system. The displays that are not part of pGsyncDisplays, will be un-synchronized.
[in] | flags- | Reserved for future use.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_INVALID_ARGUMENT | If the display topology or count not valid.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INVALID_SYNC_TOPOLOGY | 1.If any mosaic grid is partial. 2.If timing(HVisible/VVisible/refreshRate) applied of any display is different. 3.If There is a across GPU mosaic grid in system and that is not a part of pGsyncDisplays.


Data Structures | Defines | Typedefs | Enumerations | Functions
Stereoscopic 3D APIs

Data Structures

struct | _NVAPI_STEREO_CAPS

Defines

#define | NVAPI_STEREO_QUADBUFFERED_API_VERSION 0x2

Typedefs

typedef enum
_NV_StereoRegistryProfileType 		NV_STEREO_REGISTRY_PROFILE_TYPE
typedef enum _NV_StereoRegistryID | NV_STEREO_REGISTRY_ID
typedef enum _NV_FrustumAdjustMode | NV_FRUSTUM_ADJUST_MODE
typedef enum
_NV_StereoSwapChainMode 		NV_STEREO_SWAPCHAIN_MODE
typedef enum _NV_StereoActiveEye | NV_STEREO_ACTIVE_EYE
typedef enum _NV_StereoDriverMode | NV_STEREO_DRIVER_MODE
typedef enum
_NVAPI_STEREO_SURFACECREATEMODE 		NVAPI_STEREO_SURFACECREATEMODE

Enumerations

enum | _NV_StereoRegistryProfileType { NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE, NVAPI_STEREO_DX9_REGISTRY_PROFILE, NVAPI_STEREO_DX10_REGISTRY_PROFILE }
enum | _NV_StereoRegistryID { NVAPI_CONVERGENCE_ID, NVAPI_FRUSTUM_ADJUST_MODE_ID }
enum | _NV_FrustumAdjustMode { NVAPI_NO_FRUSTUM_ADJUST, NVAPI_FRUSTUM_STRETCH, NVAPI_FRUSTUM_CLEAR_EDGES }
enum | _NV_StereoSwapChainMode { NVAPI_STEREO_SWAPCHAIN_DEFAULT = 0, NVAPI_STEREO_SWAPCHAIN_STEREO = 1, NVAPI_STEREO_SWAPCHAIN_MONO = 2 }
enum | _NV_StereoActiveEye { NVAPI_STEREO_EYE_RIGHT = 1, NVAPI_STEREO_EYE_LEFT = 2, NVAPI_STEREO_EYE_MONO = 3 }
enum | _NV_StereoDriverMode { NVAPI_STEREO_DRIVER_MODE_AUTOMATIC = 0, NVAPI_STEREO_DRIVER_MODE_DIRECT = 2 }
enum | _NVAPI_STEREO_SURFACECREATEMODE { NVAPI_STEREO_SURFACECREATEMODE_AUTO, NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO, NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO }

Functions

NVAPI_INTERFACE | NvAPI_Stereo_CreateConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_SetConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID, void *pValue)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID)
NVAPI_INTERFACE | NvAPI_Stereo_GetStereoSupport (__in NvMonitorHandle hMonitor, __out NVAPI_STEREO_CAPS *pCaps)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_GetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE *pFrustumAdjustMode)
NVAPI_INTERFACE | NvAPI_Stereo_SetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE newFrustumAdjustModeValue)
NVAPI_INTERFACE | NvAPI_Stereo_CaptureJpegImage (StereoHandle stereoHandle, NvU32 quality)
NVAPI_INTERFACE | NvAPI_Stereo_Trigger_Activation (__in StereoHandle hStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_CapturePngImage (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_ReverseStereoBlitControl (StereoHandle hStereoHandle, NvU8 TurnOn)
NVAPI_INTERFACE | NvAPI_Stereo_SetNotificationMessage (StereoHandle hStereoHandle, NvU64 hWnd, NvU64 messageID)
NVAPI_INTERFACE | NvAPI_D3D1x_CreateSwapChain (StereoHandle hStereoHandle, DXGI_SWAP_CHAIN_DESC *pDesc, IDXGISwapChain **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NVAPI_INTERFACE | NvAPI_D3D9_CreateSwapChain (StereoHandle hStereoHandle, D3DPRESENT_PARAMETERS *pPresentationParameters, IDirect3DSwapChain9 **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NVAPI_INTERFACE | NvAPI_Stereo_Enable (void)
NVAPI_INTERFACE | NvAPI_Stereo_Disable (void)
NVAPI_INTERFACE | NvAPI_Stereo_IsEnabled (NvU8 *pIsStereoEnabled)
NVAPI_INTERFACE | NvAPI_Stereo_CreateHandleFromIUnknown (IUnknown *pDevice, StereoHandle *pStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DestroyHandle (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Activate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Deactivate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IsActivated (StereoHandle stereoHandle, NvU8 *pIsStereoOn)
NVAPI_INTERFACE | NvAPI_Stereo_GetSeparation (StereoHandle stereoHandle, float *pSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_SetSeparation (StereoHandle stereoHandle, float newSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_GetConvergence (StereoHandle stereoHandle, float *pConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetConvergence (StereoHandle stereoHandle, float newConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetActiveEye (StereoHandle hStereoHandle, NV_STEREO_ACTIVE_EYE StereoEye)
NVAPI_INTERFACE | NvAPI_Stereo_SetDriverMode (NV_STEREO_DRIVER_MODE mode)
NVAPI_INTERFACE | NvAPI_Stereo_GetEyeSeparation (StereoHandle hStereoHandle, float *pSeparation)
NVAPI_INTERFACE | NvAPI_Stereo_IsWindowedModeSupported (NvU8 *bSupported)
NVAPI_INTERFACE | NvAPI_Stereo_SetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE creationMode)
NVAPI_INTERFACE | NvAPI_Stereo_GetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE *pCreationMode)
NVAPI_INTERFACE | NvAPI_Stereo_Debug_WasLastDrawStereoized (__in StereoHandle hStereoHandle, __out NvU8 *pWasStereoized)
NVAPI_INTERFACE | NvAPI_Stereo_SetDefaultProfile (__in const char *szProfileName)
NVAPI_INTERFACE | NvAPI_Stereo_GetDefaultProfile (__in NvU32 cbSizeIn, __out_bcount_part_opt(cbSizeIn,*pcbSizeOut) char *szProfileName, __out NvU32 *pcbSizeOut)
typedef struct _NVAPI_STEREO_CAPS | NVAPI_STEREO_CAPS_V1
enum | _NVAPI_STEREO_INIT_ACTIVATION_FLAGS { NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE = 0X00, NVAPI_STEREO_INIT_ACTIVATION_DELAYED = 0x01 }
typedef enum
_NVAPI_STEREO_INIT_ACTIVATION_FLAGS 		NVAPI_STEREO_INIT_ACTIVATION_FLAGS
NVAPI_INTERFACE | NvAPI_Stereo_InitActivation (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_INIT_ACTIVATION_FLAGS flags)

Detailed Description

These APIs control NVIDIA Stereoscopic 3D.

Define Documentation

#define NVAPI_STEREO_QUADBUFFERED_API_VERSION 0x2

Typedef Documentation

typedef enum _NV_FrustumAdjustMode NV_FRUSTUM_ADJUST_MODE

Used in NvAPI_Stereo_GetFrustumAdjustMode().

typedef enum _NV_StereoActiveEye NV_STEREO_ACTIVE_EYE
typedef enum _NV_StereoDriverMode NV_STEREO_DRIVER_MODE
typedef enum _NV_StereoRegistryID NV_STEREO_REGISTRY_ID

Used in NvAPI_Stereo_SetConfigurationProfileValue()

typedef enum _NV_StereoRegistryProfileType NV_STEREO_REGISTRY_PROFILE_TYPE

Used in NvAPI_Stereo_CreateConfigurationProfileRegistryKey()

typedef enum _NV_StereoSwapChainMode NV_STEREO_SWAPCHAIN_MODE
typedef struct _NVAPI_STEREO_CAPS NVAPI_STEREO_CAPS_V1
typedef enum _NVAPI_STEREO_INIT_ACTIVATION_FLAGS NVAPI_STEREO_INIT_ACTIVATION_FLAGS

InitActivation Flags.

DESCRIPTION: This API allows an application to enable stereo viewing, without the need of a GUID/Key pair This API cannot be used to enable stereo viewing on 3DTV.

HOW TO USE: Call this function immediately after device creation, then follow with a reset.
Very generically: Create Device->Create Stereo Handle->InitActivation->Reset Device

SUPPORTED OS: Windows Vista and higher

Since:
Release: 302
Parameters:
[in] | hStereoHandle | Stereo handle corresponding to the device interface.
[in] | flags | Use delayed activation
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_STEREO_NOT_INITIALIZED - Stereo part of NVAPI not initialized.
typedef enum _NVAPI_STEREO_SURFACECREATEMODE NVAPI_STEREO_SURFACECREATEMODE

NvAPI_Stereo_SetSurfaceCreationMode(StereoHandle hStereoHandle, NVAPI_STEREO_SURFACECREATEMODE creationMode)

Parameters:
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[in] | creationMode | New surface creation mode for this device interface.
Since:
Release: 285

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This API sets surface creation mode for this device interface.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns:
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.

Enumeration Type Documentation

enum _NV_FrustumAdjustMode

Used in NvAPI_Stereo_GetFrustumAdjustMode().

Enumerator:
NVAPI_NO_FRUSTUM_ADJUST

Do not adjust frustum.

NVAPI_FRUSTUM_STRETCH

Stretch images in X.

NVAPI_FRUSTUM_CLEAR_EDGES

Clear corresponding edges for each eye.

enum _NV_StereoActiveEye
Enumerator:
NVAPI_STEREO_EYE_RIGHT
NVAPI_STEREO_EYE_LEFT
NVAPI_STEREO_EYE_MONO
enum _NV_StereoDriverMode
Enumerator:
NVAPI_STEREO_DRIVER_MODE_AUTOMATIC
NVAPI_STEREO_DRIVER_MODE_DIRECT
enum _NV_StereoRegistryID

Used in NvAPI_Stereo_SetConfigurationProfileValue()

Enumerator:
NVAPI_CONVERGENCE_ID

Symbolic constant for convergence registry ID.

NVAPI_FRUSTUM_ADJUST_MODE_ID

Symbolic constant for frustum adjust mode registry ID.

enum _NV_StereoRegistryProfileType

Used in NvAPI_Stereo_CreateConfigurationProfileRegistryKey()

Enumerator:
NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE

Default registry configuration profile.

NVAPI_STEREO_DX9_REGISTRY_PROFILE

Separate registry configuration profile for a DirectX 9 executable.

NVAPI_STEREO_DX10_REGISTRY_PROFILE

Separate registry configuration profile for a DirectX 10 executable.

enum _NV_StereoSwapChainMode
Enumerator:
NVAPI_STEREO_SWAPCHAIN_DEFAULT
NVAPI_STEREO_SWAPCHAIN_STEREO
NVAPI_STEREO_SWAPCHAIN_MONO
enum _NVAPI_STEREO_INIT_ACTIVATION_FLAGS

InitActivation Flags.

DESCRIPTION: This API allows an application to enable stereo viewing, without the need of a GUID/Key pair This API cannot be used to enable stereo viewing on 3DTV.

HOW TO USE: Call this function immediately after device creation, then follow with a reset.
Very generically: Create Device->Create Stereo Handle->InitActivation->Reset Device

SUPPORTED OS: Windows Vista and higher

Since:
Release: 302
Parameters:
[in] | hStereoHandle | Stereo handle corresponding to the device interface.
[in] | flags | Use delayed activation
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_STEREO_NOT_INITIALIZED - Stereo part of NVAPI not initialized.
Enumerator:
NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE
NVAPI_STEREO_INIT_ACTIVATION_DELAYED
enum _NVAPI_STEREO_SURFACECREATEMODE

NvAPI_Stereo_SetSurfaceCreationMode(StereoHandle hStereoHandle, NVAPI_STEREO_SURFACECREATEMODE creationMode)

Parameters:
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[in] | creationMode | New surface creation mode for this device interface.
Since:
Release: 285

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This API sets surface creation mode for this device interface.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns:
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.
Enumerator:
NVAPI_STEREO_SURFACECREATEMODE_AUTO

Use driver registry profile settings for surface creation mode.

NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO

Always create stereo surfaces.

NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO

Always create mono surfaces.

Function Documentation

NVAPI_INTERFACE NvAPI_D3D1x_CreateSwapChain | ( | StereoHandle | hStereoHandle,
 |  | DXGI_SWAP_CHAIN_DESC * | pDesc,
 |  | IDXGISwapChain ** | ppSwapChain,
 |  | NV_STEREO_SWAPCHAIN_MODE | mode
 | ) |  |

DESCRIPTION: This API allows the user to create a mono or a stereo swap chain.

NOTE: NvAPI_D3D1x_CreateSwapChain is a wrapper of the method IDXGIFactory::CreateSwapChain which additionally notifies the D3D driver of the mode in which stereo mode the swap chain is to be created.

Since:
Release: 285

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | hStereoHandle | Stereo handle that corresponds to the device interface. A pointer to the device that will write 2D images to the swap chain.
[in] | pDesc | A pointer to the swap-chain description (DXGI_SWAP_CHAIN_DESC). This parameter cannot be NULL.
[out] | ppSwapChain | A pointer to the swap chain created.
[in] | mode | The stereo mode fot the swap chain. NVAPI_STEREO_SWAPCHAIN_DEFAULT NVAPI_STEREO_SWAPCHAIN_STEREO NVAPI_STEREO_SWAPCHAIN_MONO
Return values:
NVAPI_OK | The swap chain was created successfully.
NVAPI_ERROR | The operation failed.
NVAPI_INTERFACE NvAPI_D3D9_CreateSwapChain | ( | StereoHandle | hStereoHandle,
 |  | D3DPRESENT_PARAMETERS * | pPresentationParameters,
 |  | IDirect3DSwapChain9 ** | ppSwapChain,
 |  | NV_STEREO_SWAPCHAIN_MODE | mode
 | ) |  |

DESCRIPTION: This API allows the user to create a mono or a stereo swap chain.

NOTE: NvAPI_D3D9_CreateSwapChain is a wrapper of the method IDirect3DDevice9::CreateAdditionalSwapChain which additionally notifies the D3D driver if the swap chain creation mode must be stereo or mono.

Since:
Release: 285

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[in,out] | pPresentationParameters | A pointer to the swap-chain description (DXGI). This parameter cannot be NULL.
[out] | ppSwapChain | A pointer to the swap chain created.
[in] | mode | The stereo mode for the swap chain. NVAPI_STEREO_SWAPCHAIN_DEFAULT NVAPI_STEREO_SWAPCHAIN_STEREO NVAPI_STEREO_SWAPCHAIN_MONO
Return values:
NVAPI_OK | The swap chain creation was successful
NVAPI_ERROR | The operation failed.
NVAPI_INTERFACE NvAPI_Stereo_Activate ( StereoHandle stereoHandle )

DESCRIPTION: This API activates stereo for the device interface corresponding to the given stereo handle. Activating stereo is possible only if stereo was enabled previously in the registry. If stereo is not activated, then calls to functions that require that stereo is activated have no effect, and will return the appropriate error code.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle corresponding to the device interface.
Return values:
NVAPI_OK | Stereo is turned on.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_CaptureJpegImage | ( | StereoHandle | stereoHandle,
 |  | NvU32 | quality
 | ) |  |

DESCRIPTION: This API captures the current stereo image in JPEG stereo format with the given quality. Only the last capture call per flip will be effective.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | quality | Quality of the JPEG image to be captured. Integer value betweeen 0 and 100.
Return values:
NVAPI_OK | Image captured.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED
NVAPI_STEREO_PARAMETER_OUT_OF_RANGE | Given quality is out of [0..100] range.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_CapturePngImage ( StereoHandle stereoHandle )

DESCRIPTION: This API captures the current stereo image in PNG stereo format. Only the last capture call per flip will be effective.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle corresponding to the device interface.
Return values:
NVAPI_OK | Image captured.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NvAPI_Stereo_CreateConfigurationProfileRegistryKey ( NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType )

DESCRIPTION: Creates new configuration registry key for current application.

If there is no configuration profile prior to the function call, this API tries to create a new configuration profile registry key for a given application and fill it with the default values. If an application already has a configuration profile registry key, the API does nothing. The name of the key is automatically set to the name of the executable that calls this function. Because of this, the executable should have a distinct and unique name. If the application is using only one version of DirectX, then the default profile type will be appropriate. If the application is using more than one version of DirectX from the same executable, it should use the appropriate profile type for each configuration profile.

HOW TO USE: When there is a need for an application to have default stereo parameter values, use this function to create a key to store the values.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] registryProfileType Type of profile the application wants to create. It should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause function to do nothing and return ::NV_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED.
Return values:
NVAPI_OK | Key exists in the registry.
NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED | This profile type is not supported.
NVAPI_STEREO_REGISTRY_ACCESS_FAILED | Access to registry failed.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_CreateHandleFromIUnknown | ( | IUnknown * | pDevice,
 |  | StereoHandle * | pStereoHandle
 | ) |  |

DESCRIPTION: This API creates a stereo handle that is used in subsequent calls related to a given device interface. This must be called before any other NvAPI_Stereo_ function for that handle. Multiple devices can be used at one time using multiple calls to this function (one per each device).

HOW TO USE: After the Direct3D device is created, create the stereo handle. On call success:

  1. Use all other NvAPI_Stereo_ functions that have stereo handle as first parameter.
  2. After the device interface that corresponds to the the stereo handle is destroyed, the application should call NvAPI_DestroyStereoHandle() for that stereo handle.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | pDevice | Pointer to IUnknown interface that is IDirect3DDevice9* in DX9, ID3D10Device*.
[out] | pStereoHandle | Pointer to the newly created stereo handle.
Return values:
NVAPI_OK | Stereo handle is created for given device interface.
NVAPI_INVALID_ARGUMENT | Provided device interface is invalid.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_Deactivate ( StereoHandle stereoHandle )

DESCRIPTION: This API deactivates stereo for the given device interface. If stereo is not activated, then calls to functions that require that stereo is activated have no effect, and will return the appropriate error code.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values:
NVAPI_OK | Stereo is turned off.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_Debug_WasLastDrawStereoized | ( | __in StereoHandle | hStereoHandle,
 |  | __out NvU8 * | pWasStereoized
 | ) |  |
Parameters:
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[out] | pWasStereoized | Address where result of the inquiry will be placed.

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This API checks if the last draw call was stereoized. It is a very expensive to call and should be used for debugging purpose *only*.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns:
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.
NVAPI_INTERFACE NvAPI_Stereo_DecreaseConvergence ( StereoHandle stereoHandle )

DESCRIPTION: This API decreases convergence for the given device interface (just like the Ctrl+F5 hotkey).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values:
NVAPI_OK | - Decrease of convergence was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_ERROR | - Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_DecreaseSeparation ( StereoHandle stereoHandle )

DESCRIPTION: This API decreases separation for the given device interface (just like the Ctrl+F3 hotkey).

WHEN TO USE: After the stereo handle for device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values:
NVAPI_OK | - Decrease of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_ERROR | - Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_DeleteConfigurationProfileRegistryKey ( NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType )

DESCRIPTION: Removes configuration registry key for current application.

If an application already has a configuration profile prior to this function call, the function attempts to remove the application's configuration profile registry key from the registry. If there is no configuration profile registry key prior to the function call, the function does nothing and does not report an error.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] registryProfileType Type of profile that the application wants to delete. This should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause the function to do nothing and return ::NV_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED.
Return values:
NVAPI_OK | Key does not exist in the registry any more.
NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED | This profile type is not supported.
NVAPI_STEREO_REGISTRY_ACCESS_FAILED | Access to registry failed.
NVAPI_API_NOT_INTIALIZED | NVAPI is not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI is not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_DeleteConfigurationProfileValue | ( | NV_STEREO_REGISTRY_PROFILE_TYPE | registryProfileType,
 |  | NV_STEREO_REGISTRY_ID | valueRegistryID
 | ) |  |

DESCRIPTION: This API removes the given value from the application's configuration profile registry key. If there is no such value, the function does nothing and does not report an error.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | registryProfileType | The type of profile the application wants to access. It should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause function to do nothing and return ::NV_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED.
[in] | valueRegistryID | ID of the value that is being deleted. It should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause function to do nothing and return NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED.
Return values:
NVAPI_OK | Value does not exist in registry any more.
NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED | This profile type is not supported.
NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED | This value is not supported.
NVAPI_STEREO_REGISTRY_ACCESS_FAILED | Access to registry failed.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_DestroyHandle ( StereoHandle stereoHandle )

DESCRIPTION: This API destroys the stereo handle created with one of the NvAPI_Stereo_CreateHandleFrom() functions. This should be called after the device corresponding to the handle has been destroyed.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle that is to be destroyed.
Return values:
NVAPI_OK | Stereo handle is destroyed.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_Disable ( void )

DESCRIPTION: This API disables stereo mode in the registry. Calls to this function affect the entire system. If stereo is not enabled, then calls to functions that require that stereo is enabled have no effect, and will return the appropriate error code.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Return values:
NVAPI_OK | Stereo is now disabled.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_Enable ( void )

DESCRIPTION: This APU enables stereo mode in the registry. Calls to this function affect the entire system. If stereo is not enabled, then calls to functions that require that stereo is enabled have no effect, and will return the appropriate error code.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Return values:
NVAPI_OK | Stereo is now enabled.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_GetConvergence | ( | StereoHandle | stereoHandle,
 |  | float * | pConvergence
 | ) |  |

DESCRIPTION: This API gets the current convergence value.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[out] | pConvergence | Address of float type variable to store current convergence value in.
Return values:
NVAPI_OK | Retrieval of convergence value was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_GetDefaultProfile | ( | __in NvU32 | cbSizeIn,
 |  | __out_bcount_part_opt(cbSizeIn,*pcbSizeOut) char * | szProfileName,
 |  | __out NvU32 * | pcbSizeOut
 | ) |  |

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This API retrieves the current default stereo profile.

After call cbSizeOut contain 0 if default profile is not set required buffer size cbSizeOut. To get needed buffer size this function can be called with szProfileName==0 and cbSizeIn == 0.

WHEN TO USE: This API can be called at any time.

Parameters:
[in] | cbSizeIn | Size of buffer allocated for default stereo profile name.
[out] | szProfileName | Default stereo profile name.
[out] | pcbSizeOut | Required buffer size. # ==0 - there is no default stereo profile name currently set # !=0 - size of buffer required for currently set default stereo profile name including trailing '0'.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. Error codes specific to this API are described below.
Return values:
NVAPI_SUCCESS | - Default stereo profile name has been copied into szProfileName.
NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED | - There is no default stereo profile set at this time.
NVAPI_INVALID_ARGUMENT | - pcbSizeOut == 0 or cbSizeIn >= *pcbSizeOut && szProfileName == 0
NVAPI_INSUFFICIENT_BUFFER | - cbSizeIn < *pcbSizeOut
NVAPI_INTERFACE NvAPI_Stereo_GetEyeSeparation | ( | StereoHandle | hStereoHandle,
 |  | float * | pSeparation
 | ) |  |

DESCRIPTION: This API returns eye separation as a ratio of <between eye="" distance>="">/<physical screen="" width>="">.

HOW TO USE: After the stereo handle for device interface is created via successfull call to appropriate API. Applies only to DirectX 9 and up.

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[out] | pSeparation | Eye separation.
Return values:
NVAPI_OK | Active eye is set.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR | (generic error).
NvAPI_Stereo_GetFrustumAdjustMode | ( | StereoHandle | stereoHandle,
 |  | NV_FRUSTUM_ADJUST_MODE * | pFrustumAdjustMode
 | ) |  |

DESCRIPTION: This API gets the current frustum adjust mode value.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[out] | pFrustumAdjustMode | Address of the NV_FRUSTUM_ADJUST_MODE type variable to store current frustum value in.
Return values:
NVAPI_OK | - Retrieval of frustum adjust mode was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_ERROR | - Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_GetSeparation | ( | StereoHandle | stereoHandle,
 |  | float * | pSeparationPercentage
 | ) |  |

DESCRIPTION: This API gets current separation value (in percents).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[out] | pSeparationPercentage | Address of float type variable to store current separation percentage in.
Return values:
NVAPI_OK | Retrieval of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_GetStereoSupport | ( | __in NvMonitorHandle | hMonitor,
 |  | __out NVAPI_STEREO_CAPS * | pCaps
 | ) |  |

DESCRIPTION: This API checks what kind of stereo support is currently supported on a particular display. If the the display is prohibited from showing stereo (e.g. secondary in a multi-mon setup), we will return 0 for all stereo modes (full screen exclusive, automatic windowed, persistent windowed). Otherwise, we will check which stereo mode is supported. On 120Hz display, this will be what the user chooses in control panel. On HDMI 1.4 display, persistent windowed mode is always assumed to be supported. Note that this function does not check if the CURRENT RESOLUTION/REFRESH RATE can support stereo. For HDMI 1.4, it is the app's responsibility to change the resolution/refresh rate to one that is 3D compatible. For 120Hz, the driver will ALWAYS force 120Hz anyway.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 304
Parameters:
[in] | hMonitor | handle to monitor that app is going to run on
[out] | pCaps | Address where the result of the inquiry will be placed. pCaps is defined in NVAPI_STEREO_CAPS.
Returns:
This API can return any of the following error codes enumerated in NvAPI_Status
Return values:
NVAPI_OK
NVAPI_INTERFACE NvAPI_Stereo_GetSurfaceCreationMode | ( | __in StereoHandle | hStereoHandle,
 |  | __in NVAPI_STEREO_SURFACECREATEMODE * | pCreationMode
 | ) |  |

NvAPI_Stereo_GetSurfaceCreationMode(StereoHandle hStereoHandle, NVAPI_STEREO_SURFACECREATEMODE* pCreationMode)

Parameters:
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[out] | pCreationMode | The current creation mode for this device interface.
Since:
Release: 295

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This API gets surface creation mode for this device interface.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns:
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.
NVAPI_INTERFACE NvAPI_Stereo_IncreaseConvergence ( StereoHandle stereoHandle )

DESCRIPTION: This API increases convergence for given the device interface (just like the Ctrl+F5 hotkey).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values:
NVAPI_OK | Increase of convergence was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_IncreaseSeparation ( StereoHandle stereoHandle )

DESCRIPTION: This API increases separation for the given device interface (just like the Ctrl+F4 hotkey).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values:
NVAPI_OK | Increase of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR | Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_InitActivation | ( | __in StereoHandle | hStereoHandle,
 |  | __in NVAPI_STEREO_INIT_ACTIVATION_FLAGS | flags
 | ) |  |

InitActivation Flags.

DESCRIPTION: This API allows an application to enable stereo viewing, without the need of a GUID/Key pair This API cannot be used to enable stereo viewing on 3DTV.

HOW TO USE: Call this function immediately after device creation, then follow with a reset.
Very generically: Create Device->Create Stereo Handle->InitActivation->Reset Device

SUPPORTED OS: Windows Vista and higher

Since:
Release: 302
Parameters:
[in] | hStereoHandle | Stereo handle corresponding to the device interface.
[in] | flags | Use delayed activation
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_STEREO_NOT_INITIALIZED - Stereo part of NVAPI not initialized.
NVAPI_INTERFACE NvAPI_Stereo_IsActivated | ( | StereoHandle | stereoHandle,
 |  | NvU8 * | pIsStereoOn
 | ) |  |

DESCRIPTION: This API checks if stereo is activated for the given device interface.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | pIsStereoOn | Address where result of the inquiry will be placed.
Return values:
NVAPI_OK | - Check was sucessfully completed and result reflects current state of stereo (on/off).
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_ERROR | - Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_IsEnabled ( NvU8 * pIsStereoEnabled )

DESCRIPTION: This API checks if stereo mode is enabled in the registry.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[out] pIsStereoEnabled Address where the result of the inquiry will be placed.
Return values:
NVAPI_OK | Check was sucessfully completed and result reflects current state of stereo availability.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_IsWindowedModeSupported ( NvU8 * bSupported )

DESCRIPTION: This API returns availability of windowed mode stereo

SUPPORTED OS: Windows Vista and higher

Parameters:
[out] bSupported(OUT) != 0 - supported,
== 0 - is not supported
Return values:
NVAPI_OK | Retrieval of frustum adjust mode was successfull.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR | Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_ReverseStereoBlitControl | ( | StereoHandle | hStereoHandle,
 |  | NvU8 | TurnOn
 | ) |  |

DESCRIPTION: This API turns on/off reverse stereo blit.

HOW TO USE: Use after the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function. After reversed stereo blit control is turned on, blits from the stereo surface will produce the right-eye image in the left side of the destination surface and the left-eye image in the right side of the destination surface.

In DirectX 9, the destination surface must be created as the render target, and StretchRect must be used. Conditions:

  • DstWidth == 2*SrcWidth
  • DstHeight == SrcHeight
  • Src surface is the stereo surface.
  • SrcRect must be {0,0,SrcWidth,SrcHeight}
  • DstRect must be {0,0,DstWidth,DstHeight}

In DirectX 10, ResourceCopyRegion must be used. Conditions:

  • DstWidth == 2*SrcWidth
  • DstHeight == SrcHeight
  • dstX == 0,
  • dstY == 0,
  • dstZ == 0,
  • SrcBox: left=top=front==0; right==SrcWidth; bottom==SrcHeight; back==1;

SUPPORTED OS: Windows Vista and higher

Since:
Release: 185
Parameters:
[in] hStereoHandle Stereo handle corresponding to the device interface.
[in] TurnOn != 0 : Turns on
== 0 : Turns off
Return values:
NVAPI_OK | Retrieval of frustum adjust mode was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NvAPI_Stereo_SetActiveEye | ( | StereoHandle | hStereoHandle,
 |  | NV_STEREO_ACTIVE_EYE | StereoEye
 | ) |  |

DESCRIPTION: This API sets the back buffer to left or right in Direct stereo mode.

HOW TO USE: After the stereo handle for device interface is created via successfull call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Since:
Release: 285

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | StereoEye | Defines active eye in Direct stereo mode
Return values:
NVAPI_OK | - Active eye is set.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_INVALID_ARGUMENT | - StereoEye parameter has not allowed value.
NVAPI_SET_NOT_ALLOWED | - Current stereo mode is not Direct
NVAPI_ERROR | - Something is wrong (generic error).
NvAPI_Stereo_SetConfigurationProfileValue | ( | NV_STEREO_REGISTRY_PROFILE_TYPE | registryProfileType,
 |  | NV_STEREO_REGISTRY_ID | valueRegistryID,
 |  | void * | pValue
 | ) |  |

DESCRIPTION: This API sets the given parameter value under the application's registry key.

If the value does not exist under the application's registry key, the value will be created under the key.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | registryProfileType | The type of profile the application wants to access. It should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause function to do nothing and return ::NV_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED.
[in] | valueRegistryID | ID of the value that is being set. It should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause function to do nothing and return NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED.
[in] | pValue | Address of the value that is being set. It should be either address of a DWORD or of a float, dependent on the type of the stereo parameter whose value is being set. The API will then cast that address to DWORD* and write whatever is in those 4 bytes as a DWORD to the registry.
Return values:
NVAPI_OK | Value is written to registry.
NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED | This profile type is not supported.
NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED | This value is not supported.
NVAPI_STEREO_REGISTRY_ACCESS_FAILED | Access to registry failed.
NVAPI_API_NOT_INTIALIZED | NVAPI is not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI is not initialized.
NVAPI_ERROR | Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_SetConvergence | ( | StereoHandle | stereoHandle,
 |  | float | newConvergence
 | ) |  |

DESCRIPTION: This API sets convergence to the given value.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | newConvergence | New value for convergence.
Return values:
NVAPI_OK | Setting of convergence value was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_SetDefaultProfile ( __in const char * szProfileName )

SUPPORTED OS: Windows Vista and higher

DESCRIPTION: This API defines the stereo profile used by the driver in case the application has no associated profile.

WHEN TO USE: To take effect, this API must be called before D3D device is created. Calling once a device has been created will not affect the current device.

Parameters:
[in] szProfileName Default profile name.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. Error codes specific to this API are described below.
Return values:
NVAPI_SUCCESS | - Default stereo profile name has been copied into szProfileName.
NVAPI_INVALID_ARGUMENT | - szProfileName == NULL.
NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST | - Default stereo profile does not exist
NvAPI_Stereo_SetDriverMode ( NV_STEREO_DRIVER_MODE mode )

DESCRIPTION: This API sets the 3D stereo driver mode: Direct or Automatic

HOW TO USE: This API must be called before the device is created. Applies to DirectX 9 and higher.

Since:
Release: 285

SUPPORTED OS: Windows Vista and higher

Parameters:
[in] mode Defines the 3D stereo driver mode: Direct or Automatic
Return values:
NVAPI_OK | Active eye is set.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_INVALID_ARGUMENT | mode parameter has not allowed value.
NVAPI_ERROR | Something is wrong (generic error).
NVAPI_INTERFACE NvAPI_Stereo_SetFrustumAdjustMode | ( | StereoHandle | stereoHandle,
 |  | NV_FRUSTUM_ADJUST_MODE | newFrustumAdjustModeValue
 | ) |  |

DESCRIPTION: This API sets the current frustum adjust mode value.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | newFrustumAdjustModeValue | New value for frustum adjust mode. It should be one of the symbolic constants defined in NV_FRUSTUM_ADJUST_MODE. Any other value will cause function to do nothing and return NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED.
Return values:
NVAPI_OK | Retrieval of frustum adjust mode was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED | Given frustum adjust mode is not supported.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_SetNotificationMessage | ( | StereoHandle | hStereoHandle,
 |  | NvU64 | hWnd,
 |  | NvU64 | messageID
 | ) |  |

DESCRIPTION: This API is a Setup notification message that the stereo driver uses to notify the application when the user changes the stereo driver state.

When the user changes the stereo state (Activated or Deactivated, separation or conversion) the stereo driver posts a defined message with the following parameters:

lParam is the current conversion. (Actual conversion is *(float*)&lParam )

wParam == MAKEWPARAM(l, h) where

  • l == 0 if stereo is deactivated
  • l == 1 if stereo is deactivated
  • h is the current separation. (Actual separation is float(h*100.f/0xFFFF)

Call this API with NULL hWnd to prohibit notification.

WHEN TO USE: Use after the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | hStereoHandle | Stereo handle corresponding to the device interface.
[in] | hWnd | Window HWND that will be notified when the user changes the stereo driver state. Actual HWND must be cast to an NvU64.
[in] | messageID | MessageID of the message that will be posted to hWnd
Return values:
NVAPI_OK | Notification set.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_SetSeparation | ( | StereoHandle | stereoHandle,
 |  | float | newSeparationPercentage
 | ) |  |

DESCRIPTION: This API sets separation to given percentage.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 180
Parameters:
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | newSeparationPercentage | New value for separation percentage.
Return values:
NVAPI_OK | Setting of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_STEREO_PARAMETER_OUT_OF_RANGE | Given separation percentage is out of [0..100] range.
NVAPI_ERROR
NVAPI_INTERFACE NvAPI_Stereo_SetSurfaceCreationMode | ( | __in StereoHandle | hStereoHandle,
 |  | __in NVAPI_STEREO_SURFACECREATEMODE | creationMode
 | ) |  |
NVAPI_INTERFACE NvAPI_Stereo_Trigger_Activation ( __in StereoHandle hStereoHandle )

DESCRIPTION: This API allows an application to trigger creation of a stereo desktop, in case the creation was stopped on application launch.

SUPPORTED OS: Windows Vista and higher

Since:
Release: 302
Parameters:
[in] hStereoHandle Stereo handle that corresponds to the device interface.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE | - Stereo InitActivation not called.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.


Functions
Driver Settings (DRS) APIs

Functions

NVAPI_INTERFACE | NvAPI_DRS_CreateProfile (NvDRSSessionHandle hSession, NVDRS_PROFILE *pProfileInfo, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_SetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvAPI_UnicodeString wszGlobalProfileName)
NVAPI_INTERFACE | NvAPI_DRS_GetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_SetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_FindProfileByName (NvDRSSessionHandle hSession, NvAPI_UnicodeString profileName, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_EnumProfiles (NvDRSSessionHandle hSession, NvU32 index, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetNumProfiles (NvDRSSessionHandle hSession, NvU32 *numProfiles)
NVAPI_INTERFACE | NvAPI_DRS_CreateApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplicationEx (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApp)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName)
NVAPI_INTERFACE | NvAPI_DRS_GetApplicationInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_EnumApplications (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *appCount, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_FindApplicationByName (__in NvDRSSessionHandle hSession, __in NvAPI_UnicodeString appName, __out NvDRSProfileHandle *phProfile, __inout NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_SetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_GetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumSettings (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *settingsCount, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingIds (NvU32 *pSettingIds, NvU32 *pMaxCount)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingValues (NvU32 settingId, NvU32 *pMaxNumValues, NVDRS_SETTING_VALUES *pSettingValues)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingIdFromName (NvAPI_UnicodeString settingName, NvU32 *pSettingId)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingNameFromId (NvU32 settingId, NvAPI_UnicodeString *pSettingName)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfileSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_RestoreAllDefaults (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefault (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefaultSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_GetBaseProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)
NV_DECLARE_HANDLE (NvDRSSessionHandle)

Detailed Description

DRS, or DRiver Settings, is a new framework introduced in R256 that handles the storage, management, API layers, and related infrastructure of 3D settings, application profiles, and other settings.

Function Documentation

NV_DECLARE_HANDLE ( NvDRSSessionHandle )

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

NVAPI_INTERFACE NvAPI_DRS_CreateApplication | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API adds an executable name to a profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | *pApplication | Input NVDRS_APPLICATION struct with the executable name to be added.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_CreateProfile | ( | NvDRSSessionHandle | hSession,
 |  | NVDRS_PROFILE * | pProfileInfo,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API creates an empty profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | *pProfileInfo | Input pointer to NVDRS_PROFILE.
[in] | *phProfile | Returns pointer to profile handle.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_DeleteApplication | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvAPI_UnicodeString | appName
 | ) |  |

DESCRIPTION: This API removes an executable name from a profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | appName | Input the executable name to be removed.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | If the path provided could refer to two different executables, this error will be returned
NVAPI_INTERFACE NvAPI_DRS_DeleteApplicationEx | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_APPLICATION * | pApp
 | ) |  |

DESCRIPTION: This API removes an executable from a profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | - Input to the session handle.
[in] | hProfile | - Input profile handle.
[in] | *pApp | - Input all the information about the application to be removed.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | If the path provided could refer to two different executables, this error will be returned.
NVAPI_INTERFACE NvAPI_DRS_DeleteProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile
 | ) |  |

DESCRIPTION: This API deletes a profile or sets it back to a predefined value.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_DeleteProfileSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | settingId
 | ) |  |

DESCRIPTION: This API deletes a setting or sets it back to predefined value.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | settingId | Input settingId to be deleted.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_EnumApplications | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | startIndex,
 |  | NvU32 * | appCount,
 |  | NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API enumerates all the applications in a given profile from the starting index to the maximum length.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | startIndex | Indicates starting index for enumeration.
[in,out] | *appCount | Input maximum length of the passed in arrays. Returns the actual length.
[out] | *pApplication | Returns NVDRS_APPLICATION struct with all the attributes.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_END_ENUMERATION | startIndex exceeds the total appCount.
NVAPI_INTERFACE NvAPI_DRS_EnumAvailableSettingIds | ( | NvU32 * | pSettingIds,
 |  | NvU32 * | pMaxCount
 | ) |  |

DESCRIPTION: This API enumerates all the Ids of all the settings recognized by NVAPI.

SUPPORTED OS: Windows XP and higher

Parameters:
[out] | pSettingIds | User-provided array of length *pMaxCount that NVAPI will fill with IDs.
[in,out] | pMaxCount | Input max length of the passed in array, Returns the actual length.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors. NVAPI_END_ENUMERATION: the provided pMaxCount is not enough to hold all settingIds.
NVAPI_INTERFACE NvAPI_DRS_EnumAvailableSettingValues | ( | NvU32 | settingId,
 |  | NvU32 * | pMaxNumValues,
 |  | NVDRS_SETTING_VALUES * | pSettingValues
 | ) |  |

DESCRIPTION: This API enumerates all available setting values for a given setting.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | settingId | Input settingId.
[in,out] | *pMaxNumValues | Input max length of the passed in arrays, Returns the actual length.
[out] | *pSettingValues | Returns all available setting values and its count.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_EnumProfiles | ( | NvDRSSessionHandle | hSession,
 |  | NvU32 | index,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API enumerates through all the profiles in the session.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | index | Input the index for enumeration.
[out] | *phProfile | Returns profile handle.

RETURN STATUS: NVAPI_OK: SUCCESS if the profile is found NVAPI_ERROR: For miscellaneous errors. NVAPI_END_ENUMERATION: index exceeds the total number of available Profiles in DB.

NVAPI_INTERFACE NvAPI_DRS_EnumSettings | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | startIndex,
 |  | NvU32 * | settingsCount,
 |  | NVDRS_SETTING * | pSetting
 | ) |  |

DESCRIPTION: This API enumerates all the settings of a given profile from startIndex to the maximum length.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | startIndex | Indicates starting index for enumeration.
[in,out] | *settingsCount | Input max length of the passed in arrays, Returns the actual length.
[out] | *pSetting | Returns all the settings info.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_END_ENUMERATION | startIndex exceeds the total appCount.
NVAPI_INTERFACE NvAPI_DRS_FindApplicationByName | ( | __in NvDRSSessionHandle | hSession,
 |  | __in NvAPI_UnicodeString | appName,
 |  | __out NvDRSProfileHandle * | phProfile,
 |  | __inout NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API searches the application and the associated profile for the given application name. If a fully qualified path is provided, this function will always return the profile the driver will apply upon running the application (on the path provided).

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the hSession handle
[in] | appName | Input appName. For best results, provide a fully qualified path of the type c:/Folder1/Folder2/App.exe
[out] | *phProfile | Returns profile handle.
[in,out] | *pApplication | Returns NVDRS_APPLICATION struct pointer.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below:
Return values:
::NVAPI_APPLICATION_NOT_FOUND | If App not found
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | If the input appName was not fully qualified, this error might return in the case of multiple matches
NVAPI_INTERFACE NvAPI_DRS_FindProfileByName | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | profileName,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API finds a profile in the current session.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | profileName | Input profileName.
[out] | phProfile | Input profile handle.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_PROFILE_NOT_FOUND | if profile is not found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_GetApplicationInfo | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvAPI_UnicodeString | appName,
 |  | NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API gets information about the given application. The input application name must match exactly what the Profile has stored for the application. This function is better used to retrieve application information from a previous enumeration.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | appName | Input application name.
[out] | *pApplication | Returns NVDRS_APPLICATION struct with all the attributes.
Returns:
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values:
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | The application name could not single out only one executable.
NVAPI_EXECUTABLE_NOT_FOUND | No application with that name is found on the profile.
NVAPI_INTERFACE NvAPI_DRS_GetBaseProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: Returns the handle to the current global profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | *phProfile | Returns Base profile handle.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_GetCurrentGlobalProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API returns the handle to the current global profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[out] | *phProfile | Returns current Global profile handle.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_GetNumProfiles | ( | NvDRSSessionHandle | hSession,
 |  | NvU32 * | numProfiles
 | ) |  |

DESCRIPTION: This API obtains the number of profiles in the current session object.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[out] | *numProfiles | Returns count of profiles in the current hSession.
Return values:
NVAPI_OK | SUCCESS
NVAPI_API_NOT_INTIALIZED | Failed to initialize.
NVAPI_INVALID_ARGUMENT | Invalid Arguments.
NVAPI_INTERFACE NvAPI_DRS_GetProfileInfo | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_PROFILE * | pProfileInfo
 | ) |  |

DESCRIPTION: This API gets information about the given profile. User needs to specify the name of the Profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[out] | *pProfileInfo | Return the profile info.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_GetSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | settingId,
 |  | NVDRS_SETTING * | pSetting
 | ) |  |

DESCRIPTION: This API gets information about the given setting.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | settingId | Input settingId.
[out] | *pSetting | Returns all the setting info
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_GetSettingIdFromName | ( | NvAPI_UnicodeString | settingName,
 |  | NvU32 * | pSettingId
 | ) |  |

DESCRIPTION: This API gets the binary ID of a setting given the setting name.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | settingName | Input Unicode settingName.
[out] | *pSettingId | Returns corresponding settingId.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_PROFILE_NOT_FOUND | if profile is not found
NVAPI_SETTING_NOT_FOUND | if setting is not found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_GetSettingNameFromId | ( | NvU32 | settingId,
 |  | NvAPI_UnicodeString * | pSettingName
 | ) |  |

DESCRIPTION: This API gets the setting name given the binary ID.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | settingId | Input settingId.
[in] | *pSettingName | Returns corresponding Unicode settingName.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_PROFILE_NOT_FOUND | if profile is not found
NVAPI_SETTING_NOT_FOUND | if setting is not found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_RestoreAllDefaults ( NvDRSSessionHandle hSession )

DESCRIPTION: This API restores the whole system to predefined(default) values.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] hSession Input to the session handle.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_RestoreProfileDefault | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile
 | ) |  |

DESCRIPTION: This API restores the given profile to predefined(default) values. Any and all user specified modifications will be removed. If the whole profile was set by the user, the profile will be removed.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_PROFILE_REMOVED | SUCCESS, and the hProfile is no longer valid.
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_RestoreProfileDefaultSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | settingId
 | ) |  |

DESCRIPTION: This API restores the given profile setting to predefined(default) values.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | settingId | Input settingId.
Return values:
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_SetCurrentGlobalProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | wszGlobalProfileName
 | ) |  |

DESCRIPTION: This API sets the current global profile in the driver.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | wszGlobalProfileName | Input current Global profile name.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_SetProfileInfo | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_PROFILE * | pProfileInfo
 | ) |  |

DESCRIPTION: Specifies flags for a given profile. Currently only the NVDRS_GPU_SUPPORT is used to update the profile. Neither the name, number of settings or applications or other profile information can be changed with this function.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | *pProfileInfo | Input the new profile info.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_SetSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_SETTING * | pSetting
 | ) |  |

DESCRIPTION: This API adds/modifies a setting to a profile.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | *pSetting | Input NVDRS_SETTING struct pointer.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.


  • Data Structures
  • Class Hierarchy
  • Data Fields
Data Structures
Here are the data structures with brief descriptions:
_NV_BOARD_INFO |
_NV_COLOR_DATA_V1 |
_NV_COLOR_DATA_V2 |
_NV_COLOR_DATA_V3 |
_NV_DISPLAY_PORT_INFO_V1 |
_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 |
_NV_DISPLAYCONFIG_PATH_INFO_V1 |
_NV_DISPLAYCONFIG_PATH_INFO_V2 |
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 |
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 |
_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 |
_NV_DX_VIDEO_STEREO_INFO |
_NV_GPU_DISPLAYIDS |
_NV_GPU_GET_ILLUMINATION_PARM_V1 |
_NV_GPU_PERF_PSTATES20_INFO_V2 | Used in NvAPI_GPU_GetPstates20() interface call
_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 |
_NV_GPU_SET_ILLUMINATION_PARM_V1 |
_NV_GSYNC_CAPABILITIES_V1 | Used in NvAPI_GSync_QueryCapabilities()
_NV_GSYNC_CONTROL_PARAMS | Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters()
_NV_GSYNC_DELAY | Used in NV_GSYNC_CONTROL_PARAMS
_NV_GSYNC_DISPLAY |
_NV_GSYNC_GPU |
_NV_GSYNC_STATUS | Used in NvAPI_GSync_GetSyncStatus()
_NV_GSYNC_STATUS_PARAMS |
_NV_HDMI_SUPPORT_INFO_V1 |
_NV_HDMI_SUPPORT_INFO_V2 |
_NV_MONITOR_CAPABILITIES_V1 | See NvAPI_DISP_GetMonitorCapabilities()
_NV_MONITOR_CAPS_VCDB |
_NV_MONITOR_CAPS_VSDB | See NvAPI_DISP_GetMonitorCapabilities()
_NV_MONITOR_COLOR_DATA |
_NV_MOSAIC_DISPLAY_SETTING_V1 | Basic per-display settings that are used in setting/getting the Mosaic mode
_NV_MOSAIC_GRID_TOPO_DISPLAY_V1 |
_NV_MOSAIC_GRID_TOPO_DISPLAY_V2 |
_NV_MOSAIC_GRID_TOPO_V1 |
_NV_MOSAIC_GRID_TOPO_V2 |
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 | So arrays are bound
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 |
_NV_POSITION |
_NV_RECT |
_NV_RESOLUTION |
_NV_SCANOUT_INFORMATION |
_NV_SCANOUT_INTENSITY_STATE_DATA |
_NV_SCANOUT_WARPING_STATE_DATA |
_NV_TIMING |
_NV_TIMING_INPUT |
_NV_VIO_TOPOLOGY |
_NVAPI_STEREO_CAPS |
_NVDRS_APPLICATION_V1 |
_NVDRS_APPLICATION_V2 |
_NVDRS_APPLICATION_V3 |
_NVDRS_BINARY_SETTING | Enum to decide on the datatype of setting value
_NVDRS_GPU_SUPPORT |
_NVDRS_PROFILE_V1 |
_NVDRS_SETTING_V1 |
_NVDRS_SETTING_VALUES |
_NVVIOCAPS | Device capabilities
_NVVIOCHANNELSTATUS | Input channel status
_NVVIOCOLORCONVERSION | Colorspace conversion
_NVVIOCOMPOSITERANGE |
_NVVIOCONFIG_V1 |
_NVVIOCONFIG_V2 |
_NVVIOCONFIG_V3 |
_NVVIODATAFORMATDETAIL | Data format details
_NVVIOGAMMACORRECTION | Gamma correction
_NVVIOGAMMARAMP10 | Gamma ramp (10-bit index)
_NVVIOGAMMARAMP8 | Gamma ramp (8-bit index)
_NVVIOINPUTCONFIG | Input device configuration
_NVVIOINPUTSTATUS | Input device status
_NVVIOOUTPUTCONFIG_V1 | Output device configuration
_NVVIOOUTPUTCONFIG_V2 |
_NVVIOOUTPUTCONFIG_V3 |
_NVVIOOUTPUTREGION | Output region
_NVVIOOUTPUTSTATUS | Output device status
_NVVIOPCIINFO |
_NVVIOSIGNALFORMATDETAIL | Signal format details
_NVVIOSTATUS | Video device status
_NVVIOSTREAM | Stream configuration
_NVVIOSYNCDELAY | Sync delay
_NVVIOVIDEOMODE | Video mode information
_SettingDWORDNameString |
_SettingWSTRINGNameString |
NV_CHIPSET_INFO_v1 |
NV_CHIPSET_INFO_v2 |
NV_CHIPSET_INFO_v3 |
NV_CHIPSET_INFO_v4 |
NV_CUSTOM_DISPLAY |
NV_DISPLAY_DRIVER_MEMORY_INFO_V1 |
NV_DISPLAY_DRIVER_MEMORY_INFO_V2 |
NV_DISPLAY_DRIVER_MEMORY_INFO_V3 |
NV_DISPLAY_DRIVER_VERSION |
NV_DISPLAY_PATH |
NV_DISPLAY_PATH_INFO |
NV_DISPLAY_PATH_INFO_V3 |
NV_DISPLAY_PORT_CONFIG |
NV_EDID_V1 |
NV_EDID_V2 | Used in NvAPI_GPU_GetEDID()
NV_EDID_V3 | Used in NvAPI_GPU_GetEDID()
NV_GET_CURRENT_SLI_STATE |
NV_GPU_CLOCK_FREQUENCIES_V1 |
NV_GPU_CLOCK_FREQUENCIES_V2 |
NV_GPU_DYNAMIC_PSTATES_INFO_EX |
NV_GPU_ECC_CONFIGURATION_INFO |
NV_GPU_ECC_ERROR_INFO |
NV_GPU_ECC_STATUS_INFO |
NV_GPU_GET_HDCP_SUPPORT_STATUS | HDPC support status - used in NvAPI_GPU_GetHDCPSupportStatus()
NV_GPU_PERF_PSTATES20_INFO_V1 | Used in NvAPI_GPU_GetPstates20() interface call
NV_GPU_PERF_PSTATES20_PARAM_DELTA | Used to describe both voltage and frequency deltas
NV_GPU_PERF_PSTATES_INFO_V1 |
NV_GPU_PERF_PSTATES_INFO_V2 |
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 | Used to describe single base voltage entry
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 | Used to describe single clock entry
NV_GPU_THERMAL_SETTINGS_V1 |
NV_GPU_THERMAL_SETTINGS_V2 |
NV_I2C_INFO_V1 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
NV_I2C_INFO_V2 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
NV_I2C_INFO_V3 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
NV_INFOFRAME_AUDIO |
NV_INFOFRAME_DATA |
NV_INFOFRAME_PROPERTY |
NV_INFOFRAME_VIDEO | Adding an Auto bit to each field
NV_LID_DOCK_PARAMS |
NV_MOSAIC_DISPLAY_SETTING_V2 |
NV_MOSAIC_DISPLAY_TOPO_STATUS |
NV_MOSAIC_SUPPORTED_TOPOLOGIES | Used in NvAPI_GetSupportedMosaicTopologies()
NV_MOSAIC_TOPO_BRIEF |
NV_MOSAIC_TOPO_DETAILS | This structure defines the topology details
NV_MOSAIC_TOPO_GROUP |
NV_MOSAIC_TOPOLOGY | Used in NvAPI_GetCurrentMosaicTopology() and NvAPI_SetCurrentMosaicTopology()
NV_MULTIGPU_CAPS |
NV_SCANOUT_INTENSITY_DATA_V1 |
NV_SCANOUT_INTENSITY_DATA_V2 |
NV_SCANOUT_WARPING_DATA |
NV_TIMING_FLAG |
NV_VIEW_TARGET_INFO |
NV_VIEWPORTF |
NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 |
NvAPI_D3D11_RASTERIZER_DESC_EX |
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 |
NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 |
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 |
NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 |
NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 |
NvSBox |
NvShaderExtnStruct |
NVVIOTOPOLOGYTARGET |
tagNV_TIMINGEXT |


Data Fields
_NV_BOARD_INFO Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 BoardNum [16]

Field Documentation

NvU8 _NV_BOARD_INFO::BoardNum[16]

Board Serial Number.

NvU32 _NV_BOARD_INFO::version

structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_COLOR_DATA_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 colorFormat
NvU8 colorimetry
} data

Field Documentation

NvU8 _NV_COLOR_DATA_V1::cmd
NvU8 _NV_COLOR_DATA_V1::colorFormat

One of NV_COLOR_FORMAT enum values.

NvU8 _NV_COLOR_DATA_V1::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

struct { ... } _NV_COLOR_DATA_V1::data
NvU16 _NV_COLOR_DATA_V1::size

Size of this structure.

NvU32 _NV_COLOR_DATA_V1::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_COLOR_DATA_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 colorFormat
NvU8 colorimetry
NvU8 dynamicRange
} data

Field Documentation

NvU8 _NV_COLOR_DATA_V2::cmd
NvU8 _NV_COLOR_DATA_V2::colorFormat

One of NV_COLOR_FORMAT enum values.

NvU8 _NV_COLOR_DATA_V2::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

struct { ... } _NV_COLOR_DATA_V2::data
NvU8 _NV_COLOR_DATA_V2::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

NvU16 _NV_COLOR_DATA_V2::size

Size of this structure.

NvU32 _NV_COLOR_DATA_V2::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_COLOR_DATA_V3 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 colorFormat
NvU8 colorimetry
NvU8 dynamicRange
NV_BPC bpc
} data

Field Documentation

NV_BPC _NV_COLOR_DATA_V3::bpc

One of NV_BPC enum values.

NvU8 _NV_COLOR_DATA_V3::cmd
NvU8 _NV_COLOR_DATA_V3::colorFormat

One of NV_COLOR_FORMAT enum values.

NvU8 _NV_COLOR_DATA_V3::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

struct { ... } _NV_COLOR_DATA_V3::data
NvU8 _NV_COLOR_DATA_V3::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

NvU16 _NV_COLOR_DATA_V3::size

Size of this structure.

NvU32 _NV_COLOR_DATA_V3::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DISPLAY_PORT_INFO_V1 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 dpcd_ver
NV_DP_LINK_RATE maxLinkRate
NV_DP_LANE_COUNT maxLaneCount
NV_DP_LINK_RATE curLinkRate
NV_DP_LANE_COUNT curLaneCount
NV_DP_COLOR_FORMAT colorFormat
NV_DP_DYNAMIC_RANGE dynamicRange
NV_DP_COLORIMETRY colorimetry
NV_DP_BPC bpc
NvU32 | isDp: 1
NvU32 | isInternalDp: 1
NvU32 | isColorCtrlSupported: 1
NvU32 | is6BPCSupported: 1
NvU32 | is8BPCSupported: 1
NvU32 | is10BPCSupported: 1
NvU32 | is12BPCSupported: 1
NvU32 | is16BPCSupported: 1
NvU32 | isYCrCb422Supported: 1
NvU32 | isYCrCb444Supported: 1
NvU32 | isRgb444SupportedOnCurrentMode: 1
NvU32 | isYCbCr444SupportedOnCurrentMode: 1
NvU32 | isYCbCr422SupportedOnCurrentMode: 1
NvU32 | is6BPCSupportedOnCurrentMode: 1
NvU32 | is8BPCSupportedOnCurrentMode: 1
NvU32 | is10BPCSupportedOnCurrentMode: 1
NvU32 | is12BPCSupportedOnCurrentMode: 1
NvU32 | is16BPCSupportedOnCurrentMode: 1
NvU32 | isMonxvYCC601Capable: 1
NvU32 | isMonxvYCC709Capable: 1
NvU32 | isMonsYCC601Capable: 1
NvU32 | isMonAdobeYCC601Capable: 1
NvU32 | isMonAdobeRGBCapable: 1
NvU32 | isMonBT2020RGBCapable: 1
NvU32 | isMonBT2020YCCCapable: 1
NvU32 | isMonBT2020cYCCCapable: 1
NvU32 | reserved: 6

Detailed Description

Used in NvAPI_GetDisplayPortInfo().

Field Documentation

NV_DP_BPC _NV_DISPLAY_PORT_INFO_V1::bpc

Current bit-per-component.

NV_DP_COLOR_FORMAT _NV_DISPLAY_PORT_INFO_V1::colorFormat

Current color format.

NV_DP_COLORIMETRY _NV_DISPLAY_PORT_INFO_V1::colorimetry

Ignored in RGB space.

NV_DP_LANE_COUNT _NV_DISPLAY_PORT_INFO_V1::curLaneCount

Current lane count.

NV_DP_LINK_RATE _NV_DISPLAY_PORT_INFO_V1::curLinkRate

Current link rate.

NvU32 _NV_DISPLAY_PORT_INFO_V1::dpcd_ver

DPCD version of the monitor.

NV_DP_DYNAMIC_RANGE _NV_DISPLAY_PORT_INFO_V1::dynamicRange

Dynamic range.

NvU32 _NV_DISPLAY_PORT_INFO_V1::is10BPCSupported

If 10 bpc is supported.

NvU32 _NV_DISPLAY_PORT_INFO_V1::is10BPCSupportedOnCurrentMode

if 10 bpc is supported On Current Mode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is12BPCSupported

If 12 bpc is supported.

NvU32 _NV_DISPLAY_PORT_INFO_V1::is12BPCSupportedOnCurrentMode

if 12 bpc is supported On Current Mode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is16BPCSupported

If 16 bpc is supported.

NvU32 _NV_DISPLAY_PORT_INFO_V1::is16BPCSupportedOnCurrentMode

if 16 bpc is supported On Current Mode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is6BPCSupported

If 6 bpc is supported.

NvU32 _NV_DISPLAY_PORT_INFO_V1::is6BPCSupportedOnCurrentMode

if 6 bpc is supported On Current Mode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is8BPCSupported

If 8 bpc is supported.

NvU32 _NV_DISPLAY_PORT_INFO_V1::is8BPCSupportedOnCurrentMode

if 8 bpc is supported On Current Mode

NvU32 _NV_DISPLAY_PORT_INFO_V1::isColorCtrlSupported

If the color format change is supported.

NvU32 _NV_DISPLAY_PORT_INFO_V1::isDp

If the monitor is driven by a DisplayPort.

NvU32 _NV_DISPLAY_PORT_INFO_V1::isInternalDp

If the monitor is driven by an NV Dp transmitter.

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonAdobeRGBCapable

if AdobeRGB extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonAdobeYCC601Capable

if AdobeYCC601 extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonBT2020cYCCCapable

if BT2020 cYCbCr (constant luminance) extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonBT2020RGBCapable

if BT2020 RGB extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonBT2020YCCCapable

if BT2020 Y'CbCr extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonsYCC601Capable

if sYCC601 extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonxvYCC601Capable

if xvYCC 601 extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonxvYCC709Capable

if xvYCC 709 extended colorimetry is supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isRgb444SupportedOnCurrentMode

If Rgb444 is supported on the current mode.

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCbCr422SupportedOnCurrentMode

If YCbCr422 is support on the current mode.

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCbCr444SupportedOnCurrentMode

If YCbCr444 is supported on the current mode.

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCrCb422Supported

If YCrCb422 is supported.

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCrCb444Supported

If YCrCb444 is supported.

NV_DP_LANE_COUNT _NV_DISPLAY_PORT_INFO_V1::maxLaneCount

Maximum supported lane count.

NV_DP_LINK_RATE _NV_DISPLAY_PORT_INFO_V1::maxLinkRate

Maximum supported link rate.

NvU32 _NV_DISPLAY_PORT_INFO_V1::reserved

reserved

NvU32 _NV_DISPLAY_PORT_INFO_V1::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_ROTATE rotation
NV_SCALING scaling
NvU32 refreshRate1K
NvU32 | interlaced:1
NvU32 | primary:1
NvU32 | reservedBit1:1
NvU32 | disableVirtualModeSupport:1
NvU32 | isPreferredUnscaledTarget:1
NvU32 | reserved:27
NV_GPU_CONNECTOR_TYPE connector
NV_DISPLAY_TV_FORMAT tvFormat
NV_TIMING_OVERRIDE timingOverride
NV_TIMING timing

Field Documentation

NV_GPU_CONNECTOR_TYPE _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::connector

Specify connector type. For TV only, ignored if tvFormat == NV_DISPLAY_TV_FORMAT_NONE.

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::disableVirtualModeSupport
NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::interlaced

(IN) Interlaced mode flag, ignored if refreshRate == 0

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::isPreferredUnscaledTarget
NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::primary

(IN) Declares primary display in clone configuration. This is *NOT* GDI Primary. Only one target can be primary per source. If no primary is specified, the first target will automatically be primary.

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::refreshRate1K

(IN) Non-interlaced Refresh Rate of the mode, multiplied by 1000, 0 = ignored This is the value which driver reports to the OS.

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::reserved
NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::reservedBit1
NV_ROTATE _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::rotation

(IN) rotation setting.

NV_SCALING _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::scaling

(IN) scaling setting.

NV_TIMING _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::timing

Scan out timing, valid only if timingOverride == NV_TIMING_OVERRIDE_CUST The value NV_TIMING::NV_TIMINGEXT::rrx1k is obtained from the EDID. The driver may tweak this value for HDTV, stereo, etc., before reporting it to the OS.

NV_TIMING_OVERRIDE _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::timingOverride

Ignored if timingOverride == NV_TIMING_OVERRIDE_CURRENT.

NV_DISPLAY_TV_FORMAT _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::tvFormat

(IN) to choose the last TV format set this value to NV_DISPLAY_TV_FORMAT_NONE In case of NvAPI_DISP_GetDisplayConfig(), this field will indicate the currently applied TV format; if no TV format is applied, this field will have NV_DISPLAY_TV_FORMAT_NONE value. In case of NvAPI_DISP_SetDisplayConfig(), this field should only be set in case of TVs; for other displays this field will be ignored and resolution & refresh rate specified in input will be used to apply the TV format.

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DISPLAYCONFIG_PATH_INFO_V1 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 reserved_sourceId
NvU32 targetInfoCount
NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 * targetInfo
NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 * sourceModeInfo

Field Documentation

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V1::reserved_sourceId

This field is reserved. There is ongoing debate if we need this field. Identifies sourceIds used by Windows. If all sourceIds are 0, these will be computed automatically.

NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1* _NV_DISPLAYCONFIG_PATH_INFO_V1::sourceModeInfo

May be NULL if mode info is not important.

NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1* _NV_DISPLAYCONFIG_PATH_INFO_V1::targetInfo
NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V1::targetInfoCount

Number of elements in targetInfo array.

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V1::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DISPLAYCONFIG_PATH_INFO_V2 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
union {
NvU32 sourceId
NvU32 reserved_sourceId
};
NvU32 targetInfoCount
NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 * targetInfo
NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 * sourceModeInfo
NvU32 | IsNonNVIDIAAdapter: 1
NvU32 | reserved: 31
void * | pOSAdapterID

Field Documentation

union { ... }
NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::IsNonNVIDIAAdapter

True for non-NVIDIA adapter.

void* _NV_DISPLAYCONFIG_PATH_INFO_V2::pOSAdapterID

Used by Non-NVIDIA adapter for pointer to OS Adapter of LUID type, type casted to void *.

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::reserved

Must be 0.

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::reserved_sourceId

Only for compatibility.

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::sourceId

Identifies sourceId used by Windows CCD. This can be optionally set.

NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1* _NV_DISPLAYCONFIG_PATH_INFO_V2::sourceModeInfo

May be NULL if mode info is not important.

NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2* _NV_DISPLAYCONFIG_PATH_INFO_V2::targetInfo
NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::targetInfoCount

Number of elements in targetInfo array.

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 displayId
NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO * details

Field Documentation

NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO* _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1::details

May be NULL if no advanced settings are required. NULL for Non-NVIDIA Display.

NvU32 _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1::displayId

Display ID.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 displayId
NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO * details
NvU32 targetId

Field Documentation

NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO* _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::details

May be NULL if no advanced settings are required.

NvU32 _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::displayId

Display ID.

NvU32 _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::targetId

Windows CCD target ID. Must be present only for non-NVIDIA adapter, for NVIDIA adapter this parameter is ignored.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NV_RESOLUTION resolution
NV_FORMAT colorFormat
NV_POSITION position
NV_DISPLAYCONFIG_SPANNING_ORIENTATION spanningOrientation
NvU32 | bGDIPrimary: 1
NvU32 | bSLIFocus: 1
NvU32 | reserved: 30

Field Documentation

NvU32 _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::bGDIPrimary
NvU32 _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::bSLIFocus
NV_FORMAT _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::colorFormat

Ignored at present, must be NV_FORMAT_UNKNOWN (0)

NV_POSITION _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::position

Is all positions are 0 or invalid, displays will be automatically positioned from left to right with GDI Primary at 0,0, and all other displays in the order of the path array.

NvU32 _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::reserved

Must be 0.

NV_RESOLUTION _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::resolution
NV_DISPLAYCONFIG_SPANNING_ORIENTATION _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::spanningOrientation

Spanning is only supported on XP.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_DX_VIDEO_STEREO_INFO Struct Reference
DirectX Video Control

#include <nvapi.h>

Data Fields

NvU32 dwVersion
NVDX_ObjectHandle | hSurface
NVDX_ObjectHandle | hLinkedSurface
NV_STEREO_VIDEO_FORMAT eFormat
NvS32 sViewOffset
BOOL | bStereoEnable

Field Documentation

BOOL _NV_DX_VIDEO_STEREO_INFO::bStereoEnable

Whether stereo rendering should be enabled (if FALSE, only left view will be used)

NvU32 _NV_DX_VIDEO_STEREO_INFO::dwVersion

Must be NV_DX_VIDEO_STEREO_INFO_VER.

NV_STEREO_VIDEO_FORMAT _NV_DX_VIDEO_STEREO_INFO::eFormat

Stereo format of the surface.

NVDX_ObjectHandle _NV_DX_VIDEO_STEREO_INFO::hLinkedSurface

The linked surface (must be valid when eFormat==NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR)

NVDX_ObjectHandle _NV_DX_VIDEO_STEREO_INFO::hSurface

The surface whose stereo format is to be set.

NvS32 _NV_DX_VIDEO_STEREO_INFO::sViewOffset

Signed offset of each view (positive offset indicating left view is shifted left)

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GPU_DISPLAYIDS Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_MONITOR_CONN_TYPE connectorType
NvU32 displayId
NvU32 | isDynamic:1
NvU32 | isMultiStreamRootNode:1
NvU32 | isActive:1
NvU32 | isCluster:1
NvU32 | isOSVisible:1
NvU32 | isWFD:1
NvU32 | isConnected:1
NvU32 | reservedInternal:10
NvU32 | isPhysicallyConnected:1
NvU32 | reserved: 14

Field Documentation

NV_MONITOR_CONN_TYPE _NV_GPU_DISPLAYIDS::connectorType

out: vga, tv, dvi, hdmi and dp. This is reserved for future use and clients should not rely on this information. Instead get the GPU connector type from NvAPI_GPU_GetConnectorInfo/NvAPI_GPU_GetConnectorInfoEx

NvU32 _NV_GPU_DISPLAYIDS::displayId

this is a unique identifier for each device

NvU32 _NV_GPU_DISPLAYIDS::isActive

if bit is set then this display is being actively driven

NvU32 _NV_GPU_DISPLAYIDS::isCluster

if bit is set then this display is the representative display

NvU32 _NV_GPU_DISPLAYIDS::isConnected

if bit is set, then this display is connected

NvU32 _NV_GPU_DISPLAYIDS::isDynamic

if bit is set then this display is part of MST topology and it's a dynamic

NvU32 _NV_GPU_DISPLAYIDS::isMultiStreamRootNode

if bit is set then this displayID belongs to a multi stream enabled connector(root node). Note that when multi stream is enabled and a single multi stream capable monitor is connected to it, the monitor will share the display id with the RootNode. When there is more than one monitor connected in a multi stream topology, then the root node will have a separate displayId.

NvU32 _NV_GPU_DISPLAYIDS::isOSVisible

if bit is set, then this display is reported to the OS

NvU32 _NV_GPU_DISPLAYIDS::isPhysicallyConnected

if bit is set, then this display is a phycially connected display; Valid only when isConnected bit is set

NvU32 _NV_GPU_DISPLAYIDS::isWFD

if bit is set, then this display is wireless

NvU32 _NV_GPU_DISPLAYIDS::reserved

must be zero

NvU32 _NV_GPU_DISPLAYIDS::reservedInternal

Do not use.

NvU32 _NV_GPU_DISPLAYIDS::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GPU_GET_ILLUMINATION_PARM_V1 Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle hPhysicalGpu
NV_GPU_ILLUMINATION_ATTRIB Attribute
NvU32 Value

Field Documentation

NV_GPU_ILLUMINATION_ATTRIB _NV_GPU_GET_ILLUMINATION_PARM_V1::Attribute

An enumeration value specifying the Illumination attribute to be querried. refer to enum NV_GPU_ILLUMINATION_ATTRIB.

NvPhysicalGpuHandle _NV_GPU_GET_ILLUMINATION_PARM_V1::hPhysicalGpu

The handle of the GPU that you are checking for the specified attribute. Note that this is the GPU that is managing the attribute. Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You enumerate thru the GPUs with this call to determine which GPU is managing the attribute.

NvU32 _NV_GPU_GET_ILLUMINATION_PARM_V1::Value

A DWORD that will contain the current value of the specified attribute. This is specified as a percentage of the full range of the attribute (0-100; 0 = off, 100 = full brightness)

NvU32 _NV_GPU_GET_ILLUMINATION_PARM_V1::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GPU_PERF_PSTATES20_INFO_V2 Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bIsEditable:1
NvU32 | reserved:31
NvU32 numPstates
NvU32 numClocks
NvU32 numBaseVoltages
struct {
NV_GPU_PERF_PSTATE_ID pstateId
NvU32 bIsEditable:1
NvU32 reserved:31
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]
} pstates [NVAPI_MAX_GPU_PSTATE20_PSTATES]
struct {
NvU32 numVoltages
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 voltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]
} ov

Detailed Description

Used in NvAPI_GPU_GetPstates20() interface call.

Field Documentation

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::baseVoltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of baseVoltage entries Valid index range is 0 to numBaseVoltages-1

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::bIsEditable
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::clocks[NVAPI_MAX_GPU_PSTATE20_CLOCKS]

Array of clock entries Valid index range is 0 to numClocks-1

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numBaseVoltages

Number of populated base voltages (per pstate)

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numClocks

Number of populated clocks (per pstate)

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numPstates

Number of populated pstates.

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numVoltages

Number of populated voltages.

struct { ... } _NV_GPU_PERF_PSTATES20_INFO_V2::ov

OV settings - Please refer to NVIDIA over-volting recommendation to understand impact of this functionality Valid index range is 0 to numVoltages-1

NV_GPU_PERF_PSTATE_ID _NV_GPU_PERF_PSTATES20_INFO_V2::pstateId

ID of the P-State.

struct { ... } _NV_GPU_PERF_PSTATES20_INFO_V2::pstates[NVAPI_MAX_GPU_PSTATE20_PSTATES]

Performance state (P-State) settings Valid index range is 0 to numPstates-1

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::reserved

These bits are reserved for future use (must be always 0)

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::version

Version info of the structure (NV_GPU_PERF_PSTATES20_INFO_VER<n>)

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::voltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of voltage entries Valid index range is 0 to numVoltages-1

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle hPhysicalGpu
NV_GPU_ILLUMINATION_ATTRIB Attribute
NvU32 bSupported

Field Documentation

NV_GPU_ILLUMINATION_ATTRIB _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::Attribute

An enumeration value specifying the Illumination attribute to be querried. refer to enum NV_GPU_ILLUMINATION_ATTRIB.

NvU32 _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::bSupported

A boolean indicating if the attribute is supported.

NvPhysicalGpuHandle _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::hPhysicalGpu

The handle of the GPU that you are checking for the specified attribute. note that this is the GPU that is managing the attribute. Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You enumerate thru the GPUs with this call to determine which GPU is managing the attribute.

NvU32 _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GPU_SET_ILLUMINATION_PARM_V1 Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle hPhysicalGpu
NV_GPU_ILLUMINATION_ATTRIB Attribute
NvU32 Value

Field Documentation

NV_GPU_ILLUMINATION_ATTRIB _NV_GPU_SET_ILLUMINATION_PARM_V1::Attribute

An enumeration value specifying the Illumination attribute to be querried. refer to enum NV_GPU_ILLUMINATION_ATTRIB.

NvPhysicalGpuHandle _NV_GPU_SET_ILLUMINATION_PARM_V1::hPhysicalGpu

The handle of the GPU that you are checking for the specified attribute. Note that this is the GPU that is managing the attribute. Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You enumerate thru the GPUs with this call to determine which GPU is managing the attribute.

NvU32 _NV_GPU_SET_ILLUMINATION_PARM_V1::Value

A DWORD containing the new value for the specified attribute. This should be specified as a percentage of the full range of the attribute (0-100; 0 = off, 100 = full brightness) If a value is specified outside this range, NVAPI_INVALID_ARGUMENT will be returned.

NvU32 _NV_GPU_SET_ILLUMINATION_PARM_V1::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GSYNC_CAPABILITIES_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 boardId
NvU32 revision
NvU32 capFlags

Detailed Description

Used in NvAPI_GSync_QueryCapabilities().

Field Documentation

NvU32 _NV_GSYNC_CAPABILITIES_V1::boardId

Board ID.

NvU32 _NV_GSYNC_CAPABILITIES_V1::capFlags

Capabilities of the Sync board. Reserved for future use.

NvU32 _NV_GSYNC_CAPABILITIES_V1::revision

FPGA Revision.

NvU32 _NV_GSYNC_CAPABILITIES_V1::version

Version of the structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GSYNC_CONTROL_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NVAPI_GSYNC_POLARITY polarity
NVAPI_GSYNC_VIDEO_MODE vmode
NvU32 interval
NVAPI_GSYNC_SYNC_SOURCE source
NvU32 | interlaceMode:1
NvU32 | reserved:31
NV_GSYNC_DELAY syncSkew
NV_GSYNC_DELAY startupDelay

Detailed Description

Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters().

Field Documentation

NvU32 _NV_GSYNC_CONTROL_PARAMS::interlaceMode

interlace mode for a Sync device

NvU32 _NV_GSYNC_CONTROL_PARAMS::interval

Number of pulses to wait between framelock signal generation.

NVAPI_GSYNC_POLARITY _NV_GSYNC_CONTROL_PARAMS::polarity

Leading edge / Falling edge / both.

NvU32 _NV_GSYNC_CONTROL_PARAMS::reserved

should be set zero

NVAPI_GSYNC_SYNC_SOURCE _NV_GSYNC_CONTROL_PARAMS::source

VSync/House sync.

NV_GSYNC_DELAY _NV_GSYNC_CONTROL_PARAMS::startupDelay

Sync start delay for master.

NV_GSYNC_DELAY _NV_GSYNC_CONTROL_PARAMS::syncSkew

The time delay between the frame sync signal and the GPUs signal.

NvU32 _NV_GSYNC_CONTROL_PARAMS::version

Version of the structure.

NVAPI_GSYNC_VIDEO_MODE _NV_GSYNC_CONTROL_PARAMS::vmode

None, TTL, NTSCPALSECAM, HDTV.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GSYNC_DELAY Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numLines
NvU32 numPixels
NvU32 maxLines
NvU32 minPixels

Detailed Description

Used in NV_GSYNC_CONTROL_PARAMS.

Field Documentation

NvU32 _NV_GSYNC_DELAY::maxLines

maximum number of lines supported at current display mode to induce delay. Updated by NvAPI_GSync_GetControlParameters(). Read only.

NvU32 _NV_GSYNC_DELAY::minPixels

minimum number of pixels required at current display mode to induce delay. Updated by NvAPI_GSync_GetControlParameters(). Read only.

NvU32 _NV_GSYNC_DELAY::numLines

delay to be induced in number of horizontal lines.

NvU32 _NV_GSYNC_DELAY::numPixels

delay to be induced in number of pixels.

NvU32 _NV_GSYNC_DELAY::version

Version of the structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GSYNC_DISPLAY Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvU32 | isMasterable: 1
NvU32 | reserved: 31
NVAPI_GSYNC_DISPLAY_SYNC_STATE syncState

Field Documentation

NvU32 _NV_GSYNC_DISPLAY::displayId

display identifier for displays.The GPU to which it is connected, can be retireved from NvAPI_SYS_GetPhysicalGpuFromDisplayId

NvU32 _NV_GSYNC_DISPLAY::isMasterable

Can this display be the master? (Read only)

NvU32 _NV_GSYNC_DISPLAY::reserved

Should be set to ZERO.

NVAPI_GSYNC_DISPLAY_SYNC_STATE _NV_GSYNC_DISPLAY::syncState

Is this display slave/master (Retrieved with topology or set by caller for enable/disable sync)

NvU32 _NV_GSYNC_DISPLAY::version

Version of the structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GSYNC_GPU Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle | hPhysicalGpu
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR connector
NvPhysicalGpuHandle | hProxyPhysicalGpu
NvU32 | isSynced: 1
NvU32 | reserved: 31

Field Documentation

NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR _NV_GSYNC_GPU::connector

Indicates which connector on the device the GPU is connected to.

NvPhysicalGpuHandle _NV_GSYNC_GPU::hPhysicalGpu

GPU handle.

NvPhysicalGpuHandle _NV_GSYNC_GPU::hProxyPhysicalGpu

GPU through which hPhysicalGpu is connected to the Sync device (if not directly connected)

  • this is NULL otherwise
NvU32 _NV_GSYNC_GPU::isSynced

Whether this GPU is sync'd or not.

NvU32 _NV_GSYNC_GPU::reserved

Should be set to ZERO.

NvU32 _NV_GSYNC_GPU::version

Version of the structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GSYNC_STATUS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bIsSynced
NvU32 bIsStereoSynced
NvU32 bIsSyncSignalAvailable

Detailed Description

Used in NvAPI_GSync_GetSyncStatus().

Field Documentation

NvU32 _NV_GSYNC_STATUS::bIsStereoSynced

Does the phase of the timing signal from the GPU = the phase of the master sync signal?

NvU32 _NV_GSYNC_STATUS::bIsSynced

Is timing in sync?

NvU32 _NV_GSYNC_STATUS::bIsSyncSignalAvailable

Is the sync signal available?

NvU32 _NV_GSYNC_STATUS::version

Version of the structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_GSYNC_STATUS_PARAMS Struct Reference
Quadro G-Sync APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 refreshRate
NVAPI_GSYNC_RJ45_IO RJ45_IO [NVAPI_MAX_RJ45_PER_GSYNC]
NvU32 RJ45_Ethernet [NVAPI_MAX_RJ45_PER_GSYNC]
NvU32 houseSyncIncoming
NvU32 bHouseSync

Detailed Description

Used in NvAPI_GSync_GetStatusParameters().

Field Documentation

NvU32 _NV_GSYNC_STATUS_PARAMS::bHouseSync

Is house sync connected?

NvU32 _NV_GSYNC_STATUS_PARAMS::houseSyncIncoming

Incoming house sync frequency in Hz.

NvU32 _NV_GSYNC_STATUS_PARAMS::refreshRate

The refresh rate.

NvU32 _NV_GSYNC_STATUS_PARAMS::RJ45_Ethernet[NVAPI_MAX_RJ45_PER_GSYNC]

Connected to ethernet hub? [ERRONEOUSLY CONNECTED!].

NVAPI_GSYNC_RJ45_IO _NV_GSYNC_STATUS_PARAMS::RJ45_IO[NVAPI_MAX_RJ45_PER_GSYNC]

Configured as input / output.

NvU32 _NV_GSYNC_STATUS_PARAMS::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_HDMI_SUPPORT_INFO_V1 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isGpuHDMICapable: 1
NvU32 | isMonUnderscanCapable: 1
NvU32 | isMonBasicAudioCapable: 1
NvU32 | isMonYCbCr444Capable: 1
NvU32 | isMonYCbCr422Capable: 1
NvU32 | isMonxvYCC601Capable: 1
NvU32 | isMonxvYCC709Capable: 1
NvU32 | isMonHDMI: 1
NvU32 | reserved: 24
NvU32 EDID861ExtRev

Detailed Description

Used in NvAPI_GetHDMISupportInfo().

Field Documentation

NvU32 _NV_HDMI_SUPPORT_INFO_V1::EDID861ExtRev

Revision number of the EDID 861 extension.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isGpuHDMICapable

If the GPU can handle HDMI.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonBasicAudioCapable

If the monitor supports basic audio.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonHDMI

If the monitor is HDMI (with IEEE's HDMI registry ID)

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonUnderscanCapable

If the monitor supports underscan.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonxvYCC601Capable

If xvYCC 601 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonxvYCC709Capable

If xvYCC 709 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonYCbCr422Capable

If YCbCr 4:2:2 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonYCbCr444Capable

If YCbCr 4:4:4 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::reserved

Reserved.

NvU32 _NV_HDMI_SUPPORT_INFO_V1::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_HDMI_SUPPORT_INFO_V2 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isGpuHDMICapable: 1
NvU32 | isMonUnderscanCapable: 1
NvU32 | isMonBasicAudioCapable: 1
NvU32 | isMonYCbCr444Capable: 1
NvU32 | isMonYCbCr422Capable: 1
NvU32 | isMonxvYCC601Capable: 1
NvU32 | isMonxvYCC709Capable: 1
NvU32 | isMonHDMI: 1
NvU32 | isMonsYCC601Capable: 1
NvU32 | isMonAdobeYCC601Capable: 1
NvU32 | isMonAdobeRGBCapable: 1
NvU32 | reserved: 21
NvU32 EDID861ExtRev

Detailed Description

Used in NvAPI_GetHDMISupportInfo().

Field Documentation

NvU32 _NV_HDMI_SUPPORT_INFO_V2::EDID861ExtRev

Revision number of the EDID 861 extension.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isGpuHDMICapable

If the GPU can handle HDMI.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonAdobeRGBCapable

if AdobeRGB extended colorimetry is supported

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonAdobeYCC601Capable

if AdobeYCC601 extended colorimetry is supported

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonBasicAudioCapable

If the monitor supports basic audio.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonHDMI

If the monitor is HDMI (with IEEE's HDMI registry ID)

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonsYCC601Capable

if sYCC601 extended colorimetry is supported

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonUnderscanCapable

If the monitor supports underscan.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonxvYCC601Capable

If xvYCC extended colorimetry 601 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonxvYCC709Capable

If xvYCC extended colorimetry 709 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonYCbCr422Capable

If YCbCr 4:2:2 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonYCbCr444Capable

If YCbCr 4:4:4 is supported.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::reserved

Reserved.

NvU32 _NV_HDMI_SUPPORT_INFO_V2::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MONITOR_CAPABILITIES_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU32 infoType
NvU32 connectorType
NvU8 bIsValidInfo: 1
union {
NV_MONITOR_CAPS_VSDB vsdb
NV_MONITOR_CAPS_VCDB vcdb
} data

Detailed Description

See NvAPI_DISP_GetMonitorCapabilities().

Field Documentation

NvU8 _NV_MONITOR_CAPABILITIES_V1::bIsValidInfo

Boolean : Returns invalid if requested info is not present such as VCDB not present.

NvU32 _NV_MONITOR_CAPABILITIES_V1::connectorType

Out: VGA, TV, DVI, HDMI, DP.

union { ... } _NV_MONITOR_CAPABILITIES_V1::data
NvU32 _NV_MONITOR_CAPABILITIES_V1::infoType
NvU16 _NV_MONITOR_CAPABILITIES_V1::size
NV_MONITOR_CAPS_VCDB _NV_MONITOR_CAPABILITIES_V1::vcdb
NvU32 _NV_MONITOR_CAPABILITIES_V1::version
NV_MONITOR_CAPS_VSDB _NV_MONITOR_CAPABILITIES_V1::vsdb
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MONITOR_CAPS_VCDB Struct Reference

#include <nvapi.h>

Data Fields

NvU8 | quantizationRangeYcc: 1
NvU8 | quantizationRangeRgb: 1
NvU8 | scanInfoPreferredVideoFormat: 2
NvU8 | scanInfoITVideoFormats: 2
NvU8 | scanInfoCEVideoFormats: 2

Field Documentation

NvU8 _NV_MONITOR_CAPS_VCDB::quantizationRangeRgb
NvU8 _NV_MONITOR_CAPS_VCDB::quantizationRangeYcc
NvU8 _NV_MONITOR_CAPS_VCDB::scanInfoCEVideoFormats
NvU8 _NV_MONITOR_CAPS_VCDB::scanInfoITVideoFormats
NvU8 _NV_MONITOR_CAPS_VCDB::scanInfoPreferredVideoFormat
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MONITOR_CAPS_VSDB Struct Reference

#include <nvapi.h>

Data Fields

NvU8 | sourcePhysicalAddressB: 4
NvU8 | sourcePhysicalAddressA: 4
NvU8 | sourcePhysicalAddressD: 4
NvU8 | sourcePhysicalAddressC: 4
NvU8 | supportDualDviOperation: 1
NvU8 | reserved6: 2
NvU8 | supportDeepColorYCbCr444: 1
NvU8 | supportDeepColor30bits: 1
NvU8 | supportDeepColor36bits: 1
NvU8 | supportDeepColor48bits: 1
NvU8 | supportAI: 1
NvU8 maxTmdsClock
NvU8 | cnc0SupportGraphicsTextContent: 1
NvU8 | cnc1SupportPhotoContent: 1
NvU8 | cnc2SupportCinemaContent: 1
NvU8 | cnc3SupportGameContent: 1
NvU8 | reserved8: 1
NvU8 | hasVicEntries: 1
NvU8 | hasInterlacedLatencyField: 1
NvU8 | hasLatencyField: 1
NvU8 videoLatency
NvU8 audioLatency
NvU8 interlacedVideoLatency
NvU8 interlacedAudioLatency
NvU8 | reserved13: 7
NvU8 | has3dEntries: 1
NvU8 | hdmi3dLength: 5
NvU8 | hdmiVicLength: 3
NvU8 | hdmi_vic [7]
NvU8 | hdmi_3d [31]

Detailed Description

See NvAPI_DISP_GetMonitorCapabilities().

Field Documentation

NvU8 _NV_MONITOR_CAPS_VSDB::audioLatency

Byte 7.

NvU8 _NV_MONITOR_CAPS_VSDB::cnc0SupportGraphicsTextContent

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::cnc1SupportPhotoContent

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::cnc2SupportCinemaContent

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::cnc3SupportGameContent

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::has3dEntries

Byte 10.

NvU8 _NV_MONITOR_CAPS_VSDB::hasInterlacedLatencyField

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::hasLatencyField

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::hasVicEntries

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::hdmi3dLength

Byte 11.

NvU8 _NV_MONITOR_CAPS_VSDB::hdmi_3d[31]

Keeping maximum length for 5 bits.

NvU8 _NV_MONITOR_CAPS_VSDB::hdmi_vic[7]

Keeping maximum length for 3 bits.

NvU8 _NV_MONITOR_CAPS_VSDB::hdmiVicLength

Byte 11.

NvU8 _NV_MONITOR_CAPS_VSDB::interlacedAudioLatency

Byte 9.

NvU8 _NV_MONITOR_CAPS_VSDB::interlacedVideoLatency

Byte 8.

NvU8 _NV_MONITOR_CAPS_VSDB::maxTmdsClock

Bye 4.

NvU8 _NV_MONITOR_CAPS_VSDB::reserved13

Byte 10.

NvU8 _NV_MONITOR_CAPS_VSDB::reserved6

Byte 3.

NvU8 _NV_MONITOR_CAPS_VSDB::reserved8

Byte 5.

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressA

Byte 1.

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressB

Byte 1.

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressC

Byte 2.

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressD

Byte 2.

NvU8 _NV_MONITOR_CAPS_VSDB::supportAI

Byte 3.

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColor30bits

Byte 3.

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColor36bits

Byte 3.

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColor48bits

Byte 3.

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColorYCbCr444

Byte 3.

NvU8 _NV_MONITOR_CAPS_VSDB::supportDualDviOperation

Byte 3.

NvU8 _NV_MONITOR_CAPS_VSDB::videoLatency

Byte 6.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MONITOR_COLOR_DATA Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_DP_COLOR_FORMAT colorFormat
NV_DP_BPC backendBitDepths

Field Documentation

NV_DP_BPC _NV_MONITOR_COLOR_DATA::backendBitDepths

One of the supported bit depths.

NV_DP_COLOR_FORMAT _NV_MONITOR_COLOR_DATA::colorFormat

One of the supported color formats.

NvU32 _NV_MONITOR_COLOR_DATA::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MOSAIC_DISPLAY_SETTING_V1 Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
NvU32 bpp
NvU32 freq

Detailed Description

Basic per-display settings that are used in setting/getting the Mosaic mode.

Field Documentation

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::bpp

Bits per pixel.

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::freq

Display frequency.

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::height

Per-display height.

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::version

Version of this structure.

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::width

Per-display width.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MOSAIC_GRID_TOPO_DISPLAY_V1 Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 displayId
NvS32 overlapX
NvS32 overlapY
NV_ROTATE rotation
NvU32 cloneGroup

Field Documentation

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::cloneGroup

Reserved, must be 0.

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::displayId

DisplayID of the display.

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::overlapX

(+overlap, -gap)

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::overlapY

(+overlap, -gap)

NV_ROTATE _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::rotation

Rotation of display.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MOSAIC_GRID_TOPO_DISPLAY_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvS32 overlapX
NvS32 overlapY
NV_ROTATE rotation
NvU32 cloneGroup
NV_PIXEL_SHIFT_TYPE pixelShiftType

Field Documentation

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::cloneGroup

Reserved, must be 0.

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::displayId

DisplayID of the display.

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::overlapX

(+overlap, -gap)

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::overlapY

(+overlap, -gap)

NV_PIXEL_SHIFT_TYPE _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::pixelShiftType

Type of the pixel shift enabled display.

NV_ROTATE _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::rotation

Rotation of display.

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MOSAIC_GRID_TOPO_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 rows
NvU32 columns
NvU32 displayCount
NvU32 | applyWithBezelCorrect: 1
NvU32 | immersiveGaming: 1
NvU32 | baseMosaic: 1
NvU32 | driverReloadAllowed: 1
NvU32 | acceleratePrimaryDisplay: 1
NvU32 | reserved: 27
NV_MOSAIC_GRID_TOPO_DISPLAY_V1 displays [NV_MOSAIC_MAX_DISPLAYS]
NV_MOSAIC_DISPLAY_SETTING_V1 displaySettings

Field Documentation

NvU32 _NV_MOSAIC_GRID_TOPO_V1::acceleratePrimaryDisplay

Enable SLI acceleration on the primary display while in single-wide mode (For Immersive Gaming only). Will not be persisted. Value undefined on get.

NvU32 _NV_MOSAIC_GRID_TOPO_V1::applyWithBezelCorrect

When enabling and doing the modeset, do we switch to the bezel-corrected resolution.

NvU32 _NV_MOSAIC_GRID_TOPO_V1::baseMosaic

Enable as Base Mosaic (Panoramic) instead of Mosaic SLI (for NVS and Quadro-boards only)

NvU32 _NV_MOSAIC_GRID_TOPO_V1::columns

Number of columns.

NvU32 _NV_MOSAIC_GRID_TOPO_V1::displayCount

Number of display details.

NV_MOSAIC_GRID_TOPO_DISPLAY_V1 _NV_MOSAIC_GRID_TOPO_V1::displays[NV_MOSAIC_MAX_DISPLAYS]

Displays are done as [(row * columns) + column].

NV_MOSAIC_DISPLAY_SETTING_V1 _NV_MOSAIC_GRID_TOPO_V1::displaySettings

Display settings.

NvU32 _NV_MOSAIC_GRID_TOPO_V1::driverReloadAllowed

If necessary, reloading the driver is permitted (for Vista and above only). Will not be persisted. Value undefined on get.

NvU32 _NV_MOSAIC_GRID_TOPO_V1::immersiveGaming

Enable as immersive gaming instead of Mosaic SLI (for Quadro-boards only)

NvU32 _NV_MOSAIC_GRID_TOPO_V1::reserved

Reserved, must be 0.

NvU32 _NV_MOSAIC_GRID_TOPO_V1::rows

Number of rows.

NvU32 _NV_MOSAIC_GRID_TOPO_V1::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MOSAIC_GRID_TOPO_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 rows
NvU32 columns
NvU32 displayCount
NvU32 | applyWithBezelCorrect: 1
NvU32 | immersiveGaming: 1
NvU32 | baseMosaic: 1
NvU32 | driverReloadAllowed: 1
NvU32 | acceleratePrimaryDisplay: 1
NvU32 | pixelShift: 1
NvU32 | reserved: 26
NV_MOSAIC_GRID_TOPO_DISPLAY_V2 displays [NV_MOSAIC_MAX_DISPLAYS]
NV_MOSAIC_DISPLAY_SETTING_V1 displaySettings

Field Documentation

NvU32 _NV_MOSAIC_GRID_TOPO_V2::acceleratePrimaryDisplay

Enable SLI acceleration on the primary display while in single-wide mode (For Immersive Gaming only). Will not be persisted. Value undefined on get.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::applyWithBezelCorrect

When enabling and doing the modeset, do we switch to the bezel-corrected resolution.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::baseMosaic

Enable as Base Mosaic (Panoramic) instead of Mosaic SLI (for NVS and Quadro-boards only)

NvU32 _NV_MOSAIC_GRID_TOPO_V2::columns

Number of columns.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::displayCount

Number of display details.

NV_MOSAIC_GRID_TOPO_DISPLAY_V2 _NV_MOSAIC_GRID_TOPO_V2::displays[NV_MOSAIC_MAX_DISPLAYS]

Displays are done as [(row * columns) + column].

NV_MOSAIC_DISPLAY_SETTING_V1 _NV_MOSAIC_GRID_TOPO_V2::displaySettings

Display settings.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::driverReloadAllowed

If necessary, reloading the driver is permitted (for Vista and above only). Will not be persisted. Value undefined on get.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::immersiveGaming

Enable as immersive gaming instead of Mosaic SLI (for Quadro-boards only)

NvU32 _NV_MOSAIC_GRID_TOPO_V2::pixelShift

Enable Pixel shift.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::reserved

Reserved, must be 0.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::rows

Number of rows.

NvU32 _NV_MOSAIC_GRID_TOPO_V2::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 topoBriefsCount
NV_MOSAIC_TOPO_BRIEF topoBriefs [NV_MOSAIC_TOPO_MAX]
NvU32 displaySettingsCount
NV_MOSAIC_DISPLAY_SETTING_V1 displaySettings [NV_MOSAIC_DISPLAY_SETTINGS_MAX]

Detailed Description

so arrays are bound.

This structure is used to contain a list of supported Mosaic topologies along with the display settings that can be used.

Field Documentation

NV_MOSAIC_DISPLAY_SETTING_V1 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::displaySettings[NV_MOSAIC_DISPLAY_SETTINGS_MAX]

List of per display settings possible.

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::displaySettingsCount

Number of display settings in below array.

NV_MOSAIC_TOPO_BRIEF _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::topoBriefs[NV_MOSAIC_TOPO_MAX]

List of supported topologies with only brief details.

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::topoBriefsCount

Number of topologies in below array.

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 topoBriefsCount
NV_MOSAIC_TOPO_BRIEF topoBriefs [NV_MOSAIC_TOPO_MAX]
NvU32 displaySettingsCount
NV_MOSAIC_DISPLAY_SETTING_V2 displaySettings [NV_MOSAIC_DISPLAY_SETTINGS_MAX]

Field Documentation

NV_MOSAIC_DISPLAY_SETTING_V2 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::displaySettings[NV_MOSAIC_DISPLAY_SETTINGS_MAX]

List of per display settings possible.

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::displaySettingsCount

Number of display settings in below array.

NV_MOSAIC_TOPO_BRIEF _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::topoBriefs[NV_MOSAIC_TOPO_MAX]

List of supported topologies with only brief details.

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::topoBriefsCount

Number of topologies in below array.

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_POSITION Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvS32 x
NvS32 y

Field Documentation

NvS32 _NV_POSITION::x
NvS32 _NV_POSITION::y
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_RECT Struct Reference

#include <nvapi_lite_common.h>

Data Fields

NvU32 left
NvU32 top
NvU32 right
NvU32 bottom

Field Documentation

NvU32 _NV_RECT::bottom
NvU32 _NV_RECT::left
NvU32 _NV_RECT::right
NvU32 _NV_RECT::top
The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
_NV_RESOLUTION Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 width
NvU32 height
NvU32 colorDepth

Field Documentation

NvU32 _NV_RESOLUTION::colorDepth
NvU32 _NV_RESOLUTION::height
NvU32 _NV_RESOLUTION::width
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_SCANOUT_INFORMATION Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvSBox sourceDesktopRect
NvSBox sourceViewportRect
NvSBox targetViewportRect
NvU32 targetDisplayWidth
NvU32 targetDisplayHeight
NvU32 cloneImportance
NV_ROTATE sourceToTargetRotation

Detailed Description

Used in NvAPI_GPU_GetScanoutConfigurationEx().

Field Documentation

NvU32 _NV_SCANOUT_INFORMATION::cloneImportance

If targets are cloned views of the sourceDesktopRect the cloned targets have an importance assigned (0:primary,1 secondary,...).

NvSBox _NV_SCANOUT_INFORMATION::sourceDesktopRect

Operating system display device rect in desktop coordinates displayId is scanning out from.

NV_ROTATE _NV_SCANOUT_INFORMATION::sourceToTargetRotation

Rotation performed between the sourceViewportRect and the targetViewportRect.

NvSBox _NV_SCANOUT_INFORMATION::sourceViewportRect

Area inside the sourceDesktopRect which is scanned out to the display.

NvU32 _NV_SCANOUT_INFORMATION::targetDisplayHeight

Vertical size of the active resolution scanned out to the display.

NvU32 _NV_SCANOUT_INFORMATION::targetDisplayWidth

Horizontal size of the active resolution scanned out to the display.

NvSBox _NV_SCANOUT_INFORMATION::targetViewportRect

Area inside the rect described by targetDisplayWidth/Height sourceViewportRect is scanned out to.

NvU32 _NV_SCANOUT_INFORMATION::version

Structure version, needs to be initialized with NV_SCANOUT_INFORMATION_VER.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_SCANOUT_INTENSITY_STATE_DATA Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bEnabled

Field Documentation

NvU32 _NV_SCANOUT_INTENSITY_STATE_DATA::bEnabled

intensity is enabled or not

NvU32 _NV_SCANOUT_INTENSITY_STATE_DATA::version

version of this structure

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_SCANOUT_WARPING_STATE_DATA Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bEnabled

Field Documentation

NvU32 _NV_SCANOUT_WARPING_STATE_DATA::bEnabled

warping is enabled or not

NvU32 _NV_SCANOUT_WARPING_STATE_DATA::version

version of this structure

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_TIMING Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU16 HVisible
NvU16 HBorder
NvU16 HFrontPorch
NvU16 HSyncWidth
NvU16 HTotal
NvU8 HSyncPol
NvU16 VVisible
NvU16 VBorder
NvU16 VFrontPorch
NvU16 VSyncWidth
NvU16 VTotal
NvU8 VSyncPol
NvU16 interlaced
NvU32 pclk
NV_TIMINGEXT etc

Detailed Description

The very basic timing structure based on the VESA standard:

            |<----------------------------htotal--------------------------->|
             ---------"active" video-------->|<-------blanking------>|<-----
            |<-------hvisible-------->|<-hb->|<-hfp->|<-hsw->|<-hbp->|<-hb->|
 --------- -+-------------------------+      |       |       |       |      |
   A      A |                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
   :vertical|    addressable video    |      |       |       |       |      |
   : visible|                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
   :      : |                         |      |       |       |       |      |
 vertical V |                         |      |       |       |       |      |
  total   --+-------------------------+      |       |       |       |      |
   :      vb         border                  |       |       |       |      |
   :      -----------------------------------+       |       |       |      |
   :      vfp        front porch                     |       |       |      |
   :      -------------------------------------------+       |       |      |
   :      vsw        sync width                              |       |      |
   :      ---------------------------------------------------+       |      |
   :      vbp        back porch                                      |      |
   :      -----------------------------------------------------------+      |
   V      vb         border                                                 |
 ---------------------------------------------------------------------------+

Field Documentation

NV_TIMINGEXT _NV_TIMING::etc
NvU16 _NV_TIMING::HBorder

horizontal border

NvU16 _NV_TIMING::HFrontPorch

horizontal front porch

NvU8 _NV_TIMING::HSyncPol

horizontal sync polarity: 1-negative, 0-positive

NvU16 _NV_TIMING::HSyncWidth

horizontal sync width

NvU16 _NV_TIMING::HTotal

horizontal total

NvU16 _NV_TIMING::HVisible

horizontal visible

NvU16 _NV_TIMING::interlaced

1-interlaced, 0-progressive

NvU32 _NV_TIMING::pclk

pixel clock in 10 kHz

NvU16 _NV_TIMING::VBorder

vertical border

NvU16 _NV_TIMING::VFrontPorch

vertical front porch

NvU8 _NV_TIMING::VSyncPol

vertical sync polarity: 1-negative, 0-positive

NvU16 _NV_TIMING::VSyncWidth

vertical sync width

NvU16 _NV_TIMING::VTotal

vertical total

NvU16 _NV_TIMING::VVisible

vertical visible

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_TIMING_INPUT Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
float rr
NV_TIMING_FLAG flag
NV_TIMING_OVERRIDE type

Detailed Description

Used in NvAPI_DISP_GetTiming().

Field Documentation

NV_TIMING_FLAG _NV_TIMING_INPUT::flag

Flag containing additional info for timing calculation.

NvU32 _NV_TIMING_INPUT::height

Visible vertical size.

float _NV_TIMING_INPUT::rr

Timing refresh rate.

NV_TIMING_OVERRIDE _NV_TIMING_INPUT::type

Timing type(formula) to use for calculating the timing.

NvU32 _NV_TIMING_INPUT::version

(IN) structure version

NvU32 _NV_TIMING_INPUT::width

Visible horizontal size.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NV_VIO_TOPOLOGY Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vioTotalDeviceCount
NVVIOTOPOLOGYTARGET vioTarget [NVAPI_MAX_VIO_DEVICES]

Field Documentation

NvU32 _NV_VIO_TOPOLOGY::version
NVVIOTOPOLOGYTARGET _NV_VIO_TOPOLOGY::vioTarget[NVAPI_MAX_VIO_DEVICES]

Array of video I/O targets.

NvU32 _NV_VIO_TOPOLOGY::vioTotalDeviceCount

How many video I/O targets are valid.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVAPI_STEREO_CAPS Struct Reference
Stereoscopic 3D APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | supportsWindowedModeOff: 1
NvU32 | supportsWindowedModeAutomatic: 1
NvU32 | supportsWindowedModePersistent: 1
NvU32 | reserved: 29
NvU32 | reserved2 [3]

Field Documentation

NvU32 _NVAPI_STEREO_CAPS::reserved
NvU32 _NVAPI_STEREO_CAPS::reserved2[3]
NvU32 _NVAPI_STEREO_CAPS::supportsWindowedModeAutomatic
NvU32 _NVAPI_STEREO_CAPS::supportsWindowedModeOff
NvU32 _NVAPI_STEREO_CAPS::supportsWindowedModePersistent
NvU32 _NVAPI_STEREO_CAPS::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_APPLICATION_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 isPredefined
NvAPI_UnicodeString appName
NvAPI_UnicodeString userFriendlyName
NvAPI_UnicodeString launcher

Field Documentation

NvAPI_UnicodeString _NVDRS_APPLICATION_V1::appName

String name of the Application.

NvU32 _NVDRS_APPLICATION_V1::isPredefined

Is the application userdefined/predefined.

NvAPI_UnicodeString _NVDRS_APPLICATION_V1::launcher

Indicates the name (if any) of the launcher that starts the application.

NvAPI_UnicodeString _NVDRS_APPLICATION_V1::userFriendlyName

UserFriendly name of the Application.

NvU32 _NVDRS_APPLICATION_V1::version

Structure Version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_APPLICATION_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 isPredefined
NvAPI_UnicodeString appName
NvAPI_UnicodeString userFriendlyName
NvAPI_UnicodeString launcher
NvAPI_UnicodeString fileInFolder

Field Documentation

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::appName

String name of the Application.

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::fileInFolder

Select this application only if this file is found. When specifying multiple files, separate them using the ':' character.

NvU32 _NVDRS_APPLICATION_V2::isPredefined

Is the application userdefined/predefined.

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::launcher

Indicates the name (if any) of the launcher that starts the Application.

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::userFriendlyName

UserFriendly name of the Application.

NvU32 _NVDRS_APPLICATION_V2::version

Structure Version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_APPLICATION_V3 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 isPredefined
NvAPI_UnicodeString appName
NvAPI_UnicodeString userFriendlyName
NvAPI_UnicodeString launcher
NvAPI_UnicodeString fileInFolder
NvU32 | isMetro:1
NvU32 | isCommandLine:1
NvU32 | reserved:30

Field Documentation

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::appName

String name of the Application.

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::fileInFolder

Select this application only if this file is found. When specifying multiple files, separate them using the ':' character.

NvU32 _NVDRS_APPLICATION_V3::isCommandLine

Command line parsing for the application name.

NvU32 _NVDRS_APPLICATION_V3::isMetro

Windows 8 style app.

NvU32 _NVDRS_APPLICATION_V3::isPredefined

Is the application userdefined/predefined.

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::launcher

Indicates the name (if any) of the launcher that starts the Application.

NvU32 _NVDRS_APPLICATION_V3::reserved

Reserved. Should be 0.

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::userFriendlyName

UserFriendly name of the Application.

NvU32 _NVDRS_APPLICATION_V3::version

Structure Version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_BINARY_SETTING Struct Reference

#include <nvapi.h>

Data Fields

NvU32 valueLength
NvU8 valueData [NVAPI_BINARY_DATA_MAX]

Detailed Description

Enum to decide on the datatype of setting value.

Field Documentation

NvU8 _NVDRS_BINARY_SETTING::valueData[NVAPI_BINARY_DATA_MAX]
NvU32 _NVDRS_BINARY_SETTING::valueLength

valueLength should always be in number of bytes.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_GPU_SUPPORT Struct Reference

#include <nvapi.h>

Data Fields

NvU32 | geforce: 1
NvU32 | quadro: 1
NvU32 | nvs: 1
NvU32 | reserved4: 1
NvU32 | reserved5: 1
NvU32 | reserved6: 1
NvU32 | reserved7: 1
NvU32 | reserved8: 1
NvU32 | reserved9: 1
NvU32 | reserved10: 1
NvU32 | reserved11: 1
NvU32 | reserved12: 1
NvU32 | reserved13: 1
NvU32 | reserved14: 1
NvU32 | reserved15: 1
NvU32 | reserved16: 1
NvU32 | reserved17: 1
NvU32 | reserved18: 1
NvU32 | reserved19: 1
NvU32 | reserved20: 1
NvU32 | reserved21: 1
NvU32 | reserved22: 1
NvU32 | reserved23: 1
NvU32 | reserved24: 1
NvU32 | reserved25: 1
NvU32 | reserved26: 1
NvU32 | reserved27: 1
NvU32 | reserved28: 1
NvU32 | reserved29: 1
NvU32 | reserved30: 1
NvU32 | reserved31: 1
NvU32 | reserved32: 1

Field Documentation

NvU32 _NVDRS_GPU_SUPPORT::geforce
NvU32 _NVDRS_GPU_SUPPORT::nvs
NvU32 _NVDRS_GPU_SUPPORT::quadro
NvU32 _NVDRS_GPU_SUPPORT::reserved10
NvU32 _NVDRS_GPU_SUPPORT::reserved11
NvU32 _NVDRS_GPU_SUPPORT::reserved12
NvU32 _NVDRS_GPU_SUPPORT::reserved13
NvU32 _NVDRS_GPU_SUPPORT::reserved14
NvU32 _NVDRS_GPU_SUPPORT::reserved15
NvU32 _NVDRS_GPU_SUPPORT::reserved16
NvU32 _NVDRS_GPU_SUPPORT::reserved17
NvU32 _NVDRS_GPU_SUPPORT::reserved18
NvU32 _NVDRS_GPU_SUPPORT::reserved19
NvU32 _NVDRS_GPU_SUPPORT::reserved20
NvU32 _NVDRS_GPU_SUPPORT::reserved21
NvU32 _NVDRS_GPU_SUPPORT::reserved22
NvU32 _NVDRS_GPU_SUPPORT::reserved23
NvU32 _NVDRS_GPU_SUPPORT::reserved24
NvU32 _NVDRS_GPU_SUPPORT::reserved25
NvU32 _NVDRS_GPU_SUPPORT::reserved26
NvU32 _NVDRS_GPU_SUPPORT::reserved27
NvU32 _NVDRS_GPU_SUPPORT::reserved28
NvU32 _NVDRS_GPU_SUPPORT::reserved29
NvU32 _NVDRS_GPU_SUPPORT::reserved30
NvU32 _NVDRS_GPU_SUPPORT::reserved31
NvU32 _NVDRS_GPU_SUPPORT::reserved32
NvU32 _NVDRS_GPU_SUPPORT::reserved4
NvU32 _NVDRS_GPU_SUPPORT::reserved5
NvU32 _NVDRS_GPU_SUPPORT::reserved6
NvU32 _NVDRS_GPU_SUPPORT::reserved7
NvU32 _NVDRS_GPU_SUPPORT::reserved8
NvU32 _NVDRS_GPU_SUPPORT::reserved9
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_PROFILE_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvAPI_UnicodeString profileName
NVDRS_GPU_SUPPORT gpuSupport
NvU32 isPredefined
NvU32 numOfApps
NvU32 numOfSettings

Field Documentation

NVDRS_GPU_SUPPORT _NVDRS_PROFILE_V1::gpuSupport

This read-only flag indicates the profile support on either Quadro, or Geforce, or both.

NvU32 _NVDRS_PROFILE_V1::isPredefined

Is the Profile user-defined, or predefined.

NvU32 _NVDRS_PROFILE_V1::numOfApps

Total number of applications that belong to this profile. Read-only.

NvU32 _NVDRS_PROFILE_V1::numOfSettings

Total number of settings applied for this Profile. Read-only.

NvAPI_UnicodeString _NVDRS_PROFILE_V1::profileName

String name of the Profile.

NvU32 _NVDRS_PROFILE_V1::version

Structure Version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_SETTING_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvAPI_UnicodeString settingName
NvU32 settingId
NVDRS_SETTING_TYPE settingType
NVDRS_SETTING_LOCATION settingLocation
NvU32 isCurrentPredefined
NvU32 isPredefinedValid
union {
NvU32 u32PredefinedValue
NVDRS_BINARY_SETTING binaryPredefinedValue
NvAPI_UnicodeString wszPredefinedValue
};
union {
NvU32 u32CurrentValue
NVDRS_BINARY_SETTING binaryCurrentValue
NvAPI_UnicodeString wszCurrentValue
};

Field Documentation

union { ... }
union { ... }
NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryCurrentValue

Accessing current Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryPredefinedValue

Accessing default Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

NvU32 _NVDRS_SETTING_V1::isCurrentPredefined

It is different than 0 if the currentValue is a predefined Value, 0 if the currentValue is a user value.

NvU32 _NVDRS_SETTING_V1::isPredefinedValid

It is different than 0 if the PredefinedValue union contains a valid value.

NvU32 _NVDRS_SETTING_V1::settingId

32 bit setting Id

NVDRS_SETTING_LOCATION _NVDRS_SETTING_V1::settingLocation

Describes where the value in CurrentValue comes from.

NvAPI_UnicodeString _NVDRS_SETTING_V1::settingName

String name of setting.

NVDRS_SETTING_TYPE _NVDRS_SETTING_V1::settingType

Type of setting value.

NvU32 _NVDRS_SETTING_V1::u32CurrentValue

Accessing current DWORD value of this setting.

NvU32 _NVDRS_SETTING_V1::u32PredefinedValue

Accessing default DWORD value of this setting.

NvU32 _NVDRS_SETTING_V1::version

Structure Version.

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszCurrentValue

Accessing current unicode string value of this setting.

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszPredefinedValue

Accessing default unicode string value of this setting.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVDRS_SETTING_VALUES Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numSettingValues
NVDRS_SETTING_TYPE settingType
union {
NvU32 u32DefaultValue
NVDRS_BINARY_SETTING binaryDefaultValue
NvAPI_UnicodeString wszDefaultValue
};
union {
NvU32 u32Value
NVDRS_BINARY_SETTING binaryValue
NvAPI_UnicodeString wszValue
} settingValues [NVAPI_SETTING_MAX_VALUES]

Field Documentation

union { ... }
NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryDefaultValue

Accessing default Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryValue

All possible Binary values for a setting.

NvU32 _NVDRS_SETTING_VALUES::numSettingValues

Total number of values available in a setting.

NVDRS_SETTING_TYPE _NVDRS_SETTING_VALUES::settingType

Type of setting value.

union { ... } _NVDRS_SETTING_VALUES::settingValues[NVAPI_SETTING_MAX_VALUES]
NvU32 _NVDRS_SETTING_VALUES::u32DefaultValue

Accessing default DWORD value of this setting.

NvU32 _NVDRS_SETTING_VALUES::u32Value

< NOT mixed types.

All possible DWORD values for a setting

NvU32 _NVDRS_SETTING_VALUES::version

Structure Version.

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszDefaultValue

Accessing default unicode string value of this setting.

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszValue

Accessing current unicode string value of this setting.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOCAPS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvAPI_String adapterName
NvU32 adapterClass
NvU32 adapterCaps
NvU32 dipSwitch
NvU32 dipSwitchReserved
NvU32 boardID
struct {
NvU32 majorVersion
NvU32 minorVersion
} driver
struct {
NvU32 majorVersion
NvU32 minorVersion
} firmWare
NVVIOOWNERID ownerId
NVVIOOWNERTYPE ownerType

Detailed Description

Device capabilities.

Field Documentation

NvU32 _NVVIOCAPS::adapterCaps

Graphics adapter capabilities (NVVIOCAPS_* mask)

NvU32 _NVVIOCAPS::adapterClass

Graphics adapter classes (NVVIOCLASS_SDI mask)

NvAPI_String _NVVIOCAPS::adapterName

Graphics adapter name.

NvU32 _NVVIOCAPS::boardID

Board ID

NvU32 _NVVIOCAPS::dipSwitch

On-board DIP switch settings bits.

NvU32 _NVVIOCAPS::dipSwitchReserved

On-board DIP switch settings reserved bits.

struct { ... } _NVVIOCAPS::driver

Driver version.

struct { ... } _NVVIOCAPS::firmWare

Firmware version.

NvU32 _NVVIOCAPS::majorVersion

Major version. For GVI, majorVersion contains MajorVersion(HIWORD) And MinorVersion(LOWORD)

Major version. In version 2, for both GVI and GVO, majorVersion contains MajorVersion(HIWORD) And MinorVersion(LOWORD)

NvU32 _NVVIOCAPS::minorVersion

Minor version. For GVI, minorVersion contains Revison(HIWORD) And Build(LOWORD)

Minor version. In version 2, for both GVI and GVO, minorVersion contains Revison(HIWORD) And Build(LOWORD)

NVVIOOWNERID _NVVIOCAPS::ownerId

Unique identifier for owner of video output (NVVIOOWNERID_INVALID if free running)

NVVIOOWNERTYPE _NVVIOCAPS::ownerType

Owner type (OpenGL application or Desktop mode)

NvU32 _NVVIOCAPS::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOCHANNELSTATUS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 smpte352
NVVIOSIGNALFORMAT signalFormat
NVVIOBITSPERCOMPONENT bitsPerComponent
NVVIOCOMPONENTSAMPLING samplingFormat
NVVIOCOLORSPACE colorSpace
NVVIOLINKID linkID

Detailed Description

Input channel status.

Field Documentation

NVVIOBITSPERCOMPONENT _NVVIOCHANNELSTATUS::bitsPerComponent

Bits per component.

NVVIOCOLORSPACE _NVVIOCHANNELSTATUS::colorSpace

Color space.

NVVIOLINKID _NVVIOCHANNELSTATUS::linkID

Link ID.

NVVIOCOMPONENTSAMPLING _NVVIOCHANNELSTATUS::samplingFormat

Sampling format.

NVVIOSIGNALFORMAT _NVVIOCHANNELSTATUS::signalFormat

Signal format.

NvU32 _NVVIOCHANNELSTATUS::smpte352

4-byte SMPTE 352 video payload identifier

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOCOLORCONVERSION Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
float | colorMatrix [3][3]
float | colorOffset [3]
float | colorScale [3]
NvU32 compositeSafe

Detailed Description

Colorspace conversion.

Field Documentation

float _NVVIOCOLORCONVERSION::colorMatrix[3][3]

Output[n] =.

float _NVVIOCOLORCONVERSION::colorOffset[3]

Input[0] * colorMatrix[n][0] +.

float _NVVIOCOLORCONVERSION::colorScale[3]

Input[1] * colorMatrix[n][1] + Input[2] * colorMatrix[n][2] + OutputRange * colorOffset[n] where OutputRange is the standard magnitude of Output[n][n] and colorMatrix and colorOffset values are within the range -1.0 to +1.0

NvU32 _NVVIOCOLORCONVERSION::compositeSafe

compositeSafe constrains luminance range when using composite output

NvU32 _NVVIOCOLORCONVERSION::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOCOMPOSITERANGE Struct Reference

#include <nvapi.h>

Data Fields

NvU32 uRange
NvU32 uEnabled
NvU32 uMin
NvU32 uMax

Field Documentation

NvU32 _NVVIOCOMPOSITERANGE::uEnabled
NvU32 _NVVIOCOMPOSITERANGE::uMax
NvU32 _NVVIOCOMPOSITERANGE::uMin
NvU32 _NVVIOCOMPOSITERANGE::uRange
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOCONFIG_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 fields
NVVIOCONFIGTYPE nvvioConfigType
union {
NVVIOINPUTCONFIG inConfig
NVVIOOUTPUTCONFIG_V1 outConfig
} vioConfig

Field Documentation

NvU32 _NVVIOCONFIG_V1::fields

Caller sets to NVVIOCONFIG_* mask for fields to use.

NVVIOINPUTCONFIG _NVVIOCONFIG_V1::inConfig

Input device configuration.

NVVIOCONFIGTYPE _NVVIOCONFIG_V1::nvvioConfigType

Input or Output configuration.

NVVIOOUTPUTCONFIG_V1 _NVVIOCONFIG_V1::outConfig

Output device configuration.

NvU32 _NVVIOCONFIG_V1::version

Structure version.

union { ... } _NVVIOCONFIG_V1::vioConfig
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOCONFIG_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 fields
NVVIOCONFIGTYPE nvvioConfigType
union {
NVVIOINPUTCONFIG inConfig
NVVIOOUTPUTCONFIG_V2 outConfig
} vioConfig

Field Documentation

NvU32 _NVVIOCONFIG_V2::fields

Caller sets to NVVIOCONFIG_* mask for fields to use.

NVVIOINPUTCONFIG _NVVIOCONFIG_V2::inConfig

Input device configuration.

NVVIOCONFIGTYPE _NVVIOCONFIG_V2::nvvioConfigType

Input or Output configuration.

NVVIOOUTPUTCONFIG_V2 _NVVIOCONFIG_V2::outConfig

Output device configuration.

NvU32 _NVVIOCONFIG_V2::version

Structure version.

union { ... } _NVVIOCONFIG_V2::vioConfig
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOCONFIG_V3 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 fields
NVVIOCONFIGTYPE nvvioConfigType
union {
NVVIOINPUTCONFIG inConfig
NVVIOOUTPUTCONFIG_V3 outConfig
} vioConfig

Field Documentation

NvU32 _NVVIOCONFIG_V3::fields

Caller sets to NVVIOCONFIG_* mask for fields to use.

NVVIOINPUTCONFIG _NVVIOCONFIG_V3::inConfig

Input device configuration.

NVVIOCONFIGTYPE _NVVIOCONFIG_V3::nvvioConfigType

Input or Output configuration.

NVVIOOUTPUTCONFIG_V3 _NVVIOCONFIG_V3::outConfig

Output device configuration.

NvU32 _NVVIOCONFIG_V3::version

Structure version.

union { ... } _NVVIOCONFIG_V3::vioConfig
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIODATAFORMATDETAIL Struct Reference

#include <nvapi.h>

Data Fields

NVVIODATAFORMAT dataFormat
NvU32 vioCaps

Detailed Description

Data format details.

Field Documentation

NVVIODATAFORMAT _NVVIODATAFORMATDETAIL::dataFormat

Data format enumerated value.

NvU32 _NVVIODATAFORMATDETAIL::vioCaps

Data format capabilities (NVVIOCAPS_* mask)

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOGAMMACORRECTION Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vioGammaCorrectionType
union {
NVVIOGAMMARAMP8 gammaRamp8
NVVIOGAMMARAMP10 gammaRamp10
} gammaRamp
float | fGammaValueR
float | fGammaValueG
float | fGammaValueB

Detailed Description

Gamma correction.

Field Documentation

float _NVVIOGAMMACORRECTION::fGammaValueB

Blue Gamma value within gamma ranges. 0.5 - 6.0.

float _NVVIOGAMMACORRECTION::fGammaValueG

Green Gamma value within gamma ranges. 0.5 - 6.0.

float _NVVIOGAMMACORRECTION::fGammaValueR

Red Gamma value within gamma ranges. 0.5 - 6.0.

union { ... } _NVVIOGAMMACORRECTION::gammaRamp

Gamma correction:

NVVIOGAMMARAMP10 _NVVIOGAMMACORRECTION::gammaRamp10

Gamma ramp (10-bit index, 16-bit values)

NVVIOGAMMARAMP8 _NVVIOGAMMACORRECTION::gammaRamp8

Gamma ramp (8-bit index, 16-bit values)

NvU32 _NVVIOGAMMACORRECTION::version

Structure version.

NvU32 _NVVIOGAMMACORRECTION::vioGammaCorrectionType

Gamma correction type (8-bit or 10-bit)

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOGAMMARAMP10 Struct Reference

#include <nvapi.h>

Data Fields

NvU16 | uRed [1024]
NvU16 | uGreen [1024]
NvU16 | uBlue [1024]

Detailed Description

Gamma ramp (10-bit index)

Field Documentation

NvU16 _NVVIOGAMMARAMP10::uBlue[1024]

Blue channel gamma ramp (10-bit index, 16-bit values)

NvU16 _NVVIOGAMMARAMP10::uGreen[1024]

Green channel gamma ramp (10-bit index, 16-bit values)

NvU16 _NVVIOGAMMARAMP10::uRed[1024]

Red channel gamma ramp (10-bit index, 16-bit values)

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOGAMMARAMP8 Struct Reference

#include <nvapi.h>

Data Fields

NvU16 | uRed [256]
NvU16 | uGreen [256]
NvU16 | uBlue [256]

Detailed Description

Gamma ramp (8-bit index)

Field Documentation

NvU16 _NVVIOGAMMARAMP8::uBlue[256]

Blue channel gamma ramp (8-bit index, 16-bit values)

NvU16 _NVVIOGAMMARAMP8::uGreen[256]

Green channel gamma ramp (8-bit index, 16-bit values)

NvU16 _NVVIOGAMMARAMP8::uRed[256]

Red channel gamma ramp (8-bit index, 16-bit values)

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOINPUTCONFIG Struct Reference

#include <nvapi.h>

Data Fields

NvU32 numRawCaptureImages
NVVIOSIGNALFORMAT signalFormat
NvU32 numStreams
NVVIOSTREAM streams [NVAPI_MAX_VIO_STREAMS]
NvU32 bTestMode

Detailed Description

Input device configuration.

Field Documentation

NvU32 _NVVIOINPUTCONFIG::bTestMode

This attribute controls the GVI test mode. Possible values 0/1. When testmode enabled, the GVI device will generate fake data as quickly as possible.

NvU32 _NVVIOINPUTCONFIG::numRawCaptureImages

numRawCaptureImages is the number of frames to keep in the capture queue. must be between NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES and NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES,

NvU32 _NVVIOINPUTCONFIG::numStreams

Number of active streams.

NVVIOSIGNALFORMAT _NVVIOINPUTCONFIG::signalFormat

Signal format. Please note that both numRawCaptureImages and signalFormat should be set together.

NVVIOSTREAM _NVVIOINPUTCONFIG::streams[NVAPI_MAX_VIO_STREAMS]

Stream configurations.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOINPUTSTATUS Struct Reference

#include <nvapi.h>

Data Fields

NVVIOCHANNELSTATUS vidIn [NVAPI_MAX_VIO_JACKS][NVAPI_MAX_VIO_CHANNELS_PER_JACK]
NVVIOCAPTURESTATUS captureStatus

Detailed Description

Input device status.

Field Documentation

NVVIOCAPTURESTATUS _NVVIOINPUTSTATUS::captureStatus

status of video capture

NVVIOCHANNELSTATUS _NVVIOINPUTSTATUS::vidIn[NVAPI_MAX_VIO_JACKS][NVAPI_MAX_VIO_CHANNELS_PER_JACK]

Video input status per channel within a jack.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOOUTPUTCONFIG_V1 Struct Reference

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIODATAFORMAT dataFormat
NVVIOOUTPUTREGION outputRegion
NVVIOOUTPUTAREA outputArea
NVVIOCOLORCONVERSION colorConversion
NVVIOGAMMACORRECTION gammaCorrection
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSYNCDELAY syncDelay
NVVIOCOMPSYNCTYPE compositeSyncType
NvU32 frameLockEnable
NvU32 psfSignalFormat
NvU32 enable422Filter
NvU32 compositeTerminate
NvU32 enableDataIntegrityCheck
NvU32 cscOverride
NvU32 flipQueueLength
NvU32 enableANCTimeCodeGeneration
NvU32 enableComposite
NvU32 enableAlphaKeyComposite
NVVIOCOMPOSITERANGE compRange
NvU8 reservedData [256]
NvU32 enableFullColorRange
NvU32 enableRGBData

Detailed Description

Output device configuration.

Field Documentation

NVVIOCOLORCONVERSION _NVVIOOUTPUTCONFIG_V1::colorConversion

Color conversion.

NVVIOCOMPSYNCTYPE _NVVIOOUTPUTCONFIG_V1::compositeSyncType

Composite sync type.

NvU32 _NVVIOOUTPUTCONFIG_V1::compositeTerminate

Composite termination.

NVVIOCOMPOSITERANGE _NVVIOOUTPUTCONFIG_V1::compRange

Composite ranges.

NvU32 _NVVIOOUTPUTCONFIG_V1::cscOverride

Use provided CSC color matrix to overwrite.

NVVIODATAFORMAT _NVVIOOUTPUTCONFIG_V1::dataFormat

Data format for video output.

NvU32 _NVVIOOUTPUTCONFIG_V1::enable422Filter

Enables/Disables 4:2:2 filter.

NvU32 _NVVIOOUTPUTCONFIG_V1::enableAlphaKeyComposite

Enable Alpha key composite.

NvU32 _NVVIOOUTPUTCONFIG_V1::enableANCTimeCodeGeneration

Enable SDI ANC time code generation.

NvU32 _NVVIOOUTPUTCONFIG_V1::enableComposite

Enable composite.

NvU32 _NVVIOOUTPUTCONFIG_V1::enableDataIntegrityCheck

Enable data integrity check: true - enable, false - disable.

NvU32 _NVVIOOUTPUTCONFIG_V1::enableFullColorRange

Flag indicating Full Color Range.

NvU32 _NVVIOOUTPUTCONFIG_V1::enableRGBData

Indicates data is in RGB format.

NvU32 _NVVIOOUTPUTCONFIG_V1::flipQueueLength

Number of buffers used for the internal flipqueue.

NvU32 _NVVIOOUTPUTCONFIG_V1::frameLockEnable

Flag indicating whether framelock was on/off.

NVVIOGAMMACORRECTION _NVVIOOUTPUTCONFIG_V1::gammaCorrection
NVVIOOUTPUTAREA _NVVIOOUTPUTCONFIG_V1::outputArea

Usable resolution for video output (safe area)

NVVIOOUTPUTREGION _NVVIOOUTPUTCONFIG_V1::outputRegion

Region for video output (Desktop mode)

NvU32 _NVVIOOUTPUTCONFIG_V1::psfSignalFormat

Indicates whether contained format is PSF Signal format.

NvU8 _NVVIOOUTPUTCONFIG_V1::reservedData[256]

Inicates last stored SDI output state TRUE-ON / FALSE-OFF.

NVVIOSIGNALFORMAT _NVVIOOUTPUTCONFIG_V1::signalFormat

Signal format for video output.

NVVIOSYNCDELAY _NVVIOOUTPUTCONFIG_V1::syncDelay

Sync delay.

NvU32 _NVVIOOUTPUTCONFIG_V1::syncEnable

Sync enable (TRUE to use syncSource)

NVVIOSYNCSOURCE _NVVIOOUTPUTCONFIG_V1::syncSource

Sync source.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOOUTPUTCONFIG_V2 Struct Reference

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIODATAFORMAT dataFormat
NVVIOOUTPUTREGION outputRegion
NVVIOOUTPUTAREA outputArea
NVVIOCOLORCONVERSION colorConversion
NVVIOGAMMACORRECTION gammaCorrection
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSYNCDELAY syncDelay
NVVIOCOMPSYNCTYPE compositeSyncType
NvU32 frameLockEnable
NvU32 psfSignalFormat
NvU32 enable422Filter
NvU32 compositeTerminate
NvU32 enableDataIntegrityCheck
NvU32 cscOverride
NvU32 flipQueueLength
NvU32 enableANCTimeCodeGeneration
NvU32 enableComposite
NvU32 enableAlphaKeyComposite
NVVIOCOMPOSITERANGE compRange
NvU8 reservedData [256]
NvU32 enableFullColorRange
NvU32 enableRGBData
NVVIOANCPARITYCOMPUTATION ancParityComputation

Field Documentation

NVVIOANCPARITYCOMPUTATION _NVVIOOUTPUTCONFIG_V2::ancParityComputation

Enable HW ANC parity bit computation (auto/on/off)

NVVIOCOLORCONVERSION _NVVIOOUTPUTCONFIG_V2::colorConversion

Color conversion.

NVVIOCOMPSYNCTYPE _NVVIOOUTPUTCONFIG_V2::compositeSyncType

Composite sync type.

NvU32 _NVVIOOUTPUTCONFIG_V2::compositeTerminate

Composite termination.

NVVIOCOMPOSITERANGE _NVVIOOUTPUTCONFIG_V2::compRange

Composite ranges.

NvU32 _NVVIOOUTPUTCONFIG_V2::cscOverride

Use provided CSC color matrix to overwrite.

NVVIODATAFORMAT _NVVIOOUTPUTCONFIG_V2::dataFormat

Data format for video output.

NvU32 _NVVIOOUTPUTCONFIG_V2::enable422Filter

Enables/Disables 4:2:2 filter.

NvU32 _NVVIOOUTPUTCONFIG_V2::enableAlphaKeyComposite

Enable Alpha key composite.

NvU32 _NVVIOOUTPUTCONFIG_V2::enableANCTimeCodeGeneration

Enable SDI ANC time code generation.

NvU32 _NVVIOOUTPUTCONFIG_V2::enableComposite

Enable composite.

NvU32 _NVVIOOUTPUTCONFIG_V2::enableDataIntegrityCheck

Enable data integrity check: true - enable, false - disable.

NvU32 _NVVIOOUTPUTCONFIG_V2::enableFullColorRange

Flag indicating Full Color Range.

NvU32 _NVVIOOUTPUTCONFIG_V2::enableRGBData

Indicates data is in RGB format.

NvU32 _NVVIOOUTPUTCONFIG_V2::flipQueueLength

Number of buffers used for the internal flip queue.

NvU32 _NVVIOOUTPUTCONFIG_V2::frameLockEnable

Flag indicating whether framelock was on/off.

NVVIOGAMMACORRECTION _NVVIOOUTPUTCONFIG_V2::gammaCorrection
NVVIOOUTPUTAREA _NVVIOOUTPUTCONFIG_V2::outputArea

Usable resolution for video output (safe area)

NVVIOOUTPUTREGION _NVVIOOUTPUTCONFIG_V2::outputRegion

Region for video output (Desktop mode)

NvU32 _NVVIOOUTPUTCONFIG_V2::psfSignalFormat

Indicates whether contained format is PSF Signal format.

NvU8 _NVVIOOUTPUTCONFIG_V2::reservedData[256]

Indicates last stored SDI output state TRUE-ON / FALSE-OFF.

NVVIOSIGNALFORMAT _NVVIOOUTPUTCONFIG_V2::signalFormat

Signal format for video output.

NVVIOSYNCDELAY _NVVIOOUTPUTCONFIG_V2::syncDelay

Sync delay.

NvU32 _NVVIOOUTPUTCONFIG_V2::syncEnable

Sync enable (TRUE to use syncSource)

NVVIOSYNCSOURCE _NVVIOOUTPUTCONFIG_V2::syncSource

Sync source.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOOUTPUTCONFIG_V3 Struct Reference

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIODATAFORMAT dataFormat
NVVIOOUTPUTREGION outputRegion
NVVIOOUTPUTAREA outputArea
NVVIOCOLORCONVERSION colorConversion
NVVIOGAMMACORRECTION gammaCorrection
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSYNCDELAY syncDelay
NVVIOCOMPSYNCTYPE compositeSyncType
NvU32 frameLockEnable
NvU32 psfSignalFormat
NvU32 enable422Filter
NvU32 compositeTerminate
NvU32 enableDataIntegrityCheck
NvU32 cscOverride
NvU32 flipQueueLength
NvU32 enableANCTimeCodeGeneration
NvU32 enableComposite
NvU32 enableAlphaKeyComposite
NVVIOCOMPOSITERANGE compRange
NvU8 reservedData [256]
NvU32 enableFullColorRange
NvU32 enableRGBData
NVVIOANCPARITYCOMPUTATION ancParityComputation
NvU32 enableAudioBlanking

Field Documentation

NVVIOANCPARITYCOMPUTATION _NVVIOOUTPUTCONFIG_V3::ancParityComputation

Enable HW ANC parity bit computation (auto/on/off)

NVVIOCOLORCONVERSION _NVVIOOUTPUTCONFIG_V3::colorConversion

Color conversion.

NVVIOCOMPSYNCTYPE _NVVIOOUTPUTCONFIG_V3::compositeSyncType

Composite sync type.

NvU32 _NVVIOOUTPUTCONFIG_V3::compositeTerminate

Composite termination.

NVVIOCOMPOSITERANGE _NVVIOOUTPUTCONFIG_V3::compRange

Composite ranges.

NvU32 _NVVIOOUTPUTCONFIG_V3::cscOverride

Use provided CSC color matrix to overwrite.

NVVIODATAFORMAT _NVVIOOUTPUTCONFIG_V3::dataFormat

Data format for video output.

NvU32 _NVVIOOUTPUTCONFIG_V3::enable422Filter

Enables/Disables 4:2:2 filter.

NvU32 _NVVIOOUTPUTCONFIG_V3::enableAlphaKeyComposite

Enable Alpha key composite.

NvU32 _NVVIOOUTPUTCONFIG_V3::enableANCTimeCodeGeneration

Enable SDI ANC time code generation.

NvU32 _NVVIOOUTPUTCONFIG_V3::enableAudioBlanking

Enable HANC audio blanking on repeat frames.

NvU32 _NVVIOOUTPUTCONFIG_V3::enableComposite

Enable composite.

NvU32 _NVVIOOUTPUTCONFIG_V3::enableDataIntegrityCheck

Enable data integrity check: true - enable, false - disable.

NvU32 _NVVIOOUTPUTCONFIG_V3::enableFullColorRange

Flag indicating Full Color Range.

NvU32 _NVVIOOUTPUTCONFIG_V3::enableRGBData

Indicates data is in RGB format.

NvU32 _NVVIOOUTPUTCONFIG_V3::flipQueueLength

Number of buffers used for the internal flip queue.

NvU32 _NVVIOOUTPUTCONFIG_V3::frameLockEnable

Flag indicating whether framelock was on/off.

NVVIOGAMMACORRECTION _NVVIOOUTPUTCONFIG_V3::gammaCorrection
NVVIOOUTPUTAREA _NVVIOOUTPUTCONFIG_V3::outputArea

Usable resolution for video output (safe area)

NVVIOOUTPUTREGION _NVVIOOUTPUTCONFIG_V3::outputRegion

Region for video output (Desktop mode)

NvU32 _NVVIOOUTPUTCONFIG_V3::psfSignalFormat

Indicates whether contained format is PSF Signal format.

NvU8 _NVVIOOUTPUTCONFIG_V3::reservedData[256]

Indicates last stored SDI output state TRUE-ON / FALSE-OFF.

NVVIOSIGNALFORMAT _NVVIOOUTPUTCONFIG_V3::signalFormat

Signal format for video output.

NVVIOSYNCDELAY _NVVIOOUTPUTCONFIG_V3::syncDelay

Sync delay.

NvU32 _NVVIOOUTPUTCONFIG_V3::syncEnable

Sync enable (TRUE to use syncSource)

NVVIOSYNCSOURCE _NVVIOOUTPUTCONFIG_V3::syncSource

Sync source.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOOUTPUTREGION Struct Reference

#include <nvapi.h>

Data Fields

NvU32 x
NvU32 y
NvU32 width
NvU32 height

Detailed Description

Output region.

Field Documentation

NvU32 _NVVIOOUTPUTREGION::height

Height of region in pixels.

NvU32 _NVVIOOUTPUTREGION::width

Width of region in pixels.

NvU32 _NVVIOOUTPUTREGION::x

Horizontal origin in pixels.

NvU32 _NVVIOOUTPUTREGION::y

Vertical origin in pixels.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOOUTPUTSTATUS Struct Reference

#include <nvapi.h>

Data Fields

NVVIOINPUTOUTPUTSTATUS vid1Out
NVVIOINPUTOUTPUTSTATUS vid2Out
NVVIOSYNCSTATUS sdiSyncIn
NVVIOSYNCSTATUS compSyncIn
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSIGNALFORMAT syncFormat
NvU32 frameLockEnable
NvU32 outputVideoLocked
NvU32 dataIntegrityCheckErrorCount
NvU32 dataIntegrityCheckEnabled
NvU32 dataIntegrityCheckFailed
NvU32 uSyncSourceLocked
NvU32 uPowerOn

Detailed Description

Output device status.

Field Documentation

NVVIOSYNCSTATUS _NVVIOOUTPUTSTATUS::compSyncIn

Composite sync input status.

NvU32 _NVVIOOUTPUTSTATUS::dataIntegrityCheckEnabled

Data integrity check status enabled.

NvU32 _NVVIOOUTPUTSTATUS::dataIntegrityCheckErrorCount

Data integrity check error count.

NvU32 _NVVIOOUTPUTSTATUS::dataIntegrityCheckFailed

Data integrity check status failed.

NvU32 _NVVIOOUTPUTSTATUS::frameLockEnable

Framelock enable flag.

NvU32 _NVVIOOUTPUTSTATUS::outputVideoLocked

Output locked status.

NVVIOSYNCSTATUS _NVVIOOUTPUTSTATUS::sdiSyncIn

SDI sync input status.

NvU32 _NVVIOOUTPUTSTATUS::syncEnable

Sync enable (TRUE if using syncSource)

NVVIOSIGNALFORMAT _NVVIOOUTPUTSTATUS::syncFormat

Sync format.

NVVIOSYNCSOURCE _NVVIOOUTPUTSTATUS::syncSource

Sync source.

NvU32 _NVVIOOUTPUTSTATUS::uPowerOn

TRUE: indicates there is sufficient power.

NvU32 _NVVIOOUTPUTSTATUS::uSyncSourceLocked

genlocked to framelocked to ref signal

NVVIOINPUTOUTPUTSTATUS _NVVIOOUTPUTSTATUS::vid1Out

Video 1 output status.

NVVIOINPUTOUTPUTSTATUS _NVVIOOUTPUTSTATUS::vid2Out

Video 2 output status.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOPCIINFO Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 pciDeviceId
NvU32 pciSubSystemId
NvU32 pciRevisionId
NvU32 pciDomain
NvU32 pciBus
NvU32 pciSlot
NVVIOPCILINKWIDTH pciLinkWidth
NVVIOPCILINKRATE pciLinkRate

Field Documentation

NvU32 _NVVIOPCIINFO::pciBus

specifies the PCI bus number of the GVI device.

NvU32 _NVVIOPCIINFO::pciDeviceId

specifies the internal PCI device identifier for the GVI.

NvU32 _NVVIOPCIINFO::pciDomain

specifies the PCI domain of the GVI device.

NVVIOPCILINKRATE _NVVIOPCIINFO::pciLinkRate

specifies the the negotiated PCIE link rate.

NVVIOPCILINKWIDTH _NVVIOPCIINFO::pciLinkWidth

specifies the the negotiated PCIE link width.

NvU32 _NVVIOPCIINFO::pciRevisionId

specifies the internal PCI device-specific revision identifier for the GVI.

NvU32 _NVVIOPCIINFO::pciSlot

specifies the PCI slot number of the GVI device.

NvU32 _NVVIOPCIINFO::pciSubSystemId

specifies the internal PCI subsystem identifier for the GVI.

NvU32 _NVVIOPCIINFO::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOSIGNALFORMATDETAIL Struct Reference

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIOVIDEOMODE videoMode

Detailed Description

Signal format details.

Field Documentation

NVVIOSIGNALFORMAT _NVVIOSIGNALFORMATDETAIL::signalFormat

Signal format enumerated value.

NVVIOVIDEOMODE _NVVIOSIGNALFORMATDETAIL::videoMode

Video mode for signal format.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOSTATUS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NVVIOSTATUSTYPE nvvioStatusType
union {
NVVIOINPUTSTATUS inStatus
NVVIOOUTPUTSTATUS outStatus
} vioStatus

Detailed Description

Video device status.

Field Documentation

NVVIOINPUTSTATUS _NVVIOSTATUS::inStatus

Input device status.

NVVIOSTATUSTYPE _NVVIOSTATUS::nvvioStatusType

Input or Output status.

NVVIOOUTPUTSTATUS _NVVIOSTATUS::outStatus

Output device status.

NvU32 _NVVIOSTATUS::version

Structure version.

union { ... } _NVVIOSTATUS::vioStatus
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOSTREAM Struct Reference

#include <nvapi.h>

Data Fields

NvU32 bitsPerComponent
NVVIOCOMPONENTSAMPLING sampling
NvU32 expansionEnable
NvU32 numLinks
struct {
NvU32 jack
NvU32 channel
} links [NVAPI_MAX_VIO_LINKS_PER_STREAM]

Detailed Description

Stream configuration.

Field Documentation

NvU32 _NVVIOSTREAM::bitsPerComponent

Bits per component.

NvU32 _NVVIOSTREAM::channel

specified (0-based) jack

NvU32 _NVVIOSTREAM::expansionEnable

Enable/disable 4:2:2->4:4:4 expansion.

NvU32 _NVVIOSTREAM::jack

This stream's link[i] will use the specified (0-based) channel within the.

struct { ... } _NVVIOSTREAM::links[NVAPI_MAX_VIO_LINKS_PER_STREAM]
NvU32 _NVVIOSTREAM::numLinks

Number of active links.

NVVIOCOMPONENTSAMPLING _NVVIOSTREAM::sampling

Sampling.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOSYNCDELAY Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 horizontalDelay
NvU32 verticalDelay

Detailed Description

Sync delay.

Field Documentation

NvU32 _NVVIOSYNCDELAY::horizontalDelay

Horizontal delay in pixels.

NvU32 _NVVIOSYNCDELAY::version

Structure version.

NvU32 _NVVIOSYNCDELAY::verticalDelay

Vertical delay in lines.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_NVVIOVIDEOMODE Struct Reference

#include <nvapi.h>

Data Fields

NvU32 horizontalPixels
NvU32 verticalLines
float fFrameRate
NVVIOINTERLACEMODE interlaceMode
NVVIOVIDEOSTANDARD videoStandard
NVVIOVIDEOTYPE videoType

Detailed Description

Video mode information.

Field Documentation

float _NVVIOVIDEOMODE::fFrameRate

Frame rate.

NvU32 _NVVIOVIDEOMODE::horizontalPixels

Horizontal resolution (in pixels)

NVVIOINTERLACEMODE _NVVIOVIDEOMODE::interlaceMode

Interlace mode.

NvU32 _NVVIOVIDEOMODE::verticalLines

Vertical resolution for frame (in lines)

NVVIOVIDEOSTANDARD _NVVIOVIDEOMODE::videoStandard

SMPTE standards format.

NVVIOVIDEOTYPE _NVVIOVIDEOMODE::videoType

HD or SD signal classification.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
_SettingDWORDNameString Struct Reference

#include <NvApiDriverSettings.h>

Data Fields

NvU32 settingId
const wchar_t * settingNameString
NvU32 numSettingValues
NvU32 * settingValues
NvU32 defaultValue

Field Documentation

NvU32 _SettingDWORDNameString::defaultValue
NvU32 _SettingDWORDNameString::numSettingValues
NvU32 _SettingDWORDNameString::settingId
const wchar_t* _SettingDWORDNameString::settingNameString
NvU32* _SettingDWORDNameString::settingValues
The documentation for this struct was generated from the following file:
  • NvApiDriverSettings.h


Data Fields
_SettingWSTRINGNameString Struct Reference

#include <NvApiDriverSettings.h>

Data Fields

NvU32 settingId
const wchar_t * | settingNameString
NvU32 numSettingValues
const wchar_t ** | settingValues
const wchar_t * | defaultValue

Field Documentation

const wchar_t* _SettingWSTRINGNameString::defaultValue
NvU32 _SettingWSTRINGNameString::numSettingValues
NvU32 _SettingWSTRINGNameString::settingId
const wchar_t* _SettingWSTRINGNameString::settingNameString
const wchar_t** _SettingWSTRINGNameString::settingValues
The documentation for this struct was generated from the following file:
  • NvApiDriverSettings.h


Data Fields
NV_CHIPSET_INFO_v1 Struct Reference
System - General Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName

Field Documentation

NvU32 NV_CHIPSET_INFO_v1::deviceId
NvAPI_ShortString NV_CHIPSET_INFO_v1::szChipsetName
NvAPI_ShortString NV_CHIPSET_INFO_v1::szVendorName
NvU32 NV_CHIPSET_INFO_v1::vendorId
NvU32 NV_CHIPSET_INFO_v1::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_CHIPSET_INFO_v2 Struct Reference
System - General Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName
NvU32 flags

Field Documentation

NvU32 NV_CHIPSET_INFO_v2::deviceId

device ID

NvU32 NV_CHIPSET_INFO_v2::flags

Chipset info flags.

NvAPI_ShortString NV_CHIPSET_INFO_v2::szChipsetName

device Name

NvAPI_ShortString NV_CHIPSET_INFO_v2::szVendorName

vendor Name

NvU32 NV_CHIPSET_INFO_v2::vendorId

vendor ID

NvU32 NV_CHIPSET_INFO_v2::version

structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_CHIPSET_INFO_v3 Struct Reference
System - General Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName
NvU32 flags
NvU32 subSysVendorId
NvU32 subSysDeviceId
NvAPI_ShortString szSubSysVendorName

Field Documentation

NvU32 NV_CHIPSET_INFO_v3::deviceId

device ID

NvU32 NV_CHIPSET_INFO_v3::flags

Chipset info flags - obsolete.

NvU32 NV_CHIPSET_INFO_v3::subSysDeviceId

subsystem device ID

NvU32 NV_CHIPSET_INFO_v3::subSysVendorId

subsystem vendor ID

NvAPI_ShortString NV_CHIPSET_INFO_v3::szChipsetName

device Name

NvAPI_ShortString NV_CHIPSET_INFO_v3::szSubSysVendorName

subsystem vendor Name

NvAPI_ShortString NV_CHIPSET_INFO_v3::szVendorName

vendor Name

NvU32 NV_CHIPSET_INFO_v3::vendorId

vendor ID

NvU32 NV_CHIPSET_INFO_v3::version

structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_CHIPSET_INFO_v4 Struct Reference
System - General Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName
NvU32 flags
NvU32 subSysVendorId
NvU32 subSysDeviceId
NvAPI_ShortString szSubSysVendorName
NvU32 HBvendorId
NvU32 HBdeviceId
NvU32 HBsubSysVendorId
NvU32 HBsubSysDeviceId

Field Documentation

NvU32 NV_CHIPSET_INFO_v4::deviceId

Chipset device identification.

NvU32 NV_CHIPSET_INFO_v4::flags

Chipset info flags - obsolete.

NvU32 NV_CHIPSET_INFO_v4::HBdeviceId

Host bridge device identification.

NvU32 NV_CHIPSET_INFO_v4::HBsubSysDeviceId

Host bridge subsystem device identification.

NvU32 NV_CHIPSET_INFO_v4::HBsubSysVendorId

Host bridge subsystem vendor identification.

NvU32 NV_CHIPSET_INFO_v4::HBvendorId

Host bridge vendor identification.

NvU32 NV_CHIPSET_INFO_v4::subSysDeviceId

Chipset subsystem device identification.

NvU32 NV_CHIPSET_INFO_v4::subSysVendorId

Chipset subsystem vendor identification.

NvAPI_ShortString NV_CHIPSET_INFO_v4::szChipsetName

Chipset device Name.

NvAPI_ShortString NV_CHIPSET_INFO_v4::szSubSysVendorName

subsystem vendor Name

NvAPI_ShortString NV_CHIPSET_INFO_v4::szVendorName

Chipset vendor Name.

NvU32 NV_CHIPSET_INFO_v4::vendorId

Chipset vendor identification.

NvU32 NV_CHIPSET_INFO_v4::version

structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_CUSTOM_DISPLAY Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
NvU32 depth
NV_FORMAT colorFormat
NV_VIEWPORTF srcPartition
float | xRatio
float | yRatio
NV_TIMING timing
NvU32 | hwModeSetOnly: 1

Detailed Description

Used in NvAPI_DISP_EnumCustomDisplay() and NvAPI_DISP_TryCustomDisplay().

Field Documentation

NV_FORMAT NV_CUSTOM_DISPLAY::colorFormat

Color format (optional)

NvU32 NV_CUSTOM_DISPLAY::depth

Source surface color depth."0" means all 8/16/32bpp.

NvU32 NV_CUSTOM_DISPLAY::height

Source surface(source mode) height.

NvU32 NV_CUSTOM_DISPLAY::hwModeSetOnly

If set, it means a hardware modeset without OS update.

NV_VIEWPORTF NV_CUSTOM_DISPLAY::srcPartition

For multimon support, should be set to (0,0,1.0,1.0) for now.

NV_TIMING NV_CUSTOM_DISPLAY::timing

Timing used to program TMDS/DAC/LVDS/HDMI/TVEncoder, etc.

NvU32 NV_CUSTOM_DISPLAY::version
NvU32 NV_CUSTOM_DISPLAY::width

Source surface(source mode) width.

float NV_CUSTOM_DISPLAY::xRatio

Horizontal scaling ratio.

float NV_CUSTOM_DISPLAY::yRatio

Vertical scaling ratio.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_DISPLAY_DRIVER_MEMORY_INFO_V1 Struct Reference
Graphics Driver APIs

#include <nvapi_lite_common.h>

Data Fields

NvU32 version
NvU32 dedicatedVideoMemory
NvU32 availableDedicatedVideoMemory
NvU32 systemVideoMemory
NvU32 sharedSystemMemory

Detailed Description

Used in NvAPI_GPU_GetMemoryInfo().

Field Documentation

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::availableDedicatedVideoMemory

Size(in kb) of the available physical framebuffer for allocating video memory surfaces.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::dedicatedVideoMemory

Size(in kb) of the physical framebuffer.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::sharedSystemMemory

Size(in kb) of shared system memory that driver is allowed to commit for surfaces across all allocations.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::systemVideoMemory

Size(in kb) of system memory the driver allocates at load time.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::version

Version info.

The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NV_DISPLAY_DRIVER_MEMORY_INFO_V2 Struct Reference
Graphics Driver APIs

#include <nvapi_lite_common.h>

Data Fields

NvU32 version
NvU32 dedicatedVideoMemory
NvU32 availableDedicatedVideoMemory
NvU32 systemVideoMemory
NvU32 sharedSystemMemory
NvU32 curAvailableDedicatedVideoMemory

Detailed Description

Used in NvAPI_GPU_GetMemoryInfo().

Field Documentation

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::availableDedicatedVideoMemory

Size(in kb) of the available physical framebuffer for allocating video memory surfaces.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::curAvailableDedicatedVideoMemory

Size(in kb) of the current available physical framebuffer for allocating video memory surfaces.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::dedicatedVideoMemory

Size(in kb) of the physical framebuffer.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::sharedSystemMemory

Size(in kb) of shared system memory that driver is allowed to commit for surfaces across all allocations.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::systemVideoMemory

Size(in kb) of system memory the driver allocates at load time.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::version

Version info.

The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NV_DISPLAY_DRIVER_MEMORY_INFO_V3 Struct Reference
Graphics Driver APIs

#include <nvapi_lite_common.h>

Data Fields

NvU32 version
NvU32 dedicatedVideoMemory
NvU32 availableDedicatedVideoMemory
NvU32 systemVideoMemory
NvU32 sharedSystemMemory
NvU32 curAvailableDedicatedVideoMemory
NvU32 dedicatedVideoMemoryEvictionsSize
NvU32 dedicatedVideoMemoryEvictionCount

Detailed Description

Used in NvAPI_GPU_GetMemoryInfo().

Field Documentation

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::availableDedicatedVideoMemory

Size(in kb) of the available physical framebuffer for allocating video memory surfaces.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::curAvailableDedicatedVideoMemory

Size(in kb) of the current available physical framebuffer for allocating video memory surfaces.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::dedicatedVideoMemory

Size(in kb) of the physical framebuffer.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::dedicatedVideoMemoryEvictionCount

Indicates the number of eviction events that caused an allocation to be removed from dedicated video memory to free GPU video memory to make room for other allocations.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::dedicatedVideoMemoryEvictionsSize

Size(in kb) of the total size of memory released as a result of the evictions.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::sharedSystemMemory

Size(in kb) of shared system memory that driver is allowed to commit for surfaces across all allocations.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::systemVideoMemory

Size(in kb) of system memory the driver allocates at load time.

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::version

Version info.

The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NV_DISPLAY_DRIVER_VERSION Struct Reference
Graphics Driver APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 drvVersion
NvU32 bldChangeListNum
NvAPI_ShortString szBuildBranchString
NvAPI_ShortString szAdapterString

Detailed Description

Used in NvAPI_GetDisplayDriverVersion()

Field Documentation

NvU32 NV_DISPLAY_DRIVER_VERSION::bldChangeListNum
NvU32 NV_DISPLAY_DRIVER_VERSION::drvVersion
NvAPI_ShortString NV_DISPLAY_DRIVER_VERSION::szAdapterString
NvAPI_ShortString NV_DISPLAY_DRIVER_VERSION::szBuildBranchString
NvU32 NV_DISPLAY_DRIVER_VERSION::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_DISPLAY_PATH Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 deviceMask
NvU32 sourceId
NvU32 | bPrimary:1
NV_GPU_CONNECTOR_TYPE connector
NvU32 width
NvU32 height
NvU32 depth
NV_FORMAT colorFormat
NV_ROTATE rotation
NV_SCALING scaling
NvU32 refreshRate
NvU32 | interlaced:1
NV_DISPLAY_TV_FORMAT tvFormat
NvU32 posx
NvU32 posy
NvU32 | bGDIPrimary:1
NvU32 | bForceModeSet:1
NvU32 | bFocusDisplay:1
NvU32 | gpuId:24

Detailed Description

Used in NV_DISPLAY_PATH_INFO.

Field Documentation

NvU32 NV_DISPLAY_PATH::bFocusDisplay

(IN) If set, this display path should have the focus after the GPU topology change

NvU32 NV_DISPLAY_PATH::bForceModeSet

(IN) Used only on Win7 and higher during a call to NvAPI_SetViewEx(). Turns off optimization & forces OS to set supplied mode.

NvU32 NV_DISPLAY_PATH::bGDIPrimary

(IN/OUT) Indicates if this is the desktop GDI primary.

NvU32 NV_DISPLAY_PATH::bPrimary

(IN/OUT) Indicates if this is the GPU's primary view target. This is not the desktop GDI primary. NvAPI_SetViewEx() automatically selects the first target in NV_DISPLAY_PATH_INFO index 0 as the GPU's primary view.

NV_FORMAT NV_DISPLAY_PATH::colorFormat

Color format if it needs to be specified. Not used now.

NV_GPU_CONNECTOR_TYPE NV_DISPLAY_PATH::connector

(IN) Specify connector type. For TV only.

NvU32 NV_DISPLAY_PATH::depth

(IN) Depth of the mode

NvU32 NV_DISPLAY_PATH::deviceMask

(IN) Device mask

NvU32 NV_DISPLAY_PATH::gpuId

(IN) the physical display/target Gpu id which is the owner of the scan out (for SLI multimon, display from the slave Gpu)

NvU32 NV_DISPLAY_PATH::height

(IN) Height of the mode

NvU32 NV_DISPLAY_PATH::interlaced

(IN) Interlaced mode flag

NvU32 NV_DISPLAY_PATH::posx

(IN/OUT) X-offset of this display on the Windows desktop

NvU32 NV_DISPLAY_PATH::posy

(IN/OUT) Y-offset of this display on the Windows desktop

NvU32 NV_DISPLAY_PATH::refreshRate

(IN) Refresh rate of the mode

NV_ROTATE NV_DISPLAY_PATH::rotation

(IN) Rotation setting.

NV_SCALING NV_DISPLAY_PATH::scaling

(IN) Scaling setting

NvU32 NV_DISPLAY_PATH::sourceId

(IN) Values will be based on the number of heads exposed per GPU(0, 1?)

NV_DISPLAY_TV_FORMAT NV_DISPLAY_PATH::tvFormat

(IN) To choose the last TV format set this value to NV_DISPLAY_TV_FORMAT_NONE

NvU32 NV_DISPLAY_PATH::width

(IN) Width of the mode

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_DISPLAY_PATH_INFO Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
NV_DISPLAY_PATH path [NVAPI_ADVANCED_MAX_DISPLAY_PATH]

Detailed Description

Used in NvAPI_SetViewEx() and NvAPI_GetViewEx().

Field Documentation

NvU32 NV_DISPLAY_PATH_INFO::count

(IN) Path count

NV_DISPLAY_PATH NV_DISPLAY_PATH_INFO::path[NVAPI_ADVANCED_MAX_DISPLAY_PATH]
NvU32 NV_DISPLAY_PATH_INFO::version

(IN) Structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_DISPLAY_PATH_INFO_V3 Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
NV_DISPLAY_PATH path [NVAPI_MAX_DISPLAY_PATH]

Detailed Description

Used in NvAPI_SetViewEx() and NvAPI_GetViewEx().

Field Documentation

NvU32 NV_DISPLAY_PATH_INFO_V3::count

(IN) Path count

NV_DISPLAY_PATH NV_DISPLAY_PATH_INFO_V3::path[NVAPI_MAX_DISPLAY_PATH]
NvU32 NV_DISPLAY_PATH_INFO_V3::version

(IN) Structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_DISPLAY_PORT_CONFIG Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_DP_LINK_RATE linkRate
NV_DP_LANE_COUNT laneCount
NV_DP_COLOR_FORMAT colorFormat
NV_DP_DYNAMIC_RANGE dynamicRange
NV_DP_COLORIMETRY colorimetry
NV_DP_BPC bpc
NvU32 | isHPD: 1
NvU32 | isSetDeferred: 1
NvU32 | isChromaLpfOff: 1
NvU32 | isDitherOff: 1
NvU32 | testLinkTrain: 1
NvU32 | testColorChange: 1

Detailed Description

DisplayPort configuration settings - used in NvAPI_SetDisplayPort().

Field Documentation

NV_DP_BPC NV_DISPLAY_PORT_CONFIG::bpc

Bit-per-component.

NV_DP_COLOR_FORMAT NV_DISPLAY_PORT_CONFIG::colorFormat

Color format to set.

NV_DP_COLORIMETRY NV_DISPLAY_PORT_CONFIG::colorimetry

Ignored in RGB space.

NV_DP_DYNAMIC_RANGE NV_DISPLAY_PORT_CONFIG::dynamicRange

Dynamic range.

NvU32 NV_DISPLAY_PORT_CONFIG::isChromaLpfOff

Force the chroma low_pass_filter to be off.

NvU32 NV_DISPLAY_PORT_CONFIG::isDitherOff

Force to turn off dither.

NvU32 NV_DISPLAY_PORT_CONFIG::isHPD

If the control panel is making this call due to HPD.

NvU32 NV_DISPLAY_PORT_CONFIG::isSetDeferred

Requires an OS modeset to finalize the setup if set.

NV_DP_LANE_COUNT NV_DISPLAY_PORT_CONFIG::laneCount

Lane count.

NV_DP_LINK_RATE NV_DISPLAY_PORT_CONFIG::linkRate

Link rate.

NvU32 NV_DISPLAY_PORT_CONFIG::testColorChange

If testing mode, skip validation.

NvU32 NV_DISPLAY_PORT_CONFIG::testLinkTrain

If testing mode, skip validation.

NvU32 NV_DISPLAY_PORT_CONFIG::version

Structure version - 2 is the latest.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_EDID_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 EDID_Data [NV_EDID_DATA_SIZE]

Field Documentation

NvU8 NV_EDID_V1::EDID_Data[NV_EDID_DATA_SIZE]
NvU32 NV_EDID_V1::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_EDID_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 EDID_Data [NV_EDID_DATA_SIZE]
NvU32 sizeofEDID

Detailed Description

Used in NvAPI_GPU_GetEDID()

Field Documentation

NvU8 NV_EDID_V2::EDID_Data[NV_EDID_DATA_SIZE]
NvU32 NV_EDID_V2::sizeofEDID
NvU32 NV_EDID_V2::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_EDID_V3 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 EDID_Data [NV_EDID_DATA_SIZE]
NvU32 sizeofEDID
NvU32 edidId
NvU32 offset

Detailed Description

Used in NvAPI_GPU_GetEDID()

Field Documentation

NvU8 NV_EDID_V3::EDID_Data[NV_EDID_DATA_SIZE]
NvU32 NV_EDID_V3::edidId

ID which always returned in a monotonically increasing counter. Across a split-EDID read we need to verify that all calls returned the same edidId. This counter is incremented if we get the updated EDID.

NvU32 NV_EDID_V3::offset

Which 256-byte page of the EDID we want to read. Start at 0. If the read succeeds with edidSize > NV_EDID_DATA_SIZE, call back again with offset+256 until we have read the entire buffer

NvU32 NV_EDID_V3::sizeofEDID
NvU32 NV_EDID_V3::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GET_CURRENT_SLI_STATE Struct Reference
DirectX Interface

#include <nvapi_lite_sli.h>

Data Fields

NvU32 version
NvU32 maxNumAFRGroups
NvU32 numAFRGroups
NvU32 currentAFRIndex
NvU32 nextFrameAFRIndex
NvU32 previousFrameAFRIndex
NvU32 bIsCurAFRGroupNew

Detailed Description

Used in NvAPI_D3D10_GetCurrentSLIState(), and NvAPI_D3D_GetCurrentSLIState().

Field Documentation

NvU32 NV_GET_CURRENT_SLI_STATE::bIsCurAFRGroupNew

[OUT] Boolean: Is this frame the first time running on the current AFR group

NvU32 NV_GET_CURRENT_SLI_STATE::currentAFRIndex

[OUT] The AFR group index for the frame currently being rendered

NvU32 NV_GET_CURRENT_SLI_STATE::maxNumAFRGroups

[OUT] The maximum possible value of numAFRGroups

NvU32 NV_GET_CURRENT_SLI_STATE::nextFrameAFRIndex

[OUT] What the AFR group index will be for the next frame (i.e. after calling Present)

NvU32 NV_GET_CURRENT_SLI_STATE::numAFRGroups

[OUT] The number of AFR groups enabled in the system

NvU32 NV_GET_CURRENT_SLI_STATE::previousFrameAFRIndex

[OUT] The AFR group index that was used for the previous frame (~0 if more than one frame has not been rendered yet)

NvU32 NV_GET_CURRENT_SLI_STATE::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi_lite_sli.h


Data Fields
NV_GPU_CLOCK_FREQUENCIES_V1 Struct Reference
GPU Clock Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 reserved
struct {
NvU32 bIsPresent:1
NvU32 reserved:31
NvU32 frequency
} domain [NVAPI_MAX_GPU_PUBLIC_CLOCKS]

Detailed Description

Used in NvAPI_GPU_GetAllClockFrequencies()

Field Documentation

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::bIsPresent

Set if this domain is present on this GPU.

struct { ... } NV_GPU_CLOCK_FREQUENCIES_V1::domain[NVAPI_MAX_GPU_PUBLIC_CLOCKS]
NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::frequency

Clock frequency (kHz)

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::reserved

These bits are reserved for future use.

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_CLOCK_FREQUENCIES_V2 Struct Reference
GPU Clock Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | ClockType:2
NvU32 | reserved:22
NvU32 | reserved1:8
struct {
NvU32 bIsPresent:1
NvU32 reserved:31
NvU32 frequency
} domain [NVAPI_MAX_GPU_PUBLIC_CLOCKS]

Detailed Description

Used in NvAPI_GPU_GetAllClockFrequencies()

Field Documentation

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::bIsPresent

Set if this domain is present on this GPU.

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::ClockType

One of NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE. Used to specify the type of clock to be returned.

struct { ... } NV_GPU_CLOCK_FREQUENCIES_V2::domain[NVAPI_MAX_GPU_PUBLIC_CLOCKS]
NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::frequency

Clock frequency (kHz)

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::reserved

These bits are reserved for future use. Must be set to 0.

These bits are reserved for future use.

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::reserved1

These bits are reserved.

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_DYNAMIC_PSTATES_INFO_EX Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
struct {
NvU32 bIsPresent:1
NvU32 percentage
} utilization [NVAPI_MAX_GPU_UTILIZATIONS]

Detailed Description

Used in NvAPI_GPU_GetDynamicPstatesInfoEx().

Field Documentation

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::bIsPresent

Set if this utilization domain is present on this GPU.

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::flags

bit 0 indicates if the dynamic Pstate is enabled or not

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::percentage

Percentage of time where the domain is considered busy in the last 1 second interval.

struct { ... } NV_GPU_DYNAMIC_PSTATES_INFO_EX::utilization[NVAPI_MAX_GPU_UTILIZATIONS]
NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_ECC_CONFIGURATION_INFO Struct Reference
GPU ECC Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isEnabled: 1
NvU32 | isEnabledByDefault: 1

Detailed Description

Used in NvAPI_GPU_GetECCConfigurationInfo().

Field Documentation

NvU32 NV_GPU_ECC_CONFIGURATION_INFO::isEnabled

Structure version.

NvU32 NV_GPU_ECC_CONFIGURATION_INFO::isEnabledByDefault

Current ECC configuration stored in non-volatile memory.

NvU32 NV_GPU_ECC_CONFIGURATION_INFO::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_ECC_ERROR_INFO Struct Reference
GPU ECC Interface

#include <nvapi.h>

Data Fields

NvU32 version
struct {
NvU64 singleBitErrors
NvU64 doubleBitErrors
} current
struct {
NvU64 singleBitErrors
NvU64 doubleBitErrors
} aggregate

Detailed Description

Used in NvAPI_GPU_GetECCErrorInfo()/

Field Documentation

struct { ... } NV_GPU_ECC_ERROR_INFO::aggregate
struct { ... } NV_GPU_ECC_ERROR_INFO::current
NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors

Number of double-bit ECC errors detected since last boot.

Number of double-bit ECC errors detected since last counter reset.

NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors

Number of single-bit ECC errors detected since last boot.

Number of single-bit ECC errors detected since last counter reset.

NvU32 NV_GPU_ECC_ERROR_INFO::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_ECC_STATUS_INFO Struct Reference
GPU ECC Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isSupported: 1
NV_ECC_CONFIGURATION configurationOptions
NvU32 | isEnabled: 1

Detailed Description

Used in NvAPI_GPU_GetECCStatusInfo().

Field Documentation

NV_ECC_CONFIGURATION NV_GPU_ECC_STATUS_INFO::configurationOptions

Supported ECC memory feature configuration options.

NvU32 NV_GPU_ECC_STATUS_INFO::isEnabled

Active ECC memory setting.

NvU32 NV_GPU_ECC_STATUS_INFO::isSupported

ECC memory feature support.

NvU32 NV_GPU_ECC_STATUS_INFO::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_GET_HDCP_SUPPORT_STATUS Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_GPU_HDCP_FUSE_STATE hdcpFuseState
NV_GPU_HDCP_KEY_SOURCE hdcpKeySource
NV_GPU_HDCP_KEY_SOURCE_STATE hdcpKeySourceState

Detailed Description

HDPC support status - used in NvAPI_GPU_GetHDCPSupportStatus()

Field Documentation

NV_GPU_HDCP_FUSE_STATE NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpFuseState

Structure version constucted by macro NV_GPU_GET_HDCP_SUPPORT_STATUS.

NV_GPU_HDCP_KEY_SOURCE NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpKeySource

GPU's HDCP fuse state.

NV_GPU_HDCP_KEY_SOURCE_STATE NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpKeySourceState

GPU's HDCP key source.

NvU32 NV_GPU_GET_HDCP_SUPPORT_STATUS::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_PERF_PSTATES20_INFO_V1 Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bIsEditable:1
NvU32 | reserved:31
NvU32 numPstates
NvU32 numClocks
NvU32 numBaseVoltages
struct {
NV_GPU_PERF_PSTATE_ID pstateId
NvU32 bIsEditable:1
NvU32 reserved:31
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]
} pstates [NVAPI_MAX_GPU_PSTATE20_PSTATES]

Detailed Description

Used in NvAPI_GPU_GetPstates20() interface call.

Field Documentation

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::baseVoltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of baseVoltage entries Valid index range is 0 to numBaseVoltages-1

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::bIsEditable
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::clocks[NVAPI_MAX_GPU_PSTATE20_CLOCKS]

Array of clock entries Valid index range is 0 to numClocks-1

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::numBaseVoltages

Number of populated base voltages (per pstate)

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::numClocks

Number of populated clocks (per pstate)

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::numPstates

Number of populated pstates.

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES20_INFO_V1::pstateId

ID of the P-State.

struct { ... } NV_GPU_PERF_PSTATES20_INFO_V1::pstates[NVAPI_MAX_GPU_PSTATE20_PSTATES]

Performance state (P-State) settings Valid index range is 0 to numPstates-1

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::reserved

These bits are reserved for future use (must be always 0)

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::version

Version info of the structure (NV_GPU_PERF_PSTATES20_INFO_VER<n>)

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_PERF_PSTATES20_PARAM_DELTA Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvS32 value
struct {
NvS32 min
NvS32 max
} valueRange

Detailed Description

Used to describe both voltage and frequency deltas.

Field Documentation

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::max

Max value allowed for parameter delta (in respective units [kHz, uV])

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::min

Min value allowed for parameter delta (in respective units [kHz, uV])

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::value

Value of parameter delta (in respective units [kHz, uV])

struct { ... } NV_GPU_PERF_PSTATES20_PARAM_DELTA::valueRange
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_PERF_PSTATES_INFO_V1 Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NvU32 numPstates
NvU32 numClocks
struct {
NV_GPU_PERF_PSTATE_ID pstateId
NvU32 flags
struct {
NV_GPU_PUBLIC_CLOCK_ID domainId
NvU32 flags
NvU32 freq
} clocks [NVAPI_MAX_GPU_PERF_CLOCKS]
} pstates [NVAPI_MAX_GPU_PERF_PSTATES]

Detailed Description

Used in NvAPI_GPU_GetPstatesInfoEx()

Field Documentation

struct { ... } NV_GPU_PERF_PSTATES_INFO_V1::clocks[NVAPI_MAX_GPU_PERF_CLOCKS]
NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V1::domainId

ID of the clock domain.

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags

Reserved. Must be set to 0.

  • bit 0 indicates if perfmon is enabled or not
    • bit 1 indicates if dynamic Pstate is capable or not
    • bit 2 indicates if dynamic Pstate is enable or not
    • all other bits must be set to 0
  • bit 0 indicates if the PCIE limit is GEN1 or GEN2
    • bit 1 indicates if the Pstate is overclocked or not
    • bit 2 indicates if the Pstate is overclockable or not
    • all other bits must be set to 0
NvU32 NV_GPU_PERF_PSTATES_INFO_V1::freq

Clock frequency in kHz.

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::numClocks

The number of clock domains supported by each P-State.

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::numPstates

The number of available p-states.

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V1::pstateId

ID of the p-state.

struct { ... } NV_GPU_PERF_PSTATES_INFO_V1::pstates[NVAPI_MAX_GPU_PERF_PSTATES]
NvU32 NV_GPU_PERF_PSTATES_INFO_V1::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_PERF_PSTATES_INFO_V2 Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NvU32 numPstates
NvU32 numClocks
NvU32 numVoltages
struct {
NV_GPU_PERF_PSTATE_ID pstateId
NvU32 flags
struct {
NV_GPU_PUBLIC_CLOCK_ID domainId
NvU32 flags
NvU32 freq
} clocks [NVAPI_MAX_GPU_PERF_CLOCKS]
struct {
NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID domainId
NvU32 flags
NvU32 mvolt
} voltages [NVAPI_MAX_GPU_PERF_VOLTAGES]
} pstates [NVAPI_MAX_GPU_PERF_PSTATES]

Field Documentation

struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::clocks[NVAPI_MAX_GPU_PERF_CLOCKS]
NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId
NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

ID of the voltage domain, containing flags and mvolt info.

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

Reserved for future use. Must be set to 0.

  • bit 0 indicates if perfmon is enabled or not
    • bit 1 indicates if dynamic Pstate is capable or not
    • bit 2 indicates if dynamic Pstate is enable or not
    • all other bits must be set to 0
  • bit 0 indicates if the PCIE limit is GEN1 or GEN2
    • bit 1 indicates if the Pstate is overclocked or not
    • bit 2 indicates if the Pstate is overclockable or not
    • all other bits must be set to 0

bit 0 indicates if this clock is overclockable all other bits must be set to 0

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::freq
NvU32 NV_GPU_PERF_PSTATES_INFO_V2::mvolt

Voltage in mV.

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::numClocks

The number of clock domains supported by each P-State.

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::numPstates

The number of available p-states.

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::numVoltages
NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V2::pstateId

ID of the p-state.

struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::pstates[NVAPI_MAX_GPU_PERF_PSTATES]

Valid index range is 0 to numVoltages-1.

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::version
struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::voltages[NVAPI_MAX_GPU_PERF_VOLTAGES]
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID domainId
NvU32 | bIsEditable:1
NvU32 | reserved:31
NvU32 volt_uV
NV_GPU_PERF_PSTATES20_PARAM_DELTA voltDelta_uV

Detailed Description

Used to describe single base voltage entry.

Field Documentation

NvU32 NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::bIsEditable
NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::domainId

ID of the voltage domain.

NvU32 NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::reserved

These bits are reserved for future use (must be always 0)

NvU32 NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::volt_uV

Current base voltage settings in [uV].

NV_GPU_PERF_PSTATES20_PARAM_DELTA NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::voltDelta_uV
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 Struct Reference
GPU Performance State Interface

#include <nvapi.h>

Data Fields

NV_GPU_PUBLIC_CLOCK_ID domainId
NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID typeId
NvU32 | bIsEditable:1
NvU32 | reserved:31
NV_GPU_PERF_PSTATES20_PARAM_DELTA freqDelta_kHz
union {
struct {
NvU32 freq_kHz
} single
struct {
NvU32 minFreq_kHz
NvU32 maxFreq_kHz
NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID domainId
NvU32 minVoltage_uV
NvU32 maxVoltage_uV
} range
} data

Detailed Description

Used to describe single clock entry.

Field Documentation

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::bIsEditable
union { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::data

Clock domain type dependant information.

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

ID of the clock domain.

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

Voltage domain ID and value range in (uV) required for this clock.

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freq_kHz

Clock frequency within given pstate in (kHz)

NV_GPU_PERF_PSTATES20_PARAM_DELTA NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freqDelta_kHz

Current frequency delta from nominal settings in (kHz)

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxFreq_kHz

Max clock frequency within given pstate in (kHz)

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxVoltage_uV
NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minFreq_kHz

Min clock frequency within given pstate in (kHz)

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minVoltage_uV
struct { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::range
NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::reserved

These bits are reserved for future use (must be always 0)

struct { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::single
NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::typeId

Clock type ID.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_THERMAL_SETTINGS_V1 Struct Reference
GPU Thermal Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
struct {
NV_THERMAL_CONTROLLER controller
NvU32 defaultMinTemp
NvU32 defaultMaxTemp
NvU32 currentTemp
NV_THERMAL_TARGET target
} sensor [NVAPI_MAX_THERMAL_SENSORS_PER_GPU]

Detailed Description

Used in NvAPI_GPU_GetThermalSettings()

Field Documentation

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V1::controller

internal, ADM1032, MAX6649...

NvU32 NV_GPU_THERMAL_SETTINGS_V1::count

number of associated thermal sensors

NvU32 NV_GPU_THERMAL_SETTINGS_V1::currentTemp

The current temperature value of the thermal sensor in degree Celsius.

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMaxTemp

The max default temperature value of the thermal sensor in degree Celsius.

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMinTemp

The min default temperature value of the thermal sensor in degree Celsius.

struct { ... } NV_GPU_THERMAL_SETTINGS_V1::sensor[NVAPI_MAX_THERMAL_SENSORS_PER_GPU]
NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V1::target

Thermal sensor targeted @ GPU, memory, chipset, powersupply, Visual Computing Device, etc.

NvU32 NV_GPU_THERMAL_SETTINGS_V1::version

structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_GPU_THERMAL_SETTINGS_V2 Struct Reference
GPU Thermal Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
struct {
NV_THERMAL_CONTROLLER controller
NvS32 defaultMinTemp
NvS32 defaultMaxTemp
NvS32 currentTemp
NV_THERMAL_TARGET target
} sensor [NVAPI_MAX_THERMAL_SENSORS_PER_GPU]

Field Documentation

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V2::controller

internal, ADM1032, MAX6649...

NvU32 NV_GPU_THERMAL_SETTINGS_V2::count

number of associated thermal sensors

NvS32 NV_GPU_THERMAL_SETTINGS_V2::currentTemp

Current temperature value of the thermal sensor in degree Celsius.

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMaxTemp

Maximum default temperature value of the thermal sensor in degree Celsius.

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMinTemp

Minimum default temperature value of the thermal sensor in degree Celsius.

struct { ... } NV_GPU_THERMAL_SETTINGS_V2::sensor[NVAPI_MAX_THERMAL_SENSORS_PER_GPU]
NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V2::target

Thermal sensor targeted - GPU, memory, chipset, powersupply, Visual Computing Device, etc.

NvU32 NV_GPU_THERMAL_SETTINGS_V2::version

structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_I2C_INFO_V1 Struct Reference
I2C APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayMask
NvU8 bIsDDCPort
NvU8 i2cDevAddress
NvU8 * pbI2cRegAddress
NvU32 regAddrSize
NvU8 * pbData
NvU32 cbSize
NvU32 i2cSpeed

Detailed Description

Used in NvAPI_I2CRead() and NvAPI_I2CWrite()

Field Documentation

NvU8 NV_I2C_INFO_V1::bIsDDCPort

This flag indicates either the DDC port (TRUE) or the communication port (FALSE) of the concerned display.

NvU32 NV_I2C_INFO_V1::cbSize

The size of the data buffer, pbData, to be read or written.

NvU32 NV_I2C_INFO_V1::displayMask

The Display Mask of the concerned display.

NvU8 NV_I2C_INFO_V1::i2cDevAddress

The address of the I2C slave. The address should be shifted left by one. For example, the I2C address 0x50, often used for reading EDIDs, would be stored here as 0xA0. This matches the position within the byte sent by the master, as the last bit is reserved to specify the read or write direction.

NvU32 NV_I2C_INFO_V1::i2cSpeed

The target speed of the transaction (between 28Kbps to 40Kbps; not guaranteed).

NvU8* NV_I2C_INFO_V1::pbData

The buffer of data which is to be read or written (depending on the command).

NvU8* NV_I2C_INFO_V1::pbI2cRegAddress

The I2C target register address. May be NULL, which indicates no register address should be sent.

NvU32 NV_I2C_INFO_V1::regAddrSize

The size in bytes of target register address. If pbI2cRegAddress is NULL, this field must be 0.

NvU32 NV_I2C_INFO_V1::version

The structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_I2C_INFO_V2 Struct Reference
I2C APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayMask
NvU8 bIsDDCPort
NvU8 i2cDevAddress
NvU8 * pbI2cRegAddress
NvU32 regAddrSize
NvU8 * pbData
NvU32 cbSize
NvU32 i2cSpeed
NV_I2C_SPEED i2cSpeedKhz

Detailed Description

Used in NvAPI_I2CRead() and NvAPI_I2CWrite()

Field Documentation

NvU8 NV_I2C_INFO_V2::bIsDDCPort

This flag indicates either the DDC port (TRUE) or the communication port (FALSE) of the concerned display.

NvU32 NV_I2C_INFO_V2::cbSize

The size of the data buffer, pbData, to be read or written.

NvU32 NV_I2C_INFO_V2::displayMask

The Display Mask of the concerned display.

NvU8 NV_I2C_INFO_V2::i2cDevAddress

The address of the I2C slave. The address should be shifted left by one. For example, the I2C address 0x50, often used for reading EDIDs, would be stored here as 0xA0. This matches the position within the byte sent by the master, as the last bit is reserved to specify the read or write direction.

NvU32 NV_I2C_INFO_V2::i2cSpeed

Deprecated, Must be set to NVAPI_I2C_SPEED_DEPRECATED.

NV_I2C_SPEED NV_I2C_INFO_V2::i2cSpeedKhz

The target speed of the transaction in (kHz) (Chosen from the enum NV_I2C_SPEED).

NvU8* NV_I2C_INFO_V2::pbData

The buffer of data which is to be read or written (depending on the command).

NvU8* NV_I2C_INFO_V2::pbI2cRegAddress

The I2C target register address. May be NULL, which indicates no register address should be sent.

NvU32 NV_I2C_INFO_V2::regAddrSize

The size in bytes of target register address. If pbI2cRegAddress is NULL, this field must be 0.

NvU32 NV_I2C_INFO_V2::version

The structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_I2C_INFO_V3 Struct Reference
I2C APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayMask
NvU8 bIsDDCPort
NvU8 i2cDevAddress
NvU8 * pbI2cRegAddress
NvU32 regAddrSize
NvU8 * pbData
NvU32 cbSize
NvU32 i2cSpeed
NV_I2C_SPEED i2cSpeedKhz
NvU8 portId
NvU32 bIsPortIdSet

Detailed Description

Used in NvAPI_I2CRead() and NvAPI_I2CWrite()

Field Documentation

NvU8 NV_I2C_INFO_V3::bIsDDCPort

This flag indicates either the DDC port (TRUE) or the communication port (FALSE) of the concerned display.

NvU32 NV_I2C_INFO_V3::bIsPortIdSet

set this flag on if and only if portid value is set

NvU32 NV_I2C_INFO_V3::cbSize

The size of the data buffer, pbData, to be read or written.

NvU32 NV_I2C_INFO_V3::displayMask

The Display Mask of the concerned display.

NvU8 NV_I2C_INFO_V3::i2cDevAddress

The address of the I2C slave. The address should be shifted left by one. For example, the I2C address 0x50, often used for reading EDIDs, would be stored here as 0xA0. This matches the position within the byte sent by the master, as the last bit is reserved to specify the read or write direction.

NvU32 NV_I2C_INFO_V3::i2cSpeed

Deprecated, Must be set to NVAPI_I2C_SPEED_DEPRECATED.

NV_I2C_SPEED NV_I2C_INFO_V3::i2cSpeedKhz

The target speed of the transaction in (kHz) (Chosen from the enum NV_I2C_SPEED).

NvU8* NV_I2C_INFO_V3::pbData

The buffer of data which is to be read or written (depending on the command).

NvU8* NV_I2C_INFO_V3::pbI2cRegAddress

The I2C target register address. May be NULL, which indicates no register address should be sent.

NvU8 NV_I2C_INFO_V3::portId

The portid on which device is connected (remember to set bIsPortIdSet if this value is set) Optional for pre-Kepler

NvU32 NV_I2C_INFO_V3::regAddrSize

The size in bytes of target register address. If pbI2cRegAddress is NULL, this field must be 0.

NvU32 NV_I2C_INFO_V3::version

The structure version.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_INFOFRAME_AUDIO Struct Reference

#include <nvapi.h>

Data Fields

NvU32 | codingType: 5
NvU32 | codingExtensionType: 6
NvU32 | sampleSize: 3
NvU32 | sampleRate: 4
NvU32 | channelCount: 4
NvU32 | speakerPlacement: 9
NvU32 | downmixInhibit: 2
NvU32 | lfePlaybackLevel: 3
NvU32 | levelShift: 5
NvU32 | Future12: 2
NvU32 | Future2x: 4
NvU32 | Future3x: 4
NvU32 | Future52: 2
NvU32 | Future6: 9
NvU32 | Future7: 9
NvU32 | Future8: 9
NvU32 | Future9: 9
NvU32 | Future10: 9

Field Documentation

NvU32 NV_INFOFRAME_AUDIO::channelCount
NvU32 NV_INFOFRAME_AUDIO::codingExtensionType
NvU32 NV_INFOFRAME_AUDIO::codingType
NvU32 NV_INFOFRAME_AUDIO::downmixInhibit
NvU32 NV_INFOFRAME_AUDIO::Future10
NvU32 NV_INFOFRAME_AUDIO::Future12
NvU32 NV_INFOFRAME_AUDIO::Future2x
NvU32 NV_INFOFRAME_AUDIO::Future3x
NvU32 NV_INFOFRAME_AUDIO::Future52
NvU32 NV_INFOFRAME_AUDIO::Future6
NvU32 NV_INFOFRAME_AUDIO::Future7
NvU32 NV_INFOFRAME_AUDIO::Future8
NvU32 NV_INFOFRAME_AUDIO::Future9
NvU32 NV_INFOFRAME_AUDIO::levelShift
NvU32 NV_INFOFRAME_AUDIO::lfePlaybackLevel
NvU32 NV_INFOFRAME_AUDIO::sampleRate
NvU32 NV_INFOFRAME_AUDIO::sampleSize
NvU32 NV_INFOFRAME_AUDIO::speakerPlacement
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_INFOFRAME_DATA Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
NvU8 type
union {
NV_INFOFRAME_PROPERTY property
NV_INFOFRAME_AUDIO audio
NV_INFOFRAME_VIDEO video
} infoframe

Field Documentation

NV_INFOFRAME_AUDIO NV_INFOFRAME_DATA::audio
NvU8 NV_INFOFRAME_DATA::cmd

The actions to perform from NV_INFOFRAME_CMD.

union { ... } NV_INFOFRAME_DATA::infoframe
NV_INFOFRAME_PROPERTY NV_INFOFRAME_DATA::property

This is NVIDIA-specific and corresponds to the property cmds and associated infoframe.

NvU16 NV_INFOFRAME_DATA::size

size of this structure

NvU8 NV_INFOFRAME_DATA::type

type of infoframe

NvU32 NV_INFOFRAME_DATA::version

version of this structure

NV_INFOFRAME_VIDEO NV_INFOFRAME_DATA::video
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_INFOFRAME_PROPERTY Struct Reference

#include <nvapi.h>

Data Fields

NvU32 | mode: 4
NvU32 | blackList: 2
NvU32 | reserved: 10
NvU32 | version: 8
NvU32 | length: 8

Field Documentation

NvU32 NV_INFOFRAME_PROPERTY::blackList
NvU32 NV_INFOFRAME_PROPERTY::length
NvU32 NV_INFOFRAME_PROPERTY::mode
NvU32 NV_INFOFRAME_PROPERTY::reserved
NvU32 NV_INFOFRAME_PROPERTY::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_INFOFRAME_VIDEO Struct Reference

#include <nvapi.h>

Data Fields

NvU32 | vic: 8
NvU32 | pixelRepeat: 5
NvU32 | colorSpace: 3
NvU32 | colorimetry: 3
NvU32 | extendedColorimetry: 4
NvU32 | rgbQuantizationRange: 3
NvU32 | yccQuantizationRange: 3
NvU32 | itContent: 2
NvU32 | contentTypes: 3
NvU32 | scanInfo: 3
NvU32 | activeFormatInfoPresent: 2
NvU32 | activeFormatAspectRatio: 5
NvU32 | picAspectRatio: 3
NvU32 | nonuniformScaling: 3
NvU32 | barInfo: 3
NvU32 | top_bar: 17
NvU32 | bottom_bar: 17
NvU32 | left_bar: 17
NvU32 | right_bar: 17
NvU32 | Future17: 2
NvU32 | Future47: 2

Detailed Description

Adding an Auto bit to each field.

Field Documentation

NvU32 NV_INFOFRAME_VIDEO::activeFormatAspectRatio
NvU32 NV_INFOFRAME_VIDEO::activeFormatInfoPresent
NvU32 NV_INFOFRAME_VIDEO::barInfo
NvU32 NV_INFOFRAME_VIDEO::bottom_bar
NvU32 NV_INFOFRAME_VIDEO::colorimetry
NvU32 NV_INFOFRAME_VIDEO::colorSpace
NvU32 NV_INFOFRAME_VIDEO::contentTypes
NvU32 NV_INFOFRAME_VIDEO::extendedColorimetry
NvU32 NV_INFOFRAME_VIDEO::Future17
NvU32 NV_INFOFRAME_VIDEO::Future47
NvU32 NV_INFOFRAME_VIDEO::itContent
NvU32 NV_INFOFRAME_VIDEO::left_bar
NvU32 NV_INFOFRAME_VIDEO::nonuniformScaling
NvU32 NV_INFOFRAME_VIDEO::picAspectRatio
NvU32 NV_INFOFRAME_VIDEO::pixelRepeat
NvU32 NV_INFOFRAME_VIDEO::rgbQuantizationRange
NvU32 NV_INFOFRAME_VIDEO::right_bar
NvU32 NV_INFOFRAME_VIDEO::scanInfo
NvU32 NV_INFOFRAME_VIDEO::top_bar
NvU32 NV_INFOFRAME_VIDEO::vic
NvU32 NV_INFOFRAME_VIDEO::yccQuantizationRange
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_LID_DOCK_PARAMS Struct Reference
System - General Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 currentLidState
NvU32 currentDockState
NvU32 currentLidPolicy
NvU32 currentDockPolicy
NvU32 forcedLidMechanismPresent
NvU32 forcedDockMechanismPresent

Detailed Description

Lid and dock information - used in NvAPI_GetLidDockInfo()

Field Documentation

NvU32 NV_LID_DOCK_PARAMS::currentDockPolicy
NvU32 NV_LID_DOCK_PARAMS::currentDockState
NvU32 NV_LID_DOCK_PARAMS::currentLidPolicy
NvU32 NV_LID_DOCK_PARAMS::currentLidState

Structure version, constructed from the macro NV_LID_DOCK_PARAMS_VER.

NvU32 NV_LID_DOCK_PARAMS::forcedDockMechanismPresent
NvU32 NV_LID_DOCK_PARAMS::forcedLidMechanismPresent
NvU32 NV_LID_DOCK_PARAMS::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MOSAIC_DISPLAY_SETTING_V2 Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
NvU32 bpp
NvU32 freq
NvU32 rrx1k

Field Documentation

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::bpp

Bits per pixel.

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::freq

Display frequency.

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::height

Per-display height.

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::rrx1k

Display frequency in x1k.

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::version

Version of this structure.

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::width

Per-display width.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MOSAIC_DISPLAY_TOPO_STATUS Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 errorFlags
NvU32 warningFlags
NvU32 displayCount
struct {
NvU32 displayId
NvU32 errorFlags
NvU32 warningFlags
NvU32 supportsRotation: 1
NvU32 reserved: 31
} displays [NVAPI_MAX_DISPLAYS]

Field Documentation

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::displayCount

(OUT) The number of valid entries in the displays array.

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::displayId

(OUT) The DisplayID of this display.

struct { ... } NV_MOSAIC_DISPLAY_TOPO_STATUS::displays[NVAPI_MAX_DISPLAYS]
NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::errorFlags

(OUT) Any of the NV_MOSAIC_DISPLAYTOPO_ERROR_* flags.

(OUT) Any of the NV_MOSAIC_DISPLAYCAPS_PROBLEM_* flags.

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::reserved

(OUT) reserved

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::supportsRotation

(OUT) This display can be rotated

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::version
NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::warningFlags

(OUT) Any of the NV_MOSAIC_DISPLAYTOPO_WARNING_* flags.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MOSAIC_SUPPORTED_TOPOLOGIES Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 totalCount
NV_MOSAIC_TOPOLOGY topos [NVAPI_MAX_MOSAIC_TOPOS]

Detailed Description

Used in NvAPI_GetSupportedMosaicTopologies().

Field Documentation

NV_MOSAIC_TOPOLOGY NV_MOSAIC_SUPPORTED_TOPOLOGIES::topos[NVAPI_MAX_MOSAIC_TOPOS]

Maximum number of topologies.

NvU32 NV_MOSAIC_SUPPORTED_TOPOLOGIES::totalCount

Count of valid topologies.

NvU32 NV_MOSAIC_SUPPORTED_TOPOLOGIES::version
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MOSAIC_TOPO_BRIEF Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NV_MOSAIC_TOPO topo
NvU32 enabled
NvU32 isPossible

Detailed Description

This is a "topology brief" structure. It tells you what you need to know about a topology at a high level. A list of these is returned when you query for the supported Mosaic information.

If you need more detailed information about the topology, call NvAPI_Mosaic_GetTopoGroup() with the topology value from this structure.

Field Documentation

NvU32 NV_MOSAIC_TOPO_BRIEF::enabled

1 if topo is enabled, else 0

NvU32 NV_MOSAIC_TOPO_BRIEF::isPossible

1 if topo *can* be enabled, else 0

NV_MOSAIC_TOPO NV_MOSAIC_TOPO_BRIEF::topo

The topology.

NvU32 NV_MOSAIC_TOPO_BRIEF::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MOSAIC_TOPO_DETAILS Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvLogicalGpuHandle hLogicalGPU
NvU32 validityMask
NvU32 rowCount
NvU32 colCount
struct {
NvPhysicalGpuHandle hPhysicalGPU
NvU32 displayOutputId
NvS32 overlapX
NvS32 overlapY
} gpuLayout [NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

Detailed Description

This structure defines the topology details.

NV_GPU_OUTPUT_TYPE. Check displayOutputIds to make sure they are all CRTs, or all DFPs.

Field Documentation

NvU32 NV_MOSAIC_TOPO_DETAILS::colCount

Number of displays in a column.

NvU32 NV_MOSAIC_TOPO_DETAILS::displayOutputId

Connected display target (0 if no display connected)

struct { ... } NV_MOSAIC_TOPO_DETAILS::gpuLayout[NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]
NvLogicalGpuHandle NV_MOSAIC_TOPO_DETAILS::hLogicalGPU

Logical GPU for this topology.

NvPhysicalGpuHandle NV_MOSAIC_TOPO_DETAILS::hPhysicalGPU

Physical GPU to be used in the topology (0 if GPU missing)

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapX

Pixels of overlap on left of target: (+overlap, -gap)

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapY

Pixels of overlap on top of target: (+overlap, -gap)

NvU32 NV_MOSAIC_TOPO_DETAILS::rowCount

Number of displays in a row.

NvU32 NV_MOSAIC_TOPO_DETAILS::validityMask

0 means topology is valid with the current hardware. If not 0, inspect bits against NV_MOSAIC_TOPO_VALIDITY_*.

NvU32 NV_MOSAIC_TOPO_DETAILS::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MOSAIC_TOPO_GROUP Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NV_MOSAIC_TOPO_BRIEF brief
NvU32 count
NV_MOSAIC_TOPO_DETAILS topos [NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP]

Detailed Description

This structure defines a group of topologies that work together to create one overall layout. All of the supported topologies are represented with this structure.

For example, a 'Passive Stereo' topology would be represented with this structure, and would have separate topology details for the left and right eyes. The count would be 2. A 'Basic' topology is also represented by this structure, with a count of 1.

The structure is primarily used internally, but is exposed to applications in a read-only fashion because there are some details in it that might be useful (like the number of rows/cols, or connected display information). A user can get the filled-in structure by calling NvAPI_Mosaic_GetTopoGroup().

You can then look at the detailed values within the structure. There are no entrypoints which take this structure as input (effectively making it read-only).

Field Documentation

NV_MOSAIC_TOPO_BRIEF NV_MOSAIC_TOPO_GROUP::brief

The brief details of this topo.

NvU32 NV_MOSAIC_TOPO_GROUP::count

Number of topos in array below.

NV_MOSAIC_TOPO_DETAILS NV_MOSAIC_TOPO_GROUP::topos[NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP]
NvU32 NV_MOSAIC_TOPO_GROUP::version

Version of this structure.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MOSAIC_TOPOLOGY Struct Reference
Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 rowCount
NvU32 colCount
struct {
NvPhysicalGpuHandle hPhysicalGPU
NvU32 displayOutputId
NvS32 overlapX
NvS32 overlapY
} gpuLayout [NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

Detailed Description

Used in NvAPI_GetCurrentMosaicTopology() and NvAPI_SetCurrentMosaicTopology().

Field Documentation

NvU32 NV_MOSAIC_TOPOLOGY::colCount

Vertical display count.

NvU32 NV_MOSAIC_TOPOLOGY::displayOutputId

Connected display target.

struct { ... } NV_MOSAIC_TOPOLOGY::gpuLayout[NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]
NvPhysicalGpuHandle NV_MOSAIC_TOPOLOGY::hPhysicalGPU

Physical GPU to be used in the topology.

NvS32 NV_MOSAIC_TOPOLOGY::overlapX

Pixels of overlap on the left of target: (+overlap, -gap)

NvS32 NV_MOSAIC_TOPOLOGY::overlapY

Pixels of overlap on the top of target: (+overlap, -gap)

NvU32 NV_MOSAIC_TOPOLOGY::rowCount

Horizontal display count.

NvU32 NV_MOSAIC_TOPOLOGY::version

Version number of the mosaic topology.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_MULTIGPU_CAPS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 multiGPUVersion
NvU32 reserved
NvU32 nTotalGPUs
NvU32 nSLIGPUs
NvU32 videoBridgePresent

Field Documentation

NvU32 NV_MULTIGPU_CAPS::multiGPUVersion
NvU32 NV_MULTIGPU_CAPS::nSLIGPUs
NvU32 NV_MULTIGPU_CAPS::nTotalGPUs
NvU32 NV_MULTIGPU_CAPS::reserved
NvU32 NV_MULTIGPU_CAPS::videoBridgePresent
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_SCANOUT_INTENSITY_DATA_V1 Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
float * blendingTexture

Field Documentation

float* NV_SCANOUT_INTENSITY_DATA_V1::blendingTexture

array of floating values building an intensity RGB texture

NvU32 NV_SCANOUT_INTENSITY_DATA_V1::height

height of the input texture

NvU32 NV_SCANOUT_INTENSITY_DATA_V1::version

version of this structure

NvU32 NV_SCANOUT_INTENSITY_DATA_V1::width

width of the input texture

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_SCANOUT_INTENSITY_DATA_V2 Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
float * | blendingTexture
float * | offsetTexture
NvU32 offsetTexChannels

Field Documentation

float* NV_SCANOUT_INTENSITY_DATA_V2::blendingTexture

array of floating values building an intensity RGB texture

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::height

height of the input texture

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::offsetTexChannels

number of channels per pixel in the offset texture

float* NV_SCANOUT_INTENSITY_DATA_V2::offsetTexture

array of floating values building an offset texture

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::version

version of this structure

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::width

width of the input texture

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_SCANOUT_WARPING_DATA Struct Reference
GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
float * | vertices
NV_GPU_WARPING_VERTICE_FORMAT vertexFormat
int | numVertices
NvSBox * textureRect

Field Documentation

int NV_SCANOUT_WARPING_DATA::numVertices

number of the input vertices

NvSBox* NV_SCANOUT_WARPING_DATA::textureRect

rectangle in desktop coordinates describing the source area for the warping

NvU32 NV_SCANOUT_WARPING_DATA::version

version of this structure

NV_GPU_WARPING_VERTICE_FORMAT NV_SCANOUT_WARPING_DATA::vertexFormat

format of the input vertices

float* NV_SCANOUT_WARPING_DATA::vertices

width of the input texture

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_TIMING_FLAG Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 | isInterlaced: 4
NvU32 | reserved0: 12
union {
NvU32 tvFormat: 8
NvU32 ceaId: 8
NvU32 nvPsfId: 8
};
NvU32 | scaling: 8

Detailed Description

Used in NvAPI_DISP_GetTiming().

Field Documentation

union { ... }
NvU32 NV_TIMING_FLAG::ceaId

The EIA/CEA 861B/D predefined short timing descriptor ID. Used when the timing type is NV_TIMING_OVERRIDE_EIA861 and width==height==rr==0.

NvU32 NV_TIMING_FLAG::isInterlaced

To retrieve interlaced/progressive timing.

NvU32 NV_TIMING_FLAG::nvPsfId

The NV predefined PsF format Id. Used when the timing type is NV_TIMING_OVERRIDE_NV_PREDEFINED.

NvU32 NV_TIMING_FLAG::reserved0
NvU32 NV_TIMING_FLAG::scaling

Define preferred scaling.

NvU32 NV_TIMING_FLAG::tvFormat

The actual analog HD/SDTV format. Used when the timing type is NV_TIMING_OVERRIDE_ANALOG_TV and width==height==rr==0.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_VIEW_TARGET_INFO Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
struct {
NvU32 deviceMask
NvU32 sourceId
NvU32 bPrimary:1
NvU32 bInterlaced:1
NvU32 bGDIPrimary:1
NvU32 bForceModeSet:1
} target [NVAPI_MAX_VIEW_TARGET]

Detailed Description

Used in NvAPI_SetView() and NvAPI_GetView()

Field Documentation

NvU32 NV_VIEW_TARGET_INFO::bForceModeSet

(IN) Used only on Win7 and higher during a call to NvAPI_SetView(). Turns off optimization & forces OS to set supplied mode.

NvU32 NV_VIEW_TARGET_INFO::bGDIPrimary

(IN/OUT) Indicates if this is the desktop GDI primary.

NvU32 NV_VIEW_TARGET_INFO::bInterlaced

(IN/OUT) Indicates if the timing being used on this monitor is interlaced.

NvU32 NV_VIEW_TARGET_INFO::bPrimary

(OUT) Indicates if this is the GPU's primary view target. This is not the desktop GDI primary. NvAPI_SetView automatically selects the first target in NV_VIEW_TARGET_INFO index 0 as the GPU's primary view.

NvU32 NV_VIEW_TARGET_INFO::count

(IN) target count

NvU32 NV_VIEW_TARGET_INFO::deviceMask

(IN/OUT) Device mask

NvU32 NV_VIEW_TARGET_INFO::sourceId

(IN/OUT) Source ID - values will be based on the number of heads exposed per GPU.

struct { ... } NV_VIEW_TARGET_INFO::target[NVAPI_MAX_VIEW_TARGET]
NvU32 NV_VIEW_TARGET_INFO::version

(IN) structure version

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NV_VIEWPORTF Struct Reference

#include <nvapi.h>

Data Fields

float | x
float | y
float | w
float | h

Field Documentation

float NV_VIEWPORTF::h

Height of the viewport.

float NV_VIEWPORTF::w

Width of the viewport.

float NV_VIEWPORTF::x

x-coordinate of the viewport top-left point

float NV_VIEWPORTF::y

y-coordinate of the viewport top-left point

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 Struct Reference
DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NvAPI_D3D11_SWIZZLE_MODE * pCoordinateSwizzling

Field Documentation

NvU32 NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::flags

A combination of flags from NV_FASTGS_FLAGS.

NvAPI_D3D11_SWIZZLE_MODE* NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::pCoordinateSwizzling

[optional] Array of 16 coordinate swizzle modes, one per viewport. NULL if not used.
The output x, y, z, and w coordinates of all vertices can be set to any of the coordinates or their negated versions i.e. {x, y, z, w, -x, -y, -z, -w}. Coordinates are swizzled before any viewport operation occurs i.e. before frustum clipping, scaling, and viewport clipping. And after last of vertex/tesselation/geometry shader stage, stream-out and viewport broadcast expansion (see NV_FASTGS_USE_VIEWPORT_MASK) pCoordinateSwizzling[i] sets the swizzle-mode of each component for viewport i.
See NV_SWIZZLE_MODE for values of allowed swizzle modes.
See NV_SWIZZLE_OFFSET for bit offset from where NV_SWIZZLE_MODE to be set for each component.
For example :
1. To set swizzle for viewport 0 such that - w and z are unchanged and values of x and y are swapped :
pCoordinateSwizzling[0] = (NV_SWIZZLE_POS_W << NV_SWIZZLE_OFFSET_W) |
(NV_SWIZZLE_POS_Z << NV_SWIZZLE_OFFSET_Z) |
(NV_SWIZZLE_POS_X << NV_SWIZZLE_OFFSET_Y) |
(NV_SWIZZLE_POS_Y << NV_SWIZZLE_OFFSET_X);
2. To set swizzle for viewport 0 such that - w, z and y are unchanged and value of x is negated :
pCoordinateSwizzling[0] = (NV_SWIZZLE_POS_W << NV_SWIZZLE_OFFSET_W) |
(NV_SWIZZLE_POS_Z << NV_SWIZZLE_OFFSET_Z) |
(NV_SWIZZLE_POS_Y << NV_SWIZZLE_OFFSET_Y) |
(NV_SWIZZLE_NEG_X << NV_SWIZZLE_OFFSET_X);
Need to set some valid combination of swizzle-modes for all viewports, irrespective of whether that viewport is set.
Invalid swizzle-mode for any viewport (even if that viewport is not set) may result in removal of device.

NvU32 NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::version

ALWAYS == NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NvAPI_D3D11_RASTERIZER_DESC_EX Struct Reference
DirectX Interface

#include <nvapi.h>

Data Fields

D3D11_FILL_MODE | FillMode
D3D11_CULL_MODE | CullMode
BOOL | FrontCounterClockwise
INT | DepthBias
FLOAT | DepthBiasClamp
FLOAT | SlopeScaledDepthBias
BOOL | DepthClipEnable
BOOL | ScissorEnable
BOOL | MultisampleEnable
BOOL | AntialiasedLineEnable
NvU32 ForcedSampleCount
bool | ProgrammableSamplePositionsEnable
bool | InterleavedSamplingEnable
NvU8 SampleCount
NvU8 | SamplePositionsX [16]
NvU8 | SamplePositionsY [16]
bool | ConservativeRasterEnable
NVAPI_QUAD_FILLMODE QuadFillMode
bool | PostZCoverageEnable
bool | CoverageToColorEnable
NvU8 CoverageToColorRTIndex
NvU32 | reserved [16]

Detailed Description

SUPPORTED OS: Windows Vista and higher

Field Documentation

BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::AntialiasedLineEnable
bool NvAPI_D3D11_RASTERIZER_DESC_EX::ConservativeRasterEnable
bool NvAPI_D3D11_RASTERIZER_DESC_EX::CoverageToColorEnable
NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::CoverageToColorRTIndex
D3D11_CULL_MODE NvAPI_D3D11_RASTERIZER_DESC_EX::CullMode
INT NvAPI_D3D11_RASTERIZER_DESC_EX::DepthBias
FLOAT NvAPI_D3D11_RASTERIZER_DESC_EX::DepthBiasClamp
BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::DepthClipEnable
D3D11_FILL_MODE NvAPI_D3D11_RASTERIZER_DESC_EX::FillMode
NvU32 NvAPI_D3D11_RASTERIZER_DESC_EX::ForcedSampleCount
BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::FrontCounterClockwise
bool NvAPI_D3D11_RASTERIZER_DESC_EX::InterleavedSamplingEnable
BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::MultisampleEnable
bool NvAPI_D3D11_RASTERIZER_DESC_EX::PostZCoverageEnable
bool NvAPI_D3D11_RASTERIZER_DESC_EX::ProgrammableSamplePositionsEnable
NVAPI_QUAD_FILLMODE NvAPI_D3D11_RASTERIZER_DESC_EX::QuadFillMode
NvU32 NvAPI_D3D11_RASTERIZER_DESC_EX::reserved[16]
NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::SampleCount
NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::SamplePositionsX[16]
NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::SamplePositionsY[16]
BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::ScissorEnable
FLOAT NvAPI_D3D11_RASTERIZER_DESC_EX::SlopeScaledDepthBias
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 Struct Reference
DirectX Interface

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
NvU32 flags
NvAPI_D3D11_SWIZZLE_MODE * pCoordinateSwizzling

Field Documentation

NvU32 NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::flags

A combination of flags from NV_FASTGS_FLAGS.

NvAPI_D3D11_SWIZZLE_MODE* NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::pCoordinateSwizzling

[optional] Array of 16 coordinate swizzle modes, one per viewport. NULL if not used.
The output x, y, z, and w coordinates of all vertices can be set to any of the coordinates or their negated versions i.e. {x, y, z, w, -x, -y, -z, -w}. Coordinates are swizzled before any viewport operation occurs i.e. before frustum clipping, scaling, and viewport clipping. And after last of vertex/tesselation/geometry shader stage, stream-out and viewport broadcast expansion (see NV_FASTGS_USE_VIEWPORT_MASK) pCoordinateSwizzling[i] sets the swizzle-mode of each component for viewport i.
See NV_SWIZZLE_MODE for values of allowed swizzle modes.
See NV_SWIZZLE_OFFSET for bit offset from where NV_SWIZZLE_MODE to be set for each component.
For example :
1. To set swizzle for viewport 0 such that - w and z are unchanged and values of x and y are swapped :
pCoordinateSwizzling[0] = (NV_SWIZZLE_POS_W << NV_SWIZZLE_OFFSET_W) |
(NV_SWIZZLE_POS_Z << NV_SWIZZLE_OFFSET_Z) |
(NV_SWIZZLE_POS_X << NV_SWIZZLE_OFFSET_Y) |
(NV_SWIZZLE_POS_Y << NV_SWIZZLE_OFFSET_X);
2. To set swizzle for viewport 0 such that - w, z and y are unchanged and value of x is negated :
pCoordinateSwizzling[0] = (NV_SWIZZLE_POS_W << NV_SWIZZLE_OFFSET_W) |
(NV_SWIZZLE_POS_Z << NV_SWIZZLE_OFFSET_Z) |
(NV_SWIZZLE_POS_Y << NV_SWIZZLE_OFFSET_Y) |
(NV_SWIZZLE_NEG_X << NV_SWIZZLE_OFFSET_X);
Need to set some valid combination of swizzle-modes for all viewports, irrespective of whether that viewport is set.
Invalid swizzle-mode for any viewport (even if that viewport is not set) may result in removal of device.

NvU32 NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::version

ALWAYS == NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 Struct Reference
DirectX Interface

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
bool EnableDBT

Field Documentation

bool NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1::EnableDBT
NvU32 NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1::version

Always use NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 Struct Reference
DirectX Interface

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_EXTENSION_DESC_V1:
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1

Data Fields

NvU32 baseVersion
NV_PSO_EXTENSION psoExtension

Field Documentation

NvU32 NVAPI_D3D12_PSO_EXTENSION_DESC_V1::baseVersion

Always use NV_PSO_EXTENSION_DESC_VER.

NV_PSO_EXTENSION NVAPI_D3D12_PSO_EXTENSION_DESC_V1::psoExtension
The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 Struct Reference
DirectX Interface

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
bool | ProgrammableSamplePositionsEnable
bool | InterleavedSamplingEnable
NvU8 SampleCount
NvU8 | SamplePositionsX [16]
NvU8 | SamplePositionsY [16]
NVAPI_QUAD_FILLMODE QuadFillMode
bool | PostZCoverageEnable
bool | CoverageToColorEnable
NvU8 CoverageToColorRTIndex
NvU32 | reserved [16]

Field Documentation

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::CoverageToColorEnable

Enable output of coverage to a color render-target.

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::CoverageToColorRTIndex

Index of RT for coverage-to-color.

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::InterleavedSamplingEnable

when jitter is enabled, an app need to fill the whole arrays below, otherwise only as much entries as samples

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::PostZCoverageEnable

Enable pixel-shader input SV_COVERAGE to account for z-test in early-z mode.

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::ProgrammableSamplePositionsEnable

enable Programmable Samples feature

NVAPI_QUAD_FILLMODE NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::QuadFillMode

Fill a triangle outside its bounds as a screen-aligned quad, matching the tri's bounding-box or filling the full viewport.

NvU32 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::reserved[16]

reserved for expansion, set to zero.

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SampleCount

number of samples. In TIR N->1 it needs to match N, in non-TIR it needs to match RT sample count. Ignored if ForcePerSampleInterlock is set

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SamplePositionsX[16]

x positions in API sample order

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SamplePositionsY[16]

y positions in API sample order

NvU32 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::version

Always use NV_RASTERIZER_PSO_EXTENSION_DESC_VER.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 Struct Reference
DirectX Interface

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version

Field Documentation

NvU32 NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1::version

Always use NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
NvSBox Struct Reference
General NVAPI Defines, Structs, and Enums

#include <nvapi_lite_common.h>

Data Fields

NvS32 sX
NvS32 sY
NvS32 sWidth
NvS32 sHeight

Field Documentation

NvS32 NvSBox::sHeight
NvS32 NvSBox::sWidth
NvS32 NvSBox::sX
NvS32 NvSBox::sY
The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NvShaderExtnStruct Struct Reference

#include <nvHLSLExtnsInternal.h>

Data Fields

uint | opcode
uint | rid
uint | sid
uint4 | dst1u
uint4 | padding0 [3]
uint4 | src0u
uint4 | src1u
uint4 | src2u
uint4 | dst0u
uint | markUavRef
float | padding1 [28]

Field Documentation

uint4 NvShaderExtnStruct::dst0u
uint4 NvShaderExtnStruct::dst1u
uint NvShaderExtnStruct::markUavRef
uint NvShaderExtnStruct::opcode
uint4 NvShaderExtnStruct::padding0[3]
float NvShaderExtnStruct::padding1[28]
uint NvShaderExtnStruct::rid
uint NvShaderExtnStruct::sid
uint4 NvShaderExtnStruct::src0u
uint4 NvShaderExtnStruct::src1u
uint4 NvShaderExtnStruct::src2u
The documentation for this struct was generated from the following file:
  • nvHLSLExtnsInternal.h


Data Fields
NVVIOTOPOLOGYTARGET Struct Reference

#include <nvapi.h>

Data Fields

NvPhysicalGpuHandle | hPhysicalGpu
NvVioHandle | hVioHandle
NvU32 vioId
NvU32 outputId

Field Documentation

NvPhysicalGpuHandle NVVIOTOPOLOGYTARGET::hPhysicalGpu

Handle to Physical GPU (This could be NULL for GVI device if its not binded)

NvVioHandle NVVIOTOPOLOGYTARGET::hVioHandle

handle to SDI Input/Output device

NvU32 NVVIOTOPOLOGYTARGET::outputId

outputId will be 0 for GVI device.

deviceMask of the SDI display connected to GVO device.

NvU32 NVVIOTOPOLOGYTARGET::vioId

device Id of SDI Input/Output device

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Fields
tagNV_TIMINGEXT Struct Reference
Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 flag
NvU16 rr
NvU32 rrx1k
NvU32 aspect
NvU16 rep
NvU32 status
NvU8 name [40]

Detailed Description

NVIDIA-specific timing extras
Used in NV_TIMING.

Field Documentation

NvU32 tagNV_TIMINGEXT::aspect

Display aspect ratio Hi(aspect):horizontal-aspect, Low(aspect):vertical-aspect.

NvU32 tagNV_TIMINGEXT::flag

Reserved for NVIDIA hardware-based enhancement, such as double-scan.

NvU8 tagNV_TIMINGEXT::name[40]

Timing name.

NvU16 tagNV_TIMINGEXT::rep

Bit-wise pixel repetition factor: 0x1:no pixel repetition; 0x2:each pixel repeats twice horizontally,..

NvU16 tagNV_TIMINGEXT::rr

Logical refresh rate to present.

NvU32 tagNV_TIMINGEXT::rrx1k

Physical vertical refresh rate in 0.001Hz.

NvU32 tagNV_TIMINGEXT::status

Timing standard.

The documentation for this struct was generated from the following file:
  • nvapi.h


Data Structure Index
N | T | _
N
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 _NV_GSYNC_STATUS _NVDRS_SETTING_V1
NV_GPU_THERMAL_SETTINGS_V1 NvSBox _NV_GSYNC_STATUS_PARAMS _NVDRS_SETTING_VALUES
NV_CHIPSET_INFO_v1 NV_GPU_THERMAL_SETTINGS_V2 NvShaderExtnStruct _NV_HDMI_SUPPORT_INFO_V1 _NVVIOCAPS
NV_CHIPSET_INFO_v2 NV_I2C_INFO_V1 NVVIOTOPOLOGYTARGET _NV_HDMI_SUPPORT_INFO_V2 _NVVIOCHANNELSTATUS
NV_CHIPSET_INFO_v3 NV_I2C_INFO_V2
T
_NV_MONITOR_CAPABILITIES_V1 _NVVIOCOLORCONVERSION
NV_CHIPSET_INFO_v4 NV_I2C_INFO_V3 _NV_MONITOR_CAPS_VCDB _NVVIOCOMPOSITERANGE
NV_CUSTOM_DISPLAY NV_INFOFRAME_AUDIO tagNV_TIMINGEXT _NV_MONITOR_CAPS_VSDB _NVVIOCONFIG_V1
NV_DISPLAY_DRIVER_MEMORY_INFO_V1 NV_INFOFRAME_DATA
_
_NV_MONITOR_COLOR_DATA _NVVIOCONFIG_V2
NV_DISPLAY_DRIVER_MEMORY_INFO_V2 NV_INFOFRAME_PROPERTY _NV_MOSAIC_DISPLAY_SETTING_V1 _NVVIOCONFIG_V3
NV_DISPLAY_DRIVER_MEMORY_INFO_V3 NV_INFOFRAME_VIDEO _NV_BOARD_INFO _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 _NVVIODATAFORMATDETAIL
NV_DISPLAY_DRIVER_VERSION NV_LID_DOCK_PARAMS _NV_COLOR_DATA_V1 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 _NVVIOGAMMACORRECTION
NV_DISPLAY_PATH NV_MOSAIC_DISPLAY_SETTING_V2 _NV_COLOR_DATA_V2 _NV_MOSAIC_GRID_TOPO_V1 _NVVIOGAMMARAMP10
NV_DISPLAY_PATH_INFO NV_MOSAIC_DISPLAY_TOPO_STATUS _NV_COLOR_DATA_V3 _NV_MOSAIC_GRID_TOPO_V2 _NVVIOGAMMARAMP8
NV_DISPLAY_PATH_INFO_V3 NV_MOSAIC_SUPPORTED_TOPOLOGIES _NV_DISPLAY_PORT_INFO_V1 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 _NVVIOINPUTCONFIG
NV_DISPLAY_PORT_CONFIG NV_MOSAIC_TOPO_BRIEF _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 _NVVIOINPUTSTATUS
NV_EDID_V1 NV_MOSAIC_TOPO_DETAILS _NV_DISPLAYCONFIG_PATH_INFO_V1 _NV_POSITION _NVVIOOUTPUTCONFIG_V1
NV_EDID_V2 NV_MOSAIC_TOPO_GROUP _NV_DISPLAYCONFIG_PATH_INFO_V2 _NV_RECT _NVVIOOUTPUTCONFIG_V2
NV_EDID_V3 NV_MOSAIC_TOPOLOGY _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 _NV_RESOLUTION _NVVIOOUTPUTCONFIG_V3
NV_GET_CURRENT_SLI_STATE NV_MULTIGPU_CAPS _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 _NV_SCANOUT_INFORMATION _NVVIOOUTPUTREGION
NV_GPU_CLOCK_FREQUENCIES_V1 NV_SCANOUT_INTENSITY_DATA_V1 _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 _NV_SCANOUT_INTENSITY_STATE_DATA _NVVIOOUTPUTSTATUS
NV_GPU_CLOCK_FREQUENCIES_V2 NV_SCANOUT_INTENSITY_DATA_V2 _NV_DX_VIDEO_STEREO_INFO _NV_SCANOUT_WARPING_STATE_DATA _NVVIOPCIINFO
NV_GPU_DYNAMIC_PSTATES_INFO_EX NV_SCANOUT_WARPING_DATA _NV_GPU_DISPLAYIDS _NV_TIMING _NVVIOSIGNALFORMATDETAIL
NV_GPU_ECC_CONFIGURATION_INFO NV_TIMING_FLAG _NV_GPU_GET_ILLUMINATION_PARM_V1 _NV_TIMING_INPUT _NVVIOSTATUS
NV_GPU_ECC_ERROR_INFO NV_VIEW_TARGET_INFO _NV_GPU_PERF_PSTATES20_INFO_V2 _NV_VIO_TOPOLOGY _NVVIOSTREAM
NV_GPU_ECC_STATUS_INFO NV_VIEWPORTF _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 _NVAPI_STEREO_CAPS _NVVIOSYNCDELAY
NV_GPU_GET_HDCP_SUPPORT_STATUS NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 _NV_GPU_SET_ILLUMINATION_PARM_V1 _NVDRS_APPLICATION_V1 _NVVIOVIDEOMODE
NV_GPU_PERF_PSTATES20_INFO_V1 NvAPI_D3D11_RASTERIZER_DESC_EX _NV_GSYNC_CAPABILITIES_V1 _NVDRS_APPLICATION_V2 _SettingDWORDNameString
NV_GPU_PERF_PSTATES20_PARAM_DELTA NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 _NV_GSYNC_CONTROL_PARAMS _NVDRS_APPLICATION_V3 _SettingWSTRINGNameString
NV_GPU_PERF_PSTATES_INFO_V1 NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 _NV_GSYNC_DELAY _NVDRS_BINARY_SETTING
NV_GPU_PERF_PSTATES_INFO_V2 NVAPI_D3D12_PSO_EXTENSION_DESC_V1 _NV_GSYNC_DISPLAY _NVDRS_GPU_SUPPORT
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 _NV_GSYNC_GPU _NVDRS_PROFILE_V1
N | T | _


Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
  • _NV_BOARD_INFO
  • _NV_COLOR_DATA_V1
  • _NV_COLOR_DATA_V2
  • _NV_COLOR_DATA_V3
  • _NV_DISPLAY_PORT_INFO_V1
  • _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • _NV_DISPLAYCONFIG_PATH_INFO_V1
  • _NV_DISPLAYCONFIG_PATH_INFO_V2
  • _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
  • _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • _NV_DX_VIDEO_STEREO_INFO
  • _NV_GPU_DISPLAYIDS
  • _NV_GPU_GET_ILLUMINATION_PARM_V1
  • _NV_GPU_PERF_PSTATES20_INFO_V2
  • _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
  • _NV_GPU_SET_ILLUMINATION_PARM_V1
  • _NV_GSYNC_CAPABILITIES_V1
  • _NV_GSYNC_CONTROL_PARAMS
  • _NV_GSYNC_DELAY
  • _NV_GSYNC_DISPLAY
  • _NV_GSYNC_GPU
  • _NV_GSYNC_STATUS
  • _NV_GSYNC_STATUS_PARAMS
  • _NV_HDMI_SUPPORT_INFO_V1
  • _NV_HDMI_SUPPORT_INFO_V2
  • _NV_MONITOR_CAPABILITIES_V1
  • _NV_MONITOR_CAPS_VCDB
  • _NV_MONITOR_CAPS_VSDB
  • _NV_MONITOR_COLOR_DATA
  • _NV_MOSAIC_DISPLAY_SETTING_V1
  • _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
  • _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • _NV_MOSAIC_GRID_TOPO_V1
  • _NV_MOSAIC_GRID_TOPO_V2
  • _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
  • _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • _NV_POSITION
  • _NV_RECT
  • _NV_RESOLUTION
  • _NV_SCANOUT_INFORMATION
  • _NV_SCANOUT_INTENSITY_STATE_DATA
  • _NV_SCANOUT_WARPING_STATE_DATA
  • _NV_TIMING
  • _NV_TIMING_INPUT
  • _NV_VIO_TOPOLOGY
  • _NVAPI_STEREO_CAPS
  • _NVDRS_APPLICATION_V1
  • _NVDRS_APPLICATION_V2
  • _NVDRS_APPLICATION_V3
  • _NVDRS_BINARY_SETTING
  • _NVDRS_GPU_SUPPORT
  • _NVDRS_PROFILE_V1
  • _NVDRS_SETTING_V1
  • _NVDRS_SETTING_VALUES
  • _NVVIOCAPS
  • _NVVIOCHANNELSTATUS
  • _NVVIOCOLORCONVERSION
  • _NVVIOCOMPOSITERANGE
  • _NVVIOCONFIG_V1
  • _NVVIOCONFIG_V2
  • _NVVIOCONFIG_V3
  • _NVVIODATAFORMATDETAIL
  • _NVVIOGAMMACORRECTION
  • _NVVIOGAMMARAMP10
  • _NVVIOGAMMARAMP8
  • _NVVIOINPUTCONFIG
  • _NVVIOINPUTSTATUS
  • _NVVIOOUTPUTCONFIG_V1
  • _NVVIOOUTPUTCONFIG_V2
  • _NVVIOOUTPUTCONFIG_V3
  • _NVVIOOUTPUTREGION
  • _NVVIOOUTPUTSTATUS
  • _NVVIOPCIINFO
  • _NVVIOSIGNALFORMATDETAIL
  • _NVVIOSTATUS
  • _NVVIOSTREAM
  • _NVVIOSYNCDELAY
  • _NVVIOVIDEOMODE
  • _SettingDWORDNameString
  • _SettingWSTRINGNameString
  • NV_CHIPSET_INFO_v1
  • NV_CHIPSET_INFO_v2
  • NV_CHIPSET_INFO_v3
  • NV_CHIPSET_INFO_v4
  • NV_CUSTOM_DISPLAY
  • NV_DISPLAY_DRIVER_MEMORY_INFO_V1
  • NV_DISPLAY_DRIVER_MEMORY_INFO_V2
  • NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • NV_DISPLAY_DRIVER_VERSION
  • NV_DISPLAY_PATH
  • NV_DISPLAY_PATH_INFO
  • NV_DISPLAY_PATH_INFO_V3
  • NV_DISPLAY_PORT_CONFIG
  • NV_EDID_V1
  • NV_EDID_V2
  • NV_EDID_V3
  • NV_GET_CURRENT_SLI_STATE
  • NV_GPU_CLOCK_FREQUENCIES_V1
  • NV_GPU_CLOCK_FREQUENCIES_V2
  • NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • NV_GPU_ECC_CONFIGURATION_INFO
  • NV_GPU_ECC_ERROR_INFO
  • NV_GPU_ECC_STATUS_INFO
  • NV_GPU_GET_HDCP_SUPPORT_STATUS
  • NV_GPU_PERF_PSTATES20_INFO_V1
  • NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • NV_GPU_PERF_PSTATES_INFO_V1
  • NV_GPU_PERF_PSTATES_INFO_V2
  • NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • NV_GPU_THERMAL_SETTINGS_V1
  • NV_GPU_THERMAL_SETTINGS_V2
  • NV_I2C_INFO_V1
  • NV_I2C_INFO_V2
  • NV_I2C_INFO_V3
  • NV_INFOFRAME_AUDIO
  • NV_INFOFRAME_DATA
  • NV_INFOFRAME_PROPERTY
  • NV_INFOFRAME_VIDEO
  • NV_LID_DOCK_PARAMS
  • NV_MOSAIC_DISPLAY_SETTING_V2
  • NV_MOSAIC_DISPLAY_TOPO_STATUS
  • NV_MOSAIC_SUPPORTED_TOPOLOGIES
  • NV_MOSAIC_TOPO_BRIEF
  • NV_MOSAIC_TOPO_DETAILS
  • NV_MOSAIC_TOPO_GROUP
  • NV_MOSAIC_TOPOLOGY
  • NV_MULTIGPU_CAPS
  • NV_SCANOUT_INTENSITY_DATA_V1
  • NV_SCANOUT_INTENSITY_DATA_V2
  • NV_SCANOUT_WARPING_DATA
  • NV_TIMING_FLAG
  • NV_VIEW_TARGET_INFO
  • NV_VIEWPORTF
  • NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1
  • NvAPI_D3D11_RASTERIZER_DESC_EX
  • NVAPI_D3D12_PSO_EXTENSION_DESC_V1
    • NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
    • NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
    • NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
    • NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1
  • NvSBox
  • NvShaderExtnStruct
  • NVVIOTOPOLOGYTARGET
  • tagNV_TIMINGEXT


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • acceleratePrimaryDisplay : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • activeFormatAspectRatio : NV_INFOFRAME_VIDEO
  • activeFormatInfoPresent : NV_INFOFRAME_VIDEO
  • adapterCaps : _NVVIOCAPS
  • adapterClass : _NVVIOCAPS
  • adapterName : _NVVIOCAPS
  • aggregate : NV_GPU_ECC_ERROR_INFO
  • ancParityComputation : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • AntialiasedLineEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • applyWithBezelCorrect : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • appName : _NVDRS_APPLICATION_V3 , _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V1
  • aspect : tagNV_TIMINGEXT
  • Attribute : _NV_GPU_SET_ILLUMINATION_PARM_V1 , _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 , _NV_GPU_GET_ILLUMINATION_PARM_V1
  • audio : NV_INFOFRAME_DATA
  • audioLatency : _NV_MONITOR_CAPS_VSDB
  • availableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • backendBitDepths : _NV_MONITOR_COLOR_DATA
  • barInfo : NV_INFOFRAME_VIDEO
  • baseMosaic : _NV_MOSAIC_GRID_TOPO_V2 , _NV_MOSAIC_GRID_TOPO_V1
  • baseVersion : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • baseVoltages : NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • bEnabled : _NV_SCANOUT_INTENSITY_STATE_DATA , _NV_SCANOUT_WARPING_STATE_DATA
  • bFocusDisplay : NV_DISPLAY_PATH
  • bForceModeSet : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH
  • bGDIPrimary : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • bHouseSync : _NV_GSYNC_STATUS_PARAMS
  • binaryCurrentValue : _NVDRS_SETTING_V1
  • binaryDefaultValue : _NVDRS_SETTING_VALUES
  • binaryPredefinedValue : _NVDRS_SETTING_V1
  • binaryValue : _NVDRS_SETTING_VALUES
  • bInterlaced : NV_VIEW_TARGET_INFO
  • bIsCurAFRGroupNew : NV_GET_CURRENT_SLI_STATE
  • bIsDDCPort : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • bIsEditable : NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • bIsPortIdSet : NV_I2C_INFO_V3
  • bIsPresent : NV_GPU_CLOCK_FREQUENCIES_V2 , NV_GPU_DYNAMIC_PSTATES_INFO_EX , NV_GPU_CLOCK_FREQUENCIES_V1
  • bIsStereoSynced : _NV_GSYNC_STATUS
  • bIsSynced : _NV_GSYNC_STATUS
  • bIsSyncSignalAvailable : _NV_GSYNC_STATUS
  • bIsValidInfo : _NV_MONITOR_CAPABILITIES_V1
  • bitsPerComponent : _NVVIOCHANNELSTATUS , _NVVIOSTREAM
  • blackList : NV_INFOFRAME_PROPERTY
  • bldChangeListNum : NV_DISPLAY_DRIVER_VERSION
  • blendingTexture : NV_SCANOUT_INTENSITY_DATA_V1 , NV_SCANOUT_INTENSITY_DATA_V2
  • boardId : _NV_GSYNC_CAPABILITIES_V1
  • boardID : _NVVIOCAPS
  • BoardNum : _NV_BOARD_INFO
  • bottom : _NV_RECT
  • bottom_bar : NV_INFOFRAME_VIDEO
  • bpc : NV_DISPLAY_PORT_CONFIG , _NV_COLOR_DATA_V3 , _NV_DISPLAY_PORT_INFO_V1
  • bpp : _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2
  • bPrimary : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH
  • brief : NV_MOSAIC_TOPO_GROUP
  • bSLIFocus : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • bStereoEnable : _NV_DX_VIDEO_STEREO_INFO
  • bSupported : _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
  • bTestMode : _NVVIOINPUTCONFIG


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • capFlags : _NV_GSYNC_CAPABILITIES_V1
  • captureStatus : _NVVIOINPUTSTATUS
  • cbSize : NV_I2C_INFO_V2 , NV_I2C_INFO_V3 , NV_I2C_INFO_V1
  • ceaId : NV_TIMING_FLAG
  • channel : _NVVIOSTREAM
  • channelCount : NV_INFOFRAME_AUDIO
  • clocks : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • ClockType : NV_GPU_CLOCK_FREQUENCIES_V2
  • cloneGroup : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • cloneImportance : _NV_SCANOUT_INFORMATION
  • cmd : NV_INFOFRAME_DATA , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3
  • cnc0SupportGraphicsTextContent : _NV_MONITOR_CAPS_VSDB
  • cnc1SupportPhotoContent : _NV_MONITOR_CAPS_VSDB
  • cnc2SupportCinemaContent : _NV_MONITOR_CAPS_VSDB
  • cnc3SupportGameContent : _NV_MONITOR_CAPS_VSDB
  • codingExtensionType : NV_INFOFRAME_AUDIO
  • codingType : NV_INFOFRAME_AUDIO
  • colCount : NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY
  • colorConversion : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • colorDepth : _NV_RESOLUTION
  • colorFormat : NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 , _NV_DISPLAY_PORT_INFO_V1 , NV_DISPLAY_PORT_CONFIG , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3 , _NV_MONITOR_COLOR_DATA , NV_CUSTOM_DISPLAY
  • colorimetry : _NV_DISPLAY_PORT_INFO_V1 , NV_DISPLAY_PORT_CONFIG , NV_INFOFRAME_VIDEO , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3
  • colorMatrix : _NVVIOCOLORCONVERSION
  • colorOffset : _NVVIOCOLORCONVERSION
  • colorScale : _NVVIOCOLORCONVERSION
  • colorSpace : NV_INFOFRAME_VIDEO , _NVVIOCHANNELSTATUS
  • columns : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • compositeSafe : _NVVIOCOLORCONVERSION
  • compositeSyncType : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • compositeTerminate : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • compRange : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1
  • compSyncIn : _NVVIOOUTPUTSTATUS
  • configurationOptions : NV_GPU_ECC_STATUS_INFO
  • connector : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , _NV_GSYNC_GPU , NV_DISPLAY_PATH
  • connectorType : _NV_GPU_DISPLAYIDS , _NV_MONITOR_CAPABILITIES_V1
  • ConservativeRasterEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • contentTypes : NV_INFOFRAME_VIDEO
  • controller : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • count : NV_VIEW_TARGET_INFO , NV_MOSAIC_TOPO_GROUP , NV_GPU_THERMAL_SETTINGS_V2 , NV_DISPLAY_PATH_INFO_V3 , NV_GPU_THERMAL_SETTINGS_V1 , NV_DISPLAY_PATH_INFO
  • CoverageToColorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • CoverageToColorRTIndex : NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NvAPI_D3D11_RASTERIZER_DESC_EX
  • cscOverride : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • CullMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • curAvailableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V3 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2
  • curLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • curLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • current : NV_GPU_ECC_ERROR_INFO
  • currentAFRIndex : NV_GET_CURRENT_SLI_STATE
  • currentDockPolicy : NV_LID_DOCK_PARAMS
  • currentDockState : NV_LID_DOCK_PARAMS
  • currentLidPolicy : NV_LID_DOCK_PARAMS
  • currentLidState : NV_LID_DOCK_PARAMS
  • currentTemp : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • data : NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V3 , _NV_MONITOR_CAPABILITIES_V1 , _NV_COLOR_DATA_V2
  • dataFormat : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3 , _NVVIODATAFORMATDETAIL , _NVVIOOUTPUTCONFIG_V1
  • dataIntegrityCheckEnabled : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckErrorCount : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckFailed : _NVVIOOUTPUTSTATUS
  • dedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • dedicatedVideoMemoryEvictionCount : NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • dedicatedVideoMemoryEvictionsSize : NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • defaultMaxTemp : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • defaultMinTemp : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • defaultValue : _SettingDWORDNameString , _SettingWSTRINGNameString
  • depth : NV_DISPLAY_PATH , NV_CUSTOM_DISPLAY
  • DepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthBiasClamp : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthClipEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • details : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 , _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • deviceId : NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v1 , NV_CHIPSET_INFO_v4
  • deviceMask : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH
  • dipSwitch : _NVVIOCAPS
  • dipSwitchReserved : _NVVIOCAPS
  • disableVirtualModeSupport : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • displayCount : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2 , NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displayId : _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 , _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 , _NV_GPU_DISPLAYIDS , _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 , NV_MOSAIC_DISPLAY_TOPO_STATUS , _NV_GSYNC_DISPLAY
  • displayMask : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • displayOutputId : NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY
  • displays : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2 , NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displaySettings : _NV_MOSAIC_GRID_TOPO_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_GRID_TOPO_V1
  • displaySettingsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
  • domain : NV_GPU_CLOCK_FREQUENCIES_V1 , NV_GPU_CLOCK_FREQUENCIES_V2
  • domainId : NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 , NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V1
  • doubleBitErrors : NV_GPU_ECC_ERROR_INFO
  • downmixInhibit : NV_INFOFRAME_AUDIO
  • dpcd_ver : _NV_DISPLAY_PORT_INFO_V1
  • driver : _NVVIOCAPS
  • driverReloadAllowed : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • drvVersion : NV_DISPLAY_DRIVER_VERSION
  • dst0u : NvShaderExtnStruct
  • dst1u : NvShaderExtnStruct
  • dwVersion : _NV_DX_VIDEO_STEREO_INFO
  • dynamicRange : NV_DISPLAY_PORT_CONFIG , _NV_COLOR_DATA_V2 , _NV_DISPLAY_PORT_INFO_V1 , _NV_COLOR_DATA_V3


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • EDID861ExtRev : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • EDID_Data : NV_EDID_V2 , NV_EDID_V3 , NV_EDID_V1
  • edidId : NV_EDID_V3
  • eFormat : _NV_DX_VIDEO_STEREO_INFO
  • enable422Filter : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • enableAlphaKeyComposite : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • enableANCTimeCodeGeneration : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • enableAudioBlanking : _NVVIOOUTPUTCONFIG_V3
  • enableComposite : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • enabled : NV_MOSAIC_TOPO_BRIEF
  • enableDataIntegrityCheck : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V3
  • EnableDBT : NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
  • enableFullColorRange : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V3
  • enableRGBData : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1
  • errorFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • etc : _NV_TIMING
  • expansionEnable : _NVVIOSTREAM
  • extendedColorimetry : NV_INFOFRAME_VIDEO


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fFrameRate : _NVVIOVIDEOMODE
  • fGammaValueB : _NVVIOGAMMACORRECTION
  • fGammaValueG : _NVVIOGAMMACORRECTION
  • fGammaValueR : _NVVIOGAMMACORRECTION
  • fields : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • fileInFolder : _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V3
  • FillMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • firmWare : _NVVIOCAPS
  • flag : tagNV_TIMINGEXT , _NV_TIMING_INPUT
  • flags : NV_GPU_DYNAMIC_PSTATES_INFO_EX , NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 , NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 , NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2
  • flipQueueLength : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • forcedDockMechanismPresent : NV_LID_DOCK_PARAMS
  • forcedLidMechanismPresent : NV_LID_DOCK_PARAMS
  • ForcedSampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX
  • frameLockEnable : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTSTATUS , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • freq : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2
  • freq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • freqDelta_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • frequency : NV_GPU_CLOCK_FREQUENCIES_V1 , NV_GPU_CLOCK_FREQUENCIES_V2
  • FrontCounterClockwise : NvAPI_D3D11_RASTERIZER_DESC_EX
  • Future10 : NV_INFOFRAME_AUDIO
  • Future12 : NV_INFOFRAME_AUDIO
  • Future17 : NV_INFOFRAME_VIDEO
  • Future2x : NV_INFOFRAME_AUDIO
  • Future3x : NV_INFOFRAME_AUDIO
  • Future47 : NV_INFOFRAME_VIDEO
  • Future52 : NV_INFOFRAME_AUDIO
  • Future6 : NV_INFOFRAME_AUDIO
  • Future7 : NV_INFOFRAME_AUDIO
  • Future8 : NV_INFOFRAME_AUDIO
  • Future9 : NV_INFOFRAME_AUDIO


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • gammaCorrection : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • gammaRamp : _NVVIOGAMMACORRECTION
  • gammaRamp10 : _NVVIOGAMMACORRECTION
  • gammaRamp8 : _NVVIOGAMMACORRECTION
  • geforce : _NVDRS_GPU_SUPPORT
  • gpuId : NV_DISPLAY_PATH
  • gpuLayout : NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY
  • gpuSupport : _NVDRS_PROFILE_V1


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • h : NV_VIEWPORTF
  • has3dEntries : _NV_MONITOR_CAPS_VSDB
  • hasInterlacedLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasVicEntries : _NV_MONITOR_CAPS_VSDB
  • HBdeviceId : NV_CHIPSET_INFO_v4
  • HBorder : _NV_TIMING
  • HBsubSysDeviceId : NV_CHIPSET_INFO_v4
  • HBsubSysVendorId : NV_CHIPSET_INFO_v4
  • HBvendorId : NV_CHIPSET_INFO_v4
  • hdcpFuseState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySource : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySourceState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdmi3dLength : _NV_MONITOR_CAPS_VSDB
  • hdmi_3d : _NV_MONITOR_CAPS_VSDB
  • hdmi_vic : _NV_MONITOR_CAPS_VSDB
  • hdmiVicLength : _NV_MONITOR_CAPS_VSDB
  • height : NV_DISPLAY_PATH , _NV_RESOLUTION , NV_SCANOUT_INTENSITY_DATA_V1 , NV_SCANOUT_INTENSITY_DATA_V2 , _NV_TIMING_INPUT , NV_CUSTOM_DISPLAY , _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2 , _NVVIOOUTPUTREGION
  • HFrontPorch : _NV_TIMING
  • hLinkedSurface : _NV_DX_VIDEO_STEREO_INFO
  • hLogicalGPU : NV_MOSAIC_TOPO_DETAILS
  • horizontalDelay : _NVVIOSYNCDELAY
  • horizontalPixels : _NVVIOVIDEOMODE
  • houseSyncIncoming : _NV_GSYNC_STATUS_PARAMS
  • hPhysicalGpu : _NV_GSYNC_GPU
  • hPhysicalGPU : NV_MOSAIC_TOPOLOGY
  • hPhysicalGpu : _NV_GPU_GET_ILLUMINATION_PARM_V1 , NVVIOTOPOLOGYTARGET , _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
  • hPhysicalGPU : NV_MOSAIC_TOPO_DETAILS
  • hPhysicalGpu : _NV_GPU_SET_ILLUMINATION_PARM_V1
  • hProxyPhysicalGpu : _NV_GSYNC_GPU
  • hSurface : _NV_DX_VIDEO_STEREO_INFO
  • HSyncPol : _NV_TIMING
  • HSyncWidth : _NV_TIMING
  • HTotal : _NV_TIMING
  • hVioHandle : NVVIOTOPOLOGYTARGET
  • HVisible : _NV_TIMING
  • hwModeSetOnly : NV_CUSTOM_DISPLAY


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • i2cDevAddress : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • i2cSpeed : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • i2cSpeedKhz : NV_I2C_INFO_V3 , NV_I2C_INFO_V2
  • immersiveGaming : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • inConfig : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • infoframe : NV_INFOFRAME_DATA
  • infoType : _NV_MONITOR_CAPABILITIES_V1
  • inStatus : _NVVIOSTATUS
  • interlaced : _NV_TIMING , NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • interlacedAudioLatency : _NV_MONITOR_CAPS_VSDB
  • interlacedVideoLatency : _NV_MONITOR_CAPS_VSDB
  • interlaceMode : _NV_GSYNC_CONTROL_PARAMS , _NVVIOVIDEOMODE
  • InterleavedSamplingEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • interval : _NV_GSYNC_CONTROL_PARAMS
  • is10BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is10BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isActive : _NV_GPU_DISPLAYIDS
  • isChromaLpfOff : NV_DISPLAY_PORT_CONFIG
  • isCluster : _NV_GPU_DISPLAYIDS
  • isColorCtrlSupported : _NV_DISPLAY_PORT_INFO_V1
  • isCommandLine : _NVDRS_APPLICATION_V3
  • isConnected : _NV_GPU_DISPLAYIDS
  • isCurrentPredefined : _NVDRS_SETTING_V1
  • isDitherOff : NV_DISPLAY_PORT_CONFIG
  • isDp : _NV_DISPLAY_PORT_INFO_V1
  • isDynamic : _NV_GPU_DISPLAYIDS
  • isEnabled : NV_GPU_ECC_STATUS_INFO , NV_GPU_ECC_CONFIGURATION_INFO
  • isEnabledByDefault : NV_GPU_ECC_CONFIGURATION_INFO
  • isGpuHDMICapable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isHPD : NV_DISPLAY_PORT_CONFIG
  • isInterlaced : NV_TIMING_FLAG
  • isInternalDp : _NV_DISPLAY_PORT_INFO_V1
  • isMasterable : _NV_GSYNC_DISPLAY
  • isMetro : _NVDRS_APPLICATION_V3
  • isMonAdobeRGBCapable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonAdobeYCC601Capable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonBasicAudioCapable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonBT2020cYCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020RGBCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020YCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonHDMI : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonsYCC601Capable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonUnderscanCapable : _NV_HDMI_SUPPORT_INFO_V2 , _NV_HDMI_SUPPORT_INFO_V1
  • isMonxvYCC601Capable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2 , _NV_HDMI_SUPPORT_INFO_V1
  • isMonxvYCC709Capable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr422Capable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr444Capable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMultiStreamRootNode : _NV_GPU_DISPLAYIDS
  • IsNonNVIDIAAdapter : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • isOSVisible : _NV_GPU_DISPLAYIDS
  • isPhysicallyConnected : _NV_GPU_DISPLAYIDS
  • isPossible : NV_MOSAIC_TOPO_BRIEF
  • isPredefined : _NVDRS_PROFILE_V1 , _NVDRS_APPLICATION_V1 , _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V3
  • isPredefinedValid : _NVDRS_SETTING_V1
  • isPreferredUnscaledTarget : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • isRgb444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isSetDeferred : NV_DISPLAY_PORT_CONFIG
  • isSupported : NV_GPU_ECC_STATUS_INFO
  • isSynced : _NV_GSYNC_GPU
  • isWFD : _NV_GPU_DISPLAYIDS
  • isYCbCr422SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCbCr444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb422Supported : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb444Supported : _NV_DISPLAY_PORT_INFO_V1
  • itContent : NV_INFOFRAME_VIDEO


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- j -

  • jack : _NVVIOSTREAM


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • laneCount : NV_DISPLAY_PORT_CONFIG
  • launcher : _NVDRS_APPLICATION_V1 , _NVDRS_APPLICATION_V3 , _NVDRS_APPLICATION_V2
  • left : _NV_RECT
  • left_bar : NV_INFOFRAME_VIDEO
  • length : NV_INFOFRAME_PROPERTY
  • levelShift : NV_INFOFRAME_AUDIO
  • lfePlaybackLevel : NV_INFOFRAME_AUDIO
  • linkID : _NVVIOCHANNELSTATUS
  • linkRate : NV_DISPLAY_PORT_CONFIG
  • links : _NVVIOSTREAM


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • majorVersion : _NVVIOCAPS
  • markUavRef : NvShaderExtnStruct
  • max : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • maxFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • maxLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • maxLines : _NV_GSYNC_DELAY
  • maxLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • maxNumAFRGroups : NV_GET_CURRENT_SLI_STATE
  • maxTmdsClock : _NV_MONITOR_CAPS_VSDB
  • maxVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • min : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • minFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • minorVersion : _NVVIOCAPS
  • minPixels : _NV_GSYNC_DELAY
  • minVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • mode : NV_INFOFRAME_PROPERTY
  • multiGPUVersion : NV_MULTIGPU_CAPS
  • MultisampleEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • mvolt : NV_GPU_PERF_PSTATES_INFO_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • name : tagNV_TIMINGEXT
  • nextFrameAFRIndex : NV_GET_CURRENT_SLI_STATE
  • nonuniformScaling : NV_INFOFRAME_VIDEO
  • nSLIGPUs : NV_MULTIGPU_CAPS
  • nTotalGPUs : NV_MULTIGPU_CAPS
  • numAFRGroups : NV_GET_CURRENT_SLI_STATE
  • numBaseVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1
  • numClocks : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • numLines : _NV_GSYNC_DELAY
  • numLinks : _NVVIOSTREAM
  • numOfApps : _NVDRS_PROFILE_V1
  • numOfSettings : _NVDRS_PROFILE_V1
  • numPixels : _NV_GSYNC_DELAY
  • numPstates : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • numRawCaptureImages : _NVVIOINPUTCONFIG
  • numSettingValues : _SettingWSTRINGNameString , _SettingDWORDNameString , _NVDRS_SETTING_VALUES
  • numStreams : _NVVIOINPUTCONFIG
  • numVertices : NV_SCANOUT_WARPING_DATA
  • numVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V2
  • nvPsfId : NV_TIMING_FLAG
  • nvs : _NVDRS_GPU_SUPPORT
  • nvvioConfigType : _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3 , _NVVIOCONFIG_V1
  • nvvioStatusType : _NVVIOSTATUS


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • offset : NV_EDID_V3
  • offsetTexChannels : NV_SCANOUT_INTENSITY_DATA_V2
  • offsetTexture : NV_SCANOUT_INTENSITY_DATA_V2
  • opcode : NvShaderExtnStruct
  • outConfig : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • outputArea : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • outputId : NVVIOTOPOLOGYTARGET
  • outputRegion : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • outputVideoLocked : _NVVIOOUTPUTSTATUS
  • outStatus : _NVVIOSTATUS
  • ov : _NV_GPU_PERF_PSTATES20_INFO_V2
  • overlapX : NV_MOSAIC_TOPOLOGY , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , NV_MOSAIC_TOPO_DETAILS , _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
  • overlapY : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 , NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • ownerId : _NVVIOCAPS
  • ownerType : _NVVIOCAPS


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • padding0 : NvShaderExtnStruct
  • padding1 : NvShaderExtnStruct
  • path : NV_DISPLAY_PATH_INFO , NV_DISPLAY_PATH_INFO_V3
  • pbData : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • pbI2cRegAddress : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • pciBus : _NVVIOPCIINFO
  • pciDeviceId : _NVVIOPCIINFO
  • pciDomain : _NVVIOPCIINFO
  • pciLinkRate : _NVVIOPCIINFO
  • pciLinkWidth : _NVVIOPCIINFO
  • pciRevisionId : _NVVIOPCIINFO
  • pciSlot : _NVVIOPCIINFO
  • pciSubSystemId : _NVVIOPCIINFO
  • pclk : _NV_TIMING
  • pCoordinateSwizzling : NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 , NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
  • percentage : NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • picAspectRatio : NV_INFOFRAME_VIDEO
  • pixelRepeat : NV_INFOFRAME_VIDEO
  • pixelShift : _NV_MOSAIC_GRID_TOPO_V2
  • pixelShiftType : _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • polarity : _NV_GSYNC_CONTROL_PARAMS
  • portId : NV_I2C_INFO_V3
  • pOSAdapterID : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • position : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • PostZCoverageEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • posx : NV_DISPLAY_PATH
  • posy : NV_DISPLAY_PATH
  • previousFrameAFRIndex : NV_GET_CURRENT_SLI_STATE
  • primary : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • profileName : _NVDRS_PROFILE_V1
  • ProgrammableSamplePositionsEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • property : NV_INFOFRAME_DATA
  • psfSignalFormat : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1
  • psoExtension : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • pstateId : NV_GPU_PERF_PSTATES_INFO_V2 , _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES20_INFO_V1
  • pstates : NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • QuadFillMode : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • quadro : _NVDRS_GPU_SUPPORT
  • quantizationRangeRgb : _NV_MONITOR_CAPS_VCDB
  • quantizationRangeYcc : _NV_MONITOR_CAPS_VCDB


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • range : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • refreshRate : NV_DISPLAY_PATH , _NV_GSYNC_STATUS_PARAMS
  • refreshRate1K : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • regAddrSize : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • rep : tagNV_TIMINGEXT
  • reserved : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 , _NVAPI_STEREO_CAPS , _NVDRS_APPLICATION_V3 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2 , _NV_DISPLAY_PORT_INFO_V1 , _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2 , _NV_DISPLAYCONFIG_PATH_INFO_V2 , NV_INFOFRAME_PROPERTY , _NV_MOSAIC_GRID_TOPO_V1 , _NV_GPU_DISPLAYIDS , _NV_MOSAIC_GRID_TOPO_V2 , NV_MOSAIC_DISPLAY_TOPO_STATUS , NV_GPU_CLOCK_FREQUENCIES_V1 , _NV_GSYNC_GPU , _NV_GSYNC_DISPLAY , NV_GPU_CLOCK_FREQUENCIES_V2 , _NV_GSYNC_CONTROL_PARAMS , NvAPI_D3D11_RASTERIZER_DESC_EX , NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NV_MULTIGPU_CAPS
  • reserved0 : NV_TIMING_FLAG
  • reserved1 : NV_GPU_CLOCK_FREQUENCIES_V2
  • reserved10 : _NVDRS_GPU_SUPPORT
  • reserved11 : _NVDRS_GPU_SUPPORT
  • reserved12 : _NVDRS_GPU_SUPPORT
  • reserved13 : _NV_MONITOR_CAPS_VSDB , _NVDRS_GPU_SUPPORT
  • reserved14 : _NVDRS_GPU_SUPPORT
  • reserved15 : _NVDRS_GPU_SUPPORT
  • reserved16 : _NVDRS_GPU_SUPPORT
  • reserved17 : _NVDRS_GPU_SUPPORT
  • reserved18 : _NVDRS_GPU_SUPPORT
  • reserved19 : _NVDRS_GPU_SUPPORT
  • reserved2 : _NVAPI_STEREO_CAPS
  • reserved20 : _NVDRS_GPU_SUPPORT
  • reserved21 : _NVDRS_GPU_SUPPORT
  • reserved22 : _NVDRS_GPU_SUPPORT
  • reserved23 : _NVDRS_GPU_SUPPORT
  • reserved24 : _NVDRS_GPU_SUPPORT
  • reserved25 : _NVDRS_GPU_SUPPORT
  • reserved26 : _NVDRS_GPU_SUPPORT
  • reserved27 : _NVDRS_GPU_SUPPORT
  • reserved28 : _NVDRS_GPU_SUPPORT
  • reserved29 : _NVDRS_GPU_SUPPORT
  • reserved30 : _NVDRS_GPU_SUPPORT
  • reserved31 : _NVDRS_GPU_SUPPORT
  • reserved32 : _NVDRS_GPU_SUPPORT
  • reserved4 : _NVDRS_GPU_SUPPORT
  • reserved5 : _NVDRS_GPU_SUPPORT
  • reserved6 : _NVDRS_GPU_SUPPORT , _NV_MONITOR_CAPS_VSDB
  • reserved7 : _NVDRS_GPU_SUPPORT
  • reserved8 : _NV_MONITOR_CAPS_VSDB , _NVDRS_GPU_SUPPORT
  • reserved9 : _NVDRS_GPU_SUPPORT
  • reserved_sourceId : _NV_DISPLAYCONFIG_PATH_INFO_V1 , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • reservedBit1 : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • reservedData : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • reservedInternal : _NV_GPU_DISPLAYIDS
  • resolution : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • revision : _NV_GSYNC_CAPABILITIES_V1
  • rgbQuantizationRange : NV_INFOFRAME_VIDEO
  • rid : NvShaderExtnStruct
  • right : _NV_RECT
  • right_bar : NV_INFOFRAME_VIDEO
  • RJ45_Ethernet : _NV_GSYNC_STATUS_PARAMS
  • RJ45_IO : _NV_GSYNC_STATUS_PARAMS
  • rotation : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , NV_DISPLAY_PATH , _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
  • rowCount : NV_MOSAIC_TOPOLOGY , NV_MOSAIC_TOPO_DETAILS
  • rows : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • rr : _NV_TIMING_INPUT , tagNV_TIMINGEXT
  • rrx1k : tagNV_TIMINGEXT , NV_MOSAIC_DISPLAY_SETTING_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • SampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • SamplePositionsX : NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NvAPI_D3D11_RASTERIZER_DESC_EX
  • SamplePositionsY : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • sampleRate : NV_INFOFRAME_AUDIO
  • sampleSize : NV_INFOFRAME_AUDIO
  • sampling : _NVVIOSTREAM
  • samplingFormat : _NVVIOCHANNELSTATUS
  • scaling : NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , NV_TIMING_FLAG
  • scanInfo : NV_INFOFRAME_VIDEO
  • scanInfoCEVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoITVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoPreferredVideoFormat : _NV_MONITOR_CAPS_VCDB
  • ScissorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • sdiSyncIn : _NVVIOOUTPUTSTATUS
  • sensor : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • settingId : _NVDRS_SETTING_V1 , _SettingDWORDNameString , _SettingWSTRINGNameString
  • settingLocation : _NVDRS_SETTING_V1
  • settingName : _NVDRS_SETTING_V1
  • settingNameString : _SettingDWORDNameString , _SettingWSTRINGNameString
  • settingType : _NVDRS_SETTING_VALUES , _NVDRS_SETTING_V1
  • settingValues : _SettingDWORDNameString , _SettingWSTRINGNameString , _NVDRS_SETTING_VALUES
  • sharedSystemMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • sHeight : NvSBox
  • sid : NvShaderExtnStruct
  • signalFormat : _NVVIOCHANNELSTATUS , _NVVIOSIGNALFORMATDETAIL , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3 , _NVVIOINPUTCONFIG
  • single : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • singleBitErrors : NV_GPU_ECC_ERROR_INFO
  • size : NV_INFOFRAME_DATA , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3 , _NV_MONITOR_CAPABILITIES_V1
  • sizeofEDID : NV_EDID_V2 , NV_EDID_V3
  • SlopeScaledDepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • smpte352 : _NVVIOCHANNELSTATUS
  • source : _NV_GSYNC_CONTROL_PARAMS
  • sourceDesktopRect : _NV_SCANOUT_INFORMATION
  • sourceId : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • sourceModeInfo : _NV_DISPLAYCONFIG_PATH_INFO_V1 , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • sourcePhysicalAddressA : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressB : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressC : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressD : _NV_MONITOR_CAPS_VSDB
  • sourceToTargetRotation : _NV_SCANOUT_INFORMATION
  • sourceViewportRect : _NV_SCANOUT_INFORMATION
  • spanningOrientation : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • speakerPlacement : NV_INFOFRAME_AUDIO
  • src0u : NvShaderExtnStruct
  • src1u : NvShaderExtnStruct
  • src2u : NvShaderExtnStruct
  • srcPartition : NV_CUSTOM_DISPLAY
  • startupDelay : _NV_GSYNC_CONTROL_PARAMS
  • status : tagNV_TIMINGEXT
  • streams : _NVVIOINPUTCONFIG
  • subSysDeviceId : NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v4
  • subSysVendorId : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3
  • supportAI : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor30bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor36bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor48bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColorYCbCr444 : _NV_MONITOR_CAPS_VSDB
  • supportDualDviOperation : _NV_MONITOR_CAPS_VSDB
  • supportsRotation : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • supportsWindowedModeAutomatic : _NVAPI_STEREO_CAPS
  • supportsWindowedModeOff : _NVAPI_STEREO_CAPS
  • supportsWindowedModePersistent : _NVAPI_STEREO_CAPS
  • sViewOffset : _NV_DX_VIDEO_STEREO_INFO
  • sWidth : NvSBox
  • sX : NvSBox
  • sY : NvSBox
  • syncDelay : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • syncEnable : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTSTATUS
  • syncFormat : _NVVIOOUTPUTSTATUS
  • syncSkew : _NV_GSYNC_CONTROL_PARAMS
  • syncSource : _NVVIOOUTPUTSTATUS , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • syncState : _NV_GSYNC_DISPLAY
  • systemVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • szAdapterString : NV_DISPLAY_DRIVER_VERSION
  • szBuildBranchString : NV_DISPLAY_DRIVER_VERSION
  • szChipsetName : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v1
  • szSubSysVendorName : NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v4
  • szVendorName : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v1 , NV_CHIPSET_INFO_v2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • target : NV_VIEW_TARGET_INFO , NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • targetDisplayHeight : _NV_SCANOUT_INFORMATION
  • targetDisplayWidth : _NV_SCANOUT_INFORMATION
  • targetId : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • targetInfo : _NV_DISPLAYCONFIG_PATH_INFO_V2 , _NV_DISPLAYCONFIG_PATH_INFO_V1
  • targetInfoCount : _NV_DISPLAYCONFIG_PATH_INFO_V1 , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • targetViewportRect : _NV_SCANOUT_INFORMATION
  • testColorChange : NV_DISPLAY_PORT_CONFIG
  • testLinkTrain : NV_DISPLAY_PORT_CONFIG
  • textureRect : NV_SCANOUT_WARPING_DATA
  • timing : NV_CUSTOM_DISPLAY , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • timingOverride : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • top : _NV_RECT
  • top_bar : NV_INFOFRAME_VIDEO
  • topo : NV_MOSAIC_TOPO_BRIEF
  • topoBriefs : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topoBriefsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topos : NV_MOSAIC_SUPPORTED_TOPOLOGIES , NV_MOSAIC_TOPO_GROUP
  • totalCount : NV_MOSAIC_SUPPORTED_TOPOLOGIES
  • tvFormat : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , NV_DISPLAY_PATH , NV_TIMING_FLAG
  • type : _NV_TIMING_INPUT , NV_INFOFRAME_DATA
  • typeId : NV_GPU_PSTATE20_CLOCK_ENTRY_V1


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • u32CurrentValue : _NVDRS_SETTING_V1
  • u32DefaultValue : _NVDRS_SETTING_VALUES
  • u32PredefinedValue : _NVDRS_SETTING_V1
  • u32Value : _NVDRS_SETTING_VALUES
  • uBlue : _NVVIOGAMMARAMP8 , _NVVIOGAMMARAMP10
  • uEnabled : _NVVIOCOMPOSITERANGE
  • uGreen : _NVVIOGAMMARAMP8 , _NVVIOGAMMARAMP10
  • uMax : _NVVIOCOMPOSITERANGE
  • uMin : _NVVIOCOMPOSITERANGE
  • uPowerOn : _NVVIOOUTPUTSTATUS
  • uRange : _NVVIOCOMPOSITERANGE
  • uRed : _NVVIOGAMMARAMP10 , _NVVIOGAMMARAMP8
  • userFriendlyName : _NVDRS_APPLICATION_V1 , _NVDRS_APPLICATION_V3 , _NVDRS_APPLICATION_V2
  • uSyncSourceLocked : _NVVIOOUTPUTSTATUS
  • utilization : NV_GPU_DYNAMIC_PSTATES_INFO_EX


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • validityMask : NV_MOSAIC_TOPO_DETAILS
  • Value : _NV_GPU_GET_ILLUMINATION_PARM_V1
  • value : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • Value : _NV_GPU_SET_ILLUMINATION_PARM_V1
  • valueData : _NVDRS_BINARY_SETTING
  • valueLength : _NVDRS_BINARY_SETTING
  • valueRange : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • VBorder : _NV_TIMING
  • vcdb : _NV_MONITOR_CAPABILITIES_V1
  • vendorId : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v1
  • version : NV_EDID_V3 , NV_GPU_DYNAMIC_PSTATES_INFO_EX , NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPO_BRIEF , NV_GPU_THERMAL_SETTINGS_V1 , _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2 , NV_VIEW_TARGET_INFO , NV_GPU_THERMAL_SETTINGS_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 , NV_I2C_INFO_V1 , NV_MOSAIC_TOPO_GROUP , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , NV_DISPLAY_PATH_INFO_V3 , NV_I2C_INFO_V2 , _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2 , NV_I2C_INFO_V3 , NV_MOSAIC_DISPLAY_TOPO_STATUS , NV_MOSAIC_TOPOLOGY , NV_DISPLAY_PATH_INFO , NV_GET_CURRENT_SLI_STATE , NV_DISPLAY_DRIVER_MEMORY_INFO_V3 , NV_GPU_GET_HDCP_SUPPORT_STATUS , NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_LID_DOCK_PARAMS , NV_CHIPSET_INFO_v1 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v4 , _NVDRS_PROFILE_V1 , NV_MOSAIC_SUPPORTED_TOPOLOGIES , _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V1 , _NVDRS_SETTING_V1 , _NVDRS_SETTING_VALUES , _NVAPI_STEREO_CAPS , _NVVIOPCIINFO , _NV_GSYNC_CAPABILITIES_V1 , NV_GPU_ECC_STATUS_INFO , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V1 , _NVVIOGAMMACORRECTION , _NVVIOCOLORCONVERSION , _NVVIOSYNCDELAY , _NVVIOSTATUS , _NVVIOCAPS , _NV_GSYNC_GPU , NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 , NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 , _NV_GSYNC_STATUS_PARAMS , _NV_GSYNC_STATUS , _NV_GSYNC_DISPLAY , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , NV_GPU_ECC_ERROR_INFO , _NV_GSYNC_DELAY , _NV_GSYNC_CONTROL_PARAMS , NV_GPU_ECC_CONFIGURATION_INFO , _NV_DISPLAYCONFIG_PATH_INFO_V1 , NV_SCANOUT_INTENSITY_DATA_V1 , NV_SCANOUT_INTENSITY_DATA_V2 , _NV_DISPLAYCONFIG_PATH_INFO_V2 , _NV_SCANOUT_INTENSITY_STATE_DATA , NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 , NV_SCANOUT_WARPING_DATA , NV_DISPLAY_DRIVER_VERSION , _NV_SCANOUT_WARPING_STATE_DATA , _NV_SCANOUT_INFORMATION , _NV_GPU_DISPLAYIDS , _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 , NV_CUSTOM_DISPLAY , _NV_MONITOR_COLOR_DATA , _NV_MONITOR_CAPABILITIES_V1 , _NV_TIMING_INPUT , _NV_COLOR_DATA_V3 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_INFOFRAME_PROPERTY , _NV_HDMI_SUPPORT_INFO_V2 , _NV_HDMI_SUPPORT_INFO_V1 , _NVDRS_APPLICATION_V3 , _NV_DISPLAY_PORT_INFO_V1 , _NV_GPU_SET_ILLUMINATION_PARM_V1 , _NVVIOCONFIG_V3 , _NV_VIO_TOPOLOGY , _NV_GPU_GET_ILLUMINATION_PARM_V1 , _NV_BOARD_INFO , NV_GPU_CLOCK_FREQUENCIES_V1 , NV_DISPLAY_PORT_CONFIG , NV_GPU_CLOCK_FREQUENCIES_V2 , NV_EDID_V1 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_INFOFRAME_DATA , NV_GPU_PERF_PSTATES_INFO_V2 , NV_EDID_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • vertexFormat : NV_SCANOUT_WARPING_DATA
  • verticalDelay : _NVVIOSYNCDELAY
  • verticalLines : _NVVIOVIDEOMODE
  • vertices : NV_SCANOUT_WARPING_DATA
  • VFrontPorch : _NV_TIMING
  • vic : NV_INFOFRAME_VIDEO
  • vid1Out : _NVVIOOUTPUTSTATUS
  • vid2Out : _NVVIOOUTPUTSTATUS
  • video : NV_INFOFRAME_DATA
  • videoBridgePresent : NV_MULTIGPU_CAPS
  • videoLatency : _NV_MONITOR_CAPS_VSDB
  • videoMode : _NVVIOSIGNALFORMATDETAIL
  • videoStandard : _NVVIOVIDEOMODE
  • videoType : _NVVIOVIDEOMODE
  • vidIn : _NVVIOINPUTSTATUS
  • vioCaps : _NVVIODATAFORMATDETAIL
  • vioConfig : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • vioGammaCorrectionType : _NVVIOGAMMACORRECTION
  • vioId : NVVIOTOPOLOGYTARGET
  • vioStatus : _NVVIOSTATUS
  • vioTarget : _NV_VIO_TOPOLOGY
  • vioTotalDeviceCount : _NV_VIO_TOPOLOGY
  • vmode : _NV_GSYNC_CONTROL_PARAMS
  • volt_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • voltages : _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V2
  • voltDelta_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • vsdb : _NV_MONITOR_CAPABILITIES_V1
  • VSyncPol : _NV_TIMING
  • VSyncWidth : _NV_TIMING
  • VTotal : _NV_TIMING
  • VVisible : _NV_TIMING


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • w : NV_VIEWPORTF
  • warningFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • width : _NV_RESOLUTION , NV_CUSTOM_DISPLAY , _NV_MOSAIC_DISPLAY_SETTING_V1 , _NVVIOOUTPUTREGION , NV_SCANOUT_INTENSITY_DATA_V1 , NV_MOSAIC_DISPLAY_SETTING_V2 , NV_DISPLAY_PATH , _NV_TIMING_INPUT , NV_SCANOUT_INTENSITY_DATA_V2
  • wszCurrentValue : _NVDRS_SETTING_V1
  • wszDefaultValue : _NVDRS_SETTING_VALUES
  • wszPredefinedValue : _NVDRS_SETTING_V1
  • wszValue : _NVDRS_SETTING_VALUES


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- x -

  • x : NV_VIEWPORTF , _NV_POSITION , _NVVIOOUTPUTREGION
  • xRatio : NV_CUSTOM_DISPLAY


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • y : NV_VIEWPORTF , _NV_POSITION , _NVVIOOUTPUTREGION
  • yccQuantizationRange : NV_INFOFRAME_VIDEO
  • yRatio : NV_CUSTOM_DISPLAY


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • acceleratePrimaryDisplay : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • activeFormatAspectRatio : NV_INFOFRAME_VIDEO
  • activeFormatInfoPresent : NV_INFOFRAME_VIDEO
  • adapterCaps : _NVVIOCAPS
  • adapterClass : _NVVIOCAPS
  • adapterName : _NVVIOCAPS
  • aggregate : NV_GPU_ECC_ERROR_INFO
  • ancParityComputation : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • AntialiasedLineEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • applyWithBezelCorrect : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • appName : _NVDRS_APPLICATION_V3 , _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V1
  • aspect : tagNV_TIMINGEXT
  • Attribute : _NV_GPU_SET_ILLUMINATION_PARM_V1 , _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 , _NV_GPU_GET_ILLUMINATION_PARM_V1
  • audio : NV_INFOFRAME_DATA
  • audioLatency : _NV_MONITOR_CAPS_VSDB
  • availableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • backendBitDepths : _NV_MONITOR_COLOR_DATA
  • barInfo : NV_INFOFRAME_VIDEO
  • baseMosaic : _NV_MOSAIC_GRID_TOPO_V2 , _NV_MOSAIC_GRID_TOPO_V1
  • baseVersion : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • baseVoltages : NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • bEnabled : _NV_SCANOUT_INTENSITY_STATE_DATA , _NV_SCANOUT_WARPING_STATE_DATA
  • bFocusDisplay : NV_DISPLAY_PATH
  • bForceModeSet : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH
  • bGDIPrimary : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • bHouseSync : _NV_GSYNC_STATUS_PARAMS
  • binaryCurrentValue : _NVDRS_SETTING_V1
  • binaryDefaultValue : _NVDRS_SETTING_VALUES
  • binaryPredefinedValue : _NVDRS_SETTING_V1
  • binaryValue : _NVDRS_SETTING_VALUES
  • bInterlaced : NV_VIEW_TARGET_INFO
  • bIsCurAFRGroupNew : NV_GET_CURRENT_SLI_STATE
  • bIsDDCPort : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • bIsEditable : NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • bIsPortIdSet : NV_I2C_INFO_V3
  • bIsPresent : NV_GPU_CLOCK_FREQUENCIES_V2 , NV_GPU_DYNAMIC_PSTATES_INFO_EX , NV_GPU_CLOCK_FREQUENCIES_V1
  • bIsStereoSynced : _NV_GSYNC_STATUS
  • bIsSynced : _NV_GSYNC_STATUS
  • bIsSyncSignalAvailable : _NV_GSYNC_STATUS
  • bIsValidInfo : _NV_MONITOR_CAPABILITIES_V1
  • bitsPerComponent : _NVVIOCHANNELSTATUS , _NVVIOSTREAM
  • blackList : NV_INFOFRAME_PROPERTY
  • bldChangeListNum : NV_DISPLAY_DRIVER_VERSION
  • blendingTexture : NV_SCANOUT_INTENSITY_DATA_V1 , NV_SCANOUT_INTENSITY_DATA_V2
  • boardId : _NV_GSYNC_CAPABILITIES_V1
  • boardID : _NVVIOCAPS
  • BoardNum : _NV_BOARD_INFO
  • bottom : _NV_RECT
  • bottom_bar : NV_INFOFRAME_VIDEO
  • bpc : NV_DISPLAY_PORT_CONFIG , _NV_COLOR_DATA_V3 , _NV_DISPLAY_PORT_INFO_V1
  • bpp : _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2
  • bPrimary : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH
  • brief : NV_MOSAIC_TOPO_GROUP
  • bSLIFocus : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • bStereoEnable : _NV_DX_VIDEO_STEREO_INFO
  • bSupported : _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
  • bTestMode : _NVVIOINPUTCONFIG


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • capFlags : _NV_GSYNC_CAPABILITIES_V1
  • captureStatus : _NVVIOINPUTSTATUS
  • cbSize : NV_I2C_INFO_V2 , NV_I2C_INFO_V3 , NV_I2C_INFO_V1
  • ceaId : NV_TIMING_FLAG
  • channel : _NVVIOSTREAM
  • channelCount : NV_INFOFRAME_AUDIO
  • clocks : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • ClockType : NV_GPU_CLOCK_FREQUENCIES_V2
  • cloneGroup : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • cloneImportance : _NV_SCANOUT_INFORMATION
  • cmd : NV_INFOFRAME_DATA , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3
  • cnc0SupportGraphicsTextContent : _NV_MONITOR_CAPS_VSDB
  • cnc1SupportPhotoContent : _NV_MONITOR_CAPS_VSDB
  • cnc2SupportCinemaContent : _NV_MONITOR_CAPS_VSDB
  • cnc3SupportGameContent : _NV_MONITOR_CAPS_VSDB
  • codingExtensionType : NV_INFOFRAME_AUDIO
  • codingType : NV_INFOFRAME_AUDIO
  • colCount : NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY
  • colorConversion : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • colorDepth : _NV_RESOLUTION
  • colorFormat : NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 , _NV_DISPLAY_PORT_INFO_V1 , NV_DISPLAY_PORT_CONFIG , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3 , _NV_MONITOR_COLOR_DATA , NV_CUSTOM_DISPLAY
  • colorimetry : _NV_DISPLAY_PORT_INFO_V1 , NV_DISPLAY_PORT_CONFIG , NV_INFOFRAME_VIDEO , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3
  • colorMatrix : _NVVIOCOLORCONVERSION
  • colorOffset : _NVVIOCOLORCONVERSION
  • colorScale : _NVVIOCOLORCONVERSION
  • colorSpace : NV_INFOFRAME_VIDEO , _NVVIOCHANNELSTATUS
  • columns : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • compositeSafe : _NVVIOCOLORCONVERSION
  • compositeSyncType : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • compositeTerminate : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • compRange : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1
  • compSyncIn : _NVVIOOUTPUTSTATUS
  • configurationOptions : NV_GPU_ECC_STATUS_INFO
  • connector : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , _NV_GSYNC_GPU , NV_DISPLAY_PATH
  • connectorType : _NV_GPU_DISPLAYIDS , _NV_MONITOR_CAPABILITIES_V1
  • ConservativeRasterEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • contentTypes : NV_INFOFRAME_VIDEO
  • controller : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • count : NV_VIEW_TARGET_INFO , NV_MOSAIC_TOPO_GROUP , NV_GPU_THERMAL_SETTINGS_V2 , NV_DISPLAY_PATH_INFO_V3 , NV_GPU_THERMAL_SETTINGS_V1 , NV_DISPLAY_PATH_INFO
  • CoverageToColorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • CoverageToColorRTIndex : NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NvAPI_D3D11_RASTERIZER_DESC_EX
  • cscOverride : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • CullMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • curAvailableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V3 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2
  • curLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • curLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • current : NV_GPU_ECC_ERROR_INFO
  • currentAFRIndex : NV_GET_CURRENT_SLI_STATE
  • currentDockPolicy : NV_LID_DOCK_PARAMS
  • currentDockState : NV_LID_DOCK_PARAMS
  • currentLidPolicy : NV_LID_DOCK_PARAMS
  • currentLidState : NV_LID_DOCK_PARAMS
  • currentTemp : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • data : NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V3 , _NV_MONITOR_CAPABILITIES_V1 , _NV_COLOR_DATA_V2
  • dataFormat : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3 , _NVVIODATAFORMATDETAIL , _NVVIOOUTPUTCONFIG_V1
  • dataIntegrityCheckEnabled : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckErrorCount : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckFailed : _NVVIOOUTPUTSTATUS
  • dedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • dedicatedVideoMemoryEvictionCount : NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • dedicatedVideoMemoryEvictionsSize : NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • defaultMaxTemp : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • defaultMinTemp : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • defaultValue : _SettingDWORDNameString , _SettingWSTRINGNameString
  • depth : NV_DISPLAY_PATH , NV_CUSTOM_DISPLAY
  • DepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthBiasClamp : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthClipEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • details : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 , _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • deviceId : NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v1 , NV_CHIPSET_INFO_v4
  • deviceMask : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH
  • dipSwitch : _NVVIOCAPS
  • dipSwitchReserved : _NVVIOCAPS
  • disableVirtualModeSupport : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • displayCount : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2 , NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displayId : _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 , _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 , _NV_GPU_DISPLAYIDS , _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 , NV_MOSAIC_DISPLAY_TOPO_STATUS , _NV_GSYNC_DISPLAY
  • displayMask : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • displayOutputId : NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY
  • displays : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2 , NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displaySettings : _NV_MOSAIC_GRID_TOPO_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_GRID_TOPO_V1
  • displaySettingsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
  • domain : NV_GPU_CLOCK_FREQUENCIES_V1 , NV_GPU_CLOCK_FREQUENCIES_V2
  • domainId : NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 , NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V1
  • doubleBitErrors : NV_GPU_ECC_ERROR_INFO
  • downmixInhibit : NV_INFOFRAME_AUDIO
  • dpcd_ver : _NV_DISPLAY_PORT_INFO_V1
  • driver : _NVVIOCAPS
  • driverReloadAllowed : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • drvVersion : NV_DISPLAY_DRIVER_VERSION
  • dst0u : NvShaderExtnStruct
  • dst1u : NvShaderExtnStruct
  • dwVersion : _NV_DX_VIDEO_STEREO_INFO
  • dynamicRange : NV_DISPLAY_PORT_CONFIG , _NV_COLOR_DATA_V2 , _NV_DISPLAY_PORT_INFO_V1 , _NV_COLOR_DATA_V3


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • EDID861ExtRev : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • EDID_Data : NV_EDID_V2 , NV_EDID_V3 , NV_EDID_V1
  • edidId : NV_EDID_V3
  • eFormat : _NV_DX_VIDEO_STEREO_INFO
  • enable422Filter : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • enableAlphaKeyComposite : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • enableANCTimeCodeGeneration : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • enableAudioBlanking : _NVVIOOUTPUTCONFIG_V3
  • enableComposite : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • enabled : NV_MOSAIC_TOPO_BRIEF
  • enableDataIntegrityCheck : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V3
  • EnableDBT : NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
  • enableFullColorRange : _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V3
  • enableRGBData : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1
  • errorFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • etc : _NV_TIMING
  • expansionEnable : _NVVIOSTREAM
  • extendedColorimetry : NV_INFOFRAME_VIDEO


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • fFrameRate : _NVVIOVIDEOMODE
  • fGammaValueB : _NVVIOGAMMACORRECTION
  • fGammaValueG : _NVVIOGAMMACORRECTION
  • fGammaValueR : _NVVIOGAMMACORRECTION
  • fields : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • fileInFolder : _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V3
  • FillMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • firmWare : _NVVIOCAPS
  • flag : tagNV_TIMINGEXT , _NV_TIMING_INPUT
  • flags : NV_GPU_DYNAMIC_PSTATES_INFO_EX , NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 , NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 , NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2
  • flipQueueLength : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • forcedDockMechanismPresent : NV_LID_DOCK_PARAMS
  • forcedLidMechanismPresent : NV_LID_DOCK_PARAMS
  • ForcedSampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX
  • frameLockEnable : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTSTATUS , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • freq : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2
  • freq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • freqDelta_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • frequency : NV_GPU_CLOCK_FREQUENCIES_V1 , NV_GPU_CLOCK_FREQUENCIES_V2
  • FrontCounterClockwise : NvAPI_D3D11_RASTERIZER_DESC_EX
  • Future10 : NV_INFOFRAME_AUDIO
  • Future12 : NV_INFOFRAME_AUDIO
  • Future17 : NV_INFOFRAME_VIDEO
  • Future2x : NV_INFOFRAME_AUDIO
  • Future3x : NV_INFOFRAME_AUDIO
  • Future47 : NV_INFOFRAME_VIDEO
  • Future52 : NV_INFOFRAME_AUDIO
  • Future6 : NV_INFOFRAME_AUDIO
  • Future7 : NV_INFOFRAME_AUDIO
  • Future8 : NV_INFOFRAME_AUDIO
  • Future9 : NV_INFOFRAME_AUDIO


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • gammaCorrection : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • gammaRamp : _NVVIOGAMMACORRECTION
  • gammaRamp10 : _NVVIOGAMMACORRECTION
  • gammaRamp8 : _NVVIOGAMMACORRECTION
  • geforce : _NVDRS_GPU_SUPPORT
  • gpuId : NV_DISPLAY_PATH
  • gpuLayout : NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY
  • gpuSupport : _NVDRS_PROFILE_V1


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • h : NV_VIEWPORTF
  • has3dEntries : _NV_MONITOR_CAPS_VSDB
  • hasInterlacedLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasVicEntries : _NV_MONITOR_CAPS_VSDB
  • HBdeviceId : NV_CHIPSET_INFO_v4
  • HBorder : _NV_TIMING
  • HBsubSysDeviceId : NV_CHIPSET_INFO_v4
  • HBsubSysVendorId : NV_CHIPSET_INFO_v4
  • HBvendorId : NV_CHIPSET_INFO_v4
  • hdcpFuseState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySource : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySourceState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdmi3dLength : _NV_MONITOR_CAPS_VSDB
  • hdmi_3d : _NV_MONITOR_CAPS_VSDB
  • hdmi_vic : _NV_MONITOR_CAPS_VSDB
  • hdmiVicLength : _NV_MONITOR_CAPS_VSDB
  • height : NV_DISPLAY_PATH , _NV_RESOLUTION , NV_SCANOUT_INTENSITY_DATA_V1 , NV_SCANOUT_INTENSITY_DATA_V2 , _NV_TIMING_INPUT , NV_CUSTOM_DISPLAY , _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2 , _NVVIOOUTPUTREGION
  • HFrontPorch : _NV_TIMING
  • hLinkedSurface : _NV_DX_VIDEO_STEREO_INFO
  • hLogicalGPU : NV_MOSAIC_TOPO_DETAILS
  • horizontalDelay : _NVVIOSYNCDELAY
  • horizontalPixels : _NVVIOVIDEOMODE
  • houseSyncIncoming : _NV_GSYNC_STATUS_PARAMS
  • hPhysicalGpu : _NV_GSYNC_GPU
  • hPhysicalGPU : NV_MOSAIC_TOPOLOGY
  • hPhysicalGpu : _NV_GPU_GET_ILLUMINATION_PARM_V1 , NVVIOTOPOLOGYTARGET , _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
  • hPhysicalGPU : NV_MOSAIC_TOPO_DETAILS
  • hPhysicalGpu : _NV_GPU_SET_ILLUMINATION_PARM_V1
  • hProxyPhysicalGpu : _NV_GSYNC_GPU
  • hSurface : _NV_DX_VIDEO_STEREO_INFO
  • HSyncPol : _NV_TIMING
  • HSyncWidth : _NV_TIMING
  • HTotal : _NV_TIMING
  • hVioHandle : NVVIOTOPOLOGYTARGET
  • HVisible : _NV_TIMING
  • hwModeSetOnly : NV_CUSTOM_DISPLAY


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • i2cDevAddress : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • i2cSpeed : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • i2cSpeedKhz : NV_I2C_INFO_V3 , NV_I2C_INFO_V2
  • immersiveGaming : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • inConfig : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • infoframe : NV_INFOFRAME_DATA
  • infoType : _NV_MONITOR_CAPABILITIES_V1
  • inStatus : _NVVIOSTATUS
  • interlaced : _NV_TIMING , NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • interlacedAudioLatency : _NV_MONITOR_CAPS_VSDB
  • interlacedVideoLatency : _NV_MONITOR_CAPS_VSDB
  • interlaceMode : _NV_GSYNC_CONTROL_PARAMS , _NVVIOVIDEOMODE
  • InterleavedSamplingEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • interval : _NV_GSYNC_CONTROL_PARAMS
  • is10BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is10BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isActive : _NV_GPU_DISPLAYIDS
  • isChromaLpfOff : NV_DISPLAY_PORT_CONFIG
  • isCluster : _NV_GPU_DISPLAYIDS
  • isColorCtrlSupported : _NV_DISPLAY_PORT_INFO_V1
  • isCommandLine : _NVDRS_APPLICATION_V3
  • isConnected : _NV_GPU_DISPLAYIDS
  • isCurrentPredefined : _NVDRS_SETTING_V1
  • isDitherOff : NV_DISPLAY_PORT_CONFIG
  • isDp : _NV_DISPLAY_PORT_INFO_V1
  • isDynamic : _NV_GPU_DISPLAYIDS
  • isEnabled : NV_GPU_ECC_STATUS_INFO , NV_GPU_ECC_CONFIGURATION_INFO
  • isEnabledByDefault : NV_GPU_ECC_CONFIGURATION_INFO
  • isGpuHDMICapable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isHPD : NV_DISPLAY_PORT_CONFIG
  • isInterlaced : NV_TIMING_FLAG
  • isInternalDp : _NV_DISPLAY_PORT_INFO_V1
  • isMasterable : _NV_GSYNC_DISPLAY
  • isMetro : _NVDRS_APPLICATION_V3
  • isMonAdobeRGBCapable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonAdobeYCC601Capable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonBasicAudioCapable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonBT2020cYCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020RGBCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020YCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonHDMI : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonsYCC601Capable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonUnderscanCapable : _NV_HDMI_SUPPORT_INFO_V2 , _NV_HDMI_SUPPORT_INFO_V1
  • isMonxvYCC601Capable : _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2 , _NV_HDMI_SUPPORT_INFO_V1
  • isMonxvYCC709Capable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_DISPLAY_PORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr422Capable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr444Capable : _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2
  • isMultiStreamRootNode : _NV_GPU_DISPLAYIDS
  • IsNonNVIDIAAdapter : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • isOSVisible : _NV_GPU_DISPLAYIDS
  • isPhysicallyConnected : _NV_GPU_DISPLAYIDS
  • isPossible : NV_MOSAIC_TOPO_BRIEF
  • isPredefined : _NVDRS_PROFILE_V1 , _NVDRS_APPLICATION_V1 , _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V3
  • isPredefinedValid : _NVDRS_SETTING_V1
  • isPreferredUnscaledTarget : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • isRgb444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isSetDeferred : NV_DISPLAY_PORT_CONFIG
  • isSupported : NV_GPU_ECC_STATUS_INFO
  • isSynced : _NV_GSYNC_GPU
  • isWFD : _NV_GPU_DISPLAYIDS
  • isYCbCr422SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCbCr444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb422Supported : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb444Supported : _NV_DISPLAY_PORT_INFO_V1
  • itContent : NV_INFOFRAME_VIDEO


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- j -

  • jack : _NVVIOSTREAM


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • laneCount : NV_DISPLAY_PORT_CONFIG
  • launcher : _NVDRS_APPLICATION_V1 , _NVDRS_APPLICATION_V3 , _NVDRS_APPLICATION_V2
  • left : _NV_RECT
  • left_bar : NV_INFOFRAME_VIDEO
  • length : NV_INFOFRAME_PROPERTY
  • levelShift : NV_INFOFRAME_AUDIO
  • lfePlaybackLevel : NV_INFOFRAME_AUDIO
  • linkID : _NVVIOCHANNELSTATUS
  • linkRate : NV_DISPLAY_PORT_CONFIG
  • links : _NVVIOSTREAM


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • majorVersion : _NVVIOCAPS
  • markUavRef : NvShaderExtnStruct
  • max : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • maxFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • maxLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • maxLines : _NV_GSYNC_DELAY
  • maxLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • maxNumAFRGroups : NV_GET_CURRENT_SLI_STATE
  • maxTmdsClock : _NV_MONITOR_CAPS_VSDB
  • maxVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • min : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • minFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • minorVersion : _NVVIOCAPS
  • minPixels : _NV_GSYNC_DELAY
  • minVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • mode : NV_INFOFRAME_PROPERTY
  • multiGPUVersion : NV_MULTIGPU_CAPS
  • MultisampleEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • mvolt : NV_GPU_PERF_PSTATES_INFO_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • name : tagNV_TIMINGEXT
  • nextFrameAFRIndex : NV_GET_CURRENT_SLI_STATE
  • nonuniformScaling : NV_INFOFRAME_VIDEO
  • nSLIGPUs : NV_MULTIGPU_CAPS
  • nTotalGPUs : NV_MULTIGPU_CAPS
  • numAFRGroups : NV_GET_CURRENT_SLI_STATE
  • numBaseVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1
  • numClocks : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • numLines : _NV_GSYNC_DELAY
  • numLinks : _NVVIOSTREAM
  • numOfApps : _NVDRS_PROFILE_V1
  • numOfSettings : _NVDRS_PROFILE_V1
  • numPixels : _NV_GSYNC_DELAY
  • numPstates : NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • numRawCaptureImages : _NVVIOINPUTCONFIG
  • numSettingValues : _SettingWSTRINGNameString , _SettingDWORDNameString , _NVDRS_SETTING_VALUES
  • numStreams : _NVVIOINPUTCONFIG
  • numVertices : NV_SCANOUT_WARPING_DATA
  • numVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V2
  • nvPsfId : NV_TIMING_FLAG
  • nvs : _NVDRS_GPU_SUPPORT
  • nvvioConfigType : _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3 , _NVVIOCONFIG_V1
  • nvvioStatusType : _NVVIOSTATUS


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • offset : NV_EDID_V3
  • offsetTexChannels : NV_SCANOUT_INTENSITY_DATA_V2
  • offsetTexture : NV_SCANOUT_INTENSITY_DATA_V2
  • opcode : NvShaderExtnStruct
  • outConfig : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • outputArea : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • outputId : NVVIOTOPOLOGYTARGET
  • outputRegion : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • outputVideoLocked : _NVVIOOUTPUTSTATUS
  • outStatus : _NVVIOSTATUS
  • ov : _NV_GPU_PERF_PSTATES20_INFO_V2
  • overlapX : NV_MOSAIC_TOPOLOGY , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , NV_MOSAIC_TOPO_DETAILS , _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
  • overlapY : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 , NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPOLOGY , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • ownerId : _NVVIOCAPS
  • ownerType : _NVVIOCAPS


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • padding0 : NvShaderExtnStruct
  • padding1 : NvShaderExtnStruct
  • path : NV_DISPLAY_PATH_INFO , NV_DISPLAY_PATH_INFO_V3
  • pbData : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • pbI2cRegAddress : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • pciBus : _NVVIOPCIINFO
  • pciDeviceId : _NVVIOPCIINFO
  • pciDomain : _NVVIOPCIINFO
  • pciLinkRate : _NVVIOPCIINFO
  • pciLinkWidth : _NVVIOPCIINFO
  • pciRevisionId : _NVVIOPCIINFO
  • pciSlot : _NVVIOPCIINFO
  • pciSubSystemId : _NVVIOPCIINFO
  • pclk : _NV_TIMING
  • pCoordinateSwizzling : NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 , NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
  • percentage : NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • picAspectRatio : NV_INFOFRAME_VIDEO
  • pixelRepeat : NV_INFOFRAME_VIDEO
  • pixelShift : _NV_MOSAIC_GRID_TOPO_V2
  • pixelShiftType : _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • polarity : _NV_GSYNC_CONTROL_PARAMS
  • portId : NV_I2C_INFO_V3
  • pOSAdapterID : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • position : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • PostZCoverageEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • posx : NV_DISPLAY_PATH
  • posy : NV_DISPLAY_PATH
  • previousFrameAFRIndex : NV_GET_CURRENT_SLI_STATE
  • primary : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • profileName : _NVDRS_PROFILE_V1
  • ProgrammableSamplePositionsEnable : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • property : NV_INFOFRAME_DATA
  • psfSignalFormat : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V1
  • psoExtension : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • pstateId : NV_GPU_PERF_PSTATES_INFO_V2 , _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES20_INFO_V1
  • pstates : NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_GPU_PERF_PSTATES_INFO_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- q -

  • QuadFillMode : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • quadro : _NVDRS_GPU_SUPPORT
  • quantizationRangeRgb : _NV_MONITOR_CAPS_VCDB
  • quantizationRangeYcc : _NV_MONITOR_CAPS_VCDB


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • range : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • refreshRate : NV_DISPLAY_PATH , _NV_GSYNC_STATUS_PARAMS
  • refreshRate1K : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • regAddrSize : NV_I2C_INFO_V1 , NV_I2C_INFO_V2 , NV_I2C_INFO_V3
  • rep : tagNV_TIMINGEXT
  • reserved : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 , _NVAPI_STEREO_CAPS , _NVDRS_APPLICATION_V3 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2 , _NV_DISPLAY_PORT_INFO_V1 , _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V1 , _NV_HDMI_SUPPORT_INFO_V2 , _NV_DISPLAYCONFIG_PATH_INFO_V2 , NV_INFOFRAME_PROPERTY , _NV_MOSAIC_GRID_TOPO_V1 , _NV_GPU_DISPLAYIDS , _NV_MOSAIC_GRID_TOPO_V2 , NV_MOSAIC_DISPLAY_TOPO_STATUS , NV_GPU_CLOCK_FREQUENCIES_V1 , _NV_GSYNC_GPU , _NV_GSYNC_DISPLAY , NV_GPU_CLOCK_FREQUENCIES_V2 , _NV_GSYNC_CONTROL_PARAMS , NvAPI_D3D11_RASTERIZER_DESC_EX , NV_GPU_PSTATE20_CLOCK_ENTRY_V1 , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NV_MULTIGPU_CAPS
  • reserved0 : NV_TIMING_FLAG
  • reserved1 : NV_GPU_CLOCK_FREQUENCIES_V2
  • reserved10 : _NVDRS_GPU_SUPPORT
  • reserved11 : _NVDRS_GPU_SUPPORT
  • reserved12 : _NVDRS_GPU_SUPPORT
  • reserved13 : _NV_MONITOR_CAPS_VSDB , _NVDRS_GPU_SUPPORT
  • reserved14 : _NVDRS_GPU_SUPPORT
  • reserved15 : _NVDRS_GPU_SUPPORT
  • reserved16 : _NVDRS_GPU_SUPPORT
  • reserved17 : _NVDRS_GPU_SUPPORT
  • reserved18 : _NVDRS_GPU_SUPPORT
  • reserved19 : _NVDRS_GPU_SUPPORT
  • reserved2 : _NVAPI_STEREO_CAPS
  • reserved20 : _NVDRS_GPU_SUPPORT
  • reserved21 : _NVDRS_GPU_SUPPORT
  • reserved22 : _NVDRS_GPU_SUPPORT
  • reserved23 : _NVDRS_GPU_SUPPORT
  • reserved24 : _NVDRS_GPU_SUPPORT
  • reserved25 : _NVDRS_GPU_SUPPORT
  • reserved26 : _NVDRS_GPU_SUPPORT
  • reserved27 : _NVDRS_GPU_SUPPORT
  • reserved28 : _NVDRS_GPU_SUPPORT
  • reserved29 : _NVDRS_GPU_SUPPORT
  • reserved30 : _NVDRS_GPU_SUPPORT
  • reserved31 : _NVDRS_GPU_SUPPORT
  • reserved32 : _NVDRS_GPU_SUPPORT
  • reserved4 : _NVDRS_GPU_SUPPORT
  • reserved5 : _NVDRS_GPU_SUPPORT
  • reserved6 : _NVDRS_GPU_SUPPORT , _NV_MONITOR_CAPS_VSDB
  • reserved7 : _NVDRS_GPU_SUPPORT
  • reserved8 : _NV_MONITOR_CAPS_VSDB , _NVDRS_GPU_SUPPORT
  • reserved9 : _NVDRS_GPU_SUPPORT
  • reserved_sourceId : _NV_DISPLAYCONFIG_PATH_INFO_V1 , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • reservedBit1 : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • reservedData : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • reservedInternal : _NV_GPU_DISPLAYIDS
  • resolution : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • revision : _NV_GSYNC_CAPABILITIES_V1
  • rgbQuantizationRange : NV_INFOFRAME_VIDEO
  • rid : NvShaderExtnStruct
  • right : _NV_RECT
  • right_bar : NV_INFOFRAME_VIDEO
  • RJ45_Ethernet : _NV_GSYNC_STATUS_PARAMS
  • RJ45_IO : _NV_GSYNC_STATUS_PARAMS
  • rotation : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , NV_DISPLAY_PATH , _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
  • rowCount : NV_MOSAIC_TOPOLOGY , NV_MOSAIC_TOPO_DETAILS
  • rows : _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2
  • rr : _NV_TIMING_INPUT , tagNV_TIMINGEXT
  • rrx1k : tagNV_TIMINGEXT , NV_MOSAIC_DISPLAY_SETTING_V2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • SampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • SamplePositionsX : NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NvAPI_D3D11_RASTERIZER_DESC_EX
  • SamplePositionsY : NvAPI_D3D11_RASTERIZER_DESC_EX , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • sampleRate : NV_INFOFRAME_AUDIO
  • sampleSize : NV_INFOFRAME_AUDIO
  • sampling : _NVVIOSTREAM
  • samplingFormat : _NVVIOCHANNELSTATUS
  • scaling : NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , NV_TIMING_FLAG
  • scanInfo : NV_INFOFRAME_VIDEO
  • scanInfoCEVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoITVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoPreferredVideoFormat : _NV_MONITOR_CAPS_VCDB
  • ScissorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • sdiSyncIn : _NVVIOOUTPUTSTATUS
  • sensor : NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • settingId : _NVDRS_SETTING_V1 , _SettingDWORDNameString , _SettingWSTRINGNameString
  • settingLocation : _NVDRS_SETTING_V1
  • settingName : _NVDRS_SETTING_V1
  • settingNameString : _SettingDWORDNameString , _SettingWSTRINGNameString
  • settingType : _NVDRS_SETTING_VALUES , _NVDRS_SETTING_V1
  • settingValues : _SettingDWORDNameString , _SettingWSTRINGNameString , _NVDRS_SETTING_VALUES
  • sharedSystemMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • sHeight : NvSBox
  • sid : NvShaderExtnStruct
  • signalFormat : _NVVIOCHANNELSTATUS , _NVVIOSIGNALFORMATDETAIL , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3 , _NVVIOINPUTCONFIG
  • single : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • singleBitErrors : NV_GPU_ECC_ERROR_INFO
  • size : NV_INFOFRAME_DATA , _NV_COLOR_DATA_V1 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V3 , _NV_MONITOR_CAPABILITIES_V1
  • sizeofEDID : NV_EDID_V2 , NV_EDID_V3
  • SlopeScaledDepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • smpte352 : _NVVIOCHANNELSTATUS
  • source : _NV_GSYNC_CONTROL_PARAMS
  • sourceDesktopRect : _NV_SCANOUT_INFORMATION
  • sourceId : NV_VIEW_TARGET_INFO , NV_DISPLAY_PATH , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • sourceModeInfo : _NV_DISPLAYCONFIG_PATH_INFO_V1 , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • sourcePhysicalAddressA : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressB : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressC : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressD : _NV_MONITOR_CAPS_VSDB
  • sourceToTargetRotation : _NV_SCANOUT_INFORMATION
  • sourceViewportRect : _NV_SCANOUT_INFORMATION
  • spanningOrientation : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • speakerPlacement : NV_INFOFRAME_AUDIO
  • src0u : NvShaderExtnStruct
  • src1u : NvShaderExtnStruct
  • src2u : NvShaderExtnStruct
  • srcPartition : NV_CUSTOM_DISPLAY
  • startupDelay : _NV_GSYNC_CONTROL_PARAMS
  • status : tagNV_TIMINGEXT
  • streams : _NVVIOINPUTCONFIG
  • subSysDeviceId : NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v4
  • subSysVendorId : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3
  • supportAI : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor30bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor36bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor48bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColorYCbCr444 : _NV_MONITOR_CAPS_VSDB
  • supportDualDviOperation : _NV_MONITOR_CAPS_VSDB
  • supportsRotation : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • supportsWindowedModeAutomatic : _NVAPI_STEREO_CAPS
  • supportsWindowedModeOff : _NVAPI_STEREO_CAPS
  • supportsWindowedModePersistent : _NVAPI_STEREO_CAPS
  • sViewOffset : _NV_DX_VIDEO_STEREO_INFO
  • sWidth : NvSBox
  • sX : NvSBox
  • sY : NvSBox
  • syncDelay : _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2
  • syncEnable : _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3 , _NVVIOOUTPUTSTATUS
  • syncFormat : _NVVIOOUTPUTSTATUS
  • syncSkew : _NV_GSYNC_CONTROL_PARAMS
  • syncSource : _NVVIOOUTPUTSTATUS , _NVVIOOUTPUTCONFIG_V1 , _NVVIOOUTPUTCONFIG_V2 , _NVVIOOUTPUTCONFIG_V3
  • syncState : _NV_GSYNC_DISPLAY
  • systemVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_DISPLAY_DRIVER_MEMORY_INFO_V3
  • szAdapterString : NV_DISPLAY_DRIVER_VERSION
  • szBuildBranchString : NV_DISPLAY_DRIVER_VERSION
  • szChipsetName : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v1
  • szSubSysVendorName : NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v4
  • szVendorName : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v1 , NV_CHIPSET_INFO_v2


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • target : NV_VIEW_TARGET_INFO , NV_GPU_THERMAL_SETTINGS_V1 , NV_GPU_THERMAL_SETTINGS_V2
  • targetDisplayHeight : _NV_SCANOUT_INFORMATION
  • targetDisplayWidth : _NV_SCANOUT_INFORMATION
  • targetId : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • targetInfo : _NV_DISPLAYCONFIG_PATH_INFO_V2 , _NV_DISPLAYCONFIG_PATH_INFO_V1
  • targetInfoCount : _NV_DISPLAYCONFIG_PATH_INFO_V1 , _NV_DISPLAYCONFIG_PATH_INFO_V2
  • targetViewportRect : _NV_SCANOUT_INFORMATION
  • testColorChange : NV_DISPLAY_PORT_CONFIG
  • testLinkTrain : NV_DISPLAY_PORT_CONFIG
  • textureRect : NV_SCANOUT_WARPING_DATA
  • timing : NV_CUSTOM_DISPLAY , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • timingOverride : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • top : _NV_RECT
  • top_bar : NV_INFOFRAME_VIDEO
  • topo : NV_MOSAIC_TOPO_BRIEF
  • topoBriefs : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topoBriefsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topos : NV_MOSAIC_SUPPORTED_TOPOLOGIES , NV_MOSAIC_TOPO_GROUP
  • totalCount : NV_MOSAIC_SUPPORTED_TOPOLOGIES
  • tvFormat : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , NV_DISPLAY_PATH , NV_TIMING_FLAG
  • type : _NV_TIMING_INPUT , NV_INFOFRAME_DATA
  • typeId : NV_GPU_PSTATE20_CLOCK_ENTRY_V1


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • u32CurrentValue : _NVDRS_SETTING_V1
  • u32DefaultValue : _NVDRS_SETTING_VALUES
  • u32PredefinedValue : _NVDRS_SETTING_V1
  • u32Value : _NVDRS_SETTING_VALUES
  • uBlue : _NVVIOGAMMARAMP8 , _NVVIOGAMMARAMP10
  • uEnabled : _NVVIOCOMPOSITERANGE
  • uGreen : _NVVIOGAMMARAMP8 , _NVVIOGAMMARAMP10
  • uMax : _NVVIOCOMPOSITERANGE
  • uMin : _NVVIOCOMPOSITERANGE
  • uPowerOn : _NVVIOOUTPUTSTATUS
  • uRange : _NVVIOCOMPOSITERANGE
  • uRed : _NVVIOGAMMARAMP10 , _NVVIOGAMMARAMP8
  • userFriendlyName : _NVDRS_APPLICATION_V1 , _NVDRS_APPLICATION_V3 , _NVDRS_APPLICATION_V2
  • uSyncSourceLocked : _NVVIOOUTPUTSTATUS
  • utilization : NV_GPU_DYNAMIC_PSTATES_INFO_EX


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • validityMask : NV_MOSAIC_TOPO_DETAILS
  • Value : _NV_GPU_GET_ILLUMINATION_PARM_V1
  • value : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • Value : _NV_GPU_SET_ILLUMINATION_PARM_V1
  • valueData : _NVDRS_BINARY_SETTING
  • valueLength : _NVDRS_BINARY_SETTING
  • valueRange : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • VBorder : _NV_TIMING
  • vcdb : _NV_MONITOR_CAPABILITIES_V1
  • vendorId : NV_CHIPSET_INFO_v4 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v1
  • version : NV_EDID_V3 , NV_GPU_DYNAMIC_PSTATES_INFO_EX , NV_MOSAIC_TOPO_DETAILS , NV_MOSAIC_TOPO_BRIEF , NV_GPU_THERMAL_SETTINGS_V1 , _NV_MOSAIC_DISPLAY_SETTING_V1 , NV_MOSAIC_DISPLAY_SETTING_V2 , NV_VIEW_TARGET_INFO , NV_GPU_THERMAL_SETTINGS_V2 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 , _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 , NV_I2C_INFO_V1 , NV_MOSAIC_TOPO_GROUP , _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 , NV_DISPLAY_PATH_INFO_V3 , NV_I2C_INFO_V2 , _NV_MOSAIC_GRID_TOPO_V1 , _NV_MOSAIC_GRID_TOPO_V2 , NV_I2C_INFO_V3 , NV_MOSAIC_DISPLAY_TOPO_STATUS , NV_MOSAIC_TOPOLOGY , NV_DISPLAY_PATH_INFO , NV_GET_CURRENT_SLI_STATE , NV_DISPLAY_DRIVER_MEMORY_INFO_V3 , NV_GPU_GET_HDCP_SUPPORT_STATUS , NV_DISPLAY_DRIVER_MEMORY_INFO_V1 , NV_LID_DOCK_PARAMS , NV_CHIPSET_INFO_v1 , NV_CHIPSET_INFO_v2 , NV_CHIPSET_INFO_v3 , NV_CHIPSET_INFO_v4 , _NVDRS_PROFILE_V1 , NV_MOSAIC_SUPPORTED_TOPOLOGIES , _NVDRS_APPLICATION_V2 , _NVDRS_APPLICATION_V1 , _NVDRS_SETTING_V1 , _NVDRS_SETTING_VALUES , _NVAPI_STEREO_CAPS , _NVVIOPCIINFO , _NV_GSYNC_CAPABILITIES_V1 , NV_GPU_ECC_STATUS_INFO , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V1 , _NVVIOGAMMACORRECTION , _NVVIOCOLORCONVERSION , _NVVIOSYNCDELAY , _NVVIOSTATUS , _NVVIOCAPS , _NV_GSYNC_GPU , NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 , NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 , NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 , NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 , _NV_GSYNC_STATUS_PARAMS , _NV_GSYNC_STATUS , _NV_GSYNC_DISPLAY , _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 , NV_GPU_ECC_ERROR_INFO , _NV_GSYNC_DELAY , _NV_GSYNC_CONTROL_PARAMS , NV_GPU_ECC_CONFIGURATION_INFO , _NV_DISPLAYCONFIG_PATH_INFO_V1 , NV_SCANOUT_INTENSITY_DATA_V1 , NV_SCANOUT_INTENSITY_DATA_V2 , _NV_DISPLAYCONFIG_PATH_INFO_V2 , _NV_SCANOUT_INTENSITY_STATE_DATA , NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 , NV_SCANOUT_WARPING_DATA , NV_DISPLAY_DRIVER_VERSION , _NV_SCANOUT_WARPING_STATE_DATA , _NV_SCANOUT_INFORMATION , _NV_GPU_DISPLAYIDS , _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 , NV_CUSTOM_DISPLAY , _NV_MONITOR_COLOR_DATA , _NV_MONITOR_CAPABILITIES_V1 , _NV_TIMING_INPUT , _NV_COLOR_DATA_V3 , _NV_COLOR_DATA_V2 , _NV_COLOR_DATA_V1 , NV_DISPLAY_DRIVER_MEMORY_INFO_V2 , NV_INFOFRAME_PROPERTY , _NV_HDMI_SUPPORT_INFO_V2 , _NV_HDMI_SUPPORT_INFO_V1 , _NVDRS_APPLICATION_V3 , _NV_DISPLAY_PORT_INFO_V1 , _NV_GPU_SET_ILLUMINATION_PARM_V1 , _NVVIOCONFIG_V3 , _NV_VIO_TOPOLOGY , _NV_GPU_GET_ILLUMINATION_PARM_V1 , _NV_BOARD_INFO , NV_GPU_CLOCK_FREQUENCIES_V1 , NV_DISPLAY_PORT_CONFIG , NV_GPU_CLOCK_FREQUENCIES_V2 , NV_EDID_V1 , NV_GPU_PERF_PSTATES_INFO_V1 , NV_INFOFRAME_DATA , NV_GPU_PERF_PSTATES_INFO_V2 , NV_EDID_V2 , NV_GPU_PERF_PSTATES20_INFO_V1 , _NV_GPU_PERF_PSTATES20_INFO_V2
  • vertexFormat : NV_SCANOUT_WARPING_DATA
  • verticalDelay : _NVVIOSYNCDELAY
  • verticalLines : _NVVIOVIDEOMODE
  • vertices : NV_SCANOUT_WARPING_DATA
  • VFrontPorch : _NV_TIMING
  • vic : NV_INFOFRAME_VIDEO
  • vid1Out : _NVVIOOUTPUTSTATUS
  • vid2Out : _NVVIOOUTPUTSTATUS
  • video : NV_INFOFRAME_DATA
  • videoBridgePresent : NV_MULTIGPU_CAPS
  • videoLatency : _NV_MONITOR_CAPS_VSDB
  • videoMode : _NVVIOSIGNALFORMATDETAIL
  • videoStandard : _NVVIOVIDEOMODE
  • videoType : _NVVIOVIDEOMODE
  • vidIn : _NVVIOINPUTSTATUS
  • vioCaps : _NVVIODATAFORMATDETAIL
  • vioConfig : _NVVIOCONFIG_V1 , _NVVIOCONFIG_V2 , _NVVIOCONFIG_V3
  • vioGammaCorrectionType : _NVVIOGAMMACORRECTION
  • vioId : NVVIOTOPOLOGYTARGET
  • vioStatus : _NVVIOSTATUS
  • vioTarget : _NV_VIO_TOPOLOGY
  • vioTotalDeviceCount : _NV_VIO_TOPOLOGY
  • vmode : _NV_GSYNC_CONTROL_PARAMS
  • volt_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • voltages : _NV_GPU_PERF_PSTATES20_INFO_V2 , NV_GPU_PERF_PSTATES_INFO_V2
  • voltDelta_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • vsdb : _NV_MONITOR_CAPABILITIES_V1
  • VSyncPol : _NV_TIMING
  • VSyncWidth : _NV_TIMING
  • VTotal : _NV_TIMING
  • VVisible : _NV_TIMING


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • w : NV_VIEWPORTF
  • warningFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • width : _NV_RESOLUTION , NV_CUSTOM_DISPLAY , _NV_MOSAIC_DISPLAY_SETTING_V1 , _NVVIOOUTPUTREGION , NV_SCANOUT_INTENSITY_DATA_V1 , NV_MOSAIC_DISPLAY_SETTING_V2 , NV_DISPLAY_PATH , _NV_TIMING_INPUT , NV_SCANOUT_INTENSITY_DATA_V2
  • wszCurrentValue : _NVDRS_SETTING_V1
  • wszDefaultValue : _NVDRS_SETTING_VALUES
  • wszPredefinedValue : _NVDRS_SETTING_V1
  • wszValue : _NVDRS_SETTING_VALUES


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • x : NV_VIEWPORTF , _NV_POSITION , _NVVIOOUTPUTREGION
  • xRatio : NV_CUSTOM_DISPLAY


  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • y : NV_VIEWPORTF , _NV_POSITION , _NVVIOOUTPUTREGION
  • yccQuantizationRange : NV_INFOFRAME_VIDEO
  • yRatio : NV_CUSTOM_DISPLAY


  • File List
  • Globals
File List
Here is a list of all files with brief descriptions:
nvapi.h
nvapi_lite_common.h
nvapi_lite_d3dext.h
nvapi_lite_salend.h
nvapi_lite_salstart.h
nvapi_lite_sli.h
nvapi_lite_stereo.h
nvapi_lite_surround.h
NvApiDriverSettings.h
nvHLSLExtns.h
nvHLSLExtnsInternal.h
nvShaderExtnEnums.h


  • File List
  • Globals
Data Structures | Defines | Typedefs | Enumerations | Functions | Variables
nvapi.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_sli.h"
#include "nvapi_lite_surround.h"
#include "nvapi_lite_stereo.h"
#include "nvapi_lite_d3dext.h"
#include "nvapi_lite_salend.h"

Data Structures

struct | NV_EDID_V1
struct | NV_EDID_V2
Used in NvAPI_GPU_GetEDID() More...
struct | NV_EDID_V3
Used in NvAPI_GPU_GetEDID() More...
struct | NV_VIEWPORTF
struct | tagNV_TIMINGEXT
struct | _NV_TIMING
struct | NV_VIEW_TARGET_INFO
struct | NV_DISPLAY_PATH
struct | NV_DISPLAY_PATH_INFO_V3
struct | NV_DISPLAY_PATH_INFO
struct | _NV_POSITION
struct | _NV_RESOLUTION
struct | _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
struct | _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V2
struct | NV_DISPLAY_DRIVER_VERSION
struct | _NV_GPU_DISPLAYIDS
struct | _NV_BOARD_INFO
struct | NV_GPU_CLOCK_FREQUENCIES_V1
struct | NV_GPU_CLOCK_FREQUENCIES_V2
struct | NV_GPU_PERF_PSTATES_INFO_V1
struct | NV_GPU_PERF_PSTATES_INFO_V2
struct | NV_GPU_PERF_PSTATES20_PARAM_DELTA
Used to describe both voltage and frequency deltas. More...
struct | NV_GPU_PSTATE20_CLOCK_ENTRY_V1
Used to describe single clock entry. More...
struct | NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
Used to describe single base voltage entry. More...
struct | NV_GPU_PERF_PSTATES20_INFO_V1
Used in NvAPI_GPU_GetPstates20() interface call. More...
struct | _NV_GPU_PERF_PSTATES20_INFO_V2
Used in NvAPI_GPU_GetPstates20() interface call. More...
struct | NV_GPU_DYNAMIC_PSTATES_INFO_EX
struct | NV_GPU_THERMAL_SETTINGS_V1
struct | NV_GPU_THERMAL_SETTINGS_V2
struct | NV_I2C_INFO_V1
Used in NvAPI_I2CRead() and NvAPI_I2CWrite() More...
struct | NV_I2C_INFO_V2
Used in NvAPI_I2CRead() and NvAPI_I2CWrite() More...
struct | NV_I2C_INFO_V3
Used in NvAPI_I2CRead() and NvAPI_I2CWrite() More...
struct | NV_GPU_GET_HDCP_SUPPORT_STATUS
HDPC support status - used in NvAPI_GPU_GetHDCPSupportStatus() More...
struct | NV_GPU_ECC_STATUS_INFO
struct | NV_GPU_ECC_ERROR_INFO
struct | NV_GPU_ECC_CONFIGURATION_INFO
struct | NV_SCANOUT_INTENSITY_DATA_V1
struct | NV_SCANOUT_INTENSITY_DATA_V2
struct | _NV_SCANOUT_INTENSITY_STATE_DATA
struct | NV_SCANOUT_WARPING_DATA
struct | _NV_SCANOUT_WARPING_STATE_DATA
struct | _NV_SCANOUT_INFORMATION
struct | _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
struct | _NV_GPU_GET_ILLUMINATION_PARM_V1
struct | _NV_GPU_SET_ILLUMINATION_PARM_V1
struct | _NV_DISPLAY_PORT_INFO_V1
struct | NV_DISPLAY_PORT_CONFIG
struct | _NV_HDMI_SUPPORT_INFO_V1
struct | _NV_HDMI_SUPPORT_INFO_V2
struct | NV_INFOFRAME_PROPERTY
struct | NV_INFOFRAME_VIDEO
Adding an Auto bit to each field. More...
struct | NV_INFOFRAME_AUDIO
struct | NV_INFOFRAME_DATA
struct | _NV_COLOR_DATA_V1
struct | _NV_COLOR_DATA_V2
struct | _NV_COLOR_DATA_V3
struct | NV_TIMING_FLAG
struct | _NV_TIMING_INPUT
struct | _NV_MONITOR_CAPS_VCDB
struct | _NV_MONITOR_CAPS_VSDB
See NvAPI_DISP_GetMonitorCapabilities(). More...
struct | _NV_MONITOR_CAPABILITIES_V1
See NvAPI_DISP_GetMonitorCapabilities(). More...
struct | _NV_MONITOR_COLOR_DATA
struct | NV_CUSTOM_DISPLAY
struct | NV_MOSAIC_TOPO_DETAILS
This structure defines the topology details. More...
struct | NV_MOSAIC_TOPO_BRIEF
struct | _NV_MOSAIC_DISPLAY_SETTING_V1
Basic per-display settings that are used in setting/getting the Mosaic mode. More...
struct | NV_MOSAIC_DISPLAY_SETTING_V2
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
so arrays are bound. More...
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
struct | NV_MOSAIC_TOPO_GROUP
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
struct | _NV_MOSAIC_GRID_TOPO_V1
struct | _NV_MOSAIC_GRID_TOPO_V2
struct | NV_MOSAIC_DISPLAY_TOPO_STATUS
struct | NV_MOSAIC_TOPOLOGY
Used in NvAPI_GetCurrentMosaicTopology() and NvAPI_SetCurrentMosaicTopology(). More...
struct | NV_MOSAIC_SUPPORTED_TOPOLOGIES
Used in NvAPI_GetSupportedMosaicTopologies(). More...
struct | _NV_GSYNC_CAPABILITIES_V1
Used in NvAPI_GSync_QueryCapabilities(). More...
struct | _NV_GSYNC_GPU
struct | _NV_GSYNC_DISPLAY
struct | _NV_GSYNC_DELAY
Used in NV_GSYNC_CONTROL_PARAMS. More...
struct | _NV_GSYNC_CONTROL_PARAMS
Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters(). More...
struct | _NV_GSYNC_STATUS
Used in NvAPI_GSync_GetSyncStatus(). More...
struct | _NV_GSYNC_STATUS_PARAMS
struct | _NV_DX_VIDEO_STEREO_INFO
struct | NvAPI_D3D11_RASTERIZER_DESC_EX
struct | NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1
struct | NVAPI_D3D12_PSO_EXTENSION_DESC_V1
struct | NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
struct | NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
struct | NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1
struct | NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
struct | NV_MULTIGPU_CAPS
struct | _NVVIOCAPS
Device capabilities. More...
struct | _NVVIOCHANNELSTATUS
Input channel status. More...
struct | _NVVIOINPUTSTATUS
Input device status. More...
struct | _NVVIOOUTPUTSTATUS
Output device status. More...
struct | _NVVIOSTATUS
Video device status. More...
struct | _NVVIOOUTPUTREGION
Output region. More...
struct | _NVVIOGAMMARAMP8
Gamma ramp (8-bit index) More...
struct | _NVVIOGAMMARAMP10
Gamma ramp (10-bit index) More...
struct | _NVVIOSYNCDELAY
Sync delay. More...
struct | _NVVIOVIDEOMODE
Video mode information. More...
struct | _NVVIOSIGNALFORMATDETAIL
Signal format details. More...
struct | _NVVIODATAFORMATDETAIL
Data format details. More...
struct | _NVVIOCOLORCONVERSION
Colorspace conversion. More...
struct | _NVVIOGAMMACORRECTION
Gamma correction. More...
struct | _NVVIOCOMPOSITERANGE
struct | _NVVIOOUTPUTCONFIG_V1
Output device configuration. More...
struct | _NVVIOOUTPUTCONFIG_V2
struct | _NVVIOOUTPUTCONFIG_V3
struct | _NVVIOSTREAM
Stream configuration. More...
struct | _NVVIOINPUTCONFIG
Input device configuration. More...
struct | _NVVIOCONFIG_V1
struct | _NVVIOCONFIG_V2
struct | _NVVIOCONFIG_V3
struct | NVVIOTOPOLOGYTARGET
struct | _NV_VIO_TOPOLOGY
struct | _NVVIOPCIINFO
struct | _NVAPI_STEREO_CAPS
struct | _NVDRS_GPU_SUPPORT
struct | _NVDRS_BINARY_SETTING
Enum to decide on the datatype of setting value. More...
struct | _NVDRS_SETTING_VALUES
struct | _NVDRS_SETTING_V1
struct | _NVDRS_APPLICATION_V1
struct | _NVDRS_APPLICATION_V2
struct | _NVDRS_APPLICATION_V3
struct | _NVDRS_PROFILE_V1
struct | NV_CHIPSET_INFO_v4
struct | NV_CHIPSET_INFO_v3
struct | NV_CHIPSET_INFO_v2
struct | NV_CHIPSET_INFO_v1
struct | NV_LID_DOCK_PARAMS

Defines

#define | _NVAPI_H
#define | __cdecl
#define | NVAPI_API_NOT_INTIALIZED NVAPI_API_NOT_INITIALIZED
#define | NVAPI_INVALID_USER_PRIVILEDGE NVAPI_INVALID_USER_PRIVILEGE
#define | DISPLAYPORT_STRUCTS_DEFINED
#define | NVFORMAT_MAKEFOURCC(ch0, ch1, ch2, ch3)
#define | NV_TIMING_STRUCTS_DEFINED
#define | NV_TIMING_H_SYNC_POSITIVE 0
#define | NV_TIMING_H_SYNC_NEGATIVE 1
#define | NV_TIMING_H_SYNC_DEFAULT NV_TIMING_H_SYNC_NEGATIVE
#define | NV_TIMING_V_SYNC_POSITIVE 0
#define | NV_TIMING_V_SYNC_NEGATIVE 1
#define | NV_TIMING_V_SYNC_DEFAULT NV_TIMING_V_SYNC_POSITIVE
#define | NV_TIMING_PROGRESSIVE 0
#define | NV_TIMING_INTERLACED 1
#define | NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 1
#define | NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 2
#define | NV_VIEW_TARGET_INFO_VER MAKE_NVAPI_VERSION(NV_VIEW_TARGET_INFO,2)
#define | NVAPI_MAX_DISPLAY_PATH NVAPI_MAX_VIEW_TARGET
#define | NVAPI_ADVANCED_MAX_DISPLAY_PATH NVAPI_ADVANCED_MAX_VIEW_TARGET
#define | NV_DISPLAY_PATH_INFO_VER NV_DISPLAY_PATH_INFO_VER4
#define | NV_DISPLAY_PATH_INFO_VER4 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,4)
#define | NV_DISPLAY_PATH_INFO_VER3 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,3)
#define | NV_DISPLAY_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,2)
#define | NV_DISPLAY_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1
#define | _NV_DISPLAYCONFIG_PATH_INFO_V2 _NV_DISPLAYCONFIG_PATH_INFO
#define | NV_DISPLAYCONFIG_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V2,2)
#define | NV_DISPLAYCONFIG_PATH_INFO_VER NV_DISPLAYCONFIG_PATH_INFO_VER2
#define | NVAPI_UNICODE_STRING_MAX 2048
#define | NVAPI_BINARY_DATA_MAX 4096
#define | NV_DISPLAY_DRIVER_VERSION_VER MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_VERSION,1)
#define | NV_GPU_CONNECTED_IDS_FLAG_UNCACHED NV_BIT(0)
#define | NV_GPU_CONNECTED_IDS_FLAG_SLI NV_BIT(1)
#define | NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE NV_BIT(2)
#define | NV_GPU_CONNECTED_IDS_FLAG_FAKE NV_BIT(3)
#define | NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST NV_BIT(4)
#define | NV_GPU_DISPLAYIDS_VER1 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,1)
#define | NV_GPU_DISPLAYIDS_VER2 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,3)
#define | NV_GPU_DISPLAYIDS_VER NV_GPU_DISPLAYIDS_VER2
#define | NV_BOARD_INFO_VER1 MAKE_NVAPI_VERSION(NV_BOARD_INFO_V1,1)
#define | NV_BOARD_INFO_VER NV_BOARD_INFO_VER1
#define | NV_GPU_CLOCK_FREQUENCIES_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V1,1)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_2 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,2)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_3 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,3)
#define | NV_GPU_CLOCK_FREQUENCIES_VER NV_GPU_CLOCK_FREQUENCIES_VER_3
#define | NVAPI_MAX_GPU_PSTATE20_PSTATES 16
#define | NVAPI_MAX_GPU_PSTATE20_CLOCKS 8
#define | NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES 4
#define | NV_GPU_PERF_PSTATES20_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES20_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES20_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES20_INFO_VER NV_GPU_PERF_PSTATES20_INFO_VER3
#define | NVAPI_MAX_GPU_UTILIZATIONS 8
#define | NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER MAKE_NVAPI_VERSION(NV_GPU_DYNAMIC_PSTATES_INFO_EX,1)
#define | NVAPI_MAX_THERMAL_SENSORS_PER_GPU 3
#define | NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER 4096
#define | NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4
#define | NVAPI_DISPLAY_DEVICE_MASK_MAX 24
#define | NVAPI_I2C_SPEED_DEPRECATED 0xFFFF
#define | NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)
#define | NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)
#define | NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)
#define | NV_I2C_INFO_VER NV_I2C_INFO_VER3
#define | NV_GPU_GET_HDCP_SUPPORT_STATUS_VER MAKE_NVAPI_VERSION(NV_GPU_GET_HDCP_SUPPORT_STATUS,1)
#define | NV_GPU_ECC_STATUS_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_STATUS_INFO,1)
#define | NV_GPU_ECC_ERROR_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_ERROR_INFO,1)
#define | NV_GPU_ECC_CONFIGURATION_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_CONFIGURATION_INFO,1)
#define | NV_SCANOUT_INTENSITY_DATA_VER1 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V1, 1)
#define | NV_SCANOUT_INTENSITY_DATA_VER2 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V2, 2)
#define | NV_SCANOUT_INTENSITY_DATA_VER NV_SCANOUT_INTENSITY_DATA_VER2
#define | NV_SCANOUT_INTENSITY_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_STATE_DATA, 1)
#define | NV_SCANOUT_WARPING_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_DATA, 1)
#define | NV_SCANOUT_WARPING_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_STATE_DATA, 1)
#define | NV_SCANOUT_INFORMATION_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INFORMATION,1)
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1,1)
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1
#define | NV_GPU_GET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_GET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_GET_ILLUMINATION_PARM_VER NV_GPU_GET_ILLUMINATION_PARM_VER_1
#define | NV_GPU_SET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_SET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_SET_ILLUMINATION_PARM_VER NV_GPU_SET_ILLUMINATION_PARM_VER_1
#define | NV_DISPLAY_PORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,1)
#define | NV_DISPLAY_PORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,2)
#define | NV_DISPLAY_PORT_INFO_VER NV_DISPLAY_PORT_INFO_VER2
#define | NV_DISPLAY_PORT_CONFIG_VER MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_DISPLAY_PORT_CONFIG_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,1)
#define | NV_DISPLAY_PORT_CONFIG_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_HDMI_SUPPORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V1, 1)
#define | NV_HDMI_SUPPORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V2, 2)
#define | NV_HDMI_SUPPORT_INFO_VER NV_HDMI_SUPPORT_INFO_VER2
#define | NV_TIMING_INPUT_VER MAKE_NVAPI_VERSION(NV_TIMING_INPUT,1)
#define | NV_MONITOR_COLOR_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_COLOR_CAPS_V1,1)
#define | NV_MONITOR_COLOR_CAPS_VER NV_MONITOR_COLOR_CAPS_VER1
#define | NV_CUSTOM_DISPLAY_VER MAKE_NVAPI_VERSION(NV_CUSTOM_DISPLAY,1)
#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NV_MOSAIC_TOPO_VALIDITY_VALID 0x00000000
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU 0x00000001
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY 0x00000002
#define | NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES 0x00000004
#define | NVAPI_MOSAIC_TOPO_DETAILS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_DETAILS,1)
#define | NVAPI_MOSAIC_TOPO_BRIEF_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_BRIEF,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V1,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V2,2)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER NVAPI_MOSAIC_DISPLAY_SETTING_VER2
#define | NV_MOSAIC_DISPLAY_SETTINGS_MAX 40
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V1,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V2,2)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2
#define | NV_MOSAIC_TOPO_IDX_DEFAULT 0
#define | NV_MOSAIC_TOPO_IDX_LEFT_EYE 0
#define | NV_MOSAIC_TOPO_IDX_RIGHT_EYE 1
#define | NV_MOSAIC_TOPO_NUM_EYES 2
#define | NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP 2
#define | NVAPI_MOSAIC_TOPO_GROUP_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_GROUP,1)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY NV_BIT(0)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD NV_BIT(1)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE NV_BIT(2)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID NV_BIT(3)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION NV_BIT(0)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED NV_BIT(1)
#define | NV_MOSAIC_DISPLAY_TOPO_STATUS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_TOPO_STATUS,1)
#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NVAPI_MAX_MOSAIC_TOPOS 16
#define | NVAPI_MOSAIC_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPOLOGY,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPOLOGIES,1)
#define | NVAPI_MAX_GSYNC_DEVICES 4
#define | NVAPI_GSYNC_BOARD_ID_P358 856
#define | NVAPI_GSYNC_BOARD_ID_P2060 8288
#define | NV_GSYNC_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V1,1)
#define | NV_GSYNC_CAPABILITIES_VER NV_GSYNC_CAPABILITIES_VER1
#define | NV_GSYNC_DISPLAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DISPLAY,1)
#define | NV_GSYNC_GPU_VER MAKE_NVAPI_VERSION(NV_GSYNC_GPU,1)
#define | NV_GSYNC_DELAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DELAY,1)
#define | NV_GSYNC_CONTROL_PARAMS_VER MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS,1)
#define | NV_GSYNC_STATUS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS,1)
#define | NVAPI_MAX_RJ45_PER_GSYNC 2
#define | NV_GSYNC_STATUS_PARAMS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS,1)
#define | NV_STEREO_VIDEO_FORMAT_DEFINE
#define | NV_DX_VIDEO_STEREO_INFO_VER MAKE_NVAPI_VERSION(NV_DX_VIDEO_STEREO_INFO,1)
#define | NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)
#define | NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1
#define | NV_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_EXTENSION_DESC_V1, 1)
#define | NV_PSO_EXTENSION_DESC_VER NV_PSO_EXTENSION_DESC_VER_1
#define | NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, 1)
#define | NV_RASTERIZER_PSO_EXTENSION_DESC_VER NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1
#define | NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)
#define | NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1
#define | NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1, 1)
#define | NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1
#define | NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1, 1)
#define | NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1
#define | NVAPI_COPY_ASYNCHRONOUSLY 1
#define | NVAPI_CPU_RESOURCE 0xffffffff
#define | FENCE_SYNCHRONIZATION_START(pMultiGPUDevice, hFence, Value, srcGpu, dstGpu)
#define | FENCE_SYNCHRONIZATION_END(pMultiGPUDevice, hFence, Value, srcGpu, dstGpu)
#define | NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE 0x01
#define | NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS 0x02
#define | NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS 0x80000000
#define | NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE 0
#define | NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE 1
#define | NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS 2
#define | NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN 3
#define | NVAPI_ALL_GPUS 0
#define | ID3D11MultiGPUDevice_VER1 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 1)
#define | ID3D11MultiGPUDevice_VER2 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 2)
#define | ID3D11MultiGPUDevice_VER ID3D11MultiGPUDevice_VER2
#define | ALL_GPUS 0
#define | NVAPI_STEREO_QUADBUFFERED_API_VERSION 0x2
#define | NV_CHIPSET_INFO_VER_1 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v1,1)
#define | NV_CHIPSET_INFO_VER_2 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v2,2)
#define | NV_CHIPSET_INFO_VER_3 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v3,3)
#define | NV_CHIPSET_INFO_VER_4 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v4,4)
#define | NV_CHIPSET_INFO NV_CHIPSET_INFO_v4
#define | NV_CHIPSET_INFO_VER NV_CHIPSET_INFO_VER_4
#define | NV_LID_DOCK_PARAMS_VER MAKE_NVAPI_VERSION(NV_LID_DOCK_PARAMS,1)
NvAPI_OGL_ExpertModeSet[Get] Functions
#define | NVAPI_OGLEXPERT_DETAIL_NONE 0x00000000
#define | NVAPI_OGLEXPERT_DETAIL_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_DETAIL_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_DETAIL_BASIC_INFO 0x00000004
#define | NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO 0x00000008
#define | NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING 0x00000010
#define | NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING 0x00000020
#define | NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING 0x00000040
#define | NVAPI_OGLEXPERT_DETAIL_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_REPORT_NONE 0x00000000
#define | NVAPI_OGLEXPERT_REPORT_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_REPORT_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX 0x00000004
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY 0x00000008
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB 0x00000010
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER 0x00000020
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT 0x00000040
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP 0x00000080
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER 0x00000100
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL 0x00000200
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE 0x00000400
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT 0x00000800
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE 0x00001000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM 0x00002000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_FBO 0x00004000
#define | NVAPI_OGLEXPERT_REPORT_FEATURE_SLI 0x00008000
#define | NVAPI_OGLEXPERT_REPORT_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_OUTPUT_TO_NONE 0x00000000
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE 0x00000001
#define | NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER 0x00000004
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK 0x00000008
#define | NVAPI_OGLEXPERT_OUTPUT_TO_ALL 0xFFFFFFFF
#define | NVAPI_MAX_GPU_CLOCKS 32
#define | NVAPI_MAX_GPU_PUBLIC_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_VOLTAGES 16
#define | NVAPI_MAX_GPU_PERF_PSTATES 16
#define | NV_GPU_PERF_PSTATES_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3
#define | NV_GPU_THERMAL_SETTINGS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V1,1)
#define | NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)
#define | NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Typedefs

typedef enum _NV_DP_LINK_RATE | NV_DP_LINK_RATE
typedef enum _NV_DP_LANE_COUNT | NV_DP_LANE_COUNT
typedef enum _NV_DP_COLOR_FORMAT | NV_DP_COLOR_FORMAT
typedef enum _NV_DP_COLORIMETRY | NV_DP_COLORIMETRY
typedef enum _NV_DP_DYNAMIC_RANGE | NV_DP_DYNAMIC_RANGE
typedef enum _NV_DP_BPC | NV_DP_BPC
typedef enum _NV_GPU_CONNECTOR_TYPE | NV_GPU_CONNECTOR_TYPE
typedef enum _NV_DISPLAY_TV_FORMAT | NV_DISPLAY_TV_FORMAT
typedef enum _NV_SCALING | NV_SCALING
typedef enum _NV_ROTATE | NV_ROTATE
typedef enum _NV_FORMAT | NV_FORMAT
typedef enum _NV_TIMING_OVERRIDE | NV_TIMING_OVERRIDE
typedef struct tagNV_TIMINGEXT | NV_TIMINGEXT
typedef struct _NV_TIMING | NV_TIMING
typedef struct _NV_POSITION | NV_POSITION
typedef struct _NV_RESOLUTION | NV_RESOLUTION
typedef struct
_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 		NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
typedef
NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 		NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO
typedef struct
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 		NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
typedef struct
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 		NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
typedef
NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 		NV_DISPLAYCONFIG_PATH_TARGET_INFO
typedef enum
_NV_DISPLAYCONFIG_SPANNING_ORIENTATION 		NV_DISPLAYCONFIG_SPANNING_ORIENTATION
typedef struct
_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 		NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
typedef struct
_NV_DISPLAYCONFIG_PATH_INFO_V1 		NV_DISPLAYCONFIG_PATH_INFO_V1
typedef struct
_NV_DISPLAYCONFIG_PATH_INFO_V2 		NV_DISPLAYCONFIG_PATH_INFO_V2
typedef
NV_DISPLAYCONFIG_PATH_INFO_V2 		NV_DISPLAYCONFIG_PATH_INFO
typedef
NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 		NV_DISPLAYCONFIG_SOURCE_MODE_INFO
typedef enum
_NV_DISPLAYCONFIG_FLAGS 		NV_DISPLAYCONFIG_FLAGS
typedef NvU16 | NvAPI_UnicodeString [NVAPI_UNICODE_STRING_MAX]
typedef const NvU16 * | NvAPI_LPCWSTR
typedef void(* | NVAPI_OGLEXPERT_CALLBACK )(unsigned int categoryId, unsigned int messageId, unsigned int detailLevel, int objectId, const char *messageStr)
typedef struct _NV_GPU_DISPLAYIDS | NV_GPU_DISPLAYIDS
typedef enum _NV_GPU_OUTPUT_TYPE | NV_GPU_OUTPUT_TYPE
typedef enum _NV_GPU_TYPE | NV_GPU_TYPE
typedef enum _NV_GPU_BUS_TYPE | NV_GPU_BUS_TYPE
typedef struct _NV_BOARD_INFO | NV_BOARD_INFO_V1
typedef NV_BOARD_INFO_V1 | NV_BOARD_INFO
typedef enum
_NV_GPU_PUBLIC_CLOCK_ID 		NV_GPU_PUBLIC_CLOCK_ID
typedef enum
_NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID 		NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID
typedef NV_GPU_CLOCK_FREQUENCIES_V2 | NV_GPU_CLOCK_FREQUENCIES
typedef enum _NV_GPU_PERF_PSTATE_ID | NV_GPU_PERF_PSTATE_ID
typedef NV_GPU_PERF_PSTATES_INFO_V2 | NV_GPU_PERF_PSTATES_INFO
typedef struct
_NV_GPU_PERF_PSTATES20_INFO_V2 		NV_GPU_PERF_PSTATES20_INFO_V2
typedef
NV_GPU_PERF_PSTATES20_INFO_V2 		NV_GPU_PERF_PSTATES20_INFO
typedef NV_GPU_THERMAL_SETTINGS_V2 | NV_GPU_THERMAL_SETTINGS
typedef NV_I2C_INFO_V3 | NV_I2C_INFO
typedef enum
_NV_GPU_HDCP_FUSE_STATE 		NV_GPU_HDCP_FUSE_STATE
typedef enum
_NV_GPU_HDCP_KEY_SOURCE 		NV_GPU_HDCP_KEY_SOURCE
typedef enum
_NV_GPU_HDCP_KEY_SOURCE_STATE 		NV_GPU_HDCP_KEY_SOURCE_STATE
typedef enum _NV_ECC_CONFIGURATION | NV_ECC_CONFIGURATION
typedef
NV_SCANOUT_INTENSITY_DATA_V2 		NV_SCANOUT_INTENSITY_DATA
typedef struct
_NV_SCANOUT_INTENSITY_STATE_DATA 		NV_SCANOUT_INTENSITY_STATE_DATA
typedef struct
_NV_SCANOUT_WARPING_STATE_DATA 		NV_SCANOUT_WARPING_STATE_DATA
typedef struct
_NV_SCANOUT_INFORMATION 		NV_SCANOUT_INFORMATION
typedef enum
_NVAPI_GPU_PERF_DECREASE 		NVAPI_GPU_PERF_DECREASE
typedef enum
_NV_GPU_ILLUMINATION_ATTRIB 		NV_GPU_ILLUMINATION_ATTRIB
typedef struct
_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 		NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
typedef
NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 		NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM
typedef struct
_NV_GPU_GET_ILLUMINATION_PARM_V1 		NV_GPU_GET_ILLUMINATION_PARM_V1
typedef
NV_GPU_GET_ILLUMINATION_PARM_V1 		NV_GPU_GET_ILLUMINATION_PARM
typedef struct
_NV_GPU_SET_ILLUMINATION_PARM_V1 		NV_GPU_SET_ILLUMINATION_PARM_V1
typedef
NV_GPU_SET_ILLUMINATION_PARM_V1 		NV_GPU_SET_ILLUMINATION_PARM
typedef struct
_NV_DISPLAY_PORT_INFO_V1 		NV_DISPLAY_PORT_INFO_V1
typedef NV_DISPLAY_PORT_INFO_V1 | NV_DISPLAY_PORT_INFO
typedef struct
_NV_HDMI_SUPPORT_INFO_V1 		NV_HDMI_SUPPORT_INFO_V1
typedef struct
_NV_HDMI_SUPPORT_INFO_V2 		NV_HDMI_SUPPORT_INFO_V2
typedef NV_HDMI_SUPPORT_INFO_V2 | NV_HDMI_SUPPORT_INFO
typedef struct _NV_TIMING_INPUT | NV_TIMING_INPUT
typedef struct
_NV_MONITOR_COLOR_DATA 		NV_MONITOR_COLOR_CAPS_V1
typedef NV_MONITOR_COLOR_CAPS_V1 | NV_MONITOR_COLOR_CAPS
typedef struct
_NV_MOSAIC_DISPLAY_SETTING_V1 		NV_MOSAIC_DISPLAY_SETTING_V1
typedef struct
NV_MOSAIC_DISPLAY_SETTING_V2 		NV_MOSAIC_DISPLAY_SETTING_V2
typedef
NV_MOSAIC_DISPLAY_SETTING_V2 		NV_MOSAIC_DISPLAY_SETTING
typedef struct
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 		NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
typedef struct
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 		NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
typedef
NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 		NV_MOSAIC_SUPPORTED_TOPO_INFO
typedef struct
_NV_GSYNC_CAPABILITIES_V1 		NV_GSYNC_CAPABILITIES_V1
typedef NV_GSYNC_CAPABILITIES_V1 | NV_GSYNC_CAPABILITIES
typedef enum
_NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR 		NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR
typedef enum
_NVAPI_GSYNC_DISPLAY_SYNC_STATE 		NVAPI_GSYNC_DISPLAY_SYNC_STATE
typedef struct _NV_GSYNC_GPU | NV_GSYNC_GPU
typedef struct _NV_GSYNC_DISPLAY | NV_GSYNC_DISPLAY
typedef enum _NVAPI_GSYNC_POLARITY | NVAPI_GSYNC_POLARITY
typedef enum
_NVAPI_GSYNC_VIDEO_MODE 		NVAPI_GSYNC_VIDEO_MODE
typedef enum
_NVAPI_GSYNC_SYNC_SOURCE 		NVAPI_GSYNC_SYNC_SOURCE
typedef struct _NV_GSYNC_DELAY | NV_GSYNC_DELAY
typedef struct
_NV_GSYNC_CONTROL_PARAMS 		NV_GSYNC_CONTROL_PARAMS
typedef enum
_NVAPI_GSYNC_DELAY_TYPE 		NVAPI_GSYNC_DELAY_TYPE
typedef struct _NV_GSYNC_STATUS | NV_GSYNC_STATUS
typedef enum _NVAPI_GSYNC_RJ45_IO | NVAPI_GSYNC_RJ45_IO
typedef struct
_NV_GSYNC_STATUS_PARAMS 		NV_GSYNC_STATUS_PARAMS
typedef enum
_NV_STEREO_VIDEO_FORMAT 		NV_STEREO_VIDEO_FORMAT
typedef struct
_NV_DX_VIDEO_STEREO_INFO 		NV_DX_VIDEO_STEREO_INFO
typedef enum
_NVAPI_D3D11_INSERTWFI_FLAG 		NVAPI_D3D11_INSERTWFI_FLAG
typedef struct
NvAPI_D3D11_RASTERIZER_DESC_EX 		NvAPI_D3D11_RASTERIZER_DESC_EX
typedef UINT | NvAPI_D3D11_SWIZZLE_MODE
typedef enum _NV_SWIZZLE_MODE | NV_SWIZZLE_MODE
typedef enum _NV_SWIZZLE_OFFSET | NV_SWIZZLE_OFFSET
typedef enum _NV_FASTGS_FLAGS | NV_FASTGS_FLAGS
typedef
NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 		NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC
typedef enum _NV_PSO_EXTENSION | NV_PSO_EXTENSION
typedef
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 		NVAPI_D3D12_PSO_EXTENSION_DESC
typedef
NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 		NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC
typedef
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 		NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC
typedef
NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 		NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC
typedef
NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 		NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC
typedef struct NV_MULTIGPU_CAPS * | PNV_MULTIGPU_CAPS
typedef ID3D11MultiGPUDevice_V1 | ID3D11MultiGPUDevice
typedef enum _IMPLICIT_SLI_CONTROL | IMPLICIT_SLI_CONTROL
typedef NvU32 | NVVIOOWNERID
typedef enum
_NV_StereoRegistryProfileType 		NV_STEREO_REGISTRY_PROFILE_TYPE
typedef enum _NV_StereoRegistryID | NV_STEREO_REGISTRY_ID
typedef enum _NV_FrustumAdjustMode | NV_FRUSTUM_ADJUST_MODE
typedef enum
_NV_StereoSwapChainMode 		NV_STEREO_SWAPCHAIN_MODE

Enumerations

enum | _NV_DP_LINK_RATE { NV_DP_1_62GBPS = 6, NV_DP_2_70GBPS = 0xA, NV_DP_5_40GBPS = 0x14, NV_DP_8_10GBPS = 0x1E }
enum | _NV_DP_LANE_COUNT { NV_DP_1_LANE = 1, NV_DP_2_LANE = 2, NV_DP_4_LANE = 4 }
enum | _NV_DP_COLOR_FORMAT { NV_DP_COLOR_FORMAT_RGB = 0, NV_DP_COLOR_FORMAT_YCbCr422, NV_DP_COLOR_FORMAT_YCbCr444 }
enum | _NV_DP_COLORIMETRY { NV_DP_COLORIMETRY_RGB = 0, NV_DP_COLORIMETRY_YCbCr_ITU601, NV_DP_COLORIMETRY_YCbCr_ITU709 }
enum | _NV_DP_DYNAMIC_RANGE { NV_DP_DYNAMIC_RANGE_VESA = 0, NV_DP_DYNAMIC_RANGE_CEA }
enum _NV_DP_BPC {
NV_DP_BPC_DEFAULT = 0, NV_DP_BPC_6, NV_DP_BPC_8, NV_DP_BPC_10,
NV_DP_BPC_12, NV_DP_BPC_16
}
enum _NV_GPU_CONNECTOR_TYPE {
NVAPI_GPU_CONNECTOR_VGA_15_PIN = 0x00000000, NVAPI_GPU_CONNECTOR_TV_COMPOSITE = 0x00000010, NVAPI_GPU_CONNECTOR_TV_SVIDEO = 0x00000011, NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT = 0x00000013,
NVAPI_GPU_CONNECTOR_TV_SCART = 0x00000014, NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 = 0x00000016, NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 = 0x00000017, NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB = 0x00000018,
NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO = 0x00000019, NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE = 0x0000001A, NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO = 0x00000020, NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE = 0x00000021,
NVAPI_GPU_CONNECTOR_DVI_I = 0x00000030, NVAPI_GPU_CONNECTOR_DVI_D = 0x00000031, NVAPI_GPU_CONNECTOR_ADC = 0x00000032, NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 = 0x00000038,
NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 = 0x00000039, NVAPI_GPU_CONNECTOR_SPWG = 0x00000040, NVAPI_GPU_CONNECTOR_OEM = 0x00000041, NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL = 0x00000046,
NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL = 0x00000047, NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT = 0x00000048, NVAPI_GPU_CONNECTOR_HDMI_A = 0x00000061, NVAPI_GPU_CONNECTOR_HDMI_C_MINI = 0x00000063,
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 = 0x00000064, NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 = 0x00000065, NVAPI_GPU_CONNECTOR_VIRTUAL_WFD = 0x00000070, NVAPI_GPU_CONNECTOR_UNKNOWN = 0xFFFFFFFF
}
enum _NV_DISPLAY_TV_FORMAT {
NV_DISPLAY_TV_FORMAT_NONE = 0, NV_DISPLAY_TV_FORMAT_SD_NTSCM = 0x00000001, NV_DISPLAY_TV_FORMAT_SD_NTSCJ = 0x00000002, NV_DISPLAY_TV_FORMAT_SD_PALM = 0x00000004,
NV_DISPLAY_TV_FORMAT_SD_PALBDGH = 0x00000008, NV_DISPLAY_TV_FORMAT_SD_PALN = 0x00000010, NV_DISPLAY_TV_FORMAT_SD_PALNC = 0x00000020, NV_DISPLAY_TV_FORMAT_SD_576i = 0x00000100,
NV_DISPLAY_TV_FORMAT_SD_480i = 0x00000200, NV_DISPLAY_TV_FORMAT_ED_480p = 0x00000400, NV_DISPLAY_TV_FORMAT_ED_576p = 0x00000800, NV_DISPLAY_TV_FORMAT_HD_720p = 0x00001000,
NV_DISPLAY_TV_FORMAT_HD_1080i = 0x00002000, NV_DISPLAY_TV_FORMAT_HD_1080p = 0x00004000, NV_DISPLAY_TV_FORMAT_HD_720p50 = 0x00008000, NV_DISPLAY_TV_FORMAT_HD_1080p24 = 0x00010000,
NV_DISPLAY_TV_FORMAT_HD_1080i50 = 0x00020000, NV_DISPLAY_TV_FORMAT_HD_1080p50 = 0x00040000, NV_DISPLAY_TV_FORMAT_UHD_4Kp30 = 0x00080000, NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp30,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25 = 0x00100000, NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp25, NV_DISPLAY_TV_FORMAT_UHD_4Kp24 = 0x00200000, NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp24,
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE = 0x00400000, NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 = 0x00800000, NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 = 0x00900000, NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 = 0x00A00000,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 = 0x00B00000, NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 = 0x00C00000, NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 = 0x00D00000, NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 = 0x00E00000,
NV_DISPLAY_TV_FORMAT_SD_OTHER = 0x01000000, NV_DISPLAY_TV_FORMAT_ED_OTHER = 0x02000000, NV_DISPLAY_TV_FORMAT_HD_OTHER = 0x04000000, NV_DISPLAY_TV_FORMAT_ANY = 0x80000000
}
enum _NV_SCALING {
NV_SCALING_DEFAULT = 0, NV_SCALING_GPU_SCALING_TO_CLOSEST = 1, NV_SCALING_GPU_SCALING_TO_NATIVE = 2, NV_SCALING_GPU_SCANOUT_TO_NATIVE = 3,
NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE = 5, NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST = 6, NV_SCALING_GPU_SCANOUT_TO_CLOSEST = 7, NV_SCALING_MONITOR_SCALING = NV_SCALING_GPU_SCALING_TO_CLOSEST,
NV_SCALING_ADAPTER_SCALING = NV_SCALING_GPU_SCALING_TO_NATIVE, NV_SCALING_CENTERED = NV_SCALING_GPU_SCANOUT_TO_NATIVE, NV_SCALING_ASPECT_SCALING = NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE, NV_SCALING_CUSTOMIZED = 255
}
enum _NV_ROTATE {
NV_ROTATE_0 = 0, NV_ROTATE_90 = 1, NV_ROTATE_180 = 2, NV_ROTATE_270 = 3,
NV_ROTATE_IGNORED = 4
}
enum _NV_FORMAT {
NV_FORMAT_UNKNOWN = 0, NV_FORMAT_P8 = 41, NV_FORMAT_R5G6B5 = 23, NV_FORMAT_A8R8G8B8 = 21,
NV_FORMAT_A16B16G16R16F = 113
}
enum _NV_TIMING_OVERRIDE {
NV_TIMING_OVERRIDE_CURRENT = 0, NV_TIMING_OVERRIDE_AUTO, NV_TIMING_OVERRIDE_EDID, NV_TIMING_OVERRIDE_DMT,
NV_TIMING_OVERRIDE_DMT_RB, NV_TIMING_OVERRIDE_CVT, NV_TIMING_OVERRIDE_CVT_RB, NV_TIMING_OVERRIDE_GTF,
NV_TIMING_OVERRIDE_EIA861, NV_TIMING_OVERRIDE_ANALOG_TV, NV_TIMING_OVERRIDE_CUST, NV_TIMING_OVERRIDE_NV_PREDEFINED,
NV_TIMING_OVERRIDE_NV_PSF = NV_TIMING_OVERRIDE_NV_PREDEFINED, NV_TIMING_OVERRIDE_NV_ASPR, NV_TIMING_OVERRIDE_SDI, NV_TIMING_OVRRIDE_MAX
}
enum | _NV_DISPLAYCONFIG_SPANNING_ORIENTATION { NV_DISPLAYCONFIG_SPAN_NONE = 0, NV_DISPLAYCONFIG_SPAN_HORIZONTAL = 1, NV_DISPLAYCONFIG_SPAN_VERTICAL = 2 }
enum | _NV_DISPLAYCONFIG_FLAGS { NV_DISPLAYCONFIG_VALIDATE_ONLY = 0x00000001, NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE = 0x00000002, NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED = 0x00000004, NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION = 0x00000008 }
enum NV_MONITOR_CONN_TYPE {
NV_MONITOR_CONN_TYPE_UNINITIALIZED = 0, NV_MONITOR_CONN_TYPE_VGA, NV_MONITOR_CONN_TYPE_COMPONENT, NV_MONITOR_CONN_TYPE_SVIDEO,
NV_MONITOR_CONN_TYPE_HDMI, NV_MONITOR_CONN_TYPE_DVI, NV_MONITOR_CONN_TYPE_LVDS, NV_MONITOR_CONN_TYPE_DP,
NV_MONITOR_CONN_TYPE_COMPOSITE, NV_MONITOR_CONN_TYPE_UNKNOWN = -1
}
enum | NV_SYSTEM_TYPE { NV_SYSTEM_TYPE_UNKNOWN = 0, NV_SYSTEM_TYPE_LAPTOP = 1, NV_SYSTEM_TYPE_DESKTOP = 2 }
enum | _NV_GPU_OUTPUT_TYPE { NVAPI_GPU_OUTPUT_UNKNOWN = 0, NVAPI_GPU_OUTPUT_CRT = 1, NVAPI_GPU_OUTPUT_DFP = 2, NVAPI_GPU_OUTPUT_TV = 3 }
enum | _NV_GPU_TYPE { NV_SYSTEM_TYPE_GPU_UNKNOWN = 0, NV_SYSTEM_TYPE_IGPU = 1, NV_SYSTEM_TYPE_DGPU = 2 }
enum _NV_GPU_BUS_TYPE {
NVAPI_GPU_BUS_TYPE_UNDEFINED = 0, NVAPI_GPU_BUS_TYPE_PCI = 1, NVAPI_GPU_BUS_TYPE_AGP = 2, NVAPI_GPU_BUS_TYPE_PCI_EXPRESS = 3,
NVAPI_GPU_BUS_TYPE_FPCI = 4, NVAPI_GPU_BUS_TYPE_AXI = 5
}
enum _NV_GPU_PUBLIC_CLOCK_ID {
NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS = 0, NVAPI_GPU_PUBLIC_CLOCK_MEMORY = 4, NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR = 7, NVAPI_GPU_PUBLIC_CLOCK_VIDEO = 8,
NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED = NVAPI_MAX_GPU_PUBLIC_CLOCKS
}
enum | _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID { NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE = 0, NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED = NVAPI_MAX_GPU_PERF_VOLTAGES }
enum | NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE { NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ = 0, NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK = 1, NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK = 2, NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM = 3 }
enum _NV_GPU_PERF_PSTATE_ID {
NVAPI_GPU_PERF_PSTATE_P0 = 0, NVAPI_GPU_PERF_PSTATE_P1, NVAPI_GPU_PERF_PSTATE_P2, NVAPI_GPU_PERF_PSTATE_P3,
NVAPI_GPU_PERF_PSTATE_P4, NVAPI_GPU_PERF_PSTATE_P5, NVAPI_GPU_PERF_PSTATE_P6, NVAPI_GPU_PERF_PSTATE_P7,
NVAPI_GPU_PERF_PSTATE_P8, NVAPI_GPU_PERF_PSTATE_P9, NVAPI_GPU_PERF_PSTATE_P10, NVAPI_GPU_PERF_PSTATE_P11,
NVAPI_GPU_PERF_PSTATE_P12, NVAPI_GPU_PERF_PSTATE_P13, NVAPI_GPU_PERF_PSTATE_P14, NVAPI_GPU_PERF_PSTATE_P15,
NVAPI_GPU_PERF_PSTATE_UNDEFINED = NVAPI_MAX_GPU_PERF_PSTATES, NVAPI_GPU_PERF_PSTATE_ALL
}
enum | NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID { NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE = 0, NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE }
enum NV_THERMAL_TARGET {
NVAPI_THERMAL_TARGET_NONE = 0, NVAPI_THERMAL_TARGET_GPU = 1, NVAPI_THERMAL_TARGET_MEMORY = 2, NVAPI_THERMAL_TARGET_POWER_SUPPLY = 4,
NVAPI_THERMAL_TARGET_BOARD = 8, NVAPI_THERMAL_TARGET_VCD_BOARD = 9, NVAPI_THERMAL_TARGET_VCD_INLET = 10, NVAPI_THERMAL_TARGET_VCD_OUTLET = 11,
NVAPI_THERMAL_TARGET_ALL = 15, NVAPI_THERMAL_TARGET_UNKNOWN = -1
}
enum NV_THERMAL_CONTROLLER {
NVAPI_THERMAL_CONTROLLER_NONE = 0, NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL, NVAPI_THERMAL_CONTROLLER_ADM1032, NVAPI_THERMAL_CONTROLLER_MAX6649,
NVAPI_THERMAL_CONTROLLER_MAX1617, NVAPI_THERMAL_CONTROLLER_LM99, NVAPI_THERMAL_CONTROLLER_LM89, NVAPI_THERMAL_CONTROLLER_LM64,
NVAPI_THERMAL_CONTROLLER_ADT7473, NVAPI_THERMAL_CONTROLLER_SBMAX6649, NVAPI_THERMAL_CONTROLLER_VBIOSEVT, NVAPI_THERMAL_CONTROLLER_OS,
NVAPI_THERMAL_CONTROLLER_UNKNOWN = -1
}
enum NV_I2C_SPEED {
NVAPI_I2C_SPEED_DEFAULT, NVAPI_I2C_SPEED_3KHZ, NVAPI_I2C_SPEED_10KHZ, NVAPI_I2C_SPEED_33KHZ,
NVAPI_I2C_SPEED_100KHZ, NVAPI_I2C_SPEED_200KHZ, NVAPI_I2C_SPEED_400KHZ
}
enum NVAPI_GPU_WORKSTATION_FEATURE_MASK {
NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP = 0x00000001, NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO = 0x00000010, NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING = 0x00000100, NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY = 0x00000200,
NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE = 0x00000400, NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 = 0x00001000
}
enum | _NV_GPU_HDCP_FUSE_STATE { NV_GPU_HDCP_FUSE_STATE_UNKNOWN = 0, NV_GPU_HDCP_FUSE_STATE_DISABLED = 1, NV_GPU_HDCP_FUSE_STATE_ENABLED = 2 }
enum _NV_GPU_HDCP_KEY_SOURCE {
NV_GPU_HDCP_KEY_SOURCE_UNKNOWN = 0, NV_GPU_HDCP_KEY_SOURCE_NONE = 1, NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM = 2, NV_GPU_HDCP_KEY_SOURCE_SBIOS = 3,
NV_GPU_HDCP_KEY_SOURCE_I2C_ROM = 4, NV_GPU_HDCP_KEY_SOURCE_FUSES = 5
}
enum | _NV_GPU_HDCP_KEY_SOURCE_STATE { NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN = 0, NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT = 1, NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT = 2 }
enum | _NV_ECC_CONFIGURATION { NV_ECC_CONFIGURATION_NOT_SUPPORTED = 0, NV_ECC_CONFIGURATION_DEFERRED, NV_ECC_CONFIGURATION_IMMEDIATE }
enum | NV_GPU_WARPING_VERTICE_FORMAT { NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ = 0, NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ = 1 }
enum | NV_GPU_SCANOUT_COMPOSITION_PARAMETER { NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD = 0 }
enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE {
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT = 0, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR = 0x100, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR = 0x101, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED = 0x102,
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE = 0x103, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR = 0x104, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED = 0x105, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE = 0x106
}
enum _NVAPI_GPU_PERF_DECREASE {
NV_GPU_PERF_DECREASE_NONE = 0, NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION = 0x00000001, NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL = 0x00000002, NV_GPU_PERF_DECREASE_REASON_AC_BATT = 0x00000004,
NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED = 0x00000008, NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER = 0x00000010, NV_GPU_PERF_DECREASE_REASON_UNKNOWN = 0x80000000
}
enum | _NV_GPU_ILLUMINATION_ATTRIB { NV_GPU_IA_LOGO_BRIGHTNESS = 0, NV_GPU_IA_SLI_BRIGHTNESS = 1 }
enum NV_MOSAIC_TOPO_TYPE {
NV_MOSAIC_TOPO_TYPE_ALL, NV_MOSAIC_TOPO_TYPE_BASIC, NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO, NV_MOSAIC_TOPO_TYPE_SCALED_CLONE,
NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE, NV_MOSAIC_TOPO_TYPE_MAX
}
enum NV_MOSAIC_TOPO {
NV_MOSAIC_TOPO_NONE, NV_MOSAIC_TOPO_BEGIN_BASIC, NV_MOSAIC_TOPO_1x2_BASIC = NV_MOSAIC_TOPO_BEGIN_BASIC, NV_MOSAIC_TOPO_2x1_BASIC,
NV_MOSAIC_TOPO_1x3_BASIC, NV_MOSAIC_TOPO_3x1_BASIC, NV_MOSAIC_TOPO_1x4_BASIC, NV_MOSAIC_TOPO_4x1_BASIC,
NV_MOSAIC_TOPO_2x2_BASIC, NV_MOSAIC_TOPO_2x3_BASIC, NV_MOSAIC_TOPO_2x4_BASIC, NV_MOSAIC_TOPO_3x2_BASIC,
NV_MOSAIC_TOPO_4x2_BASIC, NV_MOSAIC_TOPO_1x5_BASIC, NV_MOSAIC_TOPO_1x6_BASIC, NV_MOSAIC_TOPO_7x1_BASIC,
NV_MOSAIC_TOPO_END_BASIC = NV_MOSAIC_TOPO_7x1_BASIC + 9, NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO, NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO = NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO, NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO,
NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO, NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO, NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO, NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO,
NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO, NV_MOSAIC_TOPO_END_PASSIVE_STEREO = NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO + 4, NV_MOSAIC_TOPO_MAX
}
enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR {
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE = 0, NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY = 1, NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY = 2, NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY = 3,
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY = 4
}
enum | _NVAPI_GSYNC_DISPLAY_SYNC_STATE { NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED = 0, NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE = 1, NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER = 2 }
enum | _NVAPI_GSYNC_POLARITY { NVAPI_GSYNC_POLARITY_RISING_EDGE = 0, NVAPI_GSYNC_POLARITY_FALLING_EDGE = 1, NVAPI_GSYNC_POLARITY_BOTH_EDGES = 2 }
enum _NVAPI_GSYNC_VIDEO_MODE {
NVAPI_GSYNC_VIDEO_MODE_NONE = 0, NVAPI_GSYNC_VIDEO_MODE_TTL = 1, NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM = 2, NVAPI_GSYNC_VIDEO_MODE_HDTV = 3,
NVAPI_GSYNC_VIDEO_MODE_COMPOSITE = 4
}
enum | _NVAPI_GSYNC_SYNC_SOURCE { NVAPI_GSYNC_SYNC_SOURCE_VSYNC = 0, NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC = 1 }
enum | _NVAPI_GSYNC_DELAY_TYPE { NVAPI_GSYNC_DELAY_TYPE_UNKNOWN = 0, NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW = 1, NVAPI_GSYNC_DELAY_TYPE_STARTUP = 2 }
enum | _NVAPI_GSYNC_RJ45_IO { NVAPI_GSYNC_RJ45_OUTPUT = 0, NVAPI_GSYNC_RJ45_INPUT = 1, NVAPI_GSYNC_RJ45_UNUSED = 2 }
enum | NVAPI_ALIAS_SURFACE_FLAG { NVAPI_ALIAS_SURFACE_FLAG_NONE = 0x00000000, NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER = 0x00000001, NVAPI_ALIAS_SURFACE_FLAG_MASK = 0x00000001 }
enum _NV_STEREO_VIDEO_FORMAT {
NV_STEREO_VIDEO_FORMAT_NOT_STEREO = 0, NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR = 1, NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL = 2, NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR = 3,
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL = 4, NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR = 5, NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL = 6, NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR = 7,
NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET = 8, NV_STEREO_VIDEO_FORMAT_LAST = 9
}
enum | _NVAPI_D3D11_INSERTWFI_FLAG { NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI = 0x00000000, NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI = 0x00000001, NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI = 0x00000002 }
enum | NVAPI_QUAD_FILLMODE { NVAPI_QUAD_FILLMODE_DISABLED = 0, NVAPI_QUAD_FILLMODE_BBOX = 1, NVAPI_QUAD_FILLMODE_FULL_VIEWPORT = 2 }
enum _NV_SWIZZLE_MODE {
NV_SWIZZLE_POS_X = 0, NV_SWIZZLE_NEG_X = 1, NV_SWIZZLE_POS_Y = 2, NV_SWIZZLE_NEG_Y = 3,
NV_SWIZZLE_POS_Z = 4, NV_SWIZZLE_NEG_Z = 5, NV_SWIZZLE_POS_W = 6, NV_SWIZZLE_NEG_W = 7
}
enum | _NV_SWIZZLE_OFFSET { NV_SWIZZLE_OFFSET_X = 0, NV_SWIZZLE_OFFSET_Y = 4, NV_SWIZZLE_OFFSET_Z = 8, NV_SWIZZLE_OFFSET_W = 12 }
enum | _NV_FASTGS_FLAGS { NV_FASTGS_USE_VIEWPORT_MASK = 0x01, NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX = 0x02, NV_FASTGS_STRICT_API_ORDER = 0x04 }
enum | _NV_PSO_EXTENSION { NV_PSO_RASTER_EXTENSION = 0, NV_PSO_REQUEST_FASTGS_EXTENSION = 1, NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION = 3, NV_PSO_EXPLICIT_FASTGS_EXTENSION = 4 }
enum | _IMPLICIT_SLI_CONTROL { DISABLE_IMPLICIT_SLI = 0, ENABLE_IMPLICIT_SLI = 1 }
enum | _NV_StereoRegistryProfileType { NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE, NVAPI_STEREO_DX9_REGISTRY_PROFILE, NVAPI_STEREO_DX10_REGISTRY_PROFILE }
enum | _NV_StereoRegistryID { NVAPI_CONVERGENCE_ID, NVAPI_FRUSTUM_ADJUST_MODE_ID }
enum | _NV_FrustumAdjustMode { NVAPI_NO_FRUSTUM_ADJUST, NVAPI_FRUSTUM_STRETCH, NVAPI_FRUSTUM_CLEAR_EDGES }
enum | _NV_StereoSwapChainMode { NVAPI_STEREO_SWAPCHAIN_DEFAULT = 0, NVAPI_STEREO_SWAPCHAIN_STEREO = 1, NVAPI_STEREO_SWAPCHAIN_MONO = 2 }
enum | NV_CHIPSET_INFO_FLAGS { NV_CHIPSET_INFO_HYBRID = 0x00000001 }

Functions

NVAPI_INTERFACE NvAPI_Initialize ()
NVAPI_INTERFACE NvAPI_Unload ()
NVAPI_INTERFACE | NvAPI_GetErrorMessage (NvAPI_Status nr, NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GetInterfaceVersionString (NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GPU_GetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_SetDisplayConfig.") NVAPI_INTERFACE NvAPI_SetViewEx(NvDisplayHandle hNvDisplay
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_SYS_GetDriverAndBranchVersion.") NVAPI_INTERFACE NvAPI_GetDisplayDriverVersion(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask, NVAPI_OGLEXPERT_CALLBACK expertCallback)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask, NVAPI_OGLEXPERT_CALLBACK *pExpertCallback)
NVAPI_INTERFACE | NvAPI_EnumTCCPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_EnumLogicalGPUs (NvLogicalGpuHandle nvGPUHandle[NVAPI_MAX_LOGICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromDisplay (NvDisplayHandle hNvDisp, NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvPhysicalGpuHandle *pPhysicalGpu)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromDisplay (NvDisplayHandle hNvDisp, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromPhysicalGPU (NvPhysicalGpuHandle hPhysicalGPU, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromLogicalGPU (NvLogicalGpuHandle hLogicalGPU, NvPhysicalGpuHandle hPhysicalGPU[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GPU_GetGpuCoreCount (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pCount)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetAllDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetAllOutputs(NvPhysicalGpuHandle hPhysicalGpu
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetConnectedDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetConnectedOutputs(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetConnectedDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount,*pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GPU_GetAllDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount,*pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount)
NVAPI_INTERFACE | NvAPI_GPU_GetSystemType (NvPhysicalGpuHandle hPhysicalGpu, NV_SYSTEM_TYPE *pSystemType)
NVAPI_INTERFACE | NvAPI_GPU_GetActiveOutputs (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pOutputsMask)
NVAPI_INTERFACE | NvAPI_GPU_SetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
NVAPI_INTERFACE | NvAPI_GPU_GetOutputType (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NV_GPU_OUTPUT_TYPE *pOutputType)
NVAPI_INTERFACE | NvAPI_GPU_ValidateOutputCombination (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputsMask)
NVAPI_INTERFACE | NvAPI_GPU_GetFullName (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szName)
NVAPI_INTERFACE | NvAPI_GPU_GetPCIIdentifiers (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pDeviceId, NvU32 *pSubSystemId, NvU32 *pRevisionId, NvU32 *pExtDeviceId)
NVAPI_INTERFACE | NvAPI_GPU_GetGPUType (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_TYPE *pGpuType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusType (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_BUS_TYPE *pBusType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusId)
NVAPI_INTERFACE | NvAPI_GPU_GetBusSlotId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusSlotId)
NVAPI_INTERFACE | NvAPI_GPU_GetIRQ (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pIRQ)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosOEMRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosVersionString (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetAGPAperture (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentAGPRate (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pRate)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPCIEDownstreamWidth (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pWidth)
NVAPI_INTERFACE | NvAPI_GPU_GetPhysicalFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetVirtualFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetQuadroStatus (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pStatus)
NVAPI_INTERFACE | NvAPI_GPU_GetBoardInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_BOARD_INFO *pBoardInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetAllClockFrequencies (__in NvPhysicalGpuHandle hPhysicalGPU, __inout NV_GPU_CLOCK_FREQUENCIES *pClkFreqs)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 304. Instead, use NvAPI_GPU_GetPstates20.") NVAPI_INTERFACE NvAPI_GPU_GetPstatesInfoEx(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetPstates20 (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_PERF_PSTATES20_INFO *pPstatesInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPstate (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_PERF_PSTATE_ID *pCurrentPstate)
NVAPI_INTERFACE | NvAPI_GPU_GetDynamicPstatesInfoEx (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_DYNAMIC_PSTATES_INFO_EX *pDynamicPstatesInfoEx)
NVAPI_INTERFACE | NvAPI_GPU_GetThermalSettings (NvPhysicalGpuHandle hPhysicalGpu, NvU32 sensorIndex, NV_GPU_THERMAL_SETTINGS *pThermalSettings)
NVAPI_INTERFACE | NvAPI_I2CRead (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)
NVAPI_INTERFACE | NvAPI_I2CWrite (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureSetup (__in NvPhysicalGpuHandle hPhysicalGpu, __in NvU32 featureEnableMask, __in NvU32 featureDisableMask)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureQuery (__in NvPhysicalGpuHandle hPhysicalGpu, __out_opt NvU32 *pConfiguredFeatureMask, __out_opt NvU32 *pConsistentFeatureMask)
NVAPI_INTERFACE | NvAPI_GPU_GetHDCPSupportStatus (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_GET_HDCP_SUPPORT_STATUS *pGetHDCPSupportStatus)
NVAPI_INTERFACE | NvAPI_GPU_GetTachReading (NvPhysicalGpuHandle hPhysicalGPU, NvU32 *pValue)
NVAPI_INTERFACE | NvAPI_GPU_GetECCStatusInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_STATUS_INFO *pECCStatusInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_ERROR_INFO *pECCErrorInfo)
NVAPI_INTERFACE | NvAPI_GPU_ResetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bResetCurrent, NvU8 bResetAggregate)
NVAPI_INTERFACE | NvAPI_GPU_GetECCConfigurationInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_CONFIGURATION_INFO *pECCConfigurationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetECCConfiguration (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bEnable, NvU8 bEnableImmediately)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutIntensity (NvU32 displayId, NV_SCANOUT_INTENSITY_DATA *scanoutIntensityData, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutIntensityState (__in NvU32 displayId, __inout NV_SCANOUT_INTENSITY_STATE_DATA *scanoutIntensityStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutWarping (NvU32 displayId, NV_SCANOUT_WARPING_DATA *scanoutWarpingData, int *piMaxNumVertices, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutWarpingState (__in NvU32 displayId, __inout NV_SCANOUT_WARPING_STATE_DATA *scanoutWarpingStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutCompositionParameter (NvU32 displayId, NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE parameterValue, float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutCompositionParameter (__in NvU32 displayId, __in NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, __out NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE *parameterData, __out float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfiguration (NvU32 displayId, NvSBox *desktopRect, NvSBox *scanoutRect)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfigurationEx (__in NvU32 displayId, __inout NV_SCANOUT_INFORMATION *pScanoutInformation)
NVAPI_INTERFACE | NvAPI_GPU_GetPerfDecreaseInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NvU32 *pPerfDecrInfo)
NVAPI_INTERFACE | NvAPI_GPU_QueryIlluminationSupport (__inout NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM *pIlluminationSupportInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetIllumination (NV_GPU_GET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetIllumination (NV_GPU_SET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_EnumNvidiaDisplayHandle (NvU32 thisEnum, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_EnumNvidiaUnAttachedDisplayHandle (NvU32 thisEnum, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)
NVAPI_INTERFACE | NvAPI_CreateDisplayFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvDisplayHandle *pNvDisplay)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayHandle (const char *szDisplayName, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle (const char *szDisplayName, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayName (NvDisplayHandle NvDispHandle, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_GetUnAttachedAssociatedDisplayName (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_EnableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_DisableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_GetVBlankCounter (NvDisplayHandle hNvDisplay, NvU32 *pCounter)
NVAPI_INTERFACE | NvAPI_SetRefreshRateOverride (NvDisplayHandle hNvDisplay, NvU32 outputsMask, float refreshRate, NvU32 bSetDeferred)
NVAPI_INTERFACE | NvAPI_GetAssociatedDisplayOutputId (NvDisplayHandle hNvDisplay, NvU32 *pOutputId)
NVAPI_INTERFACE | NvAPI_GetDisplayPortInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_DISPLAY_PORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_SetDisplayPort (NvDisplayHandle hNvDisplay, NvU32 outputId, NV_DISPLAY_PORT_CONFIG *pCfg)
NVAPI_INTERFACE | NvAPI_GetHDMISupportInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_HDMI_SUPPORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_Disp_InfoFrameControl (__in NvU32 displayId, __inout NV_INFOFRAME_DATA *pInfoframeData)
NVAPI_INTERFACE | NvAPI_DISP_GetTiming (__in NvU32 displayId, __in NV_TIMING_INPUT *timingInput, __out NV_TIMING *pTiming)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorCapabilities (__in NvU32 displayId, __inout NV_MONITOR_CAPABILITIES *pMonitorCapabilities)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorColorCapabilities (__in NvU32 displayId, __inout_ecount_part_opt(*pColorCapsCount,*pColorCapsCount) NV_MONITOR_COLOR_CAPS *pMonitorColorCapabilities, __inout NvU32 *pColorCapsCount)
NVAPI_INTERFACE | NvAPI_DISP_EnumCustomDisplay (__in NvU32 displayId, __in NvU32 index, __inout NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_TryCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in_ecount(count) NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_DeleteCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_SaveCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NvU32 isThisOutputIdOnly, __in NvU32 isThisMonitorIdOnly)
NVAPI_INTERFACE | NvAPI_DISP_RevertCustomDisplayTrial (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_GetDisplayConfig.") NVAPI_INTERFACE NvAPI_GetView(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_GetSupportedViews (NvDisplayHandle hNvDisplay, NV_TARGET_VIEW_MODE *pTargetViews, NvU32 *pViewCount)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayIdByDisplayName (const char *displayName, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayConfig (__inout NvU32 *pathInfoCount, __out_ecount_full_opt(*pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo)
NVAPI_INTERFACE | NvAPI_DISP_SetDisplayConfig (__in NvU32 pathInfoCount, __in_ecount(pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_Mosaic_GetSupportedTopoInfo (NV_MOSAIC_SUPPORTED_TOPO_INFO *pSupportedTopoInfo, NV_MOSAIC_TOPO_TYPE type)
NVAPI_INTERFACE | NvAPI_Mosaic_GetTopoGroup (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_TOPO_GROUP *pTopoGroup)
NVAPI_INTERFACE | NvAPI_Mosaic_GetOverlapLimits (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pMinOverlapX, NvS32 *pMaxOverlapX, NvS32 *pMinOverlapY, NvS32 *pMaxOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_SetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 overlapX, NvS32 overlapY, NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_GetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pOverlapX, NvS32 *pOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_EnableCurrentTopo (NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_SetDisplayGrids (__in_ecount(gridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __in NvU32 gridCount, __in NvU32 setTopoFlags)
NVAPI_INTERFACE | NvAPI_Mosaic_ValidateDisplayGrids (__in NvU32 setTopoFlags, __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout_ecount_full(gridCount) NV_MOSAIC_DISPLAY_TOPO_STATUS *pTopoStatus, __in NvU32 gridCount)
NVAPI_INTERFACE | NvAPI_Mosaic_EnumDisplayModes (__in NV_MOSAIC_GRID_TOPO *pGridTopology, __inout_ecount_part_opt(*pDisplayCount,*pDisplayCount) NV_MOSAIC_DISPLAY_SETTING *pDisplaySettings, __inout NvU32 *pDisplayCount)
NVAPI_INTERFACE | NvAPI_Mosaic_EnumDisplayGrids (__inout_ecount_part_opt(*pGridCount,*pGridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout NvU32 *pGridCount)
NVAPI_INTERFACE | NvAPI_GetSupportedMosaicTopologies (NV_MOSAIC_SUPPORTED_TOPOLOGIES *pMosaicTopos)
NVAPI_INTERFACE | NvAPI_GetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo, NvU32 *pEnabled)
NVAPI_INTERFACE | NvAPI_SetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo)
NVAPI_INTERFACE | NvAPI_EnableCurrentMosaicTopology (NvU32 enable)
NVAPI_INTERFACE | NvAPI_GSync_EnumSyncDevices (__out NvGSyncDeviceHandle nvGSyncHandles[NVAPI_MAX_GSYNC_DEVICES], __out NvU32 *gsyncCount)
NVAPI_INTERFACE | NvAPI_GSync_QueryCapabilities (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CAPABILITIES *pNvGSyncCapabilities)
NVAPI_INTERFACE | NvAPI_GSync_GetTopology (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout_opt NvU32 *gsyncGpuCount, __inout_ecount_part_opt(*gsyncGpuCount,*gsyncGpuCount) NV_GSYNC_GPU *gsyncGPUs, __inout_opt NvU32 *gsyncDisplayCount, __inout_ecount_part_opt(*gsyncDisplayCount,*gsyncDisplayCount) NV_GSYNC_DISPLAY *gsyncDisplays)
NVAPI_INTERFACE | NvAPI_GSync_SetSyncStateSettings (__in NvU32 gsyncDisplayCount, __in_ecount(gsyncDisplayCount) NV_GSYNC_DISPLAY *pGsyncDisplays, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GSync_GetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_SetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_AdjustSyncDelay (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NVAPI_GSYNC_DELAY_TYPE delayType, __inout NV_GSYNC_DELAY *pGsyncDelay, __out_opt NvU32 *syncSteps)
NVAPI_INTERFACE | NvAPI_GSync_GetSyncStatus (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GSYNC_STATUS *status)
NVAPI_INTERFACE | NvAPI_GSync_GetStatusParameters (NvGSyncDeviceHandle hNvGSyncDevice, NV_GSYNC_STATUS_PARAMS *pStatusParams)
NVAPI_INTERFACE | NvAPI_D3D9_RegisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_UnregisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_AliasSurfaceAsTexture (IDirect3DDevice9 *pDev, IDirect3DSurface9 *pSurface, IDirect3DTexture9 **ppTexture, DWORD dwFlag)
NVAPI_INTERFACE | NvAPI_D3D9_StretchRectEx (IDirect3DDevice9 *pDevice, IDirect3DResource9 *pSourceResource, CONST RECT *pSourceRect, IDirect3DResource9 *pDestResource, CONST RECT *pDestRect, D3DTEXTUREFILTERTYPE Filter)
NVAPI_INTERFACE | NvAPI_D3D9_ClearRT (IDirect3DDevice9 *pDevice, NvU32 dwNumRects, CONST RECT *pRects, float r, float g, float b, float a)
NVAPI_INTERFACE | NvAPI_D3D9_GetSurfaceHandle (IDirect3DSurface9 *pSurface, NVDX_ObjectHandle *pHandle)
NVAPI_INTERFACE | NvAPI_D3D9_VideoSetStereoInfo (IDirect3DDevice9 *pDev, NV_DX_VIDEO_STEREO_INFO *pStereoInfo)
NVAPI_INTERFACE | NvAPI_D3D11_IsNvShaderExtnOpCodeSupported (__in IUnknown *pDev, __in NvU32 opCode, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D11_SetNvShaderExtnSlot (__in IUnknown *pDev, __in NvU32 uavSlot)
NVAPI_INTERFACE | NvAPI_D3D11_BeginUAVOverlapEx (__in IUnknown *pDeviceOrContext, __in NvU32 insertWFIFlags)
NVAPI_INTERFACE | NvAPI_D3D11_BeginUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D11_EndUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D_SetFPSIndicatorState (IUnknown *pDev, NvU8 doEnable)
NVAPI_INTERFACE | NvAPI_D3D11_CreateRasterizerState (__in ID3D11Device *pDevice, __in const NvAPI_D3D11_RASTERIZER_DESC_EX *pRasterizerDesc, __out ID3D11RasterizerState **ppRasterizerState)
NVAPI_INTERFACE | NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA (__in ID3D11Device *pDevice, __in ID3D11Texture2D *pInputTex, __out ID3D11Texture2D **ppOutTex)
NVAPI_INTERFACE | NvAPI_D3D11_CreateFastGeometryShaderExplicit (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC *pCreateFastGSArgs, __out ID3D11GeometryShader **ppGeometryShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateFastGeometryShader (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __out ID3D11GeometryShader **ppGeometryShader)
NVAPI_INTERFACE | NvAPI_D3D12_CreateGraphicsPipelineState (__in ID3D12Device *pDevice, __in const D3D12_GRAPHICS_PIPELINE_STATE_DESC *pPSODesc, NvU32 numExtensions, __in const NVAPI_D3D12_PSO_EXTENSION_DESC **ppExtensions, __out ID3D12PipelineState **ppPSO)
NVAPI_INTERFACE | NvAPI_D3D12_SetDepthBoundsTestValues (__in ID3D12GraphicsCommandList *pCommandList, __in const float minDepth, __in const float maxDepth)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncCapable (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncCapable)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncActive (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncActive)
NVAPI_INTERFACE | NvAPI_D3D1x_DisableShaderDiskCache (IUnknown *pDevice)
NVAPI_INTERFACE | NvAPI_D3D1x_HintCreateLowLatencyDevice (bool bCreateLowLatencyDevice)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_GetCaps (__out PNV_MULTIGPU_CAPS pMultiGPUCaps)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_Init (__in bool bEnable)
DECLARE_INTERFACE (ID3D11MultiGPUDevice_V1)
NVAPI_INTERFACE | NvAPI_D3D11_CreateMultiGPUDevice (__in ID3D11Device *pDevice, __in ULONG version, __out ULONG *currentVersion, __out ID3D11MultiGPUDevice **ppD3D11MultiGPUDevice, __in UINT maxGpus=ALL_GPUS)
NVAPI_INTERFACE | NvAPI_D3D_RegisterDevice (__in IUnknown *pDev)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawIndexedInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D_ImplicitSLIControl (__in IMPLICIT_SLI_CONTROL implicitSLIControl)
NVAPI_INTERFACE | NvAPI_D3D1x_GetLowLatencySupport (__in LUID pAdapterId, __out BOOL *pIsLowLatencySupported)
NVAPI_INTERFACE | NvAPI_Stereo_CreateConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_SetConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID, void *pValue)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID)
NVAPI_INTERFACE | NvAPI_Stereo_GetStereoSupport (__in NvMonitorHandle hMonitor, __out NVAPI_STEREO_CAPS *pCaps)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_GetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE *pFrustumAdjustMode)
NVAPI_INTERFACE | NvAPI_Stereo_SetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE newFrustumAdjustModeValue)
NVAPI_INTERFACE | NvAPI_Stereo_CaptureJpegImage (StereoHandle stereoHandle, NvU32 quality)
NVAPI_INTERFACE | NvAPI_Stereo_Trigger_Activation (__in StereoHandle hStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_CapturePngImage (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_ReverseStereoBlitControl (StereoHandle hStereoHandle, NvU8 TurnOn)
NVAPI_INTERFACE | NvAPI_Stereo_SetNotificationMessage (StereoHandle hStereoHandle, NvU64 hWnd, NvU64 messageID)
NVAPI_INTERFACE | NvAPI_D3D1x_CreateSwapChain (StereoHandle hStereoHandle, DXGI_SWAP_CHAIN_DESC *pDesc, IDXGISwapChain **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NVAPI_INTERFACE | NvAPI_D3D9_CreateSwapChain (StereoHandle hStereoHandle, D3DPRESENT_PARAMETERS *pPresentationParameters, IDirect3DSwapChain9 **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NVAPI_INTERFACE | NvAPI_DRS_CreateProfile (NvDRSSessionHandle hSession, NVDRS_PROFILE *pProfileInfo, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_SetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvAPI_UnicodeString wszGlobalProfileName)
NVAPI_INTERFACE | NvAPI_DRS_GetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_SetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_FindProfileByName (NvDRSSessionHandle hSession, NvAPI_UnicodeString profileName, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_EnumProfiles (NvDRSSessionHandle hSession, NvU32 index, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetNumProfiles (NvDRSSessionHandle hSession, NvU32 *numProfiles)
NVAPI_INTERFACE | NvAPI_DRS_CreateApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplicationEx (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApp)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName)
NVAPI_INTERFACE | NvAPI_DRS_GetApplicationInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_EnumApplications (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *appCount, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_FindApplicationByName (__in NvDRSSessionHandle hSession, __in NvAPI_UnicodeString appName, __out NvDRSProfileHandle *phProfile, __inout NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_SetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_GetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumSettings (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *settingsCount, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingIds (NvU32 *pSettingIds, NvU32 *pMaxCount)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingValues (NvU32 settingId, NvU32 *pMaxNumValues, NVDRS_SETTING_VALUES *pSettingValues)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingIdFromName (NvAPI_UnicodeString settingName, NvU32 *pSettingId)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingNameFromId (NvU32 settingId, NvAPI_UnicodeString *pSettingName)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfileSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_RestoreAllDefaults (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefault (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefaultSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_GetBaseProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_SYS_GetChipSetInfo (NV_CHIPSET_INFO *pChipSetInfo)
NVAPI_INTERFACE | NvAPI_SYS_GetLidAndDockInfo (NV_LID_DOCK_PARAMS *pLidAndDock)
NVAPI_INTERFACE | NvAPI_SYS_GetDisplayIdFromGpuAndOutputId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_SYS_GetGpuAndOutputIdFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu, NvU32 *outputId)
NVAPI_INTERFACE | NvAPI_SYS_GetPhysicalGpuFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu)
NvAPI_OGL_ExpertModeDefaultsSet[Get] Functions
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask)
NVAPI_INTERFACE | NvAPI_VIO_GetPCIInfo (__in NvVioHandle hVioHandle, __inout NVVIOPCIINFO *pVioPCIInfo)
NVAPI_INTERFACE | NvAPI_VIO_IsRunning (NvVioHandle hVioHandle)
NVAPI_INTERFACE | NvAPI_VIO_Start (NvVioHandle hVioHandle)
NVAPI_INTERFACE | NvAPI_VIO_Stop (NvVioHandle hVioHandle)
NVAPI_INTERFACE | NvAPI_VIO_IsFrameLockModeCompatible (NvVioHandle hVioHandle, NvU32 srcEnumIndex, NvU32 destEnumIndex, NvU32 *pbCompatible)
NVAPI_INTERFACE | NvAPI_VIO_EnumDevices (NvVioHandle hVioHandle[NVAPI_MAX_VIO_DEVICES], NvU32 *vioDeviceCount)
NVAPI_INTERFACE | NvAPI_VIO_QueryTopology (NV_VIO_TOPOLOGY *pNvVIOTopology)
NVAPI_INTERFACE | NvAPI_VIO_EnumSignalFormats (NvVioHandle hVioHandle, NvU32 enumIndex, NVVIOSIGNALFORMATDETAIL *pSignalFormatDetail)
NVAPI_INTERFACE | NvAPI_VIO_EnumDataFormats (NvVioHandle hVioHandle, NvU32 enumIndex, NVVIODATAFORMATDETAIL *pDataFormatDetail)

Variables

NV_VIEW_TARGET_INFO * pTargetInfo
NV_VIEW_TARGET_INFO
NV_TARGET_VIEW_MODE 		targetView
NV_DISPLAY_PATH_INFO * pPathInfo
NV_DISPLAY_PATH_INFO
NV_TARGET_VIEW_MODE 		displayView
NV_DISPLAY_DRIVER_VERSION * pVersion
NvU32 * pOutputsMask
NV_GPU_PERF_PSTATES_INFO * pPerfPstatesInfo
NV_GPU_PERF_PSTATES_INFO NvU32 inputFlags
NV_VIEW_TARGET_INFO * pTargets
NV_VIEW_TARGET_INFO NvU32 * pTargetMaskCount
NV_VIEW_TARGET_INFO NvU32
NV_TARGET_VIEW_MODE * 		pTargetView
NV_DISPLAY_PATH_INFO NvU32 * pPathCount
NV_DISPLAY_PATH_INFO NvU32
NV_TARGET_VIEW_MODE * 		pTargetViewMode
#define | NV_EDID_V1_DATA_SIZE 256
#define | NV_EDID_DATA_SIZE NV_EDID_V1_DATA_SIZE
#define | NV_EDID_VER1 MAKE_NVAPI_VERSION(NV_EDID_V1,1)
#define | NV_EDID_VER2 MAKE_NVAPI_VERSION(NV_EDID_V2,2)
#define | NV_EDID_VER3 MAKE_NVAPI_VERSION(NV_EDID_V3,3)
#define | NV_EDID_VER NV_EDID_VER3
typedef NV_EDID_V3 | NV_EDID
#define | NVAPI_MAX_VIEW_TARGET 2
#define | NVAPI_ADVANCED_MAX_VIEW_TARGET 4
#define | _NV_TARGET_VIEW_MODE_
enum _NV_TARGET_VIEW_MODE {
NV_VIEW_MODE_STANDARD = 0, NV_VIEW_MODE_CLONE = 1, NV_VIEW_MODE_HSPAN = 2, NV_VIEW_MODE_VSPAN = 3,
NV_VIEW_MODE_DUALVIEW = 4, NV_VIEW_MODE_MULTIVIEW = 5
}
typedef enum _NV_TARGET_VIEW_MODE | NV_TARGET_VIEW_MODE
#define | NV_INFOFRAME_DATA_VER MAKE_NVAPI_VERSION(NV_INFOFRAME_DATA,1)
enum NV_INFOFRAME_CMD {
NV_INFOFRAME_CMD_GET_DEFAULT = 0, NV_INFOFRAME_CMD_RESET, NV_INFOFRAME_CMD_GET, NV_INFOFRAME_CMD_SET,
NV_INFOFRAME_CMD_GET_OVERRIDE, NV_INFOFRAME_CMD_SET_OVERRIDE, NV_INFOFRAME_CMD_GET_PROPERTY, NV_INFOFRAME_CMD_SET_PROPERTY
}
enum | NV_INFOFRAME_PROPERTY_MODE { NV_INFOFRAME_PROPERTY_MODE_AUTO = 0, NV_INFOFRAME_PROPERTY_MODE_ENABLE, NV_INFOFRAME_PROPERTY_MODE_DISABLE, NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE }
enum | NV_INFOFRAME_PROPERTY_BLACKLIST { NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE = 0, NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE }
enum NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO {
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA = 0, NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN, NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN, NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE,
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA {
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT = 0, NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT, NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT, NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT,
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO = 7
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO { NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT = 0, NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT, NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT {
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB = 0, NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422, NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444, NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE,
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO = 7
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_F17 { NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE = 0, NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE, NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION {
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD = 0, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME = 8, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME {
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA = 0, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9, NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY {
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA = 0, NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M, NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709, NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY,
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING {
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA = 0, NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL, NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL, NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH,
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION {
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT = 0, NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE, NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE, NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED,
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY {
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601 = 0, NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709, NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601, NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601,
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB, NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05, NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06, NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07,
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO = 15
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_ITC { NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT = 0, NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT, NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION {
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE = 0, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14, NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE {
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS = 0, NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO, NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA, NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME,
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION {
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE = 0, NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE, NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02, NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03,
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO = 15
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY {
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ, NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO = 15
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30, NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO = 63
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL = 0X31, NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO = 0x1FF
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL {
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES {
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB, NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO = 31
}
enum | NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX { NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED = 0, NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED, NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO = 3 }
#define | NV_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V1, 1)
#define | NV_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V2, 2)
#define | NV_COLOR_DATA_VER3 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V3, 3)
#define | NV_COLOR_DATA_VER NV_COLOR_DATA_VER3
enum | NV_COLOR_CMD { NV_COLOR_CMD_GET = 1, NV_COLOR_CMD_SET, NV_COLOR_CMD_IS_SUPPORTED_COLOR, NV_COLOR_CMD_GET_DEFAULT }
enum NV_COLOR_FORMAT {
NV_COLOR_FORMAT_RGB = 0, NV_COLOR_FORMAT_YUV422, NV_COLOR_FORMAT_YUV444, NV_COLOR_FORMAT_YUV420,
NV_COLOR_FORMAT_DEFAULT = 0xFE, NV_COLOR_FORMAT_AUTO = 0xFF
}
enum NV_COLOR_COLORIMETRY {
NV_COLOR_COLORIMETRY_RGB = 0, NV_COLOR_COLORIMETRY_YCC601, NV_COLOR_COLORIMETRY_YCC709, NV_COLOR_COLORIMETRY_XVYCC601,
NV_COLOR_COLORIMETRY_XVYCC709, NV_COLOR_COLORIMETRY_SYCC601, NV_COLOR_COLORIMETRY_ADOBEYCC601, NV_COLOR_COLORIMETRY_ADOBERGB,
NV_COLOR_COLORIMETRY_BT2020RGB, NV_COLOR_COLORIMETRY_BT2020YCC, NV_COLOR_COLORIMETRY_BT2020cYCC, NV_COLOR_COLORIMETRY_DEFAULT = 0xFE,
NV_COLOR_COLORIMETRY_AUTO = 0xFF
}
enum | _NV_DYNAMIC_RANGE { NV_DYNAMIC_RANGE_VESA = 0x0, NV_DYNAMIC_RANGE_CEA = 0x1, NV_DYNAMIC_RANGE_AUTO = 0xFF }
enum _NV_BPC {
NV_BPC_DEFAULT = 0, NV_BPC_6 = 1, NV_BPC_8 = 2, NV_BPC_10 = 3,
NV_BPC_12 = 4, NV_BPC_16 = 5
}
typedef enum _NV_DYNAMIC_RANGE | NV_DYNAMIC_RANGE
typedef enum _NV_BPC | NV_BPC
typedef struct _NV_COLOR_DATA_V1 | NV_COLOR_DATA_V1
typedef struct _NV_COLOR_DATA_V2 | NV_COLOR_DATA_V2
typedef struct _NV_COLOR_DATA_V3 | NV_COLOR_DATA_V3
typedef NV_COLOR_DATA_V3 | NV_COLOR_DATA
NVAPI_INTERFACE | NvAPI_Disp_ColorControl (NvU32 displayId, NV_COLOR_DATA *pColorData)
#define | NV_MONITOR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_CAPABILITIES_V1,1)
#define | NV_MONITOR_CAPABILITIES_VER NV_MONITOR_CAPABILITIES_VER1
enum | NV_MONITOR_CAPS_TYPE { NV_MONITOR_CAPS_TYPE_HDMI_VSDB = 0x1000, NV_MONITOR_CAPS_TYPE_HDMI_VCDB = 0x1001 }
typedef struct
_NV_MONITOR_CAPS_VCDB 		NV_MONITOR_CAPS_VCDB
typedef struct
_NV_MONITOR_CAPS_VSDB 		NV_MONITOR_CAPS_VSDB
typedef struct
_NV_MONITOR_CAPABILITIES_V1 		NV_MONITOR_CAPABILITIES_V1
typedef NV_MONITOR_CAPABILITIES_V1 | NV_MONITOR_CAPABILITIES
#define | NV_MOSAIC_GRID_TOPO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V1,1)
#define | NV_MOSAIC_GRID_TOPO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V2,2)
#define | NV_MOSAIC_GRID_TOPO_VER NV_MOSAIC_GRID_TOPO_VER2
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU NV_BIT(0)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR NV_BIT(1)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS NV_BIT(2)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE NV_BIT(3)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE NV_BIT(4)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED NV_BIT(5)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY NV_BIT(6)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED NV_BIT(7)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE NV_BIT(8)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED NV_BIT(9)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED NV_BIT(10)
enum | _NV_PIXEL_SHIFT_TYPE { NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT = 0, NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS = 1, NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS = 2 }
typedef struct
_NV_MOSAIC_GRID_TOPO_DISPLAY_V1 		NV_MOSAIC_GRID_TOPO_DISPLAY_V1
typedef enum _NV_PIXEL_SHIFT_TYPE | NV_PIXEL_SHIFT_TYPE
typedef struct
_NV_MOSAIC_GRID_TOPO_DISPLAY_V2 		NV_MOSAIC_GRID_TOPO_DISPLAY_V2
typedef
NV_MOSAIC_GRID_TOPO_DISPLAY_V1 		NV_MOSAIC_GRID_TOPO_DISPLAY
typedef struct
_NV_MOSAIC_GRID_TOPO_V1 		NV_MOSAIC_GRID_TOPO_V1
typedef struct
_NV_MOSAIC_GRID_TOPO_V2 		NV_MOSAIC_GRID_TOPO_V2
typedef NV_MOSAIC_GRID_TOPO_V2 | NV_MOSAIC_GRID_TOPO
#define | NVVIOOWNERID_NONE 0
#define | NVVIO_O_READ 0x00000000
#define | NVVIO_O_WRITE_EXCLUSIVE 0x00010001
#define | NVVIO_VALID_ACCESSRIGHTS
#define | NVVIO_OWNERID_INITIALIZED 0x80000000
#define | NVVIO_OWNERID_EXCLUSIVE 0x40000000
#define | NVVIO_OWNERID_TYPEMASK 0x0FFFFFFF
enum | _NVVIOOWNERTYPE { NVVIOOWNERTYPE_NONE, NVVIOOWNERTYPE_APPLICATION, NVVIOOWNERTYPE_DESKTOP }
typedef enum _NVVIOOWNERTYPE | NVVIOOWNERTYPE
#define | NVAPI_MAX_VIO_DEVICES 8
#define | NVAPI_MAX_VIO_JACKS 4
#define | NVAPI_MAX_VIO_CHANNELS_PER_JACK 2
#define | NVAPI_MAX_VIO_STREAMS 4
#define | NVAPI_MIN_VIO_STREAMS 1
#define | NVAPI_MAX_VIO_LINKS_PER_STREAM 2
#define | NVAPI_MAX_FRAMELOCK_MAPPING_MODES 20
#define | NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES 1
#define | NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES 32
#define | NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES 5
enum _NVVIOSIGNALFORMAT {
NVVIOSIGNALFORMAT_NONE, NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC, NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL, NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260,
NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260, NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295, NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274, NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274,
NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274, NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274, NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274, NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274, NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274, NVVIOSIGNALFORMAT_720P_60_00_SMPTE296, NVVIOSIGNALFORMAT_720P_59_94_SMPTE296,
NVVIOSIGNALFORMAT_720P_50_00_SMPTE296, NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274, NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274, NVVIOSIGNALFORMAT_720P_30_00_SMPTE296,
NVVIOSIGNALFORMAT_720P_29_97_SMPTE296, NVVIOSIGNALFORMAT_720P_25_00_SMPTE296, NVVIOSIGNALFORMAT_720P_24_00_SMPTE296, NVVIOSIGNALFORMAT_720P_23_98_SMPTE296,
NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372, NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372, NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372, NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372,
NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372, NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372, NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372, NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372,
NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372, NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372, NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274, NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274,
NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274, NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274, NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274, NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A, NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A, NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B,
NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B,
NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B,
NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B, NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B,
NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B, NVVIOSIGNALFORMAT_END
}
enum _NVVIOVIDEOSTANDARD {
NVVIOVIDEOSTANDARD_SMPTE259, NVVIOVIDEOSTANDARD_SMPTE260, NVVIOVIDEOSTANDARD_SMPTE274, NVVIOVIDEOSTANDARD_SMPTE295,
NVVIOVIDEOSTANDARD_SMPTE296, NVVIOVIDEOSTANDARD_SMPTE372
}
enum | _NVVIOVIDEOTYPE { NVVIOVIDEOTYPE_SD, NVVIOVIDEOTYPE_HD }
enum | _NVVIOINTERLACEMODE { NVVIOINTERLACEMODE_PROGRESSIVE, NVVIOINTERLACEMODE_INTERLACE, NVVIOINTERLACEMODE_PSF }
enum _NVVIODATAFORMAT {
NVVIODATAFORMAT_UNKNOWN = -1, NVVIODATAFORMAT_R8G8B8_TO_YCRCB444, NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444, NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444,
NVVIODATAFORMAT_R8G8B8_TO_YCRCB422, NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224, NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224, NVVIODATAFORMAT_X8X8X8_444_PASSTHRU,
NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU, NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU, NVVIODATAFORMAT_X10X10X10_444_PASSTHRU, NVVIODATAFORMAT_X10X8X8_444_PASSTHRU,
NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU, NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU, NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422, NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU,
NVVIODATAFORMAT_R10G10B10_TO_YCRCB422, NVVIODATAFORMAT_R10G10B10_TO_YCRCB444, NVVIODATAFORMAT_X12X12X12_444_PASSTHRU, NVVIODATAFORMAT_X12X12X12_422_PASSTHRU,
NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422, NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422, NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224, NVVIODATAFORMAT_R10G10B10_TO_RGB444,
NVVIODATAFORMAT_R12G12B12_TO_YCRCB444, NVVIODATAFORMAT_R12G12B12_TO_YCRCB422
}
enum | _NVVIOOUTPUTAREA { NVVIOOUTPUTAREA_FULLSIZE, NVVIOOUTPUTAREA_SAFEACTION, NVVIOOUTPUTAREA_SAFETITLE }
enum | _NVVIOSYNCSOURCE { NVVIOSYNCSOURCE_SDISYNC, NVVIOSYNCSOURCE_COMPSYNC }
enum | _NVVIOCOMPSYNCTYPE { NVVIOCOMPSYNCTYPE_AUTO, NVVIOCOMPSYNCTYPE_BILEVEL, NVVIOCOMPSYNCTYPE_TRILEVEL }
enum | _NVVIOINPUTOUTPUTSTATUS { NVINPUTOUTPUTSTATUS_OFF, NVINPUTOUTPUTSTATUS_ERROR, NVINPUTOUTPUTSTATUS_SDI_SD, NVINPUTOUTPUTSTATUS_SDI_HD }
enum _NVVIOSYNCSTATUS {
NVVIOSYNCSTATUS_OFF, NVVIOSYNCSTATUS_ERROR, NVVIOSYNCSTATUS_SYNCLOSS, NVVIOSYNCSTATUS_COMPOSITE,
NVVIOSYNCSTATUS_SDI_SD, NVVIOSYNCSTATUS_SDI_HD
}
enum | _NVVIOCAPTURESTATUS { NVVIOSTATUS_STOPPED, NVVIOSTATUS_RUNNING, NVVIOSTATUS_ERROR }
enum | _NVVIOSTATUSTYPE { NVVIOSTATUSTYPE_IN, NVVIOSTATUSTYPE_OUT }
enum | _NVVIOCONFIGTYPE { NVVIOCONFIGTYPE_IN, NVVIOCONFIGTYPE_OUT }
enum _NVVIOCOLORSPACE {
NVVIOCOLORSPACE_UNKNOWN, NVVIOCOLORSPACE_YCBCR, NVVIOCOLORSPACE_YCBCRA, NVVIOCOLORSPACE_YCBCRD,
NVVIOCOLORSPACE_GBR, NVVIOCOLORSPACE_GBRA, NVVIOCOLORSPACE_GBRD
}
enum _NVVIOCOMPONENTSAMPLING {
NVVIOCOMPONENTSAMPLING_UNKNOWN, NVVIOCOMPONENTSAMPLING_4444, NVVIOCOMPONENTSAMPLING_4224, NVVIOCOMPONENTSAMPLING_444,
NVVIOCOMPONENTSAMPLING_422
}
enum | _NVVIOBITSPERCOMPONENT { NVVIOBITSPERCOMPONENT_UNKNOWN, NVVIOBITSPERCOMPONENT_8, NVVIOBITSPERCOMPONENT_10, NVVIOBITSPERCOMPONENT_12 }
enum _NVVIOLINKID {
NVVIOLINKID_UNKNOWN, NVVIOLINKID_A, NVVIOLINKID_B, NVVIOLINKID_C,
NVVIOLINKID_D
}
enum | _NVVIOANCPARITYCOMPUTATION { NVVIOANCPARITYCOMPUTATION_AUTO, NVVIOANCPARITYCOMPUTATION_ON, NVVIOANCPARITYCOMPUTATION_OFF }
typedef enum _NVVIOSIGNALFORMAT | NVVIOSIGNALFORMAT
typedef enum _NVVIOVIDEOSTANDARD | NVVIOVIDEOSTANDARD
typedef enum _NVVIOVIDEOTYPE | NVVIOVIDEOTYPE
typedef enum _NVVIOINTERLACEMODE | NVVIOINTERLACEMODE
typedef enum _NVVIODATAFORMAT | NVVIODATAFORMAT
typedef enum _NVVIOOUTPUTAREA | NVVIOOUTPUTAREA
typedef enum _NVVIOSYNCSOURCE | NVVIOSYNCSOURCE
typedef enum _NVVIOCOMPSYNCTYPE | NVVIOCOMPSYNCTYPE
typedef enum
_NVVIOINPUTOUTPUTSTATUS 		NVVIOINPUTOUTPUTSTATUS
typedef enum _NVVIOSYNCSTATUS | NVVIOSYNCSTATUS
typedef enum _NVVIOCAPTURESTATUS | NVVIOCAPTURESTATUS
typedef enum _NVVIOSTATUSTYPE | NVVIOSTATUSTYPE
typedef enum _NVVIOCONFIGTYPE | NVVIOCONFIGTYPE
typedef enum _NVVIOCOLORSPACE | NVVIOCOLORSPACE
typedef enum
_NVVIOCOMPONENTSAMPLING 		NVVIOCOMPONENTSAMPLING
typedef enum _NVVIOBITSPERCOMPONENT | NVVIOBITSPERCOMPONENT
typedef enum _NVVIOLINKID | NVVIOLINKID
typedef enum
_NVVIOANCPARITYCOMPUTATION 		NVVIOANCPARITYCOMPUTATION
#define | NVVIOCAPS_VIDOUT_SDI 0x00000001
#define | NVVIOCAPS_SYNC_INTERNAL 0x00000100
#define | NVVIOCAPS_SYNC_GENLOCK 0x00000200
#define | NVVIOCAPS_SYNCSRC_SDI 0x00001000
#define | NVVIOCAPS_SYNCSRC_COMP 0x00002000
#define | NVVIOCAPS_OUTPUTMODE_DESKTOP 0x00010000
#define | NVVIOCAPS_OUTPUTMODE_OPENGL 0x00020000
#define | NVVIOCAPS_VIDIN_SDI 0x00100000
#define | NVVIOCAPS_PACKED_ANC_SUPPORTED 0x00200000
#define | NVVIOCAPS_AUDIO_BLANKING_SUPPORTED 0x00400000
#define | NVVIOCLASS_SDI 0x00000001
#define | NVVIOCAPS_VER1 MAKE_NVAPI_VERSION(NVVIOCAPS,1)
#define | NVVIOCAPS_VER2 MAKE_NVAPI_VERSION(NVVIOCAPS,2)
#define | NVVIOCAPS_VER NVVIOCAPS_VER2
#define | NVVIOSTATUS_VER MAKE_NVAPI_VERSION(NVVIOSTATUS,1)
#define | NVVIOSYNCDELAY_VER MAKE_NVAPI_VERSION(NVVIOSYNCDELAY,1)
#define | NVVIOBUFFERFORMAT_R8G8B8 0x00000001
#define | NVVIOBUFFERFORMAT_R8G8B8Z24 0x00000002
#define | NVVIOBUFFERFORMAT_R8G8B8A8 0x00000004
#define | NVVIOBUFFERFORMAT_R8G8B8A8Z24 0x00000008
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FP 0x00000010
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 0x00000020
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP 0x00000040
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 0x00000080
#define | NVVIOCOLORCONVERSION_VER MAKE_NVAPI_VERSION(NVVIOCOLORCONVERSION,1)
#define | NVVIOGAMMACORRECTION_VER MAKE_NVAPI_VERSION(NVVIOGAMMACORRECTION,1)
#define | MAX_NUM_COMPOSITE_RANGE 2
#define | NVVIOCONFIG_SIGNALFORMAT 0x00000001
#define | NVVIOCONFIG_DATAFORMAT 0x00000002
#define | NVVIOCONFIG_OUTPUTREGION 0x00000004
#define | NVVIOCONFIG_OUTPUTAREA 0x00000008
#define | NVVIOCONFIG_COLORCONVERSION 0x00000010
#define | NVVIOCONFIG_GAMMACORRECTION 0x00000020
#define | NVVIOCONFIG_SYNCSOURCEENABLE 0x00000040
#define | NVVIOCONFIG_SYNCDELAY 0x00000080
#define | NVVIOCONFIG_COMPOSITESYNCTYPE 0x00000100
#define | NVVIOCONFIG_FRAMELOCKENABLE 0x00000200
#define | NVVIOCONFIG_422FILTER 0x00000400
#define | NVVIOCONFIG_COMPOSITETERMINATE 0x00000800
#define | NVVIOCONFIG_DATAINTEGRITYCHECK 0x00001000
#define | NVVIOCONFIG_CSCOVERRIDE 0x00002000
#define | NVVIOCONFIG_FLIPQUEUELENGTH 0x00004000
#define | NVVIOCONFIG_ANCTIMECODEGENERATION 0x00008000
#define | NVVIOCONFIG_COMPOSITE 0x00010000
#define | NVVIOCONFIG_ALPHAKEYCOMPOSITE 0x00020000
#define | NVVIOCONFIG_COMPOSITE_Y 0x00040000
#define | NVVIOCONFIG_COMPOSITE_CR 0x00080000
#define | NVVIOCONFIG_COMPOSITE_CB 0x00100000
#define | NVVIOCONFIG_FULL_COLOR_RANGE 0x00200000
#define | NVVIOCONFIG_RGB_DATA 0x00400000
#define | NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE 0x00800000
#define | NVVIOCONFIG_STREAMS 0x01000000
#define | NVVIOCONFIG_ANC_PARITY_COMPUTATION 0x02000000
#define | NVVIOCONFIG_ANC_AUDIO_REPEAT 0x04000000
#define | NVVIOCONFIG_ALLFIELDS
#define | NVVIOCONFIG_VALIDFIELDS
#define | NVVIOCONFIG_DRIVERFIELDS
#define | NVVIOCONFIG_GAMMAFIELDS ( NVVIOCONFIG_GAMMACORRECTION )
#define | NVVIOCONFIG_RMCTRLFIELDS
#define | NVVIOCONFIG_RMSKEWFIELDS ( NVVIOCONFIG_SYNCDELAY )
#define | NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS
#define | NVVIOCONFIG_RMMODESET_FIELDS
#define | NVVIOCONFIG_VER1 MAKE_NVAPI_VERSION(NVVIOCONFIG_V1,1)
#define | NVVIOCONFIG_VER2 MAKE_NVAPI_VERSION(NVVIOCONFIG_V2,2)
#define | NVVIOCONFIG_VER3 MAKE_NVAPI_VERSION(NVVIOCONFIG_V3,3)
#define | NVVIOCONFIG_VER NVVIOCONFIG_VER3
#define | NV_VIO_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_VIO_TOPOLOGY,1)
#define | NVVIOTOPOLOGY_VER MAKE_NVAPI_VERSION(NVVIOTOPOLOGY,1)
typedef struct _NVVIOCAPS | NVVIOCAPS
typedef struct _NVVIOCHANNELSTATUS | NVVIOCHANNELSTATUS
typedef struct _NVVIOINPUTSTATUS | NVVIOINPUTSTATUS
typedef struct _NVVIOOUTPUTSTATUS | NVVIOOUTPUTSTATUS
typedef struct _NVVIOSTATUS | NVVIOSTATUS
typedef struct _NVVIOOUTPUTREGION | NVVIOOUTPUTREGION
typedef struct _NVVIOGAMMARAMP8 | NVVIOGAMMARAMP8
typedef struct _NVVIOGAMMARAMP10 | NVVIOGAMMARAMP10
typedef struct _NVVIOSYNCDELAY | NVVIOSYNCDELAY
typedef struct _NVVIOVIDEOMODE | NVVIOVIDEOMODE
typedef struct
_NVVIOSIGNALFORMATDETAIL 		NVVIOSIGNALFORMATDETAIL
typedef struct
_NVVIODATAFORMATDETAIL 		NVVIODATAFORMATDETAIL
typedef struct
_NVVIOCOLORCONVERSION 		NVVIOCOLORCONVERSION
typedef struct
_NVVIOGAMMACORRECTION 		NVVIOGAMMACORRECTION
typedef struct _NVVIOCOMPOSITERANGE | NVVIOCOMPOSITERANGE
typedef struct
_NVVIOOUTPUTCONFIG_V1 		NVVIOOUTPUTCONFIG_V1
typedef struct
_NVVIOOUTPUTCONFIG_V2 		NVVIOOUTPUTCONFIG_V2
typedef struct
_NVVIOOUTPUTCONFIG_V3 		NVVIOOUTPUTCONFIG_V3
typedef struct _NVVIOSTREAM | NVVIOSTREAM
typedef struct _NVVIOINPUTCONFIG | NVVIOINPUTCONFIG
typedef struct _NVVIOCONFIG_V1 | NVVIOCONFIG_V1
typedef struct _NVVIOCONFIG_V2 | NVVIOCONFIG_V2
typedef struct _NVVIOCONFIG_V3 | NVVIOCONFIG_V3
typedef NVVIOOUTPUTCONFIG_V3 | NVVIOOUTPUTCONFIG
typedef NVVIOCONFIG_V3 | NVVIOCONFIG
typedef struct _NV_VIO_TOPOLOGY | NV_VIO_TOPOLOGY
typedef struct _NV_VIO_TOPOLOGY | NVVIOTOPOLOGY
NVVIOCOLORCONVERSION * pCSC
NVVIOGAMMACORRECTION * pGamma
const NVVIOSYNCDELAY * | pSyncDelay
NVAPI_INTERFACE | NvAPI_VIO_GetCapabilities (NvVioHandle hVioHandle, NVVIOCAPS *pAdapterCaps)
NVAPI_INTERFACE | NvAPI_VIO_Open (NvVioHandle hVioHandle, NvU32 vioClass, NVVIOOWNERTYPE ownerType)
NVAPI_INTERFACE | NvAPI_VIO_Close (NvVioHandle hVioHandle, NvU32 bRelease)
NVAPI_INTERFACE | NvAPI_VIO_Status (NvVioHandle hVioHandle, NVVIOSTATUS *pStatus)
NVAPI_INTERFACE | NvAPI_VIO_SyncFormatDetect (NvVioHandle hVioHandle, NvU32 *pWait)
NVAPI_INTERFACE | NvAPI_VIO_GetConfig (NvVioHandle hVioHandle, NVVIOCONFIG *pConfig)
NVAPI_INTERFACE | NvAPI_VIO_SetConfig (NvVioHandle hVioHandle, const NVVIOCONFIG *pConfig)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_VIO_SetConfig.") NVAPI_INTERFACE NvAPI_VIO_SetCSC(NvVioHandle hVioHandle
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_VIO_GetConfig.") NVAPI_INTERFACE NvAPI_VIO_GetCSC(NvVioHandle hVioHandle
#define | NVVIOPCIINFO_VER1 MAKE_NVAPI_VERSION(NVVIOPCIINFO_V1,1)
#define | NVVIOPCIINFO_VER NVVIOPCIINFO_VER1
enum | _NVVIOPCILINKRATE { NVVIOPCILINKRATE_UNKNOWN = 0, NVVIOPCILINKRATE_GEN1 = 1, NVVIOPCILINKRATE_GEN2 = 2, NVVIOPCILINKRATE_GEN3 = 3 }
enum _NVVIOPCILINKWIDTH {
NVVIOPCILINKWIDTH_UNKNOWN = 0, NVVIOPCILINKWIDTH_x1 = 1, NVVIOPCILINKWIDTH_x2 = 2, NVVIOPCILINKWIDTH_x4 = 4,
NVVIOPCILINKWIDTH_x8 = 8, NVVIOPCILINKWIDTH_x16 = 16
}
typedef enum _NVVIOPCILINKRATE | NVVIOPCILINKRATE
typedef enum _NVVIOPCILINKWIDTH | NVVIOPCILINKWIDTH
typedef struct _NVVIOPCIINFO | NVVIOPCIINFO_V1
typedef NVVIOPCIINFO_V1 | NVVIOPCIINFO
#define | NVAPI_STEREO_CAPS_VER1 MAKE_NVAPI_VERSION(NVAPI_STEREO_CAPS,1)
#define | NVAPI_STEREO_CAPS_VER NVAPI_STEREO_CAPS_VER1
typedef struct _NVAPI_STEREO_CAPS | NVAPI_STEREO_CAPS_V1
typedef NVAPI_STEREO_CAPS_V1 | NVAPI_STEREO_CAPS
enum | _NVAPI_STEREO_INIT_ACTIVATION_FLAGS { NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE = 0X00, NVAPI_STEREO_INIT_ACTIVATION_DELAYED = 0x01 }
typedef enum
_NVAPI_STEREO_INIT_ACTIVATION_FLAGS 		NVAPI_STEREO_INIT_ACTIVATION_FLAGS
NVAPI_INTERFACE | NvAPI_Stereo_InitActivation (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_INIT_ACTIVATION_FLAGS flags)
#define | NVAPI_DRS_GLOBAL_PROFILE ((NvDRSProfileHandle) -1)
#define | NVAPI_SETTING_MAX_VALUES 100
#define | NVDRS_SETTING_VALUES_VER MAKE_NVAPI_VERSION(NVDRS_SETTING_VALUES,1)
#define | NVDRS_SETTING_VER1 MAKE_NVAPI_VERSION(NVDRS_SETTING_V1, 1)
#define | NVDRS_SETTING_VER NVDRS_SETTING_VER1
#define | NVDRS_APPLICATION_VER_V1 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V1,1)
#define | NVDRS_APPLICATION_VER_V2 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V2,2)
#define | NVDRS_APPLICATION_VER_V3 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V3,3)
#define | NVDRS_APPLICATION_VER NVDRS_APPLICATION_VER_V3
#define | NVDRS_PROFILE_VER1 MAKE_NVAPI_VERSION(NVDRS_PROFILE_V1,1)
#define | NVDRS_PROFILE_VER NVDRS_PROFILE_VER1
enum | _NVDRS_SETTING_TYPE { NVDRS_DWORD_TYPE, NVDRS_BINARY_TYPE, NVDRS_STRING_TYPE, NVDRS_WSTRING_TYPE }
enum | _NVDRS_SETTING_LOCATION { NVDRS_CURRENT_PROFILE_LOCATION, NVDRS_GLOBAL_PROFILE_LOCATION, NVDRS_BASE_PROFILE_LOCATION, NVDRS_DEFAULT_PROFILE_LOCATION }
typedef enum _NVDRS_SETTING_TYPE | NVDRS_SETTING_TYPE
typedef enum
_NVDRS_SETTING_LOCATION 		NVDRS_SETTING_LOCATION
typedef struct _NVDRS_GPU_SUPPORT | NVDRS_GPU_SUPPORT
typedef struct
_NVDRS_BINARY_SETTING 		NVDRS_BINARY_SETTING
typedef struct
_NVDRS_SETTING_VALUES 		NVDRS_SETTING_VALUES
typedef struct _NVDRS_SETTING_V1 | NVDRS_SETTING_V1
typedef NVDRS_SETTING_V1 | NVDRS_SETTING
typedef struct
_NVDRS_APPLICATION_V1 		NVDRS_APPLICATION_V1
typedef struct
_NVDRS_APPLICATION_V2 		NVDRS_APPLICATION_V2
typedef struct
_NVDRS_APPLICATION_V3 		NVDRS_APPLICATION_V3
typedef NVDRS_APPLICATION_V3 | NVDRS_APPLICATION
typedef struct _NVDRS_PROFILE_V1 | NVDRS_PROFILE_V1
typedef NVDRS_PROFILE_V1 | NVDRS_PROFILE
NV_DECLARE_HANDLE (NvDRSSessionHandle)
NV_DECLARE_HANDLE (NvDRSProfileHandle)
NVAPI_INTERFACE | NvAPI_DRS_CreateSession (NvDRSSessionHandle *phSession)
NVAPI_INTERFACE | NvAPI_DRS_DestroySession (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_LoadSettings (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_SaveSettings (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_LoadSettingsFromFile (NvDRSSessionHandle hSession, NvAPI_UnicodeString fileName)
NVAPI_INTERFACE | NvAPI_DRS_SaveSettingsToFile (NvDRSSessionHandle hSession, NvAPI_UnicodeString fileName)

Define Documentation

#define __cdecl
#define _NVAPI_H
#define ALL_GPUS 0
#define DISPLAYPORT_STRUCTS_DEFINED
#define FENCE_SYNCHRONIZATION_END | ( | pMultiGPUDevice,
 |  | hFence,
 |  | Value,
 |  | srcGpu,
 |  | dstGpu
 | ) |
Value:
pMultiGPUDevice->SetFence(srcGpu, hFence, Value); \
    pMultiGPUDevice->WaitForFence(1 << (dstGpu), hFence, Value); \
    Value++;

#define FENCE_SYNCHRONIZATION_START | ( | pMultiGPUDevice,
 |  | hFence,
 |  | Value,
 |  | srcGpu,
 |  | dstGpu
 | ) |
Value:
pMultiGPUDevice->SetFence(dstGpu, hFence, Value); \
    pMultiGPUDevice->WaitForFence(1 << (srcGpu), hFence, Value); \
    Value++;

Synchronization macros based on fences.

#define ID3D11MultiGPUDevice_VER ID3D11MultiGPUDevice_VER2
#define ID3D11MultiGPUDevice_VER1 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 1)
#define ID3D11MultiGPUDevice_VER2 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 2)
#define NV_BOARD_INFO_VER1 MAKE_NVAPI_VERSION(NV_BOARD_INFO_V1,1)
#define NV_COLOR_DATA_VER NV_COLOR_DATA_VER3

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

#define NV_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V1, 1)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

#define NV_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V2, 2)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

#define NV_COLOR_DATA_VER3 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V3, 3)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

#define NV_DISPLAY_PORT_INFO_VER NV_DISPLAY_PORT_INFO_VER2
#define NV_DISPLAY_PORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,1)

Macro for constructing the version field of NV_DISPLAY_PORT_INFO.

#define NV_DISPLAY_PORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,2)
#define NV_DISPLAYCONFIG_PATH_INFO_VER NV_DISPLAYCONFIG_PATH_INFO_VER2
#define NV_GPU_DISPLAYIDS_VER NV_GPU_DISPLAYIDS_VER2
#define NV_GPU_DISPLAYIDS_VER2 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,3)
#define NV_GSYNC_CAPABILITIES_VER NV_GSYNC_CAPABILITIES_VER1
#define NV_GSYNC_CONTROL_PARAMS_VER MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS,1)
#define NV_GSYNC_DELAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DELAY,1)
#define NV_GSYNC_DISPLAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DISPLAY,1)
#define NV_GSYNC_GPU_VER MAKE_NVAPI_VERSION(NV_GSYNC_GPU,1)
#define NV_GSYNC_STATUS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS,1)

Macro for constructing the version field for NV_GSYNC_STATUS.

#define NV_HDMI_SUPPORT_INFO_VER NV_HDMI_SUPPORT_INFO_VER2
#define NV_HDMI_SUPPORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V1, 1)
#define NV_HDMI_SUPPORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V2, 2)
#define NV_INFOFRAME_DATA_VER MAKE_NVAPI_VERSION(NV_INFOFRAME_DATA,1)

Macro for constructing the version field of NV_INFOFRAME_DATA.

#define NV_LID_DOCK_PARAMS_VER MAKE_NVAPI_VERSION(NV_LID_DOCK_PARAMS,1)

ingroup sysgeneral

#define NV_MONITOR_CAPABILITIES_VER NV_MONITOR_CAPABILITIES_VER1

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

#define NV_MONITOR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_CAPABILITIES_V1,1)

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

#define NV_MONITOR_COLOR_CAPS_VER NV_MONITOR_COLOR_CAPS_VER1
#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU NV_BIT(0)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR NV_BIT(1)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED NV_BIT(9)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED NV_BIT(10)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE NV_BIT(4)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS NV_BIT(2)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED NV_BIT(5)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE NV_BIT(3)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY NV_BIT(6)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE NV_BIT(8)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED NV_BIT(7)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_GRID_TOPO_VER NV_MOSAIC_GRID_TOPO_VER2

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_GRID_TOPO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V1,1)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_GRID_TOPO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V2,2)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID NV_BIT(3)

Do not return an error if no configuration will work with all of the grids.

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE NV_BIT(2)

When choosing a GPU topology, choose the topology with the best performance. Without this flag, it will choose the topology that uses the smallest number of GPU's.

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD NV_BIT(1)

Do not allow a driver reload. That is, stick with the same master GPU as well as the same SLI configuration.

#define NV_SCANOUT_INFORMATION_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INFORMATION,1)
#define NV_SCANOUT_INTENSITY_DATA_VER NV_SCANOUT_INTENSITY_DATA_VER2
#define NV_SCANOUT_INTENSITY_DATA_VER2 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V2, 2)
#define NV_TIMING_INPUT_VER MAKE_NVAPI_VERSION(NV_TIMING_INPUT,1)
#define NV_TIMING_STRUCTS_DEFINED
#define NVAPI_ALL_GPUS 0
#define NVAPI_BINARY_DATA_MAX 4096
#define NVAPI_CPU_RESOURCE 0xffffffff
#define NVAPI_DRS_GLOBAL_PROFILE ((NvDRSProfileHandle) -1)

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVAPI_GSYNC_BOARD_ID_P2060 8288

GSync board ID 0x2060, see NV_GSYNC_CAPABILITIES.

#define NVAPI_GSYNC_BOARD_ID_P358 856

GSync board ID 0x358, see NV_GSYNC_CAPABILITIES.

#define NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES 5

Default number of capture images.

#define NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES 32

Max number of capture images.

#define NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES 1

Min number of capture images.

#define NVAPI_MAX_FRAMELOCK_MAPPING_MODES 20

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

#define NVAPI_MAX_GSYNC_DEVICES 4
#define NVAPI_MAX_VIO_CHANNELS_PER_JACK 2

Each physical jack an on SDI input card can have two "channels" in the case of "3G" VideoFormats, as specified by SMPTE 425; for non-3G VideoFormats, only the first channel within a physical jack is valid.

#define NVAPI_MAX_VIO_DEVICES 8

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

#define NVAPI_MAX_VIO_JACKS 4

4 physical jacks supported on each SDI input card.

#define NVAPI_MAX_VIO_LINKS_PER_STREAM 2

SDI input supports a max of 2 links per stream.

#define NVAPI_MAX_VIO_STREAMS 4

4 Streams, 1 per physical jack

#define NVAPI_MIN_VIO_STREAMS 1

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

#define NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS 0x02
#define NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS 0x80000000
#define NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE 0x01

PresentCompositingConfig method flags.

#define NVAPI_SETTING_MAX_VALUES 100

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVAPI_STEREO_CAPS_VER NVAPI_STEREO_CAPS_VER1
#define NVAPI_STEREO_CAPS_VER1 MAKE_NVAPI_VERSION(NVAPI_STEREO_CAPS,1)
#define NVAPI_UNICODE_STRING_MAX 2048
#define NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE 0
#define NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS 2
#define NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE 1
#define NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN 3
#define NVDRS_APPLICATION_VER NVDRS_APPLICATION_VER_V3

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVDRS_APPLICATION_VER_V1 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V1,1)

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVDRS_APPLICATION_VER_V2 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V2,2)

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVDRS_APPLICATION_VER_V3 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V3,3)

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVDRS_PROFILE_VER NVDRS_PROFILE_VER1

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVDRS_PROFILE_VER1 MAKE_NVAPI_VERSION(NVDRS_PROFILE_V1,1)

Macro for constructing the version field of NVDRS_PROFILE.

#define NVDRS_SETTING_VALUES_VER MAKE_NVAPI_VERSION(NVDRS_SETTING_VALUES,1)

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVDRS_SETTING_VER NVDRS_SETTING_VER1

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

#define NVDRS_SETTING_VER1 MAKE_NVAPI_VERSION(NVDRS_SETTING_V1, 1)

Macro for constructing the version field of ::_NVDRS_SETTING.

#define NVVIOPCIINFO_VER NVVIOPCIINFO_VER1
#define NVVIOPCIINFO_VER1 MAKE_NVAPI_VERSION(NVVIOPCIINFO_V1,1)

Typedef Documentation

typedef ID3D11MultiGPUDevice_V1 ID3D11MultiGPUDevice
typedef enum _NV_BPC NV_BPC

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

typedef NV_COLOR_DATA_V3 NV_COLOR_DATA

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

typedef struct _NV_COLOR_DATA_V1 NV_COLOR_DATA_V1

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

typedef struct _NV_COLOR_DATA_V2 NV_COLOR_DATA_V2

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

typedef struct _NV_COLOR_DATA_V3 NV_COLOR_DATA_V3

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

typedef NV_DISPLAY_PORT_INFO_V1 NV_DISPLAY_PORT_INFO
typedef NV_DISPLAYCONFIG_PATH_INFO_V2 NV_DISPLAYCONFIG_PATH_INFO
typedef NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 NV_DISPLAYCONFIG_SOURCE_MODE_INFO
typedef enum _NV_DYNAMIC_RANGE NV_DYNAMIC_RANGE

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

typedef enum _NV_ECC_CONFIGURATION NV_ECC_CONFIGURATION
typedef NV_GSYNC_CAPABILITIES_V1 NV_GSYNC_CAPABILITIES
typedef struct _NV_GSYNC_CAPABILITIES_V1 NV_GSYNC_CAPABILITIES_V1

Used in NvAPI_GSync_QueryCapabilities().

typedef struct _NV_GSYNC_CONTROL_PARAMS NV_GSYNC_CONTROL_PARAMS

Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters().

typedef struct _NV_GSYNC_DELAY NV_GSYNC_DELAY

Used in NV_GSYNC_CONTROL_PARAMS.

typedef struct _NV_GSYNC_DISPLAY NV_GSYNC_DISPLAY
typedef struct _NV_GSYNC_GPU NV_GSYNC_GPU
typedef struct _NV_GSYNC_STATUS NV_GSYNC_STATUS

Used in NvAPI_GSync_GetSyncStatus().

typedef NV_HDMI_SUPPORT_INFO_V2 NV_HDMI_SUPPORT_INFO
typedef NV_MONITOR_CAPABILITIES_V1 NV_MONITOR_CAPABILITIES

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

typedef struct _NV_MONITOR_CAPABILITIES_V1 NV_MONITOR_CAPABILITIES_V1

See NvAPI_DISP_GetMonitorCapabilities().

typedef struct _NV_MONITOR_CAPS_VCDB NV_MONITOR_CAPS_VCDB

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

typedef struct _NV_MONITOR_CAPS_VSDB NV_MONITOR_CAPS_VSDB

See NvAPI_DISP_GetMonitorCapabilities().

typedef NV_MONITOR_COLOR_CAPS_V1 NV_MONITOR_COLOR_CAPS
typedef NV_MOSAIC_GRID_TOPO_V2 NV_MOSAIC_GRID_TOPO

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

typedef NV_MOSAIC_GRID_TOPO_DISPLAY_V1 NV_MOSAIC_GRID_TOPO_DISPLAY

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 NV_MOSAIC_GRID_TOPO_DISPLAY_V2

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

typedef struct _NV_MOSAIC_GRID_TOPO_V1 NV_MOSAIC_GRID_TOPO_V1

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

typedef struct _NV_MOSAIC_GRID_TOPO_V2 NV_MOSAIC_GRID_TOPO_V2

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

typedef enum _NV_PIXEL_SHIFT_TYPE NV_PIXEL_SHIFT_TYPE

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

typedef NV_SCANOUT_INTENSITY_DATA_V2 NV_SCANOUT_INTENSITY_DATA
typedef enum _NVAPI_D3D11_INSERTWFI_FLAG NVAPI_D3D11_INSERTWFI_FLAG
typedef UINT NvAPI_D3D11_SWIZZLE_MODE
typedef enum _NVAPI_GPU_PERF_DECREASE NVAPI_GPU_PERF_DECREASE

Used in NvAPI_GPU_GetPerfDecreaseInfo. Bit masks for knowing the exact reason for performance decrease

typedef enum _NVAPI_GSYNC_DISPLAY_SYNC_STATE NVAPI_GSYNC_DISPLAY_SYNC_STATE

Display sync states. Used in NV_GSYNC_DISPLAY.

typedef enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR

Connector values for a GPU. Used in NV_GSYNC_GPU.

typedef enum _NVAPI_GSYNC_RJ45_IO NVAPI_GSYNC_RJ45_IO

Used in NV_GSYNC_STATUS_PARAMS.

typedef enum _NVAPI_GSYNC_SYNC_SOURCE NVAPI_GSYNC_SYNC_SOURCE

Used in NV_GSYNC_CONTROL_PARAMS.

typedef enum _NVAPI_GSYNC_VIDEO_MODE NVAPI_GSYNC_VIDEO_MODE

Used in NV_GSYNC_CONTROL_PARAMS.

typedef const NvU16* NvAPI_LPCWSTR
typedef NVAPI_STEREO_CAPS_V1 NVAPI_STEREO_CAPS
typedef NvU16 NvAPI_UnicodeString[NVAPI_UNICODE_STRING_MAX]
typedef NVDRS_APPLICATION_V3 NVDRS_APPLICATION

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef struct _NVDRS_APPLICATION_V1 NVDRS_APPLICATION_V1

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef struct _NVDRS_APPLICATION_V2 NVDRS_APPLICATION_V2

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef struct _NVDRS_APPLICATION_V3 NVDRS_APPLICATION_V3

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef struct _NVDRS_BINARY_SETTING NVDRS_BINARY_SETTING

Enum to decide on the datatype of setting value.

typedef struct _NVDRS_GPU_SUPPORT NVDRS_GPU_SUPPORT

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef NVDRS_PROFILE_V1 NVDRS_PROFILE

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef struct _NVDRS_PROFILE_V1 NVDRS_PROFILE_V1

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef NVDRS_SETTING_V1 NVDRS_SETTING

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef enum _NVDRS_SETTING_LOCATION NVDRS_SETTING_LOCATION

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef enum _NVDRS_SETTING_TYPE NVDRS_SETTING_TYPE

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef struct _NVDRS_SETTING_V1 NVDRS_SETTING_V1

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef struct _NVDRS_SETTING_VALUES NVDRS_SETTING_VALUES

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

typedef enum _NVVIOANCPARITYCOMPUTATION NVVIOANCPARITYCOMPUTATION

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

typedef enum _NVVIOBITSPERCOMPONENT NVVIOBITSPERCOMPONENT

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

typedef enum _NVVIOCAPTURESTATUS NVVIOCAPTURESTATUS

Video Capture Status.

typedef enum _NVVIOCOLORSPACE NVVIOCOLORSPACE

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

typedef enum _NVVIOCOMPONENTSAMPLING NVVIOCOMPONENTSAMPLING

Component sampling.

typedef enum _NVVIOCOMPSYNCTYPE NVVIOCOMPSYNCTYPE

Composite synchronization type.

typedef enum _NVVIOCONFIGTYPE NVVIOCONFIGTYPE

Device configuration.

typedef enum _NVVIODATAFORMAT NVVIODATAFORMAT

Video data format.

typedef enum _NVVIOINPUTOUTPUTSTATUS NVVIOINPUTOUTPUTSTATUS

Video input output status.

typedef enum _NVVIOINTERLACEMODE NVVIOINTERLACEMODE

Interlace mode.

typedef enum _NVVIOLINKID NVVIOLINKID

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

typedef enum _NVVIOOUTPUTAREA NVVIOOUTPUTAREA

Video output area.

typedef NVVIOPCIINFO_V1 NVVIOPCIINFO
typedef struct _NVVIOPCIINFO NVVIOPCIINFO_V1
typedef enum _NVVIOPCILINKWIDTH NVVIOPCILINKWIDTH
typedef enum _NVVIOSTATUSTYPE NVVIOSTATUSTYPE

Video Capture Status.

typedef enum _NVVIOSYNCSOURCE NVVIOSYNCSOURCE

Synchronization source.

typedef enum _NVVIOSYNCSTATUS NVVIOSYNCSTATUS

Synchronization input status.

typedef enum _NVVIOVIDEOSTANDARD NVVIOVIDEOSTANDARD

SMPTE standards format.

typedef enum _NVVIOVIDEOTYPE NVVIOVIDEOTYPE

HD or SD video type.

typedef struct NV_MULTIGPU_CAPS * PNV_MULTIGPU_CAPS

Enumeration Type Documentation

enum _NV_BPC

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator:
NV_BPC_DEFAULT
NV_BPC_6
NV_BPC_8
NV_BPC_10
NV_BPC_12
NV_BPC_16
enum _NV_DYNAMIC_RANGE

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator:
NV_DYNAMIC_RANGE_VESA
NV_DYNAMIC_RANGE_CEA
NV_DYNAMIC_RANGE_AUTO
enum _NV_ECC_CONFIGURATION
Enumerator:
NV_ECC_CONFIGURATION_NOT_SUPPORTED
NV_ECC_CONFIGURATION_DEFERRED

Changes require a POST to take effect.

NV_ECC_CONFIGURATION_IMMEDIATE

Changes can optionally be made to take effect immediately.

enum _NV_PIXEL_SHIFT_TYPE

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

Enumerator:
NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT

No pixel shift will be applied to this display.

NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS

This display will be used to scanout top left pixels in 2x2 PixelShift configuration.

NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS

This display will be used to scanout bottom right pixels in 2x2 PixelShift configuration.

enum _NVAPI_D3D11_INSERTWFI_FLAG
Enumerator:
NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI

no WFI

NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI

(bit 0) force graphics WFI

NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI

(bit 1) force compute WFI

enum _NVAPI_GPU_PERF_DECREASE

Used in NvAPI_GPU_GetPerfDecreaseInfo. Bit masks for knowing the exact reason for performance decrease

Enumerator:
NV_GPU_PERF_DECREASE_NONE

No Slowdown detected.

NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION

Thermal slowdown/shutdown/POR thermal protection.

NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL

Power capping / pstate cap.

NV_GPU_PERF_DECREASE_REASON_AC_BATT

AC->BATT event.

NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED

API triggered slowdown.

NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER

Power connector missing.

NV_GPU_PERF_DECREASE_REASON_UNKNOWN

Unknown reason.

enum _NVAPI_GSYNC_DISPLAY_SYNC_STATE

Display sync states. Used in NV_GSYNC_DISPLAY.

Enumerator:
NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED
NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE
NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER
enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR

Connector values for a GPU. Used in NV_GSYNC_GPU.

Enumerator:
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY
enum _NVAPI_GSYNC_RJ45_IO

Used in NV_GSYNC_STATUS_PARAMS.

Enumerator:
NVAPI_GSYNC_RJ45_OUTPUT
NVAPI_GSYNC_RJ45_INPUT
NVAPI_GSYNC_RJ45_UNUSED

This field is used to notify that the framelock is not actually present.

enum _NVAPI_GSYNC_SYNC_SOURCE

Used in NV_GSYNC_CONTROL_PARAMS.

Enumerator:
NVAPI_GSYNC_SYNC_SOURCE_VSYNC
NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC
enum _NVAPI_GSYNC_VIDEO_MODE

Used in NV_GSYNC_CONTROL_PARAMS.

Enumerator:
NVAPI_GSYNC_VIDEO_MODE_NONE
NVAPI_GSYNC_VIDEO_MODE_TTL
NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM
NVAPI_GSYNC_VIDEO_MODE_HDTV
NVAPI_GSYNC_VIDEO_MODE_COMPOSITE
enum _NVDRS_SETTING_LOCATION

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

Enumerator:
NVDRS_CURRENT_PROFILE_LOCATION
NVDRS_GLOBAL_PROFILE_LOCATION
NVDRS_BASE_PROFILE_LOCATION
NVDRS_DEFAULT_PROFILE_LOCATION
enum _NVDRS_SETTING_TYPE

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

Enumerator:
NVDRS_DWORD_TYPE
NVDRS_BINARY_TYPE
NVDRS_STRING_TYPE
NVDRS_WSTRING_TYPE
enum _NVVIOANCPARITYCOMPUTATION

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

Enumerator:
NVVIOANCPARITYCOMPUTATION_AUTO
NVVIOANCPARITYCOMPUTATION_ON
NVVIOANCPARITYCOMPUTATION_OFF
enum _NVVIOBITSPERCOMPONENT

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

Enumerator:
NVVIOBITSPERCOMPONENT_UNKNOWN
NVVIOBITSPERCOMPONENT_8
NVVIOBITSPERCOMPONENT_10
NVVIOBITSPERCOMPONENT_12
enum _NVVIOCAPTURESTATUS

Video Capture Status.

Enumerator:
NVVIOSTATUS_STOPPED

Sync not detected.

NVVIOSTATUS_RUNNING

Error detected.

NVVIOSTATUS_ERROR

Genlock in use, format mismatch with output.

enum _NVVIOCOLORSPACE

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

Enumerator:
NVVIOCOLORSPACE_UNKNOWN
NVVIOCOLORSPACE_YCBCR
NVVIOCOLORSPACE_YCBCRA
NVVIOCOLORSPACE_YCBCRD
NVVIOCOLORSPACE_GBR
NVVIOCOLORSPACE_GBRA
NVVIOCOLORSPACE_GBRD
enum _NVVIOCOMPONENTSAMPLING

Component sampling.

Enumerator:
NVVIOCOMPONENTSAMPLING_UNKNOWN
NVVIOCOMPONENTSAMPLING_4444
NVVIOCOMPONENTSAMPLING_4224
NVVIOCOMPONENTSAMPLING_444
NVVIOCOMPONENTSAMPLING_422
enum _NVVIOCOMPSYNCTYPE

Composite synchronization type.

Enumerator:
NVVIOCOMPSYNCTYPE_AUTO

Auto-detect.

NVVIOCOMPSYNCTYPE_BILEVEL

Bi-level signal.

NVVIOCOMPSYNCTYPE_TRILEVEL

Tri-level signal.

enum _NVVIOCONFIGTYPE

Device configuration.

Enumerator:
NVVIOCONFIGTYPE_IN

Input Status.

NVVIOCONFIGTYPE_OUT

Output Status.

enum _NVVIODATAFORMAT

Video data format.

Enumerator:
NVVIODATAFORMAT_UNKNOWN

Invalid DataFormat.

NVVIODATAFORMAT_R8G8B8_TO_YCRCB444

R8:G8:B8 => YCrCb (4:4:4)

NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444

R8:G8:B8:A8 => YCrCbA (4:4:4:4)

NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444

R8:G8:B8:Z10 => YCrCbZ (4:4:4:4)

NVVIODATAFORMAT_R8G8B8_TO_YCRCB422

R8:G8:B8 => YCrCb (4:2:2)

NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224

R8:G8:B8:A8 => YCrCbA (4:2:2:4)

NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224

R8:G8:B8:Z10 => YCrCbZ (4:2:2:4)

NVVIODATAFORMAT_X8X8X8_444_PASSTHRU

R8:G8:B8 => RGB (4:4:4)

NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU

R8:G8:B8:A8 => RGBA (4:4:4:4)

NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU

R8:G8:B8:Z10 => RGBZ (4:4:4:4)

NVVIODATAFORMAT_X10X10X10_444_PASSTHRU

Y10:CR10:CB10 => YCrCb (4:4:4)

NVVIODATAFORMAT_X10X8X8_444_PASSTHRU

Y10:CR8:CB8 => YCrCb (4:4:4)

NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU

Y10:CR8:CB8:A10 => YCrCbA (4:4:4:4)

NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU

Y10:CR8:CB8:Z10 => YCrCbZ (4:4:4:4)

NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422

R8:G8:B8 + R8:G8:B8 => YCrCb (4:2:2 + 4:2:2)

NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU

Y8:CR8:CB8 + Y8:CR8:CB8 => YCrCb (4:2:2 + 4:2:2)

NVVIODATAFORMAT_R10G10B10_TO_YCRCB422

R10:G10:B10 => YCrCb (4:2:2)

NVVIODATAFORMAT_R10G10B10_TO_YCRCB444

R10:G10:B10 => YCrCb (4:4:4)

NVVIODATAFORMAT_X12X12X12_444_PASSTHRU

X12:X12:X12 => XXX (4:4:4)

NVVIODATAFORMAT_X12X12X12_422_PASSTHRU

X12:X12:X12 => XXX (4:2:2)

NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422

Y10:CR10:CB10 => YCrCb (4:2:2)

NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422

Y8:CR8:CB8 => YCrCb (4:2:2)

NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224

Y10:CR8:CB8:A10 => YCrCbA (4:2:2:4)

NVVIODATAFORMAT_R10G10B10_TO_RGB444

R10:G10:B10 => RGB (4:4:4)

NVVIODATAFORMAT_R12G12B12_TO_YCRCB444

R12:G12:B12 => YCrCb (4:4:4)

NVVIODATAFORMAT_R12G12B12_TO_YCRCB422

R12:G12:B12 => YCrCb (4:2:2)

enum _NVVIOINPUTOUTPUTSTATUS

Video input output status.

Enumerator:
NVINPUTOUTPUTSTATUS_OFF

Not in use.

NVINPUTOUTPUTSTATUS_ERROR

Error detected.

NVINPUTOUTPUTSTATUS_SDI_SD

SDI (standard-definition)

NVINPUTOUTPUTSTATUS_SDI_HD

SDI (high-definition)

enum _NVVIOINTERLACEMODE

Interlace mode.

Enumerator:
NVVIOINTERLACEMODE_PROGRESSIVE

Progressive (p)

NVVIOINTERLACEMODE_INTERLACE

Interlace (i)

NVVIOINTERLACEMODE_PSF

Progressive Segment Frame (psf)

enum _NVVIOLINKID

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

Enumerator:
NVVIOLINKID_UNKNOWN
NVVIOLINKID_A
NVVIOLINKID_B
NVVIOLINKID_C
NVVIOLINKID_D
enum _NVVIOOUTPUTAREA

Video output area.

Enumerator:
NVVIOOUTPUTAREA_FULLSIZE

Output to entire video resolution (full size)

NVVIOOUTPUTAREA_SAFEACTION

Output to centered 90% of video resolution (safe action)

NVVIOOUTPUTAREA_SAFETITLE

Output to centered 80% of video resolution (safe title)

enum _NVVIOPCILINKWIDTH
Enumerator:
NVVIOPCILINKWIDTH_UNKNOWN
NVVIOPCILINKWIDTH_x1
NVVIOPCILINKWIDTH_x2
NVVIOPCILINKWIDTH_x4
NVVIOPCILINKWIDTH_x8
NVVIOPCILINKWIDTH_x16
enum _NVVIOSTATUSTYPE

Video Capture Status.

Enumerator:
NVVIOSTATUSTYPE_IN

Input Status.

NVVIOSTATUSTYPE_OUT

Output Status.

enum _NVVIOSYNCSOURCE

Synchronization source.

Enumerator:
NVVIOSYNCSOURCE_SDISYNC

SDI Sync (Digital input)

NVVIOSYNCSOURCE_COMPSYNC

COMP Sync (Composite input)

enum _NVVIOSYNCSTATUS

Synchronization input status.

Enumerator:
NVVIOSYNCSTATUS_OFF

Sync not detected.

NVVIOSYNCSTATUS_ERROR

Error detected.

NVVIOSYNCSTATUS_SYNCLOSS

Genlock in use, format mismatch with output.

NVVIOSYNCSTATUS_COMPOSITE

Composite sync.

NVVIOSYNCSTATUS_SDI_SD

SDI sync (standard-definition)

NVVIOSYNCSTATUS_SDI_HD

SDI sync (high-definition)

enum _NVVIOVIDEOSTANDARD

SMPTE standards format.

Enumerator:
NVVIOVIDEOSTANDARD_SMPTE259

SMPTE259.

NVVIOVIDEOSTANDARD_SMPTE260

SMPTE260.

NVVIOVIDEOSTANDARD_SMPTE274

SMPTE274.

NVVIOVIDEOSTANDARD_SMPTE295

SMPTE295.

NVVIOVIDEOSTANDARD_SMPTE296

SMPTE296.

NVVIOVIDEOSTANDARD_SMPTE372

SMPTE372.

enum _NVVIOVIDEOTYPE

HD or SD video type.

Enumerator:
NVVIOVIDEOTYPE_SD

Standard-definition (SD)

NVVIOVIDEOTYPE_HD

High-definition (HD)

enum NV_COLOR_CMD

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator:
NV_COLOR_CMD_GET
NV_COLOR_CMD_SET
NV_COLOR_CMD_IS_SUPPORTED_COLOR
NV_COLOR_CMD_GET_DEFAULT
enum NV_COLOR_COLORIMETRY

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator:
NV_COLOR_COLORIMETRY_RGB
NV_COLOR_COLORIMETRY_YCC601
NV_COLOR_COLORIMETRY_YCC709
NV_COLOR_COLORIMETRY_XVYCC601
NV_COLOR_COLORIMETRY_XVYCC709
NV_COLOR_COLORIMETRY_SYCC601
NV_COLOR_COLORIMETRY_ADOBEYCC601
NV_COLOR_COLORIMETRY_ADOBERGB
NV_COLOR_COLORIMETRY_BT2020RGB
NV_COLOR_COLORIMETRY_BT2020YCC
NV_COLOR_COLORIMETRY_BT2020cYCC
NV_COLOR_COLORIMETRY_DEFAULT
NV_COLOR_COLORIMETRY_AUTO
enum NV_COLOR_FORMAT

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator:
NV_COLOR_FORMAT_RGB
NV_COLOR_FORMAT_YUV422
NV_COLOR_FORMAT_YUV444
NV_COLOR_FORMAT_YUV420
NV_COLOR_FORMAT_DEFAULT
NV_COLOR_FORMAT_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION

Byte 4 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT

Byte 1 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE

Byte 3 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED
NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED
NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL

Byte 5 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE

Byte 2 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT
NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION

Byte2 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_F17

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE
NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE
NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_ITC

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT
NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT
NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING

Byte 3 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION

Byte 4 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO

Byte1 related.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO
enum NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO
enum NV_INFOFRAME_PROPERTY_BLACKLIST

Returns whether the current monitor is in blacklist or force this monitor to be in blacklist.

Enumerator:
NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE
NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE
enum NV_INFOFRAME_PROPERTY_MODE

Macro for constructing the version field of NV_INFOFRAME_DATA.

Enumerator:
NV_INFOFRAME_PROPERTY_MODE_AUTO

Driver determines whether to send infoframes.

NV_INFOFRAME_PROPERTY_MODE_ENABLE

Driver always sends infoframe.

NV_INFOFRAME_PROPERTY_MODE_DISABLE

Driver never sends infoframe.

NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE

Driver only sends infoframe when client requests it via infoframe escape call.

Function Documentation

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_VIO_SetConfig." |
 | ) |  |

Function: NvAPI_VIO_SetCSC

Description: This API sets the colorspace conversion parameters.

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[in] | pCSC | Pointer to CSC parameters
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Stucture version invalid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access

Function: NvAPI_VIO_SetGamma

Description: This API sets the gamma conversion parameters.

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[in] | pGamma | Pointer to gamma parameters
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Stucture version invalid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access

Function: NvAPI_VIO_SetSyncDelay

Description: This API sets the sync delay parameters.

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[in] | pSyncDelay | Pointer to sync delay parameters
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Stucture version invalid
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access
__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_VIO_GetConfig." |
 | ) |  |

Function: NvAPI_VIO_GetCSC

Description: This API gets the colorspace conversion parameters.

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pCSC | Pointer to CSC parameters
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Stucture version invalid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors

Function: NvAPI_VIO_GetGamma

Description: This API gets the gamma conversion parameters.

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pGamma | Pointer to gamma parameters
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Stucture version invalid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors

Function: NvAPI_VIO_GetSyncDelay

Description: This API gets the sync delay parameters.

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pSyncDelay | Pointer to sync delay parameters
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Stucture version invalid
NVAPI_ERROR | NVAPI Random errors
DECLARE_INTERFACE ( ID3D11MultiGPUDevice_V1 )
NV_DECLARE_HANDLE ( NvDRSProfileHandle )

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

NVAPI_INTERFACE NvAPI_DRS_CreateSession ( NvDRSSessionHandle * phSession )

DESCRIPTION: This API allocates memory and initializes the session.

SUPPORTED OS: Windows XP and higher

Parameters:
[out] *phSession Return pointer to the session handle.
Return values:
NVAPI_OK SUCCESS
NVAPI_ERROR,: For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_DestroySession ( NvDRSSessionHandle hSession )

DESCRIPTION: This API frees the allocation: cleanup of NvDrsSession.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] hSession Input to the session handle.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_LoadSettings ( NvDRSSessionHandle hSession )

DESCRIPTION: This API loads and parses the settings data.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] hSession Input to the session handle.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_LoadSettingsFromFile | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | fileName
 | ) |  |

DESCRIPTION: This API loads settings from the given file path.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle
[in] | fileName | Binary File Name/Path
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_SaveSettings ( NvDRSSessionHandle hSession )

DESCRIPTION: This API saves the settings data to the system.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] hSession Input to the session handle.
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_DRS_SaveSettingsToFile | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | fileName
 | ) |  |

DESCRIPTION: This API saves settings to the given file path.

SUPPORTED OS: Windows XP and higher

Parameters:
[in] | hSession | Input to the session handle.
[in] | fileName | Binary File Name/Path
Return values:
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_INTERFACE NvAPI_Mosaic_EnumDisplayModes | ( | __in NV_MOSAIC_GRID_TOPO * | pGridTopology,
 |  | __inout_ecount_part_opt *,*pDisplayCount NV_MOSAIC_DISPLAY_SETTING * | pDisplaySettings,
 |  | __inout NvU32 * | pDisplayCount
 | ) |  |

DESCRIPTION: Determines the set of available display modes for a given grid topology.

SUPPORTED OS: Windows 7 and higher

Parameters:
[in] | pGridTopology | The grid topology to use.
[in,out] | pDisplaySettings | A pointer to an array of display settings to populate, or NULL to find out the total number of available modes.
[in,out] | pDisplayCount | If pDisplaySettings is not NULL, then pDisplayCount should point to the number of elements in the pDisplaySettings array. On return, it will contain the number of modes that were actually returned. If pDisplaySettings is NULL, then pDisplayCount will receive the total number of modes that are available.
Return values:
NVAPI_OK | Capabilities have been returned.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INTERFACE NvAPI_Mosaic_SetDisplayGrids | ( | __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO * | pGridTopologies,
 |  | __in NvU32 | gridCount,
 |  | __in NvU32 | setTopoFlags
 | ) |  |
NVAPI_INTERFACE NvAPI_VIO_Close | ( | NvVioHandle | hVioHandle,
 |  | NvU32 | bRelease
 | ) |  |

Function: NvAPI_VIO_Close

Description: This API closes the graphics adapter for graphics-to-video operations using the OpenGL application interface. Closing an OpenGL handle releases the device.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI output device handle as input.
[in] | bRelease | boolean value to either keep or release ownership
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access
NVAPI_INTERFACE NvAPI_VIO_GetConfig | ( | NvVioHandle | hVioHandle,
 |  | NVVIOCONFIG * | pConfig
 | ) |  |

Function: NvAPI_VIO_GetConfig

Description: This API gets the graphics-to-video configuration.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pConfig | Pointer to the graphics-to-video configuration
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Invalid structure version
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_INTERFACE NvAPI_VIO_Open | ( | NvVioHandle | hVioHandle,
 |  | NvU32 | vioClass,
 |  | NVVIOOWNERTYPE | ownerType
 | ) |  |

Function: NvAPI_VIO_Open

Description: This API opens the graphics adapter for video I/O operations using the OpenGL application interface. Read operations are permitted in this mode by multiple clients, but Write operations are application exclusive.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI output device handle as input.
[in] | vioClass | Class interface (NVVIOCLASS_* value)
[in] | ownerType | Specify NVVIOOWNERTYPE_APPLICATION or NVVIOOWNERTYPE_DESKTOP.
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access
NVAPI_INTERFACE NvAPI_VIO_SetConfig | ( | NvVioHandle | hVioHandle,
 |  | const NVVIOCONFIG * | pConfig
 | ) |  |

Function: NvAPI_VIO_SetConfig

Description: This API sets the graphics-to-video configuration.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[in] | pConfig | Pointer to Graphics-to-Video configuration
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Stucture version invalid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_DEVICE_BUSY | Access denied for requested access
NVAPI_INTERFACE NvAPI_VIO_Status | ( | NvVioHandle | hVioHandle,
 |  | NVVIOSTATUS * | pStatus
 | ) |  |

Function: NvAPI_VIO_Status

Description: This API gets the Video I/O LED status.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pStatus | Return pointer to NVVIOSTATUS
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Invalid structure version
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVAPI_INTERFACE NvAPI_VIO_SyncFormatDetect | ( | NvVioHandle | hVioHandle,
 |  | NvU32 * | pWait
 | ) |  |

Function: NvAPI_VIO_SyncFormatDetect

Description: This API detects the Video I/O incoming sync video format.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pWait | Pointer to receive how many milliseconds will lapse before VIOStatus returns the detected syncFormat.
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors

Variable Documentation

NV_DISPLAY_PATH_INFO NV_TARGET_VIEW_MODE displayView
NV_GPU_PERF_PSTATES_INFO NvU32 inputFlags
NVVIOCOLORCONVERSION * pCSC

Function: NvAPI_VIO_GetCapabilities

Description: This API determine the graphics adapter video I/O capabilities.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pAdapterCaps | Pointer to receive capabilities
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NVVIOCAPS struct version used by the app is not compatible
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NVVIOGAMMACORRECTION * pGamma

Function: NvAPI_VIO_GetCapabilities

Description: This API determine the graphics adapter video I/O capabilities.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pAdapterCaps | Pointer to receive capabilities
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NVVIOCAPS struct version used by the app is not compatible
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NvU32 * pOutputsMask
NV_DISPLAY_PATH_INFO NvU32* pPathCount
NV_DISPLAY_PATH_INFO * pPathInfo
NV_GPU_PERF_PSTATES_INFO* pPerfPstatesInfo
NVVIOSYNCDELAY * pSyncDelay

Function: NvAPI_VIO_GetCapabilities

Description: This API determine the graphics adapter video I/O capabilities.

SUPPORTED OS: Windows XP and higher

Since:
Release: 190
Parameters:
[in] | NvVioHandle | The caller provides the SDI device handle as input.
[out] | pAdapterCaps | Pointer to receive capabilities
Return values:
NVAPI_OK | Success
NVAPI_API_NOT_INTIALIZED | NVAPI Not Initialized
NVAPI_INVALID_ARGUMENT | Arguments passed to API are not valid
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NVVIOCAPS struct version used by the app is not compatible
NVAPI_NOT_SUPPORTED | Video I/O not supported
NVAPI_ERROR | NVAPI Random errors
NV_VIEW_TARGET_INFO* pTargetInfo
NV_VIEW_TARGET_INFO NvU32* pTargetMaskCount
NV_VIEW_TARGET_INFO* pTargets
NV_VIEW_TARGET_INFO NvU32 NV_TARGET_VIEW_MODE* pTargetView
NV_DISPLAY_PATH_INFO NvU32 NV_TARGET_VIEW_MODE* pTargetViewMode
NV_DISPLAY_DRIVER_VERSION* pVersion
NV_VIEW_TARGET_INFO NV_TARGET_VIEW_MODE targetView


  • File List
  • Globals
Data Structures | Defines | Typedefs | Enumerations | Functions
nvapi_lite_common.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_salend.h"

Data Structures

struct | _NV_RECT
struct | NvSBox
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V1
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V2
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V3

Defines

#define | NV_TRUE ((NvBool)(0 == 0))
#define | NV_FALSE ((NvBool)(0 != 0))
#define | NV_DECLARE_HANDLE(name) struct name##__ { int unused; }; typedef struct name##__ *name
#define | NVAPI_GENERIC_STRING_MAX 4096
#define | NVAPI_LONG_STRING_MAX 256
#define | NVAPI_SHORT_STRING_MAX 64
#define | NVAPI_MAX_PHYSICAL_GPUS 64
#define | NVAPI_MAX_PHYSICAL_BRIDGES 100
#define | NVAPI_PHYSICAL_GPUS 32
#define | NVAPI_MAX_LOGICAL_GPUS 64
#define | NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES 256
#define | NVAPI_MAX_AVAILABLE_SLI_GROUPS 256
#define | NVAPI_MAX_GPU_TOPOLOGIES NVAPI_MAX_PHYSICAL_GPUS
#define | NVAPI_MAX_GPU_PER_TOPOLOGY 8
#define | NVAPI_MAX_DISPLAY_HEADS 2
#define | NVAPI_ADVANCED_DISPLAY_HEADS 4
#define | NVAPI_MAX_DISPLAYS NVAPI_PHYSICAL_GPUS * NVAPI_ADVANCED_DISPLAY_HEADS
#define | NVAPI_MAX_ACPI_IDS 16
#define | NVAPI_MAX_VIEW_MODES 8
#define | NV_MAX_HEADS 4
#define | NVAPI_MAX_HEADS_PER_GPU 32
#define | NV_MAX_HEADS 4
#define | NV_MAX_VID_STREAMS 4
#define | NV_MAX_VID_PROFILES 4
#define | NVAPI_SYSTEM_MAX_DISPLAYS NVAPI_MAX_PHYSICAL_GPUS * NV_MAX_HEADS
#define | NVAPI_SYSTEM_MAX_HWBCS 128
#define | NVAPI_SYSTEM_HWBC_INVALID_ID 0xffffffff
#define | NVAPI_MAX_AUDIO_DEVICES 16
#define | MAKE_NVAPI_VERSION(typeName, ver) (NvU32)(sizeof(typeName) | ((ver)<<16))
#define | GET_NVAPI_VERSION(ver) (NvU32)((ver)>>16)
#define | GET_NVAPI_SIZE(ver) (NvU32)((ver) & 0xffff)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V1,1)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V2,2)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V3,3)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3
#define | NVAPI_DEFAULT_HANDLE 0
#define | NV_BIT(x) (1 << (x))

Typedefs

typedef unsigned __int64 | NvU64
typedef __int64 | NvS64
typedef signed int | NvS32
typedef unsigned long | NvU32
typedef unsigned long | temp_NvU32
typedef signed short | NvS16
typedef unsigned short | NvU16
typedef unsigned char | NvU8
typedef signed char | NvS8
typedef NvU8 | NvBool
typedef struct _NV_RECT | NV_RECT
typedef void * | StereoHandle
typedef char | NvAPI_String [NVAPI_GENERIC_STRING_MAX]
typedef char | NvAPI_LongString [NVAPI_LONG_STRING_MAX]
typedef char | NvAPI_ShortString [NVAPI_SHORT_STRING_MAX]
typedef enum _NvAPI_Status | NvAPI_Status
typedef
NV_DISPLAY_DRIVER_MEMORY_INFO_V3 		NV_DISPLAY_DRIVER_MEMORY_INFO

Enumerations

enum _NvAPI_Status {
NVAPI_OK = 0, NVAPI_ERROR = -1, NVAPI_LIBRARY_NOT_FOUND = -2, NVAPI_NO_IMPLEMENTATION = -3,
NVAPI_API_NOT_INITIALIZED = -4, NVAPI_INVALID_ARGUMENT = -5, NVAPI_NVIDIA_DEVICE_NOT_FOUND = -6, NVAPI_END_ENUMERATION = -7,
NVAPI_INVALID_HANDLE = -8, NVAPI_INCOMPATIBLE_STRUCT_VERSION = -9, NVAPI_HANDLE_INVALIDATED = -10, NVAPI_OPENGL_CONTEXT_NOT_CURRENT = -11,
NVAPI_INVALID_POINTER = -14, NVAPI_NO_GL_EXPERT = -12, NVAPI_INSTRUMENTATION_DISABLED = -13, NVAPI_NO_GL_NSIGHT = -15,
NVAPI_EXPECTED_LOGICAL_GPU_HANDLE = -100, NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE = -101, NVAPI_EXPECTED_DISPLAY_HANDLE = -102, NVAPI_INVALID_COMBINATION = -103,
NVAPI_NOT_SUPPORTED = -104, NVAPI_PORTID_NOT_FOUND = -105, NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE = -106, NVAPI_INVALID_PERF_LEVEL = -107,
NVAPI_DEVICE_BUSY = -108, NVAPI_NV_PERSIST_FILE_NOT_FOUND = -109, NVAPI_PERSIST_DATA_NOT_FOUND = -110, NVAPI_EXPECTED_TV_DISPLAY = -111,
NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR = -112, NVAPI_NO_ACTIVE_SLI_TOPOLOGY = -113, NVAPI_SLI_RENDERING_MODE_NOTALLOWED = -114, NVAPI_EXPECTED_DIGITAL_FLAT_PANEL = -115,
NVAPI_ARGUMENT_EXCEED_MAX_SIZE = -116, NVAPI_DEVICE_SWITCHING_NOT_ALLOWED = -117, NVAPI_TESTING_CLOCKS_NOT_SUPPORTED = -118, NVAPI_UNKNOWN_UNDERSCAN_CONFIG = -119,
NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO = -120, NVAPI_DATA_NOT_FOUND = -121, NVAPI_EXPECTED_ANALOG_DISPLAY = -122, NVAPI_NO_VIDLINK = -123,
NVAPI_REQUIRES_REBOOT = -124, NVAPI_INVALID_HYBRID_MODE = -125, NVAPI_MIXED_TARGET_TYPES = -126, NVAPI_SYSWOW64_NOT_SUPPORTED = -127,
NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED = -128, NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS = -129, NVAPI_OUT_OF_MEMORY = -130, NVAPI_WAS_STILL_DRAWING = -131,
NVAPI_FILE_NOT_FOUND = -132, NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS = -133, NVAPI_INVALID_CALL = -134, NVAPI_D3D10_1_LIBRARY_NOT_FOUND = -135,
NVAPI_FUNCTION_NOT_FOUND = -136, NVAPI_INVALID_USER_PRIVILEGE = -137, NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE = -138, NVAPI_EXPECTED_COMPUTE_GPU_HANDLE = -139,
NVAPI_STEREO_NOT_INITIALIZED = -140, NVAPI_STEREO_REGISTRY_ACCESS_FAILED = -141, NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED = -142, NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED = -143,
NVAPI_STEREO_NOT_ENABLED = -144, NVAPI_STEREO_NOT_TURNED_ON = -145, NVAPI_STEREO_INVALID_DEVICE_INTERFACE = -146, NVAPI_STEREO_PARAMETER_OUT_OF_RANGE = -147,
NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED = -148, NVAPI_TOPO_NOT_POSSIBLE = -149, NVAPI_MODE_CHANGE_FAILED = -150, NVAPI_D3D11_LIBRARY_NOT_FOUND = -151,
NVAPI_INVALID_ADDRESS = -152, NVAPI_STRING_TOO_SMALL = -153, NVAPI_MATCHING_DEVICE_NOT_FOUND = -154, NVAPI_DRIVER_RUNNING = -155,
NVAPI_DRIVER_NOTRUNNING = -156, NVAPI_ERROR_DRIVER_RELOAD_REQUIRED = -157, NVAPI_SET_NOT_ALLOWED = -158, NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED = -159,
NVAPI_SETTING_NOT_FOUND = -160, NVAPI_SETTING_SIZE_TOO_LARGE = -161, NVAPI_TOO_MANY_SETTINGS_IN_PROFILE = -162, NVAPI_PROFILE_NOT_FOUND = -163,
NVAPI_PROFILE_NAME_IN_USE = -164, NVAPI_PROFILE_NAME_EMPTY = -165, NVAPI_EXECUTABLE_NOT_FOUND = -166, NVAPI_EXECUTABLE_ALREADY_IN_USE = -167,
NVAPI_DATATYPE_MISMATCH = -168, NVAPI_PROFILE_REMOVED = -169, NVAPI_UNREGISTERED_RESOURCE = -170, NVAPI_ID_OUT_OF_RANGE = -171,
NVAPI_DISPLAYCONFIG_VALIDATION_FAILED = -172, NVAPI_DPMST_CHANGED = -173, NVAPI_INSUFFICIENT_BUFFER = -174, NVAPI_ACCESS_DENIED = -175,
NVAPI_MOSAIC_NOT_ACTIVE = -176, NVAPI_SHARE_RESOURCE_RELOCATED = -177, NVAPI_REQUEST_USER_TO_DISABLE_DWM = -178, NVAPI_D3D_DEVICE_LOST = -179,
NVAPI_INVALID_CONFIGURATION = -180, NVAPI_STEREO_HANDSHAKE_NOT_DONE = -181, NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS = -182, NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED = -183,
NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST = -184, NVAPI_CLUSTER_ALREADY_EXISTS = -185, NVAPI_DPMST_DISPLAY_ID_EXPECTED = -186, NVAPI_INVALID_DISPLAY_ID = -187,
NVAPI_STREAM_IS_OUT_OF_SYNC = -188, NVAPI_INCOMPATIBLE_AUDIO_DRIVER = -189, NVAPI_VALUE_ALREADY_SET = -190, NVAPI_TIMEOUT = -191,
NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE = -192, NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE = -193, NVAPI_SYNC_NOT_ACTIVE = -194, NVAPI_SYNC_MASTER_NOT_FOUND = -195,
NVAPI_INVALID_SYNC_TOPOLOGY = -196, NVAPI_ECID_SIGN_ALGO_UNSUPPORTED = -197, NVAPI_ECID_KEY_VERIFICATION_FAILED = -198, NVAPI_FIRMWARE_OUT_OF_DATE = -199,
NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED = -200, NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED = -201, NVAPI_D3D_DEVICE_NOT_REGISTERED = -202, NVAPI_RESOURCE_NOT_ACQUIRED = -203,
NVAPI_TIMING_NOT_SUPPORTED = -204, NVAPI_HDCP_ENCRYPTION_FAILED = -205, NVAPI_PCLK_LIMITATION_FAILED = -206, NVAPI_NO_CONNECTOR_FOUND = -207
}

Functions

NV_DECLARE_HANDLE (NvDisplayHandle)
NV_DECLARE_HANDLE (NvMonitorHandle)
NV_DECLARE_HANDLE (NvUnAttachedDisplayHandle)
NV_DECLARE_HANDLE (NvLogicalGpuHandle)
NV_DECLARE_HANDLE (NvPhysicalGpuHandle)
NV_DECLARE_HANDLE (NvEventHandle)
NV_DECLARE_HANDLE (NvVisualComputingDeviceHandle)
NV_DECLARE_HANDLE (NvHICHandle)
NV_DECLARE_HANDLE (NvGSyncDeviceHandle)
NV_DECLARE_HANDLE (NvVioHandle)
NV_DECLARE_HANDLE (NvTransitionHandle)
NV_DECLARE_HANDLE (NvAudioHandle)
NV_DECLARE_HANDLE (Nv3DVPContextHandle)
NV_DECLARE_HANDLE (Nv3DVPTransceiverHandle)
NV_DECLARE_HANDLE (Nv3DVPGlassesHandle)
NV_DECLARE_HANDLE (NvSourceHandle)
NV_DECLARE_HANDLE (NvTargetHandle)
NV_DECLARE_HANDLE (NVDX_SwapChainHandle)
NVAPI_INTERFACE | NvAPI_SYS_GetDriverAndBranchVersion (NvU32 *pDriverVersion, NvAPI_ShortString szBuildBranchString)
NVAPI_INTERFACE | NvAPI_GPU_GetMemoryInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_DISPLAY_DRIVER_MEMORY_INFO *pMemoryInfo)
NVAPI_INTERFACE | NvAPI_EnumPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NV_DECLARE_HANDLE (NVDX_ObjectHandle)
NVAPI_INTERFACE | NvAPI_D3D_GetObjectHandleForResource (IUnknown *pDevice, IUnknown *pResource, NVDX_ObjectHandle *pHandle)

Define Documentation

#define NV_DECLARE_HANDLE ( name ) struct name##__ { int unused; }; typedef struct name##__ *name
#define NV_FALSE ((NvBool)(0 != 0))
#define NV_TRUE ((NvBool)(0 == 0))

Typedef Documentation

typedef struct _NV_RECT NV_RECT
typedef NvU8 NvBool
typedef signed short NvS16
typedef signed int NvS32
typedef __int64 NvS64
typedef signed char NvS8
typedef unsigned short NvU16
typedef unsigned long NvU32
typedef unsigned __int64 NvU64
typedef unsigned char NvU8
typedef unsigned long temp_NvU32

Function Documentation

NV_DECLARE_HANDLE ( NVDX_ObjectHandle )


  • File List
  • Globals
Enumerations | Functions
nvapi_lite_d3dext.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Enumerations

enum NVAPI_DEVICE_FEATURE_LEVEL {
NVAPI_DEVICE_FEATURE_LEVEL_NULL = -1, NVAPI_DEVICE_FEATURE_LEVEL_10_0 = 0, NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS = 1, NVAPI_DEVICE_FEATURE_LEVEL_10_1 = 2,
NVAPI_DEVICE_FEATURE_LEVEL_11_0 = 3
}

Functions

NVAPI_INTERFACE | NvAPI_D3D11_CreateDevice (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_CreateDeviceAndSwapChain (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, CONST DXGI_SWAP_CHAIN_DESC *pSwapChainDesc, IDXGISwapChain **ppSwapChain, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_SetDepthBoundsTest (IUnknown *pDeviceOrContext, NvU32 bEnable, float fMinDepth, float fMaxDepth)


  • File List
  • Globals
nvapi_lite_salend.h File Reference


  • File List
  • Globals
Defines
nvapi_lite_salstart.h File Reference

Defines

#define NVAPI_INTERFACE extern __success(return == NVAPI_OK) NvAPI_Status __cdecl

Define Documentation

#define NVAPI_INTERFACE extern __success(return == NVAPI_OK) NvAPI_Status __cdecl


  • File List
  • Globals
Data Structures | Defines | Typedefs | Enumerations | Functions
nvapi_lite_sli.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Data Structures

struct | NV_GET_CURRENT_SLI_STATE

Defines

#define | NV_GET_CURRENT_SLI_STATE_VER MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE,1)

Typedefs

typedef enum
_NVAPI_D3D_SETRESOURCEHINT_CATEGORY 		NVAPI_D3D_SETRESOURCEHINT_CATEGORY
typedef enum
_NVAPI_D3D_SETRESOURCEHINT_SLI 		NVAPI_D3D_SETRESOURCEHINT_SLI
typedef enum
_NVAPI_D3D_RESOURCERENDERING_FLAG 		NVAPI_D3D_RESOURCERENDERING_FLAG

Enumerations

enum | _NVAPI_D3D_SETRESOURCEHINT_CATEGORY { NVAPI_D3D_SRH_CATEGORY_SLI = 1 }
enum | _NVAPI_D3D_SETRESOURCEHINT_SLI { NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC = 1, NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE = 2 }
enum | _NVAPI_D3D_RESOURCERENDERING_FLAG { NVAPI_D3D_RR_FLAG_DEFAULTS = 0x00000000, NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT = 0x00000001, NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT = 0x00000002, NVAPI_D3D_RR_FLAG_MULTI_FRAME = 0x00000004 }

Functions

NVAPI_INTERFACE | NvAPI_D3D_GetCurrentSLIState (IUnknown *pDevice, NV_GET_CURRENT_SLI_STATE *pSliState)
NVAPI_INTERFACE | NvAPI_D3D_SetResourceHint (IUnknown *pDev, NVDX_ObjectHandle obj, NVAPI_D3D_SETRESOURCEHINT_CATEGORY dwHintCategory, NvU32 dwHintName, NvU32 *pdwHintValue)
NVAPI_INTERFACE | NvAPI_D3D_BeginResourceRendering (IUnknown *pDev, NVDX_ObjectHandle obj, NvU32 Flags)
NVAPI_INTERFACE | NvAPI_D3D_EndResourceRendering (IUnknown *pDev, NVDX_ObjectHandle obj, NvU32 Flags)


  • File List
  • Globals
Typedefs | Enumerations | Functions
nvapi_lite_stereo.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Typedefs

typedef enum _NV_StereoActiveEye | NV_STEREO_ACTIVE_EYE
typedef enum _NV_StereoDriverMode | NV_STEREO_DRIVER_MODE
typedef enum
_NVAPI_STEREO_SURFACECREATEMODE 		NVAPI_STEREO_SURFACECREATEMODE

Enumerations

enum | _NV_StereoActiveEye { NVAPI_STEREO_EYE_RIGHT = 1, NVAPI_STEREO_EYE_LEFT = 2, NVAPI_STEREO_EYE_MONO = 3 }
enum | _NV_StereoDriverMode { NVAPI_STEREO_DRIVER_MODE_AUTOMATIC = 0, NVAPI_STEREO_DRIVER_MODE_DIRECT = 2 }
enum | _NVAPI_STEREO_SURFACECREATEMODE { NVAPI_STEREO_SURFACECREATEMODE_AUTO, NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO, NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO }

Functions

NVAPI_INTERFACE | NvAPI_Stereo_Enable (void)
NVAPI_INTERFACE | NvAPI_Stereo_Disable (void)
NVAPI_INTERFACE | NvAPI_Stereo_IsEnabled (NvU8 *pIsStereoEnabled)
NVAPI_INTERFACE | NvAPI_Stereo_CreateHandleFromIUnknown (IUnknown *pDevice, StereoHandle *pStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DestroyHandle (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Activate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Deactivate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IsActivated (StereoHandle stereoHandle, NvU8 *pIsStereoOn)
NVAPI_INTERFACE | NvAPI_Stereo_GetSeparation (StereoHandle stereoHandle, float *pSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_SetSeparation (StereoHandle stereoHandle, float newSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_GetConvergence (StereoHandle stereoHandle, float *pConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetConvergence (StereoHandle stereoHandle, float newConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetActiveEye (StereoHandle hStereoHandle, NV_STEREO_ACTIVE_EYE StereoEye)
NVAPI_INTERFACE | NvAPI_Stereo_SetDriverMode (NV_STEREO_DRIVER_MODE mode)
NVAPI_INTERFACE | NvAPI_Stereo_GetEyeSeparation (StereoHandle hStereoHandle, float *pSeparation)
NVAPI_INTERFACE | NvAPI_Stereo_IsWindowedModeSupported (NvU8 *bSupported)
NVAPI_INTERFACE | NvAPI_Stereo_SetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE creationMode)
NVAPI_INTERFACE | NvAPI_Stereo_GetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE *pCreationMode)
NVAPI_INTERFACE | NvAPI_Stereo_Debug_WasLastDrawStereoized (__in StereoHandle hStereoHandle, __out NvU8 *pWasStereoized)
NVAPI_INTERFACE | NvAPI_Stereo_SetDefaultProfile (__in const char *szProfileName)
NVAPI_INTERFACE | NvAPI_Stereo_GetDefaultProfile (__in NvU32 cbSizeIn, __out_bcount_part_opt(cbSizeIn,*pcbSizeOut) char *szProfileName, __out NvU32 *pcbSizeOut)


  • File List
  • Globals
Defines | Functions
nvapi_lite_surround.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Defines

#define | NV_MOSAIC_MAX_DISPLAYS (64)

Functions

NVAPI_INTERFACE | NvAPI_DISP_GetGDIPrimaryDisplayId (NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_Mosaic_GetDisplayViewportsByResolution (NvU32 displayId, NvU32 srcWidth, NvU32 srcHeight, NV_RECT viewports[NV_MOSAIC_MAX_DISPLAYS], NvU8 *bezelCorrected)

Define Documentation

#define NV_MOSAIC_MAX_DISPLAYS (64)


  • File List
  • Globals
Data Structures | Defines | Typedefs | Enumerations
NvApiDriverSettings.h File Reference

Data Structures

struct | _SettingDWORDNameString
struct | _SettingWSTRINGNameString

Defines

#define | OGL_AA_LINE_GAMMA_STRING L"Antialiasing - Line gamma"
#define | OGL_DEEP_COLOR_SCANOUT_STRING L"Deep color for 3D applications"
#define | OGL_DEFAULT_SWAP_INTERVAL_STRING L"OpenGL default swap interval"
#define | OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING L"OpenGL default swap interval fraction"
#define | OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING L"OpenGL default swap interval sign"
#define | OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING L"Event Log Severity Threshold"
#define | OGL_EXTENSION_STRING_VERSION_STRING L"Extension String version"
#define | OGL_FORCE_BLIT_STRING L"Buffer-flipping mode"
#define | OGL_FORCE_STEREO_STRING L"Force Stereo shuttering"
#define | OGL_IMPLICIT_GPU_AFFINITY_STRING L"Preferred OpenGL GPU"
#define | OGL_MAX_FRAMES_ALLOWED_STRING L"Maximum frames allowed"
#define | OGL_MULTIMON_STRING L"Multi-display/mixed-GPU acceleration"
#define | OGL_OVERLAY_PIXEL_TYPE_STRING L"Exported Overlay pixel types"
#define | OGL_OVERLAY_SUPPORT_STRING L"Enable overlay"
#define | OGL_QUALITY_ENHANCEMENTS_STRING L"High level control of the rendering quality on OpenGL"
#define | OGL_SINGLE_BACKDEPTH_BUFFER_STRING L"Unified back/depth buffer"
#define | OGL_SLI_MULTICAST_STRING L"Enable NV_gpu_multicast extension"
#define | OGL_THREAD_CONTROL_STRING L"Threaded optimization"
#define | OGL_TRIPLE_BUFFER_STRING L"Triple buffering"
#define | OGL_VIDEO_EDITING_MODE_STRING L"OpenGL video-editing mode"
#define | AA_BEHAVIOR_FLAGS_STRING L"Antialiasing - Behavior Flags"
#define | AA_MODE_ALPHATOCOVERAGE_STRING L"Antialiasing - Transparency Multisampling"
#define | AA_MODE_GAMMACORRECTION_STRING L"Antialiasing - Gamma correction"
#define | AA_MODE_METHOD_STRING L"Antialiasing - Setting"
#define | AA_MODE_REPLAY_STRING L"Antialiasing - Transparency Supersampling"
#define | AA_MODE_SELECTOR_STRING L"Antialiasing - Mode"
#define | AA_MODE_SELECTOR_SLIAA_STRING L"Antialiasing - SLI AA"
#define | ANISO_MODE_LEVEL_STRING L"Anisotropic filtering setting"
#define | ANISO_MODE_SELECTOR_STRING L"Anisotropic filtering mode"
#define | APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING L"Application Profile Notification Popup Timeout"
#define | APPLICATION_STEAM_ID_STRING L"Steam Application ID"
#define | CPL_HIDDEN_PROFILE_STRING L"Do not display this profile in the Control Panel"
#define | CUDA_EXCLUDED_GPUS_STRING L"List of Universal GPU ids"
#define | D3DOGL_GPU_MAX_POWER_STRING L"Maximum GPU Power"
#define | EXPORT_PERF_COUNTERS_STRING L"Export Performance Counters"
#define | FXAA_ALLOW_STRING L"NVIDIA Predefined FXAA Usage"
#define | FXAA_ENABLE_STRING L"Enable FXAA"
#define | FXAA_INDICATOR_ENABLE_STRING L"Enable FXAA Indicator"
#define | MCSFRSHOWSPLIT_STRING L"SLI indicator"
#define | NV_QUALITY_UPSCALING_STRING L"NVIDIA Quality upscaling"
#define | OPTIMUS_MAXAA_STRING L"Maximum AA samples allowed for a given application"
#define | PHYSXINDICATOR_STRING L"Display the PhysX indicator"
#define | PREFERRED_PSTATE_STRING L"Power management mode"
#define | PREVENT_UI_AF_OVERRIDE_STRING L"No override of Anisotropic filtering"
#define | PS_FRAMERATE_LIMITER_STRING L"Frame Rate Limiter"
#define | PS_FRAMERATE_LIMITER_2_CONTROL_STRING L"Frame Rate Limiter 2 Control"
#define | PS_FRAMERATE_LIMITER_GPS_CTRL_STRING L"Frame Rate Monitor"
#define | PS_FRAMERATE_MONITOR_CTRL_STRING L"Frame Rate Monitor Control"
#define | SHIM_MAXRES_STRING L"Maximum resolution allowed for a given application"
#define | SHIM_MCCOMPAT_STRING L"Optimus flags for enabled applications"
#define | SHIM_RENDERING_MODE_STRING L"Enable application for Optimus"
#define | SHIM_RENDERING_OPTIONS_STRING L"Shim Rendering Mode Options per application for Optimus"
#define | SLI_GPU_COUNT_STRING L"Number of GPUs to use on SLI rendering mode"
#define | SLI_PREDEFINED_GPU_COUNT_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode"
#define | SLI_PREDEFINED_GPU_COUNT_DX10_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode on DirectX 10"
#define | SLI_PREDEFINED_MODE_STRING L"NVIDIA predefined SLI mode"
#define | SLI_PREDEFINED_MODE_DX10_STRING L"NVIDIA predefined SLI mode on DirectX 10"
#define | SLI_RENDERING_MODE_STRING L"SLI rendering mode"
#define | VRPRERENDERLIMIT_STRING L"Virtual Reality pre-rendered frames"
#define | VRRFEATUREINDICATOR_STRING L"Toggle the VRR global feature"
#define | VRROVERLAYINDICATOR_STRING L"Display the VRR Overlay Indicator"
#define | VRRREQUESTSTATE_STRING L"VRR requested state"
#define | VRR_APP_OVERRIDE_STRING L"G-SYNC"
#define | VRR_APP_OVERRIDE_REQUEST_STATE_STRING L"G-SYNC"
#define | VRR_MODE_STRING L"Enable G-SYNC globally"
#define | VSYNCSMOOTHAFR_STRING L"Flag to control smooth AFR behavior"
#define | VSYNCVRRCONTROL_STRING L"Variable refresh Rate"
#define | VSYNC_BEHAVIOR_FLAGS_STRING L"Vsync - Behavior Flags"
#define | WKS_API_STEREO_EYES_EXCHANGE_STRING L"Stereo - Swap eyes"
#define | WKS_API_STEREO_MODE_STRING L"Stereo - Display mode"
#define | WKS_MEMORY_ALLOCATION_POLICY_STRING L"Memory Allocation Policy"
#define | WKS_STEREO_DONGLE_SUPPORT_STRING L"Stereo - Dongle Support"
#define | WKS_STEREO_SUPPORT_STRING L"Stereo - Enable"
#define | WKS_STEREO_SWAP_MODE_STRING L"Stereo – swap mode"
#define | AO_MODE_STRING L"Ambient Occlusion"
#define | AO_MODE_ACTIVE_STRING L"NVIDIA Predefined Ambient Occlusion Usage"
#define | AUTO_LODBIASADJUST_STRING L"Texture filtering - Driver Controlled LOD Bias"
#define | ICAFE_LOGO_CONFIG_STRING L"ICafe Settings"
#define | LODBIASADJUST_STRING L"Texture filtering - LOD Bias"
#define | MAXWELL_B_SAMPLE_INTERLEAVE_STRING L"Enable sample interleaving (MFAA)"
#define | NLS_ALLOW_STRING L"NVIDIA Predefined Nonlinear Scale Usage"
#define | NLS_ENABLE_STRING L"Enable Nonlinear Scale"
#define | PRERENDERLIMIT_STRING L"Maximum pre-rendered frames"
#define | PS_SHADERDISKCACHE_STRING L"Shader Cache"
#define | PS_TEXFILTER_ANISO_OPTS2_STRING L"Texture filtering - Anisotropic sample optimization"
#define | PS_TEXFILTER_BILINEAR_IN_ANISO_STRING L"Texture filtering - Anisotropic filter optimization"
#define | PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING L"Texture filtering - Trilinear optimization"
#define | PS_TEXFILTER_NO_NEG_LODBIAS_STRING L"Texture filtering - Negative LOD bias"
#define | QUALITY_ENHANCEMENTS_STRING L"Texture filtering - Quality"
#define | REFRESH_RATE_OVERRIDE_STRING L"Preferred refresh rate"
#define | SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING L"PowerThrottle"
#define | SET_VAB_DATA_STRING L"VAB Default Data"
#define | VSYNCMODE_STRING L"Vertical Sync"
#define | VSYNCTEARCONTROL_STRING L"Vertical Sync Tear Control"
#define | OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR L"OGL_DEFAULT_RENDERING_GPU"
#define | OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT L"autoselect"
#define | OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES 1
#define | OGL_IMPLICIT_GPU_AFFINITY_DEFAULT OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT
#define | CUDA_EXCLUDED_GPUS_NONE L"none"
#define | CUDA_EXCLUDED_GPUS_NUM_VALUES 1
#define | CUDA_EXCLUDED_GPUS_DEFAULT CUDA_EXCLUDED_GPUS_NONE
#define | D3DOGL_GPU_MAX_POWER_DEFAULTPOWER L"0"
#define | D3DOGL_GPU_MAX_POWER_NUM_VALUES 1
#define | D3DOGL_GPU_MAX_POWER_DEFAULT D3DOGL_GPU_MAX_POWER_DEFAULTPOWER

Typedefs

typedef struct
_SettingDWORDNameString 		SettingDWORDNameString
typedef struct
_SettingWSTRINGNameString 		SettingWSTRINGNameString

Enumerations

enum ESetting {
OGL_AA_LINE_GAMMA_ID = 0x2089BF6C, OGL_DEEP_COLOR_SCANOUT_ID = 0x2097C2F6, OGL_DEFAULT_SWAP_INTERVAL_ID = 0x206A6582, OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID = 0x206C4581,
OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID = 0x20655CFA, OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID = 0x209DF23E, OGL_EXTENSION_STRING_VERSION_ID = 0x20FF7493, OGL_FORCE_BLIT_ID = 0x201F619F,
OGL_FORCE_STEREO_ID = 0x204D9A0C, OGL_IMPLICIT_GPU_AFFINITY_ID = 0x20D0F3E6, OGL_MAX_FRAMES_ALLOWED_ID = 0x208E55E3, OGL_MULTIMON_ID = 0x200AEBFC,
OGL_OVERLAY_PIXEL_TYPE_ID = 0x209AE66F, OGL_OVERLAY_SUPPORT_ID = 0x206C28C4, OGL_QUALITY_ENHANCEMENTS_ID = 0x20797D6C, OGL_SINGLE_BACKDEPTH_BUFFER_ID = 0x20A29055,
OGL_SLI_MULTICAST_ID = 0x2092D3BE, OGL_THREAD_CONTROL_ID = 0x20C1221E, OGL_TRIPLE_BUFFER_ID = 0x20FDD1F9, OGL_VIDEO_EDITING_MODE_ID = 0x20EE02B4,
AA_BEHAVIOR_FLAGS_ID = 0x10ECDB82, AA_MODE_ALPHATOCOVERAGE_ID = 0x10FC2D9C, AA_MODE_GAMMACORRECTION_ID = 0x107D639D, AA_MODE_METHOD_ID = 0x10D773D2,
AA_MODE_REPLAY_ID = 0x10D48A85, AA_MODE_SELECTOR_ID = 0x107EFC5B, AA_MODE_SELECTOR_SLIAA_ID = 0x107AFC5B, ANISO_MODE_LEVEL_ID = 0x101E61A9,
ANISO_MODE_SELECTOR_ID = 0x10D2BB16, APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID = 0x104554B6, APPLICATION_STEAM_ID_ID = 0x107CDDBC, CPL_HIDDEN_PROFILE_ID = 0x106D5CFF,
CUDA_EXCLUDED_GPUS_ID = 0x10354FF8, D3DOGL_GPU_MAX_POWER_ID = 0x10D1EF29, EXPORT_PERF_COUNTERS_ID = 0x108F0841, FXAA_ALLOW_ID = 0x1034CB89,
FXAA_ENABLE_ID = 0x1074C972, FXAA_INDICATOR_ENABLE_ID = 0x1068FB9C, MCSFRSHOWSPLIT_ID = 0x10287051, NV_QUALITY_UPSCALING_ID = 0x10444444,
OPTIMUS_MAXAA_ID = 0x10F9DC83, PHYSXINDICATOR_ID = 0x1094F16F, PREFERRED_PSTATE_ID = 0x1057EB71, PREVENT_UI_AF_OVERRIDE_ID = 0x103BCCB5,
PS_FRAMERATE_LIMITER_ID = 0x10834FEE, PS_FRAMERATE_LIMITER_2_CONTROL_ID = 0x10834FFF, PS_FRAMERATE_LIMITER_GPS_CTRL_ID = 0x10834F01, PS_FRAMERATE_MONITOR_CTRL_ID = 0x10834F05,
SHIM_MAXRES_ID = 0x10F9DC82, SHIM_MCCOMPAT_ID = 0x10F9DC80, SHIM_RENDERING_MODE_ID = 0x10F9DC81, SHIM_RENDERING_OPTIONS_ID = 0x10F9DC84,
SLI_GPU_COUNT_ID = 0x1033DCD1, SLI_PREDEFINED_GPU_COUNT_ID = 0x1033DCD2, SLI_PREDEFINED_GPU_COUNT_DX10_ID = 0x1033DCD3, SLI_PREDEFINED_MODE_ID = 0x1033CEC1,
SLI_PREDEFINED_MODE_DX10_ID = 0x1033CEC2, SLI_RENDERING_MODE_ID = 0x1033CED1, VRPRERENDERLIMIT_ID = 0x10111133, VRRFEATUREINDICATOR_ID = 0x1094F157,
VRROVERLAYINDICATOR_ID = 0x1095F16F, VRRREQUESTSTATE_ID = 0x1094F1F7, VRR_APP_OVERRIDE_ID = 0x10A879CF, VRR_APP_OVERRIDE_REQUEST_STATE_ID = 0x10A879AC,
VRR_MODE_ID = 0x1194F158, VSYNCSMOOTHAFR_ID = 0x101AE763, VSYNCVRRCONTROL_ID = 0x10A879CE, VSYNC_BEHAVIOR_FLAGS_ID = 0x10FDEC23,
WKS_API_STEREO_EYES_EXCHANGE_ID = 0x11AE435C, WKS_API_STEREO_MODE_ID = 0x11E91A61, WKS_MEMORY_ALLOCATION_POLICY_ID = 0x11112233, WKS_STEREO_DONGLE_SUPPORT_ID = 0x112493BD,
WKS_STEREO_SUPPORT_ID = 0x11AA9E99, WKS_STEREO_SWAP_MODE_ID = 0x11333333, AO_MODE_ID = 0x00667329, AO_MODE_ACTIVE_ID = 0x00664339,
AUTO_LODBIASADJUST_ID = 0x00638E8F, ICAFE_LOGO_CONFIG_ID = 0x00DB1337, LODBIASADJUST_ID = 0x00738E8F, MAXWELL_B_SAMPLE_INTERLEAVE_ID = 0x0098C1AC,
NLS_ALLOW_ID = 0x00041806, NLS_ENABLE_ID = 0x00120618, PRERENDERLIMIT_ID = 0x007BA09E, PS_SHADERDISKCACHE_ID = 0x00198FFF,
PS_TEXFILTER_ANISO_OPTS2_ID = 0x00E73211, PS_TEXFILTER_BILINEAR_IN_ANISO_ID = 0x0084CD70, PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID = 0x002ECAF2, PS_TEXFILTER_NO_NEG_LODBIAS_ID = 0x0019BB68,
QUALITY_ENHANCEMENTS_ID = 0x00CE2691, REFRESH_RATE_OVERRIDE_ID = 0x0064B541, SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID = 0x00AE785C, SET_VAB_DATA_ID = 0x00AB8687,
VSYNCMODE_ID = 0x00A879CF, VSYNCTEARCONTROL_ID = 0x005A375C, TOTAL_DWORD_SETTING_NUM = 90, TOTAL_WSTRING_SETTING_NUM = 4,
TOTAL_SETTING_NUM = 94, INVALID_SETTING_ID = 0xFFFFFFFF
}
enum EValues_OGL_AA_LINE_GAMMA {
OGL_AA_LINE_GAMMA_DISABLED = 0x10, OGL_AA_LINE_GAMMA_ENABLED = 0x23, OGL_AA_LINE_GAMMA_MIN = 1, OGL_AA_LINE_GAMMA_MAX = 100,
OGL_AA_LINE_GAMMA_NUM_VALUES = 4, OGL_AA_LINE_GAMMA_DEFAULT = OGL_AA_LINE_GAMMA_DISABLED
}
enum | EValues_OGL_DEEP_COLOR_SCANOUT { OGL_DEEP_COLOR_SCANOUT_DISABLE = 0, OGL_DEEP_COLOR_SCANOUT_ENABLE = 1, OGL_DEEP_COLOR_SCANOUT_NUM_VALUES = 2, OGL_DEEP_COLOR_SCANOUT_DEFAULT = OGL_DEEP_COLOR_SCANOUT_ENABLE }
enum EValues_OGL_DEFAULT_SWAP_INTERVAL {
OGL_DEFAULT_SWAP_INTERVAL_TEAR = 0, OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE = 1, OGL_DEFAULT_SWAP_INTERVAL_VSYNC = 1, OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK = 0x0000FFFF,
OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK = 0xF0000000, OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF = 0xF0000000, OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON = 0x10000000, OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED = 0x00000000,
OGL_DEFAULT_SWAP_INTERVAL_DISABLE = 0xffffffff, OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES = 9, OGL_DEFAULT_SWAP_INTERVAL_DEFAULT = OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE
}
enum | EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL { OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES = 0, OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES = 100, OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES = 2, OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT = 0 }
enum | EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN { OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE = 0, OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE = 1, OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES = 2, OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT = OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE }
enum EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD {
OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE = 0, OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL = 1, OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING = 2, OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION = 3,
OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL = 4, OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES = 5, OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT = OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL
}
enum | EValues_OGL_FORCE_BLIT { OGL_FORCE_BLIT_ON = 1, OGL_FORCE_BLIT_OFF = 0, OGL_FORCE_BLIT_NUM_VALUES = 2, OGL_FORCE_BLIT_DEFAULT = OGL_FORCE_BLIT_OFF }
enum | EValues_OGL_FORCE_STEREO { OGL_FORCE_STEREO_OFF = 0, OGL_FORCE_STEREO_ON = 1, OGL_FORCE_STEREO_NUM_VALUES = 2, OGL_FORCE_STEREO_DEFAULT = OGL_FORCE_STEREO_OFF }
enum EValues_OGL_MULTIMON {
OGL_MULTIMON_SINGLE_MONITOR = 0, OGL_MULTIMON_COMPATIBILITY_LCD = 1, OGL_MULTIMON_COMPATIBILITY_GCD = 2, OGL_MULTIMON_PERFORMANCE_LCD = 3,
OGL_MULTIMON_PERFORMANCE_GCD = 4, OGL_MULTIMON_EXTENDED_SINGLE_MONITOR = 5, OGL_MULTIMON_PERFORMANCE_QUADRO = 6, OGL_MULTIMON_MULTIMON_BUFFER = 7,
OGL_MULTIMON_NUM_VALUES = 8, OGL_MULTIMON_DEFAULT = OGL_MULTIMON_PERFORMANCE_LCD
}
enum EValues_OGL_OVERLAY_PIXEL_TYPE {
OGL_OVERLAY_PIXEL_TYPE_NONE = 0x0, OGL_OVERLAY_PIXEL_TYPE_CI = 0x1, OGL_OVERLAY_PIXEL_TYPE_RGBA = 0x2, OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA = 0x3,
OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES = 4, OGL_OVERLAY_PIXEL_TYPE_DEFAULT = OGL_OVERLAY_PIXEL_TYPE_CI
}
enum EValues_OGL_OVERLAY_SUPPORT {
OGL_OVERLAY_SUPPORT_OFF = 0, OGL_OVERLAY_SUPPORT_ON = 1, OGL_OVERLAY_SUPPORT_FORCE_SW = 2, OGL_OVERLAY_SUPPORT_NUM_VALUES = 3,
OGL_OVERLAY_SUPPORT_DEFAULT = OGL_OVERLAY_SUPPORT_OFF
}
enum EValues_OGL_QUALITY_ENHANCEMENTS {
OGL_QUALITY_ENHANCEMENTS_HQUAL = -10, OGL_QUALITY_ENHANCEMENTS_QUAL = 0, OGL_QUALITY_ENHANCEMENTS_PERF = 10, OGL_QUALITY_ENHANCEMENTS_HPERF = 20,
OGL_QUALITY_ENHANCEMENTS_NUM_VALUES = 4, OGL_QUALITY_ENHANCEMENTS_DEFAULT = OGL_QUALITY_ENHANCEMENTS_QUAL
}
enum EValues_OGL_SINGLE_BACKDEPTH_BUFFER {
OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE = 0x0, OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE = 0x1, OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT = 0xffffffff, OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES = 3,
OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT = OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE
}
enum EValues_OGL_SLI_MULTICAST {
OGL_SLI_MULTICAST_DISABLE = 0x00, OGL_SLI_MULTICAST_ENABLE = 0x01, OGL_SLI_MULTICAST_FORCE_DISABLE = 0x02, OGL_SLI_MULTICAST_NUM_VALUES = 3,
OGL_SLI_MULTICAST_DEFAULT = OGL_SLI_MULTICAST_DISABLE
}
enum | EValues_OGL_THREAD_CONTROL { OGL_THREAD_CONTROL_ENABLE = 0x00000001, OGL_THREAD_CONTROL_DISABLE = 0x00000002, OGL_THREAD_CONTROL_NUM_VALUES = 2, OGL_THREAD_CONTROL_DEFAULT = 0 }
enum | EValues_OGL_TRIPLE_BUFFER { OGL_TRIPLE_BUFFER_DISABLED = 0x00000000, OGL_TRIPLE_BUFFER_ENABLED = 0x00000001, OGL_TRIPLE_BUFFER_NUM_VALUES = 2, OGL_TRIPLE_BUFFER_DEFAULT = OGL_TRIPLE_BUFFER_DISABLED }
enum | EValues_OGL_VIDEO_EDITING_MODE { OGL_VIDEO_EDITING_MODE_DISABLE = 0x00000000, OGL_VIDEO_EDITING_MODE_ENABLE = 0x00000001, OGL_VIDEO_EDITING_MODE_NUM_VALUES = 2, OGL_VIDEO_EDITING_MODE_DEFAULT = OGL_VIDEO_EDITING_MODE_DISABLE }
enum EValues_AA_BEHAVIOR_FLAGS {
AA_BEHAVIOR_FLAGS_NONE = 0x00000000, AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED = 0x00000001, AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE = 0x00000002, AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE = 0x00000003,
AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED = 0x00000004, AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE = 0x00000008, AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE = 0x0000000c, AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING = 0x00010000,
AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING = 0x00020000, AA_BEHAVIOR_FLAGS_DISABLE_CPLAA = 0x00040000, AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE = 0x00080000, AA_BEHAVIOR_FLAGS_DISABLE_SLIAA = 0x00100000,
AA_BEHAVIOR_FLAGS_DEFAULT = 0x00000000, AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4 = 0xf0000000, AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT = 28, AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4 = 0x0f000000,
AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT = 24, AA_BEHAVIOR_FLAGS_MASK = 0xff1f000f, AA_BEHAVIOR_FLAGS_NUM_VALUES = 18
}
enum EValues_AA_MODE_ALPHATOCOVERAGE {
AA_MODE_ALPHATOCOVERAGE_MODE_MASK = 0x00000004, AA_MODE_ALPHATOCOVERAGE_MODE_OFF = 0x00000000, AA_MODE_ALPHATOCOVERAGE_MODE_ON = 0x00000004, AA_MODE_ALPHATOCOVERAGE_MODE_MAX = 0x00000004,
AA_MODE_ALPHATOCOVERAGE_NUM_VALUES = 4, AA_MODE_ALPHATOCOVERAGE_DEFAULT = 0x00000000
}
enum EValues_AA_MODE_GAMMACORRECTION {
AA_MODE_GAMMACORRECTION_MASK = 0x00000003, AA_MODE_GAMMACORRECTION_OFF = 0x00000000, AA_MODE_GAMMACORRECTION_ON_IF_FOS = 0x00000001, AA_MODE_GAMMACORRECTION_ON_ALWAYS = 0x00000002,
AA_MODE_GAMMACORRECTION_MAX = 0x00000002, AA_MODE_GAMMACORRECTION_DEFAULT = 0x00000000, AA_MODE_GAMMACORRECTION_DEFAULT_TESLA = 0x00000002, AA_MODE_GAMMACORRECTION_DEFAULT_FERMI = 0x00000002,
AA_MODE_GAMMACORRECTION_NUM_VALUES = 8
}
enum EValues_AA_MODE_METHOD {
AA_MODE_METHOD_NONE = 0x0, AA_MODE_METHOD_SUPERSAMPLE_2X_H = 0x1, AA_MODE_METHOD_SUPERSAMPLE_2X_V = 0x2, AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5 = 0x2,
AA_MODE_METHOD_FREE_0x03 = 0x3, AA_MODE_METHOD_FREE_0x04 = 0x4, AA_MODE_METHOD_SUPERSAMPLE_4X = 0x5, AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS = 0x6,
AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN = 0x7, AA_MODE_METHOD_FREE_0x08 = 0x8, AA_MODE_METHOD_FREE_0x09 = 0x9, AA_MODE_METHOD_SUPERSAMPLE_9X = 0xA,
AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS = 0xB, AA_MODE_METHOD_SUPERSAMPLE_16X = 0xC, AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS = 0xD, AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL = 0xE,
AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX = 0xF, AA_MODE_METHOD_MULTISAMPLE_4X = 0x10, AA_MODE_METHOD_FREE_0x11 = 0x11, AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN = 0x12,
AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP = 0x13, AA_MODE_METHOD_FREE_0x14 = 0x14, AA_MODE_METHOD_FREE_0x15 = 0x15, AA_MODE_METHOD_MIXEDSAMPLE_6X = 0x16,
AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP = 0x17, AA_MODE_METHOD_MIXEDSAMPLE_8X = 0x18, AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP = 0x19, AA_MODE_METHOD_MIXEDSAMPLE_16X = 0x1a,
AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA = 0x1b, AA_MODE_METHOD_MULTISAMPLE_16X = 0x1c, AA_MODE_METHOD_VCAA_32X_8v24 = 0x1d, AA_MODE_METHOD_CORRUPTION_CHECK = 0x1e,
AA_MODE_METHOD_6X_CT = 0x1f, AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA = 0x20, AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA = 0x21, AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA = 0x22,
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA = 0x23, AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA = 0x24, AA_MODE_METHOD_MULTISAMPLE_8X = 0x25, AA_MODE_METHOD_VCAA_8X_4v4 = 0x26,
AA_MODE_METHOD_VCAA_16X_4v12 = 0x27, AA_MODE_METHOD_VCAA_16X_8v8 = 0x28, AA_MODE_METHOD_MIXEDSAMPLE_32X = 0x29, AA_MODE_METHOD_SUPERVCAA_64X_4v12 = 0x2a,
AA_MODE_METHOD_SUPERVCAA_64X_8v8 = 0x2b, AA_MODE_METHOD_MIXEDSAMPLE_64X = 0x2c, AA_MODE_METHOD_MIXEDSAMPLE_128X = 0x2d, AA_MODE_METHOD_COUNT = 0x2e,
AA_MODE_METHOD_METHOD_MASK = 0x0000ffff, AA_MODE_METHOD_METHOD_MAX = 0xf1c57815, AA_MODE_METHOD_NUM_VALUES = 50, AA_MODE_METHOD_DEFAULT = AA_MODE_METHOD_NONE
}
enum EValues_AA_MODE_REPLAY {
AA_MODE_REPLAY_SAMPLES_MASK = 0x00000070, AA_MODE_REPLAY_SAMPLES_ONE = 0x00000000, AA_MODE_REPLAY_SAMPLES_TWO = 0x00000010, AA_MODE_REPLAY_SAMPLES_FOUR = 0x00000020,
AA_MODE_REPLAY_SAMPLES_EIGHT = 0x00000030, AA_MODE_REPLAY_SAMPLES_MAX = 0x00000030, AA_MODE_REPLAY_MODE_MASK = 0x0000000f, AA_MODE_REPLAY_MODE_OFF = 0x00000000,
AA_MODE_REPLAY_MODE_ALPHA_TEST = 0x00000001, AA_MODE_REPLAY_MODE_PIXEL_KILL = 0x00000002, AA_MODE_REPLAY_MODE_DYN_BRANCH = 0x00000004, AA_MODE_REPLAY_MODE_OPTIMAL = 0x00000004,
AA_MODE_REPLAY_MODE_ALL = 0x00000008, AA_MODE_REPLAY_MODE_MAX = 0x0000000f, AA_MODE_REPLAY_TRANSPARENCY = 0x00000023, AA_MODE_REPLAY_DISALLOW_TRAA = 0x00000100,
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT = 0x00000000, AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA = 0x00000000, AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI = 0x00000000, AA_MODE_REPLAY_MASK = 0x0000017f,
AA_MODE_REPLAY_NUM_VALUES = 20, AA_MODE_REPLAY_DEFAULT = 0x00000000
}
enum EValues_AA_MODE_SELECTOR {
AA_MODE_SELECTOR_MASK = 0x00000003, AA_MODE_SELECTOR_APP_CONTROL = 0x00000000, AA_MODE_SELECTOR_OVERRIDE = 0x00000001, AA_MODE_SELECTOR_ENHANCE = 0x00000002,
AA_MODE_SELECTOR_MAX = 0x00000002, AA_MODE_SELECTOR_NUM_VALUES = 5, AA_MODE_SELECTOR_DEFAULT = AA_MODE_SELECTOR_APP_CONTROL
}
enum | EValues_AA_MODE_SELECTOR_SLIAA { AA_MODE_SELECTOR_SLIAA_DISABLED = 0, AA_MODE_SELECTOR_SLIAA_ENABLED = 1, AA_MODE_SELECTOR_SLIAA_NUM_VALUES = 2, AA_MODE_SELECTOR_SLIAA_DEFAULT = AA_MODE_SELECTOR_SLIAA_DISABLED }
enum EValues_ANISO_MODE_LEVEL {
ANISO_MODE_LEVEL_MASK = 0x0000ffff, ANISO_MODE_LEVEL_NONE_POINT = 0x00000000, ANISO_MODE_LEVEL_NONE_LINEAR = 0x00000001, ANISO_MODE_LEVEL_MAX = 0x00000010,
ANISO_MODE_LEVEL_DEFAULT = 0x00000001, ANISO_MODE_LEVEL_NUM_VALUES = 5
}
enum EValues_ANISO_MODE_SELECTOR {
ANISO_MODE_SELECTOR_MASK = 0x0000000f, ANISO_MODE_SELECTOR_APP = 0x00000000, ANISO_MODE_SELECTOR_USER = 0x00000001, ANISO_MODE_SELECTOR_COND = 0x00000002,
ANISO_MODE_SELECTOR_MAX = 0x00000002, ANISO_MODE_SELECTOR_DEFAULT = 0x00000000, ANISO_MODE_SELECTOR_NUM_VALUES = 6
}
enum EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT {
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED = 0, APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS = 9, APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS = 15, APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS = 30,
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE = 60, APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES = 120, APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES = 6, APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT = APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED
}
enum | EValues_CPL_HIDDEN_PROFILE { CPL_HIDDEN_PROFILE_DISABLED = 0, CPL_HIDDEN_PROFILE_ENABLED = 1, CPL_HIDDEN_PROFILE_NUM_VALUES = 2, CPL_HIDDEN_PROFILE_DEFAULT = CPL_HIDDEN_PROFILE_DISABLED }
enum | EValues_EXPORT_PERF_COUNTERS { EXPORT_PERF_COUNTERS_OFF = 0x00000000, EXPORT_PERF_COUNTERS_ON = 0x00000001, EXPORT_PERF_COUNTERS_NUM_VALUES = 2, EXPORT_PERF_COUNTERS_DEFAULT = EXPORT_PERF_COUNTERS_OFF }
enum | EValues_FXAA_ALLOW { FXAA_ALLOW_DISALLOWED = 0, FXAA_ALLOW_ALLOWED = 1, FXAA_ALLOW_NUM_VALUES = 2, FXAA_ALLOW_DEFAULT = FXAA_ALLOW_ALLOWED }
enum | EValues_FXAA_ENABLE { FXAA_ENABLE_OFF = 0, FXAA_ENABLE_ON = 1, FXAA_ENABLE_NUM_VALUES = 2, FXAA_ENABLE_DEFAULT = FXAA_ENABLE_OFF }
enum | EValues_FXAA_INDICATOR_ENABLE { FXAA_INDICATOR_ENABLE_OFF = 0, FXAA_INDICATOR_ENABLE_ON = 1, FXAA_INDICATOR_ENABLE_NUM_VALUES = 2, FXAA_INDICATOR_ENABLE_DEFAULT = FXAA_INDICATOR_ENABLE_OFF }
enum | EValues_MCSFRSHOWSPLIT { MCSFRSHOWSPLIT_DISABLED = 0x34534064, MCSFRSHOWSPLIT_ENABLED = 0x24545582, MCSFRSHOWSPLIT_NUM_VALUES = 2, MCSFRSHOWSPLIT_DEFAULT = MCSFRSHOWSPLIT_DISABLED }
enum | EValues_NV_QUALITY_UPSCALING { NV_QUALITY_UPSCALING_OFF = 0, NV_QUALITY_UPSCALING_ON = 1, NV_QUALITY_UPSCALING_NUM_VALUES = 2, NV_QUALITY_UPSCALING_DEFAULT = NV_QUALITY_UPSCALING_OFF }
enum | EValues_OPTIMUS_MAXAA { OPTIMUS_MAXAA_MIN = 0, OPTIMUS_MAXAA_MAX = 16, OPTIMUS_MAXAA_NUM_VALUES = 2, OPTIMUS_MAXAA_DEFAULT = 0 }
enum | EValues_PHYSXINDICATOR { PHYSXINDICATOR_DISABLED = 0x34534064, PHYSXINDICATOR_ENABLED = 0x24545582, PHYSXINDICATOR_NUM_VALUES = 2, PHYSXINDICATOR_DEFAULT = PHYSXINDICATOR_DISABLED }
enum EValues_PREFERRED_PSTATE {
PREFERRED_PSTATE_ADAPTIVE = 0x00000000, PREFERRED_PSTATE_PREFER_MAX = 0x00000001, PREFERRED_PSTATE_DRIVER_CONTROLLED = 0x00000002, PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE = 0x00000003,
PREFERRED_PSTATE_PREFER_MIN = 0x00000004, PREFERRED_PSTATE_MIN = 0x00000000, PREFERRED_PSTATE_MAX = 0x00000004, PREFERRED_PSTATE_NUM_VALUES = 7,
PREFERRED_PSTATE_DEFAULT = PREFERRED_PSTATE_ADAPTIVE
}
enum | EValues_PREVENT_UI_AF_OVERRIDE { PREVENT_UI_AF_OVERRIDE_OFF = 0, PREVENT_UI_AF_OVERRIDE_ON = 1, PREVENT_UI_AF_OVERRIDE_NUM_VALUES = 2, PREVENT_UI_AF_OVERRIDE_DEFAULT = PREVENT_UI_AF_OVERRIDE_OFF }
enum EValues_PS_FRAMERATE_LIMITER {
PS_FRAMERATE_LIMITER_DISABLED = 0x00000000, PS_FRAMERATE_LIMITER_FPS_20 = 0x00000014, PS_FRAMERATE_LIMITER_FPS_30 = 0x0000001e, PS_FRAMERATE_LIMITER_FPS_40 = 0x00000028,
PS_FRAMERATE_LIMITER_FPSMASK = 0x000000ff, PS_FRAMERATE_LIMITER_FRL2 = 0x00010000, PS_FRAMERATE_LIMITER_FORCE_VSYNC_OFF = 0x00040000, PS_FRAMERATE_LIMITER_GPS_WEB = 0x00080000,
PS_FRAMERATE_LIMITER_FORCE_OPTIMUS_POLICY = 0x00100000, PS_FRAMERATE_LIMITER_DISALLOWED = 0x00200000, PS_FRAMERATE_LIMITER_USE_CPU_WAIT = 0x00400000, PS_FRAMERATE_LIMITER_THRESHOLD = 0x00000000,
PS_FRAMERATE_LIMITER_TEMPERATURE = 0x02000000, PS_FRAMERATE_LIMITER_POWER = 0x04000000, PS_FRAMERATE_LIMITER_MODEMASK = 0x0f000000, PS_FRAMERATE_LIMITER_ACCURATE = 0x10000000,
PS_FRAMERATE_LIMITER_ALLOW_WINDOWED = 0x20000000, PS_FRAMERATE_LIMITER_FORCEON = 0x40000000, PS_FRAMERATE_LIMITER_ENABLED = 0x80000000, PS_FRAMERATE_LIMITER_OPENGL_REMOTE_DESKTOP = 0xe010003c,
PS_FRAMERATE_LIMITER_MASK = 0xff7C00ff, PS_FRAMERATE_LIMITER_NUM_VALUES = 21, PS_FRAMERATE_LIMITER_DEFAULT = PS_FRAMERATE_LIMITER_DISABLED
}
enum EValues_PS_FRAMERATE_LIMITER_2_CONTROL {
PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_CE = 0x00000000, PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_3D = 0x00000001, PS_FRAMERATE_LIMITER_2_CONTROL_AVOID_NOOP = 0x00000002, PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL_MAXWELL = 0x00000010,
PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL = 0x00000020, PS_FRAMERATE_LIMITER_2_CONTROL_FORCE_OFF = 0x00000040, PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT_FOR_GM10X = 0x00000011, PS_FRAMERATE_LIMITER_2_CONTROL_NUM_VALUES = 7,
PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT = PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_CE
}
enum EValues_PS_FRAMERATE_LIMITER_GPS_CTRL {
PS_FRAMERATE_LIMITER_GPS_CTRL_DISABLED = 0x00000000, PS_FRAMERATE_LIMITER_GPS_CTRL_DECREASE_FILTER_MASK = 0x000001FF, PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_MASK = 0x0000FE00, PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_SHIFT = 9,
PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_MASK = 0x00FF0000, PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_SHIFT = 16, PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_MASK = 0x1F000000, PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_SHIFT = 24,
PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_MASK = 0xE0000000, PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_SHIFT = 29, PS_FRAMERATE_LIMITER_GPS_CTRL_OPTIMAL_SETTING = 0x4A5A3219, PS_FRAMERATE_LIMITER_GPS_CTRL_NUM_VALUES = 11,
PS_FRAMERATE_LIMITER_GPS_CTRL_DEFAULT = PS_FRAMERATE_LIMITER_GPS_CTRL_DISABLED
}
enum EValues_PS_FRAMERATE_MONITOR_CTRL {
PS_FRAMERATE_MONITOR_CTRL_DISABLED = 0x00000000, PS_FRAMERATE_MONITOR_CTRL_THRESHOLD_PCT_MASK = 0x000000FF, PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_MASK = 0x00000F00, PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_SHIFT = 8,
PS_FRAMERATE_MONITOR_CTRL_ENABLE_ON_VSYNC = 0x00800000, PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_MASK = 0x0000F000, PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_SHIFT = 12, PS_FRAMERATE_MONITOR_CTRL_FPS_USE_FRL = 0x00000000,
PS_FRAMERATE_MONITOR_CTRL_FPS_30 = 0x1E000000, PS_FRAMERATE_MONITOR_CTRL_FPS_60 = 0x3C000000, PS_FRAMERATE_MONITOR_CTRL_FPS_MASK = 0xFF000000, PS_FRAMERATE_MONITOR_CTRL_FPS_SHIFT = 24,
PS_FRAMERATE_MONITOR_CTRL_OPTIMAL_SETTING = 0x00000364, PS_FRAMERATE_MONITOR_CTRL_VSYNC_OPTIMAL_SETTING = 0x0080f364, PS_FRAMERATE_MONITOR_CTRL_NUM_VALUES = 14, PS_FRAMERATE_MONITOR_CTRL_DEFAULT = PS_FRAMERATE_MONITOR_CTRL_DISABLED
}
enum EValues_SHIM_MCCOMPAT {
SHIM_MCCOMPAT_INTEGRATED = 0x00000000, SHIM_MCCOMPAT_ENABLE = 0x00000001, SHIM_MCCOMPAT_USER_EDITABLE = 0x00000002, SHIM_MCCOMPAT_MASK = 0x00000003,
SHIM_MCCOMPAT_VIDEO_MASK = 0x00000004, SHIM_MCCOMPAT_VARYING_BIT = 0x00000008, SHIM_MCCOMPAT_AUTO_SELECT = 0x00000010, SHIM_MCCOMPAT_OVERRIDE_BIT = 0x80000000,
SHIM_MCCOMPAT_NUM_VALUES = 8, SHIM_MCCOMPAT_DEFAULT = SHIM_MCCOMPAT_AUTO_SELECT
}
enum EValues_SHIM_RENDERING_MODE {
SHIM_RENDERING_MODE_INTEGRATED = 0x00000000, SHIM_RENDERING_MODE_ENABLE = 0x00000001, SHIM_RENDERING_MODE_USER_EDITABLE = 0x00000002, SHIM_RENDERING_MODE_MASK = 0x00000003,
SHIM_RENDERING_MODE_VIDEO_MASK = 0x00000004, SHIM_RENDERING_MODE_VARYING_BIT = 0x00000008, SHIM_RENDERING_MODE_AUTO_SELECT = 0x00000010, SHIM_RENDERING_MODE_OVERRIDE_BIT = 0x80000000,
SHIM_RENDERING_MODE_NUM_VALUES = 8, SHIM_RENDERING_MODE_DEFAULT = SHIM_RENDERING_MODE_AUTO_SELECT
}
enum EValues_SHIM_RENDERING_OPTIONS {
SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE = 0x00000000, SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT = 0x00000001, SHIM_RENDERING_OPTIONS_EHSHELL_DETECT = 0x00000002, SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT = 0x00000004,
SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT = 0x00000008, SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES = 0x00000010, SHIM_RENDERING_OPTIONS_RESERVED1 = 0x00000020, SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT = 0x00000040,
SHIM_RENDERING_OPTIONS_RESERVED2 = 0x00000080, SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE = 0x00000100, SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS = 0x00000200, SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS = 0x00000400,
SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS = 0x00000800, SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT = 0x00001000, SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING = 0x00002000, SHIM_RENDERING_OPTIONS_DISABLE_CUDA = 0x00004000,
SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO = 0x00008000, SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS = 0x00010000, SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT = 0x00020000, SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO = 0x00040000,
SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID = 0x00080000, SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD = 0x00100000, SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT = 0x00200000, SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG = 0x00400000,
SHIM_RENDERING_OPTIONS_NUM_VALUES = 24, SHIM_RENDERING_OPTIONS_DEFAULT = SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE
}
enum EValues_SLI_GPU_COUNT {
SLI_GPU_COUNT_AUTOSELECT = 0x00000000, SLI_GPU_COUNT_ONE = 0x00000001, SLI_GPU_COUNT_TWO = 0x00000002, SLI_GPU_COUNT_THREE = 0x00000003,
SLI_GPU_COUNT_FOUR = 0x00000004, SLI_GPU_COUNT_NUM_VALUES = 5, SLI_GPU_COUNT_DEFAULT = SLI_GPU_COUNT_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_GPU_COUNT {
SLI_PREDEFINED_GPU_COUNT_AUTOSELECT = 0x00000000, SLI_PREDEFINED_GPU_COUNT_ONE = 0x00000001, SLI_PREDEFINED_GPU_COUNT_TWO = 0x00000002, SLI_PREDEFINED_GPU_COUNT_THREE = 0x00000003,
SLI_PREDEFINED_GPU_COUNT_FOUR = 0x00000004, SLI_PREDEFINED_GPU_COUNT_NUM_VALUES = 5, SLI_PREDEFINED_GPU_COUNT_DEFAULT = SLI_PREDEFINED_GPU_COUNT_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_GPU_COUNT_DX10 {
SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT = 0x00000000, SLI_PREDEFINED_GPU_COUNT_DX10_ONE = 0x00000001, SLI_PREDEFINED_GPU_COUNT_DX10_TWO = 0x00000002, SLI_PREDEFINED_GPU_COUNT_DX10_THREE = 0x00000003,
SLI_PREDEFINED_GPU_COUNT_DX10_FOUR = 0x00000004, SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES = 5, SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT = SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_MODE {
SLI_PREDEFINED_MODE_AUTOSELECT = 0x00000000, SLI_PREDEFINED_MODE_FORCE_SINGLE = 0x00000001, SLI_PREDEFINED_MODE_FORCE_AFR = 0x00000002, SLI_PREDEFINED_MODE_FORCE_AFR2 = 0x00000003,
SLI_PREDEFINED_MODE_FORCE_SFR = 0x00000004, SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR = 0x00000005, SLI_PREDEFINED_MODE_NUM_VALUES = 6, SLI_PREDEFINED_MODE_DEFAULT = SLI_PREDEFINED_MODE_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_MODE_DX10 {
SLI_PREDEFINED_MODE_DX10_AUTOSELECT = 0x00000000, SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE = 0x00000001, SLI_PREDEFINED_MODE_DX10_FORCE_AFR = 0x00000002, SLI_PREDEFINED_MODE_DX10_FORCE_AFR2 = 0x00000003,
SLI_PREDEFINED_MODE_DX10_FORCE_SFR = 0x00000004, SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR = 0x00000005, SLI_PREDEFINED_MODE_DX10_NUM_VALUES = 6, SLI_PREDEFINED_MODE_DX10_DEFAULT = SLI_PREDEFINED_MODE_DX10_AUTOSELECT
}
enum EValues_SLI_RENDERING_MODE {
SLI_RENDERING_MODE_AUTOSELECT = 0x00000000, SLI_RENDERING_MODE_FORCE_SINGLE = 0x00000001, SLI_RENDERING_MODE_FORCE_AFR = 0x00000002, SLI_RENDERING_MODE_FORCE_AFR2 = 0x00000003,
SLI_RENDERING_MODE_FORCE_SFR = 0x00000004, SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR = 0x00000005, SLI_RENDERING_MODE_NUM_VALUES = 6, SLI_RENDERING_MODE_DEFAULT = SLI_RENDERING_MODE_AUTOSELECT
}
enum EValues_VRPRERENDERLIMIT {
VRPRERENDERLIMIT_MIN = 0x00, VRPRERENDERLIMIT_MAX = 0xff, VRPRERENDERLIMIT_APP_CONTROLLED = 0x00, VRPRERENDERLIMIT_DEFAULT = 0x01,
VRPRERENDERLIMIT_NUM_VALUES = 4
}
enum | EValues_VRRFEATUREINDICATOR { VRRFEATUREINDICATOR_DISABLED = 0x0, VRRFEATUREINDICATOR_ENABLED = 0x1, VRRFEATUREINDICATOR_NUM_VALUES = 2, VRRFEATUREINDICATOR_DEFAULT = VRRFEATUREINDICATOR_ENABLED }
enum | EValues_VRROVERLAYINDICATOR { VRROVERLAYINDICATOR_DISABLED = 0x0, VRROVERLAYINDICATOR_ENABLED = 0x1, VRROVERLAYINDICATOR_NUM_VALUES = 2, VRROVERLAYINDICATOR_DEFAULT = VRROVERLAYINDICATOR_ENABLED }
enum EValues_VRRREQUESTSTATE {
VRRREQUESTSTATE_DISABLED = 0x0, VRRREQUESTSTATE_FULLSCREEN_ONLY = 0x1, VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED = 0x2, VRRREQUESTSTATE_NUM_VALUES = 3,
VRRREQUESTSTATE_DEFAULT = VRRREQUESTSTATE_FULLSCREEN_ONLY
}
enum EValues_VRR_APP_OVERRIDE {
VRR_APP_OVERRIDE_ALLOW = 0, VRR_APP_OVERRIDE_FORCE_OFF = 1, VRR_APP_OVERRIDE_DISALLOW = 2, VRR_APP_OVERRIDE_ULMB = 3,
VRR_APP_OVERRIDE_FIXED_REFRESH = 4, VRR_APP_OVERRIDE_NUM_VALUES = 5, VRR_APP_OVERRIDE_DEFAULT = VRR_APP_OVERRIDE_ALLOW
}
enum EValues_VRR_APP_OVERRIDE_REQUEST_STATE {
VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW = 0, VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF = 1, VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW = 2, VRR_APP_OVERRIDE_REQUEST_STATE_ULMB = 3,
VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH = 4, VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES = 5, VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT = VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW
}
enum EValues_VRR_MODE {
VRR_MODE_DISABLED = 0x0, VRR_MODE_FULLSCREEN_ONLY = 0x1, VRR_MODE_FULLSCREEN_AND_WINDOWED = 0x2, VRR_MODE_NUM_VALUES = 3,
VRR_MODE_DEFAULT = VRR_MODE_FULLSCREEN_ONLY
}
enum | EValues_VSYNCSMOOTHAFR { VSYNCSMOOTHAFR_OFF = 0x00000000, VSYNCSMOOTHAFR_ON = 0x00000001, VSYNCSMOOTHAFR_NUM_VALUES = 2, VSYNCSMOOTHAFR_DEFAULT = VSYNCSMOOTHAFR_OFF }
enum EValues_VSYNCVRRCONTROL {
VSYNCVRRCONTROL_DISABLE = 0x00000000, VSYNCVRRCONTROL_ENABLE = 0x00000001, VSYNCVRRCONTROL_NOTSUPPORTED = 0x9f95128e, VSYNCVRRCONTROL_NUM_VALUES = 3,
VSYNCVRRCONTROL_DEFAULT = VSYNCVRRCONTROL_ENABLE
}
enum | EValues_VSYNC_BEHAVIOR_FLAGS { VSYNC_BEHAVIOR_FLAGS_NONE = 0x00000000, VSYNC_BEHAVIOR_FLAGS_DEFAULT = 0x00000000, VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE = 0x00000001, VSYNC_BEHAVIOR_FLAGS_NUM_VALUES = 3 }
enum | EValues_WKS_API_STEREO_EYES_EXCHANGE { WKS_API_STEREO_EYES_EXCHANGE_OFF = 0, WKS_API_STEREO_EYES_EXCHANGE_ON = 1, WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES = 2, WKS_API_STEREO_EYES_EXCHANGE_DEFAULT = WKS_API_STEREO_EYES_EXCHANGE_OFF }
enum EValues_WKS_API_STEREO_MODE {
WKS_API_STEREO_MODE_SHUTTER_GLASSES = 0, WKS_API_STEREO_MODE_VERTICAL_INTERLACED = 1, WKS_API_STEREO_MODE_TWINVIEW = 2, WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO = 3,
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0 = 4, WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1 = 5, WKS_API_STEREO_MODE_COLOR_LINE = 6, WKS_API_STEREO_MODE_COLOR_INTERLEAVED = 7,
WKS_API_STEREO_MODE_ANAGLYPH = 8, WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED = 9, WKS_API_STEREO_MODE_SIDE_FIELD = 10, WKS_API_STEREO_MODE_SUB_FIELD = 11,
WKS_API_STEREO_MODE_CHECKERBOARD = 12, WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD = 13, WKS_API_STEREO_MODE_TRIDELITY_SL = 14, WKS_API_STEREO_MODE_TRIDELITY_MV = 15,
WKS_API_STEREO_MODE_SEEFRONT = 16, WKS_API_STEREO_MODE_STEREO_MIRROR = 17, WKS_API_STEREO_MODE_FRAME_SEQUENTIAL = 18, WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE = 19,
WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL = 20, WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL = 21, WKS_API_STEREO_MODE_USE_HW_DEFAULT = 0xffffffff, WKS_API_STEREO_MODE_DEFAULT_GL = 3,
WKS_API_STEREO_MODE_NUM_VALUES = 24, WKS_API_STEREO_MODE_DEFAULT = WKS_API_STEREO_MODE_SHUTTER_GLASSES
}
enum EValues_WKS_MEMORY_ALLOCATION_POLICY {
WKS_MEMORY_ALLOCATION_POLICY_AS_NEEDED = 0x0, WKS_MEMORY_ALLOCATION_POLICY_MODERATE_PRE_ALLOCATION = 0x1, WKS_MEMORY_ALLOCATION_POLICY_AGGRESSIVE_PRE_ALLOCATION = 0x2, WKS_MEMORY_ALLOCATION_POLICY_NUM_VALUES = 3,
WKS_MEMORY_ALLOCATION_POLICY_DEFAULT = WKS_MEMORY_ALLOCATION_POLICY_AS_NEEDED
}
enum EValues_WKS_STEREO_DONGLE_SUPPORT {
WKS_STEREO_DONGLE_SUPPORT_OFF = 0, WKS_STEREO_DONGLE_SUPPORT_DAC = 1, WKS_STEREO_DONGLE_SUPPORT_DLP = 2, WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES = 3,
WKS_STEREO_DONGLE_SUPPORT_DEFAULT = WKS_STEREO_DONGLE_SUPPORT_OFF
}
enum | EValues_WKS_STEREO_SUPPORT { WKS_STEREO_SUPPORT_OFF = 0, WKS_STEREO_SUPPORT_ON = 1, WKS_STEREO_SUPPORT_NUM_VALUES = 2, WKS_STEREO_SUPPORT_DEFAULT = WKS_STEREO_SUPPORT_OFF }
enum EValues_WKS_STEREO_SWAP_MODE {
WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL = 0x0, WKS_STEREO_SWAP_MODE_PER_EYE = 0x1, WKS_STEREO_SWAP_MODE_PER_EYE_PAIR = 0x2, WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR = 0x3,
WKS_STEREO_SWAP_MODE_NUM_VALUES = 4, WKS_STEREO_SWAP_MODE_DEFAULT = WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL
}
enum EValues_AO_MODE {
AO_MODE_OFF = 0, AO_MODE_LOW = 1, AO_MODE_MEDIUM = 2, AO_MODE_HIGH = 3,
AO_MODE_NUM_VALUES = 4, AO_MODE_DEFAULT = AO_MODE_OFF
}
enum | EValues_AO_MODE_ACTIVE { AO_MODE_ACTIVE_DISABLED = 0, AO_MODE_ACTIVE_ENABLED = 1, AO_MODE_ACTIVE_NUM_VALUES = 2, AO_MODE_ACTIVE_DEFAULT = AO_MODE_ACTIVE_DISABLED }
enum | EValues_AUTO_LODBIASADJUST { AUTO_LODBIASADJUST_OFF = 0x00000000, AUTO_LODBIASADJUST_ON = 0x00000001, AUTO_LODBIASADJUST_NUM_VALUES = 2, AUTO_LODBIASADJUST_DEFAULT = AUTO_LODBIASADJUST_ON }
enum | EValues_LODBIASADJUST { LODBIASADJUST_MIN = 0xffffff80, LODBIASADJUST_MAX = 128, LODBIASADJUST_NUM_VALUES = 2, LODBIASADJUST_DEFAULT = 0 }
enum | EValues_MAXWELL_B_SAMPLE_INTERLEAVE { MAXWELL_B_SAMPLE_INTERLEAVE_OFF = 0, MAXWELL_B_SAMPLE_INTERLEAVE_ON = 1, MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES = 2, MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT = MAXWELL_B_SAMPLE_INTERLEAVE_OFF }
enum | EValues_NLS_ALLOW { NLS_ALLOW_DISALLOWED = 0, NLS_ALLOW_ALLOWED = 1, NLS_ALLOW_NUM_VALUES = 2, NLS_ALLOW_DEFAULT = NLS_ALLOW_ALLOWED }
enum | EValues_NLS_ENABLE { NLS_ENABLE_OFF = 0, NLS_ENABLE_ON = 1, NLS_ENABLE_NUM_VALUES = 2, NLS_ENABLE_DEFAULT = NLS_ENABLE_OFF }
enum EValues_PRERENDERLIMIT {
PRERENDERLIMIT_MIN = 0x00, PRERENDERLIMIT_MAX = 0xff, PRERENDERLIMIT_APP_CONTROLLED = 0x00, PRERENDERLIMIT_NUM_VALUES = 3,
PRERENDERLIMIT_DEFAULT = PRERENDERLIMIT_APP_CONTROLLED
}
enum | EValues_PS_SHADERDISKCACHE { PS_SHADERDISKCACHE_OFF = 0x00000000, PS_SHADERDISKCACHE_ON = 0x00000001, PS_SHADERDISKCACHE_NUM_VALUES = 2, PS_SHADERDISKCACHE_DEFAULT = 0x1 }
enum | EValues_PS_TEXFILTER_ANISO_OPTS2 { PS_TEXFILTER_ANISO_OPTS2_OFF = 0x00000000, PS_TEXFILTER_ANISO_OPTS2_ON = 0x00000001, PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES = 2, PS_TEXFILTER_ANISO_OPTS2_DEFAULT = PS_TEXFILTER_ANISO_OPTS2_OFF }
enum | EValues_PS_TEXFILTER_BILINEAR_IN_ANISO { PS_TEXFILTER_BILINEAR_IN_ANISO_OFF = 0x00000000, PS_TEXFILTER_BILINEAR_IN_ANISO_ON = 0x00000001, PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES = 2, PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT = PS_TEXFILTER_BILINEAR_IN_ANISO_OFF }
enum | EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE { PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF = 0x00000000, PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON = 0x00000001, PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES = 2, PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT = PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF }
enum | EValues_PS_TEXFILTER_NO_NEG_LODBIAS { PS_TEXFILTER_NO_NEG_LODBIAS_OFF = 0x00000000, PS_TEXFILTER_NO_NEG_LODBIAS_ON = 0x00000001, PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES = 2, PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT = PS_TEXFILTER_NO_NEG_LODBIAS_OFF }
enum EValues_QUALITY_ENHANCEMENTS {
QUALITY_ENHANCEMENTS_HIGHQUALITY = 0xfffffff6, QUALITY_ENHANCEMENTS_QUALITY = 0x00000000, QUALITY_ENHANCEMENTS_PERFORMANCE = 0x0000000a, QUALITY_ENHANCEMENTS_HIGHPERFORMANCE = 0x00000014,
QUALITY_ENHANCEMENTS_NUM_VALUES = 4, QUALITY_ENHANCEMENTS_DEFAULT = QUALITY_ENHANCEMENTS_QUALITY
}
enum EValues_REFRESH_RATE_OVERRIDE {
REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED = 0x00000000, REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE = 0x00000001, REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK = 0x00000FF0, REFRESH_RATE_OVERRIDE_NUM_VALUES = 3,
REFRESH_RATE_OVERRIDE_DEFAULT = REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED
}
enum | EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE { SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF = 0x00000000, SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON = 0x00000001, SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES = 2, SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT = SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF }
enum EValues_SET_VAB_DATA {
SET_VAB_DATA_ZERO = 0x00000000, SET_VAB_DATA_UINT_ONE = 0x00000001, SET_VAB_DATA_FLOAT_ONE = 0x3f800000, SET_VAB_DATA_FLOAT_POS_INF = 0x7f800000,
SET_VAB_DATA_FLOAT_NAN = 0x7fc00000, SET_VAB_DATA_USE_API_DEFAULTS = 0xffffffff, SET_VAB_DATA_NUM_VALUES = 6, SET_VAB_DATA_DEFAULT = SET_VAB_DATA_USE_API_DEFAULTS
}
enum EValues_VSYNCMODE {
VSYNCMODE_PASSIVE = 0x60925292, VSYNCMODE_FORCEOFF = 0x08416747, VSYNCMODE_FORCEON = 0x47814940, VSYNCMODE_FLIPINTERVAL2 = 0x32610244,
VSYNCMODE_FLIPINTERVAL3 = 0x71271021, VSYNCMODE_FLIPINTERVAL4 = 0x13245256, VSYNCMODE_NUM_VALUES = 6, VSYNCMODE_DEFAULT = VSYNCMODE_PASSIVE
}
enum | EValues_VSYNCTEARCONTROL { VSYNCTEARCONTROL_DISABLE = 0x96861077, VSYNCTEARCONTROL_ENABLE = 0x99941284, VSYNCTEARCONTROL_NUM_VALUES = 2, VSYNCTEARCONTROL_DEFAULT = VSYNCTEARCONTROL_DISABLE }

Define Documentation

#define AA_BEHAVIOR_FLAGS_STRING L"Antialiasing - Behavior Flags"
#define AA_MODE_ALPHATOCOVERAGE_STRING L"Antialiasing - Transparency Multisampling"
#define AA_MODE_GAMMACORRECTION_STRING L"Antialiasing - Gamma correction"
#define AA_MODE_METHOD_STRING L"Antialiasing - Setting"
#define AA_MODE_REPLAY_STRING L"Antialiasing - Transparency Supersampling"
#define AA_MODE_SELECTOR_SLIAA_STRING L"Antialiasing - SLI AA"
#define AA_MODE_SELECTOR_STRING L"Antialiasing - Mode"
#define ANISO_MODE_LEVEL_STRING L"Anisotropic filtering setting"
#define ANISO_MODE_SELECTOR_STRING L"Anisotropic filtering mode"
#define AO_MODE_ACTIVE_STRING L"NVIDIA Predefined Ambient Occlusion Usage"
#define AO_MODE_STRING L"Ambient Occlusion"
#define APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING L"Application Profile Notification Popup Timeout"
#define APPLICATION_STEAM_ID_STRING L"Steam Application ID"
#define AUTO_LODBIASADJUST_STRING L"Texture filtering - Driver Controlled LOD Bias"
#define CPL_HIDDEN_PROFILE_STRING L"Do not display this profile in the Control Panel"
#define CUDA_EXCLUDED_GPUS_DEFAULT CUDA_EXCLUDED_GPUS_NONE
#define CUDA_EXCLUDED_GPUS_NONE L"none"
#define CUDA_EXCLUDED_GPUS_NUM_VALUES 1
#define CUDA_EXCLUDED_GPUS_STRING L"List of Universal GPU ids"
#define D3DOGL_GPU_MAX_POWER_DEFAULT D3DOGL_GPU_MAX_POWER_DEFAULTPOWER
#define D3DOGL_GPU_MAX_POWER_DEFAULTPOWER L"0"
#define D3DOGL_GPU_MAX_POWER_NUM_VALUES 1
#define D3DOGL_GPU_MAX_POWER_STRING L"Maximum GPU Power"
#define EXPORT_PERF_COUNTERS_STRING L"Export Performance Counters"
#define FXAA_ALLOW_STRING L"NVIDIA Predefined FXAA Usage"
#define FXAA_ENABLE_STRING L"Enable FXAA"
#define FXAA_INDICATOR_ENABLE_STRING L"Enable FXAA Indicator"
#define ICAFE_LOGO_CONFIG_STRING L"ICafe Settings"
#define LODBIASADJUST_STRING L"Texture filtering - LOD Bias"
#define MAXWELL_B_SAMPLE_INTERLEAVE_STRING L"Enable sample interleaving (MFAA)"
#define MCSFRSHOWSPLIT_STRING L"SLI indicator"
#define NLS_ALLOW_STRING L"NVIDIA Predefined Nonlinear Scale Usage"
#define NLS_ENABLE_STRING L"Enable Nonlinear Scale"
#define NV_QUALITY_UPSCALING_STRING L"NVIDIA Quality upscaling"
#define OGL_AA_LINE_GAMMA_STRING L"Antialiasing - Line gamma"
#define OGL_DEEP_COLOR_SCANOUT_STRING L"Deep color for 3D applications"
#define OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING L"OpenGL default swap interval fraction"
#define OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING L"OpenGL default swap interval sign"
#define OGL_DEFAULT_SWAP_INTERVAL_STRING L"OpenGL default swap interval"
#define OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING L"Event Log Severity Threshold"
#define OGL_EXTENSION_STRING_VERSION_STRING L"Extension String version"
#define OGL_FORCE_BLIT_STRING L"Buffer-flipping mode"
#define OGL_FORCE_STEREO_STRING L"Force Stereo shuttering"
#define OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT L"autoselect"
#define OGL_IMPLICIT_GPU_AFFINITY_DEFAULT OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT
#define OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR L"OGL_DEFAULT_RENDERING_GPU"
#define OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES 1
#define OGL_IMPLICIT_GPU_AFFINITY_STRING L"Preferred OpenGL GPU"
#define OGL_MAX_FRAMES_ALLOWED_STRING L"Maximum frames allowed"
#define OGL_MULTIMON_STRING L"Multi-display/mixed-GPU acceleration"
#define OGL_OVERLAY_PIXEL_TYPE_STRING L"Exported Overlay pixel types"
#define OGL_OVERLAY_SUPPORT_STRING L"Enable overlay"
#define OGL_QUALITY_ENHANCEMENTS_STRING L"High level control of the rendering quality on OpenGL"
#define OGL_SINGLE_BACKDEPTH_BUFFER_STRING L"Unified back/depth buffer"
#define OGL_SLI_MULTICAST_STRING L"Enable NV_gpu_multicast extension"
#define OGL_THREAD_CONTROL_STRING L"Threaded optimization"
#define OGL_TRIPLE_BUFFER_STRING L"Triple buffering"
#define OGL_VIDEO_EDITING_MODE_STRING L"OpenGL video-editing mode"
#define OPTIMUS_MAXAA_STRING L"Maximum AA samples allowed for a given application"
#define PHYSXINDICATOR_STRING L"Display the PhysX indicator"
#define PREFERRED_PSTATE_STRING L"Power management mode"
#define PRERENDERLIMIT_STRING L"Maximum pre-rendered frames"
#define PREVENT_UI_AF_OVERRIDE_STRING L"No override of Anisotropic filtering"
#define PS_FRAMERATE_LIMITER_2_CONTROL_STRING L"Frame Rate Limiter 2 Control"
#define PS_FRAMERATE_LIMITER_GPS_CTRL_STRING L"Frame Rate Monitor"
#define PS_FRAMERATE_LIMITER_STRING L"Frame Rate Limiter"
#define PS_FRAMERATE_MONITOR_CTRL_STRING L"Frame Rate Monitor Control"
#define PS_SHADERDISKCACHE_STRING L"Shader Cache"
#define PS_TEXFILTER_ANISO_OPTS2_STRING L"Texture filtering - Anisotropic sample optimization"
#define PS_TEXFILTER_BILINEAR_IN_ANISO_STRING L"Texture filtering - Anisotropic filter optimization"
#define PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING L"Texture filtering - Trilinear optimization"
#define PS_TEXFILTER_NO_NEG_LODBIAS_STRING L"Texture filtering - Negative LOD bias"
#define QUALITY_ENHANCEMENTS_STRING L"Texture filtering - Quality"
#define REFRESH_RATE_OVERRIDE_STRING L"Preferred refresh rate"
#define SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING L"PowerThrottle"
#define SET_VAB_DATA_STRING L"VAB Default Data"
#define SHIM_MAXRES_STRING L"Maximum resolution allowed for a given application"
#define SHIM_MCCOMPAT_STRING L"Optimus flags for enabled applications"
#define SHIM_RENDERING_MODE_STRING L"Enable application for Optimus"
#define SHIM_RENDERING_OPTIONS_STRING L"Shim Rendering Mode Options per application for Optimus"
#define SLI_GPU_COUNT_STRING L"Number of GPUs to use on SLI rendering mode"
#define SLI_PREDEFINED_GPU_COUNT_DX10_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode on DirectX 10"
#define SLI_PREDEFINED_GPU_COUNT_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode"
#define SLI_PREDEFINED_MODE_DX10_STRING L"NVIDIA predefined SLI mode on DirectX 10"
#define SLI_PREDEFINED_MODE_STRING L"NVIDIA predefined SLI mode"
#define SLI_RENDERING_MODE_STRING L"SLI rendering mode"
#define VRPRERENDERLIMIT_STRING L"Virtual Reality pre-rendered frames"
#define VRR_APP_OVERRIDE_REQUEST_STATE_STRING L"G-SYNC"
#define VRR_APP_OVERRIDE_STRING L"G-SYNC"
#define VRR_MODE_STRING L"Enable G-SYNC globally"
#define VRRFEATUREINDICATOR_STRING L"Toggle the VRR global feature"
#define VRROVERLAYINDICATOR_STRING L"Display the VRR Overlay Indicator"
#define VRRREQUESTSTATE_STRING L"VRR requested state"
#define VSYNC_BEHAVIOR_FLAGS_STRING L"Vsync - Behavior Flags"
#define VSYNCMODE_STRING L"Vertical Sync"
#define VSYNCSMOOTHAFR_STRING L"Flag to control smooth AFR behavior"
#define VSYNCTEARCONTROL_STRING L"Vertical Sync Tear Control"
#define VSYNCVRRCONTROL_STRING L"Variable refresh Rate"
#define WKS_API_STEREO_EYES_EXCHANGE_STRING L"Stereo - Swap eyes"
#define WKS_API_STEREO_MODE_STRING L"Stereo - Display mode"
#define WKS_MEMORY_ALLOCATION_POLICY_STRING L"Memory Allocation Policy"
#define WKS_STEREO_DONGLE_SUPPORT_STRING L"Stereo - Dongle Support"
#define WKS_STEREO_SUPPORT_STRING L"Stereo - Enable"
#define WKS_STEREO_SWAP_MODE_STRING L"Stereo – swap mode"

Typedef Documentation

typedef struct _SettingDWORDNameString SettingDWORDNameString
typedef struct _SettingWSTRINGNameString SettingWSTRINGNameString

Enumeration Type Documentation

enum ESetting
Enumerator:
OGL_AA_LINE_GAMMA_ID
OGL_DEEP_COLOR_SCANOUT_ID
OGL_DEFAULT_SWAP_INTERVAL_ID
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID
OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID
OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID
OGL_EXTENSION_STRING_VERSION_ID
OGL_FORCE_BLIT_ID
OGL_FORCE_STEREO_ID
OGL_IMPLICIT_GPU_AFFINITY_ID
OGL_MAX_FRAMES_ALLOWED_ID
OGL_MULTIMON_ID
OGL_OVERLAY_PIXEL_TYPE_ID
OGL_OVERLAY_SUPPORT_ID
OGL_QUALITY_ENHANCEMENTS_ID
OGL_SINGLE_BACKDEPTH_BUFFER_ID
OGL_SLI_MULTICAST_ID
OGL_THREAD_CONTROL_ID
OGL_TRIPLE_BUFFER_ID
OGL_VIDEO_EDITING_MODE_ID
AA_BEHAVIOR_FLAGS_ID
AA_MODE_ALPHATOCOVERAGE_ID
AA_MODE_GAMMACORRECTION_ID
AA_MODE_METHOD_ID
AA_MODE_REPLAY_ID
AA_MODE_SELECTOR_ID
AA_MODE_SELECTOR_SLIAA_ID
ANISO_MODE_LEVEL_ID
ANISO_MODE_SELECTOR_ID
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID
APPLICATION_STEAM_ID_ID
CPL_HIDDEN_PROFILE_ID
CUDA_EXCLUDED_GPUS_ID
D3DOGL_GPU_MAX_POWER_ID
EXPORT_PERF_COUNTERS_ID
FXAA_ALLOW_ID
FXAA_ENABLE_ID
FXAA_INDICATOR_ENABLE_ID
MCSFRSHOWSPLIT_ID
NV_QUALITY_UPSCALING_ID
OPTIMUS_MAXAA_ID
PHYSXINDICATOR_ID
PREFERRED_PSTATE_ID
PREVENT_UI_AF_OVERRIDE_ID
PS_FRAMERATE_LIMITER_ID
PS_FRAMERATE_LIMITER_2_CONTROL_ID
PS_FRAMERATE_LIMITER_GPS_CTRL_ID
PS_FRAMERATE_MONITOR_CTRL_ID
SHIM_MAXRES_ID
SHIM_MCCOMPAT_ID
SHIM_RENDERING_MODE_ID
SHIM_RENDERING_OPTIONS_ID
SLI_GPU_COUNT_ID
SLI_PREDEFINED_GPU_COUNT_ID
SLI_PREDEFINED_GPU_COUNT_DX10_ID
SLI_PREDEFINED_MODE_ID
SLI_PREDEFINED_MODE_DX10_ID
SLI_RENDERING_MODE_ID
VRPRERENDERLIMIT_ID
VRRFEATUREINDICATOR_ID
VRROVERLAYINDICATOR_ID
VRRREQUESTSTATE_ID
VRR_APP_OVERRIDE_ID
VRR_APP_OVERRIDE_REQUEST_STATE_ID
VRR_MODE_ID
VSYNCSMOOTHAFR_ID
VSYNCVRRCONTROL_ID
VSYNC_BEHAVIOR_FLAGS_ID
WKS_API_STEREO_EYES_EXCHANGE_ID
WKS_API_STEREO_MODE_ID
WKS_MEMORY_ALLOCATION_POLICY_ID
WKS_STEREO_DONGLE_SUPPORT_ID
WKS_STEREO_SUPPORT_ID
WKS_STEREO_SWAP_MODE_ID
AO_MODE_ID
AO_MODE_ACTIVE_ID
AUTO_LODBIASADJUST_ID
ICAFE_LOGO_CONFIG_ID
LODBIASADJUST_ID
MAXWELL_B_SAMPLE_INTERLEAVE_ID
NLS_ALLOW_ID
NLS_ENABLE_ID
PRERENDERLIMIT_ID
PS_SHADERDISKCACHE_ID
PS_TEXFILTER_ANISO_OPTS2_ID
PS_TEXFILTER_BILINEAR_IN_ANISO_ID
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID
PS_TEXFILTER_NO_NEG_LODBIAS_ID
QUALITY_ENHANCEMENTS_ID
REFRESH_RATE_OVERRIDE_ID
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID
SET_VAB_DATA_ID
VSYNCMODE_ID
VSYNCTEARCONTROL_ID
TOTAL_DWORD_SETTING_NUM
TOTAL_WSTRING_SETTING_NUM
TOTAL_SETTING_NUM
INVALID_SETTING_ID
enum EValues_AA_BEHAVIOR_FLAGS
Enumerator:
AA_BEHAVIOR_FLAGS_NONE
AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED
AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE
AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE
AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED
AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE
AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE
AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING
AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING
AA_BEHAVIOR_FLAGS_DISABLE_CPLAA
AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE
AA_BEHAVIOR_FLAGS_DISABLE_SLIAA
AA_BEHAVIOR_FLAGS_DEFAULT
AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4
AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT
AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4
AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT
AA_BEHAVIOR_FLAGS_MASK
AA_BEHAVIOR_FLAGS_NUM_VALUES
enum EValues_AA_MODE_ALPHATOCOVERAGE
Enumerator:
AA_MODE_ALPHATOCOVERAGE_MODE_MASK
AA_MODE_ALPHATOCOVERAGE_MODE_OFF
AA_MODE_ALPHATOCOVERAGE_MODE_ON
AA_MODE_ALPHATOCOVERAGE_MODE_MAX
AA_MODE_ALPHATOCOVERAGE_NUM_VALUES
AA_MODE_ALPHATOCOVERAGE_DEFAULT
enum EValues_AA_MODE_GAMMACORRECTION
Enumerator:
AA_MODE_GAMMACORRECTION_MASK
AA_MODE_GAMMACORRECTION_OFF
AA_MODE_GAMMACORRECTION_ON_IF_FOS
AA_MODE_GAMMACORRECTION_ON_ALWAYS
AA_MODE_GAMMACORRECTION_MAX
AA_MODE_GAMMACORRECTION_DEFAULT
AA_MODE_GAMMACORRECTION_DEFAULT_TESLA
AA_MODE_GAMMACORRECTION_DEFAULT_FERMI
AA_MODE_GAMMACORRECTION_NUM_VALUES
enum EValues_AA_MODE_METHOD
Enumerator:
AA_MODE_METHOD_NONE
AA_MODE_METHOD_SUPERSAMPLE_2X_H
AA_MODE_METHOD_SUPERSAMPLE_2X_V
AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5
AA_MODE_METHOD_FREE_0x03
AA_MODE_METHOD_FREE_0x04
AA_MODE_METHOD_SUPERSAMPLE_4X
AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS
AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN
AA_MODE_METHOD_FREE_0x08
AA_MODE_METHOD_FREE_0x09
AA_MODE_METHOD_SUPERSAMPLE_9X
AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS
AA_MODE_METHOD_SUPERSAMPLE_16X
AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL
AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX
AA_MODE_METHOD_MULTISAMPLE_4X
AA_MODE_METHOD_FREE_0x11
AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN
AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP
AA_MODE_METHOD_FREE_0x14
AA_MODE_METHOD_FREE_0x15
AA_MODE_METHOD_MIXEDSAMPLE_6X
AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP
AA_MODE_METHOD_MIXEDSAMPLE_8X
AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP
AA_MODE_METHOD_MIXEDSAMPLE_16X
AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA
AA_MODE_METHOD_MULTISAMPLE_16X
AA_MODE_METHOD_VCAA_32X_8v24
AA_MODE_METHOD_CORRUPTION_CHECK
AA_MODE_METHOD_6X_CT
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA
AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA
AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA
AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA
AA_MODE_METHOD_MULTISAMPLE_8X
AA_MODE_METHOD_VCAA_8X_4v4
AA_MODE_METHOD_VCAA_16X_4v12
AA_MODE_METHOD_VCAA_16X_8v8
AA_MODE_METHOD_MIXEDSAMPLE_32X
AA_MODE_METHOD_SUPERVCAA_64X_4v12
AA_MODE_METHOD_SUPERVCAA_64X_8v8
AA_MODE_METHOD_MIXEDSAMPLE_64X
AA_MODE_METHOD_MIXEDSAMPLE_128X
AA_MODE_METHOD_COUNT
AA_MODE_METHOD_METHOD_MASK
AA_MODE_METHOD_METHOD_MAX
AA_MODE_METHOD_NUM_VALUES
AA_MODE_METHOD_DEFAULT
enum EValues_AA_MODE_REPLAY
Enumerator:
AA_MODE_REPLAY_SAMPLES_MASK
AA_MODE_REPLAY_SAMPLES_ONE
AA_MODE_REPLAY_SAMPLES_TWO
AA_MODE_REPLAY_SAMPLES_FOUR
AA_MODE_REPLAY_SAMPLES_EIGHT
AA_MODE_REPLAY_SAMPLES_MAX
AA_MODE_REPLAY_MODE_MASK
AA_MODE_REPLAY_MODE_OFF
AA_MODE_REPLAY_MODE_ALPHA_TEST
AA_MODE_REPLAY_MODE_PIXEL_KILL
AA_MODE_REPLAY_MODE_DYN_BRANCH
AA_MODE_REPLAY_MODE_OPTIMAL
AA_MODE_REPLAY_MODE_ALL
AA_MODE_REPLAY_MODE_MAX
AA_MODE_REPLAY_TRANSPARENCY
AA_MODE_REPLAY_DISALLOW_TRAA
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI
AA_MODE_REPLAY_MASK
AA_MODE_REPLAY_NUM_VALUES
AA_MODE_REPLAY_DEFAULT
enum EValues_AA_MODE_SELECTOR
Enumerator:
AA_MODE_SELECTOR_MASK
AA_MODE_SELECTOR_APP_CONTROL
AA_MODE_SELECTOR_OVERRIDE
AA_MODE_SELECTOR_ENHANCE
AA_MODE_SELECTOR_MAX
AA_MODE_SELECTOR_NUM_VALUES
AA_MODE_SELECTOR_DEFAULT
enum EValues_AA_MODE_SELECTOR_SLIAA
Enumerator:
AA_MODE_SELECTOR_SLIAA_DISABLED
AA_MODE_SELECTOR_SLIAA_ENABLED
AA_MODE_SELECTOR_SLIAA_NUM_VALUES
AA_MODE_SELECTOR_SLIAA_DEFAULT
enum EValues_ANISO_MODE_LEVEL
Enumerator:
ANISO_MODE_LEVEL_MASK
ANISO_MODE_LEVEL_NONE_POINT
ANISO_MODE_LEVEL_NONE_LINEAR
ANISO_MODE_LEVEL_MAX
ANISO_MODE_LEVEL_DEFAULT
ANISO_MODE_LEVEL_NUM_VALUES
enum EValues_ANISO_MODE_SELECTOR
Enumerator:
ANISO_MODE_SELECTOR_MASK
ANISO_MODE_SELECTOR_APP
ANISO_MODE_SELECTOR_USER
ANISO_MODE_SELECTOR_COND
ANISO_MODE_SELECTOR_MAX
ANISO_MODE_SELECTOR_DEFAULT
ANISO_MODE_SELECTOR_NUM_VALUES
enum EValues_AO_MODE
Enumerator:
AO_MODE_OFF
AO_MODE_LOW
AO_MODE_MEDIUM
AO_MODE_HIGH
AO_MODE_NUM_VALUES
AO_MODE_DEFAULT
enum EValues_AO_MODE_ACTIVE
Enumerator:
AO_MODE_ACTIVE_DISABLED
AO_MODE_ACTIVE_ENABLED
AO_MODE_ACTIVE_NUM_VALUES
AO_MODE_ACTIVE_DEFAULT
enum EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT
Enumerator:
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT
enum EValues_AUTO_LODBIASADJUST
Enumerator:
AUTO_LODBIASADJUST_OFF
AUTO_LODBIASADJUST_ON
AUTO_LODBIASADJUST_NUM_VALUES
AUTO_LODBIASADJUST_DEFAULT
enum EValues_CPL_HIDDEN_PROFILE
Enumerator:
CPL_HIDDEN_PROFILE_DISABLED
CPL_HIDDEN_PROFILE_ENABLED
CPL_HIDDEN_PROFILE_NUM_VALUES
CPL_HIDDEN_PROFILE_DEFAULT
enum EValues_EXPORT_PERF_COUNTERS
Enumerator:
EXPORT_PERF_COUNTERS_OFF
EXPORT_PERF_COUNTERS_ON
EXPORT_PERF_COUNTERS_NUM_VALUES
EXPORT_PERF_COUNTERS_DEFAULT
enum EValues_FXAA_ALLOW
Enumerator:
FXAA_ALLOW_DISALLOWED
FXAA_ALLOW_ALLOWED
FXAA_ALLOW_NUM_VALUES
FXAA_ALLOW_DEFAULT
enum EValues_FXAA_ENABLE
Enumerator:
FXAA_ENABLE_OFF
FXAA_ENABLE_ON
FXAA_ENABLE_NUM_VALUES
FXAA_ENABLE_DEFAULT
enum EValues_FXAA_INDICATOR_ENABLE
Enumerator:
FXAA_INDICATOR_ENABLE_OFF
FXAA_INDICATOR_ENABLE_ON
FXAA_INDICATOR_ENABLE_NUM_VALUES
FXAA_INDICATOR_ENABLE_DEFAULT
enum EValues_LODBIASADJUST
Enumerator:
LODBIASADJUST_MIN
LODBIASADJUST_MAX
LODBIASADJUST_NUM_VALUES
LODBIASADJUST_DEFAULT
enum EValues_MAXWELL_B_SAMPLE_INTERLEAVE
Enumerator:
MAXWELL_B_SAMPLE_INTERLEAVE_OFF
MAXWELL_B_SAMPLE_INTERLEAVE_ON
MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES
MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT
enum EValues_MCSFRSHOWSPLIT
Enumerator:
MCSFRSHOWSPLIT_DISABLED
MCSFRSHOWSPLIT_ENABLED
MCSFRSHOWSPLIT_NUM_VALUES
MCSFRSHOWSPLIT_DEFAULT
enum EValues_NLS_ALLOW
Enumerator:
NLS_ALLOW_DISALLOWED
NLS_ALLOW_ALLOWED
NLS_ALLOW_NUM_VALUES
NLS_ALLOW_DEFAULT
enum EValues_NLS_ENABLE
Enumerator:
NLS_ENABLE_OFF
NLS_ENABLE_ON
NLS_ENABLE_NUM_VALUES
NLS_ENABLE_DEFAULT
enum EValues_NV_QUALITY_UPSCALING
Enumerator:
NV_QUALITY_UPSCALING_OFF
NV_QUALITY_UPSCALING_ON
NV_QUALITY_UPSCALING_NUM_VALUES
NV_QUALITY_UPSCALING_DEFAULT
enum EValues_OGL_AA_LINE_GAMMA
Enumerator:
OGL_AA_LINE_GAMMA_DISABLED
OGL_AA_LINE_GAMMA_ENABLED
OGL_AA_LINE_GAMMA_MIN
OGL_AA_LINE_GAMMA_MAX
OGL_AA_LINE_GAMMA_NUM_VALUES
OGL_AA_LINE_GAMMA_DEFAULT
enum EValues_OGL_DEEP_COLOR_SCANOUT
Enumerator:
OGL_DEEP_COLOR_SCANOUT_DISABLE
OGL_DEEP_COLOR_SCANOUT_ENABLE
OGL_DEEP_COLOR_SCANOUT_NUM_VALUES
OGL_DEEP_COLOR_SCANOUT_DEFAULT
enum EValues_OGL_DEFAULT_SWAP_INTERVAL
Enumerator:
OGL_DEFAULT_SWAP_INTERVAL_TEAR
OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE
OGL_DEFAULT_SWAP_INTERVAL_VSYNC
OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK
OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK
OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF
OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON
OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED
OGL_DEFAULT_SWAP_INTERVAL_DISABLE
OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES
OGL_DEFAULT_SWAP_INTERVAL_DEFAULT
enum EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL
Enumerator:
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT
enum EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN
Enumerator:
OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE
OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE
OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES
OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT
enum EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD
Enumerator:
OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE
OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL
OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING
OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION
OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL
OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES
OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT
enum EValues_OGL_FORCE_BLIT
Enumerator:
OGL_FORCE_BLIT_ON
OGL_FORCE_BLIT_OFF
OGL_FORCE_BLIT_NUM_VALUES
OGL_FORCE_BLIT_DEFAULT
enum EValues_OGL_FORCE_STEREO
Enumerator:
OGL_FORCE_STEREO_OFF
OGL_FORCE_STEREO_ON
OGL_FORCE_STEREO_NUM_VALUES
OGL_FORCE_STEREO_DEFAULT
enum EValues_OGL_MULTIMON
Enumerator:
OGL_MULTIMON_SINGLE_MONITOR
OGL_MULTIMON_COMPATIBILITY_LCD
OGL_MULTIMON_COMPATIBILITY_GCD
OGL_MULTIMON_PERFORMANCE_LCD
OGL_MULTIMON_PERFORMANCE_GCD
OGL_MULTIMON_EXTENDED_SINGLE_MONITOR
OGL_MULTIMON_PERFORMANCE_QUADRO
OGL_MULTIMON_MULTIMON_BUFFER
OGL_MULTIMON_NUM_VALUES
OGL_MULTIMON_DEFAULT
enum EValues_OGL_OVERLAY_PIXEL_TYPE
Enumerator:
OGL_OVERLAY_PIXEL_TYPE_NONE
OGL_OVERLAY_PIXEL_TYPE_CI
OGL_OVERLAY_PIXEL_TYPE_RGBA
OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA
OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES
OGL_OVERLAY_PIXEL_TYPE_DEFAULT
enum EValues_OGL_OVERLAY_SUPPORT
Enumerator:
OGL_OVERLAY_SUPPORT_OFF
OGL_OVERLAY_SUPPORT_ON
OGL_OVERLAY_SUPPORT_FORCE_SW
OGL_OVERLAY_SUPPORT_NUM_VALUES
OGL_OVERLAY_SUPPORT_DEFAULT
enum EValues_OGL_QUALITY_ENHANCEMENTS
Enumerator:
OGL_QUALITY_ENHANCEMENTS_HQUAL
OGL_QUALITY_ENHANCEMENTS_QUAL
OGL_QUALITY_ENHANCEMENTS_PERF
OGL_QUALITY_ENHANCEMENTS_HPERF
OGL_QUALITY_ENHANCEMENTS_NUM_VALUES
OGL_QUALITY_ENHANCEMENTS_DEFAULT
enum EValues_OGL_SINGLE_BACKDEPTH_BUFFER
Enumerator:
OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE
OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE
OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT
OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES
OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT
enum EValues_OGL_SLI_MULTICAST
Enumerator:
OGL_SLI_MULTICAST_DISABLE
OGL_SLI_MULTICAST_ENABLE
OGL_SLI_MULTICAST_FORCE_DISABLE
OGL_SLI_MULTICAST_NUM_VALUES
OGL_SLI_MULTICAST_DEFAULT
enum EValues_OGL_THREAD_CONTROL
Enumerator:
OGL_THREAD_CONTROL_ENABLE
OGL_THREAD_CONTROL_DISABLE
OGL_THREAD_CONTROL_NUM_VALUES
OGL_THREAD_CONTROL_DEFAULT
enum EValues_OGL_TRIPLE_BUFFER
Enumerator:
OGL_TRIPLE_BUFFER_DISABLED
OGL_TRIPLE_BUFFER_ENABLED
OGL_TRIPLE_BUFFER_NUM_VALUES
OGL_TRIPLE_BUFFER_DEFAULT
enum EValues_OGL_VIDEO_EDITING_MODE
Enumerator:
OGL_VIDEO_EDITING_MODE_DISABLE
OGL_VIDEO_EDITING_MODE_ENABLE
OGL_VIDEO_EDITING_MODE_NUM_VALUES
OGL_VIDEO_EDITING_MODE_DEFAULT
enum EValues_OPTIMUS_MAXAA
Enumerator:
OPTIMUS_MAXAA_MIN
OPTIMUS_MAXAA_MAX
OPTIMUS_MAXAA_NUM_VALUES
OPTIMUS_MAXAA_DEFAULT
enum EValues_PHYSXINDICATOR
Enumerator:
PHYSXINDICATOR_DISABLED
PHYSXINDICATOR_ENABLED
PHYSXINDICATOR_NUM_VALUES
PHYSXINDICATOR_DEFAULT
enum EValues_PREFERRED_PSTATE
Enumerator:
PREFERRED_PSTATE_ADAPTIVE
PREFERRED_PSTATE_PREFER_MAX
PREFERRED_PSTATE_DRIVER_CONTROLLED
PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE
PREFERRED_PSTATE_PREFER_MIN
PREFERRED_PSTATE_MIN
PREFERRED_PSTATE_MAX
PREFERRED_PSTATE_NUM_VALUES
PREFERRED_PSTATE_DEFAULT
enum EValues_PRERENDERLIMIT
Enumerator:
PRERENDERLIMIT_MIN
PRERENDERLIMIT_MAX
PRERENDERLIMIT_APP_CONTROLLED
PRERENDERLIMIT_NUM_VALUES
PRERENDERLIMIT_DEFAULT
enum EValues_PREVENT_UI_AF_OVERRIDE
Enumerator:
PREVENT_UI_AF_OVERRIDE_OFF
PREVENT_UI_AF_OVERRIDE_ON
PREVENT_UI_AF_OVERRIDE_NUM_VALUES
PREVENT_UI_AF_OVERRIDE_DEFAULT
enum EValues_PS_FRAMERATE_LIMITER
Enumerator:
PS_FRAMERATE_LIMITER_DISABLED
PS_FRAMERATE_LIMITER_FPS_20
PS_FRAMERATE_LIMITER_FPS_30
PS_FRAMERATE_LIMITER_FPS_40
PS_FRAMERATE_LIMITER_FPSMASK
PS_FRAMERATE_LIMITER_FRL2
PS_FRAMERATE_LIMITER_FORCE_VSYNC_OFF
PS_FRAMERATE_LIMITER_GPS_WEB
PS_FRAMERATE_LIMITER_FORCE_OPTIMUS_POLICY
PS_FRAMERATE_LIMITER_DISALLOWED
PS_FRAMERATE_LIMITER_USE_CPU_WAIT
PS_FRAMERATE_LIMITER_THRESHOLD
PS_FRAMERATE_LIMITER_TEMPERATURE
PS_FRAMERATE_LIMITER_POWER
PS_FRAMERATE_LIMITER_MODEMASK
PS_FRAMERATE_LIMITER_ACCURATE
PS_FRAMERATE_LIMITER_ALLOW_WINDOWED
PS_FRAMERATE_LIMITER_FORCEON
PS_FRAMERATE_LIMITER_ENABLED
PS_FRAMERATE_LIMITER_OPENGL_REMOTE_DESKTOP
PS_FRAMERATE_LIMITER_MASK
PS_FRAMERATE_LIMITER_NUM_VALUES
PS_FRAMERATE_LIMITER_DEFAULT
enum EValues_PS_FRAMERATE_LIMITER_2_CONTROL
Enumerator:
PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_CE
PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_3D
PS_FRAMERATE_LIMITER_2_CONTROL_AVOID_NOOP
PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL_MAXWELL
PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL
PS_FRAMERATE_LIMITER_2_CONTROL_FORCE_OFF
PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT_FOR_GM10X
PS_FRAMERATE_LIMITER_2_CONTROL_NUM_VALUES
PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT
enum EValues_PS_FRAMERATE_LIMITER_GPS_CTRL
Enumerator:
PS_FRAMERATE_LIMITER_GPS_CTRL_DISABLED
PS_FRAMERATE_LIMITER_GPS_CTRL_DECREASE_FILTER_MASK
PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_MASK
PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_SHIFT
PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_MASK
PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_SHIFT
PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_MASK
PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_SHIFT
PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_MASK
PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_SHIFT
PS_FRAMERATE_LIMITER_GPS_CTRL_OPTIMAL_SETTING
PS_FRAMERATE_LIMITER_GPS_CTRL_NUM_VALUES
PS_FRAMERATE_LIMITER_GPS_CTRL_DEFAULT
enum EValues_PS_FRAMERATE_MONITOR_CTRL
Enumerator:
PS_FRAMERATE_MONITOR_CTRL_DISABLED
PS_FRAMERATE_MONITOR_CTRL_THRESHOLD_PCT_MASK
PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_MASK
PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_SHIFT
PS_FRAMERATE_MONITOR_CTRL_ENABLE_ON_VSYNC
PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_MASK
PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_SHIFT
PS_FRAMERATE_MONITOR_CTRL_FPS_USE_FRL
PS_FRAMERATE_MONITOR_CTRL_FPS_30
PS_FRAMERATE_MONITOR_CTRL_FPS_60
PS_FRAMERATE_MONITOR_CTRL_FPS_MASK
PS_FRAMERATE_MONITOR_CTRL_FPS_SHIFT
PS_FRAMERATE_MONITOR_CTRL_OPTIMAL_SETTING
PS_FRAMERATE_MONITOR_CTRL_VSYNC_OPTIMAL_SETTING
PS_FRAMERATE_MONITOR_CTRL_NUM_VALUES
PS_FRAMERATE_MONITOR_CTRL_DEFAULT
enum EValues_PS_SHADERDISKCACHE
Enumerator:
PS_SHADERDISKCACHE_OFF
PS_SHADERDISKCACHE_ON
PS_SHADERDISKCACHE_NUM_VALUES
PS_SHADERDISKCACHE_DEFAULT
enum EValues_PS_TEXFILTER_ANISO_OPTS2
Enumerator:
PS_TEXFILTER_ANISO_OPTS2_OFF
PS_TEXFILTER_ANISO_OPTS2_ON
PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES
PS_TEXFILTER_ANISO_OPTS2_DEFAULT
enum EValues_PS_TEXFILTER_BILINEAR_IN_ANISO
Enumerator:
PS_TEXFILTER_BILINEAR_IN_ANISO_OFF
PS_TEXFILTER_BILINEAR_IN_ANISO_ON
PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES
PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT
enum EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE
Enumerator:
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT
enum EValues_PS_TEXFILTER_NO_NEG_LODBIAS
Enumerator:
PS_TEXFILTER_NO_NEG_LODBIAS_OFF
PS_TEXFILTER_NO_NEG_LODBIAS_ON
PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES
PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT
enum EValues_QUALITY_ENHANCEMENTS
Enumerator:
QUALITY_ENHANCEMENTS_HIGHQUALITY
QUALITY_ENHANCEMENTS_QUALITY
QUALITY_ENHANCEMENTS_PERFORMANCE
QUALITY_ENHANCEMENTS_HIGHPERFORMANCE
QUALITY_ENHANCEMENTS_NUM_VALUES
QUALITY_ENHANCEMENTS_DEFAULT
enum EValues_REFRESH_RATE_OVERRIDE
Enumerator:
REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED
REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE
REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK
REFRESH_RATE_OVERRIDE_NUM_VALUES
REFRESH_RATE_OVERRIDE_DEFAULT
enum EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE
Enumerator:
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT
enum EValues_SET_VAB_DATA
Enumerator:
SET_VAB_DATA_ZERO
SET_VAB_DATA_UINT_ONE
SET_VAB_DATA_FLOAT_ONE
SET_VAB_DATA_FLOAT_POS_INF
SET_VAB_DATA_FLOAT_NAN
SET_VAB_DATA_USE_API_DEFAULTS
SET_VAB_DATA_NUM_VALUES
SET_VAB_DATA_DEFAULT
enum EValues_SHIM_MCCOMPAT
Enumerator:
SHIM_MCCOMPAT_INTEGRATED
SHIM_MCCOMPAT_ENABLE
SHIM_MCCOMPAT_USER_EDITABLE
SHIM_MCCOMPAT_MASK
SHIM_MCCOMPAT_VIDEO_MASK
SHIM_MCCOMPAT_VARYING_BIT
SHIM_MCCOMPAT_AUTO_SELECT
SHIM_MCCOMPAT_OVERRIDE_BIT
SHIM_MCCOMPAT_NUM_VALUES
SHIM_MCCOMPAT_DEFAULT
enum EValues_SHIM_RENDERING_MODE
Enumerator:
SHIM_RENDERING_MODE_INTEGRATED
SHIM_RENDERING_MODE_ENABLE
SHIM_RENDERING_MODE_USER_EDITABLE
SHIM_RENDERING_MODE_MASK
SHIM_RENDERING_MODE_VIDEO_MASK
SHIM_RENDERING_MODE_VARYING_BIT
SHIM_RENDERING_MODE_AUTO_SELECT
SHIM_RENDERING_MODE_OVERRIDE_BIT
SHIM_RENDERING_MODE_NUM_VALUES
SHIM_RENDERING_MODE_DEFAULT
enum EValues_SHIM_RENDERING_OPTIONS
Enumerator:
SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE
SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT
SHIM_RENDERING_OPTIONS_EHSHELL_DETECT
SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT
SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT
SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES
SHIM_RENDERING_OPTIONS_RESERVED1
SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT
SHIM_RENDERING_OPTIONS_RESERVED2
SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE
SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS
SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS
SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS
SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT
SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING
SHIM_RENDERING_OPTIONS_DISABLE_CUDA
SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO
SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS
SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT
SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO
SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID
SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD
SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT
SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG
SHIM_RENDERING_OPTIONS_NUM_VALUES
SHIM_RENDERING_OPTIONS_DEFAULT
enum EValues_SLI_GPU_COUNT
Enumerator:
SLI_GPU_COUNT_AUTOSELECT
SLI_GPU_COUNT_ONE
SLI_GPU_COUNT_TWO
SLI_GPU_COUNT_THREE
SLI_GPU_COUNT_FOUR
SLI_GPU_COUNT_NUM_VALUES
SLI_GPU_COUNT_DEFAULT
enum EValues_SLI_PREDEFINED_GPU_COUNT
Enumerator:
SLI_PREDEFINED_GPU_COUNT_AUTOSELECT
SLI_PREDEFINED_GPU_COUNT_ONE
SLI_PREDEFINED_GPU_COUNT_TWO
SLI_PREDEFINED_GPU_COUNT_THREE
SLI_PREDEFINED_GPU_COUNT_FOUR
SLI_PREDEFINED_GPU_COUNT_NUM_VALUES
SLI_PREDEFINED_GPU_COUNT_DEFAULT
enum EValues_SLI_PREDEFINED_GPU_COUNT_DX10
Enumerator:
SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT
SLI_PREDEFINED_GPU_COUNT_DX10_ONE
SLI_PREDEFINED_GPU_COUNT_DX10_TWO
SLI_PREDEFINED_GPU_COUNT_DX10_THREE
SLI_PREDEFINED_GPU_COUNT_DX10_FOUR
SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES
SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT
enum EValues_SLI_PREDEFINED_MODE
Enumerator:
SLI_PREDEFINED_MODE_AUTOSELECT
SLI_PREDEFINED_MODE_FORCE_SINGLE
SLI_PREDEFINED_MODE_FORCE_AFR
SLI_PREDEFINED_MODE_FORCE_AFR2
SLI_PREDEFINED_MODE_FORCE_SFR
SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR
SLI_PREDEFINED_MODE_NUM_VALUES
SLI_PREDEFINED_MODE_DEFAULT
enum EValues_SLI_PREDEFINED_MODE_DX10
Enumerator:
SLI_PREDEFINED_MODE_DX10_AUTOSELECT
SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE
SLI_PREDEFINED_MODE_DX10_FORCE_AFR
SLI_PREDEFINED_MODE_DX10_FORCE_AFR2
SLI_PREDEFINED_MODE_DX10_FORCE_SFR
SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR
SLI_PREDEFINED_MODE_DX10_NUM_VALUES
SLI_PREDEFINED_MODE_DX10_DEFAULT
enum EValues_SLI_RENDERING_MODE
Enumerator:
SLI_RENDERING_MODE_AUTOSELECT
SLI_RENDERING_MODE_FORCE_SINGLE
SLI_RENDERING_MODE_FORCE_AFR
SLI_RENDERING_MODE_FORCE_AFR2
SLI_RENDERING_MODE_FORCE_SFR
SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR
SLI_RENDERING_MODE_NUM_VALUES
SLI_RENDERING_MODE_DEFAULT
enum EValues_VRPRERENDERLIMIT
Enumerator:
VRPRERENDERLIMIT_MIN
VRPRERENDERLIMIT_MAX
VRPRERENDERLIMIT_APP_CONTROLLED
VRPRERENDERLIMIT_DEFAULT
VRPRERENDERLIMIT_NUM_VALUES
enum EValues_VRR_APP_OVERRIDE
Enumerator:
VRR_APP_OVERRIDE_ALLOW
VRR_APP_OVERRIDE_FORCE_OFF
VRR_APP_OVERRIDE_DISALLOW
VRR_APP_OVERRIDE_ULMB
VRR_APP_OVERRIDE_FIXED_REFRESH
VRR_APP_OVERRIDE_NUM_VALUES
VRR_APP_OVERRIDE_DEFAULT
enum EValues_VRR_APP_OVERRIDE_REQUEST_STATE
Enumerator:
VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW
VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF
VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW
VRR_APP_OVERRIDE_REQUEST_STATE_ULMB
VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH
VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES
VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT
enum EValues_VRR_MODE
Enumerator:
VRR_MODE_DISABLED
VRR_MODE_FULLSCREEN_ONLY
VRR_MODE_FULLSCREEN_AND_WINDOWED
VRR_MODE_NUM_VALUES
VRR_MODE_DEFAULT
enum EValues_VRRFEATUREINDICATOR
Enumerator:
VRRFEATUREINDICATOR_DISABLED
VRRFEATUREINDICATOR_ENABLED
VRRFEATUREINDICATOR_NUM_VALUES
VRRFEATUREINDICATOR_DEFAULT
enum EValues_VRROVERLAYINDICATOR
Enumerator:
VRROVERLAYINDICATOR_DISABLED
VRROVERLAYINDICATOR_ENABLED
VRROVERLAYINDICATOR_NUM_VALUES
VRROVERLAYINDICATOR_DEFAULT
enum EValues_VRRREQUESTSTATE
Enumerator:
VRRREQUESTSTATE_DISABLED
VRRREQUESTSTATE_FULLSCREEN_ONLY
VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED
VRRREQUESTSTATE_NUM_VALUES
VRRREQUESTSTATE_DEFAULT
enum EValues_VSYNC_BEHAVIOR_FLAGS
Enumerator:
VSYNC_BEHAVIOR_FLAGS_NONE
VSYNC_BEHAVIOR_FLAGS_DEFAULT
VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE
VSYNC_BEHAVIOR_FLAGS_NUM_VALUES
enum EValues_VSYNCMODE
Enumerator:
VSYNCMODE_PASSIVE
VSYNCMODE_FORCEOFF
VSYNCMODE_FORCEON
VSYNCMODE_FLIPINTERVAL2
VSYNCMODE_FLIPINTERVAL3
VSYNCMODE_FLIPINTERVAL4
VSYNCMODE_NUM_VALUES
VSYNCMODE_DEFAULT
enum EValues_VSYNCSMOOTHAFR
Enumerator:
VSYNCSMOOTHAFR_OFF
VSYNCSMOOTHAFR_ON
VSYNCSMOOTHAFR_NUM_VALUES
VSYNCSMOOTHAFR_DEFAULT
enum EValues_VSYNCTEARCONTROL
Enumerator:
VSYNCTEARCONTROL_DISABLE
VSYNCTEARCONTROL_ENABLE
VSYNCTEARCONTROL_NUM_VALUES
VSYNCTEARCONTROL_DEFAULT
enum EValues_VSYNCVRRCONTROL
Enumerator:
VSYNCVRRCONTROL_DISABLE
VSYNCVRRCONTROL_ENABLE
VSYNCVRRCONTROL_NOTSUPPORTED
VSYNCVRRCONTROL_NUM_VALUES
VSYNCVRRCONTROL_DEFAULT
enum EValues_WKS_API_STEREO_EYES_EXCHANGE
Enumerator:
WKS_API_STEREO_EYES_EXCHANGE_OFF
WKS_API_STEREO_EYES_EXCHANGE_ON
WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES
WKS_API_STEREO_EYES_EXCHANGE_DEFAULT
enum EValues_WKS_API_STEREO_MODE
Enumerator:
WKS_API_STEREO_MODE_SHUTTER_GLASSES
WKS_API_STEREO_MODE_VERTICAL_INTERLACED
WKS_API_STEREO_MODE_TWINVIEW
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1
WKS_API_STEREO_MODE_COLOR_LINE
WKS_API_STEREO_MODE_COLOR_INTERLEAVED
WKS_API_STEREO_MODE_ANAGLYPH
WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED
WKS_API_STEREO_MODE_SIDE_FIELD
WKS_API_STEREO_MODE_SUB_FIELD
WKS_API_STEREO_MODE_CHECKERBOARD
WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD
WKS_API_STEREO_MODE_TRIDELITY_SL
WKS_API_STEREO_MODE_TRIDELITY_MV
WKS_API_STEREO_MODE_SEEFRONT
WKS_API_STEREO_MODE_STEREO_MIRROR
WKS_API_STEREO_MODE_FRAME_SEQUENTIAL
WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE
WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL
WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL
WKS_API_STEREO_MODE_USE_HW_DEFAULT
WKS_API_STEREO_MODE_DEFAULT_GL
WKS_API_STEREO_MODE_NUM_VALUES
WKS_API_STEREO_MODE_DEFAULT
enum EValues_WKS_MEMORY_ALLOCATION_POLICY
Enumerator:
WKS_MEMORY_ALLOCATION_POLICY_AS_NEEDED
WKS_MEMORY_ALLOCATION_POLICY_MODERATE_PRE_ALLOCATION
WKS_MEMORY_ALLOCATION_POLICY_AGGRESSIVE_PRE_ALLOCATION
WKS_MEMORY_ALLOCATION_POLICY_NUM_VALUES
WKS_MEMORY_ALLOCATION_POLICY_DEFAULT
enum EValues_WKS_STEREO_DONGLE_SUPPORT
Enumerator:
WKS_STEREO_DONGLE_SUPPORT_OFF
WKS_STEREO_DONGLE_SUPPORT_DAC
WKS_STEREO_DONGLE_SUPPORT_DLP
WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES
WKS_STEREO_DONGLE_SUPPORT_DEFAULT
enum EValues_WKS_STEREO_SUPPORT
Enumerator:
WKS_STEREO_SUPPORT_OFF
WKS_STEREO_SUPPORT_ON
WKS_STEREO_SUPPORT_NUM_VALUES
WKS_STEREO_SUPPORT_DEFAULT
enum EValues_WKS_STEREO_SWAP_MODE
Enumerator:
WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL
WKS_STEREO_SWAP_MODE_PER_EYE
WKS_STEREO_SWAP_MODE_PER_EYE_PAIR
WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR
WKS_STEREO_SWAP_MODE_NUM_VALUES
WKS_STEREO_SWAP_MODE_DEFAULT


  • File List
  • Globals
Functions
nvHLSLExtns.h File Reference
#include "nvHLSLExtnsInternal.h"

Functions

int | NvShfl (int val, uint srcLane, int width=NV_WARP_SIZE)
int | NvShflUp (int val, uint delta, int width=NV_WARP_SIZE)
int | NvShflDown (int val, uint delta, int width=NV_WARP_SIZE)
int | NvShflXor (int val, uint laneMask, int width=NV_WARP_SIZE)
uint | NvAny (int predicate)
uint | NvAll (int predicate)
uint | NvBallot (int predicate)
int | NvGetLaneId ()
uint | NvInterlockedAddFp16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWByteAddressBuffer uav, uint byteAddress, float2 val)
uint | NvInterlockedMinFp16x2 (RWByteAddressBuffer uav, uint byteAddress, float2 val)
uint | NvInterlockedMaxFp16x2 (RWByteAddressBuffer uav, uint byteAddress, float2 val)
uint | NvInterlockedAddFp16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWTexture1D< float2 > uav, uint address, float2 val)
uint | NvInterlockedMinFp16x2 (RWTexture1D< float2 > uav, uint address, float2 val)
uint | NvInterlockedMaxFp16x2 (RWTexture1D< float2 > uav, uint address, float2 val)
uint | NvInterlockedAddFp16x2 (RWTexture2D< float2 > uav, uint2 address, float2 val)
uint | NvInterlockedMinFp16x2 (RWTexture2D< float2 > uav, uint2 address, float2 val)
uint | NvInterlockedMaxFp16x2 (RWTexture2D< float2 > uav, uint2 address, float2 val)
uint | NvInterlockedAddFp16x2 (RWTexture3D< float2 > uav, uint3 address, float2 val)
uint | NvInterlockedMinFp16x2 (RWTexture3D< float2 > uav, uint3 address, float2 val)
uint | NvInterlockedMaxFp16x2 (RWTexture3D< float2 > uav, uint3 address, float2 val)
uint2 | NvInterlockedAddFp16x4 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val)
uint2 | NvInterlockedMinFp16x4 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val)
uint2 | NvInterlockedAddFp16x4 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val)
uint2 | NvInterlockedMinFp16x4 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val)
uint2 | NvInterlockedAddFp16x4 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val)
uint2 | NvInterlockedMinFp16x4 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val)
uint2 | NvInterlockedAddFp16x4 (RWTexture1D< float4 > uav, uint address, float4 val)
uint2 | NvInterlockedMinFp16x4 (RWTexture1D< float4 > uav, uint address, float4 val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture1D< float4 > uav, uint address, float4 val)
uint2 | NvInterlockedAddFp16x4 (RWTexture2D< float4 > uav, uint2 address, float4 val)
uint2 | NvInterlockedMinFp16x4 (RWTexture2D< float4 > uav, uint2 address, float4 val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture2D< float4 > uav, uint2 address, float4 val)
uint2 | NvInterlockedAddFp16x4 (RWTexture3D< float4 > uav, uint3 address, float4 val)
uint2 | NvInterlockedMinFp16x4 (RWTexture3D< float4 > uav, uint3 address, float4 val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture3D< float4 > uav, uint3 address, float4 val)
float | NvInterlockedAddFp32 (RWByteAddressBuffer uav, uint byteAddress, float val)
float | NvInterlockedAddFp32 (RWTexture1D< float > uav, uint address, float val)
float | NvInterlockedAddFp32 (RWTexture2D< float > uav, uint2 address, float val)
float | NvInterlockedAddFp32 (RWTexture3D< float > uav, uint3 address, float val)
float4 | NvLoadUavTyped (RWTexture1D< float4 > uav, uint address)
float4 | NvLoadUavTyped (RWTexture2D< float4 > uav, uint2 address)
float4 | NvLoadUavTyped (RWTexture3D< float4 > uav, uint3 address)
float2 | NvLoadUavTyped (RWTexture1D< float2 > uav, uint address)
float2 | NvLoadUavTyped (RWTexture2D< float2 > uav, uint2 address)
float2 | NvLoadUavTyped (RWTexture3D< float2 > uav, uint3 address)
float | NvLoadUavTyped (RWTexture1D< float > uav, uint address)
float | NvLoadUavTyped (RWTexture2D< float > uav, uint2 address)
float | NvLoadUavTyped (RWTexture3D< float > uav, uint3 address)
uint4 | NvLoadUavTyped (RWTexture1D< uint4 > uav, uint address)
uint4 | NvLoadUavTyped (RWTexture2D< uint4 > uav, uint2 address)
uint4 | NvLoadUavTyped (RWTexture3D< uint4 > uav, uint3 address)
uint2 | NvLoadUavTyped (RWTexture1D< uint2 > uav, uint address)
uint2 | NvLoadUavTyped (RWTexture2D< uint2 > uav, uint2 address)
uint2 | NvLoadUavTyped (RWTexture3D< uint2 > uav, uint3 address)
uint | NvLoadUavTyped (RWTexture1D< uint > uav, uint address)
uint | NvLoadUavTyped (RWTexture2D< uint > uav, uint2 address)
uint | NvLoadUavTyped (RWTexture3D< uint > uav, uint3 address)
int4 | NvLoadUavTyped (RWTexture1D< int4 > uav, uint address)
int4 | NvLoadUavTyped (RWTexture2D< int4 > uav, uint2 address)
int4 | NvLoadUavTyped (RWTexture3D< int4 > uav, uint3 address)
int2 | NvLoadUavTyped (RWTexture1D< int2 > uav, uint address)
int2 | NvLoadUavTyped (RWTexture2D< int2 > uav, uint2 address)
int2 | NvLoadUavTyped (RWTexture3D< int2 > uav, uint3 address)
int | NvLoadUavTyped (RWTexture1D< int > uav, uint address)
int | NvLoadUavTyped (RWTexture2D< int > uav, uint2 address)
int | NvLoadUavTyped (RWTexture3D< int > uav, uint3 address)

Function Documentation

uint NvAll ( int predicate )

References g_NvidiaExt, and NV_EXTN_OP_VOTE_ALL.

uint NvAny ( int predicate )

References g_NvidiaExt, and NV_EXTN_OP_VOTE_ANY.

uint NvBallot ( int predicate )

References g_NvidiaExt, and NV_EXTN_OP_VOTE_BALLOT.

int NvGetLaneId ( )

References g_NvidiaExt, and NV_EXTN_OP_GET_LANE_ID.

uint NvInterlockedAddFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint NvInterlockedAddFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint NvInterlockedAddFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint NvInterlockedAddFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint NvInterlockedAddFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint NvInterlockedAddFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint NvInterlockedAddFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint NvInterlockedAddFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint2 NvInterlockedAddFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint2 NvInterlockedAddFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint2 NvInterlockedAddFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint2 NvInterlockedAddFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint2 NvInterlockedAddFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

uint2 NvInterlockedAddFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

float NvInterlockedAddFp32 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

float NvInterlockedAddFp32 | ( | RWTexture1D< float > | uav,
 |  | uint | address,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

float NvInterlockedAddFp32 | ( | RWTexture2D< float > | uav,
 |  | uint2 | address,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

float NvInterlockedAddFp32 | ( | RWTexture3D< float > | uav,
 |  | uint3 | address,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

uint NvInterlockedMaxFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMaxFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMaxFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMaxFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMaxFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMaxFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMaxFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMaxFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

uint NvInterlockedMinFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint NvInterlockedMinFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint NvInterlockedMinFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint NvInterlockedMinFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint NvInterlockedMinFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint NvInterlockedMinFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint NvInterlockedMinFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint NvInterlockedMinFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint2 NvInterlockedMinFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint2 NvInterlockedMinFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint2 NvInterlockedMinFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint2 NvInterlockedMinFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint2 NvInterlockedMinFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

uint2 NvInterlockedMinFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

float4 NvLoadUavTyped | ( | RWTexture1D< float4 > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float4 NvLoadUavTyped | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float4 NvLoadUavTyped | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float2 NvLoadUavTyped | ( | RWTexture1D< float2 > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float2 NvLoadUavTyped | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float2 NvLoadUavTyped | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float NvLoadUavTyped | ( | RWTexture1D< float > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float NvLoadUavTyped | ( | RWTexture2D< float > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

float NvLoadUavTyped | ( | RWTexture3D< float > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint4 NvLoadUavTyped | ( | RWTexture1D< uint4 > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint4 NvLoadUavTyped | ( | RWTexture2D< uint4 > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint4 NvLoadUavTyped | ( | RWTexture3D< uint4 > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint2 NvLoadUavTyped | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint2 NvLoadUavTyped | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint2 NvLoadUavTyped | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint NvLoadUavTyped | ( | RWTexture1D< uint > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint NvLoadUavTyped | ( | RWTexture2D< uint > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

uint NvLoadUavTyped | ( | RWTexture3D< uint > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int4 NvLoadUavTyped | ( | RWTexture1D< int4 > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int4 NvLoadUavTyped | ( | RWTexture2D< int4 > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int4 NvLoadUavTyped | ( | RWTexture3D< int4 > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int2 NvLoadUavTyped | ( | RWTexture1D< int2 > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int2 NvLoadUavTyped | ( | RWTexture2D< int2 > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int2 NvLoadUavTyped | ( | RWTexture3D< int2 > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int NvLoadUavTyped | ( | RWTexture1D< int > | uav,
 |  | uint | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int NvLoadUavTyped | ( | RWTexture2D< int > | uav,
 |  | uint2 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int NvLoadUavTyped | ( | RWTexture3D< int > | uav,
 |  | uint3 | address
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_TYPED_UAV_LOAD.

int NvShfl | ( | int | val,
 |  | uint | srcLane,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References __NvGetShflMaskFromWidth(), g_NvidiaExt, and NV_EXTN_OP_SHFL.

int NvShflDown | ( | int | val,
 |  | uint | delta,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References __NvGetShflMaskFromWidth(), g_NvidiaExt, and NV_EXTN_OP_SHFL_DOWN.

int NvShflUp | ( | int | val,
 |  | uint | delta,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References g_NvidiaExt, NV_EXTN_OP_SHFL_UP, and NV_WARP_SIZE.

int NvShflXor | ( | int | val,
 |  | uint | laneMask,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References __NvGetShflMaskFromWidth(), g_NvidiaExt, and NV_EXTN_OP_SHFL_XOR.


  • File List
  • Globals
Data Structures | Defines | Functions | Variables
nvHLSLExtnsInternal.h File Reference
#include "nvShaderExtnEnums.h"

Data Structures

struct | NvShaderExtnStruct

Defines

#define | NV_EXTN_ATOM_ADD 3
#define | NV_EXTN_ATOM_MAX 6
#define | NV_EXTN_ATOM_MIN 7

Functions

int | __NvGetShflMaskFromWidth (uint width)
void | __NvReferenceUAVForOp (RWByteAddressBuffer uav)
void | __NvReferenceUAVForOp (RWTexture1D< float2 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< float2 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< float2 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< float4 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< float4 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< float4 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< float > uav)
void | __NvReferenceUAVForOp (RWTexture2D< float > uav)
void | __NvReferenceUAVForOp (RWTexture3D< float > uav)
void | __NvReferenceUAVForOp (RWTexture1D< uint2 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< uint2 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< uint2 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< uint4 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< uint4 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< uint4 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< uint > uav)
void | __NvReferenceUAVForOp (RWTexture2D< uint > uav)
void | __NvReferenceUAVForOp (RWTexture3D< uint > uav)
void | __NvReferenceUAVForOp (RWTexture1D< int2 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< int2 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< int2 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< int4 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< int4 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< int4 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< int > uav)
void | __NvReferenceUAVForOp (RWTexture2D< int > uav)
void | __NvReferenceUAVForOp (RWTexture3D< int > uav)
uint | __NvAtomicOpFP16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val, uint atomicOpType)
uint | __NvAtomicOpFP16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val, uint atomicOpType)
uint | __NvAtomicOpFP16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val, uint atomicOpType)
uint | __NvAtomicOpFP16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val, uint atomicOpType)
uint2 | __NvAtomicOpFP16x2 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val, uint atomicOpType)
uint2 | __NvAtomicOpFP16x2 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val, uint atomicOpType)
uint2 | __NvAtomicOpFP16x2 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val, uint atomicOpType)
uint | __fp32x2Tofp16x2 (float2 val)
uint2 | __fp32x4Tofp16x4 (float4 val)
float | __NvAtomicAddFP32 (RWByteAddressBuffer uav, uint byteAddress, float val)
float | __NvAtomicAddFP32 (RWTexture1D< float > uav, uint address, float val)
float | __NvAtomicAddFP32 (RWTexture2D< float > uav, uint2 address, float val)
float | __NvAtomicAddFP32 (RWTexture3D< float > uav, uint3 address, float val)

Variables

RWStructuredBuffer
< NvShaderExtnStruct > 		g_NvidiaExt

Define Documentation

#define NV_EXTN_ATOM_ADD 3

Referenced by __NvAtomicAddFP32(), NvInterlockedAddFp16x2(), and NvInterlockedAddFp16x4().

#define NV_EXTN_ATOM_MAX 6

Referenced by NvInterlockedMaxFp16x2(), and NvInterlockedMaxFp16x4().

#define NV_EXTN_ATOM_MIN 7

Referenced by NvInterlockedMinFp16x2(), and NvInterlockedMinFp16x4().

Function Documentation

uint __fp32x2Tofp16x2 ( float2 val )

Referenced by NvInterlockedAddFp16x2(), NvInterlockedMaxFp16x2(), and NvInterlockedMinFp16x2().

uint2 __fp32x4Tofp16x4 ( float4 val )

Referenced by NvInterlockedAddFp16x4(), NvInterlockedMaxFp16x4(), and NvInterlockedMinFp16x4().

float __NvAtomicAddFP32 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

Referenced by NvInterlockedAddFp32().

float __NvAtomicAddFP32 | ( | RWTexture1D< float > | uav,
 |  | uint | address,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

float __NvAtomicAddFP32 | ( | RWTexture2D< float > | uav,
 |  | uint2 | address,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

float __NvAtomicAddFP32 | ( | RWTexture3D< float > | uav,
 |  | uint3 | address,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

uint __NvAtomicOpFP16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

Referenced by NvInterlockedAddFp16x2(), NvInterlockedAddFp16x4(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x4(), NvInterlockedMinFp16x2(), and NvInterlockedMinFp16x4().

uint __NvAtomicOpFP16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

uint __NvAtomicOpFP16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

uint __NvAtomicOpFP16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

uint2 __NvAtomicOpFP16x2 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

uint2 __NvAtomicOpFP16x2 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

uint2 __NvAtomicOpFP16x2 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

int __NvGetShflMaskFromWidth ( uint width )

References NV_WARP_SIZE.

Referenced by NvShfl(), NvShflDown(), and NvShflXor().

void __NvReferenceUAVForOp ( RWByteAddressBuffer uav )

References g_NvidiaExt.

Referenced by __NvAtomicAddFP32(), __NvAtomicOpFP16x2(), and NvLoadUavTyped().

void __NvReferenceUAVForOp ( RWTexture1D< float2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< float2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< float2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< float4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< float4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< float4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< float > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< float > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< float > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< uint2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< uint2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< uint2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< uint4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< uint4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< uint4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< uint > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< uint > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< uint > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< int2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< int2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< int2 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< int4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< int4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< int4 > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture1D< int > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture2D< int > uav )

References g_NvidiaExt.

void __NvReferenceUAVForOp ( RWTexture3D< int > uav )

References g_NvidiaExt.

Variable Documentation

RWStructuredBuffer<NvShaderExtnStruct> g_NvidiaExt

Referenced by __NvAtomicAddFP32(), __NvAtomicOpFP16x2(), __NvReferenceUAVForOp(), NvAll(), NvAny(), NvBallot(), NvGetLaneId(), NvLoadUavTyped(), NvShfl(), NvShflDown(), NvShflUp(), and NvShflXor().


  • File List
  • Globals
Defines
nvShaderExtnEnums.h File Reference

Defines

#define | NV_SHADER_EXTN_VERSION 1
#define | NV_WARP_SIZE 32
#define | NV_EXTN_OP_SHFL 1
#define | NV_EXTN_OP_SHFL_UP 2
#define | NV_EXTN_OP_SHFL_DOWN 3
#define | NV_EXTN_OP_SHFL_XOR 4
#define | NV_EXTN_OP_VOTE_ALL 5
#define | NV_EXTN_OP_VOTE_ANY 6
#define | NV_EXTN_OP_VOTE_BALLOT 7
#define | NV_EXTN_OP_GET_LANE_ID 8
#define | NV_EXTN_OP_FP16_ATOMIC 12
#define | NV_EXTN_OP_FP32_ATOMIC 13
#define | NV_EXTN_OP_TYPED_UAV_LOAD 14

Define Documentation

#define NV_EXTN_OP_FP16_ATOMIC 12

Referenced by __NvAtomicOpFP16x2().

#define NV_EXTN_OP_FP32_ATOMIC 13

Referenced by __NvAtomicAddFP32().

#define NV_EXTN_OP_GET_LANE_ID 8

Referenced by NvGetLaneId().

#define NV_EXTN_OP_SHFL 1

Referenced by NvShfl().

#define NV_EXTN_OP_SHFL_DOWN 3

Referenced by NvShflDown().

#define NV_EXTN_OP_SHFL_UP 2

Referenced by NvShflUp().

#define NV_EXTN_OP_SHFL_XOR 4

Referenced by NvShflXor().

#define NV_EXTN_OP_TYPED_UAV_LOAD 14

Referenced by NvLoadUavTyped().

#define NV_EXTN_OP_VOTE_ALL 5

Referenced by NvAll().

#define NV_EXTN_OP_VOTE_ANY 6

Referenced by NvAny().

#define NV_EXTN_OP_VOTE_BALLOT 7

Referenced by NvBallot().

#define NV_SHADER_EXTN_VERSION 1
#define NV_WARP_SIZE 32

Referenced by __NvGetShflMaskFromWidth(), and NvShflUp().


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __cdecl : nvapi.h
  • __cplusplus : defines.txt
  • __d3d10_1_h__ : defines.txt
  • __d3d10_h__ : defines.txt
  • __d3d11_h__ : defines.txt
  • __fp32x2Tofp16x2() : nvHLSLExtnsInternal.h
  • __fp32x4Tofp16x4() : nvHLSLExtnsInternal.h
  • __nvapi_deprecated_function() : nvapi.h
  • __NvAtomicAddFP32() : nvHLSLExtnsInternal.h
  • __NvAtomicOpFP16x2() : nvHLSLExtnsInternal.h
  • __NvGetShflMaskFromWidth() : nvHLSLExtnsInternal.h
  • __NvReferenceUAVForOp() : nvHLSLExtnsInternal.h
  • _D3D9_H_ : defines.txt
  • _IMPLICIT_SLI_CONTROL : nvapi.h
  • _NV_BPC : nvapi.h
  • _NV_DISPLAY_TV_FORMAT : nvapi.h
  • _NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • _NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • _NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • _NV_DP_BPC : nvapi.h
  • _NV_DP_COLOR_FORMAT : nvapi.h
  • _NV_DP_COLORIMETRY : nvapi.h
  • _NV_DP_DYNAMIC_RANGE : nvapi.h
  • _NV_DP_LANE_COUNT : nvapi.h
  • _NV_DP_LINK_RATE : nvapi.h
  • _NV_DYNAMIC_RANGE : nvapi.h
  • _NV_ECC_CONFIGURATION : nvapi.h
  • _NV_FASTGS_FLAGS : nvapi.h
  • _NV_FORMAT : nvapi.h
  • _NV_FrustumAdjustMode : nvapi.h
  • _NV_GPU_BUS_TYPE : nvapi.h
  • _NV_GPU_CONNECTOR_TYPE : nvapi.h
  • _NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • _NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • _NV_GPU_OUTPUT_TYPE : nvapi.h
  • _NV_GPU_PERF_PSTATE_ID : nvapi.h
  • _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • _NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • _NV_GPU_TYPE : nvapi.h
  • _NV_PIXEL_SHIFT_TYPE : nvapi.h
  • _NV_PSO_EXTENSION : nvapi.h
  • _NV_ROTATE : nvapi.h
  • _NV_SCALING : nvapi.h
  • _NV_STEREO_VIDEO_FORMAT : nvapi.h
  • _NV_StereoActiveEye : nvapi_lite_stereo.h
  • _NV_StereoDriverMode : nvapi_lite_stereo.h
  • _NV_StereoRegistryID : nvapi.h
  • _NV_StereoRegistryProfileType : nvapi.h
  • _NV_StereoSwapChainMode : nvapi.h
  • _NV_SWIZZLE_MODE : nvapi.h
  • _NV_SWIZZLE_OFFSET : nvapi.h
  • _NV_TARGET_VIEW_MODE : nvapi.h
  • _NV_TARGET_VIEW_MODE_ : nvapi.h
  • _NV_TIMING_OVERRIDE : nvapi.h
  • _NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • _NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • _NVAPI_GPU_PERF_DECREASE : nvapi.h
  • _NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • _NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • _NVAPI_GSYNC_POLARITY : nvapi.h
  • _NVAPI_GSYNC_RJ45_IO : nvapi.h
  • _NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • _NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • _NVAPI_H : nvapi.h
  • _NvAPI_Status : nvapi_lite_common.h
  • _NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • _NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • _NVDRS_SETTING_LOCATION : nvapi.h
  • _NVDRS_SETTING_TYPE : nvapi.h
  • _NVVIOANCPARITYCOMPUTATION : nvapi.h
  • _NVVIOBITSPERCOMPONENT : nvapi.h
  • _NVVIOCAPTURESTATUS : nvapi.h
  • _NVVIOCOLORSPACE : nvapi.h
  • _NVVIOCOMPONENTSAMPLING : nvapi.h
  • _NVVIOCOMPSYNCTYPE : nvapi.h
  • _NVVIOCONFIGTYPE : nvapi.h
  • _NVVIODATAFORMAT : nvapi.h
  • _NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • _NVVIOINTERLACEMODE : nvapi.h
  • _NVVIOLINKID : nvapi.h
  • _NVVIOOUTPUTAREA : nvapi.h
  • _NVVIOOWNERTYPE : nvapi.h
  • _NVVIOPCILINKRATE : nvapi.h
  • _NVVIOPCILINKWIDTH : nvapi.h
  • _NVVIOSIGNALFORMAT : nvapi.h
  • _NVVIOSTATUSTYPE : nvapi.h
  • _NVVIOSYNCSOURCE : nvapi.h
  • _NVVIOSYNCSTATUS : nvapi.h
  • _NVVIOVIDEOSTANDARD : nvapi.h
  • _NVVIOVIDEOTYPE : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_CPLAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_SLIAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MASK : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_ID : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_ON : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_STRING : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ID : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MASK : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MAX : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_OFF : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_ALWAYS : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_IF_FOS : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_STRING : NvApiDriverSettings.h
  • AA_MODE_METHOD_6X_CT : NvApiDriverSettings.h
  • AA_MODE_METHOD_CORRUPTION_CHECK : NvApiDriverSettings.h
  • AA_MODE_METHOD_COUNT : NvApiDriverSettings.h
  • AA_MODE_METHOD_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x03 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x04 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x08 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x09 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x11 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x14 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x15 : NvApiDriverSettings.h
  • AA_MODE_METHOD_ID : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MASK : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MAX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_128X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_32X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_64X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_NONE : NvApiDriverSettings.h
  • AA_MODE_METHOD_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_METHOD_STRING : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_H : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_V : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_32X_8v24 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_8X_4v4 : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DISALLOW_TRAA : NvApiDriverSettings.h
  • AA_MODE_REPLAY_ID : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALPHA_TEST : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_DYN_BRANCH : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OPTIMAL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_PIXEL_KILL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_EIGHT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_FOUR : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_ONE : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_TWO : NvApiDriverSettings.h
  • AA_MODE_REPLAY_STRING : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_APP_CONTROL : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_OVERRIDE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DISABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ENABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_STRING : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • ALL_GPUS : nvapi.h
  • ANISO_MODE_LEVEL_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_ID : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MASK : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MAX : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_LINEAR : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_POINT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_STRING : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_APP : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_COND : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_USER : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DISABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ENABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ID : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_STRING : NvApiDriverSettings.h
  • AO_MODE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_HIGH : NvApiDriverSettings.h
  • AO_MODE_ID : NvApiDriverSettings.h
  • AO_MODE_LOW : NvApiDriverSettings.h
  • AO_MODE_MEDIUM : NvApiDriverSettings.h
  • AO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_OFF : NvApiDriverSettings.h
  • AO_MODE_STRING : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_ID : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_STRING : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ID : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_OFF : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ON : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • CPL_HIDDEN_PROFILE_DEFAULT : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_DISABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ENABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ID : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_NUM_VALUES : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_STRING : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_DEFAULT : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_ID : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NONE : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NUM_VALUES : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • D3DOGL_GPU_MAX_POWER_DEFAULT : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_DEFAULTPOWER : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_ID : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_NUM_VALUES : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_STRING : NvApiDriverSettings.h
  • DECLARE_INTERFACE() : nvapi.h
  • DISABLE_IMPLICIT_SLI : nvapi.h
  • DISPLAYPORT_STRUCTS_DEFINED : nvapi.h
  • displayView : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • ENABLE_IMPLICIT_SLI : nvapi.h
  • ESetting : NvApiDriverSettings.h
  • EValues_AA_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_AA_MODE_ALPHATOCOVERAGE : NvApiDriverSettings.h
  • EValues_AA_MODE_GAMMACORRECTION : NvApiDriverSettings.h
  • EValues_AA_MODE_METHOD : NvApiDriverSettings.h
  • EValues_AA_MODE_REPLAY : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR_SLIAA : NvApiDriverSettings.h
  • EValues_ANISO_MODE_LEVEL : NvApiDriverSettings.h
  • EValues_ANISO_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_AO_MODE : NvApiDriverSettings.h
  • EValues_AO_MODE_ACTIVE : NvApiDriverSettings.h
  • EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT : NvApiDriverSettings.h
  • EValues_AUTO_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_CPL_HIDDEN_PROFILE : NvApiDriverSettings.h
  • EValues_EXPORT_PERF_COUNTERS : NvApiDriverSettings.h
  • EValues_FXAA_ALLOW : NvApiDriverSettings.h
  • EValues_FXAA_ENABLE : NvApiDriverSettings.h
  • EValues_FXAA_INDICATOR_ENABLE : NvApiDriverSettings.h
  • EValues_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_MAXWELL_B_SAMPLE_INTERLEAVE : NvApiDriverSettings.h
  • EValues_MCSFRSHOWSPLIT : NvApiDriverSettings.h
  • EValues_NLS_ALLOW : NvApiDriverSettings.h
  • EValues_NLS_ENABLE : NvApiDriverSettings.h
  • EValues_NV_QUALITY_UPSCALING : NvApiDriverSettings.h
  • EValues_OGL_AA_LINE_GAMMA : NvApiDriverSettings.h
  • EValues_OGL_DEEP_COLOR_SCANOUT : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN : NvApiDriverSettings.h
  • EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD : NvApiDriverSettings.h
  • EValues_OGL_FORCE_BLIT : NvApiDriverSettings.h
  • EValues_OGL_FORCE_STEREO : NvApiDriverSettings.h
  • EValues_OGL_MULTIMON : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_PIXEL_TYPE : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_SUPPORT : NvApiDriverSettings.h
  • EValues_OGL_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_OGL_SINGLE_BACKDEPTH_BUFFER : NvApiDriverSettings.h
  • EValues_OGL_SLI_MULTICAST : NvApiDriverSettings.h
  • EValues_OGL_THREAD_CONTROL : NvApiDriverSettings.h
  • EValues_OGL_TRIPLE_BUFFER : NvApiDriverSettings.h
  • EValues_OGL_VIDEO_EDITING_MODE : NvApiDriverSettings.h
  • EValues_OPTIMUS_MAXAA : NvApiDriverSettings.h
  • EValues_PHYSXINDICATOR : NvApiDriverSettings.h
  • EValues_PREFERRED_PSTATE : NvApiDriverSettings.h
  • EValues_PRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_PREVENT_UI_AF_OVERRIDE : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_LIMITER : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_LIMITER_2_CONTROL : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_LIMITER_GPS_CTRL : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_MONITOR_CTRL : NvApiDriverSettings.h
  • EValues_PS_SHADERDISKCACHE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_ANISO_OPTS2 : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_BILINEAR_IN_ANISO : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_NO_NEG_LODBIAS : NvApiDriverSettings.h
  • EValues_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_REFRESH_RATE_OVERRIDE : NvApiDriverSettings.h
  • EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE : NvApiDriverSettings.h
  • EValues_SET_VAB_DATA : NvApiDriverSettings.h
  • EValues_SHIM_MCCOMPAT : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_OPTIONS : NvApiDriverSettings.h
  • EValues_SLI_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT_DX10 : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE_DX10 : NvApiDriverSettings.h
  • EValues_SLI_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_VRPRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE_REQUEST_STATE : NvApiDriverSettings.h
  • EValues_VRR_MODE : NvApiDriverSettings.h
  • EValues_VRRFEATUREINDICATOR : NvApiDriverSettings.h
  • EValues_VRROVERLAYINDICATOR : NvApiDriverSettings.h
  • EValues_VRRREQUESTSTATE : NvApiDriverSettings.h
  • EValues_VSYNC_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_VSYNCMODE : NvApiDriverSettings.h
  • EValues_VSYNCSMOOTHAFR : NvApiDriverSettings.h
  • EValues_VSYNCTEARCONTROL : NvApiDriverSettings.h
  • EValues_VSYNCVRRCONTROL : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_EYES_EXCHANGE : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_MODE : NvApiDriverSettings.h
  • EValues_WKS_MEMORY_ALLOCATION_POLICY : NvApiDriverSettings.h
  • EValues_WKS_STEREO_DONGLE_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SWAP_MODE : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DEFAULT : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ID : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_NUM_VALUES : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_OFF : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ON : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • FENCE_SYNCHRONIZATION_END : nvapi.h
  • FENCE_SYNCHRONIZATION_START : nvapi.h
  • FXAA_ALLOW_ALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_DEFAULT : NvApiDriverSettings.h
  • FXAA_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_ID : NvApiDriverSettings.h
  • FXAA_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ALLOW_STRING : NvApiDriverSettings.h
  • FXAA_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_ENABLE_ON : NvApiDriverSettings.h
  • FXAA_ENABLE_STRING : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ON : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • g_NvidiaExt : nvHLSLExtnsInternal.h
  • GET_NVAPI_SIZE : nvapi_lite_common.h
  • GET_NVAPI_VERSION : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • ICAFE_LOGO_CONFIG_ID : NvApiDriverSettings.h
  • ICAFE_LOGO_CONFIG_STRING : NvApiDriverSettings.h
  • ID3D11MultiGPUDevice : nvapi.h
  • ID3D11MultiGPUDevice_VER : nvapi.h
  • ID3D11MultiGPUDevice_VER1 : nvapi.h
  • ID3D11MultiGPUDevice_VER2 : nvapi.h
  • IMPLICIT_SLI_CONTROL : nvapi.h
  • inputFlags : nvapi.h
  • INVALID_SETTING_ID : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • LODBIASADJUST_ID : NvApiDriverSettings.h
  • LODBIASADJUST_MAX : NvApiDriverSettings.h
  • LODBIASADJUST_MIN : NvApiDriverSettings.h
  • LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h
  • LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • MAKE_NVAPI_VERSION : nvapi_lite_common.h
  • MAX_NUM_COMPOSITE_RANGE : nvapi.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ID : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_OFF : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ON : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_STRING : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DEFAULT : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DISABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ENABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ID : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_NUM_VALUES : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • NLS_ALLOW_ALLOWED : NvApiDriverSettings.h
  • NLS_ALLOW_DEFAULT : NvApiDriverSettings.h
  • NLS_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • NLS_ALLOW_ID : NvApiDriverSettings.h
  • NLS_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • NLS_ALLOW_STRING : NvApiDriverSettings.h
  • NLS_ENABLE_DEFAULT : NvApiDriverSettings.h
  • NLS_ENABLE_ID : NvApiDriverSettings.h
  • NLS_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • NLS_ENABLE_OFF : NvApiDriverSettings.h
  • NLS_ENABLE_ON : NvApiDriverSettings.h
  • NLS_ENABLE_STRING : NvApiDriverSettings.h
  • NV_BIT : nvapi_lite_common.h
  • NV_BOARD_INFO : nvapi.h
  • NV_BOARD_INFO_V1 : nvapi.h
  • NV_BOARD_INFO_VER : nvapi.h
  • NV_BOARD_INFO_VER1 : nvapi.h
  • NV_BPC : nvapi.h
  • NV_BPC_10 : nvapi.h
  • NV_BPC_12 : nvapi.h
  • NV_BPC_16 : nvapi.h
  • NV_BPC_6 : nvapi.h
  • NV_BPC_8 : nvapi.h
  • NV_BPC_DEFAULT : nvapi.h
  • NV_CHIPSET_INFO : nvapi.h
  • NV_CHIPSET_INFO_FLAGS : nvapi.h
  • NV_CHIPSET_INFO_HYBRID : nvapi.h
  • NV_CHIPSET_INFO_VER : nvapi.h
  • NV_CHIPSET_INFO_VER_1 : nvapi.h
  • NV_CHIPSET_INFO_VER_2 : nvapi.h
  • NV_CHIPSET_INFO_VER_3 : nvapi.h
  • NV_CHIPSET_INFO_VER_4 : nvapi.h
  • NV_COLOR_CMD : nvapi.h
  • NV_COLOR_CMD_GET : nvapi.h
  • NV_COLOR_CMD_GET_DEFAULT : nvapi.h
  • NV_COLOR_CMD_IS_SUPPORTED_COLOR : nvapi.h
  • NV_COLOR_CMD_SET : nvapi.h
  • NV_COLOR_COLORIMETRY : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBERGB : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_AUTO : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020cYCC : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020YCC : nvapi.h
  • NV_COLOR_COLORIMETRY_DEFAULT : nvapi.h
  • NV_COLOR_COLORIMETRY_RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_SYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC709 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC709 : nvapi.h
  • NV_COLOR_DATA : nvapi.h
  • NV_COLOR_DATA_V1 : nvapi.h
  • NV_COLOR_DATA_V2 : nvapi.h
  • NV_COLOR_DATA_V3 : nvapi.h
  • NV_COLOR_DATA_VER : nvapi.h
  • NV_COLOR_DATA_VER1 : nvapi.h
  • NV_COLOR_DATA_VER2 : nvapi.h
  • NV_COLOR_DATA_VER3 : nvapi.h
  • NV_COLOR_FORMAT : nvapi.h
  • NV_COLOR_FORMAT_AUTO : nvapi.h
  • NV_COLOR_FORMAT_DEFAULT : nvapi.h
  • NV_COLOR_FORMAT_RGB : nvapi.h
  • NV_COLOR_FORMAT_YUV420 : nvapi.h
  • NV_COLOR_FORMAT_YUV422 : nvapi.h
  • NV_COLOR_FORMAT_YUV444 : nvapi.h
  • NV_CUSTOM_DISPLAY_VER : nvapi.h
  • NV_DECLARE_HANDLE : nvapi_lite_common.h , nvapi.h , nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_VERSION_VER : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER2 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER3 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER4 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_1 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_2 : nvapi.h
  • NV_DISPLAY_PORT_INFO : nvapi.h
  • NV_DISPLAY_PORT_INFO_V1 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER2 : nvapi.h
  • NV_DISPLAY_TV_FORMAT : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ANY : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_480p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_576p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_NONE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_480i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_576i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCJ : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALBDGH : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALN : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALNC : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 : nvapi.h
  • NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED : nvapi.h
  • NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_HORIZONTAL : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_NONE : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_VERTICAL : nvapi.h
  • NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • NV_DISPLAYCONFIG_VALIDATE_ONLY : nvapi.h
  • NV_DP_1_62GBPS : nvapi.h
  • NV_DP_1_LANE : nvapi.h
  • NV_DP_2_70GBPS : nvapi.h
  • NV_DP_2_LANE : nvapi.h
  • NV_DP_4_LANE : nvapi.h
  • NV_DP_5_40GBPS : nvapi.h
  • NV_DP_8_10GBPS : nvapi.h
  • NV_DP_BPC : nvapi.h
  • NV_DP_BPC_10 : nvapi.h
  • NV_DP_BPC_12 : nvapi.h
  • NV_DP_BPC_16 : nvapi.h
  • NV_DP_BPC_6 : nvapi.h
  • NV_DP_BPC_8 : nvapi.h
  • NV_DP_BPC_DEFAULT : nvapi.h
  • NV_DP_COLOR_FORMAT : nvapi.h
  • NV_DP_COLOR_FORMAT_RGB : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr422 : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr444 : nvapi.h
  • NV_DP_COLORIMETRY : nvapi.h
  • NV_DP_COLORIMETRY_RGB : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU601 : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU709 : nvapi.h
  • NV_DP_DYNAMIC_RANGE : nvapi.h
  • NV_DP_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DP_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_DP_LANE_COUNT : nvapi.h
  • NV_DP_LINK_RATE : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO_VER : nvapi.h
  • NV_DYNAMIC_RANGE : nvapi.h
  • NV_DYNAMIC_RANGE_AUTO : nvapi.h
  • NV_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_ECC_CONFIGURATION : nvapi.h
  • NV_ECC_CONFIGURATION_DEFERRED : nvapi.h
  • NV_ECC_CONFIGURATION_IMMEDIATE : nvapi.h
  • NV_ECC_CONFIGURATION_NOT_SUPPORTED : nvapi.h
  • NV_EDID : nvapi.h
  • NV_EDID_DATA_SIZE : nvapi.h
  • NV_EDID_V1_DATA_SIZE : nvapi.h
  • NV_EDID_VER : nvapi.h
  • NV_EDID_VER1 : nvapi.h
  • NV_EDID_VER2 : nvapi.h
  • NV_EDID_VER3 : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_EXTN_ATOM_ADD : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MAX : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MIN : nvHLSLExtnsInternal.h
  • NV_EXTN_OP_FP16_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_FP32_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_LANE_ID : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_DOWN : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_UP : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_XOR : nvShaderExtnEnums.h
  • NV_EXTN_OP_TYPED_UAV_LOAD : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ALL : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ANY : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_BALLOT : nvShaderExtnEnums.h
  • NV_FALSE : nvapi_lite_common.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER : nvapi.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_FASTGS_FLAGS : nvapi.h
  • NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX : nvapi.h
  • NV_FASTGS_STRICT_API_ORDER : nvapi.h
  • NV_FASTGS_USE_VIEWPORT_MASK : nvapi.h
  • NV_FORMAT : nvapi.h
  • NV_FORMAT_A16B16G16R16F : nvapi.h
  • NV_FORMAT_A8R8G8B8 : nvapi.h
  • NV_FORMAT_P8 : nvapi.h
  • NV_FORMAT_R5G6B5 : nvapi.h
  • NV_FORMAT_UNKNOWN : nvapi.h
  • NV_FRUSTUM_ADJUST_MODE : nvapi.h
  • NV_GET_CURRENT_SLI_STATE_VER : nvapi_lite_sli.h
  • NV_GPU_BUS_TYPE : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_1 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_2 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_3 : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_FAKE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_SLI : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_UNCACHED : nvapi.h
  • NV_GPU_CONNECTOR_TYPE : nvapi.h
  • NV_GPU_DISPLAYIDS : nvapi.h
  • NV_GPU_DISPLAYIDS_VER : nvapi.h
  • NV_GPU_DISPLAYIDS_VER1 : nvapi.h
  • NV_GPU_DISPLAYIDS_VER2 : nvapi.h
  • NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER : nvapi.h
  • NV_GPU_ECC_CONFIGURATION_INFO_VER : nvapi.h
  • NV_GPU_ECC_ERROR_INFO_VER : nvapi.h
  • NV_GPU_ECC_STATUS_INFO_VER : nvapi.h
  • NV_GPU_GET_HDCP_SUPPORT_STATUS_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_DISABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_ENABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_FUSES : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_I2C_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_NONE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_SBIOS : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_UNKNOWN : nvapi.h
  • NV_GPU_IA_LOGO_BRIGHTNESS : nvapi.h
  • NV_GPU_IA_SLI_BRIGHTNESS : nvapi.h
  • NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • NV_GPU_OUTPUT_TYPE : nvapi.h
  • NV_GPU_PERF_DECREASE_NONE : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_AC_BATT : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_UNKNOWN : nvapi.h
  • NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID : nvapi.h
  • NV_GPU_PERF_PSTATE_ID : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_V2 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER3 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER3 : nvapi.h
  • NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_2 : nvapi.h
  • NV_GPU_TYPE : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ : nvapi.h
  • NV_GSYNC_CAPABILITIES : nvapi.h
  • NV_GSYNC_CAPABILITIES_V1 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER1 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER : nvapi.h
  • NV_GSYNC_DELAY : nvapi.h
  • NV_GSYNC_DELAY_VER : nvapi.h
  • NV_GSYNC_DISPLAY : nvapi.h
  • NV_GSYNC_DISPLAY_VER : nvapi.h
  • NV_GSYNC_GPU : nvapi.h
  • NV_GSYNC_GPU_VER : nvapi.h
  • NV_GSYNC_STATUS : nvapi.h
  • NV_GSYNC_STATUS_PARAMS : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER : nvapi.h
  • NV_GSYNC_STATUS_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V2 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER2 : nvapi.h
  • NV_I2C_INFO : nvapi.h
  • NV_I2C_INFO_VER : nvapi.h
  • NV_I2C_INFO_VER1 : nvapi.h
  • NV_I2C_INFO_VER2 : nvapi.h
  • NV_I2C_INFO_VER3 : nvapi.h
  • NV_I2C_SPEED : nvapi.h
  • NV_INFOFRAME_CMD : nvapi.h
  • NV_INFOFRAME_CMD_GET : nvapi.h
  • NV_INFOFRAME_CMD_GET_DEFAULT : nvapi.h
  • NV_INFOFRAME_CMD_GET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_GET_PROPERTY : nvapi.h
  • NV_INFOFRAME_CMD_RESET : nvapi.h
  • NV_INFOFRAME_CMD_SET : nvapi.h
  • NV_INFOFRAME_CMD_SET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_SET_PROPERTY : nvapi.h
  • NV_INFOFRAME_DATA_VER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03 : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_AUTO : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_DISABLE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ENABLE : nvapi.h
  • NV_LID_DOCK_PARAMS_VER : nvapi.h
  • NV_MAX_HEADS : nvapi_lite_common.h
  • NV_MAX_VID_PROFILES : nvapi_lite_common.h
  • NV_MAX_VID_STREAMS : nvapi_lite_common.h
  • NV_MONITOR_CAPABILITIES : nvapi.h
  • NV_MONITOR_CAPABILITIES_V1 : nvapi.h
  • NV_MONITOR_CAPABILITIES_VER : nvapi.h
  • NV_MONITOR_CAPABILITIES_VER1 : nvapi.h
  • NV_MONITOR_CAPS_TYPE : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VCDB : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VSDB : nvapi.h
  • NV_MONITOR_CAPS_VCDB : nvapi.h
  • NV_MONITOR_CAPS_VSDB : nvapi.h
  • NV_MONITOR_COLOR_CAPS : nvapi.h
  • NV_MONITOR_COLOR_CAPS_V1 : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER1 : nvapi.h
  • NV_MONITOR_CONN_TYPE : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPONENT : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPOSITE : nvapi.h
  • NV_MONITOR_CONN_TYPE_DP : nvapi.h
  • NV_MONITOR_CONN_TYPE_DVI : nvapi.h
  • NV_MONITOR_CONN_TYPE_HDMI : nvapi.h
  • NV_MONITOR_CONN_TYPE_LVDS : nvapi.h
  • NV_MONITOR_CONN_TYPE_SVIDEO : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNINITIALIZED : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNKNOWN : nvapi.h
  • NV_MONITOR_CONN_TYPE_VGA : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V2 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTINGS_MAX : nvapi.h
  • NV_MOSAIC_DISPLAY_TOPO_STATUS_VER : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED : nvapi.h
  • NV_MOSAIC_GRID_TOPO : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER2 : nvapi.h
  • NV_MOSAIC_MAX_DISPLAYS : nvapi_lite_surround.h
  • NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 : nvapi.h
  • NV_MOSAIC_TOPO : nvapi.h
  • NV_MOSAIC_TOPO_1x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x5_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x6_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_3x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_4x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_7x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_END_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_END_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_IDX_DEFAULT : nvapi.h
  • NV_MOSAIC_TOPO_IDX_LEFT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_IDX_RIGHT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_MAX : nvapi.h
  • NV_MOSAIC_TOPO_NONE : nvapi.h
  • NV_MOSAIC_TOPO_NUM_EYES : nvapi.h
  • NV_MOSAIC_TOPO_TYPE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_ALL : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_MAX : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_SCALED_CLONE : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_VALID : nvapi.h
  • NV_PIXEL_SHIFT_TYPE : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT : nvapi.h
  • NV_POSITION : nvapi.h
  • NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION : nvapi.h
  • NV_PSO_EXPLICIT_FASTGS_EXTENSION : nvapi.h
  • NV_PSO_EXTENSION : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_PSO_RASTER_EXTENSION : nvapi.h
  • NV_PSO_REQUEST_FASTGS_EXTENSION : nvapi.h
  • NV_QUALITY_UPSCALING_DEFAULT : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ID : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_NUM_VALUES : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_OFF : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ON : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_STRING : NvApiDriverSettings.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_RECT : nvapi_lite_common.h
  • NV_RESOLUTION : nvapi.h
  • NV_ROTATE : nvapi.h
  • NV_ROTATE_0 : nvapi.h
  • NV_ROTATE_180 : nvapi.h
  • NV_ROTATE_270 : nvapi.h
  • NV_ROTATE_90 : nvapi.h
  • NV_ROTATE_IGNORED : nvapi.h
  • NV_SCALING : nvapi.h
  • NV_SCALING_ADAPTER_SCALING : nvapi.h
  • NV_SCALING_ASPECT_SCALING : nvapi.h
  • NV_SCALING_CENTERED : nvapi.h
  • NV_SCALING_CUSTOMIZED : nvapi.h
  • NV_SCALING_DEFAULT : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_MONITOR_SCALING : nvapi.h
  • NV_SCANOUT_INFORMATION : nvapi.h
  • NV_SCANOUT_INFORMATION_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER1 : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER2 : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_DATA : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_STATE_DATA : nvapi.h
  • NV_SCANOUT_WARPING_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_VER : nvapi.h
  • NV_SHADER_EXTN_VERSION : nvShaderExtnEnums.h
  • NV_STEREO_ACTIVE_EYE : nvapi_lite_stereo.h
  • NV_STEREO_DRIVER_MODE : nvapi_lite_stereo.h
  • NV_STEREO_REGISTRY_ID : nvapi.h
  • NV_STEREO_REGISTRY_PROFILE_TYPE : nvapi.h
  • NV_STEREO_SWAPCHAIN_MODE : nvapi.h
  • NV_STEREO_VIDEO_FORMAT : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_DEFINE : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_LAST : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_NOT_STEREO : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR : nvapi.h
  • NV_SWIZZLE_MODE : nvapi.h
  • NV_SWIZZLE_NEG_W : nvapi.h
  • NV_SWIZZLE_NEG_X : nvapi.h
  • NV_SWIZZLE_NEG_Y : nvapi.h
  • NV_SWIZZLE_NEG_Z : nvapi.h
  • NV_SWIZZLE_OFFSET : nvapi.h
  • NV_SWIZZLE_OFFSET_W : nvapi.h
  • NV_SWIZZLE_OFFSET_X : nvapi.h
  • NV_SWIZZLE_OFFSET_Y : nvapi.h
  • NV_SWIZZLE_OFFSET_Z : nvapi.h
  • NV_SWIZZLE_POS_W : nvapi.h
  • NV_SWIZZLE_POS_X : nvapi.h
  • NV_SWIZZLE_POS_Y : nvapi.h
  • NV_SWIZZLE_POS_Z : nvapi.h
  • NV_SYSTEM_TYPE : nvapi.h
  • NV_SYSTEM_TYPE_DESKTOP : nvapi.h
  • NV_SYSTEM_TYPE_DGPU : nvapi.h
  • NV_SYSTEM_TYPE_GPU_UNKNOWN : nvapi.h
  • NV_SYSTEM_TYPE_IGPU : nvapi.h
  • NV_SYSTEM_TYPE_LAPTOP : nvapi.h
  • NV_SYSTEM_TYPE_UNKNOWN : nvapi.h
  • NV_TARGET_VIEW_MODE : nvapi.h
  • NV_THERMAL_CONTROLLER : nvapi.h
  • NV_THERMAL_TARGET : nvapi.h
  • NV_TIMING : nvapi.h
  • NV_TIMING_H_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_H_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_H_SYNC_POSITIVE : nvapi.h
  • NV_TIMING_INPUT : nvapi.h
  • NV_TIMING_INPUT_VER : nvapi.h
  • NV_TIMING_INTERLACED : nvapi.h
  • NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_OVERRIDE : nvapi.h
  • NV_TIMING_OVERRIDE_ANALOG_TV : nvapi.h
  • NV_TIMING_OVERRIDE_AUTO : nvapi.h
  • NV_TIMING_OVERRIDE_CURRENT : nvapi.h
  • NV_TIMING_OVERRIDE_CUST : nvapi.h
  • NV_TIMING_OVERRIDE_CVT : nvapi.h
  • NV_TIMING_OVERRIDE_CVT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_DMT : nvapi.h
  • NV_TIMING_OVERRIDE_DMT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_EDID : nvapi.h
  • NV_TIMING_OVERRIDE_EIA861 : nvapi.h
  • NV_TIMING_OVERRIDE_GTF : nvapi.h
  • NV_TIMING_OVERRIDE_NV_ASPR : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PREDEFINED : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PSF : nvapi.h
  • NV_TIMING_OVERRIDE_SDI : nvapi.h
  • NV_TIMING_OVRRIDE_MAX : nvapi.h
  • NV_TIMING_PROGRESSIVE : nvapi.h
  • NV_TIMING_STRUCTS_DEFINED : nvapi.h
  • NV_TIMING_V_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_V_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_V_SYNC_POSITIVE : nvapi.h
  • NV_TIMINGEXT : nvapi.h
  • NV_TRUE : nvapi_lite_common.h
  • NV_VIEW_MODE_CLONE : nvapi.h
  • NV_VIEW_MODE_DUALVIEW : nvapi.h
  • NV_VIEW_MODE_HSPAN : nvapi.h
  • NV_VIEW_MODE_MULTIVIEW : nvapi.h
  • NV_VIEW_MODE_STANDARD : nvapi.h
  • NV_VIEW_MODE_VSPAN : nvapi.h
  • NV_VIEW_TARGET_INFO_VER : nvapi.h
  • NV_VIO_TOPOLOGY : nvapi.h
  • NV_VIO_TOPOLOGY_VER : nvapi.h
  • NV_WARP_SIZE : nvShaderExtnEnums.h
  • NvAll() : nvHLSLExtns.h
  • NvAny() : nvHLSLExtns.h
  • NVAPI_ACCESS_DENIED : nvapi_lite_common.h
  • NVAPI_ADVANCED_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED : nvapi_lite_common.h
  • NVAPI_ADVANCED_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_ADVANCED_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_MASK : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_NONE : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER : nvapi.h
  • NVAPI_ALL_GPUS : nvapi.h
  • NVAPI_API_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_API_NOT_INTIALIZED : nvapi.h
  • NVAPI_ARGUMENT_EXCEED_MAX_SIZE : nvapi_lite_common.h
  • NVAPI_BINARY_DATA_MAX : nvapi.h
  • NVAPI_CLUSTER_ALREADY_EXISTS : nvapi_lite_common.h
  • NVAPI_CONVERGENCE_ID : nvapi.h
  • NVAPI_COPY_ASYNCHRONOUSLY : nvapi.h
  • NVAPI_CPU_RESOURCE : nvapi.h
  • NvAPI_CreateDisplayFromUnAttachedDisplay() : nvapi.h
  • NVAPI_D3D10_1_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlap() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlapEx() : nvapi.h
  • NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NvAPI_D3D11_CreateDevice() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateDeviceAndSwapChain() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateFastGeometryShader() : nvapi.h
  • NvAPI_D3D11_CreateFastGeometryShaderExplicit() : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 : nvapi.h
  • NvAPI_D3D11_CreateMultiGPUDevice() : nvapi.h
  • NvAPI_D3D11_CreateRasterizerState() : nvapi.h
  • NvAPI_D3D11_EndUAVOverlap() : nvapi.h
  • NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • NvAPI_D3D11_IsNvShaderExtnOpCodeSupported() : nvapi.h
  • NVAPI_D3D11_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NvAPI_D3D11_MultiDrawIndexedInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiDrawInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiGPU_GetCaps() : nvapi.h
  • NvAPI_D3D11_MultiGPU_Init() : nvapi.h
  • NvAPI_D3D11_RASTERIZER_DESC_EX : nvapi.h
  • NvAPI_D3D11_SetDepthBoundsTest() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_SetNvShaderExtnSlot() : nvapi.h
  • NvAPI_D3D11_SWIZZLE_MODE : nvapi.h
  • NvAPI_D3D12_CreateGraphicsPipelineState() : nvapi.h
  • NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC : nvapi.h
  • NVAPI_D3D12_PSO_EXTENSION_DESC : nvapi.h
  • NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC : nvapi.h
  • NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC : nvapi.h
  • NvAPI_D3D12_SetDepthBoundsTestValues() : nvapi.h
  • NvAPI_D3D1x_CreateSwapChain() : nvapi.h
  • NvAPI_D3D1x_DisableShaderDiskCache() : nvapi.h
  • NvAPI_D3D1x_GetLowLatencySupport() : nvapi.h
  • NvAPI_D3D1x_HintCreateLowLatencyDevice() : nvapi.h
  • NvAPI_D3D9_AliasSurfaceAsTexture() : nvapi.h
  • NvAPI_D3D9_ClearRT() : nvapi.h
  • NvAPI_D3D9_CreateSwapChain() : nvapi.h
  • NvAPI_D3D9_GetSurfaceHandle() : nvapi.h
  • NvAPI_D3D9_RegisterResource() : nvapi.h
  • NvAPI_D3D9_StretchRectEx() : nvapi.h
  • NvAPI_D3D9_UnregisterResource() : nvapi.h
  • NvAPI_D3D9_VideoSetStereoInfo() : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI : nvapi.h
  • NvAPI_D3D_BeginResourceRendering() : nvapi_lite_sli.h
  • NVAPI_D3D_DEVICE_LOST : nvapi_lite_common.h
  • NVAPI_D3D_DEVICE_NOT_REGISTERED : nvapi_lite_common.h
  • NvAPI_D3D_EndResourceRendering() : nvapi_lite_sli.h
  • NvAPI_D3D_GetCurrentSLIState() : nvapi_lite_sli.h
  • NvAPI_D3D_GetObjectHandleForResource() : nvapi_lite_common.h
  • NvAPI_D3D_ImplicitSLIControl() : nvapi.h
  • NvAPI_D3D_IsGSyncActive() : nvapi.h
  • NvAPI_D3D_IsGSyncCapable() : nvapi.h
  • NvAPI_D3D_RegisterDevice() : nvapi.h
  • NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_DEFAULTS : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_MULTI_FRAME : nvapi_lite_sli.h
  • NvAPI_D3D_SetFPSIndicatorState() : nvapi.h
  • NvAPI_D3D_SetResourceHint() : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_CATEGORY_SLI : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE : nvapi_lite_sli.h
  • NVAPI_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_DATATYPE_MISMATCH : nvapi_lite_common.h
  • NVAPI_DEFAULT_HANDLE : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED : nvapi_lite_common.h
  • NVAPI_DEVICE_BUSY : nvapi_lite_common.h
  • NVAPI_DEVICE_FEATURE_LEVEL : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_1 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_11_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_NULL : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_SWITCHING_NOT_ALLOWED : nvapi_lite_common.h
  • NvAPI_DisableHWCursor() : nvapi.h
  • NvAPI_Disp_ColorControl() : nvapi.h
  • NvAPI_DISP_DeleteCustomDisplay() : nvapi.h
  • NvAPI_DISP_EnumCustomDisplay() : nvapi.h
  • NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_DISP_GetDisplayConfig() : nvapi.h
  • NvAPI_DISP_GetDisplayIdByDisplayName() : nvapi.h
  • NvAPI_DISP_GetGDIPrimaryDisplayId() : nvapi_lite_surround.h
  • NvAPI_DISP_GetMonitorCapabilities() : nvapi.h
  • NvAPI_DISP_GetMonitorColorCapabilities() : nvapi.h
  • NvAPI_DISP_GetTiming() : nvapi.h
  • NvAPI_Disp_InfoFrameControl() : nvapi.h
  • NvAPI_DISP_RevertCustomDisplayTrial() : nvapi.h
  • NvAPI_DISP_SaveCustomDisplay() : nvapi.h
  • NvAPI_DISP_SetDisplayConfig() : nvapi.h
  • NvAPI_DISP_TryCustomDisplay() : nvapi.h
  • NVAPI_DISPLAY_DEVICE_MASK_MAX : nvapi.h
  • NVAPI_DISPLAYCONFIG_VALIDATION_FAILED : nvapi_lite_common.h
  • NVAPI_DPMST_CHANGED : nvapi_lite_common.h
  • NVAPI_DPMST_DISPLAY_ID_EXPECTED : nvapi_lite_common.h
  • NVAPI_DRIVER_NOTRUNNING : nvapi_lite_common.h
  • NVAPI_DRIVER_RUNNING : nvapi_lite_common.h
  • NvAPI_DRS_CreateApplication() : nvapi.h
  • NvAPI_DRS_CreateProfile() : nvapi.h
  • NvAPI_DRS_CreateSession() : nvapi.h
  • NvAPI_DRS_DeleteApplication() : nvapi.h
  • NvAPI_DRS_DeleteApplicationEx() : nvapi.h
  • NvAPI_DRS_DeleteProfile() : nvapi.h
  • NvAPI_DRS_DeleteProfileSetting() : nvapi.h
  • NvAPI_DRS_DestroySession() : nvapi.h
  • NvAPI_DRS_EnumApplications() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingIds() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingValues() : nvapi.h
  • NvAPI_DRS_EnumProfiles() : nvapi.h
  • NvAPI_DRS_EnumSettings() : nvapi.h
  • NvAPI_DRS_FindApplicationByName() : nvapi.h
  • NvAPI_DRS_FindProfileByName() : nvapi.h
  • NvAPI_DRS_GetApplicationInfo() : nvapi.h
  • NvAPI_DRS_GetBaseProfile() : nvapi.h
  • NvAPI_DRS_GetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_GetNumProfiles() : nvapi.h
  • NvAPI_DRS_GetProfileInfo() : nvapi.h
  • NvAPI_DRS_GetSetting() : nvapi.h
  • NvAPI_DRS_GetSettingIdFromName() : nvapi.h
  • NvAPI_DRS_GetSettingNameFromId() : nvapi.h
  • NVAPI_DRS_GLOBAL_PROFILE : nvapi.h
  • NvAPI_DRS_LoadSettings() : nvapi.h
  • NvAPI_DRS_LoadSettingsFromFile() : nvapi.h
  • NvAPI_DRS_RestoreAllDefaults() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefault() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefaultSetting() : nvapi.h
  • NvAPI_DRS_SaveSettings() : nvapi.h
  • NvAPI_DRS_SaveSettingsToFile() : nvapi.h
  • NvAPI_DRS_SetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_SetProfileInfo() : nvapi.h
  • NvAPI_DRS_SetSetting() : nvapi.h
  • NVAPI_ECID_KEY_VERIFICATION_FAILED : nvapi_lite_common.h
  • NVAPI_ECID_SIGN_ALGO_UNSUPPORTED : nvapi_lite_common.h
  • NvAPI_EnableCurrentMosaicTopology() : nvapi.h
  • NvAPI_EnableHWCursor() : nvapi.h
  • NVAPI_END_ENUMERATION : nvapi_lite_common.h
  • NvAPI_EnumLogicalGPUs() : nvapi.h
  • NvAPI_EnumNvidiaDisplayHandle() : nvapi.h
  • NvAPI_EnumNvidiaUnAttachedDisplayHandle() : nvapi.h
  • NvAPI_EnumPhysicalGPUs() : nvapi_lite_common.h
  • NvAPI_EnumTCCPhysicalGPUs() : nvapi.h
  • NVAPI_ERROR : nvapi_lite_common.h
  • NVAPI_ERROR_DRIVER_RELOAD_REQUIRED : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_ALREADY_IN_USE : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS : nvapi_lite_common.h
  • NVAPI_EXPECTED_ANALOG_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_COMPUTE_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_DIGITAL_FLAT_PANEL : nvapi_lite_common.h
  • NVAPI_EXPECTED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_LOGICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR : nvapi_lite_common.h
  • NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_FIRMWARE_OUT_OF_DATE : nvapi_lite_common.h
  • NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_FRUSTUM_ADJUST_MODE_ID : nvapi.h
  • NVAPI_FRUSTUM_CLEAR_EDGES : nvapi.h
  • NVAPI_FRUSTUM_STRETCH : nvapi.h
  • NVAPI_FUNCTION_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_GENERIC_STRING_MAX : nvapi_lite_common.h
  • NvAPI_GetAssociatedDisplayOutputId() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayName() : nvapi.h
  • NvAPI_GetCurrentMosaicTopology() : nvapi.h
  • NvAPI_GetDisplayPortInfo() : nvapi.h
  • NvAPI_GetErrorMessage() : nvapi.h
  • NvAPI_GetHDMISupportInfo() : nvapi.h
  • NvAPI_GetInterfaceVersionString() : nvapi.h
  • NvAPI_GetLogicalGPUFromDisplay() : nvapi.h
  • NvAPI_GetLogicalGPUFromPhysicalGPU() : nvapi.h
  • NvAPI_GetPhysicalGPUFromUnAttachedDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromLogicalGPU() : nvapi.h
  • NvAPI_GetSupportedMosaicTopologies() : nvapi.h
  • NvAPI_GetSupportedViews() : nvapi.h
  • NvAPI_GetUnAttachedAssociatedDisplayName() : nvapi.h
  • NvAPI_GetVBlankCounter() : nvapi.h
  • NVAPI_GPU_BUS_TYPE_AGP : nvapi.h
  • NVAPI_GPU_BUS_TYPE_AXI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_FPCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI_EXPRESS : nvapi.h
  • NVAPI_GPU_BUS_TYPE_UNDEFINED : nvapi.h
  • NVAPI_GPU_CONNECTOR_ADC : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_D : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_A : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_C_MINI : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_OEM : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_SPWG : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SCART : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_UNKNOWN : nvapi.h
  • NVAPI_GPU_CONNECTOR_VGA_15_PIN : nvapi.h
  • NVAPI_GPU_CONNECTOR_VIRTUAL_WFD : nvapi.h
  • NvAPI_GPU_GetActiveOutputs() : nvapi.h
  • NvAPI_GPU_GetAGPAperture() : nvapi.h
  • NvAPI_GPU_GetAllClockFrequencies() : nvapi.h
  • NvAPI_GPU_GetAllDisplayIds() : nvapi.h
  • NvAPI_GPU_GetBoardInfo() : nvapi.h
  • NvAPI_GPU_GetBusId() : nvapi.h
  • NvAPI_GPU_GetBusSlotId() : nvapi.h
  • NvAPI_GPU_GetBusType() : nvapi.h
  • NvAPI_GPU_GetConnectedDisplayIds() : nvapi.h
  • NvAPI_GPU_GetCurrentAGPRate() : nvapi.h
  • NvAPI_GPU_GetCurrentPCIEDownstreamWidth() : nvapi.h
  • NvAPI_GPU_GetCurrentPstate() : nvapi.h
  • NvAPI_GPU_GetDynamicPstatesInfoEx() : nvapi.h
  • NvAPI_GPU_GetECCConfigurationInfo() : nvapi.h
  • NvAPI_GPU_GetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_GetECCStatusInfo() : nvapi.h
  • NvAPI_GPU_GetEDID() : nvapi.h
  • NvAPI_GPU_GetFullName() : nvapi.h
  • NvAPI_GPU_GetGpuCoreCount() : nvapi.h
  • NvAPI_GPU_GetGPUType() : nvapi.h
  • NvAPI_GPU_GetHDCPSupportStatus() : nvapi.h
  • NvAPI_GPU_GetIllumination() : nvapi.h
  • NvAPI_GPU_GetIRQ() : nvapi.h
  • NvAPI_GPU_GetMemoryInfo() : nvapi_lite_common.h
  • NvAPI_GPU_GetOutputType() : nvapi.h
  • NvAPI_GPU_GetPCIIdentifiers() : nvapi.h
  • NvAPI_GPU_GetPerfDecreaseInfo() : nvapi.h
  • NvAPI_GPU_GetPhysicalFrameBufferSize() : nvapi.h
  • NvAPI_GPU_GetPstates20() : nvapi.h
  • NvAPI_GPU_GetQuadroStatus() : nvapi.h
  • NvAPI_GPU_GetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_GetScanoutConfiguration() : nvapi.h
  • NvAPI_GPU_GetScanoutConfigurationEx() : nvapi.h
  • NvAPI_GPU_GetScanoutIntensityState() : nvapi.h
  • NvAPI_GPU_GetScanoutWarpingState() : nvapi.h
  • NvAPI_GPU_GetSystemType() : nvapi.h
  • NvAPI_GPU_GetTachReading() : nvapi.h
  • NvAPI_GPU_GetThermalSettings() : nvapi.h
  • NvAPI_GPU_GetVbiosOEMRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosVersionString() : nvapi.h
  • NvAPI_GPU_GetVirtualFrameBufferSize() : nvapi.h
  • NVAPI_GPU_OUTPUT_CRT : nvapi.h
  • NVAPI_GPU_OUTPUT_DFP : nvapi.h
  • NVAPI_GPU_OUTPUT_TV : nvapi.h
  • NVAPI_GPU_OUTPUT_UNKNOWN : nvapi.h
  • NVAPI_GPU_PERF_DECREASE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_ALL : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P0 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P1 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P10 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P11 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P12 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P13 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P14 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P15 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P2 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P3 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P4 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P5 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P6 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P7 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P8 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P9 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_UNDEFINED : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_MEMORY : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_VIDEO : nvapi.h
  • NvAPI_GPU_QueryIlluminationSupport() : nvapi.h
  • NvAPI_GPU_ResetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_SetECCConfiguration() : nvapi.h
  • NvAPI_GPU_SetEDID() : nvapi.h
  • NvAPI_GPU_SetIllumination() : nvapi.h
  • NvAPI_GPU_SetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_SetScanoutIntensity() : nvapi.h
  • NvAPI_GPU_SetScanoutWarping() : nvapi.h
  • NvAPI_GPU_ValidateOutputCombination() : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE : nvapi_lite_common.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING : nvapi.h
  • NvAPI_GPU_WorkstationFeatureQuery() : nvapi.h
  • NvAPI_GPU_WorkstationFeatureSetup() : nvapi.h
  • NvAPI_GSync_AdjustSyncDelay() : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P2060 : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P358 : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_STARTUP : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_UNKNOWN : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED : nvapi.h
  • NvAPI_GSync_EnumSyncDevices() : nvapi.h
  • NvAPI_GSync_GetControlParameters() : nvapi.h
  • NvAPI_GSync_GetStatusParameters() : nvapi.h
  • NvAPI_GSync_GetSyncStatus() : nvapi.h
  • NvAPI_GSync_GetTopology() : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY : nvapi.h
  • NVAPI_GSYNC_POLARITY : nvapi.h
  • NVAPI_GSYNC_POLARITY_BOTH_EDGES : nvapi.h
  • NVAPI_GSYNC_POLARITY_FALLING_EDGE : nvapi.h
  • NVAPI_GSYNC_POLARITY_RISING_EDGE : nvapi.h
  • NvAPI_GSync_QueryCapabilities() : nvapi.h
  • NVAPI_GSYNC_RJ45_INPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_IO : nvapi.h
  • NVAPI_GSYNC_RJ45_OUTPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_UNUSED : nvapi.h
  • NvAPI_GSync_SetControlParameters() : nvapi.h
  • NvAPI_GSync_SetSyncStateSettings() : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_VSYNC : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_COMPOSITE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_HDTV : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NONE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_TTL : nvapi.h
  • NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_HANDLE_INVALIDATED : nvapi_lite_common.h
  • NVAPI_HDCP_ENCRYPTION_FAILED : nvapi_lite_common.h
  • NVAPI_I2C_SPEED_100KHZ : nvapi.h
  • NVAPI_I2C_SPEED_10KHZ : nvapi.h
  • NVAPI_I2C_SPEED_200KHZ : nvapi.h
  • NVAPI_I2C_SPEED_33KHZ : nvapi.h
  • NVAPI_I2C_SPEED_3KHZ : nvapi.h
  • NVAPI_I2C_SPEED_400KHZ : nvapi.h
  • NVAPI_I2C_SPEED_DEFAULT : nvapi.h
  • NVAPI_I2C_SPEED_DEPRECATED : nvapi.h
  • NvAPI_I2CRead() : nvapi.h
  • NvAPI_I2CWrite() : nvapi.h
  • NVAPI_ID_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_AUDIO_DRIVER : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_STRUCT_VERSION : nvapi_lite_common.h
  • NvAPI_Initialize() : nvapi.h
  • NVAPI_INSTRUMENTATION_DISABLED : nvapi_lite_common.h
  • NVAPI_INSUFFICIENT_BUFFER : nvapi_lite_common.h
  • NVAPI_INTERFACE : nvapi_lite_salstart.h
  • NVAPI_INVALID_ADDRESS : nvapi_lite_common.h
  • NVAPI_INVALID_ARGUMENT : nvapi_lite_common.h
  • NVAPI_INVALID_CALL : nvapi_lite_common.h
  • NVAPI_INVALID_COMBINATION : nvapi_lite_common.h
  • NVAPI_INVALID_CONFIGURATION : nvapi_lite_common.h
  • NVAPI_INVALID_DISPLAY_ID : nvapi_lite_common.h
  • NVAPI_INVALID_HANDLE : nvapi_lite_common.h
  • NVAPI_INVALID_HYBRID_MODE : nvapi_lite_common.h
  • NVAPI_INVALID_PERF_LEVEL : nvapi_lite_common.h
  • NVAPI_INVALID_POINTER : nvapi_lite_common.h
  • NVAPI_INVALID_SYNC_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_INVALID_USER_PRIVILEDGE : nvapi.h
  • NVAPI_INVALID_USER_PRIVILEGE : nvapi_lite_common.h
  • NVAPI_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED : nvapi_lite_common.h
  • NVAPI_LONG_STRING_MAX : nvapi_lite_common.h
  • NvAPI_LongString : nvapi_lite_common.h
  • NvAPI_LPCWSTR : nvapi.h
  • NVAPI_MATCHING_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_MAX_ACPI_IDS : nvapi_lite_common.h
  • NVAPI_MAX_AUDIO_DEVICES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_SLI_GROUPS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_MAX_FRAMELOCK_MAPPING_MODES : nvapi.h
  • NVAPI_MAX_GPU_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PER_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_MAX_GPU_PERF_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PERF_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PERF_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PUBLIC_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_GPU_UTILIZATIONS : nvapi.h
  • NVAPI_MAX_GSYNC_DEVICES : nvapi.h
  • NVAPI_MAX_HEADS_PER_GPU : nvapi_lite_common.h
  • NVAPI_MAX_LOGICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS : nvapi.h
  • NVAPI_MAX_MOSAIC_DISPLAY_ROWS : nvapi.h
  • NVAPI_MAX_MOSAIC_TOPOS : nvapi.h
  • NVAPI_MAX_PHYSICAL_BRIDGES : nvapi_lite_common.h
  • NVAPI_MAX_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_RJ45_PER_GSYNC : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS : nvapi.h
  • NVAPI_MAX_THERMAL_SENSORS_PER_GPU : nvapi.h
  • NVAPI_MAX_VIEW_MODES : nvapi_lite_common.h
  • NVAPI_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_MAX_VIO_CHANNELS_PER_JACK : nvapi.h
  • NVAPI_MAX_VIO_DEVICES : nvapi.h
  • NVAPI_MAX_VIO_JACKS : nvapi.h
  • NVAPI_MAX_VIO_LINKS_PER_STREAM : nvapi.h
  • NVAPI_MAX_VIO_STREAMS : nvapi.h
  • NVAPI_MIN_VIO_STREAMS : nvapi.h
  • NVAPI_MIXED_TARGET_TYPES : nvapi_lite_common.h
  • NVAPI_MODE_CHANGE_FAILED : nvapi_lite_common.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER1 : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER2 : nvapi.h
  • NvAPI_Mosaic_EnableCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayGrids() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayModes() : nvapi.h
  • NvAPI_Mosaic_GetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_GetDisplayViewportsByResolution() : nvapi_lite_surround.h
  • NvAPI_Mosaic_GetOverlapLimits() : nvapi.h
  • NvAPI_Mosaic_GetSupportedTopoInfo() : nvapi.h
  • NvAPI_Mosaic_GetTopoGroup() : nvapi.h
  • NVAPI_MOSAIC_NOT_ACTIVE : nvapi_lite_common.h
  • NvAPI_Mosaic_SetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_SetDisplayGrids() : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_BRIEF_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_DETAILS_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_GROUP_VER : nvapi.h
  • NVAPI_MOSAIC_TOPOLOGY_VER : nvapi.h
  • NvAPI_Mosaic_ValidateDisplayGrids() : nvapi.h
  • NVAPI_NO_ACTIVE_SLI_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_NO_CONNECTOR_FOUND : nvapi_lite_common.h
  • NVAPI_NO_FRUSTUM_ADJUST : nvapi.h
  • NVAPI_NO_GL_EXPERT : nvapi_lite_common.h
  • NVAPI_NO_GL_NSIGHT : nvapi_lite_common.h
  • NVAPI_NO_IMPLEMENTATION : nvapi_lite_common.h
  • NVAPI_NO_VIDLINK : nvapi_lite_common.h
  • NVAPI_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_NV_PERSIST_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVIDIA_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NvAPI_OGL_ExpertModeDefaultsGet() : nvapi.h
  • NvAPI_OGL_ExpertModeDefaultsSet() : nvapi.h
  • NvAPI_OGL_ExpertModeGet() : nvapi.h
  • NvAPI_OGL_ExpertModeSet() : nvapi.h
  • NVAPI_OGLEXPERT_CALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ALL : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_BASIC_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_NONE : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_SWFALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_ALL : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ALL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_FEATURE_SLI : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_FBO : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_SWFALLBACK : nvapi.h
  • NVAPI_OK : nvapi_lite_common.h
  • NVAPI_OPENGL_CONTEXT_NOT_CURRENT : nvapi_lite_common.h
  • NVAPI_OUT_OF_MEMORY : nvapi_lite_common.h
  • NVAPI_PCLK_LIMITATION_FAILED : nvapi_lite_common.h
  • NVAPI_PERSIST_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_PORTID_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE : nvapi.h
  • NVAPI_PROFILE_NAME_EMPTY : nvapi_lite_common.h
  • NVAPI_PROFILE_NAME_IN_USE : nvapi_lite_common.h
  • NVAPI_PROFILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PROFILE_REMOVED : nvapi_lite_common.h
  • NVAPI_QUAD_FILLMODE : nvapi.h
  • NVAPI_QUAD_FILLMODE_BBOX : nvapi.h
  • NVAPI_QUAD_FILLMODE_DISABLED : nvapi.h
  • NVAPI_QUAD_FILLMODE_FULL_VIEWPORT : nvapi.h
  • NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS : nvapi_lite_common.h
  • NVAPI_REQUEST_USER_TO_DISABLE_DWM : nvapi_lite_common.h
  • NVAPI_REQUIRES_REBOOT : nvapi_lite_common.h
  • NVAPI_RESOURCE_NOT_ACQUIRED : nvapi_lite_common.h
  • NVAPI_SET_NOT_ALLOWED : nvapi_lite_common.h
  • NvAPI_SetCurrentMosaicTopology() : nvapi.h
  • NvAPI_SetDisplayPort() : nvapi.h
  • NvAPI_SetRefreshRateOverride() : nvapi.h
  • NVAPI_SETTING_MAX_VALUES : nvapi.h
  • NVAPI_SETTING_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SETTING_SIZE_TOO_LARGE : nvapi_lite_common.h
  • NVAPI_SHARE_RESOURCE_RELOCATED : nvapi_lite_common.h
  • NVAPI_SHORT_STRING_MAX : nvapi_lite_common.h
  • NvAPI_ShortString : nvapi_lite_common.h
  • NVAPI_SLI_RENDERING_MODE_NOTALLOWED : nvapi_lite_common.h
  • NvAPI_Status : nvapi_lite_common.h
  • NvAPI_Stereo_Activate() : nvapi_lite_stereo.h
  • NVAPI_STEREO_CAPS : nvapi.h
  • NVAPI_STEREO_CAPS_V1 : nvapi.h
  • NVAPI_STEREO_CAPS_VER : nvapi.h
  • NVAPI_STEREO_CAPS_VER1 : nvapi.h
  • NvAPI_Stereo_CaptureJpegImage() : nvapi.h
  • NvAPI_Stereo_CapturePngImage() : nvapi.h
  • NvAPI_Stereo_CreateConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_CreateHandleFromIUnknown() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Deactivate() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Debug_WasLastDrawStereoized() : nvapi_lite_stereo.h
  • NvAPI_Stereo_DecreaseConvergence() : nvapi.h
  • NvAPI_Stereo_DecreaseSeparation() : nvapi.h
  • NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_DestroyHandle() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Disable() : nvapi_lite_stereo.h
  • NVAPI_STEREO_DRIVER_MODE_AUTOMATIC : nvapi_lite_stereo.h
  • NVAPI_STEREO_DRIVER_MODE_DIRECT : nvapi_lite_stereo.h
  • NVAPI_STEREO_DX10_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_DX9_REGISTRY_PROFILE : nvapi.h
  • NvAPI_Stereo_Enable() : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_LEFT : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_MONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_RIGHT : nvapi_lite_stereo.h
  • NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED : nvapi_lite_common.h
  • NvAPI_Stereo_GetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetEyeSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_GetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetStereoSupport() : nvapi.h
  • NvAPI_Stereo_GetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NVAPI_STEREO_HANDSHAKE_NOT_DONE : nvapi_lite_common.h
  • NvAPI_Stereo_IncreaseConvergence() : nvapi.h
  • NvAPI_Stereo_IncreaseSeparation() : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_DELAYED : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE : nvapi_lite_common.h
  • NvAPI_Stereo_InitActivation() : nvapi.h
  • NVAPI_STEREO_INVALID_DEVICE_INTERFACE : nvapi_lite_common.h
  • NvAPI_Stereo_IsActivated() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsEnabled() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsWindowedModeSupported() : nvapi_lite_stereo.h
  • NVAPI_STEREO_NOT_ENABLED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_TURNED_ON : nvapi_lite_common.h
  • NVAPI_STEREO_PARAMETER_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_STEREO_QUADBUFFERED_API_VERSION : nvapi.h
  • NVAPI_STEREO_REGISTRY_ACCESS_FAILED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED : nvapi_lite_common.h
  • NvAPI_Stereo_ReverseStereoBlitControl() : nvapi.h
  • NvAPI_Stereo_SetActiveEye() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_SetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDriverMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_SetNotificationMessage() : nvapi.h
  • NvAPI_Stereo_SetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_AUTO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SWAPCHAIN_DEFAULT : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_MONO : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_STEREO : nvapi.h
  • NvAPI_Stereo_Trigger_Activation() : nvapi.h
  • NVAPI_STREAM_IS_OUT_OF_SYNC : nvapi_lite_common.h
  • NvAPI_String : nvapi_lite_common.h
  • NVAPI_STRING_TOO_SMALL : nvapi_lite_common.h
  • NVAPI_SYNC_MASTER_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SYNC_NOT_ACTIVE : nvapi_lite_common.h
  • NvAPI_SYS_GetChipSetInfo() : nvapi.h
  • NvAPI_SYS_GetDisplayIdFromGpuAndOutputId() : nvapi.h
  • NvAPI_SYS_GetDriverAndBranchVersion() : nvapi_lite_common.h
  • NvAPI_SYS_GetGpuAndOutputIdFromDisplayId() : nvapi.h
  • NvAPI_SYS_GetLidAndDockInfo() : nvapi.h
  • NvAPI_SYS_GetPhysicalGpuFromDisplayId() : nvapi.h
  • NVAPI_SYSTEM_HWBC_INVALID_ID : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_HWBCS : nvapi_lite_common.h
  • NVAPI_SYSWOW64_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TESTING_CLOCKS_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_THERMAL_CONTROLLER_ADM1032 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_ADT7473 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM64 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM89 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM99 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX1617 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_NONE : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_OS : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_SBMAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_VBIOSEVT : nvapi.h
  • NVAPI_THERMAL_TARGET_ALL : nvapi.h
  • NVAPI_THERMAL_TARGET_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_GPU : nvapi.h
  • NVAPI_THERMAL_TARGET_MEMORY : nvapi.h
  • NVAPI_THERMAL_TARGET_NONE : nvapi.h
  • NVAPI_THERMAL_TARGET_POWER_SUPPLY : nvapi.h
  • NVAPI_THERMAL_TARGET_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_INLET : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_OUTLET : nvapi.h
  • NVAPI_TIMEOUT : nvapi_lite_common.h
  • NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO : nvapi_lite_common.h
  • NVAPI_TIMING_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TOO_MANY_SETTINGS_IN_PROFILE : nvapi_lite_common.h
  • NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS : nvapi_lite_common.h
  • NVAPI_TOPO_NOT_POSSIBLE : nvapi_lite_common.h
  • NVAPI_UNICODE_STRING_MAX : nvapi.h
  • NvAPI_UnicodeString : nvapi.h
  • NVAPI_UNKNOWN_UNDERSCAN_CONFIG : nvapi_lite_common.h
  • NvAPI_Unload() : nvapi.h
  • NVAPI_UNREGISTERED_RESOURCE : nvapi_lite_common.h
  • NVAPI_VALUE_ALREADY_SET : nvapi_lite_common.h
  • NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN : nvapi.h
  • NvAPI_VIO_Close() : nvapi.h
  • NvAPI_VIO_EnumDataFormats() : nvapi.h
  • NvAPI_VIO_EnumDevices() : nvapi.h
  • NvAPI_VIO_EnumSignalFormats() : nvapi.h
  • NvAPI_VIO_GetCapabilities() : nvapi.h
  • NvAPI_VIO_GetConfig() : nvapi.h
  • NvAPI_VIO_GetPCIInfo() : nvapi.h
  • NvAPI_VIO_IsFrameLockModeCompatible() : nvapi.h
  • NvAPI_VIO_IsRunning() : nvapi.h
  • NvAPI_VIO_Open() : nvapi.h
  • NvAPI_VIO_QueryTopology() : nvapi.h
  • NvAPI_VIO_SetConfig() : nvapi.h
  • NvAPI_VIO_Start() : nvapi.h
  • NvAPI_VIO_Status() : nvapi.h
  • NvAPI_VIO_Stop() : nvapi.h
  • NvAPI_VIO_SyncFormatDetect() : nvapi.h
  • NVAPI_WAS_STILL_DRAWING : nvapi_lite_common.h
  • NvBallot() : nvHLSLExtns.h
  • NvBool : nvapi_lite_common.h
  • NVDRS_APPLICATION : nvapi.h
  • NVDRS_APPLICATION_V1 : nvapi.h
  • NVDRS_APPLICATION_V2 : nvapi.h
  • NVDRS_APPLICATION_V3 : nvapi.h
  • NVDRS_APPLICATION_VER : nvapi.h
  • NVDRS_APPLICATION_VER_V1 : nvapi.h
  • NVDRS_APPLICATION_VER_V2 : nvapi.h
  • NVDRS_APPLICATION_VER_V3 : nvapi.h
  • NVDRS_BASE_PROFILE_LOCATION : nvapi.h
  • NVDRS_BINARY_SETTING : nvapi.h
  • NVDRS_BINARY_TYPE : nvapi.h
  • NVDRS_CURRENT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DEFAULT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DWORD_TYPE : nvapi.h
  • NVDRS_GLOBAL_PROFILE_LOCATION : nvapi.h
  • NVDRS_GPU_SUPPORT : nvapi.h
  • NVDRS_PROFILE : nvapi.h
  • NVDRS_PROFILE_V1 : nvapi.h
  • NVDRS_PROFILE_VER : nvapi.h
  • NVDRS_PROFILE_VER1 : nvapi.h
  • NVDRS_SETTING : nvapi.h
  • NVDRS_SETTING_LOCATION : nvapi.h
  • NVDRS_SETTING_TYPE : nvapi.h
  • NVDRS_SETTING_V1 : nvapi.h
  • NVDRS_SETTING_VALUES : nvapi.h
  • NVDRS_SETTING_VALUES_VER : nvapi.h
  • NVDRS_SETTING_VER : nvapi.h
  • NVDRS_SETTING_VER1 : nvapi.h
  • NVDRS_STRING_TYPE : nvapi.h
  • NVDRS_WSTRING_TYPE : nvapi.h
  • NVFORMAT_MAKEFOURCC : nvapi.h
  • NvGetLaneId() : nvHLSLExtns.h
  • NVINPUTOUTPUTSTATUS_ERROR : nvapi.h
  • NVINPUTOUTPUTSTATUS_OFF : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_HD : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_SD : nvapi.h
  • NvInterlockedAddFp16x2() : nvHLSLExtns.h
  • NvInterlockedAddFp16x4() : nvHLSLExtns.h
  • NvInterlockedAddFp32() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x2() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x4() : nvHLSLExtns.h
  • NvInterlockedMinFp16x2() : nvHLSLExtns.h
  • NvInterlockedMinFp16x4() : nvHLSLExtns.h
  • NvLoadUavTyped() : nvHLSLExtns.h
  • NvS16 : nvapi_lite_common.h
  • NvS32 : nvapi_lite_common.h
  • NvS64 : nvapi_lite_common.h
  • NvS8 : nvapi_lite_common.h
  • NvShfl() : nvHLSLExtns.h
  • NvShflDown() : nvHLSLExtns.h
  • NvShflUp() : nvHLSLExtns.h
  • NvShflXor() : nvHLSLExtns.h
  • NvU16 : nvapi_lite_common.h
  • NvU32 : nvapi_lite_common.h
  • NvU64 : nvapi_lite_common.h
  • NvU8 : nvapi_lite_common.h
  • NVVIO_O_READ : nvapi.h
  • NVVIO_O_WRITE_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_INITIALIZED : nvapi.h
  • NVVIO_OWNERID_TYPEMASK : nvapi.h
  • NVVIO_VALID_ACCESSRIGHTS : nvapi.h
  • NVVIOANCPARITYCOMPUTATION : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_AUTO : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_OFF : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_ON : nvapi.h
  • NVVIOBITSPERCOMPONENT : nvapi.h
  • NVVIOBITSPERCOMPONENT_10 : nvapi.h
  • NVVIOBITSPERCOMPONENT_12 : nvapi.h
  • NVVIOBITSPERCOMPONENT_8 : nvapi.h
  • NVVIOBITSPERCOMPONENT_UNKNOWN : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8Z24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8Z24 : nvapi.h
  • NVVIOCAPS : nvapi.h
  • NVVIOCAPS_AUDIO_BLANKING_SUPPORTED : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_DESKTOP : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_OPENGL : nvapi.h
  • NVVIOCAPS_PACKED_ANC_SUPPORTED : nvapi.h
  • NVVIOCAPS_SYNC_GENLOCK : nvapi.h
  • NVVIOCAPS_SYNC_INTERNAL : nvapi.h
  • NVVIOCAPS_SYNCSRC_COMP : nvapi.h
  • NVVIOCAPS_SYNCSRC_SDI : nvapi.h
  • NVVIOCAPS_VER : nvapi.h
  • NVVIOCAPS_VER1 : nvapi.h
  • NVVIOCAPS_VER2 : nvapi.h
  • NVVIOCAPS_VIDIN_SDI : nvapi.h
  • NVVIOCAPS_VIDOUT_SDI : nvapi.h
  • NVVIOCAPTURESTATUS : nvapi.h
  • NVVIOCHANNELSTATUS : nvapi.h
  • NVVIOCLASS_SDI : nvapi.h
  • NVVIOCOLORCONVERSION : nvapi.h
  • NVVIOCOLORCONVERSION_VER : nvapi.h
  • NVVIOCOLORSPACE : nvapi.h
  • NVVIOCOLORSPACE_GBR : nvapi.h
  • NVVIOCOLORSPACE_GBRA : nvapi.h
  • NVVIOCOLORSPACE_GBRD : nvapi.h
  • NVVIOCOLORSPACE_UNKNOWN : nvapi.h
  • NVVIOCOLORSPACE_YCBCR : nvapi.h
  • NVVIOCOLORSPACE_YCBCRA : nvapi.h
  • NVVIOCOLORSPACE_YCBCRD : nvapi.h
  • NVVIOCOMPONENTSAMPLING : nvapi.h
  • NVVIOCOMPONENTSAMPLING_422 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4224 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_UNKNOWN : nvapi.h
  • NVVIOCOMPOSITERANGE : nvapi.h
  • NVVIOCOMPSYNCTYPE : nvapi.h
  • NVVIOCOMPSYNCTYPE_AUTO : nvapi.h
  • NVVIOCOMPSYNCTYPE_BILEVEL : nvapi.h
  • NVVIOCOMPSYNCTYPE_TRILEVEL : nvapi.h
  • NVVIOCONFIG : nvapi.h
  • NVVIOCONFIG_422FILTER : nvapi.h
  • NVVIOCONFIG_ALLFIELDS : nvapi.h
  • NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS : nvapi.h
  • NVVIOCONFIG_ALPHAKEYCOMPOSITE : nvapi.h
  • NVVIOCONFIG_ANC_AUDIO_REPEAT : nvapi.h
  • NVVIOCONFIG_ANC_PARITY_COMPUTATION : nvapi.h
  • NVVIOCONFIG_ANCTIMECODEGENERATION : nvapi.h
  • NVVIOCONFIG_COLORCONVERSION : nvapi.h
  • NVVIOCONFIG_COMPOSITE : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CB : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CR : nvapi.h
  • NVVIOCONFIG_COMPOSITE_Y : nvapi.h
  • NVVIOCONFIG_COMPOSITESYNCTYPE : nvapi.h
  • NVVIOCONFIG_COMPOSITETERMINATE : nvapi.h
  • NVVIOCONFIG_CSCOVERRIDE : nvapi.h
  • NVVIOCONFIG_DATAFORMAT : nvapi.h
  • NVVIOCONFIG_DATAINTEGRITYCHECK : nvapi.h
  • NVVIOCONFIG_DRIVERFIELDS : nvapi.h
  • NVVIOCONFIG_FLIPQUEUELENGTH : nvapi.h
  • NVVIOCONFIG_FRAMELOCKENABLE : nvapi.h
  • NVVIOCONFIG_FULL_COLOR_RANGE : nvapi.h
  • NVVIOCONFIG_GAMMACORRECTION : nvapi.h
  • NVVIOCONFIG_GAMMAFIELDS : nvapi.h
  • NVVIOCONFIG_OUTPUTAREA : nvapi.h
  • NVVIOCONFIG_OUTPUTREGION : nvapi.h
  • NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE : nvapi.h
  • NVVIOCONFIG_RGB_DATA : nvapi.h
  • NVVIOCONFIG_RMCTRLFIELDS : nvapi.h
  • NVVIOCONFIG_RMMODESET_FIELDS : nvapi.h
  • NVVIOCONFIG_RMSKEWFIELDS : nvapi.h
  • NVVIOCONFIG_SIGNALFORMAT : nvapi.h
  • NVVIOCONFIG_STREAMS : nvapi.h
  • NVVIOCONFIG_SYNCDELAY : nvapi.h
  • NVVIOCONFIG_SYNCSOURCEENABLE : nvapi.h
  • NVVIOCONFIG_V1 : nvapi.h
  • NVVIOCONFIG_V2 : nvapi.h
  • NVVIOCONFIG_V3 : nvapi.h
  • NVVIOCONFIG_VALIDFIELDS : nvapi.h
  • NVVIOCONFIG_VER : nvapi.h
  • NVVIOCONFIG_VER1 : nvapi.h
  • NVVIOCONFIG_VER2 : nvapi.h
  • NVVIOCONFIG_VER3 : nvapi.h
  • NVVIOCONFIGTYPE : nvapi.h
  • NVVIOCONFIGTYPE_IN : nvapi.h
  • NVVIOCONFIGTYPE_OUT : nvapi.h
  • NVVIODATAFORMAT : nvapi.h
  • NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_RGB444 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444 : nvapi.h
  • NVVIODATAFORMAT_UNKNOWN : nvapi.h
  • NVVIODATAFORMAT_X10X10X10_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMATDETAIL : nvapi.h
  • NVVIOGAMMACORRECTION : nvapi.h
  • NVVIOGAMMACORRECTION_VER : nvapi.h
  • NVVIOGAMMARAMP10 : nvapi.h
  • NVVIOGAMMARAMP8 : nvapi.h
  • NVVIOINPUTCONFIG : nvapi.h
  • NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • NVVIOINPUTSTATUS : nvapi.h
  • NVVIOINTERLACEMODE : nvapi.h
  • NVVIOINTERLACEMODE_INTERLACE : nvapi.h
  • NVVIOINTERLACEMODE_PROGRESSIVE : nvapi.h
  • NVVIOINTERLACEMODE_PSF : nvapi.h
  • NVVIOLINKID : nvapi.h
  • NVVIOLINKID_A : nvapi.h
  • NVVIOLINKID_B : nvapi.h
  • NVVIOLINKID_C : nvapi.h
  • NVVIOLINKID_D : nvapi.h
  • NVVIOLINKID_UNKNOWN : nvapi.h
  • NVVIOOUTPUTAREA : nvapi.h
  • NVVIOOUTPUTAREA_FULLSIZE : nvapi.h
  • NVVIOOUTPUTAREA_SAFEACTION : nvapi.h
  • NVVIOOUTPUTAREA_SAFETITLE : nvapi.h
  • NVVIOOUTPUTCONFIG : nvapi.h
  • NVVIOOUTPUTCONFIG_V1 : nvapi.h
  • NVVIOOUTPUTCONFIG_V2 : nvapi.h
  • NVVIOOUTPUTCONFIG_V3 : nvapi.h
  • NVVIOOUTPUTREGION : nvapi.h
  • NVVIOOUTPUTSTATUS : nvapi.h
  • NVVIOOWNERID : nvapi.h
  • NVVIOOWNERID_NONE : nvapi.h
  • NVVIOOWNERTYPE : nvapi.h
  • NVVIOOWNERTYPE_APPLICATION : nvapi.h
  • NVVIOOWNERTYPE_DESKTOP : nvapi.h
  • NVVIOOWNERTYPE_NONE : nvapi.h
  • NVVIOPCIINFO : nvapi.h
  • NVVIOPCIINFO_V1 : nvapi.h
  • NVVIOPCIINFO_VER : nvapi.h
  • NVVIOPCIINFO_VER1 : nvapi.h
  • NVVIOPCILINKRATE : nvapi.h
  • NVVIOPCILINKRATE_GEN1 : nvapi.h
  • NVVIOPCILINKRATE_GEN2 : nvapi.h
  • NVVIOPCILINKRATE_GEN3 : nvapi.h
  • NVVIOPCILINKRATE_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH : nvapi.h
  • NVVIOPCILINKWIDTH_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH_x1 : nvapi.h
  • NVVIOPCILINKWIDTH_x16 : nvapi.h
  • NVVIOPCILINKWIDTH_x2 : nvapi.h
  • NVVIOPCILINKWIDTH_x4 : nvapi.h
  • NVVIOPCILINKWIDTH_x8 : nvapi.h
  • NVVIOSIGNALFORMAT : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC : nvapi.h
  • NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL : nvapi.h
  • NVVIOSIGNALFORMAT_720P_23_98_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_24_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_25_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_29_97_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_30_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_50_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_59_94_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_60_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_END : nvapi.h
  • NVVIOSIGNALFORMAT_NONE : nvapi.h
  • NVVIOSIGNALFORMATDETAIL : nvapi.h
  • NVVIOSTATUS : nvapi.h
  • NVVIOSTATUS_ERROR : nvapi.h
  • NVVIOSTATUS_RUNNING : nvapi.h
  • NVVIOSTATUS_STOPPED : nvapi.h
  • NVVIOSTATUS_VER : nvapi.h
  • NVVIOSTATUSTYPE : nvapi.h
  • NVVIOSTATUSTYPE_IN : nvapi.h
  • NVVIOSTATUSTYPE_OUT : nvapi.h
  • NVVIOSTREAM : nvapi.h
  • NVVIOSYNCDELAY : nvapi.h
  • NVVIOSYNCDELAY_VER : nvapi.h
  • NVVIOSYNCSOURCE : nvapi.h
  • NVVIOSYNCSOURCE_COMPSYNC : nvapi.h
  • NVVIOSYNCSOURCE_SDISYNC : nvapi.h
  • NVVIOSYNCSTATUS : nvapi.h
  • NVVIOSYNCSTATUS_COMPOSITE : nvapi.h
  • NVVIOSYNCSTATUS_ERROR : nvapi.h
  • NVVIOSYNCSTATUS_OFF : nvapi.h
  • NVVIOSYNCSTATUS_SDI_HD : nvapi.h
  • NVVIOSYNCSTATUS_SDI_SD : nvapi.h
  • NVVIOSYNCSTATUS_SYNCLOSS : nvapi.h
  • NVVIOTOPOLOGY : nvapi.h
  • NVVIOTOPOLOGY_VER : nvapi.h
  • NVVIOVIDEOMODE : nvapi.h
  • NVVIOVIDEOSTANDARD : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE259 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE260 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE274 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE295 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE296 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE372 : nvapi.h
  • NVVIOVIDEOTYPE : nvapi.h
  • NVVIOVIDEOTYPE_HD : nvapi.h
  • NVVIOVIDEOTYPE_SD : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • OGL_AA_LINE_GAMMA_DEFAULT : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_DISABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ENABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ID : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MAX : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MIN : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_NUM_VALUES : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_STRING : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DEFAULT : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DISABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ENABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ID : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DISABLE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_TEAR : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_ID : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_STRING : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ID : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_OFF : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ON : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_STRING : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ID : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_OFF : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ON : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_STRING : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_DEFAULT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ID : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_STRING : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_ID : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_STRING : NvApiDriverSettings.h
  • OGL_MULTIMON_COMPATIBILITY_GCD : NvApiDriverSettings.h
  • OGL_MULTIMON_COMPATIBILITY_LCD : NvApiDriverSettings.h
  • OGL_MULTIMON_DEFAULT : NvApiDriverSettings.h
  • OGL_MULTIMON_EXTENDED_SINGLE_MONITOR : NvApiDriverSettings.h
  • OGL_MULTIMON_ID : NvApiDriverSettings.h
  • OGL_MULTIMON_MULTIMON_BUFFER : NvApiDriverSettings.h
  • OGL_MULTIMON_NUM_VALUES : NvApiDriverSettings.h
  • OGL_MULTIMON_PERFORMANCE_GCD : NvApiDriverSettings.h
  • OGL_MULTIMON_PERFORMANCE_LCD : NvApiDriverSettings.h
  • OGL_MULTIMON_PERFORMANCE_QUADRO : NvApiDriverSettings.h
  • OGL_MULTIMON_SINGLE_MONITOR : NvApiDriverSettings.h
  • OGL_MULTIMON_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NONE : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_FORCE_SW : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_OFF : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ON : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_STRING : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HPERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HQUAL : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_PERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_QUAL : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ID : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_STRING : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ENABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_FORCE_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ID : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_NUM_VALUES : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_STRING : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DEFAULT : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DISABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ENABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ID : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_STRING : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DISABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ENABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ID : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_STRING : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_DEFAULT : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_DISABLE : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_ENABLE : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_ID : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_STRING : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_DEFAULT : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_ID : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MAX : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MIN : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_NUM_VALUES : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • pCSC : nvapi.h
  • pGamma : nvapi.h
  • PHYSXINDICATOR_DEFAULT : NvApiDriverSettings.h
  • PHYSXINDICATOR_DISABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ENABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ID : NvApiDriverSettings.h
  • PHYSXINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • PHYSXINDICATOR_STRING : NvApiDriverSettings.h
  • PNV_MULTIGPU_CAPS : nvapi.h
  • pOutputsMask : nvapi.h
  • pPathCount : nvapi.h
  • pPathInfo : nvapi.h
  • pPerfPstatesInfo : nvapi.h
  • PREFERRED_PSTATE_ADAPTIVE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DEFAULT : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DRIVER_CONTROLLED : NvApiDriverSettings.h
  • PREFERRED_PSTATE_ID : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MIN : NvApiDriverSettings.h
  • PREFERRED_PSTATE_NUM_VALUES : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MIN : NvApiDriverSettings.h
  • PREFERRED_PSTATE_STRING : NvApiDriverSettings.h
  • PRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • PRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • PRERENDERLIMIT_ID : NvApiDriverSettings.h
  • PRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • PRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • PRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • PRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ID : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_OFF : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ON : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL_MAXWELL : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_AVOID_NOOP : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT_FOR_GM10X : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_3D : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_CE : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_FORCE_OFF : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ACCURATE : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ALLOW_WINDOWED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_DISABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_DISALLOWED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ENABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FORCE_OPTIMUS_POLICY : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FORCE_VSYNC_OFF : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FORCEON : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPS_20 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPS_30 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPS_40 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPSMASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FRL2 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_DECREASE_FILTER_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_DISABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_OPTIMAL_SETTING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_WEB : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_MODEMASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_OPENGL_REMOTE_DESKTOP : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_POWER : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_TEMPERATURE : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_THRESHOLD : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_USE_CPU_WAIT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_DISABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_ENABLE_ON_VSYNC : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_30 : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_60 : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_USE_FRL : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_OPTIMAL_SETTING : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_THRESHOLD_PCT_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_VSYNC_OPTIMAL_SETTING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DEFAULT : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_NUM_VALUES : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_OFF : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ON : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_STRING : NvApiDriverSettings.h
  • pSyncDelay : nvapi.h
  • pTargetInfo : nvapi.h
  • pTargetMaskCount : nvapi.h
  • pTargets : nvapi.h
  • pTargetView : nvapi.h
  • pTargetViewMode : nvapi.h
  • pVersion : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- q -

  • QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHPERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHQUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_PERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_QUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_ID : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING : NvApiDriverSettings.h
  • SET_VAB_DATA_DEFAULT : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_NAN : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_POS_INF : NvApiDriverSettings.h
  • SET_VAB_DATA_ID : NvApiDriverSettings.h
  • SET_VAB_DATA_NUM_VALUES : NvApiDriverSettings.h
  • SET_VAB_DATA_STRING : NvApiDriverSettings.h
  • SET_VAB_DATA_UINT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_USE_API_DEFAULTS : NvApiDriverSettings.h
  • SET_VAB_DATA_ZERO : NvApiDriverSettings.h
  • SettingDWORDNameString : NvApiDriverSettings.h
  • SettingWSTRINGNameString : NvApiDriverSettings.h
  • SHIM_MAXRES_ID : NvApiDriverSettings.h
  • SHIM_MAXRES_STRING : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_DEFAULT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ENABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ID : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_INTEGRATED : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_MASK : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_STRING : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ENABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_INTEGRATED : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_CUDA : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_EHSHELL_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED1 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED2 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_STRING : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_STRING : NvApiDriverSettings.h
  • StereoHandle : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • targetView : nvapi.h
  • temp_NvU32 : nvapi_lite_common.h
  • TOTAL_DWORD_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_WSTRING_SETTING_NUM : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • VRPRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_ID : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ULMB : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ULMB : NvApiDriverSettings.h
  • VRR_MODE_DEFAULT : NvApiDriverSettings.h
  • VRR_MODE_DISABLED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRR_MODE_ID : NvApiDriverSettings.h
  • VRR_MODE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_MODE_STRING : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ID : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_STRING : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ID : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_STRING : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DEFAULT : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DISABLED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRRREQUESTSTATE_ID : NvApiDriverSettings.h
  • VRRREQUESTSTATE_NUM_VALUES : NvApiDriverSettings.h
  • VRRREQUESTSTATE_STRING : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • VSYNCMODE_DEFAULT : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL2 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL3 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL4 : NvApiDriverSettings.h
  • VSYNCMODE_FORCEOFF : NvApiDriverSettings.h
  • VSYNCMODE_FORCEON : NvApiDriverSettings.h
  • VSYNCMODE_ID : NvApiDriverSettings.h
  • VSYNCMODE_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCMODE_PASSIVE : NvApiDriverSettings.h
  • VSYNCMODE_STRING : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_DEFAULT : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ID : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_OFF : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ON : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_STRING : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ID : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_STRING : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ID : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NOTSUPPORTED : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • WKS_API_STEREO_EYES_EXCHANGE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_OFF : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ON : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_STRING : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ANAGLYPH : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_INTERLEAVED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_LINE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT_GL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SEEFRONT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SHUTTER_GLASSES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SIDE_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STEREO_MIRROR : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STRING : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SUB_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_MV : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_SL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TWINVIEW : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_USE_HW_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_VERTICAL_INTERLACED : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_AGGRESSIVE_PRE_ALLOCATION : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_AS_NEEDED : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_DEFAULT : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_ID : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_MODERATE_PRE_ALLOCATION : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_NUM_VALUES : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_STRING : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DAC : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DLP : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ON : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_ID : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE_PAIR : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • d
  • n

- _ -

  • __fp32x2Tofp16x2() : nvHLSLExtnsInternal.h
  • __fp32x4Tofp16x4() : nvHLSLExtnsInternal.h
  • __nvapi_deprecated_function() : nvapi.h
  • __NvAtomicAddFP32() : nvHLSLExtnsInternal.h
  • __NvAtomicOpFP16x2() : nvHLSLExtnsInternal.h
  • __NvGetShflMaskFromWidth() : nvHLSLExtnsInternal.h
  • __NvReferenceUAVForOp() : nvHLSLExtnsInternal.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • d
  • n

- d -

  • DECLARE_INTERFACE() : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • d
  • n

- n -

  • NV_DECLARE_HANDLE() : nvapi.h , nvapi_lite_common.h
  • NvAll() : nvHLSLExtns.h
  • NvAny() : nvHLSLExtns.h
  • NvAPI_CreateDisplayFromUnAttachedDisplay() : nvapi.h
  • NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlap() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlapEx() : nvapi.h
  • NvAPI_D3D11_CreateDevice() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateDeviceAndSwapChain() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateFastGeometryShader() : nvapi.h
  • NvAPI_D3D11_CreateFastGeometryShaderExplicit() : nvapi.h
  • NvAPI_D3D11_CreateMultiGPUDevice() : nvapi.h
  • NvAPI_D3D11_CreateRasterizerState() : nvapi.h
  • NvAPI_D3D11_EndUAVOverlap() : nvapi.h
  • NvAPI_D3D11_IsNvShaderExtnOpCodeSupported() : nvapi.h
  • NvAPI_D3D11_MultiDrawIndexedInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiDrawInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiGPU_GetCaps() : nvapi.h
  • NvAPI_D3D11_MultiGPU_Init() : nvapi.h
  • NvAPI_D3D11_SetDepthBoundsTest() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_SetNvShaderExtnSlot() : nvapi.h
  • NvAPI_D3D12_CreateGraphicsPipelineState() : nvapi.h
  • NvAPI_D3D12_SetDepthBoundsTestValues() : nvapi.h
  • NvAPI_D3D1x_CreateSwapChain() : nvapi.h
  • NvAPI_D3D1x_DisableShaderDiskCache() : nvapi.h
  • NvAPI_D3D1x_GetLowLatencySupport() : nvapi.h
  • NvAPI_D3D1x_HintCreateLowLatencyDevice() : nvapi.h
  • NvAPI_D3D9_AliasSurfaceAsTexture() : nvapi.h
  • NvAPI_D3D9_ClearRT() : nvapi.h
  • NvAPI_D3D9_CreateSwapChain() : nvapi.h
  • NvAPI_D3D9_GetSurfaceHandle() : nvapi.h
  • NvAPI_D3D9_RegisterResource() : nvapi.h
  • NvAPI_D3D9_StretchRectEx() : nvapi.h
  • NvAPI_D3D9_UnregisterResource() : nvapi.h
  • NvAPI_D3D9_VideoSetStereoInfo() : nvapi.h
  • NvAPI_D3D_BeginResourceRendering() : nvapi_lite_sli.h
  • NvAPI_D3D_EndResourceRendering() : nvapi_lite_sli.h
  • NvAPI_D3D_GetCurrentSLIState() : nvapi_lite_sli.h
  • NvAPI_D3D_GetObjectHandleForResource() : nvapi_lite_common.h
  • NvAPI_D3D_ImplicitSLIControl() : nvapi.h
  • NvAPI_D3D_IsGSyncActive() : nvapi.h
  • NvAPI_D3D_IsGSyncCapable() : nvapi.h
  • NvAPI_D3D_RegisterDevice() : nvapi.h
  • NvAPI_D3D_SetFPSIndicatorState() : nvapi.h
  • NvAPI_D3D_SetResourceHint() : nvapi_lite_sli.h
  • NvAPI_DisableHWCursor() : nvapi.h
  • NvAPI_Disp_ColorControl() : nvapi.h
  • NvAPI_DISP_DeleteCustomDisplay() : nvapi.h
  • NvAPI_DISP_EnumCustomDisplay() : nvapi.h
  • NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_DISP_GetDisplayConfig() : nvapi.h
  • NvAPI_DISP_GetDisplayIdByDisplayName() : nvapi.h
  • NvAPI_DISP_GetGDIPrimaryDisplayId() : nvapi_lite_surround.h
  • NvAPI_DISP_GetMonitorCapabilities() : nvapi.h
  • NvAPI_DISP_GetMonitorColorCapabilities() : nvapi.h
  • NvAPI_DISP_GetTiming() : nvapi.h
  • NvAPI_Disp_InfoFrameControl() : nvapi.h
  • NvAPI_DISP_RevertCustomDisplayTrial() : nvapi.h
  • NvAPI_DISP_SaveCustomDisplay() : nvapi.h
  • NvAPI_DISP_SetDisplayConfig() : nvapi.h
  • NvAPI_DISP_TryCustomDisplay() : nvapi.h
  • NvAPI_DRS_CreateApplication() : nvapi.h
  • NvAPI_DRS_CreateProfile() : nvapi.h
  • NvAPI_DRS_CreateSession() : nvapi.h
  • NvAPI_DRS_DeleteApplication() : nvapi.h
  • NvAPI_DRS_DeleteApplicationEx() : nvapi.h
  • NvAPI_DRS_DeleteProfile() : nvapi.h
  • NvAPI_DRS_DeleteProfileSetting() : nvapi.h
  • NvAPI_DRS_DestroySession() : nvapi.h
  • NvAPI_DRS_EnumApplications() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingIds() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingValues() : nvapi.h
  • NvAPI_DRS_EnumProfiles() : nvapi.h
  • NvAPI_DRS_EnumSettings() : nvapi.h
  • NvAPI_DRS_FindApplicationByName() : nvapi.h
  • NvAPI_DRS_FindProfileByName() : nvapi.h
  • NvAPI_DRS_GetApplicationInfo() : nvapi.h
  • NvAPI_DRS_GetBaseProfile() : nvapi.h
  • NvAPI_DRS_GetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_GetNumProfiles() : nvapi.h
  • NvAPI_DRS_GetProfileInfo() : nvapi.h
  • NvAPI_DRS_GetSetting() : nvapi.h
  • NvAPI_DRS_GetSettingIdFromName() : nvapi.h
  • NvAPI_DRS_GetSettingNameFromId() : nvapi.h
  • NvAPI_DRS_LoadSettings() : nvapi.h
  • NvAPI_DRS_LoadSettingsFromFile() : nvapi.h
  • NvAPI_DRS_RestoreAllDefaults() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefault() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefaultSetting() : nvapi.h
  • NvAPI_DRS_SaveSettings() : nvapi.h
  • NvAPI_DRS_SaveSettingsToFile() : nvapi.h
  • NvAPI_DRS_SetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_SetProfileInfo() : nvapi.h
  • NvAPI_DRS_SetSetting() : nvapi.h
  • NvAPI_EnableCurrentMosaicTopology() : nvapi.h
  • NvAPI_EnableHWCursor() : nvapi.h
  • NvAPI_EnumLogicalGPUs() : nvapi.h
  • NvAPI_EnumNvidiaDisplayHandle() : nvapi.h
  • NvAPI_EnumNvidiaUnAttachedDisplayHandle() : nvapi.h
  • NvAPI_EnumPhysicalGPUs() : nvapi_lite_common.h
  • NvAPI_EnumTCCPhysicalGPUs() : nvapi.h
  • NvAPI_GetAssociatedDisplayOutputId() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayName() : nvapi.h
  • NvAPI_GetCurrentMosaicTopology() : nvapi.h
  • NvAPI_GetDisplayPortInfo() : nvapi.h
  • NvAPI_GetErrorMessage() : nvapi.h
  • NvAPI_GetHDMISupportInfo() : nvapi.h
  • NvAPI_GetInterfaceVersionString() : nvapi.h
  • NvAPI_GetLogicalGPUFromDisplay() : nvapi.h
  • NvAPI_GetLogicalGPUFromPhysicalGPU() : nvapi.h
  • NvAPI_GetPhysicalGPUFromUnAttachedDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromLogicalGPU() : nvapi.h
  • NvAPI_GetSupportedMosaicTopologies() : nvapi.h
  • NvAPI_GetSupportedViews() : nvapi.h
  • NvAPI_GetUnAttachedAssociatedDisplayName() : nvapi.h
  • NvAPI_GetVBlankCounter() : nvapi.h
  • NvAPI_GPU_GetActiveOutputs() : nvapi.h
  • NvAPI_GPU_GetAGPAperture() : nvapi.h
  • NvAPI_GPU_GetAllClockFrequencies() : nvapi.h
  • NvAPI_GPU_GetAllDisplayIds() : nvapi.h
  • NvAPI_GPU_GetBoardInfo() : nvapi.h
  • NvAPI_GPU_GetBusId() : nvapi.h
  • NvAPI_GPU_GetBusSlotId() : nvapi.h
  • NvAPI_GPU_GetBusType() : nvapi.h
  • NvAPI_GPU_GetConnectedDisplayIds() : nvapi.h
  • NvAPI_GPU_GetCurrentAGPRate() : nvapi.h
  • NvAPI_GPU_GetCurrentPCIEDownstreamWidth() : nvapi.h
  • NvAPI_GPU_GetCurrentPstate() : nvapi.h
  • NvAPI_GPU_GetDynamicPstatesInfoEx() : nvapi.h
  • NvAPI_GPU_GetECCConfigurationInfo() : nvapi.h
  • NvAPI_GPU_GetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_GetECCStatusInfo() : nvapi.h
  • NvAPI_GPU_GetEDID() : nvapi.h
  • NvAPI_GPU_GetFullName() : nvapi.h
  • NvAPI_GPU_GetGpuCoreCount() : nvapi.h
  • NvAPI_GPU_GetGPUType() : nvapi.h
  • NvAPI_GPU_GetHDCPSupportStatus() : nvapi.h
  • NvAPI_GPU_GetIllumination() : nvapi.h
  • NvAPI_GPU_GetIRQ() : nvapi.h
  • NvAPI_GPU_GetMemoryInfo() : nvapi_lite_common.h
  • NvAPI_GPU_GetOutputType() : nvapi.h
  • NvAPI_GPU_GetPCIIdentifiers() : nvapi.h
  • NvAPI_GPU_GetPerfDecreaseInfo() : nvapi.h
  • NvAPI_GPU_GetPhysicalFrameBufferSize() : nvapi.h
  • NvAPI_GPU_GetPstates20() : nvapi.h
  • NvAPI_GPU_GetQuadroStatus() : nvapi.h
  • NvAPI_GPU_GetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_GetScanoutConfiguration() : nvapi.h
  • NvAPI_GPU_GetScanoutConfigurationEx() : nvapi.h
  • NvAPI_GPU_GetScanoutIntensityState() : nvapi.h
  • NvAPI_GPU_GetScanoutWarpingState() : nvapi.h
  • NvAPI_GPU_GetSystemType() : nvapi.h
  • NvAPI_GPU_GetTachReading() : nvapi.h
  • NvAPI_GPU_GetThermalSettings() : nvapi.h
  • NvAPI_GPU_GetVbiosOEMRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosVersionString() : nvapi.h
  • NvAPI_GPU_GetVirtualFrameBufferSize() : nvapi.h
  • NvAPI_GPU_QueryIlluminationSupport() : nvapi.h
  • NvAPI_GPU_ResetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_SetECCConfiguration() : nvapi.h
  • NvAPI_GPU_SetEDID() : nvapi.h
  • NvAPI_GPU_SetIllumination() : nvapi.h
  • NvAPI_GPU_SetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_SetScanoutIntensity() : nvapi.h
  • NvAPI_GPU_SetScanoutWarping() : nvapi.h
  • NvAPI_GPU_ValidateOutputCombination() : nvapi.h
  • NvAPI_GPU_WorkstationFeatureQuery() : nvapi.h
  • NvAPI_GPU_WorkstationFeatureSetup() : nvapi.h
  • NvAPI_GSync_AdjustSyncDelay() : nvapi.h
  • NvAPI_GSync_EnumSyncDevices() : nvapi.h
  • NvAPI_GSync_GetControlParameters() : nvapi.h
  • NvAPI_GSync_GetStatusParameters() : nvapi.h
  • NvAPI_GSync_GetSyncStatus() : nvapi.h
  • NvAPI_GSync_GetTopology() : nvapi.h
  • NvAPI_GSync_QueryCapabilities() : nvapi.h
  • NvAPI_GSync_SetControlParameters() : nvapi.h
  • NvAPI_GSync_SetSyncStateSettings() : nvapi.h
  • NvAPI_I2CRead() : nvapi.h
  • NvAPI_I2CWrite() : nvapi.h
  • NvAPI_Initialize() : nvapi.h
  • NvAPI_Mosaic_EnableCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayGrids() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayModes() : nvapi.h
  • NvAPI_Mosaic_GetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_GetDisplayViewportsByResolution() : nvapi_lite_surround.h
  • NvAPI_Mosaic_GetOverlapLimits() : nvapi.h
  • NvAPI_Mosaic_GetSupportedTopoInfo() : nvapi.h
  • NvAPI_Mosaic_GetTopoGroup() : nvapi.h
  • NvAPI_Mosaic_SetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_SetDisplayGrids() : nvapi.h
  • NvAPI_Mosaic_ValidateDisplayGrids() : nvapi.h
  • NvAPI_OGL_ExpertModeDefaultsGet() : nvapi.h
  • NvAPI_OGL_ExpertModeDefaultsSet() : nvapi.h
  • NvAPI_OGL_ExpertModeGet() : nvapi.h
  • NvAPI_OGL_ExpertModeSet() : nvapi.h
  • NvAPI_SetCurrentMosaicTopology() : nvapi.h
  • NvAPI_SetDisplayPort() : nvapi.h
  • NvAPI_SetRefreshRateOverride() : nvapi.h
  • NvAPI_Stereo_Activate() : nvapi_lite_stereo.h
  • NvAPI_Stereo_CaptureJpegImage() : nvapi.h
  • NvAPI_Stereo_CapturePngImage() : nvapi.h
  • NvAPI_Stereo_CreateConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_CreateHandleFromIUnknown() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Deactivate() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Debug_WasLastDrawStereoized() : nvapi_lite_stereo.h
  • NvAPI_Stereo_DecreaseConvergence() : nvapi.h
  • NvAPI_Stereo_DecreaseSeparation() : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_DestroyHandle() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Disable() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Enable() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetEyeSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_GetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetStereoSupport() : nvapi.h
  • NvAPI_Stereo_GetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IncreaseConvergence() : nvapi.h
  • NvAPI_Stereo_IncreaseSeparation() : nvapi.h
  • NvAPI_Stereo_InitActivation() : nvapi.h
  • NvAPI_Stereo_IsActivated() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsEnabled() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsWindowedModeSupported() : nvapi_lite_stereo.h
  • NvAPI_Stereo_ReverseStereoBlitControl() : nvapi.h
  • NvAPI_Stereo_SetActiveEye() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_SetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDriverMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_SetNotificationMessage() : nvapi.h
  • NvAPI_Stereo_SetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Trigger_Activation() : nvapi.h
  • NvAPI_SYS_GetChipSetInfo() : nvapi.h
  • NvAPI_SYS_GetDisplayIdFromGpuAndOutputId() : nvapi.h
  • NvAPI_SYS_GetDriverAndBranchVersion() : nvapi_lite_common.h
  • NvAPI_SYS_GetGpuAndOutputIdFromDisplayId() : nvapi.h
  • NvAPI_SYS_GetLidAndDockInfo() : nvapi.h
  • NvAPI_SYS_GetPhysicalGpuFromDisplayId() : nvapi.h
  • NvAPI_Unload() : nvapi.h
  • NvAPI_VIO_Close() : nvapi.h
  • NvAPI_VIO_EnumDataFormats() : nvapi.h
  • NvAPI_VIO_EnumDevices() : nvapi.h
  • NvAPI_VIO_EnumSignalFormats() : nvapi.h
  • NvAPI_VIO_GetCapabilities() : nvapi.h
  • NvAPI_VIO_GetConfig() : nvapi.h
  • NvAPI_VIO_GetPCIInfo() : nvapi.h
  • NvAPI_VIO_IsFrameLockModeCompatible() : nvapi.h
  • NvAPI_VIO_IsRunning() : nvapi.h
  • NvAPI_VIO_Open() : nvapi.h
  • NvAPI_VIO_QueryTopology() : nvapi.h
  • NvAPI_VIO_SetConfig() : nvapi.h
  • NvAPI_VIO_Start() : nvapi.h
  • NvAPI_VIO_Status() : nvapi.h
  • NvAPI_VIO_Stop() : nvapi.h
  • NvAPI_VIO_SyncFormatDetect() : nvapi.h
  • NvBallot() : nvHLSLExtns.h
  • NvGetLaneId() : nvHLSLExtns.h
  • NvInterlockedAddFp16x2() : nvHLSLExtns.h
  • NvInterlockedAddFp16x4() : nvHLSLExtns.h
  • NvInterlockedAddFp32() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x2() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x4() : nvHLSLExtns.h
  • NvInterlockedMinFp16x2() : nvHLSLExtns.h
  • NvInterlockedMinFp16x4() : nvHLSLExtns.h
  • NvLoadUavTyped() : nvHLSLExtns.h
  • NvShfl() : nvHLSLExtns.h
  • NvShflDown() : nvHLSLExtns.h
  • NvShflUp() : nvHLSLExtns.h
  • NvShflXor() : nvHLSLExtns.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • __cplusplus : defines.txt
  • __d3d10_1_h__ : defines.txt
  • __d3d10_h__ : defines.txt
  • __d3d11_h__ : defines.txt
  • _D3D9_H_ : defines.txt
  • displayView : nvapi.h
  • g_NvidiaExt : nvHLSLExtnsInternal.h
  • inputFlags : nvapi.h
  • pCSC : nvapi.h
  • pGamma : nvapi.h
  • pOutputsMask : nvapi.h
  • pPathCount : nvapi.h
  • pPathInfo : nvapi.h
  • pPerfPstatesInfo : nvapi.h
  • pSyncDelay : nvapi.h
  • pTargetInfo : nvapi.h
  • pTargetMaskCount : nvapi.h
  • pTargets : nvapi.h
  • pTargetView : nvapi.h
  • pTargetViewMode : nvapi.h
  • pVersion : nvapi.h
  • targetView : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • n
  • p
  • s
  • t

- i -

  • ID3D11MultiGPUDevice : nvapi.h
  • IMPLICIT_SLI_CONTROL : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • n
  • p
  • s
  • t

- n -

  • NV_BOARD_INFO : nvapi.h
  • NV_BOARD_INFO_V1 : nvapi.h
  • NV_BPC : nvapi.h
  • NV_COLOR_DATA : nvapi.h
  • NV_COLOR_DATA_V1 : nvapi.h
  • NV_COLOR_DATA_V2 : nvapi.h
  • NV_COLOR_DATA_V3 : nvapi.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO : nvapi_lite_common.h
  • NV_DISPLAY_PORT_INFO : nvapi.h
  • NV_DISPLAY_PORT_INFO_V1 : nvapi.h
  • NV_DISPLAY_TV_FORMAT : nvapi.h
  • NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • NV_DP_BPC : nvapi.h
  • NV_DP_COLOR_FORMAT : nvapi.h
  • NV_DP_COLORIMETRY : nvapi.h
  • NV_DP_DYNAMIC_RANGE : nvapi.h
  • NV_DP_LANE_COUNT : nvapi.h
  • NV_DP_LINK_RATE : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO : nvapi.h
  • NV_DYNAMIC_RANGE : nvapi.h
  • NV_ECC_CONFIGURATION : nvapi.h
  • NV_EDID : nvapi.h
  • NV_FASTGS_FLAGS : nvapi.h
  • NV_FORMAT : nvapi.h
  • NV_FRUSTUM_ADJUST_MODE : nvapi.h
  • NV_GPU_BUS_TYPE : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES : nvapi.h
  • NV_GPU_CONNECTOR_TYPE : nvapi.h
  • NV_GPU_DISPLAYIDS : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • NV_GPU_OUTPUT_TYPE : nvapi.h
  • NV_GPU_PERF_PSTATE_ID : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_V2 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO : nvapi.h
  • NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS : nvapi.h
  • NV_GPU_TYPE : nvapi.h
  • NV_GSYNC_CAPABILITIES : nvapi.h
  • NV_GSYNC_CAPABILITIES_V1 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS : nvapi.h
  • NV_GSYNC_DELAY : nvapi.h
  • NV_GSYNC_DISPLAY : nvapi.h
  • NV_GSYNC_GPU : nvapi.h
  • NV_GSYNC_STATUS : nvapi.h
  • NV_GSYNC_STATUS_PARAMS : nvapi.h
  • NV_HDMI_SUPPORT_INFO : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V2 : nvapi.h
  • NV_I2C_INFO : nvapi.h
  • NV_MONITOR_CAPABILITIES : nvapi.h
  • NV_MONITOR_CAPABILITIES_V1 : nvapi.h
  • NV_MONITOR_CAPS_VCDB : nvapi.h
  • NV_MONITOR_CAPS_VSDB : nvapi.h
  • NV_MONITOR_COLOR_CAPS : nvapi.h
  • NV_MONITOR_COLOR_CAPS_V1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V2 : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 : nvapi.h
  • NV_PIXEL_SHIFT_TYPE : nvapi.h
  • NV_POSITION : nvapi.h
  • NV_PSO_EXTENSION : nvapi.h
  • NV_RECT : nvapi_lite_common.h
  • NV_RESOLUTION : nvapi.h
  • NV_ROTATE : nvapi.h
  • NV_SCALING : nvapi.h
  • NV_SCANOUT_INFORMATION : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_DATA : nvapi.h
  • NV_SCANOUT_WARPING_STATE_DATA : nvapi.h
  • NV_STEREO_ACTIVE_EYE : nvapi_lite_stereo.h
  • NV_STEREO_DRIVER_MODE : nvapi_lite_stereo.h
  • NV_STEREO_REGISTRY_ID : nvapi.h
  • NV_STEREO_REGISTRY_PROFILE_TYPE : nvapi.h
  • NV_STEREO_SWAPCHAIN_MODE : nvapi.h
  • NV_STEREO_VIDEO_FORMAT : nvapi.h
  • NV_SWIZZLE_MODE : nvapi.h
  • NV_SWIZZLE_OFFSET : nvapi.h
  • NV_TARGET_VIEW_MODE : nvapi.h
  • NV_TIMING : nvapi.h
  • NV_TIMING_INPUT : nvapi.h
  • NV_TIMING_OVERRIDE : nvapi.h
  • NV_TIMINGEXT : nvapi.h
  • NV_VIO_TOPOLOGY : nvapi.h
  • NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • NvAPI_D3D11_RASTERIZER_DESC_EX : nvapi.h
  • NvAPI_D3D11_SWIZZLE_MODE : nvapi.h
  • NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC : nvapi.h
  • NVAPI_D3D12_PSO_EXTENSION_DESC : nvapi.h
  • NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC : nvapi.h
  • NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC : nvapi.h
  • NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • NVAPI_GPU_PERF_DECREASE : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • NVAPI_GSYNC_POLARITY : nvapi.h
  • NVAPI_GSYNC_RJ45_IO : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • NvAPI_LongString : nvapi_lite_common.h
  • NvAPI_LPCWSTR : nvapi.h
  • NVAPI_OGLEXPERT_CALLBACK : nvapi.h
  • NvAPI_ShortString : nvapi_lite_common.h
  • NvAPI_Status : nvapi_lite_common.h
  • NVAPI_STEREO_CAPS : nvapi.h
  • NVAPI_STEREO_CAPS_V1 : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • NvAPI_String : nvapi_lite_common.h
  • NvAPI_UnicodeString : nvapi.h
  • NvBool : nvapi_lite_common.h
  • NVDRS_APPLICATION : nvapi.h
  • NVDRS_APPLICATION_V1 : nvapi.h
  • NVDRS_APPLICATION_V2 : nvapi.h
  • NVDRS_APPLICATION_V3 : nvapi.h
  • NVDRS_BINARY_SETTING : nvapi.h
  • NVDRS_GPU_SUPPORT : nvapi.h
  • NVDRS_PROFILE : nvapi.h
  • NVDRS_PROFILE_V1 : nvapi.h
  • NVDRS_SETTING : nvapi.h
  • NVDRS_SETTING_LOCATION : nvapi.h
  • NVDRS_SETTING_TYPE : nvapi.h
  • NVDRS_SETTING_V1 : nvapi.h
  • NVDRS_SETTING_VALUES : nvapi.h
  • NvS16 : nvapi_lite_common.h
  • NvS32 : nvapi_lite_common.h
  • NvS64 : nvapi_lite_common.h
  • NvS8 : nvapi_lite_common.h
  • NvU16 : nvapi_lite_common.h
  • NvU32 : nvapi_lite_common.h
  • NvU64 : nvapi_lite_common.h
  • NvU8 : nvapi_lite_common.h
  • NVVIOANCPARITYCOMPUTATION : nvapi.h
  • NVVIOBITSPERCOMPONENT : nvapi.h
  • NVVIOCAPS : nvapi.h
  • NVVIOCAPTURESTATUS : nvapi.h
  • NVVIOCHANNELSTATUS : nvapi.h
  • NVVIOCOLORCONVERSION : nvapi.h
  • NVVIOCOLORSPACE : nvapi.h
  • NVVIOCOMPONENTSAMPLING : nvapi.h
  • NVVIOCOMPOSITERANGE : nvapi.h
  • NVVIOCOMPSYNCTYPE : nvapi.h
  • NVVIOCONFIG : nvapi.h
  • NVVIOCONFIG_V1 : nvapi.h
  • NVVIOCONFIG_V2 : nvapi.h
  • NVVIOCONFIG_V3 : nvapi.h
  • NVVIOCONFIGTYPE : nvapi.h
  • NVVIODATAFORMAT : nvapi.h
  • NVVIODATAFORMATDETAIL : nvapi.h
  • NVVIOGAMMACORRECTION : nvapi.h
  • NVVIOGAMMARAMP10 : nvapi.h
  • NVVIOGAMMARAMP8 : nvapi.h
  • NVVIOINPUTCONFIG : nvapi.h
  • NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • NVVIOINPUTSTATUS : nvapi.h
  • NVVIOINTERLACEMODE : nvapi.h
  • NVVIOLINKID : nvapi.h
  • NVVIOOUTPUTAREA : nvapi.h
  • NVVIOOUTPUTCONFIG : nvapi.h
  • NVVIOOUTPUTCONFIG_V1 : nvapi.h
  • NVVIOOUTPUTCONFIG_V2 : nvapi.h
  • NVVIOOUTPUTCONFIG_V3 : nvapi.h
  • NVVIOOUTPUTREGION : nvapi.h
  • NVVIOOUTPUTSTATUS : nvapi.h
  • NVVIOOWNERID : nvapi.h
  • NVVIOOWNERTYPE : nvapi.h
  • NVVIOPCIINFO : nvapi.h
  • NVVIOPCIINFO_V1 : nvapi.h
  • NVVIOPCILINKRATE : nvapi.h
  • NVVIOPCILINKWIDTH : nvapi.h
  • NVVIOSIGNALFORMAT : nvapi.h
  • NVVIOSIGNALFORMATDETAIL : nvapi.h
  • NVVIOSTATUS : nvapi.h
  • NVVIOSTATUSTYPE : nvapi.h
  • NVVIOSTREAM : nvapi.h
  • NVVIOSYNCDELAY : nvapi.h
  • NVVIOSYNCSOURCE : nvapi.h
  • NVVIOSYNCSTATUS : nvapi.h
  • NVVIOTOPOLOGY : nvapi.h
  • NVVIOVIDEOMODE : nvapi.h
  • NVVIOVIDEOSTANDARD : nvapi.h
  • NVVIOVIDEOTYPE : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • n
  • p
  • s
  • t

- p -

  • PNV_MULTIGPU_CAPS : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • n
  • p
  • s
  • t

- s -

  • SettingDWORDNameString : NvApiDriverSettings.h
  • SettingWSTRINGNameString : NvApiDriverSettings.h
  • StereoHandle : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • n
  • p
  • s
  • t

- t -

  • temp_NvU32 : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • e
  • n

- _ -

  • _IMPLICIT_SLI_CONTROL : nvapi.h
  • _NV_BPC : nvapi.h
  • _NV_DISPLAY_TV_FORMAT : nvapi.h
  • _NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • _NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • _NV_DP_BPC : nvapi.h
  • _NV_DP_COLOR_FORMAT : nvapi.h
  • _NV_DP_COLORIMETRY : nvapi.h
  • _NV_DP_DYNAMIC_RANGE : nvapi.h
  • _NV_DP_LANE_COUNT : nvapi.h
  • _NV_DP_LINK_RATE : nvapi.h
  • _NV_DYNAMIC_RANGE : nvapi.h
  • _NV_ECC_CONFIGURATION : nvapi.h
  • _NV_FASTGS_FLAGS : nvapi.h
  • _NV_FORMAT : nvapi.h
  • _NV_FrustumAdjustMode : nvapi.h
  • _NV_GPU_BUS_TYPE : nvapi.h
  • _NV_GPU_CONNECTOR_TYPE : nvapi.h
  • _NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • _NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • _NV_GPU_OUTPUT_TYPE : nvapi.h
  • _NV_GPU_PERF_PSTATE_ID : nvapi.h
  • _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • _NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • _NV_GPU_TYPE : nvapi.h
  • _NV_PIXEL_SHIFT_TYPE : nvapi.h
  • _NV_PSO_EXTENSION : nvapi.h
  • _NV_ROTATE : nvapi.h
  • _NV_SCALING : nvapi.h
  • _NV_STEREO_VIDEO_FORMAT : nvapi.h
  • _NV_StereoActiveEye : nvapi_lite_stereo.h
  • _NV_StereoDriverMode : nvapi_lite_stereo.h
  • _NV_StereoRegistryID : nvapi.h
  • _NV_StereoRegistryProfileType : nvapi.h
  • _NV_StereoSwapChainMode : nvapi.h
  • _NV_SWIZZLE_MODE : nvapi.h
  • _NV_SWIZZLE_OFFSET : nvapi.h
  • _NV_TARGET_VIEW_MODE : nvapi.h
  • _NV_TIMING_OVERRIDE : nvapi.h
  • _NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • _NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • _NVAPI_GPU_PERF_DECREASE : nvapi.h
  • _NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • _NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • _NVAPI_GSYNC_POLARITY : nvapi.h
  • _NVAPI_GSYNC_RJ45_IO : nvapi.h
  • _NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • _NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • _NvAPI_Status : nvapi_lite_common.h
  • _NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • _NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • _NVDRS_SETTING_LOCATION : nvapi.h
  • _NVDRS_SETTING_TYPE : nvapi.h
  • _NVVIOANCPARITYCOMPUTATION : nvapi.h
  • _NVVIOBITSPERCOMPONENT : nvapi.h
  • _NVVIOCAPTURESTATUS : nvapi.h
  • _NVVIOCOLORSPACE : nvapi.h
  • _NVVIOCOMPONENTSAMPLING : nvapi.h
  • _NVVIOCOMPSYNCTYPE : nvapi.h
  • _NVVIOCONFIGTYPE : nvapi.h
  • _NVVIODATAFORMAT : nvapi.h
  • _NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • _NVVIOINTERLACEMODE : nvapi.h
  • _NVVIOLINKID : nvapi.h
  • _NVVIOOUTPUTAREA : nvapi.h
  • _NVVIOOWNERTYPE : nvapi.h
  • _NVVIOPCILINKRATE : nvapi.h
  • _NVVIOPCILINKWIDTH : nvapi.h
  • _NVVIOSIGNALFORMAT : nvapi.h
  • _NVVIOSTATUSTYPE : nvapi.h
  • _NVVIOSYNCSOURCE : nvapi.h
  • _NVVIOSYNCSTATUS : nvapi.h
  • _NVVIOVIDEOSTANDARD : nvapi.h
  • _NVVIOVIDEOTYPE : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • e
  • n

- e -

  • ESetting : NvApiDriverSettings.h
  • EValues_AA_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_AA_MODE_ALPHATOCOVERAGE : NvApiDriverSettings.h
  • EValues_AA_MODE_GAMMACORRECTION : NvApiDriverSettings.h
  • EValues_AA_MODE_METHOD : NvApiDriverSettings.h
  • EValues_AA_MODE_REPLAY : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR_SLIAA : NvApiDriverSettings.h
  • EValues_ANISO_MODE_LEVEL : NvApiDriverSettings.h
  • EValues_ANISO_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_AO_MODE : NvApiDriverSettings.h
  • EValues_AO_MODE_ACTIVE : NvApiDriverSettings.h
  • EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT : NvApiDriverSettings.h
  • EValues_AUTO_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_CPL_HIDDEN_PROFILE : NvApiDriverSettings.h
  • EValues_EXPORT_PERF_COUNTERS : NvApiDriverSettings.h
  • EValues_FXAA_ALLOW : NvApiDriverSettings.h
  • EValues_FXAA_ENABLE : NvApiDriverSettings.h
  • EValues_FXAA_INDICATOR_ENABLE : NvApiDriverSettings.h
  • EValues_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_MAXWELL_B_SAMPLE_INTERLEAVE : NvApiDriverSettings.h
  • EValues_MCSFRSHOWSPLIT : NvApiDriverSettings.h
  • EValues_NLS_ALLOW : NvApiDriverSettings.h
  • EValues_NLS_ENABLE : NvApiDriverSettings.h
  • EValues_NV_QUALITY_UPSCALING : NvApiDriverSettings.h
  • EValues_OGL_AA_LINE_GAMMA : NvApiDriverSettings.h
  • EValues_OGL_DEEP_COLOR_SCANOUT : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN : NvApiDriverSettings.h
  • EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD : NvApiDriverSettings.h
  • EValues_OGL_FORCE_BLIT : NvApiDriverSettings.h
  • EValues_OGL_FORCE_STEREO : NvApiDriverSettings.h
  • EValues_OGL_MULTIMON : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_PIXEL_TYPE : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_SUPPORT : NvApiDriverSettings.h
  • EValues_OGL_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_OGL_SINGLE_BACKDEPTH_BUFFER : NvApiDriverSettings.h
  • EValues_OGL_SLI_MULTICAST : NvApiDriverSettings.h
  • EValues_OGL_THREAD_CONTROL : NvApiDriverSettings.h
  • EValues_OGL_TRIPLE_BUFFER : NvApiDriverSettings.h
  • EValues_OGL_VIDEO_EDITING_MODE : NvApiDriverSettings.h
  • EValues_OPTIMUS_MAXAA : NvApiDriverSettings.h
  • EValues_PHYSXINDICATOR : NvApiDriverSettings.h
  • EValues_PREFERRED_PSTATE : NvApiDriverSettings.h
  • EValues_PRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_PREVENT_UI_AF_OVERRIDE : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_LIMITER : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_LIMITER_2_CONTROL : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_LIMITER_GPS_CTRL : NvApiDriverSettings.h
  • EValues_PS_FRAMERATE_MONITOR_CTRL : NvApiDriverSettings.h
  • EValues_PS_SHADERDISKCACHE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_ANISO_OPTS2 : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_BILINEAR_IN_ANISO : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_NO_NEG_LODBIAS : NvApiDriverSettings.h
  • EValues_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_REFRESH_RATE_OVERRIDE : NvApiDriverSettings.h
  • EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE : NvApiDriverSettings.h
  • EValues_SET_VAB_DATA : NvApiDriverSettings.h
  • EValues_SHIM_MCCOMPAT : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_OPTIONS : NvApiDriverSettings.h
  • EValues_SLI_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT_DX10 : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE_DX10 : NvApiDriverSettings.h
  • EValues_SLI_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_VRPRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE_REQUEST_STATE : NvApiDriverSettings.h
  • EValues_VRR_MODE : NvApiDriverSettings.h
  • EValues_VRRFEATUREINDICATOR : NvApiDriverSettings.h
  • EValues_VRROVERLAYINDICATOR : NvApiDriverSettings.h
  • EValues_VRRREQUESTSTATE : NvApiDriverSettings.h
  • EValues_VSYNC_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_VSYNCMODE : NvApiDriverSettings.h
  • EValues_VSYNCSMOOTHAFR : NvApiDriverSettings.h
  • EValues_VSYNCTEARCONTROL : NvApiDriverSettings.h
  • EValues_VSYNCVRRCONTROL : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_EYES_EXCHANGE : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_MODE : NvApiDriverSettings.h
  • EValues_WKS_MEMORY_ALLOCATION_POLICY : NvApiDriverSettings.h
  • EValues_WKS_STEREO_DONGLE_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SWAP_MODE : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • e
  • n

- n -

  • NV_CHIPSET_INFO_FLAGS : nvapi.h
  • NV_COLOR_CMD : nvapi.h
  • NV_COLOR_COLORIMETRY : nvapi.h
  • NV_COLOR_FORMAT : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE : nvapi.h
  • NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT : nvapi.h
  • NV_I2C_SPEED : nvapi.h
  • NV_INFOFRAME_CMD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE : nvapi.h
  • NV_MONITOR_CAPS_TYPE : nvapi.h
  • NV_MONITOR_CONN_TYPE : nvapi.h
  • NV_MOSAIC_TOPO : nvapi.h
  • NV_MOSAIC_TOPO_TYPE : nvapi.h
  • NV_SYSTEM_TYPE : nvapi.h
  • NV_THERMAL_CONTROLLER : nvapi.h
  • NV_THERMAL_TARGET : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG : nvapi.h
  • NVAPI_DEVICE_FEATURE_LEVEL : nvapi_lite_d3dext.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK : nvapi.h
  • NVAPI_QUAD_FILLMODE : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- a -

  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_CPLAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_SLIAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MASK : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_ID : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_ON : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ID : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MASK : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MAX : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_OFF : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_ALWAYS : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_IF_FOS : NvApiDriverSettings.h
  • AA_MODE_METHOD_6X_CT : NvApiDriverSettings.h
  • AA_MODE_METHOD_CORRUPTION_CHECK : NvApiDriverSettings.h
  • AA_MODE_METHOD_COUNT : NvApiDriverSettings.h
  • AA_MODE_METHOD_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x03 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x04 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x08 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x09 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x11 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x14 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x15 : NvApiDriverSettings.h
  • AA_MODE_METHOD_ID : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MASK : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MAX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_128X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_32X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_64X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_NONE : NvApiDriverSettings.h
  • AA_MODE_METHOD_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_H : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_V : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_32X_8v24 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_8X_4v4 : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DISALLOW_TRAA : NvApiDriverSettings.h
  • AA_MODE_REPLAY_ID : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALPHA_TEST : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_DYN_BRANCH : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OPTIMAL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_PIXEL_KILL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_EIGHT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_FOUR : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_ONE : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_TWO : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_APP_CONTROL : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_OVERRIDE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DISABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ENABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_ID : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MASK : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MAX : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_LINEAR : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_POINT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_APP : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_COND : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_USER : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DISABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ENABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ID : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_HIGH : NvApiDriverSettings.h
  • AO_MODE_ID : NvApiDriverSettings.h
  • AO_MODE_LOW : NvApiDriverSettings.h
  • AO_MODE_MEDIUM : NvApiDriverSettings.h
  • AO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_OFF : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_ID : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ID : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_OFF : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- c -

  • CPL_HIDDEN_PROFILE_DEFAULT : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_DISABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ENABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ID : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_NUM_VALUES : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_ID : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- d -

  • D3DOGL_GPU_MAX_POWER_ID : NvApiDriverSettings.h
  • DISABLE_IMPLICIT_SLI : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- e -

  • ENABLE_IMPLICIT_SLI : nvapi.h
  • EXPORT_PERF_COUNTERS_DEFAULT : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ID : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_NUM_VALUES : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_OFF : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- f -

  • FXAA_ALLOW_ALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_DEFAULT : NvApiDriverSettings.h
  • FXAA_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_ID : NvApiDriverSettings.h
  • FXAA_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_ENABLE_ON : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- i -

  • ICAFE_LOGO_CONFIG_ID : NvApiDriverSettings.h
  • INVALID_SETTING_ID : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- l -

  • LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • LODBIASADJUST_ID : NvApiDriverSettings.h
  • LODBIASADJUST_MAX : NvApiDriverSettings.h
  • LODBIASADJUST_MIN : NvApiDriverSettings.h
  • LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- m -

  • MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ID : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_OFF : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ON : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DEFAULT : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DISABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ENABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ID : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- n -

  • NLS_ALLOW_ALLOWED : NvApiDriverSettings.h
  • NLS_ALLOW_DEFAULT : NvApiDriverSettings.h
  • NLS_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • NLS_ALLOW_ID : NvApiDriverSettings.h
  • NLS_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • NLS_ENABLE_DEFAULT : NvApiDriverSettings.h
  • NLS_ENABLE_ID : NvApiDriverSettings.h
  • NLS_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • NLS_ENABLE_OFF : NvApiDriverSettings.h
  • NLS_ENABLE_ON : NvApiDriverSettings.h
  • NV_BPC_10 : nvapi.h
  • NV_BPC_12 : nvapi.h
  • NV_BPC_16 : nvapi.h
  • NV_BPC_6 : nvapi.h
  • NV_BPC_8 : nvapi.h
  • NV_BPC_DEFAULT : nvapi.h
  • NV_CHIPSET_INFO_HYBRID : nvapi.h
  • NV_COLOR_CMD_GET : nvapi.h
  • NV_COLOR_CMD_GET_DEFAULT : nvapi.h
  • NV_COLOR_CMD_IS_SUPPORTED_COLOR : nvapi.h
  • NV_COLOR_CMD_SET : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBERGB : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_AUTO : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020cYCC : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020YCC : nvapi.h
  • NV_COLOR_COLORIMETRY_DEFAULT : nvapi.h
  • NV_COLOR_COLORIMETRY_RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_SYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC709 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC709 : nvapi.h
  • NV_COLOR_FORMAT_AUTO : nvapi.h
  • NV_COLOR_FORMAT_DEFAULT : nvapi.h
  • NV_COLOR_FORMAT_RGB : nvapi.h
  • NV_COLOR_FORMAT_YUV420 : nvapi.h
  • NV_COLOR_FORMAT_YUV422 : nvapi.h
  • NV_COLOR_FORMAT_YUV444 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ANY : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_480p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_576p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_NONE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_480i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_576i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCJ : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALBDGH : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALN : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALNC : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 : nvapi.h
  • NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED : nvapi.h
  • NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION : nvapi.h
  • NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_HORIZONTAL : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_NONE : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_VERTICAL : nvapi.h
  • NV_DISPLAYCONFIG_VALIDATE_ONLY : nvapi.h
  • NV_DP_1_62GBPS : nvapi.h
  • NV_DP_1_LANE : nvapi.h
  • NV_DP_2_70GBPS : nvapi.h
  • NV_DP_2_LANE : nvapi.h
  • NV_DP_4_LANE : nvapi.h
  • NV_DP_5_40GBPS : nvapi.h
  • NV_DP_8_10GBPS : nvapi.h
  • NV_DP_BPC_10 : nvapi.h
  • NV_DP_BPC_12 : nvapi.h
  • NV_DP_BPC_16 : nvapi.h
  • NV_DP_BPC_6 : nvapi.h
  • NV_DP_BPC_8 : nvapi.h
  • NV_DP_BPC_DEFAULT : nvapi.h
  • NV_DP_COLOR_FORMAT_RGB : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr422 : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr444 : nvapi.h
  • NV_DP_COLORIMETRY_RGB : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU601 : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU709 : nvapi.h
  • NV_DP_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DP_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_DYNAMIC_RANGE_AUTO : nvapi.h
  • NV_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_ECC_CONFIGURATION_DEFERRED : nvapi.h
  • NV_ECC_CONFIGURATION_IMMEDIATE : nvapi.h
  • NV_ECC_CONFIGURATION_NOT_SUPPORTED : nvapi.h
  • NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX : nvapi.h
  • NV_FASTGS_STRICT_API_ORDER : nvapi.h
  • NV_FASTGS_USE_VIEWPORT_MASK : nvapi.h
  • NV_FORMAT_A16B16G16R16F : nvapi.h
  • NV_FORMAT_A8R8G8B8 : nvapi.h
  • NV_FORMAT_P8 : nvapi.h
  • NV_FORMAT_R5G6B5 : nvapi.h
  • NV_FORMAT_UNKNOWN : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_DISABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_ENABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_FUSES : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_I2C_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_NONE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_SBIOS : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_UNKNOWN : nvapi.h
  • NV_GPU_IA_LOGO_BRIGHTNESS : nvapi.h
  • NV_GPU_IA_SLI_BRIGHTNESS : nvapi.h
  • NV_GPU_PERF_DECREASE_NONE : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_AC_BATT : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_UNKNOWN : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ : nvapi.h
  • NV_INFOFRAME_CMD_GET : nvapi.h
  • NV_INFOFRAME_CMD_GET_DEFAULT : nvapi.h
  • NV_INFOFRAME_CMD_GET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_GET_PROPERTY : nvapi.h
  • NV_INFOFRAME_CMD_RESET : nvapi.h
  • NV_INFOFRAME_CMD_SET : nvapi.h
  • NV_INFOFRAME_CMD_SET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_SET_PROPERTY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03 : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_AUTO : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_DISABLE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ENABLE : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VCDB : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VSDB : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPONENT : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPOSITE : nvapi.h
  • NV_MONITOR_CONN_TYPE_DP : nvapi.h
  • NV_MONITOR_CONN_TYPE_DVI : nvapi.h
  • NV_MONITOR_CONN_TYPE_HDMI : nvapi.h
  • NV_MONITOR_CONN_TYPE_LVDS : nvapi.h
  • NV_MONITOR_CONN_TYPE_SVIDEO : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNINITIALIZED : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNKNOWN : nvapi.h
  • NV_MONITOR_CONN_TYPE_VGA : nvapi.h
  • NV_MOSAIC_TOPO_1x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x5_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x6_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_3x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_4x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_7x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_END_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_END_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_MAX : nvapi.h
  • NV_MOSAIC_TOPO_NONE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_ALL : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_MAX : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_SCALED_CLONE : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT : nvapi.h
  • NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION : nvapi.h
  • NV_PSO_EXPLICIT_FASTGS_EXTENSION : nvapi.h
  • NV_PSO_RASTER_EXTENSION : nvapi.h
  • NV_PSO_REQUEST_FASTGS_EXTENSION : nvapi.h
  • NV_QUALITY_UPSCALING_DEFAULT : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ID : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_NUM_VALUES : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_OFF : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ON : NvApiDriverSettings.h
  • NV_ROTATE_0 : nvapi.h
  • NV_ROTATE_180 : nvapi.h
  • NV_ROTATE_270 : nvapi.h
  • NV_ROTATE_90 : nvapi.h
  • NV_ROTATE_IGNORED : nvapi.h
  • NV_SCALING_ADAPTER_SCALING : nvapi.h
  • NV_SCALING_ASPECT_SCALING : nvapi.h
  • NV_SCALING_CENTERED : nvapi.h
  • NV_SCALING_CUSTOMIZED : nvapi.h
  • NV_SCALING_DEFAULT : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_MONITOR_SCALING : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_LAST : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_NOT_STEREO : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR : nvapi.h
  • NV_SWIZZLE_NEG_W : nvapi.h
  • NV_SWIZZLE_NEG_X : nvapi.h
  • NV_SWIZZLE_NEG_Y : nvapi.h
  • NV_SWIZZLE_NEG_Z : nvapi.h
  • NV_SWIZZLE_OFFSET_W : nvapi.h
  • NV_SWIZZLE_OFFSET_X : nvapi.h
  • NV_SWIZZLE_OFFSET_Y : nvapi.h
  • NV_SWIZZLE_OFFSET_Z : nvapi.h
  • NV_SWIZZLE_POS_W : nvapi.h
  • NV_SWIZZLE_POS_X : nvapi.h
  • NV_SWIZZLE_POS_Y : nvapi.h
  • NV_SWIZZLE_POS_Z : nvapi.h
  • NV_SYSTEM_TYPE_DESKTOP : nvapi.h
  • NV_SYSTEM_TYPE_DGPU : nvapi.h
  • NV_SYSTEM_TYPE_GPU_UNKNOWN : nvapi.h
  • NV_SYSTEM_TYPE_IGPU : nvapi.h
  • NV_SYSTEM_TYPE_LAPTOP : nvapi.h
  • NV_SYSTEM_TYPE_UNKNOWN : nvapi.h
  • NV_TIMING_OVERRIDE_ANALOG_TV : nvapi.h
  • NV_TIMING_OVERRIDE_AUTO : nvapi.h
  • NV_TIMING_OVERRIDE_CURRENT : nvapi.h
  • NV_TIMING_OVERRIDE_CUST : nvapi.h
  • NV_TIMING_OVERRIDE_CVT : nvapi.h
  • NV_TIMING_OVERRIDE_CVT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_DMT : nvapi.h
  • NV_TIMING_OVERRIDE_DMT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_EDID : nvapi.h
  • NV_TIMING_OVERRIDE_EIA861 : nvapi.h
  • NV_TIMING_OVERRIDE_GTF : nvapi.h
  • NV_TIMING_OVERRIDE_NV_ASPR : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PREDEFINED : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PSF : nvapi.h
  • NV_TIMING_OVERRIDE_SDI : nvapi.h
  • NV_TIMING_OVRRIDE_MAX : nvapi.h
  • NV_VIEW_MODE_CLONE : nvapi.h
  • NV_VIEW_MODE_DUALVIEW : nvapi.h
  • NV_VIEW_MODE_HSPAN : nvapi.h
  • NV_VIEW_MODE_MULTIVIEW : nvapi.h
  • NV_VIEW_MODE_STANDARD : nvapi.h
  • NV_VIEW_MODE_VSPAN : nvapi.h
  • NVAPI_ACCESS_DENIED : nvapi_lite_common.h
  • NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED : nvapi_lite_common.h
  • NVAPI_ALIAS_SURFACE_FLAG_MASK : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_NONE : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER : nvapi.h
  • NVAPI_API_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_ARGUMENT_EXCEED_MAX_SIZE : nvapi_lite_common.h
  • NVAPI_CLUSTER_ALREADY_EXISTS : nvapi_lite_common.h
  • NVAPI_CONVERGENCE_ID : nvapi.h
  • NVAPI_D3D10_1_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_D3D11_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI : nvapi.h
  • NVAPI_D3D_DEVICE_LOST : nvapi_lite_common.h
  • NVAPI_D3D_DEVICE_NOT_REGISTERED : nvapi_lite_common.h
  • NVAPI_D3D_RR_FLAG_DEFAULTS : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_MULTI_FRAME : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_CATEGORY_SLI : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE : nvapi_lite_sli.h
  • NVAPI_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_DATATYPE_MISMATCH : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED : nvapi_lite_common.h
  • NVAPI_DEVICE_BUSY : nvapi_lite_common.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_1 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_11_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_NULL : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_SWITCHING_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_DISPLAYCONFIG_VALIDATION_FAILED : nvapi_lite_common.h
  • NVAPI_DPMST_CHANGED : nvapi_lite_common.h
  • NVAPI_DPMST_DISPLAY_ID_EXPECTED : nvapi_lite_common.h
  • NVAPI_DRIVER_NOTRUNNING : nvapi_lite_common.h
  • NVAPI_DRIVER_RUNNING : nvapi_lite_common.h
  • NVAPI_ECID_KEY_VERIFICATION_FAILED : nvapi_lite_common.h
  • NVAPI_ECID_SIGN_ALGO_UNSUPPORTED : nvapi_lite_common.h
  • NVAPI_END_ENUMERATION : nvapi_lite_common.h
  • NVAPI_ERROR : nvapi_lite_common.h
  • NVAPI_ERROR_DRIVER_RELOAD_REQUIRED : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_ALREADY_IN_USE : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS : nvapi_lite_common.h
  • NVAPI_EXPECTED_ANALOG_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_COMPUTE_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_DIGITAL_FLAT_PANEL : nvapi_lite_common.h
  • NVAPI_EXPECTED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_LOGICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR : nvapi_lite_common.h
  • NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_FIRMWARE_OUT_OF_DATE : nvapi_lite_common.h
  • NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_FRUSTUM_ADJUST_MODE_ID : nvapi.h
  • NVAPI_FRUSTUM_CLEAR_EDGES : nvapi.h
  • NVAPI_FRUSTUM_STRETCH : nvapi.h
  • NVAPI_FUNCTION_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_GPU_BUS_TYPE_AGP : nvapi.h
  • NVAPI_GPU_BUS_TYPE_AXI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_FPCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI_EXPRESS : nvapi.h
  • NVAPI_GPU_BUS_TYPE_UNDEFINED : nvapi.h
  • NVAPI_GPU_CONNECTOR_ADC : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_D : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_A : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_C_MINI : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_OEM : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_SPWG : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SCART : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_UNKNOWN : nvapi.h
  • NVAPI_GPU_CONNECTOR_VGA_15_PIN : nvapi.h
  • NVAPI_GPU_CONNECTOR_VIRTUAL_WFD : nvapi.h
  • NVAPI_GPU_OUTPUT_CRT : nvapi.h
  • NVAPI_GPU_OUTPUT_DFP : nvapi.h
  • NVAPI_GPU_OUTPUT_TV : nvapi.h
  • NVAPI_GPU_OUTPUT_UNKNOWN : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_ALL : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P0 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P1 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P10 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P11 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P12 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P13 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P14 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P15 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P2 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P3 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P4 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P5 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P6 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P7 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P8 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P9 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_UNDEFINED : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_MEMORY : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_VIDEO : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE : nvapi_lite_common.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_STARTUP : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_UNKNOWN : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY : nvapi.h
  • NVAPI_GSYNC_POLARITY_BOTH_EDGES : nvapi.h
  • NVAPI_GSYNC_POLARITY_FALLING_EDGE : nvapi.h
  • NVAPI_GSYNC_POLARITY_RISING_EDGE : nvapi.h
  • NVAPI_GSYNC_RJ45_INPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_OUTPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_UNUSED : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_VSYNC : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_COMPOSITE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_HDTV : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NONE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_TTL : nvapi.h
  • NVAPI_HANDLE_INVALIDATED : nvapi_lite_common.h
  • NVAPI_HDCP_ENCRYPTION_FAILED : nvapi_lite_common.h
  • NVAPI_I2C_SPEED_100KHZ : nvapi.h
  • NVAPI_I2C_SPEED_10KHZ : nvapi.h
  • NVAPI_I2C_SPEED_200KHZ : nvapi.h
  • NVAPI_I2C_SPEED_33KHZ : nvapi.h
  • NVAPI_I2C_SPEED_3KHZ : nvapi.h
  • NVAPI_I2C_SPEED_400KHZ : nvapi.h
  • NVAPI_I2C_SPEED_DEFAULT : nvapi.h
  • NVAPI_ID_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_AUDIO_DRIVER : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_STRUCT_VERSION : nvapi_lite_common.h
  • NVAPI_INSTRUMENTATION_DISABLED : nvapi_lite_common.h
  • NVAPI_INSUFFICIENT_BUFFER : nvapi_lite_common.h
  • NVAPI_INVALID_ADDRESS : nvapi_lite_common.h
  • NVAPI_INVALID_ARGUMENT : nvapi_lite_common.h
  • NVAPI_INVALID_CALL : nvapi_lite_common.h
  • NVAPI_INVALID_COMBINATION : nvapi_lite_common.h
  • NVAPI_INVALID_CONFIGURATION : nvapi_lite_common.h
  • NVAPI_INVALID_DISPLAY_ID : nvapi_lite_common.h
  • NVAPI_INVALID_HANDLE : nvapi_lite_common.h
  • NVAPI_INVALID_HYBRID_MODE : nvapi_lite_common.h
  • NVAPI_INVALID_PERF_LEVEL : nvapi_lite_common.h
  • NVAPI_INVALID_POINTER : nvapi_lite_common.h
  • NVAPI_INVALID_SYNC_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_INVALID_USER_PRIVILEGE : nvapi_lite_common.h
  • NVAPI_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED : nvapi_lite_common.h
  • NVAPI_MATCHING_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_MIXED_TARGET_TYPES : nvapi_lite_common.h
  • NVAPI_MODE_CHANGE_FAILED : nvapi_lite_common.h
  • NVAPI_MOSAIC_NOT_ACTIVE : nvapi_lite_common.h
  • NVAPI_NO_ACTIVE_SLI_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_NO_CONNECTOR_FOUND : nvapi_lite_common.h
  • NVAPI_NO_FRUSTUM_ADJUST : nvapi.h
  • NVAPI_NO_GL_EXPERT : nvapi_lite_common.h
  • NVAPI_NO_GL_NSIGHT : nvapi_lite_common.h
  • NVAPI_NO_IMPLEMENTATION : nvapi_lite_common.h
  • NVAPI_NO_VIDLINK : nvapi_lite_common.h
  • NVAPI_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_NV_PERSIST_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVIDIA_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_OK : nvapi_lite_common.h
  • NVAPI_OPENGL_CONTEXT_NOT_CURRENT : nvapi_lite_common.h
  • NVAPI_OUT_OF_MEMORY : nvapi_lite_common.h
  • NVAPI_PCLK_LIMITATION_FAILED : nvapi_lite_common.h
  • NVAPI_PERSIST_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PORTID_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PROFILE_NAME_EMPTY : nvapi_lite_common.h
  • NVAPI_PROFILE_NAME_IN_USE : nvapi_lite_common.h
  • NVAPI_PROFILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PROFILE_REMOVED : nvapi_lite_common.h
  • NVAPI_QUAD_FILLMODE_BBOX : nvapi.h
  • NVAPI_QUAD_FILLMODE_DISABLED : nvapi.h
  • NVAPI_QUAD_FILLMODE_FULL_VIEWPORT : nvapi.h
  • NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS : nvapi_lite_common.h
  • NVAPI_REQUEST_USER_TO_DISABLE_DWM : nvapi_lite_common.h
  • NVAPI_REQUIRES_REBOOT : nvapi_lite_common.h
  • NVAPI_RESOURCE_NOT_ACQUIRED : nvapi_lite_common.h
  • NVAPI_SET_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_SETTING_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SETTING_SIZE_TOO_LARGE : nvapi_lite_common.h
  • NVAPI_SHARE_RESOURCE_RELOCATED : nvapi_lite_common.h
  • NVAPI_SLI_RENDERING_MODE_NOTALLOWED : nvapi_lite_common.h
  • NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_DRIVER_MODE_AUTOMATIC : nvapi_lite_stereo.h
  • NVAPI_STEREO_DRIVER_MODE_DIRECT : nvapi_lite_stereo.h
  • NVAPI_STEREO_DX10_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_DX9_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_EYE_LEFT : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_MONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_RIGHT : nvapi_lite_stereo.h
  • NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_HANDSHAKE_NOT_DONE : nvapi_lite_common.h
  • NVAPI_STEREO_INIT_ACTIVATION_DELAYED : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE : nvapi_lite_common.h
  • NVAPI_STEREO_INVALID_DEVICE_INTERFACE : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_ENABLED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_TURNED_ON : nvapi_lite_common.h
  • NVAPI_STEREO_PARAMETER_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_ACCESS_FAILED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_SURFACECREATEMODE_AUTO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SWAPCHAIN_DEFAULT : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_MONO : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_STEREO : nvapi.h
  • NVAPI_STREAM_IS_OUT_OF_SYNC : nvapi_lite_common.h
  • NVAPI_STRING_TOO_SMALL : nvapi_lite_common.h
  • NVAPI_SYNC_MASTER_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SYNC_NOT_ACTIVE : nvapi_lite_common.h
  • NVAPI_SYSWOW64_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TESTING_CLOCKS_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_THERMAL_CONTROLLER_ADM1032 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_ADT7473 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM64 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM89 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM99 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX1617 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_NONE : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_OS : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_SBMAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_VBIOSEVT : nvapi.h
  • NVAPI_THERMAL_TARGET_ALL : nvapi.h
  • NVAPI_THERMAL_TARGET_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_GPU : nvapi.h
  • NVAPI_THERMAL_TARGET_MEMORY : nvapi.h
  • NVAPI_THERMAL_TARGET_NONE : nvapi.h
  • NVAPI_THERMAL_TARGET_POWER_SUPPLY : nvapi.h
  • NVAPI_THERMAL_TARGET_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_INLET : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_OUTLET : nvapi.h
  • NVAPI_TIMEOUT : nvapi_lite_common.h
  • NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO : nvapi_lite_common.h
  • NVAPI_TIMING_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TOO_MANY_SETTINGS_IN_PROFILE : nvapi_lite_common.h
  • NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS : nvapi_lite_common.h
  • NVAPI_TOPO_NOT_POSSIBLE : nvapi_lite_common.h
  • NVAPI_UNKNOWN_UNDERSCAN_CONFIG : nvapi_lite_common.h
  • NVAPI_UNREGISTERED_RESOURCE : nvapi_lite_common.h
  • NVAPI_VALUE_ALREADY_SET : nvapi_lite_common.h
  • NVAPI_WAS_STILL_DRAWING : nvapi_lite_common.h
  • NVDRS_BASE_PROFILE_LOCATION : nvapi.h
  • NVDRS_BINARY_TYPE : nvapi.h
  • NVDRS_CURRENT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DEFAULT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DWORD_TYPE : nvapi.h
  • NVDRS_GLOBAL_PROFILE_LOCATION : nvapi.h
  • NVDRS_STRING_TYPE : nvapi.h
  • NVDRS_WSTRING_TYPE : nvapi.h
  • NVINPUTOUTPUTSTATUS_ERROR : nvapi.h
  • NVINPUTOUTPUTSTATUS_OFF : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_HD : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_SD : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_AUTO : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_OFF : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_ON : nvapi.h
  • NVVIOBITSPERCOMPONENT_10 : nvapi.h
  • NVVIOBITSPERCOMPONENT_12 : nvapi.h
  • NVVIOBITSPERCOMPONENT_8 : nvapi.h
  • NVVIOBITSPERCOMPONENT_UNKNOWN : nvapi.h
  • NVVIOCOLORSPACE_GBR : nvapi.h
  • NVVIOCOLORSPACE_GBRA : nvapi.h
  • NVVIOCOLORSPACE_GBRD : nvapi.h
  • NVVIOCOLORSPACE_UNKNOWN : nvapi.h
  • NVVIOCOLORSPACE_YCBCR : nvapi.h
  • NVVIOCOLORSPACE_YCBCRA : nvapi.h
  • NVVIOCOLORSPACE_YCBCRD : nvapi.h
  • NVVIOCOMPONENTSAMPLING_422 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4224 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_UNKNOWN : nvapi.h
  • NVVIOCOMPSYNCTYPE_AUTO : nvapi.h
  • NVVIOCOMPSYNCTYPE_BILEVEL : nvapi.h
  • NVVIOCOMPSYNCTYPE_TRILEVEL : nvapi.h
  • NVVIOCONFIGTYPE_IN : nvapi.h
  • NVVIOCONFIGTYPE_OUT : nvapi.h
  • NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_RGB444 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444 : nvapi.h
  • NVVIODATAFORMAT_UNKNOWN : nvapi.h
  • NVVIODATAFORMAT_X10X10X10_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422 : nvapi.h
  • NVVIOINTERLACEMODE_INTERLACE : nvapi.h
  • NVVIOINTERLACEMODE_PROGRESSIVE : nvapi.h
  • NVVIOINTERLACEMODE_PSF : nvapi.h
  • NVVIOLINKID_A : nvapi.h
  • NVVIOLINKID_B : nvapi.h
  • NVVIOLINKID_C : nvapi.h
  • NVVIOLINKID_D : nvapi.h
  • NVVIOLINKID_UNKNOWN : nvapi.h
  • NVVIOOUTPUTAREA_FULLSIZE : nvapi.h
  • NVVIOOUTPUTAREA_SAFEACTION : nvapi.h
  • NVVIOOUTPUTAREA_SAFETITLE : nvapi.h
  • NVVIOOWNERTYPE_APPLICATION : nvapi.h
  • NVVIOOWNERTYPE_DESKTOP : nvapi.h
  • NVVIOOWNERTYPE_NONE : nvapi.h
  • NVVIOPCILINKRATE_GEN1 : nvapi.h
  • NVVIOPCILINKRATE_GEN2 : nvapi.h
  • NVVIOPCILINKRATE_GEN3 : nvapi.h
  • NVVIOPCILINKRATE_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH_x1 : nvapi.h
  • NVVIOPCILINKWIDTH_x16 : nvapi.h
  • NVVIOPCILINKWIDTH_x2 : nvapi.h
  • NVVIOPCILINKWIDTH_x4 : nvapi.h
  • NVVIOPCILINKWIDTH_x8 : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC : nvapi.h
  • NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL : nvapi.h
  • NVVIOSIGNALFORMAT_720P_23_98_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_24_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_25_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_29_97_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_30_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_50_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_59_94_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_60_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_END : nvapi.h
  • NVVIOSIGNALFORMAT_NONE : nvapi.h
  • NVVIOSTATUS_ERROR : nvapi.h
  • NVVIOSTATUS_RUNNING : nvapi.h
  • NVVIOSTATUS_STOPPED : nvapi.h
  • NVVIOSTATUSTYPE_IN : nvapi.h
  • NVVIOSTATUSTYPE_OUT : nvapi.h
  • NVVIOSYNCSOURCE_COMPSYNC : nvapi.h
  • NVVIOSYNCSOURCE_SDISYNC : nvapi.h
  • NVVIOSYNCSTATUS_COMPOSITE : nvapi.h
  • NVVIOSYNCSTATUS_ERROR : nvapi.h
  • NVVIOSYNCSTATUS_OFF : nvapi.h
  • NVVIOSYNCSTATUS_SDI_HD : nvapi.h
  • NVVIOSYNCSTATUS_SDI_SD : nvapi.h
  • NVVIOSYNCSTATUS_SYNCLOSS : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE259 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE260 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE274 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE295 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE296 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE372 : nvapi.h
  • NVVIOVIDEOTYPE_HD : nvapi.h
  • NVVIOVIDEOTYPE_SD : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- o -

  • OGL_AA_LINE_GAMMA_DEFAULT : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_DISABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ENABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ID : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MAX : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MIN : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DEFAULT : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DISABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ENABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ID : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DISABLE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_TEAR : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_ID : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ID : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_OFF : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ON : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ID : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_OFF : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ON : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ID : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_ID : NvApiDriverSettings.h
  • OGL_MULTIMON_COMPATIBILITY_GCD : NvApiDriverSettings.h
  • OGL_MULTIMON_COMPATIBILITY_LCD : NvApiDriverSettings.h
  • OGL_MULTIMON_DEFAULT : NvApiDriverSettings.h
  • OGL_MULTIMON_EXTENDED_SINGLE_MONITOR : NvApiDriverSettings.h
  • OGL_MULTIMON_ID : NvApiDriverSettings.h
  • OGL_MULTIMON_MULTIMON_BUFFER : NvApiDriverSettings.h
  • OGL_MULTIMON_NUM_VALUES : NvApiDriverSettings.h
  • OGL_MULTIMON_PERFORMANCE_GCD : NvApiDriverSettings.h
  • OGL_MULTIMON_PERFORMANCE_LCD : NvApiDriverSettings.h
  • OGL_MULTIMON_PERFORMANCE_QUADRO : NvApiDriverSettings.h
  • OGL_MULTIMON_SINGLE_MONITOR : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NONE : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_FORCE_SW : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_OFF : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ON : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HPERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HQUAL : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_PERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_QUAL : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ID : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ENABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_FORCE_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ID : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_NUM_VALUES : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DEFAULT : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DISABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ENABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ID : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DISABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ENABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ID : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_DEFAULT : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_DISABLE : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_ENABLE : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_ID : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_DEFAULT : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_ID : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MAX : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MIN : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- p -

  • PHYSXINDICATOR_DEFAULT : NvApiDriverSettings.h
  • PHYSXINDICATOR_DISABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ENABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ID : NvApiDriverSettings.h
  • PHYSXINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • PREFERRED_PSTATE_ADAPTIVE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DEFAULT : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DRIVER_CONTROLLED : NvApiDriverSettings.h
  • PREFERRED_PSTATE_ID : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MIN : NvApiDriverSettings.h
  • PREFERRED_PSTATE_NUM_VALUES : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MIN : NvApiDriverSettings.h
  • PRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • PRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • PRERENDERLIMIT_ID : NvApiDriverSettings.h
  • PRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • PRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • PRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ID : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_OFF : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ON : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_ALLOW_ALL_MAXWELL : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_AVOID_NOOP : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DEFAULT_FOR_GM10X : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_3D : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_DELAY_CE : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_FORCE_OFF : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ACCURATE : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ALLOW_WINDOWED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_DISABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_DISALLOWED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ENABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FORCE_OPTIMUS_POLICY : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FORCE_VSYNC_OFF : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FORCEON : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPS_20 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPS_30 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPS_40 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FPSMASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_FRL2 : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_DECREASE_FILTER_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_DISABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_INCREASE_FILTER_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_OPTIMAL_SETTING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PAUSE_TIME_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_PERF_STEP_SIZE_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_TARGET_RENDER_TIME_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_WEB : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_MODEMASK : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_OPENGL_REMOTE_DESKTOP : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_POWER : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_TEMPERATURE : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_THRESHOLD : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_USE_CPU_WAIT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_DEFAULT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_DISABLED : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_ENABLE_ON_VSYNC : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_30 : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_60 : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_FPS_USE_FRL : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_ID : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_MOVING_AVG_X_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_NUM_VALUES : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_OPTIMAL_SETTING : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_THRESHOLD_PCT_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_MASK : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_VSYNC_OFFSET_SHIFT : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_VSYNC_OPTIMAL_SETTING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DEFAULT : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_NUM_VALUES : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_OFF : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- q -

  • QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHPERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHQUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_PERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_QUALITY : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- r -

  • REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_ID : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- s -

  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON : NvApiDriverSettings.h
  • SET_VAB_DATA_DEFAULT : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_NAN : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_POS_INF : NvApiDriverSettings.h
  • SET_VAB_DATA_ID : NvApiDriverSettings.h
  • SET_VAB_DATA_NUM_VALUES : NvApiDriverSettings.h
  • SET_VAB_DATA_UINT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_USE_API_DEFAULTS : NvApiDriverSettings.h
  • SET_VAB_DATA_ZERO : NvApiDriverSettings.h
  • SHIM_MAXRES_ID : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_DEFAULT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ENABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ID : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_INTEGRATED : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_MASK : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ENABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_INTEGRATED : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_CUDA : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_EHSHELL_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED1 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED2 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- t -

  • TOTAL_DWORD_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_WSTRING_SETTING_NUM : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- v -

  • VRPRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_ID : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ULMB : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ULMB : NvApiDriverSettings.h
  • VRR_MODE_DEFAULT : NvApiDriverSettings.h
  • VRR_MODE_DISABLED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRR_MODE_ID : NvApiDriverSettings.h
  • VRR_MODE_NUM_VALUES : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ID : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ID : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DEFAULT : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DISABLED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRRREQUESTSTATE_ID : NvApiDriverSettings.h
  • VRRREQUESTSTATE_NUM_VALUES : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCMODE_DEFAULT : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL2 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL3 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL4 : NvApiDriverSettings.h
  • VSYNCMODE_FORCEOFF : NvApiDriverSettings.h
  • VSYNCMODE_FORCEON : NvApiDriverSettings.h
  • VSYNCMODE_ID : NvApiDriverSettings.h
  • VSYNCMODE_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCMODE_PASSIVE : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_DEFAULT : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ID : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_OFF : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ON : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ID : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ID : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NOTSUPPORTED : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- w -

  • WKS_API_STEREO_EYES_EXCHANGE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_OFF : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ON : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ANAGLYPH : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_INTERLEAVED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_LINE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT_GL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SEEFRONT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SHUTTER_GLASSES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SIDE_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STEREO_MIRROR : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SUB_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_MV : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_SL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TWINVIEW : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_USE_HW_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_VERTICAL_INTERLACED : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_AGGRESSIVE_PRE_ALLOCATION : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_AS_NEEDED : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_DEFAULT : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_ID : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_MODERATE_PRE_ALLOCATION : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DAC : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DLP : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ON : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_ID : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE_PAIR : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- _ -

  • __cdecl : nvapi.h
  • _NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • _NV_TARGET_VIEW_MODE_ : nvapi.h
  • _NVAPI_H : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- a -

  • AA_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_STRING : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_STRING : NvApiDriverSettings.h
  • AA_MODE_METHOD_STRING : NvApiDriverSettings.h
  • AA_MODE_REPLAY_STRING : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_STRING : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • ALL_GPUS : nvapi.h
  • ANISO_MODE_LEVEL_STRING : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_STRING : NvApiDriverSettings.h
  • AO_MODE_STRING : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_STRING : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- c -

  • CPL_HIDDEN_PROFILE_STRING : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_DEFAULT : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NONE : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NUM_VALUES : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- d -

  • D3DOGL_GPU_MAX_POWER_DEFAULT : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_DEFAULTPOWER : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_NUM_VALUES : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_STRING : NvApiDriverSettings.h
  • DISPLAYPORT_STRUCTS_DEFINED : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- e -

  • EXPORT_PERF_COUNTERS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- f -

  • FENCE_SYNCHRONIZATION_END : nvapi.h
  • FENCE_SYNCHRONIZATION_START : nvapi.h
  • FXAA_ALLOW_STRING : NvApiDriverSettings.h
  • FXAA_ENABLE_STRING : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- g -

  • GET_NVAPI_SIZE : nvapi_lite_common.h
  • GET_NVAPI_VERSION : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- i -

  • ICAFE_LOGO_CONFIG_STRING : NvApiDriverSettings.h
  • ID3D11MultiGPUDevice_VER : nvapi.h
  • ID3D11MultiGPUDevice_VER1 : nvapi.h
  • ID3D11MultiGPUDevice_VER2 : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- l -

  • LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- m -

  • MAKE_NVAPI_VERSION : nvapi_lite_common.h
  • MAX_NUM_COMPOSITE_RANGE : nvapi.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_STRING : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- n -

  • NLS_ALLOW_STRING : NvApiDriverSettings.h
  • NLS_ENABLE_STRING : NvApiDriverSettings.h
  • NV_BIT : nvapi_lite_common.h
  • NV_BOARD_INFO_VER : nvapi.h
  • NV_BOARD_INFO_VER1 : nvapi.h
  • NV_CHIPSET_INFO : nvapi.h
  • NV_CHIPSET_INFO_VER : nvapi.h
  • NV_CHIPSET_INFO_VER_1 : nvapi.h
  • NV_CHIPSET_INFO_VER_2 : nvapi.h
  • NV_CHIPSET_INFO_VER_3 : nvapi.h
  • NV_CHIPSET_INFO_VER_4 : nvapi.h
  • NV_COLOR_DATA_VER : nvapi.h
  • NV_COLOR_DATA_VER1 : nvapi.h
  • NV_COLOR_DATA_VER2 : nvapi.h
  • NV_COLOR_DATA_VER3 : nvapi.h
  • NV_CUSTOM_DISPLAY_VER : nvapi.h
  • NV_DECLARE_HANDLE : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_VERSION_VER : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER2 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER3 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER4 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_1 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_2 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER2 : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO_VER : nvapi.h
  • NV_EDID_DATA_SIZE : nvapi.h
  • NV_EDID_V1_DATA_SIZE : nvapi.h
  • NV_EDID_VER : nvapi.h
  • NV_EDID_VER1 : nvapi.h
  • NV_EDID_VER2 : nvapi.h
  • NV_EDID_VER3 : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_EXTN_ATOM_ADD : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MAX : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MIN : nvHLSLExtnsInternal.h
  • NV_EXTN_OP_FP16_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_FP32_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_LANE_ID : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_DOWN : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_UP : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_XOR : nvShaderExtnEnums.h
  • NV_EXTN_OP_TYPED_UAV_LOAD : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ALL : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ANY : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_BALLOT : nvShaderExtnEnums.h
  • NV_FALSE : nvapi_lite_common.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER : nvapi.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_GET_CURRENT_SLI_STATE_VER : nvapi_lite_sli.h
  • NV_GPU_CLOCK_FREQUENCIES_VER : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_1 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_2 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_3 : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_FAKE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_SLI : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_UNCACHED : nvapi.h
  • NV_GPU_DISPLAYIDS_VER : nvapi.h
  • NV_GPU_DISPLAYIDS_VER1 : nvapi.h
  • NV_GPU_DISPLAYIDS_VER2 : nvapi.h
  • NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER : nvapi.h
  • NV_GPU_ECC_CONFIGURATION_INFO_VER : nvapi.h
  • NV_GPU_ECC_ERROR_INFO_VER : nvapi.h
  • NV_GPU_ECC_STATUS_INFO_VER : nvapi.h
  • NV_GPU_GET_HDCP_SUPPORT_STATUS_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER3 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER3 : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_2 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER1 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER : nvapi.h
  • NV_GSYNC_DELAY_VER : nvapi.h
  • NV_GSYNC_DISPLAY_VER : nvapi.h
  • NV_GSYNC_GPU_VER : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER : nvapi.h
  • NV_GSYNC_STATUS_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER2 : nvapi.h
  • NV_I2C_INFO_VER : nvapi.h
  • NV_I2C_INFO_VER1 : nvapi.h
  • NV_I2C_INFO_VER2 : nvapi.h
  • NV_I2C_INFO_VER3 : nvapi.h
  • NV_INFOFRAME_DATA_VER : nvapi.h
  • NV_LID_DOCK_PARAMS_VER : nvapi.h
  • NV_MAX_HEADS : nvapi_lite_common.h
  • NV_MAX_VID_PROFILES : nvapi_lite_common.h
  • NV_MAX_VID_STREAMS : nvapi_lite_common.h
  • NV_MONITOR_CAPABILITIES_VER : nvapi.h
  • NV_MONITOR_CAPABILITIES_VER1 : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTINGS_MAX : nvapi.h
  • NV_MOSAIC_DISPLAY_TOPO_STATUS_VER : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER2 : nvapi.h
  • NV_MOSAIC_MAX_DISPLAYS : nvapi_lite_surround.h
  • NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD : nvapi.h
  • NV_MOSAIC_TOPO_IDX_DEFAULT : nvapi.h
  • NV_MOSAIC_TOPO_IDX_LEFT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_IDX_RIGHT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_NUM_EYES : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_VALID : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_QUALITY_UPSCALING_STRING : NvApiDriverSettings.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_SCANOUT_INFORMATION_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER1 : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER2 : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_VER : nvapi.h
  • NV_SHADER_EXTN_VERSION : nvShaderExtnEnums.h
  • NV_STEREO_VIDEO_FORMAT_DEFINE : nvapi.h
  • NV_TIMING_H_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_H_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_H_SYNC_POSITIVE : nvapi.h
  • NV_TIMING_INPUT_VER : nvapi.h
  • NV_TIMING_INTERLACED : nvapi.h
  • NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_PROGRESSIVE : nvapi.h
  • NV_TIMING_STRUCTS_DEFINED : nvapi.h
  • NV_TIMING_V_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_V_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_V_SYNC_POSITIVE : nvapi.h
  • NV_TRUE : nvapi_lite_common.h
  • NV_VIEW_TARGET_INFO_VER : nvapi.h
  • NV_VIO_TOPOLOGY_VER : nvapi.h
  • NV_WARP_SIZE : nvShaderExtnEnums.h
  • NVAPI_ADVANCED_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_ADVANCED_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_ADVANCED_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_ALL_GPUS : nvapi.h
  • NVAPI_API_NOT_INTIALIZED : nvapi.h
  • NVAPI_BINARY_DATA_MAX : nvapi.h
  • NVAPI_COPY_ASYNCHRONOUSLY : nvapi.h
  • NVAPI_CPU_RESOURCE : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 : nvapi.h
  • NVAPI_DEFAULT_HANDLE : nvapi_lite_common.h
  • NVAPI_DISPLAY_DEVICE_MASK_MAX : nvapi.h
  • NVAPI_DRS_GLOBAL_PROFILE : nvapi.h
  • NVAPI_GENERIC_STRING_MAX : nvapi_lite_common.h
  • NVAPI_GSYNC_BOARD_ID_P2060 : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P358 : nvapi.h
  • NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_I2C_SPEED_DEPRECATED : nvapi.h
  • NVAPI_INTERFACE : nvapi_lite_salstart.h
  • NVAPI_INVALID_USER_PRIVILEDGE : nvapi.h
  • NVAPI_LONG_STRING_MAX : nvapi_lite_common.h
  • NVAPI_MAX_ACPI_IDS : nvapi_lite_common.h
  • NVAPI_MAX_AUDIO_DEVICES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_SLI_GROUPS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_MAX_FRAMELOCK_MAPPING_MODES : nvapi.h
  • NVAPI_MAX_GPU_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PER_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_MAX_GPU_PERF_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PERF_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PERF_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PUBLIC_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_GPU_UTILIZATIONS : nvapi.h
  • NVAPI_MAX_GSYNC_DEVICES : nvapi.h
  • NVAPI_MAX_HEADS_PER_GPU : nvapi_lite_common.h
  • NVAPI_MAX_LOGICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS : nvapi.h
  • NVAPI_MAX_MOSAIC_DISPLAY_ROWS : nvapi.h
  • NVAPI_MAX_MOSAIC_TOPOS : nvapi.h
  • NVAPI_MAX_PHYSICAL_BRIDGES : nvapi_lite_common.h
  • NVAPI_MAX_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_RJ45_PER_GSYNC : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS : nvapi.h
  • NVAPI_MAX_THERMAL_SENSORS_PER_GPU : nvapi.h
  • NVAPI_MAX_VIEW_MODES : nvapi_lite_common.h
  • NVAPI_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_MAX_VIO_CHANNELS_PER_JACK : nvapi.h
  • NVAPI_MAX_VIO_DEVICES : nvapi.h
  • NVAPI_MAX_VIO_JACKS : nvapi.h
  • NVAPI_MAX_VIO_LINKS_PER_STREAM : nvapi.h
  • NVAPI_MAX_VIO_STREAMS : nvapi.h
  • NVAPI_MIN_VIO_STREAMS : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER1 : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER2 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_BRIEF_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_DETAILS_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_GROUP_VER : nvapi.h
  • NVAPI_MOSAIC_TOPOLOGY_VER : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ALL : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_BASIC_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_NONE : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_SWFALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_ALL : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ALL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_FEATURE_SLI : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_FBO : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_SWFALLBACK : nvapi.h
  • NVAPI_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE : nvapi.h
  • NVAPI_SETTING_MAX_VALUES : nvapi.h
  • NVAPI_SHORT_STRING_MAX : nvapi_lite_common.h
  • NVAPI_STEREO_CAPS_VER : nvapi.h
  • NVAPI_STEREO_CAPS_VER1 : nvapi.h
  • NVAPI_STEREO_QUADBUFFERED_API_VERSION : nvapi.h
  • NVAPI_SYSTEM_HWBC_INVALID_ID : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_HWBCS : nvapi_lite_common.h
  • NVAPI_UNICODE_STRING_MAX : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN : nvapi.h
  • NVDRS_APPLICATION_VER : nvapi.h
  • NVDRS_APPLICATION_VER_V1 : nvapi.h
  • NVDRS_APPLICATION_VER_V2 : nvapi.h
  • NVDRS_APPLICATION_VER_V3 : nvapi.h
  • NVDRS_PROFILE_VER : nvapi.h
  • NVDRS_PROFILE_VER1 : nvapi.h
  • NVDRS_SETTING_VALUES_VER : nvapi.h
  • NVDRS_SETTING_VER : nvapi.h
  • NVDRS_SETTING_VER1 : nvapi.h
  • NVFORMAT_MAKEFOURCC : nvapi.h
  • NVVIO_O_READ : nvapi.h
  • NVVIO_O_WRITE_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_INITIALIZED : nvapi.h
  • NVVIO_OWNERID_TYPEMASK : nvapi.h
  • NVVIO_VALID_ACCESSRIGHTS : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8Z24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8Z24 : nvapi.h
  • NVVIOCAPS_AUDIO_BLANKING_SUPPORTED : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_DESKTOP : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_OPENGL : nvapi.h
  • NVVIOCAPS_PACKED_ANC_SUPPORTED : nvapi.h
  • NVVIOCAPS_SYNC_GENLOCK : nvapi.h
  • NVVIOCAPS_SYNC_INTERNAL : nvapi.h
  • NVVIOCAPS_SYNCSRC_COMP : nvapi.h
  • NVVIOCAPS_SYNCSRC_SDI : nvapi.h
  • NVVIOCAPS_VER : nvapi.h
  • NVVIOCAPS_VER1 : nvapi.h
  • NVVIOCAPS_VER2 : nvapi.h
  • NVVIOCAPS_VIDIN_SDI : nvapi.h
  • NVVIOCAPS_VIDOUT_SDI : nvapi.h
  • NVVIOCLASS_SDI : nvapi.h
  • NVVIOCOLORCONVERSION_VER : nvapi.h
  • NVVIOCONFIG_422FILTER : nvapi.h
  • NVVIOCONFIG_ALLFIELDS : nvapi.h
  • NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS : nvapi.h
  • NVVIOCONFIG_ALPHAKEYCOMPOSITE : nvapi.h
  • NVVIOCONFIG_ANC_AUDIO_REPEAT : nvapi.h
  • NVVIOCONFIG_ANC_PARITY_COMPUTATION : nvapi.h
  • NVVIOCONFIG_ANCTIMECODEGENERATION : nvapi.h
  • NVVIOCONFIG_COLORCONVERSION : nvapi.h
  • NVVIOCONFIG_COMPOSITE : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CB : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CR : nvapi.h
  • NVVIOCONFIG_COMPOSITE_Y : nvapi.h
  • NVVIOCONFIG_COMPOSITESYNCTYPE : nvapi.h
  • NVVIOCONFIG_COMPOSITETERMINATE : nvapi.h
  • NVVIOCONFIG_CSCOVERRIDE : nvapi.h
  • NVVIOCONFIG_DATAFORMAT : nvapi.h
  • NVVIOCONFIG_DATAINTEGRITYCHECK : nvapi.h
  • NVVIOCONFIG_DRIVERFIELDS : nvapi.h
  • NVVIOCONFIG_FLIPQUEUELENGTH : nvapi.h
  • NVVIOCONFIG_FRAMELOCKENABLE : nvapi.h
  • NVVIOCONFIG_FULL_COLOR_RANGE : nvapi.h
  • NVVIOCONFIG_GAMMACORRECTION : nvapi.h
  • NVVIOCONFIG_GAMMAFIELDS : nvapi.h
  • NVVIOCONFIG_OUTPUTAREA : nvapi.h
  • NVVIOCONFIG_OUTPUTREGION : nvapi.h
  • NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE : nvapi.h
  • NVVIOCONFIG_RGB_DATA : nvapi.h
  • NVVIOCONFIG_RMCTRLFIELDS : nvapi.h
  • NVVIOCONFIG_RMMODESET_FIELDS : nvapi.h
  • NVVIOCONFIG_RMSKEWFIELDS : nvapi.h
  • NVVIOCONFIG_SIGNALFORMAT : nvapi.h
  • NVVIOCONFIG_STREAMS : nvapi.h
  • NVVIOCONFIG_SYNCDELAY : nvapi.h
  • NVVIOCONFIG_SYNCSOURCEENABLE : nvapi.h
  • NVVIOCONFIG_VALIDFIELDS : nvapi.h
  • NVVIOCONFIG_VER : nvapi.h
  • NVVIOCONFIG_VER1 : nvapi.h
  • NVVIOCONFIG_VER2 : nvapi.h
  • NVVIOCONFIG_VER3 : nvapi.h
  • NVVIOGAMMACORRECTION_VER : nvapi.h
  • NVVIOOWNERID_NONE : nvapi.h
  • NVVIOPCIINFO_VER : nvapi.h
  • NVVIOPCIINFO_VER1 : nvapi.h
  • NVVIOSTATUS_VER : nvapi.h
  • NVVIOSYNCDELAY_VER : nvapi.h
  • NVVIOTOPOLOGY_VER : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- o -

  • OGL_AA_LINE_GAMMA_STRING : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_STRING : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_STRING : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_STRING : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_STRING : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_DEFAULT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_STRING : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_STRING : NvApiDriverSettings.h
  • OGL_MULTIMON_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_STRING : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_STRING : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_STRING : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_STRING : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_STRING : NvApiDriverSettings.h
  • OGL_VIDEO_EDITING_MODE_STRING : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- p -

  • PHYSXINDICATOR_STRING : NvApiDriverSettings.h
  • PREFERRED_PSTATE_STRING : NvApiDriverSettings.h
  • PRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_2_CONTROL_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_GPS_CTRL_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_LIMITER_STRING : NvApiDriverSettings.h
  • PS_FRAMERATE_MONITOR_CTRL_STRING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- q -

  • QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- r -

  • REFRESH_RATE_OVERRIDE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- s -

  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING : NvApiDriverSettings.h
  • SET_VAB_DATA_STRING : NvApiDriverSettings.h
  • SHIM_MAXRES_STRING : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_STRING : NvApiDriverSettings.h
  • SLI_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_STRING : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- v -

  • VRPRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_STRING : NvApiDriverSettings.h
  • VRR_MODE_STRING : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_STRING : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_STRING : NvApiDriverSettings.h
  • VRRREQUESTSTATE_STRING : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • VSYNCMODE_STRING : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_STRING : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_STRING : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w

- w -

  • WKS_API_STEREO_EYES_EXCHANGE_STRING : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STRING : NvApiDriverSettings.h
  • WKS_MEMORY_ALLOCATION_POLICY_STRING : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
Concepts.txt File Reference


  • File List
  • Globals
Variables
defines.txt File Reference

Variables

PREDEFINED | _D3D9_H_
PREDEFINED | __d3d10_h__
PREDEFINED | __d3d11_h__
PREDEFINED | __d3d10_1_h__
PREDEFINED | __cplusplus

Variable Documentation

PREDEFINED __cplusplus
PREDEFINED __d3d10_1_h__
PREDEFINED __d3d10_h__
PREDEFINED __d3d11_h__
PREDEFINED _D3D9_H_


  • File List
  • Globals
Deprecated.txt File Reference


  • File List
  • Globals
Documentation.txt File Reference


  • File List
  • Globals
legal.txt File Reference


  • File List
  • Globals
MainPage.txt File Reference


  • File List
  • Globals
nvapigroups.txt File Reference


  • File List
  • Globals
systemrequirements.txt File Reference