Advanced Properties

Use this page to change your terminal server configuration. This page displays a tree view of the terminal server you are configuring, showing all ports defined on it. By default, RealPort assigns the next available COM numbers to the ports you define when you install the terminal server.

Use the following buttons to change the default configuration:

Add

Adds a port to the terminal server when you choose it from the list. The Add button displays default port properties for the next available unassigned port.

Remove

Removes a port you choose from the list.

Note: If a device attached to the port you remove is in use, all processes associated with the device are disconnected without warning.

Properties

Displays the Properties page if you choose the terminal server from the list.

Displays the Port Properties page if you choose a port from the list.


About the Terminal Server IP Address

The IP address must be specific to your network and is therefore usually determined by your network administrator.

During initial hardware setup, the unique IP address must be configured in the terminal server itself. See the hardware installation guide for procedures specific to your terminal server.

You must use this unique IP address to specify the terminal server in your RealPort configuration. You cannot use RealPort to change the IP address configured in a terminal server.


About the Terminal Server TCP Port Number

For all Digi terminal servers, the factory preset TCP port number is 771. See your terminal server documentation for the specific procedure to view or change the TCP port number.

For EtherLite terminal servers, the TCP port number cannot be changed.


Erase IP Address

If you know the IP address currently assigned to the EtherLite, enter it here using decimal values for each field, with no leading zeros. Otherwise, choose I don’t know the IP address.


Ethernet Address

Each device with Ethernet connectivity has a unique Ethernet medium access control (MAC) address. The twelve-digit hexadecimal MAC address assigned to your EtherLite is located on a label on the bottom of the device.

Enter the MAC address in the Ethernet Address fields. The first six digits are fixed values; you need to supply only the last six digits.

Example of a MAC Address:

00 A0 E7 21 CB 90


Assign IP Address

Enter the IP address you wish to assign to the EtherLite. Use decimal values for each field, with no leading zeros.


Operation Selection

Choose an operation to perform on the EtherLite you specified in the Ethernet Address window. Each of the following choices opens a specific window to complete the operation:

  • Store IP

    Choose Store IP to assign an IP address to an EtherLite for the first time. Because the IP address must be unique within your network, you should request a valid IP address from your network administrator.

  • Erase IP

    Choose Erase IP to erase an EtherLite IP address without assigning a new one.

  • Change IP

    Choose Change IP to simultaneously erase an EtherLite IP address and assign a new one.

  • Update Firmware

    Choose Update Firmware to apply an update you downloaded from the Digi Support Web site (http://support.digi.com).


Output

This window displays any instructions you must follow to complete the operation you chose. It also displays current status of the operation.


Add Port

This page displays default port properties for the next available unassigned port on your system.

You can change the following properties:

Port

Shows the next available unassigned terminal server port number. You can change this value to any valid port number not already in use.

Name

Shows the next available default port name. To change the name, enter a new unique name in the Name field. For example, if a printer is attached to port 5, you may wish to change the port name to Printer.

Find devices attached to the port

Windows periodically checks serial ports to see if a device has been attached. You can set the frequency of these checks from once per second up to once per minute. If you set this parameter to Manually (the default value), automatic checking is disabled and you must use the Control Panel to add a device to this port.

More about ports


Port Properties

Use this page to view or change the configuration properties of the port you chose from the list. You can add a new port, change the name of a port, and change the method Windows uses to recognize devices attached to a port.

You can change the following properties:

Port

Shows the current terminal server port number. To add a new port to this terminal server, enter a port number not already in use, then enter a unique name in the Name field.

Name

Shows the current port name. To change the name of the current port, enter a new unique name in the Name field. For example, if a printer is attached to port 5, you may wish to change the port name to Printer.

Find devices attached to the port

Windows periodically checks serial ports to see if a device has been attached. You can set the frequency of these checks from once per second up to once per minute. If you set this parameter to Manually (the default value), automatic checking is disabled and you must use the Control Panel to add a device to this port.

More about ports


Properties

Use this page to change the configuration properties of this terminal server. You can change the following properties:

  • Name
  • IP Address
  • TCP Port
  • Poll Cycle
  • Max Packet Size

Note: The IP Address and TCP Port values must match the terminal server you are configuring.

Name

Displays the current name given to the terminal server at this IP address. You can change the name at any time by supplying a new name in this field.

This name has no significance to your network configuration; it is simply a convenient way to label the device. You should use a name that uniquely identifies the terminal server (for example, by its location or function).

IP Address

Displays the IP address configured in RealPort for this terminal server. This value must match the IP address configured in the terminal server itself. See your terminal server documentation for procedures to view or set the value.

TCP Port

Displays the RealPort TCP port number configured for this terminal server. The default TCP port number is 771.

If you are having trouble connecting to the terminal server using the default of 771, check the actual TCP Port set in the terminal server. See your terminal server documentation for procedures to view or set the value.

For EtherLite terminal servers, the TCP port number is set to 771 and cannot be changed, so your system may have another problem.

Poll Cycle

The Poll Cycle is the number of milliseconds the RealPort driver waits for additional data to make a full packet (as defined by Max Packet Size) before sending the packet to the terminal server. If the Poll Cycle time elapses and the packet is not full, the packet is sent anyway.

Depending on your system setup, you may wish to increase the default value to cause less traffic on the network.

The valid Poll Cycle range is 10 to 1000 milliseconds.

Max Packet Size

The default Max Packet Size value (1460) optimizes the RealPort driver for TCP/IP over Ethernet. You should change the default only if you are using media other than Ethernet.

Max Packet Size is the number of bytes of data that the RealPort driver will put into a packet. To keep overhead to a minimum, this value must be the same as or smaller than the data portion of the MTU (Maximum Transmission Unit) of the network medium that carries the packet to the terminal server.

If the Max Packet Size is greater than the data portion of the MTU, all of the data in a RealPort packet will not fit in a single media packet, leftover data must be sent in a second packet, and traffic over the network will increase.

Example MTU Packet Structure for Ethernet

Field | Size in Bytes
MAC | 14
IP(V4) | 20
TCP | 20
TCP Data | 1460
FCS | 4

Total MTU size = 1518 bytes

Allowable Max Packet Size range is from 3 to 65,535 bytes.


IP Address and TCP Port: PortServer

Use this page to specify the IP address and TCP port number for the terminal server you are installing.

IP Address

Enter the IP address configured in this terminal server. Use decimal numbers in the IP address fields. Use the Tab key to move to the next field. If you use the IP Address field for a PortServer III terminal server, the DNS Name field is disabled.

TCP Port

Enter the RealPort TCP port number configured in this terminal server.

DNS Name

For PortServer III terminal servers, you can enter a valid DNS name instead of an IP address. If you use the DNS Name field, the IP Address field is disabled.

When you complete this page, the wizard attempts to connect to a terminal server at the IP address and TCP port number that you supply. If it cannot connect, you should see several error messages, but you can proceed with the RealPort driver configuration. Before you can use the RealPort driver, however, you must determine the reason the wizard could not connect:

  • You should verify that you are using the IP address and TCP Port number configured in the specific terminal server.
  • You should check the Event Log to see if an error is recorded.


IP Address and TCP Port: EtherLite

Use this page to specify the IP address and TCP port number for the terminal server you are installing.

IP Address

Enter the IP address configured in this terminal server. Use decimal numbers in the IP address fields. Use the Tab key to move to the next field. If you use the IP Address field for a PortServer III terminal server, the DNS Name field is disabled.

TCP Port

Enter the RealPort TCP port number configured in this terminal server.

DNS Name

For PortServer III terminal servers, you can enter a valid DNS name instead of an IP address. If you use the DNS Name field, the IP Address field is disabled.

DgIPServ

Start the DgIPServ utility if you need to assign an IP address to an EtherLite network serial concentrator. This button is enabled for EtherLite devices only.

When you complete this page, the wizard attempts to connect to a terminal server at the IP address and TCP port number that you supply. If it cannot connect, you should see several error messages, but you can proceed with the RealPort driver configuration. Before you can use the RealPort driver, however, you must determine the reason the wizard could not connect:

  • You should verify that you are using the IP address and TCP Port number configured in the specific terminal server.
  • You should check the Event Log to see if an error is recorded.


Name and Number of Ports

Use this page to define the terminal server name and the number of ports to configure for the terminal server you are installing.

Name

Enter a name for this terminal server.

If you do not type a name, the wizard supplies a default name. You can later change the name by accessing the Properties page.

Number of Ports

Enter the number of ports you want to define on this terminal server.

The actual number of ports found on your terminal server is displayed by default. You can change this value to a number less than the actual number of ports if you do not plan to access all of the available ports through the RealPort service. You can add or remove ports either before or after you complete your terminal server installation.

Note: You can also define more ports than actually exist on your terminal server, but you can use only those that represent a physical port.


More About Ports

  • Ports on the terminal server are physically labeled with the number of the port, starting with 1. A terminal server can have up to 64 ports available if you add expansion modules to the base terminal server. Each of the terminal server ports is assigned a default system name during RealPort installation: COM2, COM3, COM4, etc.
  • Ports do not need to be added or maintained in sequence. You can change the Port field to any valid port number. For example, you may use ports 1 through 8 for modems and port 26 for a printer. If those are the only ports you use, you can shorten your list by deleting unused ports.

Note: You can define more ports than actually exist on your terminal server, but you can use only those that represent a physical port.